Chapter 15

Complex Animation

Learning Objectives ':a\ :

After completing this chapter, you will be able to:
* Create dummy objects

* Create snapshot objects

* Hide objects during animation

* Animate and link cameras
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INTRODUCTION

In this chapter, you will learn to animate the objects using the dummy objects. Dummy objects
are used to control the movement of other objects by linking them, but are not rendered.
If several objects are linked to a dummy object, the dummy can be used to move all objects
simultaneously. The objects linked to the dummy can also to be moved individually without
affecting the dummy object or any other object linked to the dummy object.

TUTORIAL

Before starting the tutorial, you need to download the c15_3dsmaxdesign_2014_tut.zip file from
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds
Max Design > Autodesk 3ds Max Design 2014: A Tutorial Approach

Extract the contents of the zip file and save them in the Documents folder.

Tutorial 1

In this tutorial, you will create the animation of a steel manufacturing process. You will create
dummy objects to assist in movement during animation, refer to Figure 15-1.
(Expected time: 30 min)

Figure 15-1 Animation at frame 43
The following steps are required to complete this tutorial:

Create the project folder.

Open the file.

Create dummy objects.

Link the objects.

Set continuity value.

Animate the hook and cauldron.
Add a position key.

Create a snapshot.
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Hide the object during animation.
Hide the object using object properties.
Preview the animation.
Animate the camera.

. Animate the camera target.
Save and preview the animation.

55 —

Creating the Project Folder
Create the project folder with the name ¢15_tutl in the 3dsmaxdesign 2014 folder, as discussed
in earlier chapters.

Opening the File

1. Choose Open from the Application menu; the Open File dialog box is displayed. In
this dialog box, browse to the location |Documents\c15_3dsmaxdesign_2014_tut and select
the c15_tutl_start.max file from it. Choose the Open button to open the file, refer to
Figure 15-2.

[+1[Camera-Lift ] [ Shaded ]

Figure 15-2 The c15_tutl_start file

2. Choose Save As from the Application menu; the Save File As dialog box is displayed. Browse
to the location |\Documents\3dsmaxdesign 2014\c15_tutl\scenes. Save the file with the name
c15tutl . max at this location.

Creating Dummy Objects
In this section, you will set the number of frames in the animation and create the dummy
object.

1. Choose the Time Configuration button from the animation playback controls; the Time
Configuration dialog box is displayed, as shown in Figure 15-3.
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Figure 15-3 The Time Configuration dialog box

In the Animation area, set 150 in the Length spinner and choose the OK button; the
total number of frames for the animation is set to 150.

Choose Create > Helpers in the Command Panel. Next, invoke the Dummy tool
from the Object Type rollout.

Activate the Front viewport by clicking on it.

Click at a point below Cauldron and drag the mouse to create a small cube. Next, move
the cube in the Left viewport to position it below Cauldron; a dummy object is created, as
shown in Figure 15-4.

The size of the cube does not matter. This cube is the dummy object and will not be visible
in the rendered animation. Resize the cube so that you can select it easily, yet not so large
that it interferes with the selection of other objects in your scene.

Enter Cal-Dummy in the Name and Color rollout.

Invoke the Dummy tool again from the Object Type rollout. In the Front viewport, click
at a point below Base and drag the cursor to create another small cube. Adjust the position

of the cube in the Left viewport to position it below Base.

Enter Base-Dummy in the Name and Color rollout.
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9.
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Figure 15-4 A dummy object created

Activate the Top viewport. Next, use the Align tool from the Main Toolbar to center B
Base-Dummy with the center of the Base object along the X and Y axes. Also, align
the center of Cal-Dummy with the center of Cauldron along the X and Y axes.

Linking the Objects
In this section, you will link the objects in the scene. Linking more than one object to a
dummy object simplifies the animation process and allows individual movement later in the

animation.
1. Invoke the Select and Link tool from the Main Toolbar. %‘
2. Select Cauldron and drag the cursor to Cal-Dummy and then release the left mouse button,

refer to Figure 15-5. Invoke the Select Object tool to exit the tool.

When the first object is selected, the link cursor appears. On dragging the mouse button
and releasing it on the second object, the two objects will be linked. Cauldron becomes a
child of Cal-Dummy and will follow its movement.

Invoke the Select and Link tool. Next, select Hook, drag the cursor to Cal-Dummy, and
release the left mouse button. Invoke the Select Object tool to exit the tool; Hook becomes
a child of Cal-Dummy and will follow its movement.

Invoke the Select and Link tool. Next, select Base, drag the cursor to Base-Dummy, and
release the left mouse button; Base becomes a child of Base-Dummy. Now, invoke the Select
Object tool to exit the tool.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 15-5 Linking Cauldron with Cal-Dwmmy

Setting Continuity Value

In this section, you will set the continuity value using the Set Controller Defaults dialog box.
Continuity controls an object’s movement through animation keys, creating the appearance
of life-like motion, or creating the appearance of mechanical motion. The objects in this
animation should have mechanical motion. A continuity default value can be set before creating
animation keys so that each key does not have to be individually adjusted later.

1.

Choose Customize > Preferences from the menu bar; the Preference Settings dialog box
is displayed. Next, choose the Animation tab in the Preference Settings dialog box.

In the Controller Defaults area, choose the Set Defaults button; the Set Controller
Defaults dialog box is displayed, as shown in Figure 15-6.

In this dialog box, select TCB Float from the list and then choose the Set button; the
TCB Default Key Values dialog box is displayed, as shown in Figure 15-7.

In this dialog box, make sure 0 is displayed in the Continuity spinner and then choose
the OK button.

Choose OK in the Set Controller Defaults dialog box. Next, choose OK in the Preference
Settings dialog box.
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Figure 15-7 The TCB Default Key Values dialog box
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Figure 15-6 The Set Controller Defaults dialog box
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Animating the Hook and Cauldron

In this section, you will animate Hook and Cauldron. To create an animation, a series of keys

are defined.

1. Choose the Toggle Auto Key Mode button to turn the animation mode on (red). |autskey

When the Toggle Auto Key Mode button is chosen (red), any transformation creates an
animation key on the current frame. If this button is off, the transformation is applied to
frame 0, regardless of the current frame.

2. Drag the time slider to frame 25. Alternatively, you can set the value 25 in the spinner at

the left side of the Time Configuration button.

3. Activate the Front viewport and right-click on the Select and Move tool; the Move
Transform Type-In dialog box is displayed, as shown in Figure 15-8.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 15-8 The Move Transform Type-In dialog box

e

Select Cal-Dummy and set 300 in the X spinner of the Offset:Screen area and press the
ENTER key; Cauldron is now centered over Base.

5. Drag the time slider to frame 50.
6. Make sure Cal-Dummy is selected. In the Move Transform Type-In dialog box, set -300

in the Y spinner of the Offset:Screen area and press the ENTER key; Cauldron is placed
on Base, refer to Figure 15-9.
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Figure 15-9 The Cauldron placed on the circular Base

7. Close the Move Transform Type-In dialog box and exit the animation mode by

choosing the Toggle Auto Key Mode button.
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Adding a Position Key

Currently, if the movement of Hook is animated, the movement would begin at frame 0 and
would end at whatever frame was current when Hook was moved. As a result, Hook would
gradually drift away from its parent object. To prevent this, Hook needs a position key added
at frame 50. The position key locks the Hook’s position at frame 50. Any movement applied
to Hook affects only frames between frame 50 and the current frame. In this section, you will
use the Track View - Dope Sheet window to create the position key.

1. Selectall objects in the viewport. Next, choose Graph Editors > Track View - Dope Sheet
from the menu bar; the Track View - Dope Sheet window is displayed.

2. In this window, click on the plus sign at the left of Hook. Notice that currently there are
no animation keys for Hook.

3. Choose the Add Keys button on the upper left of the Track View - Dope Sheet
window.

4. Click on the Position track for Hook at frame 50; a position key for Hook is created at
frame 50, refer to Figure 15-10. Next, close the Track View - Dope Sheet window.

Editor Edit View Curves Keys Time Show

Figure 15-10 The new key added to the Hook’s Position track

5. Drag the time slider to frame 55 and choose the Toggle Auto Key Mode button.

6. Select Hook. In the Front viewport, move Hook —60 units on the X axis and —60 units on
the Y axis; Hook is detached from Cauldron.

7. Drag the time slider to frame 70. Next, move Hook 300 units on the Y axis.

8. Choose Graph Editors > Saved Track Views > Track View - Dope Sheet from the menu
bar; the Track View-Dope Sheet window is displayed with the previous settings active.

9. Choose the Add Keys button on the upper left of the Track View-Dope Sheet window.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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10.

11.

12.

13.

14.

15.

16.

17.

18.

19.

Zoom in the window and add a key in the Position track at frame 90 for Hook. Next, close
the Track View-Dope Sheet window; the current position of Hook is recorded in a key at
frame 90.

Drag the time slider to frame 105. Next, in the Front viewport, move Hook =300 units on
the Y axis.

Drag the time slider to frame 110. Next, move Hook 60 units on the X axis and 60 units
on the Y axis; Hook is reattached to Cauldron.

Choose Graph Editors > Saved Track Views > Track View-Dope Sheet from the menu
bar; the Track View-Dope Sheet window is displayed. Next, select Cal-Dummy in the
viewport and click on the plus sign on the left of Cal-Dummy and then Transform in the

Track View-Dope Sheet window.

Choose the Add Keys button and add a key in the Position track at frame 110 for
Cal-Dummy. Next, close the Track View-Dope Sheet window.

Drag the time slider to frame 130.

In the Front viewport, move Cal-Dummy 300 units on the Y axis; Cal-Dummy, Hook, and
Cauldron move.

Drag the time slider to frame 150.
Move Cal-Dummy —300 units on the X axis.
Choose the Toggle Auto Key Mode button to exit the animation mode. Next, drag the time

slider to left and right to replay the animation. Alternatively, choose the Play Animation
button to see the animation in the viewport.

Creating a Snapshot

The Snapshot tool duplicates an object in its current state, but unlike the Copy tool, it does
not copy any animation keys associated with the object. The snapshot copy can then be used
for complex animation sequences. In this section, you will create a snapshot of Cauldron and
rotate it by 45 degrees.

1.

2.

Drag the time slider to frame 50. Next, select Cauldron.

Choose Tools > Snapshot from the menu bar; the Snapshot dialog box is displayed, as
shown in Figure 15-11.
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Figure 15-11 The Snapshot dialog box

Make sure the Single radio button is selected in the Snapshot area. Also, select the Copy
radio button in the Clone Method area, and then choose OK to close the dialog box.

A duplicate copy of Cauldron is created at the same location as the original. Therefore,
the copy of Cauldron had to be moved to frame 50. The copy is named as Cauldron001.

Note
The Snapshot dialog box allows you to create multiple copies over a range of frames using the
Range radio button or a single copy using the Single radio button.

Drag the time slider to frame 0.

There are now two cauldrons in the scene: the original and the copy located at the original’s
position at frame 50 when the snapshot was made.

Invoke the Select and Link tool from the Main Toolbar.

Select Cauldron001 and drag the cursor to Base Dummy, and then release the left mouse
button. Invoke the Select Object tool to exit the tool; Cauldron001 is now the child of Base
Dummy and will follow its movement.

Select Base Dummy in the viewport.

Choose Graph Editors > Saved Track Views > Track View-Dope Sheet from the menu
bar; the Track View-Dope Sheet window is displayed. Next, click on the (+) plus sign at
the left of Base-Dummy and Transform.

Choose the Add Keys button and add a key in the Rotation track at frame 70 for m
Base Dummy. Next, close Track View - Dope Sheet window.

Drag the time slider to frame 80. Choose the Toggle Auto Key Mode button to enter the
animation mode.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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11. In the Front viewport, rotate Base Dummy object — 45 degrees on the Z axis.
12. Drag the time slider to frame 90.
13. In the Front viewport, rotate Base Dummy 45 degrees on the Z axis.

14. Choose the Toggle Auto Key Mode button to exit the animation mode. Next, drag the
time slider to left and right to replay the animation.

Hiding the Object During Animation

All parts of the animation are now complete, but there are two cauldrons visible during the
animation. You must turn off the visibility, or hide the cauldrons during different segments of
the animation. In this section, you will hide object using the Track View-Dope Sheet window.
There are two ways to do this. You can use the Track View -Dope Sheet window or modify
the object’s properties.

1. Select Cauldron in the viewport. Next, choose Graph Editors > Saved Track Views > Track
View-Dope Sheet from the menu bar; the Track View-Dope Sheet window is displayed.

2. Select Cauldron in the Track View-Dope Sheet window. Click on the (+) plus sign at the
left of Cauldron.

3. Choose Edit > Visibility Tracks > Add from the menu bar in the Track View - Dope
Sheet window; a visibility track is added for Cauldron.

4. Choose the Add Keys button and add a key in the Visibility track at frame 0 for Cauldron,
refer to Figure 15-12.
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Figure 15-12 Adding a new key in the Visibility track at frame 0

5. Right-click on the new key; the Cauldron/Visibility dialog box is displayed. In this dialog
box, make sure 1.0 is set in the Value spinner. Also, set the In and Out image tiles to the
square mechanical transition, refer to Figure 15-13. Do not close the Cauldron/Visibility
dialog box; Cauldron is fully visible at frame 0.
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Figure 15-13 The Cauldron/Visibility dialog box
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6. Add a key in the Visibility track at frame 50 for Cauldron.

7. In the Cauldron/Visibility dialog box, set the value 0 in the Value spinner.
Also, set the In and Out image tiles to the square mechanical transition;
Cauldron is invisible at frame 50. Close the Cauldron/Visibility dialog box.

8. Add a key in the Visibility track at frame 90 for Cauldron.

9. Right-click on the new key; the Cauldron/Visibility dialog box is displayed. In this dialog
box, set the value 1.0 in the Value spinner. Also, set the In and Out image tiles to the
square mechanical transition; Cauldron is fully visible at frame 0. Next, close the Cauldron/
Visibility dialog box and the Track View-Dope Sheet window.

Hiding the Object Using Object Properties

In this section, you will hide the objects using the object properties.
1. Drag the time slider to frame 0.

2. Select Cauldron001 in any viewport. Right-click in the viewport; the quad menu is displayed.
Choose Object Properties from the lower-right quadrant of the quad menu; the Object
Properties dialog box is displayed, as shown in Figure 15-14.

3. In this dialog box, choose the By Layer button from the Rendering Control
area; the By Layer button is replaced by the By Object button. Also, the options
in this area are activated.

4. Set the value 0 in the Visibility spinner. Next, choose the OK button to close the Object
Properties dialog box; Cauldron001 is invisible at this frame (frame 0). This also adds a
visibility track in the Track View - Dope Sheet window.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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|
|

Figure 15-14 The Object Properties dialog box

5. Drag the time slider to frame 50 and then choose the Toggle Auto Key Mode button to

enter the animation mode.

6. Make sure Cauldron001 is selected. Next, right-click in the viewport; the quad menu is

displayed. Next, choose Object Properties from the quad menu; the Object Properties
dialog box is displayed.

7. Set the value 1.0 in the Visibility spinner of the Object Properties dialog [[Hiiaer:

box.

You will notice that the corners of the spinner turn red. This indicates that the parameter
is animated.

8. Choose the OK button to close the Object Properties dialog box; Cauldron001 becomes

visible at frame 50.
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10.

11.

12.

13.

14.

15.

Drag the time slider to frame 90. Make sure Cauldron001 is selected Next, right-click in
the viewport; the quad menu is displayed. Next, choose Object Properties from the quad
menu.

Set 0 in the Visibility spinner of the Object Properties dialog box. Next, choose the OK
button to close the Object Properties dialog box; Cauldron001 is invisible at frame 90.

Choose the Toggle AutoKey Mode button to exit the animation mode. Drag the time
slider left and right to replay the animation.

You will notice that Cauldron001 fades in and out. Therefore, you need to adjust the
transition in the Track View - Dope Sheet window.

Choose Graph Editors > Saved Track Views > Track View-Dope Sheet from the menu
bar; the Track View-Dope Sheet window is displayed. In this window, click on the plus
sign on the left of Cauldron001 to expand the tree, if it is not already expanded.

Right-click on the first key in the Visibility track; the Cauldron001/Visibility dialog box
is displayed. In this dialog box, set the In and Out image tiles to the square mechanical
transition.

Repeat this for the visibility keys at frame 50 and frame 90. Close the Cauldron/Visibility
dialog box and the Track View-Dope Sheet window.

Drag the time slider left and right to preview the animation or choose the Play Animation
button.

Notice that Cauldron001 no longer fades in and out. The visibility changes for both
cauldron objects are instantaneous, providing the illusion that there is only one cauldron
in the scene.

Previewing the Animation
In this section, you will preview the animation. The preview animation is a low resolution/low
color format used to quickly verify that the animation is working correctly.

1.

2.

Make sure the Camera-Lift viewport is activated.

Choose Tools > Preview - Grab Viewport > Create Preview Animation from the menu
bar; the Make Preview dialog box is displayed, as shown in Figure 15-15.

In this dialog box, select the Frame Numbers check box in the Overlay area. Next, choose
the Create button. If the Video Compression dialog box is displayed, choose OK to accept
the default settings.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 15-15 The Make Preview dialog box

When the animation is completed, it is played in the Windows Media Player. Notice that
the invisible cauldrons will not appear clearly. This is just a representation in the preview
rendering. In the final animation, the cauldrons are completely invisible.

Animating the Camera

In this section, you will animate the camera. The camera can be animated just like any other
object in the scene. When a camera is animated, both the camera target and camera body
may need to be moved or rotated.

1. Choose the Display tab in the Command Panel. ITDI

2. In the Hide by Category rollout, clear the Cameras check box; the camera named
Camera-Lift is displayed in the scene.

3. Invoke the Zoom Extents All tool; the scene is zoomed out in the viewports so that the
camera and target fit on the screen.

4. Drag the time slider to frame 75.

5. Invoke the Select and Move tool. Next, choose the Toggle Auto Key Mode button to
enter the animation mode.



Complex Animation 15-17

6. Select the camera in the Top viewport and move it —1300 units on the X axis and 1300
units on the Y axis (to the left and up).

7. Make sure the Display tab is chosen in the Command Panel. In the Display Properties
rollout, select the Trajectory check box; the path that the camera follows is displayed.

The dots along the path represent individual frames in the animation. The white boxes
represent frames that have animation keys in them for the camera.

8. Drag the time slider to frame 32.

9. Select the camera in the Top or Front viewport and move it 600 units on the X axis
and 600 units on the Y axis (to the right and up). Invoke the Zoom Extents All tool,
refer to Figure 15-16. Next, choose the Toggle Auto Key Mode button again to
exit the animation.
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Figure 15-16 Adjusting the camera position in the viewport

Next, you will preview the animation to view the effect of moving the camera.
10. Make sure the Camera-Lift viewport is activated.

11. Choose Tools > Preview - Grab Viewport > Create Preview Animation from the menu
bar; the Make Preview dialog box is displayed.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

15-18 Autodesk 3ds Max Design 2014: A Tutorial Approach

12. In this dialog box, choose the Create button. If the Video Compression dialog box is
displayed, choose the OK button to accept the default settings.

When the animation is completed, it is played in Windows Media Player.

Animating the Camera Target

The camera target can be animated to follow the movement of an object during animation.
A camera target can be linked as a child to the object being followed in the animation to
simplify the process.

1. Drag the time slider to frame 0. Also, make sure the Toggle Auto Key Mode button is
deactivated (not red).

2. Invoke the Select and Move tool. Next, invoke the Zoom Extents All tool.

3. Select Camera-Lift.target and drag it to the center of Cauldron in the Top and Left viewports,
as shown in Figure 15-17; the camera target is now centered on Cauldron.
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Figure 15-17 Adjusting the Camera-Lift.target to the center of Cauldron in the
Top and Left viewports

!

4. Invoke the Select and Link tool from the Main Toolbar.

5. In the Front viewport, select Camera-Lifi.target, drag the cursor to Cal-Dummy, and then
release it. Invoke the Select Object tool to exit the tool; Camera-Lift.target is now the child
of Cal-Dummy and will follow its movement.
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Note
@ If the camera represents a person walking through a scene, it is better to create a dummy object

and link both the camera target and the person to the dummy object. In this way, only the dummy
object will be animated.

Saving and Previewing the Animation
In this section, you will create a quick preview of the updated animation to show the movement
of the camera target.

1.

Change the background color of the scene to white by following the steps, as given in
Tutorial 1 of Chapter 2.

Choose Save from the Application menu.
Make sure the Camera-Lift viewport is activated.

Choose Tools > Preview - Grab Viewport > Create Preview Animation from the menu
bar; the Make Preview dialog box is displayed.

Choose the Create button. If the Video Compression dialog box is displayed, choose the
OK button to accept the default settings.

When the animation is completed, it is played in the Windows Media Player.

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1.

Which of the following tools is used to duplicate an object in its current state, but does
not copy any animation keys associated with the object?

(a) Copy (b) Dummy
(c) Snapshot (d) None of these
An object can be to a dummy object, and it will then follow the movement of

the dummy object.
A dummy object will not be visible on
The window can be used to create a position key.

While adjusting the key information of a key in an object’s visibility track, a setting of
in the Value spinner will make the object completely visible.

An object can be made invisible by creating a visibility track in Track View - Dope Sheet
window, or by adjusting the object’s

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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When a camera is animated, both and can be moved or
rotated.
On selecting in the Display Properties rollout of the Command Panel, camera’s

path is displayed in the viewport.

Frames that have animation keys for the camera are indicated in the trajectory by white
boxes. (T/F)

Review Questions

Answer the following questions:

1.

Which of the following dialog boxes is used to set the total number of frames in
animation?

(a) Set Controller Defaults (b) Time Configuration
(c) Object Properties (d) None of these

The objects are used to control the movement of other objects by linking
them, but are not rendered.

The tool is used to link one object with another object.
The button is used to add keys in Track View - Dope Sheet.
The option verifies the current state of animation.

The Snapshot tool is similar to the Copy command. (T/F)
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EXERCISE

The rendered sequence of the scene used in the following exercise can be accessed by
downloading the ¢15_maxdesign_2014_exr.zip from www.cadcim.com. The path of the file is as
follows: Textbooks > Animation and Visual Effects > 3ds Max Design > Autodesk 3ds Max Design
2014: A Tutorial Approach

Exercise 1

Extract the contents of the ¢c15_3dsmaxdesign_2014 _exr.zip and then open c15_exr01_start.max.
Next, animate the vise, refer to Figures 15-18 through 15-21.

i

Figure 15-18 Animation at frame 50 Figure 15-19 Animation at frame 75
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Figure 15-20 Animation at frame 125 Figure 15-21 Animation at frame 150

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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15-22 Autodesk 3ds Max Design 2014: A Tutorial Approach

Answers to Self-Evaluation Test
1. ¢, 2. linked, 3. rendering, 4. Track View - Dope Sheet, 5. 1.0, 6. properties, 7. camera,
target, 8. Trajectory, 9. T



