
Chapter 1

Understanding the 
Softimage Interface

 Learning Objectives 
After completing this chapter, you will be able to:
• Work with the Autodesk Softimage 2014 interface
• Create projects and manage files
• Use navigation tools in different viewports 
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Introduction
Autodesk Softimage 2014 is a high performance 3D character animation and visual effects 
application that is used to create stunning artwork for films and television. To work with this 
software efficiently, you should be familiar with its interface as well as various tools and panels 
in it. In this chapter, you will learn how to start Softimage and then how to interact with its 
interface.

StartING Autodesk Softimage 2014
After installing Autodesk Softimage 2014, a shortcut icon is automatically created on 
the desktop. Double-click on this icon to start Autodesk Softimage 2014 or choose 
Start > All Programs > Autodesk > Autodesk Softimage 2014 > Softimage 2014 from the 
taskbar, as shown in Figure 1-1.

Figure 1-1  Starting Autodesk Softimage 2014 from 
the taskbar

On starting Autodesk Softimage 2014, the Softimage interface screen along with 
Netview - Netview window will be displayed, as shown in Figure 1-2. If you do not want 
the Netview - Netview window to be displayed again with the startup screen, then clear 
the Launch Netview On Startup check box. To re-display this window, you can choose 
View > General > Netview from the menu bar or press ALT+5.
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Figure 1-2  The Netview - Netview window
The Netview - Netview window is used to browse web resources both on internet and intranet. It 
also allows you to choose the mouse and keyboard interaction mode. In the Netview - Netview 
window, you can set the interaction mode for working with Autodesk Softimage. The interaction 
mode determines how the mouse and keystrokes will be interpreted. To set the interaction 
mode, you can select the Softimage, Maya, or 3ds Max option from the drop-down list available 
in the Interaction Mode area of the Netview - Netview window.

 
Alternatively, you can choose File > Interaction Mode from the menu bar to set the interaction 
mode. On doing so, the Interaction Mode dialog box will be displayed, as shown in Figure 1-3. 
Next, you can select Softimage, Maya, or 3ds Max from the drop-down list in the Interaction 
Mode dialog box. In the Netview - Netview window, you can use the New Features and 
changes in this version link to access the Softimage Wiki webpage. You can use this page to 
access documentation, release notes, tutorials, new features added in the current release, and 
the community portal, refer to Figure 1-4. 

Figure 1-3  The Interaction Mode dialog box

Tip: It is recommended that you choose the Softimage interaction mode to optimize the 
functioning of all Softimage tools. In the Maya and 3ds Max interaction modes, you need 
to use the ALT key for navigating in the viewport, whereas in Softimage, you need to use 
the S key to do the same.  
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Figure 1-4  The Softimage Wiki webpage

Understanding the Autodesk Softimage 2014 
interface
The interface of Autodesk Softimage 2014 consists of menu bar, toolbars, command panel, 
viewports, and other optional panels. All toolbars and panels in this interface are organized 
in a systematic way, thus making it a user-friendly interface, refer to Figure 1-5.

Figure 1-5  The default interface of Autodesk Softimage 2014

To view all panels and toolbars, choose View > Optional Panels from the menu bar; a 
cascading menu will be displayed. Choose Show All from the cascading menu; all panels 
will be displayed in an arranged manner in the interface. You can hide panels or restore the 
default panels by using the options in this cascading menu. The components of the interface 
are discussed next.
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Title Bar
The title bar is located at the top in the interface. It displays the name, version, and license 
type of the software as well as the name of the opened file.

Menu Bar
The  menu bar is located just below the title bar. It is used to access  commands for performing 
various file operations such as opening, saving, editing a file, setting preferences, and so on. 
The menu bar is divided into different sections based on the operations that can be performed 
by using them, refer to Figure 1-6. These sections are discussed next.

Figure 1-6  The menu bar and its sections

Standard Menus
The options in these menus are used for managing and editing files, setting preferences, 
displaying elements, and accessing the documentation. In Softimage, there are six standard 
menus namely File, Edit, View, Display, Window, and Help, refer to Figure 1-6.

Toolbar Menus
The menus in this section are Model, Animate, Render, ICE, Simulate, and Hair, refer to 
Figure 1-6. The options in these menus are used for modeling, animating, texturing, and 
rendering the elements as well as for simulating physical interaction between the geometry, 
particles, and hair. The options in these menus are same as those available in the toolbars. 

Face Robot Menu
The options in the Face Robot menu are used to rig and animate faces, refer to Figure 1-6.

Construction Mode Selector
The Construction Mode Selector drop-down list is used to specify the mode for adding 
operators to the geometry stack, refer to Figure 1-6. The construction mode is classified into 
four different modes, namely Secondary Shape Mode, Animation Construction Mode, Shape 
Modeling Mode, and Modeling Construction Mode.

Current Render Pass
The Current Render Pass drop-down list is used to select the current render pass for the scene, 
refer to Figure 1-6.
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Quick Filter Box
The Quick Filter Box is used to find and select specific elements in the scene, refer to 
Figure 1-6.

Main Toolbar					         

Figure 1-7  Flyout showing 
different toolbar options

The main toolbar is displayed on the left side of the interface 
screen. It consists of a group of toolbars. By default, the Model 
toolbar is displayed in the main toolbar. You can view other 
toolbars as well. To do so, click on the down arrow on the right 
of the Model toolbar; a flyout with the toolbar options Model, 
Animate, Render, ICE, Simulate, and Hair will be displayed, as 
shown in Figure 1-7. Click on the desired option to display the 
toolbar. Each of these toolbars contains menus and submenus. 
The submenu of a toolbar can be detached from the toolbar and 
kept in a handy floating window by clicking on the dotted line 
on the top of the submenu, refer to Figure 1-8. These toolbars 
in the main toolbar are discussed next.

Figure 1-8  Clicking on the dotted line

Model 
The Model toolbar consists of options that are used for creating, modifying, and texturing 
an object. If this toolbar is not displayed, then click on the current toolbar; a flyout will be 
displayed. Next, choose the Model option from the flyout. Alternatively, press 1 to invoke this 
toolbar. The Model toolbar is divided into various sections, namely Get, Create, and Modify, 
refer to Figure 1-9.
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Figure 1-9  Different types of toolbars

Animate
The Animate toolbar consists of the options that are used for creating animations. To invoke 
this toolbar, click on the current toolbar; a flyout will be displayed. Next, choose the Animate 
option from this flyout. Alternatively, press 2 to invoke this toolbar. The Animate toolbar is 
divided into different sections, namely Get, Create, Deform, Actions, and Tools, as shown 
in Figure 1-9.

Render
The Render toolbar consists of the options that are used to apply render settings and display 
and modify the output. To invoke this toolbar, click on the current toolbar and then choose 
the Render option from the flyout displayed. Alternatively, press 3 to invoke this toolbar. The 
Render toolbar is divided into four sections, namely Get, Modify, Render, and Pass, refer 
to Figure 1-9.

ICE (Interactive Creative Environment)
The ICE toolbar consists of the tools and options that can be used for creating advanced 
effects and character rigs. You can use these tools to create custom deformers, animate 
particles, and simulate fluids. You can also create crowd simulation and produce complex 
effects using these tools. To invoke this toolbar, click on the toolbar currently displayed; a 
flyout will be displayed. Next, choose the ICE option from this flyout. Alternatively, press 4 
to invoke this toolbar. The ICE toolbar is divided into the sections, namely Get, Particles, 
Deform, Kinematics, and CrowdFX, refer to Figure 1-9.
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Simulate
The Simulate toolbar contains options that are used for controlling the simulation in the 
environment. To invoke this toolbar, click on the toolbar currently displayed; a flyout will be 
displayed. Next, choose the Simulate option from this flyout. Alternatively, press CTRL+4 to 
invoke this toolbar. The Simulate toolbar is divided into three sections, namely Get, Create, 
and Modify, refer to Figure 1-9.

Hair
The Hair toolbar contains different options that are used for creating, modifying, and 
displaying hair in viewports. To invoke this toolbar, click on the toolbar currently displayed; 
a flyout will be displayed. Next, choose the Hair option from this flyout. Alternatively, press 
CTRL+2 to invoke this toolbar. The Hair toolbar is divided into the different sections, namely 
Create, Modify, and Display, refer to Figure 1-9.
 

Buttons
In Autodesk Softimage, there are several buttons placed on the 

Figure 1-10  The buttons on the 
bottom left corner of the interface

bottom left corner of the interface, refer to Figure 1-10. These 
buttons and their functions are discussed next. 

toolbar_panel       		
The toolbar_panel button is chosen by default. It is 
used to switch to the main toolbar, if some other panel is displayed. You can also switch 
to the main toolbar by pressing CTRL+1.

Weight Paint Panel								      
The Weight Paint Panel button is used to switch to the Weight Paint panel. This panel 
is used for painting weights or setting weight maps. The weight maps are properties 
of point clusters on geometric objects. Tools in this panel are used for painting the 

weight map on the selection. You can change the radius and opacity of the brush being used 
by changing the values in this panel. This panel consists of different sections, namely Paint 
Tools, Edit Tools, and Deformers. You can also press CTRL+3 to switch to this panel.    

Palette and Script Toolbar          
On choosing the Palette and Script Toolbar button, a panel consisting of two sections, 
namely Wire Colors and Display Types will be displayed on the left of the interface. 
When you select the desired color from the Wire Colors section, the wire color of the 
object will be changed depending on the type specified in the Display Types section. 

PresetManagerFS    
On choosing the PresetManagerFS button, a panel consisting of the Materials and 
Shaders option will be displayed on the left of the interface. It also consists of the 
embedded Scene_Root window which displays all the objects in the scene in a hierarchical 
manner.

Toggle Module Menu
This button is used to display or hide the main toolbar located on the left side of the 
interface.



Understanding the Softimage Interface						          1-9

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Toggle Main Shelf          
This button is used to display or hide the Main Shelf located below the menu bar.

Toggle TimeRange                 
This button is used to display or hide the time range located at the bottom of the 
interface.

Toggle Main Control Panel
This button is used to display or hide the Main Command Panel located on the right 
side of the interface.

Reset View Manager
This button is used to display all four viewports.
                   

1UP3DOWN View Manager
This button is used to display all four viewports. On choosing this button, the Top 
viewport will be displayed on the upper area and the other three viewports will be 
displayed at the bottom. 

Explorer, ViewB and User
This button is used to display the Explorer, Camera, and User views in the viewports.

ICE Tree, Render Tree, Animation Editor
The ICE Tree, Render Tree, Animation Editor button is used to display the Explorer, 
Camera, and Render Tree windows in a hierarchical manner. This button allows the 
user to work in these windows simultaneously.      

         

Viewports
The viewports are the main viewing areas in the interface. The Camera viewport is the default 
viewport in the interface. When you press F12 in the Camera viewport, four viewports will be 
displayed in the Softimage interface. These viewports cover maximum area in the interface and 
display different views of the elements within a scene. The four default views in the viewports 
are Top, Front, Right, and Camera, refer to Figure 1-11. Out of these views, only the Camera 
view is non-orthographic and rest are orthographic views. 

ViewCube
The ViewCube is an on screen navigation tool, which is used to switch between different views. 
When you hover the mouse pointer in the viewport, the ViewCube is displayed on the upper 
right corner of the viewport, refer to Figure 1-11. Note that the ViewCube is displayed only 
in active viewport.
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Figure 1-11  The ViewCube displayed in the active (Top) viewport

Coordinate System 
Softimage uses the Euclidean/Cartesian coordinate system. A coordinate system is a 
mathematical representation of the space. This system is based on three perpendicular axes, 
X, Y, and Z intersecting at one reference point and that point is called origin. The coordinates 
are located at the bottom left corner of the viewport, refer to Figure 1-11.

Grid
Grid is used to evaluate the accurate placement of objects in the viewports. It is visible 
in all viewports. To toggle the visibility of the grid, place the cursor on the viewport and 
then press G.

Viewport Menu Bar
The Viewport menu bar is located on the top of every viewport. A Viewport menu bar consists  
of various options, namely Viewport Letter Identifier button, Views menu, Memo cams, 
Camera Icon button, Eye Icon button, X, Y, and Z buttons, Display Mode button, and the 
Resize button, as shown in Figure 1-12. These options allow you to perform various functions 
such as changing views and displaying types, setting scene visibility, and resizing the viewport. 
These options are discussed next. 

Figure 1-12  Various options in the Viewport menu bar

Viewport Letter Identifier
The Viewport Letter Identifier button is placed on the extreme left corner of the Viewport 
menu bar, which is represented by buttons A, B, C, and D for different viewports. These 
buttons are used to make the viewport mute or solo. When you click on the Viewport Letter 
Identifier button in a viewport, all other viewports will be muted. Alternatively, you can 
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right-click on the Viewport Letter Identifier button; a flyout with the options Mute and 
Solo will be displayed. You can mute the viewport by choosing the Mute option from the 
flyout. Refresh rate of a particular viewport can be increased by muting its neighboring 
viewports. A muted viewport does not update itself until it is unmuted. Alternatively, click on 
the Viewport Letter Identifier button using the middle mouse button to mute the viewport. 
It is a toggle button, therefore left clicking the letter again will make the viewport solo. 
The Viewport Letter Identifier button of a solo viewport is displayed in green. 

Views Menu
There are different ways to set the angles from which you can view your scene in the 3D 
viewports. Options in the Views menu are used to control the views to be displayed, refer 
to Figure 1-13. A Views menu contains various options such as Cameras, User, Top, Right, 
Front, Spot lights, and so on.

Figure 1-13  Various options in the Views menu

Memo Cams
The Memo Cams buttons store up to four views that can be quickly recalled later, when 
required. You can use left-click to recall, middle-click to save, CTRL+middle-click to 
overwrite, and right-click to clear the view.

Camera Icon Button
When you choose the Camera Icon button from the Viewport menu bar, a Camera Icon 
menu will be displayed, as shown in Figure 1-14. The options in this menu are used to 
manipulate the view such as orbit, track, and dolly the scene with the help of navigation 
controls and shortcut keys. You can also change the background color of the viewport and 
scene using the options in this menu.
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Figure 1-14  Partial view of Camera Icon menu

Eye Icon Button
When you choose the Eye Icon button from the Viewport menubar, the Eye Icon menu 
will be displayed, as shown in Figure 1-15. The options in the Eye Icon menu are used to 
control the visibility of object types, components, and attributes in the viewports.	

      Figure 1-15  The Eye Icon menu
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X, Y, and Z Buttons
The X, Y, and Z buttons are used to change the view in the viewport. The X button is 
used to view the right side, Y to view the top side, and Z to view the front side of the active 
viewport, respectively. You can also click on X using the middle mouse button to view the 
left side, Y to view the bottom side, and Z to view the back side of the active viewport, 
respectively. 

Display Mode Button
When you choose the Display Mode button from the Viewport menu bar, the Display 
Mode menu is displayed, as shown in Figure 1-16. The options in this menu are used to 
change the display mode of the scene. By default, Wireframe is selected as the display 
mode. In Autodesk Softimage, the High Quality display mode gives a close view of the 
final rendered image in the viewport. 

Figure 1-16  The Display Mode menu

Resize Button
The Resize button is used to modify the size of the viewport. Choose the Resize button 
to maximize and restore the viewport, middle-click to maximize and restore horizontally, 
CTRL+middle click to maximize and restore vertically, and right-click to display a shortcut 
menu, refer to Figure 1-17.
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Figure 1-17  The shortcut menu displayed on right-clicking on the Resize button

Changing the Background Color of the Viewports
To change the background color of the viewport, choose the Camera Icon button from the 
Viewport menu bar; the Camera Icon menu will be displayed. Choose Set Background to 
Black from the menu to change the background color of the viewport to black. You can also 
change the color of an object, grid, and background by choosing the Scene Colors option 
from the menu.

Navigation Tools 
These tools allow you to change the ways in which you can view a scene in the viewports. The 
navigation controls help you to work efficiently with 3D views. To work with navigation tools, 
choose the Camera Icon button; the Camera Icon menu will be displayed. In this menu, all 
the navigational tools such as Pan & Zoom Tool, Dolly Tool, Orbit Tool, and so on will be 
displayed, refer to Figure 1-14. The most commonly used tools are discussed next.

Frame Selection
The Frame Selection option is used to frame the selected objects in the active viewport, refer 
to Figure 1-14. To frame selected objects in a viewport, select the Frame Selection option 
from the Camera Icon menu or press F. 

Frame All
The Frame All option is used to frame all objects in a viewport. To frame all objects in a 
viewport, select Frame All option from the Camera Icon menu or press A.

Center Selection
The Center Selection option is used to set the object at the center of the viewport. To set the 
object at the center of the viewport, select the Center Selection option from the Camera Icon 
menu or press ALT+C.

Track Tool
The Track Tool is used to track the camera at varying speeds in 3D viewports. You can track 
the camera at a normal speed, slowly, or quickly. To track the camera at a normal speed, press 
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and hold the left mouse button and drag the cursor. To track the camera slowly, press and 
hold the middle mouse button and drag the cursor. To track the camera quickly, press and 
hold the right mouse button and drag the cursor.

Orbit Tool
The Orbit Tool is used to rotate a camera, spotlight, or user viewpoint around its point of 
interest such that you can maneuver around the 3D objects to obtain different views. Choose 
the Orbit Tool from the Camera Icon menu or press O. Next, press the left mouse button to 
allow free rotation. You can also press the middle mouse button to allow vertical rotation and 
the right mouse button to allow horizontal rotation.

Note
The Orbit Tool is used only in non-orthographic views (Camera, User, and so on).

Pivot Tool
The Pivot Tool is used to rotate the point of interest around the camera, spotlight, or user 
viewpoint in the view. It only works in the perspective view. The left mouse button allows free 
rotation, the middle mouse button allows vertical rotation, and the right mouse button allows 
horizontal rotation in the viewport.

Dolly Tool
The Dolly Tool is used to move the view forward or backward without changing the field of 
view in the viewport. To move the view, choose Dolly Tool from the Camera Icon menu or 
press P to activate it. Next, press the left mouse button and drag the cursor to move the view 
normally, press the middle mouse button and drag the cursor to move the view slowly, or press 
the right mouse button and drag to move the view quickly. 

Roll Tool
The Roll Tool is used to rotate the camera along the viewing axis (Z). It only works in the 
Camera view and User view. To rotate the camera, choose Roll Tool from the Camera Icon 
menu or press L. Next, press the left mouse button and drag the cursor to roll the camera with 
normal speed, press the middle mouse button and drag the cursor to roll the camera slowly 
and press the right mouse button and drag the cursor to roll the view quickly. 

Walk Tool 
The Walk Tool is a walkthrough camera tool that is used to combine the mouse movement with 
a custom key map to help you navigate precisely in the Camera view. To do so, choose the Walk 
Tool from the Camera Icon menu to activate it. Next, press and hold the left mouse button 
and drag the cursor for normal walk, press and hold the middle mouse button and drag the 
cursor for slow walk, and press the right mouse button and drag the cursor for quick walk.

Shortcut Keys to Navigate in the Viewports
In Autodesk Softimage, you can invoke various commands using shortcut keys. Once you press a 
shortcut key, the shape of the cursor will change to identify the active tool. Any further key input 
will execute the related tool. For example, pressing V activates Transform Tool. Note that only 
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one tool can be activated at a time. Tools can be activated in one of the two modes: Sticky and 
Supra. The Supra mode is also referred to as temporary mode. In Sticky mode, you can activate 
a tool by quickly pressing and releasing its shortcut key, while in Supra mode, you must keep the 
key held down to let the tool remain active. For example, press V to activate Transform Tool in 
the Sticky mode. Next, press and hold S; the navigation tool will be activated in the Supra mode. 
Now, you can press the left mouse button to pan, the middle mouse button to dolly, and the right 
mouse button to orbit around in the viewport. Release S; Transform Tool will be activated again. 

Main Command Panel
The Main Command Panel contains most frequently used commands 

Figure 1-18  The  Main 
Command Panel

and tools for selecting, transforming, snapping, constraining, and editing 
objects, refer to Figure 1-18. It is located on the right side of the viewports 
along the right edge of the interface screen. In this panel, tools and 
commands of similar use are grouped under different headings as 
subpanels. To access the tools and commands in a subpanel, left-click on 
the name of the panel; the tools and options in that subpanel will be 
displayed. To expand and collapse the subpanel right-click on the 
respective subpanel. The subpanels in the Main Command Panel are 
discussed next.

Select Subpanel
The Select subpanel is used to select the objects to manipulate them. 
 
Transform Subpanel
The Transform subpanel contains different transform tools, commands, 
and edit boxes that are used to scale, rotate, and translate the objects.

Snap Subpanel
The Snap subpanel is used to align the objects while moving or creating 
them. The Snap subpanel contains different buttons that are used to 
enable different types of snapping such as snap to points, snap to segments, and snap to 
reference plane.

Constrain Subpanel 
The Constrain subpanel contains different buttons that are used to create, cut, and split the 
hierarchical link between the objects. 

Edit Subpanel
The Edit subpanel is used to edit, group, and freeze the objects. This panel can also be used 
to delete the history of actions performed on an object.  

KP/L 
The KP/L button is used to switch to the Keying panel, if this panel is not the current panel. 
The KP/L panel is divided into three sections, refer to Figure 1-19. These sections are discussed 
next.
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Mini Transform Panel
The Mini Transform panel is used to set the transformation values of the objects. This is 
the same as using the Transform panel on the Main Command Panel.              
                                   
Keying Panel
The Keying Panel is used to set the keys for an object and then animate the object based on 
the set value. This panel is displayed only when an object is created. You can set the transform 
values of the object and set the values of animation parameters in their respective fields under 
the Local Transform property set available in the Keying Panel, refer to Figure 1-20.

Figure 1-19  The KP/L 
panel

Figure 1-20  The Local 
Transform property set

Animation Layers Panel
The options in the Animation Layers panel are used to create animation layers, add keys in 
a separate layer of an object, control the animation, and manage different elements in the 
scene. 

PPG Button
The PPG button is used to switch to the Property Page panel available in the main toolbar.
In this panel, you can work with properties of elements such as height, width, angles, and 
subdivisions of the geometry. 

Lower Interface Controls
The lower interface controls are used to control animations, set animation parameters, and 
edit the animation information. These controls are located at the bottom edge of the interface 
screen, as shown in Figure 1-21. These controls are discussed next. 
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Timeline and Time Range
The Timeline displays the duration of the current animation. The Time Range displays the  
range of frames for the current animation. 

Open Script Editor
The Open Script Editor button is used to display an editor in which you can create, save, 
and modify scripts.

Open Scene Debugger
The Open Scene Debugger button is used to display the Scene Debugger window which is 
used to analyze the performance of a scene by displaying the processing time of the scene 
and the memory consumed.

Playback Control Panel
You can control an animated scene using various controls in the Playback control panel. The 
different controls available in this panel are Previous Frame (Left), Next Frame (Right), First 
Frame (Home), Play Backwards from the End Frame, Play Forward, Last Frame (End), Loop, 
Audio Mute, Current Frame, Play All Frames VS. Real-Time Playback, and so on.

Animation Panel
The Animation panel contains a number of animation controls that allow you to mark 
parameters, set keyframes, retime animation, and so on. These controls are discussed next.

Autokey Button
The Autokey button is used to automatically create the animation key after editing 
each parameter. 

Animation Button
The Animation button is used to control the animation. It contains commands 
for many animation operations such as setting and removing keys, moving 

between keyframes, copying and removing an animation, scaling and offsetting animation, 
setting expressions and scripted operators, linking parameters, unmarking parameters, 
and opening the expression and animation editors.

Previous Key and Next Key Buttons
The Previous Key and Next Key buttons are used to switch to the previous and 
next keyframes in the Timeline, respectively. Alternatively, you can press the left 
arrow or right arrow key.
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Tip: Press CTRL+left arrow and CTRL+right arrow to switch to the previous and next 
keys in the Timeline, respectively. 

Set Key on Marked Parameter Button
The Set Key on Marked Parameter button is used to add a key at the current 
frame.

Save Key Preference                                
When you start setting the animation keys, you need to set a preference

Figure 1-22  A flyout 
with various options

 
that determines which parameters are keyed, when you press K. 
Choose the Key Marked Parameters button; a flyout will be 
displayed with various options, as shown in Figure 1-22. These 
options are discussed next.  

Key Marked Parameters: This option is selected by default. As a 
result, the keys are set only on marked parameters. 

Key All Keyable: This option is used to set the keys on all parameters (keyable) for the 
selected object that is displayed in the keying panel.

Key Marked Keyable: This option is used to set the keys only on keyable parameters that 
are marked in the keying panel.

Key Character Key Set: This option is used to set the keys only on parameters in the 
current character (or sub character) key set.

	 Marked  Parameter: The options in the Marked Parameter drop-down list are used to 
open the marked parameters during animation operations. The current parameter of the 
selected object is displayed in the edit box below the drop-down list. You can also lock and 
clear the marked parameters by using the Lock and Clear Marking buttons next to the 
Marked Parameter drop-down list. Figure 1-23 shows the Marked Parameter with Lock 
and Clear Marking buttons.

Figure 1-23  The Marked Parameter drop-down list 
and the Lock and Clear Marking buttons

Character Key Sets Button
The Character Key Sets button provides commands for creating and working with 
character key sets. 



1-20				                    Autodesk Softimage 2014: A Tutorial Approach

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om
Main Shelf
The Main Shelf contains the most commonly used tools and buttons. It is located below 
the menu bar. By default, there are some predefined shelves in the Main Shelf such as 
Polygons, Primitives, Navigation, Transform, Selection, Display, and Visibility, as shown 
in Figure 1-24.

Figure 1-24  The Main Shelf

Managing FILEs in Autodesk Softimage
Softimage has many features for managing files within projects. Using these features, you 
can create, open, save, import, and export your files. Softimage also allows you to organize 
various files associated with the scene files into projects. A project may contain unlimited 
number of scenes. By default, the scene files are stored in the Scenes folder with .scn extension. 
In the next section, you will learn to manage files in Softimage.

Setting a Project Folder
Before you start a project, you need to create a project folder to keep your files in an organized 
manner. To set the project, choose File > New Project from the menu bar; the New Project 
dialog box will be displayed, as shown in Figure 1-25. 

Figure 1-25  The New Project dialog box

In the Project Name edit box of this dialog box, enter the name of the project.  In the Location 
edit box, specify the location where you want to save the project. Next, choose the OK button; 
a new project folder will be created at the specified location. You can also set your project by 
choosing File > Project Manager from the menu bar. On doing so, the Project Manager dialog 
box will be displayed, as shown in Figure 1-26. In this dialog box, a list of created projects will 
be displayed in the Select a Project list. You can create a new project, add a project, remove 
a project, delete a project by using various buttons in this dialog box. In the Select Scene list, 
all files in the selected project folder are displayed. You can also create a new scene in the 
selected project folder using the New Scene button.
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Figure 1-26  The Project Manager dialog box

Creating a Scene
When you start Autodesk Softimage, a new scene is opened automatically. You can set the 
output format of the newly opened scene in the Preferences dialog box. To do so, choose 
File > Preferences from the menu bar; the Preferences dialog box will be displayed. In this 
dialog box, choose Output Format from the list located at the left side of the dialog box; 
the Output Format properties are displayed on the right side of the pane in this dialog box. 
Next, set the required frame format in the Preset drop-down list and then choose the Save 
Custom Preset button; the frame format will be saved. Next, close the dialog box. Now, choose 
File > New Scene from the menu bar or press CTRL+N; a message box with the message 
“Do you want to save it now” will be displayed. Choose the No button from this message box; 
the Untitled scene will be displayed. 

Note
The NTSC D1 4/3 720x486 frame format is used in all tutorials of this textbook.

Opening Files
To open an existing file, choose File > Open from the menu bar; the Load Scene dialog box 
will be displayed. Alternatively, press CTRL+O. In this dialog box, choose the Paths button 
to browse to the desired path. If the project is already set, then you need to select the project 
folder in the dialog box and then select the required file from the Scenes sub folder. 

Saving a Scene
To save a scene file, Choose File > Save from the menu bar; the Save Scene dialog box will 
be displayed, as shown in Figure 1-27. Specify the file name in the File Name edit box, and 
then choose the OK button to save the scene and close the dialog box. 
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Figure 1-27  The Save Scene dialog box

Exporting and Importing Files
You can import and export files by using the options available in the Import and Export 
cascading menus from the File menu. The file formats that can be imported and exported  
are FBX, OBJ, XSI, EMDL, MOV, AVI, and so on.

shortcut keys Used in Softimage
Softimage provides a list of shortcut keys for performing the actions quickly. A list of shortcut 
keys and their functions has been given in Table 1-1.

Table 1-1  A list of commands and shortcut keys

Key Function

CTRL + N Open a new scene

CTRL + O Open a scene

CTRL + S Save a scene

CTRL + ENTER Display information of a scene

SHIFT + ENTER Display information of selection

CTRL + Q Exit (quit) the application

ESC Terminate mode / Deactivate tool

1 Switch to the Model toolbar

2 Switch to the Animate toolbar

3 Switch to the Render toolbar

4 Switch to the Simulate toolbar
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CTRL + 1 Switch to the main toolbar

CTRL + 2 Switch to the Hair toolbar

CTRL + 3 Switch to the Weight Paint panel

DELETE Delete the selected object

ALT + 5 Open the Netview window

CTRL + G Create a group

CTRL+ SHIFT+ G Remove a group

Z Zoom and Pan

SPACEBAR Activate the Object mode

T Activate the Point mode

Y Activate the Polygon mode

C Activate Rotation Tool

X Activate Scaling Tool

V Activate Translate Tool

F12 Resize the viewport

 Self-Evalution Test 
Answer the following questions:

1. 	 Which of the following tools is used to frame selected objects in viewports?
	
		  (a) Frame Selection		  (b) Frame All
		  (c) Center Selection		  (d) Reset

2. 	 In which of the following views, Softimage allows you to orbit the camera?

		  (a) Front view			   (b) Top view
		  (c) Side view 			   (d) Camera

3.	 Which of the following toolbars is used for crowd simulation?
	
		  (a) Animate	 		  (b) Model
		  (c) ICE	 			   (d) Simulate

4. 	 The __________ key is used to activate the Pan & Zoom tool.

5.	 The __________ option from the Camera Icon menu is used to set the selected object at 
the center of the viewport.

6. 	 The options in the __________ menu is used to lip-sync, rig, and animate the faces.
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7.	 You can navigate in a viewport using the __________ key.

8. 	 You can create and modify elements using the __________ toolbar from the main toolbar.

9. 	 The __________ button is to used to resize a viewport.

10.	 The MCP panel is the main panel where you set the animation keys. (T/F)

11. The V key is used to activate Transform Tool. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following toolbars is used to create particles?
	
		  (a) Animate	 		  (b) Model
		  (c) ICE	 			   (d) Simulate

2.	 Which of the following keys is used to resize the viewport?

		  (a) F12				    (b) F4
		  (c) F8				    (d) F2

3.	 You can choose the __________ tool to select the objects in the viewports.

4.	 The __________ key is used to dolly in the viewport.

5.	 The __________ option in the Camera Icon menu, which is displayed on choosing the 
Camera Icon button, is used to change the background color of the viewport.

6.	 Autodesk Softimage uses the __________ coordinate system.

7.	 Autodesk Softimage uses the __________ extension while saving the scene files.

8.	 In the Animation panel, the __________ button is used to set a key automatically after 
each parameter is edited.

9.	 The ViewCube is used to change the way you view objects in the viewport. (T/F)
 
10.	 The options in the Eye Icon menu are used to make the viewports mute and solo. (T/F)

Answers to Self-Evaluation Test
1. a, 2. d, 3. c, 4. Z, 5. Center Selection, 6. Face Robot, 7. S, 8. Model, 9. Resize, 10. F, 11. T


