
Chapter 2

Polygon Modeling
 Learning Objectives 
After completing this chapter, you will be able to:
• Create and edit polygon primitive objects
• Work with different selection modes
• Set the object properties
• Transform the objects
• Group and duplicate the objects
• Work with deformers
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Introduction
A polygon is a shape which consists of three or more sides and points. These sides are called 
edges. The area bounded by three or more points and their associated edges is called a 
polygon. In other words, there are three basic components of a polygon mesh: points, edges, 
and polygons, as shown in Figure 2-1. Polygon models are usually created using the three sided 
polygons (triangles) or four sided polygons called quadrilaterals (quads). In this chapter, you 
will learn the fundamentals of the polygon modeling.

Figure 2-1  Different components of a polygon mesh

Working with Polygon Mesh
A polygon mesh is a collection of points and 
edges that make up the surface of the polygon 
model. In polygon modeling, you can start with 
a polygon mesh and then modify it by adding 
edges, subdividing polygons, and so on. There 
are multiple tools available in Softimage for 
adding points, edges, and polygons. These 
tools can be accessed by choosing Model > 
Modify > Poly. Mesh from the main toolbar. 
Alternatively, you can press and hold ALT and 
then right-click on the polygon object to access 
these tools. 

To create a polygon mesh object such as 
cube, choose the Model toolbar from the 
main toolbar or press 1. Next, choose Get > 
Primitive > Polygon Mesh > Cube from  the 
menu bar; the Scene_Root : cube (General) 
property editor will be displayed, as shown in 
Figure 2-2.

Figure 2-2  The Scene_Root: cube (General) 
property editor



Polygon Modeling	      2-3

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

In this property editor, you can use the Length and Name edit boxes to specify the length 
and name of the cube. The options in the drop-down list in the Subdivision Rule area of the 
Polygon Mesh property set are used to specify the subdivision algorithm of the geometry. You 
can use the Subdivisions area of the Geometry property set to add segments to the cube. 

Grouping, Duplicating, and Cloning Objects
In Softimage, you can group, duplicate, and clone objects. It helps in modeling and scene 
management. These processes are discussed next.

Grouping Objects
Grouping is a process of uniting multiple objects. You can add various 3D objects that can 
grouped together to a scene. To create a group, select objects in the viewport and then choose 
Edit > Create Group from the menu bar or press CTRL+G; the Scene_Root : Group property 
editor will be displayed. Change the options in this editor as required and then close it.

Duplicating and Cloning the Objects
In Softimage, there are two methods to create copies of the objects: duplicating and cloning. 
Duplicating is the process in which you can make the duplicate copies of an object. When an 
object is duplicated, the original object and its duplicate can be modified separately. Cloning 
is the process of creating copies of object such that the changes made in the original object 
reflect in the cloned object as well.

Note
1. You can not duplicate or clone an object if it is locked.
2. When you duplicate an object, the material applied to the original object is also duplicated. 

You can access duplicate and clone options from the cascading menu displayed on choosing 
Edit > Duplicate/Instantiate from the menu bar. The most commonly used options for 
duplicating and cloning an object available in the Duplicate/Instantiate cascading menu are 
discussed next.

Duplicate Single
This option is used to duplicate the object. The values that will be copied will depend on the 
settings that you specify in the Duplicate Options property editor which can be invoked by 
choosing Duplicate/Instantiate Options from the Duplicate/Instantiate cascading menu. You 
can also duplicate an object in the viewport by first selecting it and then pressing CTRL+D. On 
duplicating the object, the duplicate object superimposes the original geometry. To rotate the 
duplicate object, press C to activate Rotate Tool and then you can rotate the duplicate object. 
If you press CTRL+D again, the object will be duplicated with the same transformation as 
in the selected duplicated object, refer to Figure 2-3. You can precisely change the transform 
values by specifying the settings in the Duplicate Options property editor.
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Duplicate Single without Options
This option is used to duplicate the object without using options specified in the Duplicate 
Options property editor. You can also invoke this option by pressing CTRL+ALT+D. To move 
the duplicate object, press V to activate Translate Tool and then drag the duplicate object. 
If you press CTRL+ALT+D again, the object will be duplicated and it will superimpose the 
selected geometry. When you use this command, it does not apply transformations to the 
duplicated geometry.  

Figure 2-3  Duplicate copies of object displayed in the viewport

You can use the Explorer window to view the original and duplicate object in a hierarchical 
structure. To do so, choose the Scene button from the Main Command Panel; the Explorer 
window will be displayed, refer to Figure 2-4. This window displays original (cone) and duplicated 
(cone1) geometries.

Note
The Explorer window is used to view the contents of the scene in a hierarchical structure called 
tree. It displays the objects as well as their properties. Also, in this window, you can search objects 
by name, rename the scene elements, sort or reorder the elements, create parent/child relationships, 
add objects to group and so on.

Duplicate Multiple
This option is used to create multiple copies of an object. Select the object in the viewport 
that you want to duplicate and then choose this option from the cascading menu; the 
Duplicate Multiple dialog box will be displayed, as shown in Figure 2-5. Alternatively, you 
can press CTRL+SHIFT+D to invoke this dialog box. In this dialog box, enter the desired 
value in the Copies edit box of the Duplicate Multiple property set. Next, set the required 
transformation values in the Rotation and Translation area of the Transform tab and then 
choose the OK button to duplicate the object with the transformation applied. Figure 2-6 
shows the duplicate cube objects with transformation applied.
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Figure 2-4  The original (cone) and duplicated (cone1) 
geometries displayed in the Explorer window

Figure 2-5  The Duplicate Multiple dialog box
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Figure 2-6  Transformation applied to the duplicated cube objects

You can also create duplicates along a curve. To do so, create a path in the viewport by choosing 
Model > Create > Curve > Draw Cubic by CVs and then select the animated object in the 
scene. Next, press CTRL+SHIFT+D to invoke the Duplicate Multiple dialog box. In this 
dialog box, specify the number of copies you need to create and then choose the OK button. 
Make sure that the duplicates are still selected and then choose the Constrain subpanel from 
the Main Command Panel; a flyout will be displayed. Choose Curve (Path) from the flyout; the 
shape of the cursor will be changed. Now, pick the curve from the viewport that you want to use 
as a path. On doing so, the Scene_Root : [multi] : PathCns property editor will be displayed. 
In this property editor, enter L(100) in the Path %age edit box; the duplicates will be placed 
along the curve, refer to Figure 2-7. If you want to spread the duplicates to a specific length 
of curve, enter L(n) in the Path %age edit box. Here, n represents percentage of the path. For 
example, if you want to spread the duplicates along half of the path, replace n by 50.

Note
The process of duplicating a group is similar to that of duplicating an object. However, it is 
important that what is selected before you execute any duplicate/instantiate command. If you select 
group container in the Explorer window and then execute any duplicate/instantiate command, 
only the container will be duplicated not its members. To duplicate the members, choose the 
Select subpanel from the Main Command Panel; a flyout will be displayed. Now, choose Select 
Member/Components and then execute any duplicate/instantiate command.

Clone Multiple
This option is used to create multiple clones of an object. To create clones of the object, select it 
in the viewport and then choose Clone Multiple from the cascading menu; the Clone Multiple 
dialog box will be displayed, as shown in Figure 2-8. The options in this dialog box are similar 
to those of the Duplicate Multiple dialog box. Figure 2-9 shows the cloned cylinder objects 
with transformation applied. 
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Figure 2-7  Duplicated cylinder objects placed along the curve

Figure 2-8  The Clone Multiple dialog box

When you make changes in the original object, it will also affect the cloned geometries. 
Figure 2-10 shows cloned cylinder objects after the Bend deformer is applied to the original 
cylinder object.

Note
In Softimage, you can copy multiple 3D objects and paste them on one or more target objects. To 
do so, select the objects in the Explorer window and then choose Edit > Copy from the menu 
bar. Now, select the target objects and choose Edit > Paste from the menu bar; the copied objects 
will be displayed under the targets objects in the Explorer window.
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Figure 2-9  The instances of the cylinder in all viewports

Figure 2-10  The instanced cylinder objects after applying the Bend deformer

Tutorials

 Tutorial 1
In this tutorial, you will create a bus stop model, as shown in Figure 2-11, by using the polygon 
primitives. 							         (Expected time: 35 min)

The following steps are required to complete this tutorial:

a. 	 Create the project folder.
b. 	 Create the floor of the bus stop.
c.  	 Create the pillars of the bus stop.
d.  	Create the roof of the bus stop.
e.  	 Create the base of the bench.
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f.	 Create the legs of the bench.
g.	 Create the back support of the bench.
h.	 Create the backrest of the bench.
i.	 Save and render the scene.

Figure 2-11  The bus stop model

Creating the Project Folder
Before you start working on a new scene, it is recommended that you create the project folder. 
Creating a project folder helps you keep all files of a project organized.

Open Windows Explorer and browse to the Documents folder. In this folder, create a new 
folder with the name softimage2014. The softimage2014 folder will be the main folder and it 
will contain all the project folders that you will create while doing tutorials of this textbook. 
Now, you will create first project folder for Tutorial 1 of this chapter. To do so, you need to 
follow the steps given below:

1.	 Start Autodesk Softimage 2014. 

2.	 Choose File > New Scene from the menu bar; a new scene is displayed.

3.	 Choose File > New Project from the menu bar; the New Project dialog box is 
displayed.

4.	 Enter c02_tut1 in the Project Name edit box. Now, choose the Browse button located 
next to the Location edit box; the Browse for Folder dialog box is displayed. Navigate 
to \Documents\softimage2014 and then choose the Select button.

5.	 Choose the OK button in the New Project dialog box; a new folder with the name c02_tut1 
created in the softimage2014 folder.
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6.	 Choose File > Save from the menu bar; the Save Scene dialog box is displayed.

7.	 Enter c02_tut_01 in the File Name edit box and then choose the OK button.

Note
1. When you start Softimage, the last project that you have worked with is opened and an empty 
scene is created with the name Untitled.

2. You can expand or collapse a subpanel in the Main Command Panel by right-clicking on 
it.

3. It is recommended that you frequently save the file while you are working on them by pressing 
the CTRL+S keys.

	
	  4. Softimage 2014 handles large scene files upto 4 GB on Windows and 2 GB on Linux.

Creating the Floor of the Bus Stop
In this section, you will create the floor of the bus stop.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Grid from the main toolbar; the 
Scene_Root : grid (General) property editor is displayed. In this property editor, enter 
base in the Name edit box.

2.	 In the Grid property set, enter 50 and 50 in the U Length and V Length edit boxes, 
respectively. Next, close the property editor.

3.	 Choose the Display Mode button from the Camera Viewport menu bar; the 
Display Mode menu is displayed. Next, choose Shaded from the menu; the 
geometry is displayed in the shaded mode in the Camera viewport.

	 When you choose the Display Mode button, the Display Mode menu is displayed. The 
options in this menu are used to specify how scene elements will be displayed in the 
viewport. You can choose options such as Wireframe, Shaded, Bounding Box, Textured, 
High Quality, and so on from this menu.

4.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the main toolbar; the 
Scene_Root : cube (General) property editor is displayed. In this property editor, enter 
floor in the Name edit box.

5	 In the Geometry property set, enter 4, 2, and 5 in the U, V, and Base edit boxes of the 
Subdivisions area, respectively, as shown in Figure 2-12. Next, close the property editor; a 
cube with the name floor is created in all viewports. To view all the viewports simultaneously, 
press F12.
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Figure 2-12  The Scene_Root: cube (General) property editor

	 Next, you will position the floor of the bus stop.

6.	 Next, set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 1.32	  		  y: 0.12	   	    	 z: 3.67

	 t area
	 x: -5.34	

	 After specifying the values, floor is displayed in viewports, as shown in Figure 2-13.

Figure 2-13  The floor displayed in viewports
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Tip: To frame a selected object in a viewport, press F. To frame selected objects in all 
viewports, press SHIFT+F. To frame all visible objects in a viewport, press A. To frame 
all visible objects in all 3D views, press SHIFT+F.

Creating the Pillars of the Bus Stop
In this section, you will create pillars of the bus stop.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cylinder from the main toolbar; 
the Scene_Root : cylinder (General) property editor is displayed. In this property editor, 
enter pillar1 in the Name edit box.

2.	 In the Geometry property set, enter 10, 6, and 3 in the U, V, and Base edit boxes, 
respectively, of the Subdivisions area. Next, close the Scene_Root : cylinder (General) 
property editor.

3.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 0.26			   y: 2.86				    z: 0.26	
	
	 t area
	 x: -9			   y: 5.79	 			   z: 13	

	 After specifying the values, pillar1 is displayed in viewports, as shown in Figure 2-14.

Figure 2-14  The pillar1 displayed in viewports

	 Next, you will duplicate and arrange the pillars at their desired positions.

4.	 Press CTRL+ALT+D; a duplicate copy of pillar1 is created with the name pillar2. Next, 
press V; Translate Tool is activated. Now, align pillar2 with the floor in viewports, as shown 
in Figure 2-15.  
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Figure 2-15  Aligning pillar2 with floor in viewports
5.	 Create two more duplicate copies of pillar and align them with floor in viewports, as shown 

in Figure 2-16.

Figure 2-16  Aligning the duplicate pillars in viewports

Creating the Roof of the Bus Stop 
In this section, you will create the roof of the bus stop.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cylinder from the main toolbar; 
the Scene_Root : cylinder (General) property editor is displayed. In this property editor, 
enter roof in the Name edit box.

2.	 In the Cylinder property set of the property editor, enter 4.62 and 28.07 in the Radius 
and Height edit boxes, respectively.

3.	 In the Geometry property set, enter 11, 5, and 3 in the U, V, and Base edit boxes, 
respectively, of the Subdivisions area.
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4.	 Enter 180 and 0 in the Start U and End U edit boxes, respectively of the Extent (Angles) 
area of the Geometry property set. Next, close the Scene_Root : cylinder (General) 
property editor; a cylinder with the name roof is created in viewports.

5.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 r area
	 x: 90			 

	 t area
 	 x: -5.47		        y: 11.06	   	        z: 0.5
	
	 After specifying the values, the roof of the bus stop is displayed in viewports, as shown in 

Figure 2-17.

Figure 2-17  The roof of the bus stop displayed in viewports

	 Next, you will create the base of the roof.

6.	 Press SPACEBAR; the Object mode is activated. Next, select floor and then duplicate it 
by pressing CTRL+ALT+D. Now, enter the values for the following parameters in the 
Transform subpanel of the Main Command Panel:

	 s area
	 x: 1.08		         y: 0.05		       z: 3.5	
	
	 t area
	 x: -5.4		         y: 11.42	   	      z: 0.5	

		N  ote
Always remember that if you align an object at a particular position in a viewport, it is obligatory 
to align it in viewports.
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Creating the Base of the Bench
In this section, you will create the base of the bench.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the menu bar; the 
Scene_Root : cube (General) property editor is displayed.  In this property editor, enter 
bench in the Name edit box.

2.	 In the Geometry property set, enter 4, 2, and 5 in the U, V, and Base edit boxes, 
respectively, of the Subdivisions area. Next, close the Scene_Root : cube (General) 
property editor; a cube with the name bench is created in all viewports.

3.	 Enter the values for the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 0.42			   y: 0.06			   z: 1.42

	 t area
	 x: -5.23	  		  y: 1.98			   z: 0.72 

	 After specifying the values, the base of bench is displayed in viewports, as shown in 
Figure 2-18.

Figure 2-18  The base of bench displayed in viewports

Creating the Legs of the Bench
In this section, you will create the legs of the bench.

1. 	 Choose Model > Get > Primitive > Polygon Mesh > Cylinder from the main toolbar; 
the Scene_Root : cylinder (General) property editor is displayed. In this property editor, 
enter leg1 in the Name edit box.
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2.	 In the Geometry property set, enter 10, 6, and 3 in the U, V, and Base edit boxes, 
respectively, of the Subdivisions area. Next, close the Scene_Root : cube (General) 
property editor; a cube with the name leg1 is created in all viewports.

3.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
  	 x: 0.19			    y: 0.37			  z: 0.11	

	 r area
	 y: -90

	 t area
	 x: -3.72	  		  y: 1.23 			   z: 5.95 

	 After specifying the values, leg1 is displayed in viewports, as shown in Figure 2-19.		

Figure 2-19  The leg1 displayed in viewports

	 Next, you will duplicate leg1 to create three more legs and then arrange them.

4.	 Press D; Duplicate Tool is activated and the shape of the cursor changes to a pen icon. 
Next, in the Top viewport, click on it where you want to place the second leg. Repeat the 
process to create other two legs. Right-click in the viewport to exit the tool. Now, you 
have created three new duplicates of leg1. Next, place and align leg2, leg3, and leg4 at the 
corner of the bench in viewports, refer to Figure 2-20.
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Figure 2-20  Aligning the legs in viewports

Creating the Back Support of the Bench
In this section, you will create the back support of the bench.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the main toolbar; the 
Scene_Root : cube (General) property editor is displayed. In this property editor, enter 
backsupport1 in the Name edit box.

2.	 In the Geometry property set, enter 4, 2, and 5 in the U, V, and Base edit boxes, 
respectively, of the Subdivisions area. Next, close the Scene_Root : cube (General) 
property editor; a cube with the name backsupport1 is created in viewports.

3.	 Set the following values in the Transform subpanel of the Main Command Panel:

	 s area
	 x: 0.05	   	             y: 0.07		  	 z: 0.32
 
	 r area
	 x: -90			   z: 180

	 t area
	 x: -6.81          		  y: 3.47       		  z: 6

4.	 Press CTRL+ALT+D; backsupport1 is duplicated with the name backsupport2. Next, 
enter -4.54 in the z edit box of the t area in the Transform subpanel of the Main Command 
Panel.

 	 After specifying the values, backsupport1 and backsupport2 are displayed in viewports, as 
shown in Figure 2-21.
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Figure 2-21  Backsupports displayed in viewports

Creating the Backrest of the Bench
In this section, you will create the backrest of the bench.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the menu bar; the 
Scene_Root : cube (General) property editor is displayed. In this property editor, enter 
backrest1 in the Name edit box.

2.	 In the Geometry property set, enter 4, 2, and 5 in the U, V, and Base edit boxes, 
respectively, of the Subdivisions area. Next, close the Scene_Root : cube (General) 
property editor; a cube with the name backrest1 is created in all viewports.

3.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	  s area
	  x: 0.05			   y: 0.04			   z: 1.32

	 r area
	 z: 90

	 t area
	 x: -6.92			    y: 4.5 	  		  z: 0.7 

4.	 Make two more copies of backrest1 and align them in viewports, as shown in Figure 2-22. 
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Figure 2-22  Aligning the copies of backrest1

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of this scene by downloading the c02_softimage_2014_rndr.zip file from 
www.cadcim.com. The path of this file is as follows: Textbooks > Animation and Visual Effects > 
Softimage > Autodesk Softimage 2014: A Tutorial Approach

1.	 Choose File > Save from the menu bar.

2.	 Hover the cursor over the Camera viewport and then press F12; the Camera viewport is 
maximized. Set the camera angle in it as required. 

3.	 Choose Render > Render > Preview from the menu bar; a window is displayed with the 
rendered output. To save the rendered image, choose the Save Picture button from this 
window; the Select File dialog box is displayed. 

4.	 In the Select File dialog box, navigate to the folder where you want save the image file. 
Next, select the required image format from the File Types drop-down list. Now, enter 
the name of the image in the File Name edit box and then choose the OK button to save 
the image file.

Note
Softimage files are saved with the .scn extension.
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 Tutorial  2
In this tutorial, you will create a house boat model, as shown in Figure 2-23, by using various 
polygon modeling techniques.                            			     (Expected time: 40 min)

Figure 2-23  The model of a house boat

The following steps are required to complete this tutorial:

a.	 Create the project folder.
b.	 Create the hull of the house boat.
c.	 Create the shelter of the house boat.
d.	 Create the roof of the boat shelter.
e.	 Create the floor of the boat shed.
f.	 Create the pillars of the boat shed.
g.	 Create the roof of the boat shed.
h.	 Save and render the scene.

Creating the Project Folder 
Create a new project folder with the name c02_tut2 at \Documents\Softimage2014 and then save 
the file with the name c02_tut_02, as discussed in Tutorial 1. 

Creating the Hull of the House Boat
In this section, you will create the hull of the house boat by using polygon primitive.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the main toolbar; the 
Scene_Root : cube (General) property editor is displayed.  In this property editor, enter 
hull in the Name edit box.

2.	 In the Cube property set, enter 12 in the Length edit box. Next, enter 6, 3, and 6 in the 
U, V, and Base edit boxes, respectively, in the Geometry property set of the Subdivisions 
area. Next, close the Scene_Root : cube (General) property editor; a cube with the name 
hull is created in viewports.
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3.	 Choose the Display Mode button from the Camera Viewport menu bar; the Display Mode 
menu is displayed. Choose Shaded from this menu; the geometry is displayed in the 
shaded mode in the Camera viewport. To view all viewports simultaneously, press F12.

4.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 7			  y: 0.3		        z: 2

	 After specifying the values, hull is displayed in viewports, as shown in Figure 2-24.

Figure 2-24  The hull displayed in viewports

5.	 Choose the Point button from the Main Command Panel; the Object mode is changed 
to the Point mode. Alternatively, you can press T to activate the Point mode.

	 Selection modes are most commonly used predefined combinations of selection filters. You 
can access these filters from the Modes cascading menu which is displayed when you click 
on the Select subpanel in the Main Command Panel or by pressing the corresponding 
shortcut keys such as T (Point mode), E (Edge mode), and Y (Polygon mode). You can 
press the SHIFT key with the aforesaid keys for enabling the extended mode. 

Note
The extended modes are similar to the non-extended modes. However, the only difference between 
these two is that when you activate the extended mode, the components those you have already 
selected are not removed from the selection.

6.	 Marque-select the left-most points in the Top viewport, as shown in Figure 2-25; the color 
of the selected points is changed from blue to red.
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Figure 2-25  Points selected in the Top viewport

7.	 Press and hold the X key; Scale Tool is activated. Next, scale the points inward along 
the X axis and then release the X key, as shown in Figure 2-26.

Figure 2-26  Selected points scaled inward

8.	 Similarly, adjust the points on the right side of  hull. Modify the shape of hull by moving 
the points using Translate Tool (press and hold V) and then define the shape of the boat, 
as shown in Figure 2-27. 

9.	 Choose the Polygon button from the Main Command Panel; the Polygon mode is activated. 
Alternatively, press Y to activate it.

10.	 Choose the Selection tab from Main Shelf. If Main Shelf is not visible, choose 
View > Optional Panels > Main Shelf from the menu bar. Next, choose the Raycast 
Polygon Selection Mode tool from the Selection tab and then select the polygons in the 
Top viewport by dragging the cursor on them, as shown in Figure 2-28. Alternatively, press 
U to invoke the Raycast Polygon Selection Mode tool.
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Figure 2-27  Modifying the shape of hull

Figure 2-28  Selecting the center polygons of hull in viewports

11.	 Choose Model > Modify > Poly. Mesh > Extrude Along Axis from the main toolbar; 
the Scene_Root : hull : Polygon Mesh : Extrude Op property editor is displayed. In 
this property editor, enter -10 and 0.123 in the Length and Inset Amount edit boxes, 
respectively. Next, enter 5 in the Subdivs edit box. Now, close the property editor; the 
extruded polygons are displayed in viewports, as shown in Figure 2-29. 

	 The Extrude Along Axis option is used to copy the selected components (polygons, edges, 
points, clusters, or polygon mesh objects) and transform the new geometry. The extruded 
components remain connected to the original geometry. 
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Figure 2-29  The extruded polygons of hull displayed in viewports

	 Next, you will apply the Smooth deformer to hull to smoothen it.

12.	 Press SPACEBAR; the Object mode is activated. Make sure hull is selected and then choose 
Model > Modify > Deform > Smooth from the main toolbar; the Scene_Root : hull 
: Polygon Mesh : Smooth property editor is displayed. In this property editor, set the 
value for the Strength parameter based on your requirement. After applying the Smooth 
deformer, the smooth hull is displayed in viewport, as shown in Figure 2-30. 

Figure 2-30  The smooth hull displayed in viewport

	 There are many deformers available in Softimage. They are powerful modeling and 
animation tools. You can apply deformers to polygon meshes, surfaces, hierarchies, cluster 
of components, lattices, particle clouds, and hair. 

	 The Smooth deformer is used to remove spikes from the geometry. It is also used to 
smoothen the discontinuities in the shape and in rounding seams around extruded 
polygons.
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13.	 Press T; the Point mode is activated. Move the mouse pointer to the Front viewport 
and press F12; the Front viewport is maximized. Next, select the points in it, refer to 
Figure 2-31 and press V; Translate Tool is activated. Now, move the selected points up 
along the Y axis, as shown in Figure 2-31. Press V again to deactivate Translate Tool.

Figure 2-31  Moving the selected points up along the Y axis 

14.	 Select the points in the Front viewport, as shown in Figure 2-32. Press V; Translate 
Tool is activated. Next, move the selected points up along the Y axis, as shown in 
Figure 2-33. Now, press the + (plus) key twice; the surface becomes smooth. 

Figure 2-32  Points selected in the Front viewport

Note
Press the + (plus) key repeatedly to increase the smoothness of the object and the - (minus) to 
decrease the smoothness of the object.
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Figure 2-33  Moving the selected points up along the Y axis 

Creating Shelter of the House Boat
In this section, you will create the shelter of the house boat.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Grid from the main toolbar; the 
Scene_Root : grid (General) property editor is displayed. In this property editor, enter 
boatshelter in the Name edit box.

2.	 In the Grid property set, enter 25 and 20 in the U Length and V Length edit boxes, 
respectively. Next, close the Scene_Root : grid (General) property editor; a grid with the 
name boatshelter is displayed in viewports.

3.	 Choose Model > Modify > Deform > Fold from the main toolbar; the Fold deformer 
is applied to boatshelter and the Scene_Root : boatshelter : Polygon Mesh : Fold Op 
property editor is displayed. Next, enter -223 and 51 in the Angle and Distortion edit 
boxes, respectively, of the Amplitude area and then close the property editor; the shape 
of boatshelter is changed.

	 The Fold deformer is used to fold the object. It wraps the extremities of an object toward 
the specified axis. The Angle parameter is used to specify the amount of folding in 
degrees.

4.	 Set the values for following parameters in the Transform subpanel of the Main Command 
Panel:

	 s area 
	 x: 1.3		  y: 1.9		      z: 1.7		

	 r area
	 y: -90		

	 t area
	 x: 5 		    y: 15	                    z: 0.07
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	 After specifying the values, boatshelter is aligned on the top of hull in viewports, as shown 
in Figure 2-34.

Figure 2-34  Aligning boatshelter in viewports

Creating the Roof of the Boat Shelter 
In this section, you will create the roof of the boat shelter.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Grid from the main toolbar; the  
Scene_Root : grid# (General) property editor is displayed. In this property editor, enter 
roof in the Name edit box.

2.	 In the Grid property set, enter 12 and 32 in the U Length and V Length edit boxes, 
respectively. Next, close the Scene_Root : grid# (General) property editor; a grid with 
the name roof is displayed in viewports.

3.	 Choose Model > Modify > Deform > Fold from the main toolbar; the Fold deformer 
is applied to roof and the Scene_Root : roof : Polygon Mesh : Fold Op property editor 
is displayed. In this property editor, enter -86 and 49 in the Angle and Distortion edit 
boxes, respectively, in the Amplitude area and then close the property editor; the shape 
of roof is changed.

4.	 Set the values for the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 1.2		    y: 1.3		           z: 1.3
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	 r area
	 y: -90
		
	 t area
	 x: 5		  	   y: 15		             z: 0
	
Creating the Floor of the Boat Shed
In this section, you will create the floor of the boat shed.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the main toolbar; the 
Scene_Root : cube (General) property editor is displayed. In this property editor, enter 
floor in the Name edit box.

2.	 In the Cube property set, enter 7 in the Length edit box.  Next, in the Geometry property 
set, enter 4, 4, and 4 in the U, V, and Base edit boxes, respectively, of the Subdivisions 
area. Now, close the Scene_Root : cube (General) property editor; a cube with the name 
floor is created in viewports.

3. 	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 1.2	   	  y: 0.03	  		  z: 1.2	  

	 t area
	 x: -21		  y: 1.12	 		   z: 0.2

	 After specifying the values,  floor is displayed in viewports, as shown in Figure 2-35.

Figure 2-35  The floor displayed in viewports
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Creating the Pillars of the Boat Shed
In this section, you will create the pillars of the boat shed.
1.	 Choose Model > Get > Primitive > Polygon Mesh > Cylinder from the main toolbar; 

the Scene_Root : cylinder (General) property editor is displayed. In this property editor, 
enter pillar1 in the Name edit box.

 
2. 	 In the Cylinder property set, enter 0.2 and 14 in the Radius and Height edit boxes, 

respectively. Next, close the Scene_Root : cylinder (General) property editor; a cylinder 
with the name pillar1 is displayed in viewports.

3. 	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 t area
	 x: -17		    y: 6.4		              z: -3.5

	 After specifying the values,  pillar1 is displayed in viewports, as shown in Figure 2-36.

Figure 2-36  The pillar1 displayed in viewports

4.	 Make three more copies of pillar1 by pressing CTRL+ALT+D and align them in viewports, 
as shown in Figure 2-37.
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Figure 2-37  Aligning pillars in viewports

Creating the Roof of the Boat Shed
In this section, you will create the roof of the boat shed.

1.	 Choose Model > Get > Primitive > Polygon Mesh > Cube from the main toolbar; the 
Scene_Root : cube# (General) property editor is displayed.  In this property editor, enter 
shedroofbase in the Name edit box.

2.	 In the Cube property set, enter 6 in the Length edit box. Next, in the Geometry property 
set, enter 4, 3, and 4 in the U, V, and Base edit boxes, respectively, of the Subdivisions 
area. Next, close the Scene_Root : cube# (General) property editor; a cube with the name 
shedroofbase is created in viewports.

3.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 s area
	 x: 1.2			   y: 0.04	 	  	 z: 1.47

	 t area
	 x: -21			   y: 13.5			   z: -0.2

	 After specifying the values, shedroofbase is displayed in viewports, as shown in 
Figure 2-38.

4. 	 Choose Model > Get > Primitive > Polygon Mesh > Grid from the main toolbar; the 
Scene_Root : grid (General) property editor is displayed. In this property editor, enter 
shedroof in the Name edit box.
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Figure 2-38  The shedroofbase displayed in viewports

5.	 In the Grid property set, enter 11 and 10 in the U Length and V Length edit boxes, 
respectively. Next, close the Scene_Root : grid (General) property editor; a grid with the 
name shedroof is created in viewports.

6.	 Choose Model > Modify > Deform > Fold from the main toolbar; the Fold deformer 
is applied to shedroof and the Scene_Root : shedroof : Polygon Mesh : Fold Op property 
editor is displayed. In this property editor, select Linear from the Type drop-down list of 
the Direction area and enter -104 in the Angle edit box in the Amplitude area and then 
close the property editor; the shape of shedroof is changed.

7.	 Set the values of the following parameters in the Transform subpanel of the Main 
Command Panel:

	 r area
	 y: 90

	 t area
	 x: -21			   y: 16		             z: 0.39

	 After specifying the values, shedroof is displayed in viewports, as shown in Figure 2-39.
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Figure 2-39  The shedroof displayed in viewports 

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of this scene by downloading the c02_softimage_2014_rndr.zip file from 
www.cadcim.com. The path of this file is as follows: Textbooks > Animation and Visual Effects > 
Softimage > Autodesk Softimage 2014: A Tutorial Approach

1.	 Choose File > Save from the menu bar.

2.	 Activate the Camera viewport and then set the camera angle in it as required. Choose 
Render > Render > Preview from the menu bar; a window is displayed with the rendered 
output. 

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following deformers is used to fold the object?

		  (a) Bend				    (b) Taper
		  (c) Smooth				    (d) Twist

2.	 Which of the following key combinations is used to create multiple duplicate copies of an 
object?

		  (a) CTRL+SHIFT+D			   (b) CTRL+D
		  (c) CTRL+ALT+D			   (d) D	
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3.	 The ____________ option in the Render menu from the menu bar is used to view the 
rendered scene.

4.	 You can duplicate the selected object at any desired location by pressing D. (T/F)

5.	 In cloning, if you edit the parent object, it will affect all the cloned objects. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following shortcut keys is used to switch the object from object mode to point 
mode?

	 (a)  V				    (b) T
	 (c)  Y				    (d) X
	
2.	 Which of the following buttons is used to open the Scene_Root flyout?

		  (a) Scene			   (b) Polygon	
		  (c) Group			   (d) Explorer

3.	 Which of the following shortcut keys is used to invoke Translate Tool?

	 (a) V				    (b) X
	 (c) T				    (d) C

4.	 The ____________ key is used to switch to Polygon mode.
	
5.	 The ____________ deformer is used to smoothen the object.

Exercises 
The rendered output of the models used in the following exercises can be accessed by 
downloading the c02_softimage_2014_exr.zip from www.cadcim.com. The path of the file is as 
follows: Textbooks > Animation and Visual Effects > Softimage > Autodesk Softimage 2014: A Tutorial 
Approach
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 Exercise 1 
Create the models of a table and bench using the polygon primitives, as shown in 
Figure 2-40.               		    				      (Expected time: 35 min)

Figure 2-40  The models of the table and bench

Exercise 2
Create the model of a houseboat using polygon primitives and deformers, as shown 
in Figure 2-41.  					     	  	   (Expected time: 40 min)

Figure 2-41  The model of the houseboat
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 Exercise 3 
Create the models of a chair and center table using the deformers, as shown in Figure 2-42. 	
						        		    (Expected time: 30 min)

Figure 2-42  The models of the chair and the center table

 Exercise 4 
Create the model of a cartoon character using Extrude Along Axis tool, as shown in 
Figure 2-43. 	   						        (Expected time: 30 min)

Figure 2-43  The model of a cartoon character
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 Exercise 5 
Create the model of a cartoon character using Extrude Along Axis tool, as shown in 
Figure 2-44.   							         (Expected time: 35 min)

Figure 2-44  The model of a cartoon character

 Exercise 6 
Create a 3D scene by using primitive tools and deformers, as shown in Figure 2-45. 	
								          (Expected time: 40 min)

Figure 2-45  3D scene created using primitive tools
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 Exercise 7 
Create the model of a cartoon character, as shown in Figure 2-46. 
								          (Expected time: 30 min)

Figure 2-46  The model of a cartoon character

 Exercise 8 
Create the stairs using polygon primitives and various duplicating techniques, as shown in 
Figure 2-47. 							         (Expected time: 25 min)

Figure 2-47  Stairs created using various primitive tools
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Answers to Self-Evaluation Test
1. d, 2. a, 3. Preview, 4. T,  5. T


