
Chapter 2

Importing Media 
Files

 Learning Objectives 
After completing this chapter, you will be able to:
• Import media files using the import option
• Import media files using the Media Browser panel
• Import multiple media files
• Import still images and layered Photoshop files
• Import a saved Premiere project into the opened project
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INTRODUCTION
In this chapter, you will learn to open the project file and import various types of media 
files using different methods. You will also learn to import single layered and multi-layered 
Photoshop files. Moreover, you will learn to import a saved Premiere project into an opened 
project.  

Before you start this chapter, you need to download the c02_premiere_cc_tut.zip from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
Premiere Pro > Adobe Premiere Pro CC: A Tutorial Approach

Next, extract the contents of the zip file at \Documents\Adobe Premiere Tutorials.

OPENING THE PROJECT FILE
In this section, you will open the project file.

1.	 Start Premiere as discussed in Chapter 1; the Welcome to Adobe Premiere Pro dialog 
box is displayed along with the Premiere screen. 

2.	 Choose the Open Project button in this dialog box; the Open Project dialog box is 
displayed, refer to Figure 2-1.

Figure 2-1  The Open Project dialog box

3.	 In this dialog box, browse to the location \Documents\Adobe Premiere Tutorials\ 
c02_premiere_cc_tut. Next, select the chapter02 file and then choose the Open button; the 
chapter02 file is opened.

4.	 Choose File > Save As from the menu bar; the Save Project dialog box is displayed, refer 
to Figure 2-2. Type the name chapter02_02 in the File name text box and choose the 
Save button; the opened file is saved with the specified name.
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Figure 2-2  The Save Project dialog box

IMPORTING FILES
You can import video, audio, still images, and Photoshop files to the Premiere project. In this 
process, you can import a single file, multiple files, or an entire folder. Next, you will learn to 
import various types of files.

Importing Files Using the Import Option
In this section, you will import files by using the Import option from the File menu.

1.	 Choose File > Import from the menu bar; the Import dialog box is displayed, as shown 
in Figure 2-3. Alternatively, press CTRL+I to invoke the Import dialog box.

Figure 2-3  The Import dialog box
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2.	 In this dialog box, browse to \Documents\Adobe Premiere Tutorials\02_premiere_cc_tut\Media 
Files\Video and then select Tickoo Wind Turbine.mp4. Next, choose the Open button; the 
selected file is imported and displayed in the Project panel, as shown in Figure 2-4.

Figure 2-4  The Tickoo Wind Turbine file displayed in the Project panel 
after importing

	 Next, you will import multiple media files.

3.	 Double-click on an empty area in the Project panel; the Import dialog box is displayed.

4.	 In this dialog box, browse to \Documents\Adobe Premiere Tutorials\c02_premiere_cc_tut\Media 
Files\Video. Next, select all media files except the Tickoo Wind Turbine.mp4, beach clips, Locked 
Backdrop, and Norway folders.

5.	 Choose the Open button; all the selected media files in the Video folder are imported and 
displayed in the Project panel, as shown in Figure 2-5.

6.	 Select all the media files in the Project panel except Tickoo Wind Turbine and then press 
DELETE; the selected media files are deleted from the Project panel.

	 Next, you will import a folder containing the media files.	

7.	 Press CTRL+I; the Import dialog box is displayed.

8.	 In this dialog box, browse to \Documents\Adobe Premiere Tutorials\c02_premiere_cc_tut\Media 
Files\Video. Now, select the Beach clips folder; the Import Folder button is activated. Choose 
this button; the entire folder is displayed in the Project panel, as shown in Figure 2-6. 

9.	 In the Project panel, click on the arrow on the left of the folder label to view all the files 
inside the folder.
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Figure 2-5  Multiple files imported in the Project 
panel

Figure 2-6  An entire folder imported in the 
Project panel
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Note
If you have deleted any recently imported file from the Project panel, you can easily reimport 
that file. To do so, choose File > Import Recent File from the menu bar; a cascading menu is 
displayed showing all the recently imported files, refer to Figure 2-7. Now, you can choose the 
required file from the cascading menu.

Figure 2-7  The recently imported files displayed in the cascading menu

Importing Files Using the Media Browser Panel
In this section, you will import the files using the Media Browser panel.

1.	 Choose the Media Browser panel, if it is not already chosen; all the drives are listed on 
the left of this panel, as shown in Figure 2-8.

Figure 2-8  All drives in hard drive displayed in the Media Browser panel 

2.	 In this panel, navigate to the \Documents\Adobe Premiere Tutorials\c02_premiere_cc_tut\Media 
Files folder. Now, double-click on the Video folder in the right pane of the Media Browser 
panel; all the files inside the Video folder are displayed on the right of the Media Browser 
panel, as shown in Figure 2-9.

3.	 Right-click on the file name that you want to import; a shortcut menu is displayed, refer 
to Figure 2-10.

4.	 Choose the Import option from the shortcut menu; the selected media file is imported 
and displayed in the Project panel. 

	 Alternatively, drag the required file from the Media Browser panel to the Project panel 
to import it. 
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Figure 2-9  All files inside the Video folder displayed in the Media Browser panel 

Figure 2-10  The shortcut menu displayed after right-clicking on a file

Importing Still Image in Adobe Premiere Pro CC
In this section, you will import the still image.

1.	 Double-click on empty area in the Project panel; the Import dialog box is displayed.

2.	 In this dialog box, browse to \Documents\Adobe Premiere Tutorials\c02_premiere_cc_tut\Media 
Files\Stills and then select sea beach.JPG. Next, choose the Open button; the selected image 
is imported and displayed in the Project panel. The thumbnail preview and description of 
the imported image is displayed at the top of the Project panel, as shown in Figure 2-11. 

Figure 2-11  The thumbnail preview and 
description of the image displayed
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	 As per the description, the default duration of the imported image is 5 seconds. However, 
you can change the default duration of the still image as per your requirement. To change 
the default duration, follow the steps given next.

3.	 Choose Edit > Preferences > General from the menu bar; the Preferences dialog box 
is displayed.

4.	 In this dialog box, enter 120 in the Still Image Default Duration edit box and then choose 
the OK button to close the dialog box. 

5.	 Import another still image in the Project panel. Now, you will notice that the duration of 
the image is 4 seconds.

Note
It is recommended to change the default duration of the still images based on your requirement 
before importing them.

Importing Layered Photoshop Files
You can import the stills created in Photoshop using one of the methods discussed earlier in 
this tutorial. In this section, you will import a layered Photoshop file in Premiere Pro.

1.	 Double-click on empty area in the Project panel; the Import dialog box is displayed.

2.	 Browse to the \Documents\Adobe Premiere Tutorials\c02_premiere_cc_tut\Media Files\psd folder 
that you have downloaded from CADCIM website. Now, select the Photoshop option from 
the drop-down list located on the right of the File name text box; the Photoshop files are 
displayed in the Import dialog box, refer to Figure 2-12.   

Figure 2-12  The Photoshop files displayed in the Import dialog box
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3.	 Select the baby center file and then choose the Open button; the Import Layered File: 
baby center dialog box is displayed, as shown in Figure 2-13. 

Figure 2-13  The Import Layered File: baby center dialog box

	 By default, the Merge All Layers option is selected in the Import As drop-down list in 
this dialog box. This option is used to import the entire psd file as a single flattened PSD 
clip. On selecting the Individual Layers option, only the selected layers will be imported. 

	 Next, you will import an individual layer from the PSD file.

4.	 Select the Individual Layers option from the Import As drop-down list and then choose 
the Select None button; all the layers are deselected. 

5.	 Select the Home Page Support check box to select this layer and then choose the OK 
button; the selected individual layer is imported and displayed in the Project panel, as 
shown in Figure 2-14.

Figure 2-14  The individual layer imported and displayed 
in the Project panel
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	 Next, you will import the individual layers according to the footage dimensions.

6.	 Repeat steps 1 to 4 discussed above.

7.	 Select the Funny nanny check box and make sure that the Document Size option is selected 
in the Footage Dimensions drop-down list. Now, choose the OK button; the selected layer 
is imported and displayed in the Project panel.

8.	 In the Project panel, double-click on the imported Funny nanny layer icon; it is displayed 
in the Source Monitor, as shown in Figure 2-15.  

Figure 2-15  The Funny nanny layer displayed in the Source Monitor

9.	 Repeat steps 1 to 4 and select the Funny nanny check box.

10.	 In the Footage Dimensions drop-down list, select the Layer Size option and choose the 
OK button; the individual selected layer is imported.

11.	 In the Project panel, double-click on the imported Funny nanny layer icon; it is displayed 
in the Source Monitor, as shown in Figure 2-16.  

	 Next, you will import the layered Photoshop file as a sequence.

12.	 Press the CTRL+ I; the Import dialog box is displayed. 

13.	 Select the baby center file and choose the Open button; the Import Layered File: baby 
center dialog box is displayed.
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Figure 2-16  The Funny nanny layer displayed in the Source Monitor

14.	 Select the Sequence option from the Import As drop-down list and choose the OK button; 
a new bin (folder) with the name baby center is created in the Project panel. Expand 
the baby center folder, if not already expanded. Notice all the layers and the sequence 
created are displayed in the Project panel, refer to Figure 2-17.

Figure 2-17 All Photoshop layers displayed 
in the baby center bin in the Project panel 

15.	 Drag the vertical slider in the Project panel to view the new baby center sequence and 
then double-click on it; the sequence is displayed in the Timeline panel as well as in the 
Program Monitor, as shown in Figures 2-18 and 2-19. You need to press the backslash (\) 
key to properly view the Photoshop layers in the Timeline panel, refer to Figure 2-18. 
Also, drag the slider in the Timeline panel to view all the video tracks. Press CTRL+S to 
save the file.
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Figure 2-18  The baby center sequence displayed in the Timeline panel

Figure 2-19  The new sequence displayed in the Program Monitor

Importing the Saved Premiere Projects
You can import the saved Premiere projects into the opened Premiere project. This is the only 
way to transfer the complete sequence and clip information of a project into another project. 
In this section, you will learn to import a saved Premiere project into the opened project.

 
1.	 Open the file chapter02_import.prproj that you have downloaded from the CADCIM website.

2.	 Choose File > Save As from the menu bar; the Save Project dialog box is displayed. Type 
the name chapter02_import_02 in the File name text box and choose the Save button; 
the opened file is saved with the specified name, refer to Figure 2-20.
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Figure 2-20  The chapter02_import_02 file displayed

3.	 Delete the beach clips from the Project panel by selecting them and then pressing DELETE.
	 On pressing DELETE; the Adobe Premiere Pro message box is displayed, as shown in 

Figure 2-21. Choose the Yes button from the message box.

Figure 2-21  The Adobe Premiere Pro message box

4.	 Double-click on empty area in the Project panel; the Import dialog box is displayed.	

5.	 In the Import dialog box, select Adobe Premiere Pro Projects from the drop-down 
list located at the bottom right corner of the dialog box. Next, browse to the location 
\Documents\Adobe Premiere Tutorials\c02_premiere_cc_tut. Then, select the chapter02_import 
file and choose the Open button; the Import Project: chapter02_import dialog box is 
displayed, as shown in Figure 2-22.

Figure 2-22 The Import Project: 
chapter02_import dialog box
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	 In the Import Project: chapter02_import dialog box, the Import Entire Project radio 
button is selected by default. This radio button is used to import the entire project with 
all its sequences and media assets. The Import Selected Sequences radio button in this 
dialog box is used to import the selected sequences from the project.  

6.	 Make sure the Import Entire Project radio button is selected in the Import Project: 
chapter02_import dialog box and then choose the OK button; the chapter02_import 
file is imported and displayed in the Project panel as a folder. You can expand the bin to 
view its sequence and files, refer to Figure 2-23. 

Figure 2-23  Partial view of the chapter02_import 
folder in the Project panel

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following shortcut keys is used to invoke the Import dialog box?
 	
		  (a) CTRL+I				    (b) ALT+CTRL+I
		  (c) ALT+I				    (d) SHIFT+I

2.	 Which of the following panels is used to import the media files in Premiere project?

		  (a) Media Browser	 		  (b) Info
		  (c) Effects Controls			   (d) Effects

3.	 To search files on your computer hard drive, you can use the ________ panel.

4.	 You cannot import an entire folder into Adobe Premiere Pro. (T/F)

5.	 You can import the saved Premiere Pro projects into your current opened project. (T/F) 
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 Review Questions 
Answer the following questions:

1.	 Which of the following shortcut keys is used to select a range of files to import them in 
Adobe Premiere Pro?

	
		  (a) CTRL				    (b) SHIFT
		  (c) CTRL+ALT				   (d) ALT

2.	 Which of the following media files can be imported into the Premiere project?

		  (a) Video clips				    (b) Photoshop files
		  (c) Audio clips				    (d) All of these

3.	 Before importing a file, you can preview in the ________ to decide whether to import or 
not.

4.	 You can double-click on empty area in the Project panel to invoke the Import dialog box. 
(T/F)
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EXERCISE
Exercise 1

Create a new project in Premiere as per the specifications of a video clip. Try to import various 
types of files using different options in Premiere.

Answers to Self-Evaluation Test
1. a, 2. a, 3. Media Browser, 4. F, 5. T


