
Chapter 1
Introduction to 

AutoCAD

Initial Setup•  

AutoCAD Screen •  
Components

Ribbon•  

Application Menu•  

Tool Palettes•  

Menu Bar•  

Toolbar•  

New•  

Save•  

Save As•  

Close•  

STARTUP•  

Open•  

Partial open•  

Drawing Recovery •  
Manager

Workspaces•  

Help•  

Autodesk Exchange •  
Apps

Autodesk 360•  

Autodesk Cloud•  

Design Feed•  

File Tabs•  

 Key Terms         

Learning Objectives
After completing this chapter, you will be able to:
• Start AutoCAD
• Understand the usage of the components of the initial AutoCAD screen
• Invoke AutoCAD commands from the keyboard, menus, toolbars, shortcut menus,
   Tool Palettes, and Ribbon
• Work with File Tabs
• Understand the usage of components of dialog boxes in AutoCAD
• Start a new drawing using the New tool, File Tabs, and the Startup dialog box
• Save a work using various fi le-saving commands
• Close a drawing
• Open an existing drawing
• Quit AutoCAD
• Understand various options of AutoCAD help
• Understand the use of Active Assistance, Learning Assistance, and other interactive help topics
• Understand the concept of Design Feed
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STARTING AutoCAD
When you install AutoCAD 2015, the AutoCAD 2015 - English shortcut icon is created on the 
desktop. You can start AutoCAD by double-clicking on it. You can also start AutoCAD from the 
taskbar. To do so, choose Start >All Programs > Autodesk > AutoCAD 2015 - English (refer 
to Figure 1-1) from the taskbar; the AutoCAD 2015 interface screen along with Startup dialog 
box will be displayed. In the dialog box, you can select the required template. By default, the 
Acad.dwt template is selected. After selecting the required template, choose the OK button. 
The initial screen of AutoCAD 2015 appears as per the template selected. You will learn more 
about selecting templates later in this chapter,

Figure 1-1  Starting AutoCAD 2015 from the taskbar

AutoCAD SCREEN COMPONENTS
The initial AutoCAD screen comprises of drawing area, command window, menu bar, several 
toolbars, Model and Layout tabs, and Status Bar, as shown in Figure 1-2. A title bar that has 
AutoCAD symbol and the current drawing name is displayed on top of the screen. 
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Figure 1-2   AutoCAD screen components in AutoCAD Drafting & Annotation workspace

New Tab
In AutoCAD 2015, the New Tab is displayed in the AutoCAD environment when you 
close all the drawing templates or when there are no drawings open. The New Tab 
contains two sliding frames, CREATE and LEARN, see Figure 1-3. These frames are 
discussed next.

Figure 1-3   New Tab in AutoCAD 2015
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CREATE
When you click on the CREATE sliding frame, the CREATE page is displayed. In the CREATE 
page, you can access sample fi le, recent fi les, templates, product updates as well as connect 
with the online community. The CREATE page is divided into three  columns: Get Started, 
Recent Documents, and Connect.

LEARN
When you click on the LEARN sliding frame, the LEARN page is displayed. The LEARN 
page provides tools to help you learn AutoCAD 2015. You can slide to the LEARN page 
from the CREATE page by clicking on LEARN at the left or bottom of the page. It is divided 
into three columns: What’s New, Getting Started Videos, and Tip/Online Resources with 
Security Updates.
 
 Drawing Area
The drawing area covers the major portion of the screen. In this area, you can draw the 
objects and use the commands. To draw the objects, you need to defi ne the coordinate points, 
which can be selected by using your pointing device. The position of the pointing device is 
represented on the screen by the cursor. The window also has the standard Windows buttons 
such as close, minimize, scroll bar, and so on, on the top right corner. These buttons have the 
same functions as for any other standard window.

Command Window
The command window at the bottom of the drawing area has the Command prompt where you 
can enter the commands. It also displays the subsequent prompt sequences and the messages. 
You can change the size of the window by placing the cursor on the top edge (double line 
bar known as the grab bar) and then dragging it. This way you can increase its size to see all 
the previous commands you have used. By default, the command window displays only three 
lines. You can also press the F2 key to display AutoCAD Text Window, which displays the 
previous commands and prompts.

Tip
You can hide all toolbars displayed on the screen by pressing the CTRL+0 keys or by choosing 
View > Clean Screen from the menu bar. To turn on the display of the toolbars again, press 
the CTRL+0 keys. You can also choose the Clean Screen button in the Status Bar to hide 
all toolbars.

Auto Correct the Command Name    
In AutoCAD, if you type a wrong command name at the Command prompt, a suggestion list 
with most relevant commands will be displayed, refer to Figure 1-4. You can invoke the desired 
command by selecting the required option from this list. 

Auto Complete the Command Name  
When you start typing a command name at the Command prompt, the complete name of 
the command will be displayed automatically. Also, a list of corresponding commands will be 
displayed, as shown in Figure 1-5. The commands that have not been used for a long time 
will be grouped in folders at the bottom of the list. 
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Figure 1-4  Suggestion list with relevant 
commands

Figure 1-5  Command bar displaying complete 
command name automatically

Internet Search
You can get more information about a command by using the Search in Help and Search 
on Internet buttons available adjacent to the command name in the Command line, refer 
to Figure 1-6. If you choose the Search in Help button, the Autodesk AutoCAD 2015-Help 
dialog box will be displayed. In this dialog box, you can fi nd information about the command. 
By using the Search on Internet button, you can fi nd information about the command on 
internet. Note that these buttons will be available adjacent to the selected command name 
in the suggestion list. 

              

Figure 1-6  The Search in Help and Search on 
Internet buttons displayed in the suggestion list

Synonym Suggestions
In AutoCAD 2015, you can invoke a command by entering synonyms of the command name. 
By entering the synonym at the Command prompt, the command related to the synonym 
entered will be displayed. For example, if you enter ROUND at the Command prompt, then 
the FILLET command will be displayed, as shown in Figure 1-7. 
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om Figure 1-7  Suggestion list displayed after entering a 
synonym of command name at the Command prompt

Input Search Options
In AutoCAD 2015, you can enable or disable the functions such as Auto Complete and 
Auto Correct by using the options available in the Input Search Options dialog box. To invoke 
this dialog box, right-click at the Command prompt; a shortcut menu will be displayed. Next, 
choose Input Search Options from the shortcut menu; the Input Search Options dialog box 
will be displayed, refer to Figure 1-8. You can now enable or disable the required functions 
by using this dialog box. 

Figure 1-8  The Input Search Options dialog box

 Navigation Bar
The Navigation Bar is displayed in the drawing area and contains navigation tools. These 
tools are grouped together, refer to Figure 1-9 and are discussed next. 

 SteeringWheels
The SteeringWheels has a set of navigation tools such as pan, zoom, and so on. You will learn 
more about the SteeringWheel in the later chapters.
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Pan
This tool allows you to view the portion of the drawing that is outside

Figure 1-9  Tools in the 
Navigation Bar

 
the current display area. To do so, choose this tool, press and hold 
the left mouse button, and then drag the drawing area. Press ESC 
to exit this command.

 Zoom
The tools to enlarge the view of the drawing on the screen without 
affecting the actual size of the objects are grouped together. You 
will learn more about zoom tools in later chapters.

 Rotate
The tools to rotate the view in the 3D space are grouped together.

 ShowMotion
Choose this button to capture different views in a sequence and animate them when 
required.

 ViewCube
ViewCube is available on the top right corner of the drawing area and is used to switch between 
the standard and isometric views or roll the current view. The ViewCube and its options are 
discussed in later chapters.

In-canvas Viewport Controls
In-canvas Viewport Controls is available on the top left corner of the drawing screen. It 

enables you to change the view, visual style as well as the viewport.

 Status Bar             
The Status Bar is displayed at the bottom of the screen and is called Application Status Bar. 
It contains some useful information and buttons (see Figure 1-10) that make it easy to change 
the status of some AutoCAD functions. You can toggle between the on and off states of most 
of these functions by choosing them.
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 Figure 1-10  The Status Bar displayed in the Drafting & Annotation workspace

Drawing Coordinates
The information about the coordinates is displayed on the left corner of the Status Bar  near the 
Model and Layout tabs. You can choose the coordinate button to toggle between the on and off 
states. The  COORDS system variable controls the type of display of the coordinates. If the value 
of the COORDS variable is set to 0, the coordinate display is static, that is, the coordinate values 
displayed in the Status Bar change only when you specify a point. If the value of the COORDS 
variable is set to 1 or 2, the coordinate display is dynamic. When the variable is set to 1, AutoCAD 
constantly displays the absolute coordinates of the graphics cursor with respect to the UCS origin. 
The polar coordinates (length<angle) are displayed if you are in an AutoCAD command and 
the COORDS variable is set to 2. By default, the COORDS variable is set to 1. You can also click 
on the Drawing Coordinates area to change the coordinate status from on to off and vice-versa.

MODEL
The  MODEL button is chosen by default because you are working in the model space to create 
drawings. You will learn more about the model space in later chapters.

GRIDMODE
In AutoCAD, the grid lines are used as reference lines to draw objects. If the  GRIDMODE 
button is chosen, the Display drawing grid is on and the grid lines are displayed on the screen. 
The F7 function key can be used to turn the grid display on or off.

SNAPMODE
If the  SNAPMODE button is chosen, the snap mode is on. So, you can move the cursor in 
fi xed increments. The F9 key acts as a toggle key to turn the snap off or on. 

 Infer Constraints
If this button is chosen then some of the geometric constraints will be automatically applied 
to sketch when it is drawn. You can use CTRL+SHIFT+I as a shortcut key to toggle this 
button.
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Dynamic Input
The  Dynamic Input button is used to turn the Dynamic Input on or off. Turning it on facilitates 
the heads-up design approach because all commands, prompts, and dimensional inputs will 
now be displayed in the drawing area and you do not need to look at the Command prompt 
all the time. This saves the design time and also increases the effi ciency of the user. If the 
Dynamic Input mode is turned on, you will be allowed to enter the commands through the 
Pointer Input boxes, and the numerical values through the Dimensional Input boxes. You 
will also be allowed to select the command options through the Dynamic Prompt options in 
the graphics window. To turn the Dynamic Input on or off, use the F12 key. 

ORTHOMODE
If the  ORTHOMODE button is chosen, you can draw lines at right angles only. You can use 
the F8 function key to turn ortho on or off.

Polar Tracking
If you turn the polar tracking on, the movement of the cursor is restricted along a path based 
on the angle set as the polar angle. Choose the  Polar Tracking button to turn the polar tracking 
on. You can also use the F10 function key to turn on this option. Note that turning the polar 
tracking on, automatically turns off the ortho mode.   

Isometric Drafting                     
In AutoCAD 2015, you can activate the required working plane. To activate the required 
working plane, choose the  Isometric Drafting button from the Status Bar. On choosing this 
button, a fl yout is displayed with the isoplane Left, isoplane Top, or isoplane Right options. 
You can choose the required option from this fl yout to activate the respective work plane.

Object Snap Tracking
When you choose this button, the inferencing lines will be displayed. Inferencing lines are 
dashed lines that are displayed automatically when you select a sketching tool and track a 
particular keypoint on the screen. Choosing this button turns the object snap tracking on or 
off. You can also use the F11 function key to turn the object snap tracking on or off.

Object Snap                       
When the  Object Snap button is chosen, you can use the running object snaps to snap on to 
a point. You can also use the F3 function key to turn the object snap on or off. The status of 
OSNAP (off or on) does not prevent you from using the immediate mode object snaps.

Show/Hide Lineweight
Choosing this button in the Status Bar allows you to turn on or off the display of lineweights  
in the drawing. If this button is not chosen, the display of lineweight will be turned off.

Transparency
This button is available in the Status Bar and is chosen to turn on or off the transparency set 
for a drawing. You can set the transparency in the Properties panel or in the layer in which 
the sketch is drawn.
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Selection Cycling
When this button is chosen, you can cycle through the objects to be selected, if they are 
overlapping or close to other entities. On selecting an entity when this button is chosen, the 
Selection list box with a list of the entities that can be selected will be displayed. You can use 
CTRL+W as a shortcut key to toggle this button.

 3D Object Snap
When this button is chosen, you can snap the key point on a solid or a surface. You can also 
use the F4 function key to turn on or off the 3D object snap.

Dynamics UCS
Choosing this button allows or disallows the use of dynamic UCS. Allowing the dynamic UCS 
ensures that the XY plane of the UCS got dynamically aligned with the selected face of the 
model. You can also use the F6 function key to turn the Dynamics UCS button on or off.

Filters object selection
In AutoCAD 2015, you can fi lter objects as per your requirement by using Filters object 
selection button. If you want to select only Vertex, Edge, Face, SolidHistory, or Drawing View 
Components of a 3D object, then you can choose the required option from the fl yout which 
is invoked by clicking on the small arrow at right side of the Filters object selection button. 
You can also select multiple objects through selection window. 

The Drawing View Components option is used to select the components of an assembly 
or parts in a multi body. Using this option, you can select components either individually, 
or through window selection. You can also turn off the fi lters by choosing the Filter object 
selection button again.

 Show gizmos
You can move, rotate and scale a 3D object by choosing the Show gizmos button from the Status 
Bar. When you click on the small arrow available at the right side of the Show gizmos button, 
a fl yout will be displayed with the Move Gizmo, Rotate Gizmo, and Scale Gizmo options. 

 Show annotation objects
This button is used to control the visibility of the annotative objects that do not support the 
current annotation scale in the drawing area.

 Add Scales to annotative objects when the annotative scale 
changes
This button, if chosen, automatically adds all the annotation scales that are set current to all 
the annotative objects present in the drawing.

Annotation Scale of the current view
The annotation scale controls the size and display of the annotative objects in the model space. 
The  Annotation Scale button has a fl yout that displays all the annotation scales available for 
the current drawing.
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Workspace Switching
In AutoCAD 2015, you can switch between different environments or workspaces, by using the 
Workspace Switching button that is available at the right of the Status Bar. On clicking the 
Workspace Switching button, a fl yout will be displayed with the list of all available workspace. 
You can select the required workspace to invoke. You will learn more about workspaces later 
in this chapter. 

Annotation Monitor                                           
The Annotation Monitor button is used to turn the 

Figure 1-11  The non-associative annotation

Annotation Monitor on or off. If it is turned on, 
all the non-associative annotations will get 
highlighted by placing a badge on them, as shown 
in Figure 1-11. In this fi gure, the Line leader is 
not associated with line.

Current drawing units
The Current drawing units button displays and controls the units of drawing. It has a fl yout 
that displays all the unit systems available for drawing.

Quick Properties
If you select a sketched entity when this button is chosen in the Status Bar, the properties of 
the selected entity will be displayed in a panel. You can use CTRL+SHIFT+P as a shortcut 
key to toggle this button.

Hardware Acceleration 
This button is used to set the performance of the software to an acceptable level.

Isolate Objects
This button is used to hide or isolate objects from the drawing area. On choosing this button, 
a fl yout will be displayed with two options. Choose the Isolate Objects option from this fl yout 
and then select the objects to hide or isolate. To end isolation or display a hidden object, click 
this button again and choose the End Object Isolation option.

Clean Screen
The  Clean Screen button is available at the lower right corner of the screen. This button, when 
chosen, displays an expanded view of the drawing area by hiding all the toolbars except the 
command window, Status Bar, and menu bar. The expanded view of the drawing area can also 
be displayed by choosing View > Clean Screen from the menu bar or by using the CTRL+0 
keys. Choose the Clean Screen button again to restore the previous display state.

Customization
The Customization button is available at right corner of the Status Bar. Using this button, 
you can customize to add or remove tools in the Status Bar.
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Plot/Publish Details Report Available 
This icon is displayed in the Status Bar when some plotting or a publishing activity is 
performed in the background. When you click on this icon, the Plot and Publish 
Details dialog box, which provides the details about the plotting and publishing 

activity, will be displayed. You can copy this report to the clipboard by choosing the Copy to 
Clipboard button from the dialog box.

Manage Xrefs
The  Manage Xrefs icon is displayed in the Status Bar whenever an external reference 
drawing is attached to the selected drawing. This icon displays a message and an alert 
whenever the Xreffed drawing needs to be reloaded. To fi nd detailed information 

regarding the status of each Xref in the drawing and the relation between the various Xrefs, 
click on the Manage Xrefs icon; the External References Palette will be displayed. The Xrefs 
are discussed in detail in Chapter 18, Understanding External References.

INVOKING TOOLS IN AutoCAD
On starting AutoCAD, when you are in the drawing area, you need to invoke AutoCAD tools to 
perform an operation. For example, to draw a line, fi rst you need to invoke the Line tool and 
then defi ne the start point and the endpoint of the line. Similarly, if you want to erase objects, 
you must invoke the Erase tool and then select the objects for erasing.  AutoCAD has provided 
the following methods to invoke the commands:

Keyboard  Ribbon   Application Menu Tool Palettes  
Menu bar  Shortcut menu               Toolbar

Keyboard
You can invoke any AutoCAD command from the keyboard by 

Figure 1-12 The Pointer Input 
box displayed when the Dynamic 
Input is on

typing  the command name and then pressing the ENTER 
key. As you type the fi rst letter of command, AutoCAD 
displays all available commands starting with the letter 
typed. If the Dynamic Input is on and the cursor is in the 
drawing area, by default, the command will be entered 
through the Pointer Input box. The Pointer Input box is 
a small box displayed on the right of the cursor, as shown 
in Figure 1-12. However, if the cursor is currently placed 
on any toolbar or menu bar, or if the Dynamic Input is 
turned off, the command will be entered through the 
Command prompt. Before you enter a command, the 
Command prompt is displayed as the last line in the command window area. If it is not 
displayed, you must cancel the existing command by pressing the ESC (Escape) key. 

The following example shows how to invoke the LINE command using the keyboard:

Command: LINE or L �   (L is command alias) 
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 Ribbon
In AutoCAD, you can also invoke a tool from the Ribbon. The tools for creating, modifying, 
and annotating the 2D and 3D designs are available in the panels instead of being spread out 
in the entire drawing area in different toolbars and menus, see Figure 1-13. 

Figure 1-13  The Ribbon for the Drafting & Annotation workspace

When you start the AutoCAD session for the fi rst time, by default the Ribbon is displayed 
horizontally below the Quick Access Toolbar. The Ribbon consists of various tabs. The tabs 
have different panels, which in turn, have tools arranged in rows. Some of the tools have 
small black down arrow. This indicates that the tools having similar functions are grouped 
together. To choose a tool, click on the down arrow; a drop-down will be displayed. Choose 
the required tool from the drop-down displayed. Note that if you choose a tool from the 
drop-down, the corresponding command will be invoked and the tool that you have chosen 
will be displayed in the panel. For example, to draw a circle using the 2-Point option, click on 
the down arrow next to the Center, Radius tool in the Draw panel of the Home tab; a fl yout 
will be displayed. Choose the 2-Point tool from the fl yout and then draw the circle. You will 
notice that the 2-Point tool is displayed in place of the Center, Radius tool. In this textbook, 
the tool selection sequence will be written as, choose the 2-Point tool from Home > Draw > 
Circle drop-down. 

Choose the down arrow to expand the panel. You will notice that a push pin is available at 
the left end of the panel. Click on the push pin to keep the panel in the expanded state. Also, 
some of the panels have an inclined arrow at the lower-right corner. When you left click on an 
inclined arrow, a dialog box is displayed. You can defi ne the setting of the corresponding panel 
in the dialog box. 

You can reorder the panels in the tab. To do so, press and hold the left mouse button on the 
panel to be moved and drag it to the required position. To undock the Ribbon, right-click on 
the blank space in the Ribbon and choose the Undock option. You can move, resize, anchor, 
and auto-hide the Ribbon using the shortcut menu that will be displayed when you right-click 
on the heading strip. To anchor the fl oating Ribbon to the left or right of the drawing area 
in the vertical position, right-click on the heading strip of the fl oating Ribbon; the shortcut 
menu is displayed. Choose the corresponding option from this shortcut menu. The Auto-hide 
option will hide the Ribbon into the heading strip and will display it only when you move the 
cursor over this strip.

You can customize the display of tabs and panels in the Ribbon. To customize the Ribbon, 
right-click on any one of the tools in it; a shortcut menu will be displayed. On moving the 
cursor over one of the options, a fl yout will be displayed with a tick mark before all options 
and the corresponding tab or panel will be displayed in the Ribbon. Select/clear appropriate 
option to display/hide a particular tab or panel.
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 Application Menu
The Application Menu is available at the top-left of the AutoCAD window. It contains 
some of the tools that are available in the Standard toolbar. Click the down arrow on the 
Application Menu to display the tools, as shown in Figure 1-14. You can search for tools or 
commands by using the search fi eld on the top of the Application Menu. To search a tool or 
command, enter its complete or partial name in the search fi eld; the list of related tools and 
commands will be displayed. If you click on a tool from the list, the corresponding command 
will get activated. 

Figure 1-14  The Application Menu

By default, the Recent Document button is chosen in the Application Menu. Therefore, 
the recently opened drawings will be listed. If you have opened multiple drawing fi les, 
choose the Open Documents button; the documents that are opened will be listed in the 
Application Menu. To set the preferences of the fi le, choose the Options button available at 
the bottom-right of the Application Menu. To exit AutoCAD, choose the Exit button next to 
the Options button. 
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Tool Palettes
AutoCAD has provided Tool Palettes as an easy and convenient way of placing and sharing 
hatch patterns and blocks in the current drawing. By default, the Tool Palettes are not 
displayed. Choose the Tool Palettes button from the Palettes panel in the View tab or choose 
the CTRL+3 keys to display the Tool Palettes as a window in the drawing area. You can resize 
the Tool Palettes using the resizing cursor that is displayed when you place the cursor on the 
top or bottom extremity of  the Tool Palettes. The Tool Palettes are discussed in detail in 
Chapter 12, Hatching Drawings.

 Menu Bar
You can also select commands from the menu bar. Menu Bar is not displayed by default. 
To display the menu bar, click on the down arrow in the Quick Access Toolbar; a fl yout is 
displayed. Select the Show Menu Bar option from it; the menu bar will be displayed.  As you 
move the cursor over the menu bar, different tabs are highlighted. You can choose the desired 
item by left-clicking on it; the corresponding menu is displayed directly under the title. For 
example, to draw an ellipse using the Center option, choose the Draw menu and then choose 
the Ellipse option; a cascading menu will be displayed. From the cascading menu, choose the 
Center option. In this text, this command selection sequence will be referenced as choosing 
Draw > Ellipse > Center from the menu bar. 

Toolbar 
Toolbars are not displayed by default. To display a toolbar, choose Tools > Toolbars 
> AutoCAD from it; a list of toolbars will be displayed. Select the required toolbar. 
Figure 1-15 shows the Draw toolbar invoked.

Figure 1-15  The Draw toolbar

 Shortcut Menu
AutoCAD has provided shortcut menus as an easy and convenient way of invoking the recently 
used tools. These shortcut menus are context-sensitive, which means that the tools present 
in them are dependent on the place/object for which they are displayed. A shortcut menu is 
invoked by right-clicking and is displayed at the cursor location. You can right-click anywhere 
in the drawing area to display the general shortcut menu. It generally contains an option to 
select the previously invoked tool again, apart from the common tools for Windows, refer to 
Figure 1-16.
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If you right-click in the drawing area while a command is active, a shortcut menu is displayed, 
containing the options of that particular command. Figure 1-17 shows the shortcut menu 
when the Polyline tool is active.

Figure 1-16  Partial view of the shortcut menu 
with the recently used tools

Figure 1-17  Shortcut menu with the 
Polyline tool active

File Tabs
The File Tabs button is available in the Interface panel of the View tab. It is used 
to toggle the display of the File tab bar which displays all opened fi les. You can 
easily switch between multiple opened drawings by clicking on them. 

You can also create a new drawing fi le by clicking on the (+) sign available at the end of the 
File tab bars. When you click on the (+) sign, the New Tab will be displayed. You can create 
a new drawing by clicking on the Start Drawing icon on the left side of the New Tab in Get 
Started area. Figure 1-18 shows the File Tabs button chosen in the Ribbon and the File tab 
bar displayed at the bottom of the Ribbon.

Figure 1-18  The File Tabs button chosen in the Ribbon and File tab bar displayed at the 
bottom of the Ribbon

In the File tab bar, all the tabs added get arranged in the sequence in which the respective 
drawings are opened or created. You can change the sequence of tabs in the File tab bar by 
using the left mouse button. To do so, press and hold the left mouse button on any tab and 
drag it to the desired location, refer to Figure 1-19.
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Figure 1-19 Tab dragged in the File tab bar

In AutoCAD, if a large number of fi les are opened, some of the fi les will not be visible in the 
File tab bar and therefore an overfl ow symbol will be displayed on the right end of the File tab 
bar, refer to Figure 1-20. To open any tab which is not visible in the File tab bar, click on the 
overfl ow symbol; the names of all the tabs will be displayed in a fl yout, refer to Figure 1-20. 
Also, when you move the cursor on a tab name, previews of the Model, Layout1, Layout2, 
and so on will be displayed, refer to Figure 1-20. You can open the desired environment by 
clicking on its preview.

Figure 1-20  Flyout with fi le tab names and preview of their respective drawings

If you move the cursor over a fi le tab, the preview of the model and layouts will be displayed. 
When you move the cursor over any preview, the corresponding preview will be displayed in 
the drawing area, refer to Figure 1-21. 
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Figure 1-21  Previews of model and layouts

There are two buttons available on the top of preview window: Plot and Publish. By using 
Plot, you can plot the drawing and by using Publish you can publish the drawing. When you 
right-click on a fi le tab, a shortcut menu containing various options such as New, Open, Save, 
Save As, Close, and so on will be displayed, refer to Figure 1-22. You can choose the option 
from the shortcut menu as per your requirement.  

Figure 1-22  Shortcut menu displayed on right-clicking on the File tab bar
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There are two icons displayed on the fi le tab: Asterisk icon and Lock icon. The Asterisk icon  
indicates that the fi le is modifi ed but not saved. The Lock icon  indicates that the fi le is 
locked and the changes cannot be saved with the original fi le name, although you can use the 
SaveAs tool to create another copy. 

To open a drawing as a locked fi le, fi rst select the Open option from the shortcut menu displayed 
on right-clicking over the fi le tab; the Select File dialog box will be displayed. Select the desired 
fi le and then select the Open Read-Only option from the Open drop-down list, as shown in 
Figure 1-23. On doing so, the fi le will be opened as a locked fi le in the drawing area. You can 
also open the fi le as a locked fi le by using the Open button from the Quick Access Bar.

AutoCAD DIALOG BOXES
There are certain commands, which when invoked, display a dialog box. A dialog box is a 
convenient method of a user interface. When you choose an item in the menu bar with the 
ellipses [...], it displays the dialog box. For example, Options in the Tools menu displays 
the Options dialog box. A dialog box contains a number of parts like the dialog label, radio 
buttons, text or edit boxes, check boxes, slider bars, image boxes, and command buttons. 
These components are also referred to as tiles. Some of the components of a dialog box are 
shown in Figure 1-24.

Figure 1-23 Selecting the Open Read-Only option

You can select the desired tile of the dialog box by using the pointing device, which is 
represented by an arrow when a dialog box is invoked. The titlebar displays the name of the 
dialog box. The tabs specify the various sections with a group of related options under them. 
The check boxes are toggle options for making the particular option available or unavailable. 
The drop-down list displays an item and an arrow on the right which when selected displays 
a list of items to choose from.
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Figure 1-24  Components of a dialog box

You can make a selection in the radio buttons. Only one can be selected at a time. The image 
displays the preview image of the item selected. The text box is an area where you can enter a 
text such as a fi le name. It is also called an edit box, because you can make changes to the text 
entered. In some dialog boxes, there is the [...] button, which displays another related dialog 
box. There are certain buttons (OK, Cancel, Help) at the bottom of the dialog box. The name 
implies their functions. The button with a dark border is the default button. The dialog box 
has the Help button for getting help on the various features of the dialog box.

STARTING A NEW DRAWING
  Application Menu:   New > Drawing    Menu Bar:   File > New > Drawing 
  Quick Access Toolbar:  New     Command:   NEW or  QNEW             

You can open a new drawing using the  New tool in the Quick Access Toolbar. When 
you invoke the New tool, by default AutoCAD will display the Select template dialog 
box, as shown in Figure 1-25. This dialog box displays a list of default templates 

available in AutoCAD 2015. The default selected template is acad.dwt, which starts the 2D 
drawing environment. You can select the acad3D.dwt template to start the 3D modeling 
environment. Alternatively, you can select any other template to start a new drawing that will 
use the settings of the selected template. You can also open any drawing without using any 
template either in metric or imperial system. To do so, choose the down arrow on the right 
of the Open button and select the Open with no Template-Metric option or the Open with 
no Template-Imperial option from the fl yout.  
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Figure 1-25  The  Select template dialog box

You can also open a new drawing using the Use a Wizard and Start from Scratch options 
from the Create New Drawing dialog box. By default, this dialog box is not invoked. To 
invoke the Create New Drawing dialog box, enter  STARTUP in the command window and 
then enter 1 as the new value for this system variable. After setting 1 as the new value for 
the system variable, whenever you invoke the New tool, the Create New Drawing dialog box 
will be displayed, as shown in Figure 1-26. The options in this dialog box are discussed next.

Figure 1-26  The  Create New Drawing dialog box
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Open a Drawing
By default, this option is not available. This option will be available when you start a new 
session of AutoCAD. This option is discussed later in this chapter.

Start from Scratch
When you choose the Start from Scratch button (Figure 1-26), AutoCAD provides you with 
options to start a new drawing that contains the default AutoCAD setup for Imperial (Acad.dwt) 
or Metric drawings (Acadiso.dwt). If you select the Imperial default setting, the limits are 12X9, 
text height is 0.20, and dimensions and linetype scale factors are 1.

Use a Template
When you choose the Use a Template button in the Create New Drawing dialog box, 
AutoCAD displays a list of templates, see Figure 1-27. The default template fi le is acad.
dwt or acadiso.dwt, depending on the installation. You can directly start a new fi le in the 2D 
sketching environment by selecting the acad.dwt or acadiso.dwt template. If you use a template 
fi le, the new drawing will have the same settings as specifi ed in the template fi le. All the 
drawing parameters of the new drawing such as units, limits, and other settings are already 
set according to the template fi le used. The preview of the template fi le selected is displayed 
in the dialog box. You can also defi ne your own template fi les that are customized to your 
requirements (see Chapter 15, Template Drawings). To differentiate the template fi les from the 
drawing fi les, the template fi les have a .dwt extension whereas the drawing fi les have a .dwg 
extension. Any drawing fi le can be saved as a template fi le. You can use the Browse button 
to select other template fi les. When you choose the Browse button, the Select a template fi le 
dialog box is displayed with the Template folder open, displaying all the template fi les.

Figure 1-27  The default templates displayed on choosing the 
Use a Template button
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Use a Wizard
The Use a Wizard option allows you to set the initial drawing settings before actually starting 
a new drawing. When you choose the Use a Wizard button, AutoCAD provides you with the 
option for using the Quick Setup or Advanced Setup, see Figure 1-28. In the Quick Setup, 
you can specify the units and the limits of the work area. In the Advanced Setup, you can set 
the units, limits, and the different types of settings for a drawing.

Figure 1-28  The wizard options displayed on choosing the Use 
a Wizard button  

Advanced Setup
This option allows you to preselect the parameters of a new drawing such as the units of linear 
and angular measurements, type and direction of angular measurements, approximate area 
desired for the drawing, precision for displaying the units after decimal, and so on. When 
you select the  Advanced Setup wizard option from the Create New Drawing dialog box and 
choose the OK button, the Advanced Setup wizard is displayed. In the wizard, the Units page 
is displayed by default, as shown in Figure 1-29. 
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Figure 1-29  The Units page of the Advanced Setup wizard

This page is used to set the units for measurement in the current drawing. You can select the 
required unit of measurement by selecting the respective radio button. You will notice that the 
preview image is modifi ed accordingly. The different units of measurement you can choose 
from are Decimal, Engineering, Architectural, Fractional, and Scientifi c. You can also set the 
precision for the measurement units by selecting it from the Precision drop-down list.

Choose the Next button to open the Angle page, as shown in Figure 1-30. You will notice 
that an arrow appears on the left of Angle in the Advanced Setup wizard. This implies that 
this page is current. 

This page is used to set the units for angular measurements and its precision. The units for 
angle measurement are Decimal Degrees, Deg/Min/Sec, Grads, Radians, and Surveyor. The 
units for angle measurement can be set by selecting any one of these radio buttons as required. 
The preview of the selected angular unit is displayed on the right of the radio buttons. The 
precision format changes automatically in the Precision drop-down list depending on the 
angle measuring system selected. You can then select the precision from the drop-down list. 

The next page is the Angle Measure page, as shown in Figure 1-31. This page is used to select 
the direction of the baseline from which the angles will be measured. You can also set your 
own direction by selecting the Other radio button and then entering the value in its edit box. 
This edit box is available when you select the Other radio button. 
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Figure 1-30  The Angle page of the Advanced Setup wizard

Figure 1-31  The Angle Measure page of the Advanced Setup wizard

Choose Next to display the Angle Direction page (Figure 1-32) to set the orientation for the 
angle measurement. By default, the angles are positive, if measured in a counterclockwise 
direction. This is because the Counter-Clockwise radio button is selected. If you select 
the Clockwise radio button, the angles will be considered positive when measured in the 
clockwise direction. 
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To set the limits of the drawing, choose the Next button; the Area page will be displayed, as 
shown in Figure 1-33. You can enter the width and length of the drawing area in the respective 
edit boxes.

Figure 1-32  The Angle Direction page of the Advanced Setup wizard

Figure 1-33  The Area page of the Advanced Setup wizard

Note
Even after you increase the limits of the drawing, the drawing display area is not increased. 
You need to invoke the Zoom All tool from the Navigation Bar to increase the drawing 
display area.
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Quick Setup 
When you select the Quick Setup option and choose the OK button, the Quick Setup wizard 
is displayed. This wizard has two pages: Units and Area. The Units page is opened by default, 
as shown in Figure 1-34. The options in the Units page are similar to those in the Units page 
of the Advanced Setup wizard. The only difference is that you cannot set the precision for 
the units in this wizard. 

Figure 1-34  The Units page of the  QuickSetup wizard

Choose Next to display the Area page, as shown in Figure 1-35. The Area page of the 
Quick Setup is similar to that of the Advanced Setup wizard. In this page, you can set the 
drawing limits.

Figure 1-35  The Area page of the QuickSetup wizard
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Tip
When you open an AutoCAD session, a drawing opens automatically. But you can open a 
new drawing using options such as Start from Scratch and Use a Wizard before entering 
into AutoCAD environment using the Startup dialog box. As mentioned earlier, the display 
of the Startup dialog box is turned off by default. Refer to the section of Starting a New 
Drawing to know how to turn on the display of this dialog box.

SAVING YOUR WORK
  Application Menu:   SAVE AS, SAVE  Menu Bar:    File > Save or Save As 
  Quick Access Toolbar:  Save or Save As Command:   QSAVE,  SAVEAS, SAVE 

You must save your work before you exit the drawing editor or turn off your system. 
Also, it is recommended that you save your drawings in regular intervals, so that 
in the event of a power failure or an editing error, all works saved before the problem 

started will be retained.

AutoCAD has provided the QSAVE, SAVEAS, and  SAVE commands that allow you to save your 
work. These commands allow you to save your drawing by writing it to a permanent storage 
device, such as a hard drive or in any removable drive.

When you choose the Save tool from the Quick Access Toolbar or the Application Menu, the 
QSAVE command is invoked. If the current drawing is unnamed and you save the drawing 
for the fi rst time in the current session, the SAVEAS command will be invoked and you will be 
prompted to enter the fi le name in the Save Drawing As dialog box, as shown in Figure 1-36. 
You can enter the name for the drawing and then choose the Save button. If you have saved 
a drawing fi le once and then edited it, you can use the Save tool to save it, without the system 
prompting you to enter a fi le name. This allows you to do a quick save.

When you choose SaveAs from the Application Menu or choose the Save As tool from the 
Quick Access Toolbar, the Save Drawing As dialog box is displayed, similar to that shown in 
Figure 1-36. Even if the drawing has been saved with a fi le name, this tool gives you an option 
to save it with a different fi le name. In addition to saving the drawing, it sets the name of the 
current drawing to the fi le name you specify, which is displayed in the title bar. This tool is 
used when you want to save a previously saved drawing with a different fi le name. You can 
also use this tool when you make certain changes to a template and want to save the changed 
template drawing but leave the original template unchanged.

Save Drawing As Dialog Box
The Save Drawing As dialog box displays the information related to the drawing fi les on your 
system. The various components of the dialog box are described next.  

Places List
A column of icons is displayed on the left side of the dialog box. These icons contain the 
shortcuts to the folders that are frequently used. You can quickly save your drawings in one of 
these folders. The History folder displays the list of the most recently saved drawings. You can 
save your personal drawings in the Documents or the Favorites folder. The FTP folder displays 
the list of the various FTP sites that are available for saving the drawing. By default, no FTP 
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sites are shown in the dialog box. To add a FTP site to the dialog box, choose the Tools button 
on the upper-right corner of the dialog box to display a shortcut menu and select Add/Modify 
FTP Locations. The Desktop folder displays the list of contents on the desktop. The Buzzsaw 
icons connect you to their respective pages on the Web. You can add a new folder in this list 
for an easy access by simply dragging the folder on to the Places list area. You can rearrange 
all these folders by dragging them and then placing them at the desired locations. It is also 
possible to remove the folders, which are not in frequent use. Right-click on the particular 
folder and then select Remove from the shortcut menu. Now, you can also save the document 
to new location of Autodesk Cloud. The option for saving the document is discussed next.

Figure 1-36  The  Save Drawing As dialog box

Autodesk 360
This button is available on the top left side of the Save Drawing As dialog box, refer to 
Figure 1-36. It is used to save the data online in Autodesk 360. Using Autodesk 360, you 
can share data online with the people who have an Autodesk account. Note that the person 
who doesn’t have an account in Autodesk can only view the fi le. 

When you choose this button, the Autodesk-Sign In window will be displayed. Now, you 
can Sign In to upload or download documents or fi les.

File name Edit Box
To save your work, enter the name of the drawing in the File name edit box by typing the 
fi le name or selecting it from the drop-down list. If you select the fi le name, it automatically 
appears in the File name edit box. If you have already assigned a name to the drawing, the 
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current drawing name is taken as the default name. If the drawing is unnamed, the default 
name Drawing1 is displayed in the File name edit box. You can also choose the down arrow 
located on the right of the edit box to display the names of the previously saved drawings 
and choose a name here.

Files of type Drop-down List
The Files of type drop-down list (Figure 1-37) is used to specify the drawing format in which 
you want to save the fi le. For example, to save the fi le as an AutoCAD 2004 drawing fi le, select 
AutoCAD 2004/LT2004 Drawing (*.dwg) from the drop-down list.

Figure 1-37  The Files of type drop-down list

Save in Drop-down List
The current drive and path information is listed in the Save in drop-down list. AutoCAD 
will initially save the drawing in the default folder, but if you want to save the drawing in a 
different folder, you have to specify the path. For example, to save the present drawing as 
house in the C1 folder, choose the arrow button in the Save in drop-down list to display the 
drop-down list. Select C: from the drop-down list; all folders in the C drive will be listed in 
the File list box. Double-click on the C1 folder, if it is already listed there or create a folder 
C1 by choosing the Create New Folder button. Select house from the list, if it is already listed 
there, or enter it in the File name edit box and then choose the Save button. Your drawing 
(house) will be saved in the C1 folder (C:\C1\house.dwg). Similarly, to save the drawing in the 
D drive, select D: in the Save in drop-down list.

Tip
The fi le name you enter to save a drawing should match its contents. This helps you to 
remember the drawing details and make it easier to refer to them later. Also, the fi le name can 
be 255 characters long and can contain spaces and punctuation marks.

Views drop-down list
The Views drop-down list has the options for the type of listing of fi les

Figure 1-38  The Views 
drop-down list

 
and displaying the preview images (Figure 1-38).

 
List, Details, and Thumbnails Options
If you choose the Details option, it will display the detailed 
information about the fi les (size, type, date, and time of modifi cation) 
in the Files list box. In the detailed information, if you click on the 
Name label, the fi les are listed with the names in alphabetical order. If you double-click on the 
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Name label, the fi les will be listed in reverse order. Similarly, if you click on the Size label, the fi les 
are listed according to their size in ascending order. Double-clicking on the Size label  will list the 
fi les in descending order of size. Similarly, you can click on the Type label or the Modifi ed label 
to list the fi les accordingly. If you choose the List option, all fi les present in the current folder will 
be listed in the File list box. If you select the Thumbnails option, the list box displays the preview 
of all the drawings, along with their names displayed at the bottom of the drawing preview.

Create New Folder Button
If you choose the Create New Folder button, AutoCAD creates a new folder under 
the name New Folder. The new folder is displayed in the File list box. You can accept 
the name or change it to your requirement. You can also use the ALT+5 keys to create 
a new folder.

Up one level Button
The Up one level button displays the folders that are up by one level. For example, 
if you are in the Sample subfolder of the AutoCAD 2015 folder, then choosing the 
Up one level button will take you to the AutoCAD 2015 folder. You can also use the 
ALT+2 keys to do the same.

Search the Web
It displays the Browse the Web dialog box that enables you to access and store AutoCAD 
fi les on the Internet. You can also use the ALT+3 keys to browse the Web when this 
dialog box is available on the screen.

Tools drop-down list                             
The Tools drop-down list (Figure 1-39) has an option for

Figure 1-39  The Tools drop-down 
list

 
adding or modifying the FTP sites. These sites can then 
be browsed from the FTP shortcut in the Places list. The 
Add Current Folder to Places and Add to Favorites 
options add the folder displayed in the Save in edit box 
to the Places list or to the Favorites folder. The Options 
button displays the Saveas Options dialog box where you 
can save the proxy images of the custom objects. It has 
the DWG Options and DXF Options tabs. The Security Options button displays the 
Security Options dialog box, which is used to confi gure the security options of the drawing.

 AUTOMATIC TIMED SAVE
AutoCAD allows you to save your work automatically at specifi c intervals. To change the time 
intervals, you can specify the intervals duration in minutes in the Minutes between saves 
text box in the File Safety Precautions area in the Options dialog box (Open and Save 
tab). This dialog box can be invoked by choosing the Options button from the Application 
Menu. Depending on the power supply, hardware, and type of drawings, you should decide 
on an appropriate time and assign it to this variable. AutoCAD saves the drawing with the fi le 
extension .sv$. You can also change the time interval by using the SAVETIME system variable. 
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Tip
Although the automatic save feature saves your drawing after a certain time interval, you 
should not completely depend on it because the procedure for converting the ac$ fi le into a 
drawing fi le is cumbersome. Therefore, it is recommended that you save your fi les regularly 
using the QSAVE or SAVEAS commands.

CREATING  BACKUP FILES
If the drawing fi le already exists and you use Save or Save As tool to update the current 
drawing, AutoCAD creates a backup fi le. AutoCAD takes the previous copy of the drawing 
and changes it from a fi le type .dwg to .bak, and the updated drawing is saved as a drawing 
fi le with the .dwg extension. For example, if the name of the drawing is myproj.dwg, AutoCAD 
will change it to myproj.bak and save the current drawing as myproj.dwg.

Changing Automatic Timed Saved and Backup Files into 
AutoCAD Format 
Sometimes, you may need to change the automatic timed saved and backup fi les into 
AutoCAD format. To change a backup fi le into AutoCAD format, open the folder, in which 
you have saved the backup or the automatic timed saved drawing using Computer or 
Windows Explorer. Choose the Organize > Folder and search options from the menu bar 
to invoke the Folder Options dialog box. Choose the View tab and under the Advanced 
settings area, and clear the Hide extensions for known fi le types text box, if selected. Exit 
the dialog box. Rename the automatic saved drawing or the backup fi le with a different name 
and also change the extension of the drawing from .sv$ or .bak to .dwg. 

Using the  Drawing Recovery Manager to Recover Files
The files that are saved automatically can also be retrieved by using the DRAWING 
RECOVERY MANAGER. You can open the DRAWING RECOVERY MANAGER again by 
choosing Drawing Utilities > Open the Drawing Recovery Manager from the Application 
Menu or by entering DRAWINGRECOVERY at the Command prompt.`

If the automatic save operation is performed in a drawing and the system crashes accidentally, 
the next time you run AutoCAD, the Drawing Recovery message box will be displayed, as 
shown in Figure 1-40. The message box informs you that the program unexpectedly failed and 
you can open the most suitable among the backup fi les created by AutoCAD. Choose the Close 
button from the Drawing Recovery message box; the DRAWING RECOVERY MANAGER 
is displayed on the left of the drawing area, as shown in Figure 1-41. 

The Backup Files rollout lists the original fi les, the backup fi les, and the automatically saved 
fi les. Select a fi le; its preview will be displayed in the Preview rollout. Also, the information 
corresponding to the selected fi le will be displayed in the Details rollout. To open a backup 
fi le, double-click on its name in the Backup Files rollout. Alternatively, right-click on the fi le 
name and then choose Open from the shortcut menu. It is recommended that you save the 
backup fi le at the desired location before you start working on it.
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Figure 1-40  The  Drawing Recovery message box Figure 1-41  The DRAWING 
RECOVERY MANAGER

CLOSING A DRAWING
You can close the current drawing fi le without actually quitting AutoCAD by choosing Close > 
Current Drawing from the Application Menu or by entering CLOSE at the Command prompt. 
If multiple drawing fi les are opened, choose Close > All Drawings from the Application 
Menu. If you have not saved the drawing after making the last changes to it and you invoke 
the CLOSE command, AutoCAD displays a dialog box that allows you to save the drawing 
before closing. This box gives you an option to discard the current drawing or the changes 
made to it. It also gives you an option to cancel the command. After closing the drawing, you 
are still in AutoCAD from where you can open a new or an already saved drawing fi le. You 
can also use the close button (X) of the drawing area to close the drawing. 

OPENING AN EXISTING DRAWING
  Application Menu: Open > Drawing Quick Access Toolbar:  Open 
  Menu Bar:  File > Open  Command:    OPEN  

You can open an existing drawing fi le that has been saved previously. There are three methods  
that can be used to open a drawing fi le: by using the Select File dialog box, by using the Create 
New Drawing dialog box, and by dragging and dropping.
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Opening an Existing Drawing Using the Select File Dialog 
Box

If you are already in the drawing editor and you want to open a drawing fi le, choose 
the Open tool from the Quick Access Toolbar; the Select File dialog box will be 
displayed, see Figure 1-42. You can select the drawing to be opened using this dialog 

box. This dialog box is similar to the standard dialog boxes. You can choose the fi le you want 
to open from the folder in which it is stored. You can change the folder from the Look in 
drop-down list. You can then select the name of the drawing from the list box or you can enter 
the name of the drawing fi le you want to open in the File name edit box. After selecting the 
drawing fi le, you can choose the Open button to open the fi le. Here, you can choose Drawing1 
from the list and then choose the Open button to open the drawing.

  
When you select a fi le name, its image is displayed in the Preview box. If you are not sure 
about the fi le name of a particular drawing but know the contents, you can select the fi le names 
and look for the particular drawing in the Preview box. You can also change the fi le type by 
selecting it in the Files of type drop-down list. Apart from the dwg fi les, you can open the dwt 
(template) fi les or the dxf fi les. You have all the standard icons in the Places list that can be 
used to open drawing fi les from different locations. The Open button has a drop-down list, 
as shown in Figure 1-43. You can choose a method for opening the fi le using this drop-down 
list. These methods are discussed next.

Figure 1-42  The  Select File dialog box
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Open Read-Only
To view a drawing without altering it, you must select the

Figure 1-43  The Open 
drop-down list

 
Open Read-Only option from the drop-down list. In other 
words, read only protects the drawing fi le from changes. 
AutoCAD does not prevent you from editing the drawing, but 
if you try to save the opened drawing with the original fi le 
name, AutoCAD warns you that the drawing fi le is write 
protected. However, you can save the edited drawing to a fi le 
with a different file name using the Save Drawing as 
dialog box. This way you can preserve your drawing.

Partial Open
The Partial Open option enables you to open only a selected view or a selected layer of a 
selected drawing. This option can be used to edit small portions of a complicated drawing 
and then save it with the complete drawing. When you select the Partial Open option from 
the Open drop-down list, the Partial Open dialog box (Figure 1-44) is displayed, which 
contains different views and layers of the selected drawing. When you select a check box for a  
layer and then choose the Open button, only the objects drawn in that particular layer for the 
drawing are displayed in the new drawing window. You can make the changes and then save it. 
For example, in the C:/Program Files/Autodesk/AutoCAD 2015 folder, double-click on the Sample 
folder and then Mechanical Sample and select Mechanical - Xref  from the list. Now, choose the 
down arrow on the right of the Open button to display the drop-down list and choose Partial 
Open. All the views and layers of this drawing are displayed in the Partial Open dialog box
(click Yes, if AutoCAD prompts for read-only files). Select the check box on the 
right of the layer that you want to open. When you choose the Open button, 
after selecting the layers, only the selected layers of the drawing will be opened. 

Figure 1-44  The  Partial Open dialog box
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Note
The concept of layers is discussed in Chapter 4, Working with Drawing Aids.

Loading Additional Objects to Partially Opened Drawing
Once you have opened a part of a drawing and made the necessary changes, you may want 
to load additional objects or layers on the existing ones. This can be done by using the 
 PARTIALOAD command, which can be invoked by choosing File > Partial Load from the 
menu bar or by entering PARTIALOAD at the Command prompt. This command displays 
the Partial Load dialog box, which is similar to the Partial Open dialog box. You can choose 
another layer and the objects drawn in it will be added to the partially loaded drawing.

Note
The 1. Partial Load option is not enabled in the File menu unless a drawing is partially 

    opened. 
Loading a drawing partially is a good practice when you are working with objects on a specifi c 2. 

    layer in a large complicated drawing. 
In the 3. Select File dialog box, the preview of a drawing which was partially opened and then 

    saved is not displayed. 

  Tip
If a drawing was partially opened and saved previously, it is possible to open it again 
with the same layers and views. AutoCAD remembers the settings so that while opening a 
previously partially opened drawing, a dialog box is displayed prompting for an option to 
fully open it or restore the partially opened drawing.

Select Initial View 
A view is defi ned as the way you look at an object. Select the Select Initial View check box if you 
want to load a specifi c view initially when AutoCAD loads the drawing. This option will work, 
if the drawing has saved views. This is generally used while working on a large complicated 
drawing, in which you want to work on a particular portion of the drawing. You can save that 
particular portion as a view and then select it to open the drawing next time. You can save a 
desired view, by using AutoCAD’s VIEW command (see “Creating Views” topic, Chapter 6). 
If the drawing has no saved views, selecting this option will load the last view. If you select 
the Select Initial View check box and then the OK button, AutoCAD will display the Select 
Initial View dialog box. You can select the view name from this dialog box, and AutoCAD will 
load the drawing with the selected view displayed.

Tip
Apart from opening a drawing from the Startup dialog box or the Select File dialog 
box, you can also open a drawing from the Application Menu. By default, the Recent 
Documents option is selected in the Application Menu. As a result the most recently opened 
drawings will be displayed and you can open the required fi le from it.

It is possible to open an AutoCAD 2000 drawing in AutoCAD 2015. However, when you save 
this drawing, it is automatically converted and saved as an AutoCAD 2015 drawing fi le. 
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Opening an Existing Drawing Using the Startup Dialog Box
If you have confi gured the settings to show the Startup dialog box by setting the STARTUP 
system variable value as 1, the Startup dialog box will be displayed every time you start a new 
AutoCAD session. The fi rst button in this dialog box is the Open a Drawing button. When you 
choose this button, a list of the recently opened drawings will be displayed for you to select 
from, see Figure 1-45. Note that this button is activated only when this dialog box is displayed 
by default on starting a new session of AutoCAD. The Browse button displays the Select File 
dialog box, which allows you to browse to another fi le. 

Figure 1-45  List of the recently opened drawings

Note
The display of the dialog boxes related to opening and saving drawings will be disabled, if 
the STARTUP and the FILEDIA system variables are set to 0. The initial value of these 
variables is 1.

Opening an Existing Drawing Using the Drag and Drop 
Method
You can also open an existing drawing in AutoCAD by dragging it from the Window Explorer 
and dropping it into AutoCAD. If you drop the selected drawing in the drawing area, the 
drawing will be inserted as a block and as a result, you cannot modify it. But, if you drag 
the drawing from the Window Explorer and drop it anywhere other than the drawing area, 
AutoCAD opens the selected drawing. 

QUITTING AutoCAD
You can exit the AutoCAD program by using the EXIT or QUIT commands. Even if you have 
an active command, you can choose Exit Autodesk AutoCAD 2015 from the Application 
Menu to quit the AutoCAD program. In case the drawing has not been saved, it allows you to 
save the work fi rst through a dialog box. Note that if you choose No in this dialog box, all the 
changes made in the current list till the last save will be lost. You can also use the Close button 
(X) of the main AutoCAD window (present in the title bar) to end the AutoCAD session. 
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CREATING AND MANAGING WORKSPACES
A workspace is defi ned as a customized arrangement of Ribbon, toolbars, menus, and 
window palettes in the AutoCAD environment. You can create your own workspaces, in which 
only specifi ed toolbars, menus, and palettes are available. When you start AutoCAD, by 
default, the Drafting & Annotation workspace is the current workspace. You can select any 
other predefi ned workspace from the Workspace drop-down list available in the title bar, next 
to the Quick Access Toolbar, see Figure 1-46. You can also set the workspace from the fl yout 
that will be displayed on choosing the Workspace Switching button on the Status Bar or by 
choosing the required workspace from the Quick Access Toolbar. 

Figure 1-46  The predefi ned workspaces

Creating a New Workspace
To create a new workspace, customize the Ribbon and invoke the palettes to be displayed in 
the new workspace. Next, select the Save Current As option from the Workspace drop-down 
list in the titlebar; the Save Workspace dialog box will be displayed, as shown in Figure 1-47. 
Enter the name of the new workspace in the Name edit box and choose the Save button. 

The new workspace is now the current workspace and is added to the drop-down list in the 
title bar. Likewise, you can create workspaces based on your requirement and switch from 
one workspace to the other by selecting the name from the drop-down list in the Workspaces 
toolbar or the drop-down list in the title bar. 

Figure 1-47  The Save Workspace dialog box

Modifying the Workspace Settings
AutoCAD allows you to modify the workspace settings. To do so, select the Workspace 
Settings option in the Workspace drop-down list in the title bar; the Workspace Settings 
dialog box will be displayed, as shown in Figure 1-48. All workspaces are listed in the My 
Workspace drop-down list. You can make any of the workspaces as My Workspace by selecting 
it from the My Workspace drop-down list. You can also choose the My Workspace button 
from the Workspaces toolbar to change the current workspace to the one that was set as My 
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Workspace in the Workspace Settings dialog box. The other options in this dialog box are 
discussed next.

Menu Display and Order Area
The options in this area are used to control the display and the order of display of workspaces 
in the Workspace drop-down list. By default, workspaces are listed in the sequence of their 
creation. To change the order, select a workspace and choose the Move Up or Move Down 
button. To control the display of the workspaces, you can select or clear the check boxes. 
You can also add a separator between workspaces by choosing the Add Separator button. A 
separator is a line that is placed between two workspaces in the Workspace drop-down list in 
the title bar, as shown in Figure 1-49. 

When Switching Workspaces Area
By default, the Do not save changes to workspace radio button is selected in this area. This 
ensures that while switching the workspaces, the changes made in the current workspace 
will not be saved. If you select the Automatically save workspace changes radio button, the 
changes made in the current workspace will be automatically saved when you switch to the 
other workspace.

Figure 1-48  The Workspace Settings dialog box Figure 1-49   The Workspace drop-down 
list after adding separators

AutoCAD  HELP
  Titlebar:  ? > Help Shortcut Key: F1  Command:  HELP or ?  

You can get the on-line help and documentation about the working of AutoCAD 2015 
commands from the Help menu in the title bar, see Figure 1-50. You can also access 
the Help menu by pressing the F1 function key. An InfoCenter bar is displayed at the 

top right corner in the title bar that will help you sign into the Autodesk Online services, see 
Figure 1-51. You can also access AutoCAD community by using certain keywords. Some 
important options in the Help menu are discussed next.
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Figure 1-51  The InfoCenter bar Figure 1-50  The Help menu

In AutoCAD 2015, you can refi ne your search by using the options available in the drop-down 
list in the Autodesk AutoCAD 2015 - Help window, as shown in Figure 1-52. This drop-down 
list is available below the Search edit box. The options available in the drop-down list are 
All Contents, User, Developer, and Administrator. By using these options, you can fi lter 
the information for your search as a User, Developer, and Administrator point of view. For 
example, if you select the User option from the drop-down list; all the information needed 
for the user point of view respective to the searched command will be displayed.  

Figure 1-52  The Autodesk AutoCAD 2015 - Help window

You can further refi ne your search by fi ltering the required information using the check 
boxes available in the fl yout displayed on choosing the Set Filter button available next to the 
drop-down list, refer to Figure 1-53. For example, if you want to fi nd information only about 
system variables of a command, you need to choose the System Variables check box from this 
fl yout. On doing so, only the information about system variables of that particular command 
will be displayed.
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Figure 1-53  The fl yout displayed on choosing the Set Filter button

Download Offl ine Help
This option is used to read the help contents and topics, when the user has no internet access. 
(AutoCAD prompts you to download 194 MB File, user can save this fi le and then use it later 
on.) 

Send Feedback
You can also directly contact Autodesk regarding support, discussion, or any consulting work. 
When you click on this option, a page will be displayed asking for the required queries and 
contact details. After entering the contact details, you can press Submit to exit.

Download Language Packs
Once AutoCAD is installed, you can install the AutoCAD language pack to run AutoCAD in 
your preferred language by choosing this option.

Customer Involvement Program
This option is used to share your confi guration information and uses of Autodesk products with 
Autodesk. The collected information is used by Autodesk for the improvement of Autodesk 
softwares.

Desktop Analytics
When you choose this option, the Desktop Analytics Program dialog box will be displayed. 
In the dialog box, Autodesk will prompt you to participate in a programme to simply collect 
nonpersonal product usage information from the Autodesk software.
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About Autodesk AutoCAD 2015
This option gives you information about the Release, Serial number, Licensed to, and also the 
legal description about AutoCAD.

Autodesk Cloud
The Autodesk Cloud is used to save and share the documents online. Using this technology, 
you can also view other documents available on Autodesk Cloud. To share a document, you 
fi rst need to login to the Autodesk account. To do so, select the Sign In to Autodesk 360 
option from the Sign In fl yout in the InfoCenter bar; the Autodesk-Sign In window will 
be displayed. Now, login to the account using the Autodesk ID and password; your account 
name will be displayed in place of Sign In in the Sign In fl yout. Next, select the Autodesk 
360 option from the Sign In fl yout; the Autodesk Cloud Documents window will be 
displayed in the default browser, refer to Figure 1-54. Next, select the Getting Started option 
from the Help drop-down on the top right corner of the window and then choose the Get 
Started Now option from the left pane of the window to start with Autodesk Cloud.

To upload a document on Autodesk Cloud, choose the Upload Document button from 
the Start area; the Upload Documents window will be displayed. Make sure that the Get 
Started Now tab is selected in the left pane. Browse to the document by choosing the Select 
Documents button or you can drag and drop the document in the box displayed in the Upload 
Documents window. Now, choose the Upload Now button; the document will be uploaded 
in the My cloud documents area, as shown in Figure 1-55. Now, you can share the document 
in the Autodesk Cloud by selecting suitable options. There are two types of options used to 
share a document- Private Sharing and Public Sharing. These options are available in the 
Actions drop-down of the Share fl yout. If you choose the Private Sharing option, you can 
restrict the document’s access to the limited users of the Autodesk Cloud. But, if you choose 
Public Sharing, anyone can access the document. 

Figure 1-54  The Autodesk Cloud Documents window
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Figure 1-55  The document added in Autodesk cloud

Autodesk Exchange Apps
Autodesk Exchange Apps helps you to download various applications for AutoCAD, get 
connected to the AutoCAD network, share information and designs, and so on. You can 
download the AutoCAD apps from the Featured Apps panel of the Featured Apps tab in the 
Ribbon, refer to Figure 1-56. To download the AutoCAD apps, choose the required apps from 
the Featured Apps panel of the Feature Apps tab; the default browser will open with icons of 
apps to be downloaded, as shown in Figure 1-57. Now, you can download the app. 

Figure 1-56  The Feature Apps panel of the Feature Apps tab in the Ribbon



 1-44 AutoCAD 2015:  A Problem-Solving  Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 1-57  The Autodesk Exchange Apps window open with icons of apps to be 
downloaded

You can also download the apps other than the apps available in the Featured Apps panel. 
To do so, choose the Connect to Exchange button from the Exchange panel of the Featured 
Apps tab; the AutoCAD Exchange Apps window will be displayed, as shown in Figure 1-58. 
Now, you can download the required apps from the window. Some of the apps are paid and 
some of them are free to download. You can download various Autodesk apps such as UDS 
Tools Blocks, Bronze Valves 3D, and so on from this page. You can also publish your own 
Autodesk products for other users of Autodesk 360. 

Figure 1-58  The Autodesk Exchange Apps window
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In addition to AutoCAD apps, you can also download apps for software other than AutoCAD 
such as Autodesk Alias, Revit, Simulation, and so on. You can also search for the apps by 
entering the name of the app in the Search Exchange Apps text box. 

After downloading and installing the apps, the apps will be available in the Plug-ins tab. You 
can choose the required app to work with. Also, you can manage the apps by choosing the 
Exchange App Manager button available in the App Manager panel of the Plug-ins tab. To 
manage the app, choose the Exchange App Manager button; the AutoCAD Exchange App 
Manager dialog box will be displayed. In the dialog box, all the installed apps are displayed. 
To manage a particular app, right-click on it; a shortcut menu will be displayed, as shown in 
Figure 1-59. Now, you can choose the required option to manage it.  

Figure 1-59  The Autodesk Exchange App Manager dialog box

 

Design Feed 
In AutoCAD 2015, the DESIGN FEED palette is used to share a document with the people 
who have Autodesk 360 account. It can be invoked by choosing the Design Feed button from 
AutoCAD Online panel in the Autodesk 360 tab of the Ribbon. On choosing this button, the 
DESIGN FEED palette will be displayed, refer to Figure 1-60. Next, click on the Login link 
in this palette; the Autodesk Sign-In window will be displayed. Enter your Autodesk ID and 
password to sign in. Now, save the drawing fi le in Autodesk 360 by clicking on the save link 
in the dialog box (which will be displayed after clicking on Invite People link), all the options 
in the DESIGN FEED palette will be activated, refer to Figure 1-61. Also, the drawing fi le will 
be saved in Autodesk 360. The options available in this palette are discussed next.
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Figure 1-60  The DESIGN FEED 
palette

Figure 1-61  The DESIGN FEED 
palette with all options activated

Create a new post Text Box
This text box is used to enter a message for the post. You can enter any query related to any 
specifi c area or point in a drawing by using this text box and then share it. Note that everyone 
can view your post but only the Autodesk 360 registered users can reply to your post.

Associate this post to an area in the drawing
This button is used to associate the post entered in the Create a new post text box to the 
desired area in a drawing. To post a message/query associated with a specifi c area in the 
drawing, choose this button and then specify the required area by using the cross selection 
method; a blue dashed rectangle enclosing the selected portion along with the design feed 
bubble is displayed in the drawing area, refer to Figure 1-62. Once the area has been specifi ed 
for the post, you need to post it so that other users of Autodesk 360 account working on the 
same drawing, can view and reply to your post. To post the text, choose the Post button from 
the DESIGN FEED palette. Figure 1-63 shows a drawing with the added post. Note that in 
the drawing area, every post is represented with its serial number assigned in the DESIGN 
FEED palette. 

Associate this post to a point in the drawing
This button is used to associate the post entered in the Create a new post text box to the desired 
point in the drawing. To do so, choose this button and then specify the point by clicking the 
left mouse button in the drawing area; the post will be assigned to the specifi ed point and a 
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design feed bubble will be displayed in the drawing area. Once the point has been specifi ed for 
the post, you need to publish the post so that other users of Autodesk 360 account working on 
the same drawing can get updated with the post. To publish the post, choose the Post button 
from the DESIGN FEED palette. Note that in the drawing area, every post is represented 
with its serial number assigned in the DESIGN FEED palette.

Figure 1-62  Drawing with enclosed area and design feed bubble

Figure 1-63  Post with the number assigned in the Design Feed palette
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Tag in this post
This button is used to tag the people with whom you want to share the post through 
Autodesk 360. To add people to the sharing list, you need to choose this button before posting 
the message. On doing so, the Add People button will be displayed in the DESIGN FEED 
palette. If you already have the connections with whom you want to share the post, select the 
check boxes adjacent to their E-mail ids from the DESIGN FEED palette and then choose 
the Post button.

You can also share the post with the new connections that are not listed in the DESIGN FEED 
palette, by choosing the Add People button. To do so, choose the Add People button; the 
Autodesk 360 dialog box will be displayed, refer to Figure 1-64. To add people in sharing list, 
enter their E-mail ids in the Connection text box and then choose the Add button adjacent to 
the text box; the specifi ed E-mail ids will be listed in the E-mail / Name list box. Next, choose 
the Save & Invite button from the dialog box; the Autodesk 360 message box will be displayed 
with the message that E-mail invitation has been sent. Choose the OK button from this message 
box; the E-mail id will be added in your connections and will be displayed in the DESIGN 
FEED palette with the check box selected by default. Choose the Post button to publish the post.
 

Figure 1-64  The Autodesk 360 dialog box

Attach image(s) to this post
This button is used to attach images to your posts. Using this button, you can attach different 
image fi le formats such as BMP, DIB, JPEG, JPG, JPE, JFIF, JIF, GIF, TIF, TIFF, and PNG to 
your post. To attach an image with the post, choose the Attach image(s) to this post button; 
the Select File dialog box will be displayed. Browse to the desired fi le, select it and then choose 
the Open button from the dialog box; the selected image fi le will be attached. Now, you can 
publish your post with the attached image fi le.
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Design Feed Settings
The options in this drop-down list are used to display and hide the design feed bubbles 
and resolved posts from the drawing. These options are discussed next.

Hide All
This option is used to hide all design feed bubbles and posts attached in the drawing area. 

Show Bubbles
This option is used to display the design feed bubbles in the drawing.  

Note
When you click on the bubble, the post will be displayed along with the blue colored dashed 
rectangle in the drawing area. Note that if you press the ESC key, the post gets disappeared 
but the bubble remains available.

Show Extended bubbles
This option is used to display the post with the preview of the message in the drawing area 
along with its bubble. Note that if you press the ESC key, the preview of the post remains 
available in the drawing area.

Show Resolved
This check box is used to toggle the display of resolved posts and their respective design feed 
bubbles in the drawing area. 

BIM 360
In AutoCAD 2015, BIM 360 tab is introduced in the Ribbon, as shown in Figure1-65. 
This tab provides tools for sharing models amongst the users of Autodesk BIM 360 
Glue online service and also allows to view the clash results in the models.

Figure 1-65  BIM 360 tab in the Ribbon

ADDITIONAL HELP RESOURCES
1. You can get help for a command while working by pressing the F1 key. The help html 

containing information about the command is displayed. You can exit the dialog box and 
continue with the command.

2. You can get help about a dialog box by choosing the Help button in that dialog box.

3. Autodesk has provided several resources that you can use to get assistance with your 
AutoCAD questions. The following is a list of some of the resources:



 1-50 AutoCAD 2015:  A Problem-Solving  Approach
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

 a. Autodesk web site http://www.autodesk.com
 b.  AutoCAD Technical Assistance website http://www.autodesk.com/support
 c. AutoCAD Discussion Groups website http://discussion.autodesk.com/index.jspa

4. You can also get help by contacting us at techsupport@cadcim.com and sales@cadcim.com.

5. You can download AutoCAD drawings, programs, and special topics by registering yourself 
at the faculty’s website by visiting: http://cadcim.com/Registration.aspx

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. You can press the F3 key to display the AutoCAD text window, which displays the previous 
commands and prompts. (T/F)

2. If you do not have internet connection, you cannot access the Help fi les. (T/F)

3. If a drawing was partially opened and saved previously, it is not possible to open it again 
with the same layers and views. (T/F)

4. If the current drawing is unnamed and you save the drawing for the fi rst time, the Save 
tool will prompt you to enter the fi le name in the Save Drawing As dialog box. (T/F) 

5. The ________ button is used to set the performance of the software at an acceptable 
level.

6. If the __________ variable is set to 1 and you invoke the New tool, the Create New Drawing 
dialog box will be displayed. 

7. If you want to work on a drawing without altering the original drawing, you must select 
the __________ option from the Open drop-down list in the Select File dialog box.

8. The __________ option enables you to open only a selected view or a selected layer of the 
current drawing.

9. You can use the __________ command to close the current drawing fi le without actually 
quitting AutoCAD.

10. The __________system variable can be used to change the time interval for automatic 
save.

11. By using the__________button, you can fi nd information about a command on internet.

12. You can enable or disable the functions such as AutoComplete, AutoCorrect, and so on        
by using the options available in the__________dialog box.
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13. The__________button is used to toggle the display of the File tab bar which displays all       
opened fi les. 

14. The __________palette is used to share a document with the people who have Autodesk 
360 account.

 Review Questions 
Answer the following questions:

1. The shortcut menu invoked by right-clicking in the command window displays the most 
recently used commands and some of the window options such as Copy, Paste, and so 
on. (T/F)

2. You can open an AutoCAD 2002 drawing in AutoCAD 2015. (T/F)

3. The fi le name that you enter to save a drawing in the Save Drawing As dialog box can 
be 255 characters long, but cannot contain spaces and punctuation marks. (T/F)

4. You can close a drawing in AutoCAD even if a command is active. (T/F)

5. Which of the following combination of keys should be pressed to hide all toolbars displayed 
on the screen?

  (a) CTRL+3   (b) CTRL+0
  (c) CTRL+5   (d) CTRL+2

6. Which of the following combination of keys should be pressed to turn on or off the display 
of the Tool Palettes window?

  (a) CTRL+3   (b) CTRL+0
  (c) CTRL+5   (d) CTRL+2

7. Which of the following commands is used to exit the AutoCAD program? 

  (a) QUIT   (b) END
  (c) CLOSE   (d) None of these

8. Which of the following options in the Startup dialog box is used to set the initial drawing 
settings before actually starting a new drawing?  

 
  (a) Start from Scratch  (b) Use a Template
  (c) Use a Wizard   (d) None  of these
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9. When you choose Save from the File menu or choose the Save tool from the Quick Access 
Toolbar, which of the following commands is invoked?

  (a) SAVE   (b) LSAVE
  (c) QSAVE   (d) SAVEAS

10. AutoCAD has provided __________ as an easy and convenient way of placing and sharing 
hatch patterns and blocks in the current drawing.

11. By default, the angles are positive if measured in the __________ direction.

12. The __________check box is used to toggle the display of resolved posts.

 Answers to Self-Evaluation Test 
1. F, 2. F, 3. F, 4. T, 5. Hardware Acceleration, 6. STARTUP, 7. Open Read-Only, 
8. Partial Open, 9. CLOSE, 10. SAVETIME, 11. Search on Internet, 12. Input Search 
Options, 13. File Tabs, 14. Design Feed


