
Chapter 2

Polygon Modeling

 Learning Objectives 
After completing this chapter, you will be able to:
• Create polygon primitives
• Edit polygon primitives
• Modify the components of polygon primitives
• Create a complex model using polygon primitives
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INTRODUCTION
In this chapter, you will learn to create and edit polygon shapes using polygon modeling 
techniques. A polygon is made up of different closed planar shapes having straight sides. 
The most commonly used shapes in 3D polygons are triangles and quadrilaterals. These 
shapes are formed by vertices, edges, and faces. An edge is a straight line formed by joining 
two vertices. In a polygon, three vertices join to each other by three edges to form a triangle 
and four vertices join to each other by four edges to form a quadrilateral. By modifying faces, 
edges, and vertices of an object, you can create a polygon model as per your requirement.

POLYGON PRIMITIVES
In Maya, polygon primitives are classified into various objects. These objects are grouped under 
Polygon Primitives in the menubar. The method of creating different polygon primitives is 
discussed next.

Creating a Sphere
Menubar:	 Create > Polygon Primitives > Sphere   
Shelf:		  Polygons > Polygon Sphere 

A sphere is a solid object in which every point on its surface is 
equidistant from its centre, as shown in Figure 2-1. The 
sphere can be created dynamically by entering the values 
using the keyboard. Both the methods are discussed next.

Creating a Sphere Dynamically
To create a sphere dynamically, choose Create > Polygon Primitives > Sphere from the 
menubar; you will be prompted to drag the cursor on the grid to draw the sphere in the 
viewport. Press and hold the left mouse button, and drag the cursor up or down to define the 
radius of the sphere. Now, release the left mouse button to get the desired radius; the sphere 
will be created in all viewports and is visible in the Smooth Shade all mode. Press the numeric 
key 4 to change the display to Wireframe mode.

Note
By default, polygon primitives are displayed in the Smooth Shade all mode. Press 4 to change 
the display to Wireframe. Alternatively, choose Shading > Wireframe from the Panel menu. 
You can also switch back to the Smooth Shade all mode by pressing 5 or by choosing Shading > 
Smooth Shade all from the Panel menu.

Creating a Sphere by Using the Keyboard
To create a sphere by using the keyboard, choose Create > Polygon Primitives > 
Sphere > Option Box from the menubar; the Tool Settings (Polygon Sphere Tool) window 
will be displayed, as shown in Figure 2-2. In this window, set the properties of the sphere 
using the keyboard and then click in the viewport; the sphere will be created in all viewports. 
Choose Reset Tool at the top of the Tool Settings (Polygon Sphere Tool) window to reset the 
settings of the sphere while creating a new sphere.

Figure 2-1  A polygon sphere
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Figure 2-2  The Tool Settings (Polygon Sphere Tool) window

Creating a Cube
Menubar:	 Create > Polygon Primitives > Cube
Shelf:		  Polygons > Polygon Cube 

A cube is a three-dimensional shape with six sides or rectangular 

Figure 2-3  A polygon cube

faces, as shown in Figure 2-3. A cube can be created dynamically 
or by entering values using the keyboard. Both these methods 
are discussed next.

Creating a Cube Dynamically
To create a cube dynamically, choose Create > Polygon Primitives > Cube from the menubar; 
you will be prompted to drag the cursor on the grid to draw the cube in the viewport. Press 
and hold the left mouse button, and drag the cursor on the grid to define the base of the 
cube. Next, release the left mouse button to get the desired base. Now, press and hold the left 
mouse button again and drag the cursor up to set the height of the cube and then release the 
left mouse button; the cube will be created in all the viewports.

Creating a Cube by Using the Keyboard
To create a cube by the using the keyboard, choose Create > Polygon Primitives > Cube > 
Option Box from the menubar; the Tool Settings (Polygon Cube Tool) window will be 
displayed, as shown in Figure 2-4. In this window, set the properties of the cube by using the 
keyboard and then click in the viewport; the cube will be created in all viewports. Choose 
Reset Tool at the top of the Tool Settings (Polygon Cube Tool) window to reset the settings 
of the cube while creating a new cube. 
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Figure 2-4  The Tool Settings (Polygon Cube Tool) window

Creating a Prism
Menubar:	 Create > Polygon Primitives > Prism

A prism is a polyhedron that has two polygonal faces lying in 
parallel planes as bases and the other faces as parallelograms, 
as shown in Figure 2-5. You can create a prism dynamically or 
by using the keyboard. Both these methods are discussed next.

Creating a Prism Dynamically
To create a prism dynamically, choose Create > Polygon Primitives > Prism from the 
menubar; you will be prompted to drag the cursor on the grid to draw the prism in 
the viewport. Press and hold the left mouse button and drag the cursor; the base of the 
prism is created. Now, release the left mouse button to get the desired base. Again, press 
and hold the left mouse button and drag the cursor up to set the height of the prism. 
Next, release the left mouse button; the polygon prism will be created in all viewports.

Creating a Prism by Using the Keyboard 
To create a prism by using the keyboard, choose Create > Polygon Primitives > Prism > 
Option Box from the menubar; the Tool Settings (Polygon Prism Tool) window will be 
displayed, as shown in Figure 2-6. In this window, set the properties of the prism by using the 
keyboard and then click in the viewport; the prism will be created in all viewports. Choose 
the Reset Tool button at the top of the Tool Settings (Polygon Prism Tool) window to reset 
the settings of the prism while creating a new prism.

Figure 2-5  A polygon prism
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Figure 2-6  The Tool Settings (Polygon Prism Tool) window 

Modifying the Name and other Parameters of a Prism
You can modify the name and other parameters of a prism. To do

Figure 2-7  Channel 
Box/Layer Editor

 
so, select the prism; the Attribute Editor is displayed on the right 
of the viewport. Next, choose the Channel Box / Layer Editor tab; 
the Channel Box / Layer Editor will be displayed. Now, click on 
the pPrism1 label in the Channel Box / Layer Editor; the pPrism1 
label is converted into an edit box. Next, enter the desired name 
in the edit box and press ENTER. To modify the properties of the 
prism, expand the polyPrism1 node in the INPUTS area; various 
options will be displayed. Enter the required values in the edit 
boxes; the changes will be dynamically reflected on the prism in 
the viewport. Alternatively, select the label of the parameter of the 
prism that you want to change; the corresponding label of the 
parameter will be highlighted in the Channel Box. Now, press and 
hold the middle mouse button and drag the cursor horizontally in 
the viewport to change that particular value of the corresponding parameter. 

Creating a Pyramid
Menubar:	 Create > Polygon Primitives > Pyramid
Shelf:       	 Polygons > Polygon Pyramid 

A pyramid is a geometric shape with a polygonal base and a point called 

Figure 2-8  A polygon 
pyramid

apex. The base and the apex are connected through triangular faces, 
as shown in Figure 2-8. You can create a pyramid dynamically or by 
entering values using the keyboard. Both these methods are discussed 
next. 
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Creating a Pyramid Dynamically
To create a pyramid dynamically, choose Create > Polygon Primitives > Pyramid from the 
menubar; you will be prompted to drag the cursor on the grid to draw the pyramid in the 
viewport. Press and hold the left mouse button, and drag the cursor up or down to define the 
shape of the pyramid, and then release the left mouse button; the pyramid will be created in 
all viewports. 

Creating a Pyramid by Using the Keyboard
To create a pyramid by using the keyboard, choose Create > Polygon Primitives > 
Pyramid > Option Box from the menubar; the Tool Settings (Polygon Pyramid Tool) 
window will be displayed, as shown in Figure 2-9. In this window, set the properties of the 
pyramid by using the keyboard and then click in the viewport; the pyramid will be created 
in all viewports. Choose Reset Tool at the top of the Tool Settings (Polygon Pyramid Tool) 
window to reset the settings of the pyramid while creating a new pyramid. 

Figure 2-9  The Tool Settings (Polygon Pyramid Tool) window

Creating a Pipe
Menubar:	 Create > Polygon Primitives > Pipe
Shelf:      	 Polygons > Polygon Pipe 

A pipe is similar to a cylinder polygonal shape with thickness,

Figure 2-10  A polygon pipe

as shown in Figure 2-10. You can create a pipe either dynamically 
or by entering values using the keyboard. Both these methods 
are discussed next.

Creating a Pipe Dynamically
To create a pipe dynamically, choose Create > Polygon Primitives > Pipe from the menubar; 
you will be prompted to drag the cursor on the grid to draw the pipe in the viewport. Press and 
hold the left mouse button and drag the cursor; the base of the pipe is created. Next, release the 
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left mouse button to get the desired base. Now, press and hold the left mouse button and drag 
the cursor up to set the height of the pipe. Next, release the left mouse button. Again, press 
and hold the left mouse button to set the thickness of the polygon pipe; the polygon pipe 
will be created in all viewports.  

Creating a Pipe by Using the Keyboard 
To create a pipe by using the keyboard, choose Create > Polygon Primitives > Pipe > Option 
Box from the menubar; the Tool Settings (Polygon Pipe Tool) window will be displayed, as 
shown in Figure 2-11. In this window, set the properties of the pipe by using the keyboard and 
then click in the viewport; the pipe will be created in all viewports. Choose the Reset Tool 
button at the top of the Tool Settings (Polygon Pipe Tool) window to reset the settings of the 
pipe while creating a new pipe. 

Figure 2-11  The Tool Settings (Polygon Pipe Tool) window

 

Creating a Helix
Menubar:	 Create > Polygon Primitives > Helix

A helix is a geometry in three dimensional space that lies on a 
cylinder and subtends a constant angle to a plane perpendicular 
to its axis, as shown in Figure 2-12. You can create a helix 
dynamically or by entering values using the keyboard. Both these 
methods are discussed next. 

Creating a Helix Dynamically
To create a helix dynamically, choose Create > Polygon Primitives > Helix from the menubar; 
you will be prompted to drag the cursor on the grid to draw the helix in the viewport. Press 
and hold the left mouse button and drag the cursor on the grid to define the diameter of the 
helix and then release the left mouse button. Again, press and hold the left mouse button 
and drag the cursor up to set the height of the helix, and then release the left mouse button. 

Figure 2-12  A polygon helix
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Next, press and hold the left mouse button and drag the cursor to set the number of coils in 
the helix and then release the left mouse button. Again, press and hold the left mouse button 
and drag the cursor to set the section radius; the helix will be created in all viewports.

Creating a Helix by Using the Keyboard 
To create a helix by using the keyboard, choose Create > Polygon Primitives > Helix > Option 
Box from the menubar; the Tool Settings (Polygon Helix Tool) window will be displayed, 
as shown in Figure 2-13. In this window, set the properties of the helix by using the keyboard 
and then click in the viewport; the helix will be created in all viewports. Choose Reset Tool 
at the top of the Tool Settings (Polygon Helix Tool) window to reset the settings of the helix 
while creating a new helix. 

Figure 2-13  The Tool Settings (Polygon Helix Tool) window

Tip. By default, the Polygon Helix Tool is not available in the shelf. To add it to the shelf, 
choose the Custom shelf tab from the Shelf. By default, the Custom shelf tab is empty. 
This tab can be used to add tools that are frequently used. Press and hold the SHIFT and 
CTRL keys and choose Create > Polygon Primitives > Helix from the main menubar; 
a helix icon is formed in the Custom shelf tab. Similarly, you can add other tools in the 
Custom shelf tab for quick access.

Creating a Soccer Ball
Menubar:	 Create > Polygon Primitives > Soccer ball 

A soccer ball polygon primitive created in Maya is very much 
similar to a real-world soccer ball, as shown in Figure 2-14. 
A soccer ball is formed by an alternate arrangement of hexagons 
and pentagons. It has total thirty two faces. You can create a 
soccer ball dynamically or by entering values  using the keyboard. 
Both these methods are discussed next.

Figure 2-14  A soccer ball
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Creating a Soccer Ball Dynamically
To create a soccer ball dynamically, choose Create > Polygon Primitives > Soccer Ball from 
the menubar; you will be prompted to drag the cursor on the grid to draw the soccer ball in 
the viewport. Press and hold the left mouse button and drag the cursor on the grid; the soccer 
ball will be created in all viewports. 

Creating a Soccer Ball by Using the Keyboard
To create a soccer ball by using the keyboard, choose Create > Polygon Primitives > Soccer 
Ball > Option Box from the menubar; the Tool Settings (Polygon Soccer Ball Tool) window will 
be displayed, as shown in Figure 2-15. In this window, set the properties of the soccer ball by 
using the keyboard and then click in the viewport; the soccer ball will be created in all the 
viewports. Choose Reset Tool at the top of the Tool Settings (Polygon Soccer Ball Tool) 
window to reset the settings of the soccer ball while creating a new soccer ball.

Figure 2-15  The Tool Settings (Polygon Soccer Ball Tool) window

Creating a Platonic Solid
Menubar:	 Create > Polygon Primitives > Platonic Solids

You can create various types of platonic solids such as tetrahedron, 
octahedron, dodecahedron, and icosehedron. Platonic solids 
have identical faces and its all sides are equal, refer to Figure 
2-16. You can create a platonic solid dynamically or by entering 
values using the keyboard. Both these methods are discussed 
next.

Figure 2-16  A platonic solid
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Creating a Platonic Solid Dynamically
To create a platonic solid dynamically, choose Create > Polygon Primitives > Platonic 
Solids from the menubar; you will be prompted to drag the cursor on the grid to draw the 
platonic solid in the viewport. Press and hold the left mouse button and drag the cursor on 
the grid; the platonic solid will be created in all viewports.

Creating a Platonic Solid by Using the Keyboard 
To create a platonic solid by using the keyboard, choose Create > Polygon Primitives > 
Platonic Solids > Option Box from the menubar; the Tool Settings (Polygon Platonic Solid 
Tool) window will be displayed, as shown in Figure 2-17. In this window, set the properties 
of the platonic solid by using the keyboard and then click in the viewport; the platonic solid 
will be created in viewports. Choose the Reset Tool button at the top of the Tool Settings 
(Polygon Platonic Solid Tool) window to reset the settings of the platonic solid while creating 
a new platonic solid.

Figure 2-17  The Tool Settings (Polygon Platonic Solid Tool) window

POLYGON EDITING TOOLS
Polygon editing tools are used to perform different operations on the polygon objects. These 
editing tools are available in the Mesh, Edit Mesh, and Mesh Tools menus of the Polygons 
menu set. Figure 2-18 displays different tools in the Mesh menu. The most commonly used 
tools under this menu are discussed next. 



Polygon Modeling		        2-11

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Figure 2-18  The Mesh menu

Booleans
Menubar:	 Mesh > COMBINE > Booleans

The Booleans tool is used to combine the polygon objects to create a new shape. Using this 
tool, you can perform three different operations to modify the shape of the new object, as 
shown in Figure 2-19. The three options are discussed next.

Figure 2-19  Three options of the Booleans

Union
Menubar:	 Mesh > COMBINE > Booleans > Union

The Union option is used to combine the volume of two polygon meshes. To merge two objects, 
create a sphere and torus and place them in the viewport, as shown in Figure 2-20. Using 
the SHIFT key, select the torus and then the sphere. Next, choose Mesh > COMBINE > 
Booleans > Union from the menubar; both the objects will be merged, and the intersecting 
geometry between them will be deleted, refer to Figure 2-21.
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Figure 2-20  Torus and sphere placed in the viewport

Figure 2-21  The Union operation carried out on the torus and the sphere

Difference
Menubar:	 Mesh > COMBINE > Booleans > Difference

The Difference option is used to subtract the last selected geometry from the geometry that 
was selected first. To subtract the geometry, create a sphere and a torus and place them in 
the viewport, refer to Figure 2-20. Using the SHIFT key, select the torus and then the sphere. 
Next, choose Mesh > COMBINE > Booleans > Difference from the menubar; the geometry 
will be deleted, as shown in Figure 2-22.

Figure 2-22  The Difference operation carried out on the torus and the sphere
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Intersection
Menubar:	 Mesh > COMBINE > Booleans > Intersection

The Intersection option is used to keep the intersecting geometry between two objects and 
delete the remaining geometry. To do so, create a sphere and torus and place them in the 
viewport, refer to Figure 2-20. Using the SHIFT key, select the torus and the sphere. Next, 
choose Mesh > COMBINE > Booleans > Intersection from the menubar; the intersecting 
geometry will be displayed and the remaining parts will be deleted, as shown in Figure 2-23.

Figure 2-23  The Intersection operation carried 
out on the torus and the sphere

Combine
Menubar:	 Mesh > COMBINE > Combine

The Combine tool is used to group two or more polygon objects into a single polygon object. 
To do so, select the polygon objects to be combined in the viewport and then choose Mesh > 
COMBINE > Combine from the menubar; the selected polygon objects are combined into 
a single polygon object.

Extract
Menubar:	 Mesh > SEPERATE > Extract

The Extract tool is used to extract the selected faces from a polygon object. To do 
so, press and hold the right mouse button over the object; a marking menu will be 
displayed. Next, choose Face from the marking menu; the face selection mode will be 
activated. Alternatively, you can press F11 to activate the face selection mode. Choose Move 
Tool from the Tool Box. Next, select the face of the polygon that you want to extract and 
choose Mesh > SEPERATE > Extract from the menubar; the selected face will be extracted 
from the polygon object, as shown in Figure 2-24.

Separate 
Menubar:	 Mesh > SEPERATE > Separate

The Separate tool is used to ungroup the combined polygon objects into separate polygon 
objects. To do so, select the group in the viewport and then choose Mesh > SEPERATE > 
Separate from the menubar; the selected group of polygon objects are separated.
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Figure 2-24  The selected face seperated from the polygon object

Average Vertices
Menubar:	 Mesh > SHAPE > Average Vertices

The Average Vertices tool is used to move the positions of the vertices and make the polygon 
object smoother without adding divisions to it.

Fill Hole
Menubar:	 Mesh > SHAPE > Fill Hole

The Fill Hole tool is used to fill a hole in an object by adding a face to it. To fill a hole, press 
and hold the right mouse button over an object; a marking menu will be displayed. Next, 
choose Face from the marking menu; the face selection mode will be activated. Choose the 
Move Tool from the Tool Box and then select any face on the polygon and press DELETE. 
Next, select the surrounding boundary edges of the deleted face by choosing Edge from the 
marking menu, refer to Figure 2-25. Next, choose Mesh > SHAPE > Fill Hole from the 
menubar; the empty space will be filled, as shown in Figure 2-26. 

Figure 2-25  Edges of the deleted face selected Figure 2-26  Filled hole of the cube

 

Tip. 
1.  You can use the shortcut keys for displaying or activating various components of an object. 
For example, press F8 for object mode, F9 for vertex, F10 for edges, and F11 for faces. 

2.  To select the four surrounding edges of a deleted face, choose one of the edges and then 
press the right arrow key on your keyboard; all the four edges will be selected.
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Quadrangulate
Menubar:	 Mesh > SHAPE > Quadrangulate

The Quadrangulate tool is used to convert the polygon faces into quadrangles.

Smooth
Menubar:	 Mesh > SHAPE > Smooth

The Smooth tool is used to make a polygon object smooth by adding divisions to it. To do so, 
create a polygonal object in the viewport and then choose Mesh > SHAPE > Smooth from 
the menubar; the selected polygonal object will be smoothened. 

Triangulate
Menubar:	 Mesh > SHAPE > Triangulate

The Triangulate tool is used to convert the polygon faces into triangles.

Reduce
Menubar:	 Mesh > OPTIMIZE > Reduce

The Reduce tool is used to reduce the number of polygons in a selected region of a 
polygon object. To do so, select a polygon object in the viewport and press and hold the right 
mouse button over the object; a marking menu will be displayed. Next, choose Face from 
the marking menu; the face selection mode will be activated. Now, select a face of the object. 
Choose Mesh > OPTIMIZE > Reduce from the menubar; the number of polygons in a 
particular face will be reduced. 

EDITING THE POLYGON COMPONENTS
In the previous section, you learned to modify simple polygon primitives. In this section, you 
will learn to edit the components of polygon primitives to create complex objects from it. To 
do so, select a polygon object in the viewport and then press and hold the right mouse button 
over it; the marking menu of the corresponding object will display various components of 
the object such as vertex, edge, face, and UV, refer to Figures 2-27 to 2-30. To access various 
tools for editing the polygon primitives, select Polygons from the Menuset drop-down list in 
Status Line. Next, choose the Edit Mesh menu from the menubar. The most commonly used 
component editing tools are discussed next.

Note
1. The face selection mode in the marking menu allows you to select the faces of the active object. 
When you move the cursor on a face, the face will be highlighted in red. Next, when you click 
on the highlighted face, its color will change to green, indicating that it is now selected. In this 
way, you can identify the selected and the unselected faces.

2. The Multi option allows you to select all components at a time without switching between 
components. To select all components, press and hold the right mouse button on the already 
selected component, and then choose the Multi option from the marking menu. Next, select a 
face on the object, press and hold the SHIFT key, and then select the next required component. 
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Figure 2-28  The sphere in the edge modeFigure 2-27  Vertices of the sphere

Figure 2-30  UVs of the sphereFigure 2-29  Faces of the sphere

Chamfer
Menubar:	 Edit Mesh > VERTEX > Chamfer

The Chamfer tool is used to replace a vertex to create a chamfered corner. To use this tool, create 
a polygon object in the viewport and press and hold the right mouse button over it; a marking 
menu will be displayed. Choose Vertex from the marking menu; the vertex selection mode will 
be activated. Select a vertex of the object. Next, choose Edit Mesh > VERTEX > Chamfer 
from the menubar; a new polygon face will be created at the place of the selected vertex, as 
shown in Figure 2-31.

Figure 2-31  A new polygon face created 
using the Chamfer Vertex tool
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Detach
Menubar:	 Edit Mesh > VERTEX > Detach

The Detach tool is used to split a vertex into multiple vertices. To use this tool, create 
a polygon object in the viewport and press and hold the right mouse button over it; a 
marking menu will be displayed. Choose Vertex from the marking menu; the vertex 
selection mode will be activated. Select a vertex of the object that needs to be split. Next, 
choose Edit Mesh > VERTEX > Detach from the menubar; the selected vertex gets split 
into multiple vertices, refer to Figure 2-32.

Figure 2-32  Selected vertex gets split into 
multiple vertices

Extrude
The Extrude tool is used to extrude various components such as vertex, face or an 
edge of a polygon object inward or outward.

Extruding Vertex
Menubar:	 Edit Mesh > VERTEX > Extrude

To extrude a vertex, select the vertex that needs to be extruded. Next, choose 
Edit Mesh >VERTEX > Extrude from the menubar; the selected vertex is extruded.

Extruding Edge
Menubar:	 Edit Mesh > EDGE > Extrude

To extrude an edge, select the edge that needs to be extruded. Next, choose 
Edit Mesh > EDGE > Extrude from the menubar; the Thickness, Offset, and Divisions 
sliders will be displayed in the viewport. Press and hold the left mouse button on the Thickness 
slider; the shape of the cursor will change. Next, drag the cursor in the viewport. If the value 
in the slider goes negative, the face will be extruded inward and for positive values, it will be 
extruded outward.

Extruding Face
Menubar:	 Edit Mesh > FACE > Extrude

To extrude a face, select the face that needs to be extruded. Next, choose Edit Mesh > FACE > 
Extrude from the menubar; the Thickness, Offset, and Divisions sliders will be displayed 
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in the viewport. Press and hold the left mouse button on the Thickness slider; the shape of 
the cursor will change. Next, drag the cursor in the viewport. If the value in the slider goes 
negative, the face will be extruded inward and for positive values, it will be extruded outward.

Add Divisions
The Add Divisions tool is used to add segments equally on edges and faces of a polygon object.

Adding Divisions to Edge
Menubar:	 Edit Mesh > EDGE > Add Divisions

To add division to the edge of a polygon object, select the edge. Next, choose Edit Mesh > 
EDGE > Add Divisions from the menubar; a division is added for the selected edge of the 
polygon object.

Adding Divisions to Face
Menubar:	 Edit Mesh > FACE > Add Divisions

To add division to the face of a polygon object, select the face. Next, choose Edit Mesh > 
FACE > Add Divisions from the menubar; a division is added for the selected face of the 
polygon object.

Bevel
Menubar:	 Edit Mesh > EDGE > Bevel

The Bevel tool is used to create beveled edges for the currently selected polygon object. This 
adds smoothness to a sharp object by adding fillets on the edges. The bevel option adds fillet 
to edges by creating new faces on the selected polygon object. To do so, create a polygon object 
in the viewport and select it. Next, choose Edit Mesh > EDGE > Bevel from the menubar; 
the selected polygon object will be beveled, as shown in Figure 2-33.

The Bevel Tool is also used to bevel the components such as face, vertex, and edge of a 
polygon object individually. To do so, create a polygon object in the viewport and right-click 
on it; the marking menu will be displayed. Next, choose Edge from the marking menu; the 
edge selection mode will be activated. Now, select any edge of the object and then choose 
Edit Mesh > EDGE > Bevel from the menubar; the selected edge will be beveled, refer to 
Figure 2-34. 

Figure 2-33  Selected polygon object beveled Figure 2-34  Selected edge beveled 
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To adjust the bevel parameters, select the object in the viewport; the Channel Box / Layer 
Editor  is displayed on the right of the viewport. Next, expand polyBevel1 in the INPUTS 
area of the Channel Box / Layer Editor and then set the bevel parameters; the changes will be 
reflected on the selected object in the viewport. Alternatively, select the object in the viewport. 
Choose Window > Attribute Editor from the menubar; the Attribute Editor will be displayed 
on the right side of the viewport. Next, choose the polyBevel1 tab from the Attribute Editor; 
the bevel parameters will be displayed in the Attribute Editor, as shown in Figure 2-35. Set 
the parameters as per your requirement.

Note
Choose the Show/Hide Channel Box button from the Status Line, if the Channel Box / Layer 
Editor is not displayed in the viewport.

Figure 2-35  Various bevel attributes in the 
Attribute Editor

Bridge
The Bridge tool is used to connect two edges or two faces of a polygon object. The connection 
between the two edges or two faces can be straight or curved, depending on the option, you 
choose from the Bridge Options dialog box.

Bridging Edge
Menubar:	 Edit Mesh > EDGE > Bridge

To create a bridge between two edges of an object, select the two edges and then choose Edit 
Mesh > EDGE > Bridge > Option Box from the menubar; the Bridge Options dialog box 
will be displayed, as shown in Figure 2-36. In this dialog box, choose the type of bridge you 
want to create by selecting the corresponding radio button and then choose the Bridge or 
Apply button.
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Bridging Face
Menubar:	 Edit Mesh > FACE > Bridge

To create a bridge between two faces of an object, select the two faces and then choose Edit 
Mesh > FACE > Bridge > Option Box from the menubar; the Bridge Options dialog box 
will be displayed, as shown in Figure 2-36. In this dialog box, choose the type of bridge you 
want to create by selecting the corresponding radio button and then choose the Bridge or 
Apply button.

Figure 2-36  The Bridge Options dialog box

Note
To create a bridge between two separate objects, you need to combine the two objects by choosing 
Mesh > COMBINE > Combine from the menubar.

Collapse
The Collapse tool is used to collapse two edges of a polygon object and merge their vertices 
seperately.

Collapsing Edge
Menubar:	 Edit Mesh > EDGE > Collapse

To collapse two edges of an object, select the two edges and then choose Edit Mesh > EDGE > 
Collapse from the menubar; the selected two edges will be collapsed and their vertices are 
also merged separately.

Collapsing Face
Menubar:	 Edit Mesh > FACE > Collapse

To collapse two faces of an object, select the two faces and then choose Edit Mesh > FACE > 
Collapse from the menubar; the selected two faces will be collapsed and their vertices are 
also merged separately.
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Delete Edge/Vertex
Menubar:	 Edit Mesh > EDGE > Delete Edge/Vertex

The Delete Edge/Vertex tool is used to delete the selected edges or vertices of a polygon object. 
To do so, select vertices of an object to be deleted and then choose Edit Mesh > EDGE > 
Delete Edge/Vertex from the menubar; the selected vertices will be deleted. Similarly, using 
the Delete Edge/Vertex tool, you can delete the selected edges of the polygon object.

Edit Edge Flow
Menubar:	 Edit Mesh > EDGE > Edit Edge Flow

The Edit Edge Flow tool is used to modify the position of edges along the curve of the surrounding 
mesh. To do so, select the two non-adjacent edges of an object and choose Edit Mesh > EDGE > 
Edit Edge Flow from the menubar; the edges move along the curvature of the object.

Duplicate
Menubar:	 Edit Mesh > FACE > Duplicate

The Duplicate tool is used to create the duplicate copies of the selected faces. To use this tool, 
create a cube in the viewport. Select the polygon cube created, press and hold the right mouse 
button on it; a marking menu will be displayed. Next, choose Face from the marking menu; 
the face selection mode will be activated. Choose Move Tool from the Tool Box. Next, select 
a face on the polygon cube and choose Edit Mesh > FACE > Duplicate from the menubar; 
a duplicate copy of the selected face will be created in the viewport.

EDITING THE POLYGON COMPONENTS USING      
MESH TOOLS
In the previous section, you learned to modify simple polygon primitives. In this section, you 
will learn to edit the polygon components such as face, vertex, and edge using various Mesh 
Tools. To do so, create a polygon object and select it in the viewport. To access various tools 
for editing the polygon components, select Polygons from the Menuset drop-down list in 
Status Line. Next, choose the Mesh Tools menu from the menubar. The most commonly used 
tools under this menu are discussed next.

Bevel Tool
Menubar:	 Mesh Tools > EDIT > Bevel Tool

The Bevel Tool is used to bevel the components such as face, vertex, and edge of a polygon 
object individually. To do so, create a polygon object in the viewport and select it. Next, choose 
Mesh Tools > EDIT > Bevel Tool from the menubar; the edges of the object will turn blue 
and the shape of the cursor will also change, as shown in Figure 2-37. Now, select the face of 
the polygon object; the selected face will be beveled, refer to Figure 2-38.
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Figure 2-37  Edges of the object turned blue and 
the cursor changed

Figure 2-38  Selected face beveled

Create Polygon Tool
Menubar:	 Mesh Tools > EDIT > Create Polygon Tool

The Create Polygon Tool is used to create polygons by placing vertices in the viewport. To 
do so, choose Mesh Tools > EDIT > Create Polygon Tool from the menubar. Next, click in 
the viewport; a vertex point will be created in the viewport. Next, depending on the shape 
required, keep on clicking in the viewport to connect the points; a shape will be created, refer 
to Figure 2-39. 

Cut Faces Tool
Menubar:	 Mesh Tools > EDIT > Cut Faces Tool

The Cut Faces Tool is used to modify a selected object by splitting its faces along a cut line. To 
use this tool, create a polygon object in the viewport and choose Mesh Tools > EDIT > Cut 
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Faces Tool from the menubar and then drag the cursor on the selected object in the viewport; 
the faces of the object will be cut along the cut line.

Figure 2-39  A shape created using Create Polygon Tool

Insert Edge Loop Tool
Menubar:	 Mesh Tools > EDIT > Insert Edge Loop Tool

The Insert Edge Loop Tool is used to add segments to the selected object. The segment 
created by using this tool ends at the same point from where it starts, thus forming a loop. 
To use this tool, create a polygon object in the viewport and choose Mesh Tools > EDIT > 
Insert Edge Loop Tool from the menubar; the edges of the object will turn blue. Next, click 
on an edge; a new segment will be created on the selected object, as shown in Figure 2-40. 
Note that the Insert Edge Loop Tool works only with objects that have quads (quads are faces 
with four sides). If the sides of a face are more or less than four, then this tool will not work. 
To set the properties of this tool, choose Mesh Tools > EDIT > Insert Edge Loop Tool > 
Option Box from the menubar; the Tool Settings (Insert Edge Loop Tool) window will be 
displayed, as shown in Figure 2-41.

Figure 2-40  A new segment created using Insert 
Edge Loop Tool
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Figure 2-41  The Tool Settings (Insert Edge Loop Tool) window

Merge Vertex Tool
Menubar:	 Mesh Tools > EDIT > Merge Vertex Tool

The Merge Vertex Tool is used to merge two vertices together by dragging the source vertex 
toward the target vertex. To merge two vertices, select an object in the viewport and press and 
hold the right mouse button over it; a marking menu will be displayed. Choose Vertex from 
the marking menu; the vertex selection mode will be activated. Next, choose Mesh Tools > 
EDIT > Merge Vertex Tool from the menubar; the Merge Vertex Tool will be activated. 
Now, select a vertex and drag the selected vertex to the target vertex, with which you want it 
to merge. When you drag the cursor from one vertex to the other, a red line appears between 
the two vertices, indicating that these two points will merge together, as shown in Figure 2-42. 
You can also use the Merge Vertex Tool for merging the selected vertex to the target vertex 
or to the center of the two vertices. To do so, choose Mesh Tools > EDIT > Merge Vertex 
Tool > Option Box from the menubar; the Tool Settings (Merge Vertex Tool) window will 
be displayed. Now, select the Center radio button from the window. Drag the cursor from one 
vertex to another vertex; the vertices will be merged to the center of the two vertices.

Figure 2-42  The red line indicating the vertices to be merged
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Multi-Cut Tool                                                               
Menubar:	 Mesh Tools > EDIT > Multi-Cut Tool

The Multi-Cut Tool is used to manually add segments between two edges of an object. To add 
segments between two edges, select the polygon object and then choose Mesh Tools > EDIT > 
Multi-Cut Tool from the menubar. Click on the edge to choose the starting point of the 
segment. Next, click on the edge where you want to end the segment and press ENTER; a 
segment will be added between the two edges, refer to Figure 2-43.

Figure 2-43  Segments added using Multi-Cut Tool

Offset Edge Loop Tool
Menubar:	 Mesh Tools > EDIT > Offset Edge Loop Tool

The Offset Edge Loop Tool works similar to Insert Edge Loop Tool with the only difference 
that it creates segments on both sides of the edges selected. To use this tool, create a polygon 
object in the viewport and choose Mesh Tools > EDIT > Offset Edge Loop Tool from the 
menubar. Next, click and drag the cursor to the already existing edges to create new segments 
on both sides of the selected object, as shown in Figure 2-44.

Figure 2-44  New segments created using Offset Edge Loop Tool
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TUTORIALS
 Tutorial 1                                                                             
In this tutorial, you will create the model of a coffee mug, as shown in Figure 2-45, using the 
polygon modeling techniques.                                                           (Expected time: 20 min)

Figure 2-45  The model of a coffee mug

The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create the basic shape of the mug.
c.	 Create the handle of the mug.
d.	 Change the background color of the scene.
e.	 Save and render the scene.

Creating a Project Folder
Before starting a new scene, it is recommended that you create a project folder. It helps you 
keep all the files of a project in an organized manner. Open Windows Explorer and browse to 
the Documents folder. In this folder, create a new folder with the name maya2015. The maya2015 
folder will be the main folder and it will contain all the projects folders that you will create 
while doing tutorials of this textbook. Now, you will create a project folder for Tutorial 1 of 
this chapter. To do so, you need to follow the steps given next.

1. 	 Start Autodesk Maya 2015 by double-clicking on its icon on the desktop.

2.	 Choose File > Project Window from the menubar; the Project Window dialog box is 
displayed. Choose the New button; the Current Project and Location text boxes are 
enabled. Now, enter c02_tut1 in the Current Project text box. 

3.	 Click on the folder icon next to the Location text box; the Select Location dialog box 
is displayed. In this dialog box, browse to the \Documents\maya2015 folder and choose 
the Select button to close the dialog box. Next, choose the Accept button in the Project 
Window dialog box; the \Documents\maya2015\c02_tut1 folder will become the current 
project folder.

4.	 Choose Save Scene from the File menu; the Save File As dialog box is displayed.
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Note
The scenes created in Maya are saved with the .ma or .mb extension. As the project folder is 
already created, the path \Documents\maya2015\c02_tut1\scenes is displayed in the Look in 
drop-down list of the Save File As dialog box. 

Tip: After setting the project folder when you open or save a scene, Maya uses the scenes 
folder inside the project folder, by default.

5.	 Enter c02tut1 in the File name edit box and then choose the Save As button to close the 
dialog box.

Note
It is recommended that you frequently save the file while you are working on it by pressing the 
CTRL+S keys.

Creating the Basic Shape of the Mug
In this section, you will use the Cylinder polygon primitive to create the basic shape of  the mug.

1.	 Choose Create > Polygon Primitives > Cylinder > Option Box from the menubar; the 
Tool Settings (Polygon Cylinder Tool) window is displayed in the viewport. Enter the 
values in the Tool Settings (Polygon Cylinder Tool) window, as shown in Figure 2-46.

2.	 Place the cursor in the persp viewport and then press the left mouse button to create a  
	 polygon cylinder, refer to Figure 2-47.

Figure 2-47  The cylinder created 
in the viewport

Figure 2-46   The Tool Settings (Polygon 
Cylinder Tool) window

3.	 In the Channel Box / Layer Editor, double-click on pCylinder1; a text box is  activated. 
Next, enter mug in the text box and press ENTER; pCylinder1 is renamed as mug.
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4. 	 Hover the cursor in the persp viewport. Press SPACEBAR; the four viewports are displayed. 
Next, hover the cursor on the front viewport and press SPACEBAR; the front viewport 
is maximized. Select mug, if it is not selected and then press and hold the right mouse 
button; a marking menu is displayed. 

5.	 Choose Vertex from the marking menu; the vertex selection mode is activated.

6.	 Select the vertices at the bottom of mug, as shown in Figure 2-48. Next, invoke Scale Tool 
by pressing the r key.

Figure 2-48  Bottom vertices of the 
cylinder selected

7. 	 Scale down the selected vertices of mug inward, uniformly, as shown in Figure 2-49. Similarly, 
select the other vertices and scale the vertices to form the shape of a mug, as shown in 
Figure 2-50. 

	

Figure 2-50  Basic shape of the mug 
created 

Figure 2-49  Bottom vertices of the 
cylinder scaled

	 Next, you need to add segments at the top and bottom. 

8.	 Make sure the Polygons menuset is selected in the Menuset drop-down list. Choose Mesh 
Tools > EDIT > Insert Edge Loop Tool from the menubar. Next, click at the top and 
bottom region of mug; two edges are inserted, refer to Figure 2-51. Deactivate Insert Edge 
Loop Tool by pressing the w key and then press 3 to view mug in the smooth mode. 
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9.	 Maximize the persp viewport. Press 1 to switch back to the original mode. Make sure mug 
is selected and then press and hold the right mouse button; a marking menu is displayed. 
Choose Face from the marking menu; the face selection mode is activated. Now, select the 
top faces of mug using the SHIFT key, as shown in Figure 2-52. Next, choose Edit Mesh > 
FACE > Extrude from the menubar. 

Figure 2-51  Two edges inserted at the top and
bottom of the cylinder

Figure 2-52  Top faces of the cylinder 
selected

10.	  Invoke Scale Tool and scale down the selected faces uniformly, as shown in Figure 2-53. 

11.  Again, choose Edit Mesh > FACE > Extrude from the menubar; the Thickness slider 	
is displayed and also the shape of the cursor changes. Next, move the cursor over the 
Thickness slider and drag the cursor toward left in the viewport such that the value in 
the Thickness edit box becomes equal to -0.3, as shown in Figure 2-54.

Figure 2-53  Selected top faces of the 
mug scaled down using Scale Tool

Figure 2-54  The Thickness edit box becomes equal
 to -0.3

12.	 Press the g key to invoke the Extrude tool again and enter the value -1.6 in the Thickness 
edit box; the top faces of mug are extruded inward.
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Note
The g key is used to repeat the last performed action in Maya.

13. Press g again to invoke the Extrude tool, and enter the value -2 in the Thickness edit box. 
In addition to this, enter 0.8 in the Offset edit box; the mug is extruded inward.

14.  Maximize the top viewport such that you can view the inner area of mug. Press 3 to view 
the object in the smooth mode. To rectify the distortion in the geometry, press 1 and insert 
two edges. To do so, choose Mesh Tools > EDIT > Insert Edge Loop Tool; the shape 
of the cursor changes and then insert two edges inside the mug, refer to Figure 2-55. 
Deactivate Insert Edge Loop Tool by pressing W.

Figure 2-55  Two edges inserted inside the mug

Creating the Handle of the Mug
In this section, you need to create the handle of the mug.

1.	 Maximize the side viewport. Move the cursor over mug and then press and hold the right 
mouse button; a marking menu is displayed. Choose Edge from the marking menu; the 
edge selection mode is activated.

2.	 Select two edges of mug, refer to Figure 2-56. Next, choose Edit Mesh > EDGE > Bevel > 
Option Box; the Bevel Options dialog box is displayed. Now, enter the value 1 in the 
Width edit box and choose the Bevel button; the selected edges will be beveled, as shown 
in Figure 2-57. 

3.	 Move the cursor over mug and then press and hold the right mouse button; a marking 
menu is displayed. Choose Face from the marking menu; the face selection mode is 
activated. Next, select a face of mug, as shown in Figure 2-58. 

4.	 Choose Edit Mesh > FACE > Extrude from the menubar. Next, invoke Scale Tool by 
pressing the r key and scale down the selected face of mug, as shown in Figure 2-59.
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Figure 2-56  Two edges of mug selected Figure 2-57  Selected edges beveled

Figure 2-58  A face of mug selected Figure 2-59  Face of the mug scaled down

5.	 Select the face of mug, as shown in Figure 2-60. Repeat the procedure as done in Step 4 
to scale down the face, refer to Figure 2-61.

Figure 2-60  A face of the mug selected Figure 2-61  A face of the mug scaled down

6.	 Maximize the persp viewport. Make sure both the scaled faces are selected, and then 
invoke the Extrude tool by pressing the g key. Next, enter the value 0.8 in the Thickness 
edit box; the selected faces of mug are extruded.

7.	 Deactivate Extrude tool by pressing the w key. Make sure the two extruded faces are 
selected. Next, choose Edit Mesh > FACE > Bridge > Option Box from the menubar; 
the Bridge Options dialog box is displayed. Enter the values in the Bridge Options dialog 
box, as shown in Figure 2-62. Next, choose the Apply button and close the dialog box; 
the extruded faces are connected to each other.
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Figure 2-62  The Bridge Options dialog box

8.	 Make sure mug is selected and then press and hold the right mouse button on it; a marking 
menu is displayed. Next, choose Object from the marking menu; the object selection mode 
is activated.

9.   	Select mug and then choose Mesh > SHAPE > Smooth from the menubar; the mesh of 
mug is smoothened. Press SPACEBAR; the four viewports are displaying the mug after 
applying Smooth Tool, as shown in Figure 2-63.

Figure 2-63  The mug displayed in all viewports

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Window > Outliner from the menubar; the Outliner window is displayed. Select 
the persp camera in the Outliner window; the perspShape tab is displayed in the Attribute 
Editor. 

2.	 In the perspShape tab, expand the Environment node and drag the Background Color 
slider bar toward right to change the background color to white. 
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Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can 
view the final rendered image of the scene by downloading the c02_maya_2015_rndr.zip 
file from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual 
Effects > Maya > Autodesk Maya 2015: A Comprehensive Guide

1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport. Choose the Render the current frame button from the 
Status Line; the Render View window is displayed. This window shows the final output 
of the scene, refer to Figure 2-45.

 Tutorial 2             

In this tutorial, you will create the model of a skateboard, as shown in Figure 2-64, using the 
polygon modeling techniques.                                                           (Expected time: 30 min)

Figure 2-64  The model of a skateboard
The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create the deck.
c.	 Create the base.
d.	 Create the wheels.
e.	 Change the background color of the scene.
f.	 Save and render the scene.

Creating a Project Folder
Create a new project folder with the name c02_tut2 at \Documents\maya2015 and then save the 
file with the name c02tut2, as discussed in Tutorial 1. 

Creating the Deck	
In this section, you need to create the deck of the skateboard using the Cube tool.

1.	 Maximize the top viewport. Choose Create > Polygon Primitives > Cube > Option Box 
from the menubar; the Tool Settings (Polygon Cube Tool) window is displayed in the 
viewport. Enter the required values in the Tool Settings (Polygon Cube Tool) window, as 
shown in Figure 2-65. Next, click in the top viewport; a cube is created in the top viewport, 
as shown in Figure 2-66.
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Figure 2-65  The Tool Settings (Polygon 
Cube Tool) window

Figure 2-66  A cube created

2.	 In the Channel Box / Layer Editor, click on pCube1; a text box is activated. Next, enter 
deck in the text box and press ENTER; pCube1 is renamed as deck.

3.	 In the top viewport, press and hold the right mouse button on deck; a marking menu is 
displayed. Choose Vertex from the marking menu; the vertex selection mode is activated. 
Next, select the vertices, as shown in Figure 2-67. Next, choose Scale Tool by pressing the 
r key and scale the vertices uniformly, refer to Figure 2-68.

4.	 Similarly, scale the other vertices to create the basic shape of deck, as shown in Figure 2-69.
    

Figure 2-68  The selected 
vertices scaled

Figure 2-67  The vertices selected Figure 2-69  The basic 
shape of  the deck

5.	 Press and hold the right mouse button on deck; a marking menu is displayed. Next, choose 
Object Mode from the marking menu; the object selection mode is activated. Select deck 
and maximize the front viewport. 
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6.	 Make sure the Polygons menuset is selected from the Menuset drop-down list in the Status 
Line. Next, choose Mesh Tools > EDIT > Insert Edge Loop Tool from the menubar; 
the shape of the cursor changes. Click on the top and bottom vertical edge and create 
two new segments on deck, as shown in Figure 2-70.

7. 	 Maximize the top viewport and repeat the previous step to create two segments on deck, 
as shown in Figure 2-71. Choose Select Tool to deactivate Insert Edge Loop Tool.

Figure 2-71  Two segments 
created in the top viewport

Figure 2-70  Two new segments created in 
the front viewport

8.	 Press and hold the right mouse button on deck; a marking menu is displayed. Choose 
Object Mode from the marking menu; the object selection mode is activated.

9.	 Make sure deck is selected and choose Mesh > SHAPE > Smooth > Option Box from 
the menubar; the Smooth Options dialog box is displayed. In the Smooth Options dialog 
box, make sure the Division levels value is set to 1. Now, choose the Smooth button; the 
geometry of deck is smoothened.

Creating the Base
In this section, you need to create the base of the skateboard using the Cube polygon primitive.

1.	 Maximize the front viewport. Choose Create > Polygon Primitives > Cube > Option 
Box from the menubar; the Tool Settings (Polygon Cube Tool) window is displayed in 
the viewport. Enter the required values in the Tool Settings (Polygon Cube Tool) window, 
as shown in Figure 2-72. Next, click in the front viewport; a cube is created in the front 
viewport, as shown in Figure 2-73.

2.	 In the Channel Box / Layer Editor, click on pCube1; a text box is activated. Next, enter 
base in the text box and press ENTER; pCube1 is renamed as base.

3.	 In the front viewport, press and hold the right mouse button on base; a marking menu is 
displayed. Choose Vertex from the marking menu; the vertex selection mode is activated. 
Next, choose Move Tool from the Tool Box. Now, adjust the vertices on base to get the 
result shown in Figure 2-74.

4.	 Maximize the side viewport. Select the left most vertices in the side viewport and then 
drag them along the Z axis to reduce the size of base, as shown in Figure 2-75.
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Figure 2-73  The cube createdFigure 2-72   The Tool Settings 
(Polygon Cube Tool) window

Figure 2-75  Dragging the 
selected vertices along the Z axis

Figure 2-74  The adjusted vertices of 
the base

5.	 Press and hold the right mouse button on base; a marking menu is displayed. Next, choose 
Object Mode from the marking menu; the object selection mode is activated.

6.	 Select base and maximize the front viewport. Next, choose Mesh Tools > EDIT > Insert 
Edge Loop Tool from the menubar. Using this tool, insert four new segments, as shown 
in Figure 2-76. Choose Select Tool to deactivate Insert Edge Loop Tool.

Figure 2-76  Four new segments inserted in 
the front viewport
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7.	 Press and hold the right mouse button on base; a marking menu is displayed. Choose 
Object Mode from the marking menu; the object selection mode is activated.

	
8.	 Select base and choose Mesh > SHAPE > Smooth  from the menubar; the geometry of 

base is smoothened. 

	 Next, you need to create the bolts.

9.	 Choose Create > Polygon Primitives > Cylinder > Option box from the menubar; the 
Tool Settings (Polygon Cylinder Tool) window is displayed. Enter the required values in 
the Tool Settings (Polygon Cylinder Tool), as shown in Figure 2-77. Click in the front 
viewport; a cylinder is created. 

Figure 2-77  The Tool Settings (Polygon 
Cylinder Tool) window

10.	 In the Channel Box / Layer Editor, click on pCylinder1; a text box is activated. Next, 
enter bolt in the text box and press ENTER; pCylinder is renamed as bolt.

11.	 Choose Move Tool from the Tool Box and align bolt with base in all viewports. Next, 
choose the Rotate Tool from the Tool Box to rotate and align it with both front and side 
viewports, as shown in Figures 2-78 and 2-79. Press 5 in the side viewport to view the 
object in the Shaded mode.

12.	 Activate the side viewport. Make sure bolt is selected and press CTRL+D; a duplicate copy 
of bolt is created with the name bolt1. Set the following parameters in the Channel Box / 
Layer Editor of bolt1:

     	 Rotate X: 90	 	 Rotate Z: 0	
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Figure 2-78  The cylinder rotated and 
aligned in the front viewport

Figure 2-79  The cylinder rotated 
and aligned in the side viewport

13.	 Choose Scale Tool from the Tool Box and scale bolt1 uniformly. Next, choose Move Tool 
from the Tool Box and align it in all viewports, as shown in Figure 2-80.

Figure 2-80  Aligning bolt1 in all viewports

	 Next, you need to create truck.

14.  Maximize the front viewport. Choose Create > Polygon Primitives > Cylinder > Option 
box from the menubar; the Tool Settings (Polygon Cylinder Tool) window is displayed 
in the viewport. In the Tool Settings (Polygon Cylinder Tool) window, set the parameters 
as follows:

	 Axis: Z			   Radius: 0.65			   Height: 1 			 
Axis divisions: 10 		  Height divisions: 3 		  Cap Divisions: 10
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	 Next, click in the viewport; the cylinder is created, as shown in

Figure 2-81  The cylinder 
created in the front viewport

 
Figure 2-81.

15.	 In the Channel Box / Layer Editor, click on pCylinder1; a text 
box is activated. Next, enter truck in the text box and press 
ENTER; the pCylinder1 is renamed as truck.

16.	 Maximize the persp viewport. Press and hold the right 
mouse button over truck and choose Face from the marking 
menu displayed; the face selection mode is activated. 
Select the faces 1 and 5 of truck, refer to Figure 2-82. Next, 
choose Edit Mesh > Extrude from the menubar; the extruded 
manipulator is displayed on the screen. Drag the blue arrow 
to extrude the faces in the persp viewport; the faces of truck are extruded, as shown in 
Figure 2-83. 

Figure 2-83  The cylinder after extrusion 
in the persp viewport

Figure 2-82  The cylinder after extrusion 
in the persp viewport

17.	 Maximize the front viewport. Choose the Mesh Tools > EDIT > Insert Edge Loop Tool 
from the menubar and add new segments to truck, as shown in Figure 2-84. Choose Select 
Tool to deactivate Insert Edge Loop Tool.

Figure 2-84   New segments added to truck

18.	 Press and hold the right mouse button on truck; a marking menu is displayed. Choose 
Object Mode from it; the object selection mode is activated. Next, select the truck and 
choose Mesh > SHAPE > Smooth > Option Box from the menubar; the Smooth Options 
dialog box is displayed.
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19.	 In the dialog box, enter 2 in the Division levels edit box and then choose the Smooth 
button; the geometry of truck is smoothened. Next, align truck, base, bolt and bolt1 in all 
viewports using Move Tool, Rotate Tool, and Scale Tool uniformly, refer to Figure 2-85. 

Figure 2-85  The parts aligned 
with base in the front viewport

20.	 Press and hold the SHIFT key and select base, truck, bolt, and bolt1 in the persp viewport. 
Next, choose Mesh > COMBINE > Combine from the menubar; the selected parts are 
combined and a group with the name base1 is created.

21. 	In the base1 area of the Channel Box / Layer Editor, enter 90 in the Rotate Y edit box 
and then press the ENTER key; the .

22.	 Align base1 in all viewports using the Move Tool and Scale Tool from the Tool Box to 
make it proportional with the deck, as shown in Figure 2-86.

Figure 2-86  The base1 aligned in all viewports
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Creating the Wheels
In this section, you need to create wheels for the skateboard using the Torus polygon primitive.

1.	 Choose Create > Polygon Primitives > Torus from the menubar. Next, click in the top 
viewport to create a torus.

2. 	 In the INPUTS area of the Channel Box / Layer Editor, expand polyTorus1 node and 
set the following parameters:

	 Radius:  0.07	 	 Section radius:  0.05	

3.	 In the pTorus1 area of the Channel Box/Layer Editor, enter 90 in the Rotate Z edit box.
 
4.	 In the Channel Box / Layer Editor, rename pTorus1 as wheel, as done earlier. 

5.	 Align the wheel with bolt1 in all viewports using Move Tool from the Tool Box, as shown 
in Figure 2-87.

Figure 2-87  The wheel aligned with bolt1 in all viewports

6.	 Maximize the front viewport. Make sure the wheel is selected and then press CTRL+D; a 
duplicate copy of wheel is created with the name wheel1. Next, move wheel1 in the opposite 
direction to wheel, as shown in Figure 2-88. 



2-42					         Autodesk Maya 2015: A Comprehensive Guide
E

va
lu

at
io

n 
C

op
y.

 D
o 

no
t r

ep
ro

du
ce

. F
or

 in
fo

rm
at

io
n 

vi
si

t w
w

w
.c

ad
ci

m
.c

om

Figure 2-88  The wheel1 moved to 
opposite direction to wheel

7.	 Maximize the persp viewport. Select base1, wheel, and wheel1 by using the SHIFT key and 
then choose Mesh > COMBINE > Combine from the menubar; the selected parts are 
combined to form a single polygon object with the name base2.

8. 	 Choose Modify > Center Pivot from the menubar; the pivot point of the combined base2 
is set to center. Next, press CTRL+d; a duplicate copy of the selected mesh is created in 
the viewport.

9.	 Maximize the side viewport. Next, move base3 along the Z axis to align with deck and also 
enter 180 in the Rotate Y edit box to rotate base3, refer to Figure 2-89.

Figure 2-89  The base3 moved and rotated

10.	 Select deck. Press and hold the right mouse button on deck; a marking menu is displayed. 
Choose Vertex from the marking menu; the vertex selection mode is activated. Next, select 
the vertices and move up along the Y axis using Move Tool, as shown in Figure 2-90.

Figure 2-90  Moving the selected vertices up along the Y axis

11.	 Press and hold the right mouse button on deck; a marking menu is displayed. Choose 
Object Mode from the marking menu; the object selection mode is activated.
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12.	 Maximize the persp viewport and select all parts of the skateboard in the persp viewport. 
Next, choose Mesh > COMBINE > Combine from the menubar; the selected parts are 
combined.

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Window > Outliner from the menubar; the Outliner window is displayed. Select 
the persp camera in the Outliner window; the perspShape tab is displayed in the Attribute 
Editor. 

Note
If Attribute Editor is not visible in the interface, press CTRL + A to make it visible.

2.	 In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the model by downloading the c02_maya_2015_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
Maya > Autodesk Maya 2015: A Comprehensive Guide

1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport, if it is not already maximized. Choose the Render the 
current frame button from the Status Line; the Render View window is displayed. This 
window shows the final output of the scene, refer to Figure 2-64.

 Self-Evaluation Test  
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following geometric shapes is formed by connecting a polygonal base and 
an apex?

		  (a) Prism			   (b) Pyramid
		  (c) Sphere	 		  (d) Cube

2. 	 Which of the following shortcuts can be used to display an object in the object 
selection mode?

	
		  (a) F8	 			   (b) F9
		  (c) F10	 			   (d) F11
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3.	 The __________ is used to merge two vertices together by dragging the source vertex 
toward the target vertex.

4.	 The __________ option is used to subtract the last selected geometry from the geometry 
that was selected first.

5.	 A __________ is a curve in three dimensional space such that its angle to a plane 
perpendicular to the axis is constant.

6. 	 The __________ solids are those primitives, in which all sides and angles are equal, and 
all faces are identical.

7.	 The __________ tool is used to reduce the number of polygons in the selected region of 
an object.

8. 	 The Insert Edge Loop Tool is used to create beveled transition surfaces on a profile curve. 
(T/F)

9. 	 The Chamfer tool is used to merge the selected edges and vertices that are within a 
numerically specified threshold distance from each other. (T/F)

10. 	The Bridge tool is used to connect two edges or two faces of a polygon object. (T/F)
 

 Review Questions 
Answer the following questions:

1.	 Which of the following tools is used to add smoothness to a sharp edge?

		  (a) Extrude			   (b) Duplicate face
		  (c) Bevel			   (d) Merge to Center

2. 	 Which of the following primitives is formed by an alternate arrangement of hexagons and 
pentagons?

		
		  (a) Prism			   (b) Helix
		  (c) Soccer ball			   (d) Sphere

3.	 The __________ option is used to create a duplicate copy of a selected face.

4.	 The __________ tool is used to add segments on both the sides of a selected edge.

5.	 The __________ tool is used to ungroup the combined polygon objects into separate 
polygon objects.

6. 	 The __________ tool is used to make a polygon object smooth by adding divisions to it. 
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7.	 The __________ operation is used to merge two intersecting objects by deleting the 
intersecting geometry between them. 

8. 	 The Combine tool is used to group two or more polygon meshes into a single polygon 
object. (T/F)

9. 	 The Multi-Cut Tool is used to manually add segments between two edges of an object. 
(T/F)

10.	 The Detach tool is used to split a vertex into multiple vertices. (T/F)

EXERCISES 
The rendered output of the models used in the following exercises can be accessed by 
downloading the file c02_maya_2015_exr.zip from www.cadcim.com. The path of the file is as 
follows: Textbooks > Animation and Visual Effects > Maya > Autodesk Maya 2015: A Comprehensive 
Guide

 Exercise 1                                                                      
Using various polygon modeling techniques, create the model of a USB cable, as shown in 
Figure 2-91.					                                  (Expected time: 30 min)

Figure 2-91  Model to be created in Exercise 1

 Exercise 2                                                                   
Using various polygon modeling techniques, create a scene, as shown in Figure 2-92.		
	                                                                                               (Expected time: 30 min)

Figure 2-92  Scene to be created in Exercise 2
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 Exercise 3                                                                      
Using polygon primitive modeling techniques, create a scene, as shown in Figure 2-93.                                                       	
								           (Expected time: 30 min)
                                                								      
	  

Figure 2-93  Scene to be created in Exercise 3

 

Answers to Self-Evaluation Test
1. b, 2. a, 3. Merge Vertex Tool, 4. Difference, 5. helix, 6. platonic, 7. Reduce, 8. F, 9. F, 10. T


