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Learning Objectives

After completing this chapter, you will be able to:
* Understand the Particle Flow system

* Work with the Particle View window

* Create event driven particle systems

* Understand events and actions (tests and operators)
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INTRODUCTION

The Particle Flow is an event-driven particle system available in 3ds Max. In this system, the
behavior of the particles is controlled by operators, events, and tests that you can combine in
a group using the Particle View window. You can group these operators to create events and
then can connect them using wires. In the particle system the particles flow from one event
to another using tests. For example, you can conduct a test to check whether a particle has
acquired a certain speed, color, or age. Once the particle passes an event, it moves to the next

wired event. In this chapter, you will create various particle effects using Particle Flow.

PF SOURCE PARTICLE SYSTEM

Menu bar: Create > Particles > Particle Flow Source
Command Panel: Create > Geometry > Particle Systems >
Object Type rollout > PF Source

The PF Source particle system is used to simulate various particle effects - ObjectType |
such as fire and water. To create a PF Source particle system, ch?ose ﬁ“
the PF Source tool from Create > Geometry > Particle
Systems > Object Type rollout in the Command Panel; the Name
and Color, Setup, Emission, and System Management rollouts will
be displayed, as shown in Figure 17-1. In the Top viewport, press and I
hold the left mouse button, drag the cursor diagonally, and then release E

= sewp

the left mouse button; an emitter will be created in the Top viewport.
Next, right-click in the viewport to exit the tool. You can change the

Enable Particle Emission

shape and size of the emitter by using the options/parameters/attributes =
available in the Emission rollout. The emitter created will not be visible F
at the time of rendering. Logo sze: [ ]
R e
Choose the Play Animation button from the animation playback e E
controls; the emission of particles from the emitter will start, refer to N E

Figure 17-2. The arrow sign indicates the direction of movement of
the particles. Now, choose the Modify tab in the Command Panel;
various rollouts will be displayed. These rollouts are discussed next.

Note
The direction of movement of the particles depends on the viewport in
which the emitter is created.

Setup Rollout

Show: Logo Icon

rQuantity Multiplier:

evport W[ET ]
Render % E

Partide Amount:

Upper Limit:

E

Integration Step:
Viewport:
Render: |Half Frame

The options in this rollout are used to toggle the visibility of particles. Figure 17-1 The PF
In this rollout, the Enable Particle Emission check box is selected by §ource tool in the
default. If you clear this check box, the emitter will not emit particles. Object Type rollout
Alternatively, choose the Particle View button from the Setup rollout;

the Particle View window will be displayed. Next, choose Edit >

Turn Off All from the menu bar of the Particle View window, refer

to Figure 17-3. The options in this window will be discussed later in the chapter.
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Figure 17-2 The Particle emitter
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Figure 17-3 The Particle View window

Emission Rollout

The options in this rollout are used to adjust the size and appearance of the Particle Flow
icon in the viewport, refer to Figure 17-4. In addition to this, you can set the quantity of the
particles to be emitted in the viewport and on rendering. This rollout has two areas: Emitter

Icon and Quantity Multiplier. These areas are discussed next.

Emitter Ilcon Area

The options in this area are used to specify the size and shape of the Particle Flow icon. The

options in the Emitter Icon area are discussed next.

Logo Size

The Logo Size spinner is used to specify the size of the Particle Flow logo.
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Icon Type Emission
The options in this drop-down list are used to specify the basic —Emitter Icon:
geometry of the source icon. By default, the Rectangle is Logo Size: [39.196 | 2
selected in this drop-down list. The other options in this ronTypei[pox  ~
drop-down list are Box, Circle, and Sphere. The options ength: [5 |
displayed below this drop-down list change according to the Width: [0 2|
option selected in it. For example, if you select the Box option Height: [0 2|
from the Icon Type drop-down list, then the Height spinner Show: ¥ Logo ¥ Tcon
below the Width spinner will be activated, refer to Figure 17-4. e

Viewport %[50.0 | 2]
Length Render %[100.0 | 2

The Length spinner is used to specify the length of the icon.
This spinner is available only if you select the Rectangle or Figure 17-4 The Emission
Box option from the Icon Type drop-down list. If the Circle ;. .

or Sphere option is selected from the Icon Type drop-down

list, the Diameter spinner will be displayed wherein you can

specify the diameter of the Circle or Sphere.

Width
The Width spinner is used to specify the width of the icon. This spinner will be available
only if you select the Rectangle or Box option from the Icon Type drop-down list.

Height
This spinner is activated only if the Box option is selected in the Icon Type drop-down
list and is used to specity the height of the icon.

Show

This group consists of two check boxes: Logo and Icon. By default, both are selected, and
therefore, the icon and logo is displayed in the viewport. On clearing the Logo check box,
the logo will be hidden in the viewport and on clearing the Icon check box, the geometry
of the icon will be hidden in the viewport. This option affects only the viewport display
but not the particle system.

Quantity Multiplier Area

The options in this area are used to specify the percentage of the particles that will be displayed in
the viewports and on rendering. This area has two spinners: Viewports % and Render %. These
spinners are discussed next.

Viewport %
This spinner is used to set the percentage of total number of particles displayed in the
viewport. By default, its value is 50.0 but can range from 0.0 to 10000.0.

Render %
This spinner is used to set the percentage of total number of particles displayed while
rendering. By default, its value is 100.0 but can range from 0.0 to 10000.0.
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Selection Rollout

The options in this rollout are used to select particles in the
viewport. This rollout has sub-object levels and areas: Select by
Particle ID, Get From Event Level, and Select by Event, refer to
Figure 17-5. These are discussed next.

Sub-object Level

There are two sub-object levels of the PF Source tool: Particle and
Event. To select the Particle and Event sub-object levels, press 1
and 2, respectively.

Particle Sub-object Level
This sub-object level is used to select the particles and

regions in the viewport.
Event Sub-object Level

This sub-object level is used to select all the particles in

a particular event.

Select by Particle ID Area

- Selecton .
35

r Sadact by Partice ID: ———

o [ add ]

[ Clear Salection [Ramave]

[ GetFromEventleval |

r Selact by Bvant:
Event 001

47 Partides

Figure 17-5 The Selection
rollout

The options in this area are used to add and remove the particles from the viewport by using
their IDs. Each particle has a unique ID number. The options in this area are activated when

you select the Particle sub-object level.

The ID spinner is used to select a particle by using its assigned ID number. You can select

only one ID number at a time.

Add

This button is used to add a particle to the selection by specifing the ID number in the

ID spinner

Remove

This button is used to remove the particle with the specified ID.

Clear Selection

This check box is used to clear all the particles from the viewport except the particles
with the ID specified in the ID spinner. You need to choose the Add button to view the

particle with the specified ID in the viewport.

Get From Event Level

The Get From Event Level button is used to convert the selection of an Event sub-object level
to the Particle sub-object level. This button is enabled only when the Particle sub-object level

is selected.
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Select by Event Area
This area is used to display all events in a flow and highlights the event list of the selected
flow of the particles.

Note
The number of particles selected in the viewport is displayed at the bottom of the Select by
Event area.

System Management Rollout
The options in this rollout are used to define the upper limit of the - SystemManagement |
number of particles to be emitted in a system and determine the |-Partice Amount:

overall accuracy of the Particle Flow in the viewport and while || Uppertimit: [150000__|f]
rendering. This rollout has two areas: Particle Amount and | o ion siep:

Integration Step, refer to Figure 17-6. These areas are discussed viewport: [Frame ]

Particle Amount Area Figure 17-6 The System

The option in this area is used to define the amount of particles to be
emitted in the viewport and render. This area consists of the Upper
Limit spinner. This spinner is discussed next.

Management rollout

Upper Limit

This spinner is used to define the maximum number of particles to be emitted in a
Particle Flow system. By default, the Upper Limit spinner is set to 100,000 and it ranges
from 0 to 1,00,00,000. You should avoid using large values in the Upper Limit spinner
as it results in poor system performance.

Integration Step Area

In this area, the Particle Flow updates the particle system at every integration step by applying
action to the particles in its event. This area has two drop-down lists: Viewport and Render.
These are discussed next.

Viewport

The various options in this drop-down list are used to define the integration step for
animation playback in the viewports. By default, the Frame option is selected, which
specifies one calculation per animation frame. The other options available in this
drop-down list are Half Frame, 1/4 Frame, and 1/8 Frame.

Render

The options in this drop-down list are used to define the integration step at render time.
By default, the Half Frame option is selected, which is two calculations per animation
frame. The other options available in this drop-down list are Frame, 1/4 Frame, 1/8
Frame, 8 Ticks, 4 Ticks, 2 Ticks, and 1 Tick. There are 4,800 ticks in a second, which
means that according to NTSC video rate of 30 frames per second, there will be 160 ticks
per frame.
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; Note

@ If the behavior of particles in the viewport fails to match with that of the render. It happens

— due to the difference in the options selected in the Viewport drop-down list and the Render
drop-down list in the Integration Step area. Set same value in the Viewport and Render
drop-down lists in the Integration Step area to make particles behave in the same manner in
the viewport as well as in rendering.

Script Rollout

The options in this rollout are used to run a script for the particle system at every integration
step or after each frame’s final integration step. This rollout has two areas: Every Step Update
and Final Step Update, as shown in Figure 17-7. These areas are discussed next.

Every Step Update Area
The options in this area are used to examine the script at the end of [ ERIIEEGSSENNN,
each integration step. This can be done only if all the actions and |[Eery StepUpdate:
events have been calculated and the particles have reached their || L Enable Seript

respective places. ||:| Use Saript Fike |
None

The Every Step Update script is used to set up history-dependent |rFinal Step Update:
properties of the particle such as speed, spin, and so on. With || O enable seript | Edit
history-dependent properties, it is necessary to calculate the script at || [ Use SaiptFie

every integration step. | None |

This area has two check boxes: Enable Script and Use Script File, Figure 17-7 The Script
and two buttons, namely Edit and None. rollout

Enable Script

The Enable Script check box in this area when selected runs a script in memory at each
integration step. By default, a script is carried out which defines the particle speed and
direction, and guides the particles to move in a wavy path. To invoke the script, choose
the Edit button next to the Enable Script check box. Note, you need to choose the Enable
Script check box to activate the Edit button.

Edit

This button is used to invoke the MAXScript Editor window with the default script namely
the Every Step Update Script. You can edit this script. By default, the Use Script File
check box is cleared. So, when you choose the Edit button, the PF Source 001: Every Step
Update Script window will be invoked, refer to Figure 17-8. If the Use Script File check
box is selected and you choose Edit button, the Open File dialog box will be displayed,
refer to Figure 17-9.

Use Script File
The Use Script File check box in this area is used to run a loaded script file from the drive.
To load this file, you need to choose the None button below the Use Script File check box.



17-8 Autodesk 3ds Max 2015: A Comprehensive Guide

None

When you choose this button, the Open dialog box is displayed. Navigate to the desired
location and select the script. After loading the script, the name of the script file appears
in place of the None button. You can also modify the loaded script.

3 o s |
File Edit Search Debugger Help
-- This is a script that can be used to update particle speed at each
-- integration step
-- Created: 5-21-2002
-- Last Updated: 2-18-2003

-- Author : Oleg Bayborodin
-- Version: 3ds max 5.1

-- MODIFY THIS AT YOUR OWN RISK

pf_node_current = particleFlow.scriptRunner() -- current particle system
if (pf_node_current != undefined) then
{

count = pf_node_current.NumParticles()
foriin 1 to count do

pf_node_current.particlelndex =i
age = 5*pf_node_current.particleAge
pf_node_current.particleSpeed = [0.05%cos(age), 0.05*sin{age), -0.05]
)
)

El P—— '

Figure 17-8 The PF Source 001: Every Step Update Script window

> =
C:\Users\CADCIM\Documents\3dsmax20 14w folder -
S -
& Name = Date modified Type Size
z’.-j' | Workspaces 42/2013350PM  File folder
Recent Places
Desktop
Libraries
Computer
Network
4 LU *
| =
Scrpt files (~ms.“mer) -

Figurel7-9 The Open File dialog box
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Final Step Update Area

The options in this area are used to examine each frame in the viewport or in the render
output after the last integration step has taken place. The Final Step Update script is used to
set up history-independent properties. The options in this area are discussed next.

Enable Script

The Enable Script check box in this area, when selected, runs a script in memory after
the last integration step. This script defines the particle speed and direction and guides
the particles to move in a bulb-shaped path. To invoke the script, choose the Edit button
next to the Enable Script check box. You need to choose the Enable Script check box to
activate the Edit button.

Edit

This button is used to invoke the MAXScript Editor window with the default script, the
Final Step Update Script. You can also make changes in the Final Step Update Script
window. By default, the Use Script File check box is clear. So when you choose the Edit
button, the PF Source 001: Final Step Update Script window will be invoked, refer to
Figure 17-10. If the Use Script File check box is selected and you choose the Edit button,
the Open File dialog box will be displayed, refer to Figure 17-9.

|® PF Source 001: Final Step Update Script =n E=R(E==)

File Edit Search Debugger Help

-- This is a script that can be used to update particle position at final
-- integration step

-- Created 5-21-2002
-- Last Updated

- Autl Oleg Bayborodin

n: 3ds max 5.1

-- MODIFY THIS AT YOUR OQWN RISK

pf_node_current = particleFlow.scriptRunner() -- current particle system
if (pf_node_current != undefined) then

count = pf_node_current.NumParticles()

foriin 1 to count do

nt.particlePosition = [factor*cos(77%i), factor*sin(77*i), -age] + pf_node_current.pos

] I »

Figure 17-10 The PF Source 001: Final Step Update Script window

Use Script File

The Use Script File check box in this area when selected runs a loaded script file from
the respective drive. To load the script file, you need to choose the None button below
the Use Script File check box.

None

The None button in the Every Step Update area is used to invoke the Open dialog box.
Navigate to the desired location and select the script. You can also modify the loaded script.
After you load a script, the name of the script file appears in the place of the None button.
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PARTICLE VIEW WINDOW

Command Panel: Create > Geometry > Particle Systems >
Object Type rollout > PF Source > Setup rollout > Particle View

Keyboard: 6

The Particle View window is the main interface used for setting up a particle system. To open
the Particle View window, choose Create > Geometry > Particle Systems > Object Type >
PF Source tool from the Command Panel. In the Top viewport, press and hold the left mouse
button, drag the cursor diagonally, and then release the left mouse button; an emitter will be
created and various rollouts will be displayed in the Command Panel. Next, right-click to exit
the tool. In the Setup rollout, choose the Particle View button; the Particle View window will
be displayed, as shown in Figure 17-11.

Menubar Event display Parameters Panel
|
(5] Particle Viep = |EEE |
I Edit Select "Display Options Tools |
* | eSO
PF Source 001 & EmitStart: [O___ ||
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Figure 17-11 The Particle View window

The Particle View window consists of different components, namely Menu Bar, Event
Display area, Depot area, Parameters panel, Description panel and Display tools, refer to
Figure 17-11. These components are discussed next.
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Menu Bar
The menu bar is located at the top of the Particle View window and it contains various
pull-down menus. These pull-down menus are Edit, Select, Display, Options, and Tools.

Event Display Area

The main area in the Particle View window is the Event P Source 091 G |
Display area. This area consists of event diagrams that =
defines the Particle Flow. The Particle Flow consists of global riener 601 (Gean=ind >
and local events wired together. Events contain multiple
operators and tests known as actions. The global event
represents PF Source and affects the entire Particle Flow. Event 001 G ~ |
The local event affects only the particles in the current @ enn oo @0 — N
event. The operators are used to manage particle Pasition Ica Append b
parameters and the tests are used to determine the Speed 001
movement of particles related to events. On right-clicking [G3] Rotstion 00 furn On
an action or an event in the Event Display area, a shortcut [ shae o ::1”: OJF.
menu containing various options will be displayed, refer ety 01 W_a e Unique
to Figure 17-12. The functions of these options depend on "
where you click or what is highlighted, or both. The most Delete
commonly used options are discussed next. Renarme
Cornrnernts..,
Insert :
Lay Out Children

The Insert option is used to insert the selected action to
the point you right-click on. This option is available only - Figure 17-12 The shortcut menu
when you right-click over an event or an action.

If you right-click on an action and then insert an action, the inserted action replaces the old
one. If you right-click above or below an action, the new action is added to the event at that
location. If you right-click over an event, the action is inserted at the first available position.

Append
The Append option is used to insert the selected action at the end of the event. This option
is available only when you right-click over an event or an action.

Turn On
The Turn on option is used to turn on the event or action.

Turn Off

The Turn off option is used to turn off the event or action

Parameters Panel

The Parameters panel is used to edit the parameters of the actions in the Particle View
window. It consists of different rollouts, spinners, drop-down lists, and radio buttons. This
panel appears on the right side of the Particle View window. If the Parameters panel is not
visible, activate it by choosing the Parameters option in the Display menu.
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Display Tools
The Display tools are located at the bottom-right corner of the [ Display | Options  Tools
Particle View window. These tools are used to pan and zoom Pan Tool
the Event Display area. Note that these tools are also present Zoom Tool
in the Display menu of the menu bar in the Particle View Zoom Regicn Tool
window, refer to Figure 17-13. These tools are discussed next. Zoorm Extents
No Zoom
Pan Tool miE
. . . arameters
n This tool is used to move around the Event Display area. 7| Depot
When you choose this tool, the mouse cursor changes .
¥ Description

into a hand icon. You can also pan in the Event Display
area by holding and dragging the middle mouse button. To Figure 17-13 The Display tools
deactivate this tool, choose the Pan tool once again from the in the Display menu
Display tools set or right-click in the Event Display area.

Zoom Tool

This tool is used to zoom in and out the Event Display area. When you choose this tool,
the shape of the cursor changes to a magnifying-glass icon. You can zoom in and out the
Event Display area by dragging the middle mouse button upward or downward. To
deactivate this tool, choose the Zoom tool once again from the Display tools set or right-click
in the Event Display area.

Zoom Region Tool

E This tool is used to zoom a particular region in the Event Display area. When you choose
this tool, the shape of the cursor changes to the image of a magnifying glass in a zoom
region. Choose this tool and press and hold the left mouse button. Next, drag the cursor

in the Event Display area, particularly on the region that you want to zoom in. To deactivate

this tool, choose the Zoom Region tool once again from the Display tools set or right-click in

the Event Display area.

Zoom Extents
- This tool is used to zoom the entire Particle Flow in the Event Display area.

No Zoom
E This tool is used to zoom the entire Particle Flow to the default value in the Event
Display area.

Depot

The Depot area is used to store the Particle Flow actions. If the Depot area is not visible, activate
it by choosing the Depot option from the Display menu. It is like a library, which stores Particle
Flow actions: Flow, Operator, and Test, refer to Figure 17-14. Drag these actions from the
Depot area to the Event Display area to build particle system setup.
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Figure 17-14 The Depot area with Particle Flow actions

Description Panel

The Description panel is used to display the description of the actions, when selected in
the Depot area. The Description panel is located at the right side of the Depot area in the
Particle View. If the Description panel is not visible, activate it by choosing the Description
option from the Display menu.

CREATING PARTICLE FLOW DIAGRAM

A Particle Flow diagram is like a flowchart that represents the process of Particle Flow with
the help of steps and their order.

To create the Particle Flow diagram in the Event Display area, press and hold the left mouse
button on Standard Flow in the Depot area and then drag it in the Event Display area; a
Particle Flow diagram will be created in the Event Display area. The actions in the Particle
Flow diagram consists of operators and tests.

To create a new event in the Event Display area, press and hold the left mouse button on the
operator in the Depot area and then drag and drop it on the Event Display area. You can
replace an existing operator in the event or append a new one. To replace an existing operator
with the new one, press and hold the left mouse button on the new operator in the Depot area
and then drag the cursor to the operator that needs to be replaced; a red line will appear on
the operator in the event and the new operator will replace the existing operator. To append
a new operator in the event, press and hold the left mouse button on the new operator in
the Depot area and then drag the cursor below the operator where you need to add the new
operator; a blue line will appear on the operator in the event and the new operator will be
added to the event.

If you drag an action to an existing event, it will be added to the existing event and will function
depending on whether a red line or a blue line appears when you drop it on the event. If a
red line appears, the new action will replace the underlying action. If a blue line appears, the
action will be added to the list.

Choose an action in the event to edit its parameters in the Particle View window. The
Parameters panel appear on the right side in the Particle View window. If the Parameters
panel is not visible, choose the Parameters option from the Display menu.
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A test can be wired to an event in the Event Display area by dragging the gray dot, that is at
the left of the test into the event input. You can also wire the global event to the local event by
connecting the source output on the bottom of the global event to the event input.

MANIPULATING ACTIONS AND EVENTS

The events and actions can be toggled, copied, moved, and deleted in the Event E
Display area by using the options in the shortcut menu. Choose the bulb icon next to

the event name in the title bar and click to toggle an event. When you deactivate an

event, its operators and tests are also deactivated. The event items do not affect the particle
system and appear gray in the event list. The Particle Flow will pass to the downstream event
if the above event is deactivated.

Choose the operator icon in the event and click to toggle the operator. If the operator is
inactive, it will not affect the particle system and will appear gray in the event list. If you toggle
an instanced operator, it will not affect its other instance operator.

Choose the test icon and click either on the left or right side of it to make a test result true or
false. The test icon changes to green check mark for true, and to red cross for false.

Choose the colored circle at the right of the Display operator and click to change Particle’s
color using the Color Selector: Display XXX dialog box displayed.

To copy an action or event, select it and press and hold

SHIFT; the shape of the cursor will change. Next, drag the # Clone Optiens =
item to a new location in the Event Dlsplay‘ area. When you e
release the mouse button, the Clone Options dialog box a0 .
. . . . opy Instance
will be displayed, refer to Figure 17-15. Select the desired
radio button in the Operator and Test area and choose the ~ Action List and Partide System
OK button. In the Clone Options dialog box, the Action ) Copy ¢ Instance
List and Particle System area is not active, as shown in
Figure 17-15. All instanced actions or events have same = | Cancel |
properties. If you change the value of one instance item,

the value of other instance also changes. For example, when

you select an instanced item in the Event Display area, all  Figure 17-15 The Clone Options
of its other instances will be highlighted in a light gray color. ~ dialog box

Copied actions can have different properties. Even if you

change the value of one copied item it does not affect the value of the other copied item.

If you want to select multiple items in an event in the Event Display area, drag the cursor on
them, or press and hold CTRL and select them one by one. To move the event or an action
in the Event Display area, drag the title bar of an event or the icon of any action. You can
also scale the width of an event by placing the cursor on its right edge and then dragging it
toward left or right. If you want to move an event or an action to a new location, select it and
then move it anywhere in the Event Display area. When you drag an event to a new location,
the Display operator will automatically move with the event. If you want to delete an event,
action, or wire, select it in the Event Display area and press DEL.
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UNDERSTANDING PARTICLE FLOW ACTIONS

The Depot area has a library, which stores the Particle Flow actions. These actions are Flow,
Operators, Tests, and mParticles and are discussed next.

Flow

The Flow is a set of actions used to create different types of particle system setups in the initial
stage of the Particle Flow. To use a flow, select and drag it from the Depot area to the Event
Display area. There are different kinds of flows: Preset Flow, Empty Flow, Standard Flow,
and One click Flow. These flows are discussed next.

Preset Flow
Preset Flow is used to merge the previously saved Particle Flow

'

setup to the current scene. Choose the Preset Flow action ¥ Select Preset Flow [=]
and drag it to the Event Display area; the Select Preset Flow ~Presets:
dialog box will be displayed, refer to Figure 17-16. The Select TElE RO -
. air_Bubbles Bursting

Preset Flow dialog box has a set of parameters where you air_Car Dust |
define the lists of the current presets in the system and displays ::::E:ﬂﬂ;esm smoke 1
the description for the selected preset. If you have any Particle arr_Dandefons

K K K ) A air_Dark Clouds
Flow setup, it will be displayed in the Presets area of this air_Dust Devi

air_Fire Flies
air_Flocking Birds Formation
air_FT Reassemble

dialog box. If you want to use any setup, select it from the

Presets area of this dialog box and then choose the OK button;
the Duplicate Name dialog box will be displayed, refer to
Figure 17-17. The options in the Duplicate Name dialog box

air_Galaxy Explosion
air_Helicopter Wash
air_Lights Attach
air_Magic Dust

air_Object Reassemble

are used to merge a previously saved Particle Flow setup to air_Pushpul
the selected scene. The merged flow can be used as an event air_snow Settle
o K . X earth_Animal Crowds
within the current flow or as a starting point for a new particle earth_Ants
earth_Arrows Many
system. earth Arrows Targets S
—Preset Description:
Empty Flow

Empty Flow is used to create the initial stage for the particle
system in the Event Display area. Empty Flow consists of
a single global event, which further contains the Render
operator. To create the initial stage for the particle system,
press and hold the left mouse button on Empty Flow and ok | Cancel |
then drag it to the particle system in the Event Display area.
Next, choose PF Source 001 in the Event Display area, Figure 17-16 The Select Preset
various rolloqu will be displayed on the right side of the Evept Flow dialog box

Display area in the Parameters panel. Here you can specify

the properties of the flow. These rollouts are same as those

of the PF Source particle system rollouts that have been discussed earlier.
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Duplicate Mame

Object PF Source 001 has the same name as an object in the scene,

sy o e
Delete Old

Figure 17-17 The Duplicate Name dialog box

Standard Flow

Standard Flow is used to create the initial stage of the Particle System where the global event
is wired to the local event. The global event consists of the Render operator and the local
event consist of the Birth, Position, Speed, Rotation, Shape, and Display operators. Press
and hold the left mouse button on Standard Flow and then drag the cursor to the particle
system in the Event Display area. When you choose Standard Flow in the Event Display
area, various rollouts will be displayed in the Parameters panel. Standard Flow has the same
operators that are created while adding the PF source icon to the viewport.

One Click Flow

One Click Flow is used to create the initial stage for the particle system using the Maya
nCache files from the cache memory. It has a set of operators such as Birth File, Material
Static, Shape, and Display. Press and hold the left mouse button on One Click Flow and
then drag the cursor to the particle system in the Event Display area. Choose the Birth File
operator from the flow and then choose the Select File button from the Parameters panel;
the Open dialog box will be displayed. The options in this dialog box are used to import the
Maya nCache files.

Operators

The operators are Particle Flow actions that are used to manage particle parameters such as
scale, speed, rotation, and shape. When combining the operators to the events, the attributes
of particles are defined over a given period of time. Drag the operator to the particle system
in the Event Display area to combine it with the event. There are two groups of operators in
the Depot area. The operator icons are usually blue in color. However, the Birth operators has
green colored icons. The first group contains operators such as Birth, Rotation, Spin, Scale,
and so on. These operators directly affect the particle behavior, such as birth rate, life span,
rotation, scale, and so on. The second group contains utility operators such as Cache, Display,
Notes, Render, and so on. The operators of both theses groups are discussed next.

Birth

The Birth operator is used to create particles within the Particle Flow system. The Birth
operator is the first operator in every event that is connected to the global event. It is always
at the beginning of the local event. If the Birth operator is positioned anywhere in the Event
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Display area, the Particle System does not connect it with other items in the Event Display area.
The Birth operator cannot be inserted in a local event that already has a Birth operator. You
can wire multiple Birth operators if they are in multiple parallel events in the Particle Flow.

Birth Paint

The Birth Paint operator is used to create particles with the Particle Paint helper. To do
so, choose Create > Helpers in the Command Panel. Next, select Particle Flow from the
drop-down list located below it and then choose the Particle Paint tool from the Object Type
rollout. Now, drag the cursor in the viewport, the Particle Paint helper will be displayed,
as shown in Figure 17-18. The Particle Paint helper places particle seeds on an object with
the defined pattern and timing. The Birth Paint operator creates particles from these seeds
by setting parameters in the Birth Paint rollout, which defines particle position, rotation,
mapping, and selection status.

Birth Script

The Birth Script operator is used to create particles within the Particle Flow system using the
Birth Script in the MAXScript Editor window.

Birth Texture

The Birth Texture operator is used to create particles from the animated texture by calculating
the time, location, and scale of the particles. The texture applied to the object should be white
or of a brighter color to create the particles.

To work with the Birth Texture operator, press and hold the left mouse button on the Birth
Texture operator and then drag the cursor to the Birth operator in the event in the Event
Display area. Next, replace the Birth operator with the Birth Texture operator of the particle
system in the Event Display area. On doing so, the Birth Texture icon is created in the
viewport, refer to Figure 17-19.

[+1[Top] [Wireframe ] [+]1[Top] [Wireframe ]

(]
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Figure 17-18 The Particle Paint helper Figure 17-19 The Birth Texture icon

Initial State
The Initial State operator is used to define the initial stage for a new event. It uses the snapshot
of another particle system or other events as a starting point.

Camera Culling
The Camera Culling operator is used to reduce the geometry load in the viewports and in
rendering by filtering out all particles outside the camera frustum.
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Camera IMBlur
The Camera IMBlur operator is used to adjust the particle speed before passing the data for
image motion blur in the displayed viewport or renderer.

Delete
The Delete operator is used to delete or remove particles from the particle system once their
function in the animation is completed.

Force

The Force operator is used to control the motion of particle to simulate the effects of wind,
gravity, and other effects. The forces which simulate effects with the Force operator are
Displace, Drag, Gravity, Motor, PBomb, Push, Vortex, and Wind.

Group Operator

The Group Operator operator is used to link an external event to the Particle Flow diagram
specified by one or more Group Selection operators. The Group Operator operator can
be added to an event that has to be linked with the Particle Flow but the particles are not
separated from the event.

Group Selection
The Group Selection operator is used to specify any number of groups of particle according
to the location, age, speed, and size of the particle.

To work with the Group Selection operator, press and hold the left mouse button on the Group
Selection operator and then drag the cursor to the Event Display area. This creates the Group

Selection icon in the viewport, refer to Figure 17-20. Alternatively, the Group Select tool can
also be chosen from Create > Helpers > Particle Flow in the Command Panel.

[+]1[Top] [Wireframe ]
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Figure 17-20 The Group Selection icon

Keep Apart
The Keep Apart operator is used to apply the forces to particles so that they are separated and
do not collide with each other. The particles are controlled by speed and acceleration values.
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Mapping
The Mapping operator is used to attach the UVW mapping to the entire surface of the
particles.

Mapping Object
The Mapping Object operator is used to assign maps to the particles by using mapping values
of the nearest reference objects from the particles.

Material Dynamic

The Material Dynamic operator is used to assign the material IDs to the particles that can
change during the event. It also assigns a different material to the particles based on their
material IDs.

Material Frequency
The Material Frequency operator is used to assign material to the particles in an event by
distributing the relative frequency of each sub-material that appears on the particles.

Material Static
The Material Static operator is used to assign material to the particles that remain constant
throughout the event.

Placement Paint
The Placement Paint operator is used to define the position, rotation, and mapping of the
particles with the help of the Particle Paint helper.

Position Icon
The Position Icon operator is used to define the initial position of the particles to be emitted
from the emitter.

Position Object
The Position Object operator is used to emit the particles from any other object or objects
in the scene.

Rotation

The Rotation operator is used to rotate the particles. The rotation of the particle can be static
or dynamic. The static rotation is applied once when the particle enters the Rotation operator.
In the dynamic rotation, the rotation value changes according to the change in Particle Flow
item rotation over a period of time.

Scale
The Scale operator is used to scale the size of the particles during an event.

Script Operator
The Script Operator operator is used to modify the properties of particles within the Particle
Flow system using MAXScript.
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Shape

The Shape operator is used to define the 2D and 3D shapes of the particles in the viewport
and in the render. The shape of the particles can have any form such as geometric primitives,
alphanumeric characters, and musical notes.

Shape Facing
The Shape Facing operator is used to create particles in a simple square polygon shape that
has mapping coordinates and are oriented toward the camera, the viewport, or the object.

Shape Instance

The Shape Instance operator is used to create the particles as the instances of a reference
object in the scene. The reference object’s animation can be synchronized with the particle
events.

Shape Mark
The Shape Mark operator is used to create the particles of rectangular or box shape, when it
comes in contact with another object in the scene.

Speed

The Speed operator is used to specify the speed of the particles and their direction. When you
create a new flow in the Event Display area, this operator is there in the first event by default.
The position and orientation of the Particle Flow icon controls the direction of movement of
the particles.

Speed By Icon
The Speed By Icon operator is used to define a non-rendering icon that controls the particle
speed and direction.

Speed by Surface

The Speed By Surface operator is used to specify the speed and direction of the particles
with objects in the scene. The Speed By Surface operator also provides options that are used
to control the speed by materials.

Spin

The Spin operator is used to spin the particles in an event.

Stop

The Stop operator is used to halt the movement and spinning of the particles immediately.

Cache
The Cache operator is used to record and store particle states in the system memory for faster
playback. This is particularly useful with large or complex Particle Systems.

Cache Disk
The Cache Disk operator is used to store the cache in a disk file separately from the Max file.
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Cache Selective
The Cache Selective operator is used to store the cache like the Cache operator. However,
you can exclude certain types of data from the cache.

Display

The Display operator is used to control the appearance of the particles in the viewports.

Notes
The Notes operator is used to add a comment to an event.

Render

The Render operator is used to control the rendering of the particles. It controls the form that
particles will take on rendering. It also controls the conversion of the particles to individual
mesh objects for rendering purpose.

Tests

The tests in the Particle Flow are used to determine whether particles satisty one or more
conditions. If particles satisty a particular condition, then they are sent to another event. When
a particle passes a test, it is called as test true. The qualified particles are passed to another
event by wiring the test to the event. If the particles don’t pass the test, then the test is called
test false. The Particles will remain in the event and will go through the conditions repeatedly
until they pass the condition and qualifies for the next event. If the test is not wired to another
event, all the particles remain in the existing event. There can be several tests in an event.
The first test checks all the particles in the event and the remaining test functions only when
they qualify the given tests. Some of the tests also function as operators if they are not wired
to any other event.

All the tests are grouped together in the Depot area in the Particle View window and are listed
in an alphabetical order. These tests are discussed next.

Age Test

The Age Test test is used to specify the age limit of particles in an event.

Collision
The Collision test is used to detect the collision of particles with one or more deflectors. It
also determines the speed of the particle when they collide with the deflectors.

Collision Spawn
The Collision Spawn test is used to create new particles from existing ones, which collide
with one or more deflectors.

Copy Out
The Copy Out test is used to make one or more copies of each particle and then send them
to the next event. It is similar to the Spawn test, which is discussed later in the chapter.
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Find Target
The Find Target test is used to send particles to a specified target. When the particles reach
the target, they are transferred to the event which is wired to the Find Target test.

Go To Rotation
The Go To Rotation test is used to test the smooth transition in the current rotation value of
the particle to the value specified by the next rotation operator.

Lock/Bond
The Lock/Bond test is used to lock the particles to the objects and keep them locked even
when the object animates.

Scale Test
The Scale Test is used to test the particle scaling.

Script Test
The Script Test is used to test particle conditions using MAXScript.

Send Out

The Send Out test is used to send all particles to the next event if the test is true or retain all
the particles in the current event if the test is false.

Spawn

The Spawn test is used to create new particles from the existing ones. The spawned particle
has the same position, orientation, and the shape as that of its parent particle. It gives particle
a different speed and scaling factor.

Speed Test

The Speed Test is used to check the speed, acceleration, or rate of circular travel of the particles.

Split Amount
The Split Amount test is used to send the specific number of particles to the next event and
keep all remaining particles in the current event.

Split Selected

The Split Selected test is used to split the particles according to the particle’s selection
status.

Split Source

The Split Source test is used to split the particles according to their parent particle.

Stop Gradually
The Stop Gradually test is used to slow down the linear and rotational speed of the particles
and then stop them gradually. When the test stops the particles are sent to the next event.



Particle Flow 17-23

mParticles

The mParticles provide flexibility to the standard Particle Flow system. With the help of
the MassFX simulation, the mParticles can be used to create more refined, realistic physics
simulations, and real-world effects such as storm, wind, rain, hail, and so on. It also bind
particles together and creates collision between particles and other objects.

All the mParticles actions are grouped together in the Depot area in the Particle View window.
These are discussed next.

mParticles Flow

The mParticles Flow is used to create a simple Particle Flow setup that is wired to a MassFX
simulation. To view the simulation, choose the Play Animation button from the time control
tools.

Birth Grid
The Birth Grid operator is used to create particles and place them in a grid like structure as
a volume.

Birth Group

The Birth Group operator is used to create particles from a reference object. The particle will
emit from the reference object and also inherit the position and orientation of the reference
object.

Birth Stream

The Birth Stream operator is used to create particles and defines their positions and speed.

mP Buoyancy
The mP Buoyancy operator is used to simulate the behavior of particles in a liquid. A particle
rises and sinks in the liquid depending on the relative densities of the particle and the liquid.

mP Drag
The mP Drag operator is used to slow down the simulation of the particles by applying the
mParticles Force operator.

mP Force
The mP Force operator is used to define the forces that influence the particles during
simulation.

mP Shape
The mP Shape operator is used to specify the particle shape required for collision during
simulation.

mP Solvent
The mP Solvent operator is used to remove bindings created by the mParticles Glue test.
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mP Switch
The mP Switch operator is used to control the adjustment of simulation animation by defining
events containing this operator as kinematic as opposed to dynamic.

mP World

The mP World operator is used to connect the particles of the current event to a specific
simulation world as a helper in the scene. After you make the connection, that helper’s settings
affect all particles in the event.

mP Collision
The mP Collision test is used to create collisions between particles and standard objects
applied with the PFlow Collision Shape (WSM) Modifier.

mP Glue

The mParticles Glue test is used to bind the particles to each other.

mP InterCollision
The mP InterCollision test is used to track interparticle collision and send particles to other
events based on the collision information.

TUTORIALS

Before starting the tutorials, you need to download the ¢17_3dsmax_2015_tut.zip file
from wwuw.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual
Effects > 3ds Max > Autodesk 3ds Max 2015: A Comprehensive Guide

Extract the contents of the zipped file and save them in the Documents folder.

Tutorial 1

In this tutorial, you will create a scene with sandman dispersing in sand, as shown in
Figure 17-21. (Expected time: 35 min)

The following steps are required to complete this tutorial:

Create the project folder.

Open the file.

Create the Particle Flow source.

Add operator to the Standard Flow.
Create an SDeflector.

Animate SDeflector space warp icon.
Create a new event.

Create forces for the particles.

Add new operator and test to the Event.
Create deflector and collide particle with it.
Play the simulation.

Save and render the scene.

TETITITR e a0 o
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Figure 17-21 The sandman dispersing in sand

Creatmg the Project Folder
Create a project folder with the name ¢17_tut! at \Document|3dsmax2015, as discussed in
Tutorial 1 of Chapter 2.

2. Open the Windows Explorer and then browse to the ¢17_3dsmax_2015_tut folder. Next,
copy the desert_texture.jpg file from this folder to \Documents\3dsmax2015\c17_tutl\sceneassets\
images.

Openmg the File
Choose Open from the Application menu; the Open File dialog box is displayed. In
this dialog box, browse to the location \Documents\c17_3dsmax_2015_tut and select the
c17_tutl_start.max file from it. Choose the Open button to open the file, refer to
Figure 17-22.

.~~~ Note

\ @, When opening the start file, if the File Load: Gamma & Lut Settings Mismatch dialog box is

~ displayed, choose the Adopt the File’s Gamma & Lut Settings? radio button and then choose
the OK button. Also, if the File Load: Units Mismatch message box is displayed, choose the
OK button.
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Figure 17-22 The c17_tutl_start.max file displayed

2. Choose Save As from the Application menu; the Save File As dialog box is displayed.
Browse to the location |Documents\3dsmax2015\c¢17 tutl\scenes. Save the file with the
name ¢l 7tutl.max at this location.

Creating the Particle Flow Source
In this section, you will create a Particle Flow source using the PF Source tool.

1. Activate the Top viewport. Choose Create > Geometry in the Command Panel. Select
the Particle Systems option from the drop-down list below the Geometry button. Choose

the PF Source tool from the Object Type rollout; various rollouts are displayed in the
Command Panel.

2. In the Top viewport, press and hold the left mouse button and drag the cursor from one
point to another, and then release the left mouse button; the PF Source icon is created in
viewports for the PF Source Particle System, as shown in Figure 17-23.

[+1[Top] [Wireframe ]

Figure 17-23 The PF source icon
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3. Make sure the PF Source icon is selected in the viewport and choose the Modify tab in the
Command Panel; various rollouts are displayed. In the Emission rollout, set the value 5
in the Viewport % spinner in the Quantity Multiplier area.

Adding Operators in the Standard Flow

In this section, you will add operators to the Standard Flow in the Particle View window.

1.

Choose Graph Editors > Particle View from the menu bar;
the Particle View window is displayed. Alternatively,
press 6 to display this window. In the Event Display
area, the Standard Flow is displayed, as shown in
Figure 17-24.

Select the Birth 001 (0-30 T:200) operator in Event
001; the Birth 001 rollout is displayed on the right side
of the Event display area. Set the value 0 in the Emit
Stop spinner in the Birth 001 rollout. In the Amount
spinner, set the value 100000.

Press and hold the left mouse button on the Position
Object operator in the Depot area and then drag the
cursor to the Position Icon 001 (Volume) operator in
Event 001; a red line appears on the Position Icon 001
(Volume) operator. Next, release the left mouse button;

the Position Object 001 (None) operator replaces the

Position Icon 001 (Volume) operator.

Select the Position Object 001 (None) operator in
Event 001; the Position Object 001 rollout is displayed
on the right side of the Event display area. In this
rollout, select the Lock On Emitter and Animated
Shape check boxes. Next, in the Emitter Objects area,
choose the By List button; the Select Emitter Objects
dialog box is displayed. Select the Sandman_skin from
the list and choose the Select button; the Sandman_
skin is added to the Emitter Objects area, as shown
in Figure 17-25.

Delete the Speed 001 (Along Icon Arrow) and
Rotation 001 (Random 3D) operators from Event
001.

Select the Shape 001 (Cube 3D) operator in Event Figure 17-25

PF Source 001 &
|3 Render 001 (Geometry)

Event 001 &
Birth 001 (0-30 T:200)

1| Pesition lcon 001 (Wolume)
Speed 001 (Along lcon Arro...
Rotation 001 (Random 30
Shape 001 (Cube 30)

| Display 001 (Ticks)

Figure 17-24 The Standard Flow

- Positon Object001 |
Lock On Emitter
[ trbherit Emitter
Multigher % [100.0 ]
Variation % [0.0 ]
rEmitter Objects:
Sandman_skin

|.ﬂdd |B? List || Remaove |

Animated Shape
[ subframe Sampling

The Sandman_skin

001; the Shape 001 rollout is displayed on the right 77,70 the Emitter Objects area

side. In this rollout, select the Sphere 20-sides option
from the drop-down list on the right side of the 3D
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radio button. Next, set the value 1.5 in the Size spinner. Select the check box preceding
the Scale % spinner and set the value 40 in the spinner. Also, set the value to 10 in the
Variation % spinner and select the Generate Mapping Coords. check box.

In Event 001 of the Event Display area, right-click below the
Display 001 (Ticks) operator; a shortcut menu is displayed.
Choose Insert > Operator > Material Static from the shortcut
menu; the Material Static 001 (None) operator is inserted
below the Shape 001 (Sphere 20-sides 3D) operator.

[ Material Static 001 |
[v Assign Material
Character_Particle | ‘

[ Assign Material ID
I~ | Show In Viewport
Sub-M ID Offset: [0 2]

& Material 0 [1 =

" Cyde " Random

Select the Material Static 001 (None) operator in Event 001;
the Material Static 001 rollout is displayed on the right side

of the Event Display arca. Choose the None button below
the Assign Material check box; the Material/Map Browser
dialog box is displayed. In the Sample Slots rollout, select
Character_Particle ( Standard ) and choose the OK button;

#oubMaterials: o | =)
rRate:———
" Per Second: Wﬂ
# PerPartide; [10 2]

the Character_Particle label is displayed on the None button, W.Loop
as shown in Figure 17-26. ~Uniqueness:

Select the Display 001 (Ticks) operator in Event 001; the
Display 001 rollout is displayed on the right. In the Type
drop-down list, select the Geometry option.

Figure 17-26 The
Character_Particle label
displayed on the None button

Creating an SDeflector
In this section, you will create an SDeflector to collide with the particles.

1.

Make sure the Top viewport is activated. Choose Create > Space Warps in the Command
Panel. Select the Deflectors category from the drop-down list below the Space Warps
button. Next, choose the SDeflector tool from the Object Type rollout.

In the Top viewport, press and hold the left mouse button, drag the cursor from one
point to another and then release the left mouse button; the SDeflector space warp icon
is displayed in viewports.

Make sure the SDeflector space warp icon is selected. Next, choose the Modify tab in the
Command Panel and set the value 400 in the Diameter spinner in the Display Icon area
of the Basic Parameters rollout.

Animating SDeflector Space Warp Icon
In this section, you will animate SDeflector Space Warp icon such that the particles flow along
with the SDeflector Space Warp icon.

1.

Choose the Time Configuration button at the bottom of the Max interface; the Time
Configuration dialog box is displayed, as shown in Figure 17-27. In the Animation area
of this dialog box, set the value 250 in the End Time spinner and press the ENTER key;
the number of frames increases in the track bar. Choose the OK button to exit the dialog
box.
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Make sure the Top viewport is activated and select the SDeflector 001. Make sure frame
is set to 0 in the timeline and then choose the Toggle Auto Key Mode button to turn on
the animation mode.

Now, right-click on the Select and Move tool in the Main Toolbar; the Move Transform
Type-In dialog box is displayed. In the Absolute:World area, set the value 96.116 in the
X spinner, 41.498 in the Y spinner, and 336.499 in the Z spinner; the SDeflector 001 is
transformed to the set position.

Move the time slider to frame 60 by entering the frame number in the Current Frame
(Go to frame) spinner and choose the Set Keys button in the animation keying controls;
the same value is set at frame 60.

Move the time slider to frame 250 by entering the frame number in the Current Frame
(Go to frame) spinner and in the Absolute:World area of the Move Transform Type-In
dialog box, set the value 88.617 in the X spinner, 41.498 in the Y spinner and 167.648
in the Z spinner. Choose the Toggle Auto Key Mode button to turn off the animation
mode. Close the Move Transform Type-In dialog box.

In the Particle View window, right-click on the Display 001 (Geometry) operator; a
shortcut menu is displayed. Choose Append > Test > Collision from the shortcut menu;
the Collision 001 (None) test is added below the Display 001 (Geometry) operator.

Select the Collision 001 (None) test in Event 001; the Collision 001 rollout is displayed on
the right side of the Particle View window. In this rollout, choose the By List button in the
Deflectors area; the Select Deflectors dialog box is displayed. Select the SDeflector 001
from the list and choose the Select button; the SDeflector 001 is added to the Deflectors
area. Next, in the Test True If Particle area, select the Continue option from the Speed
drop-down list available below the Collides radio button.

Creating a New Event
In this section, you will create a new event so that the particles start emitting from the sandman
after the deflector collides with it.

1.

Drag the Speed By Surface operator from the Depot area to the Event Display area;
the Event 002 is added in the Event Display area and the Speed By Surface 001 (None)
operator is displayed in Event 002.

Select the Speed By Surface 001 (None) operator in Event 002; the Speed By Surface
001 rollout is displayed on the right of the Event Display area. In the Speed and Variation
spinners, set the values 310 and 28, respectively. Next, in the Surface Geometry area,
choose the By List button; the Select Surface Objects dialog box is displayed. Select the
Sandman_skin from the list and choose the Select button; the Sandman_skin is added
to the Surface Geometry area.

Now, connect the Collision 001 (SDeflector001) test to Event 002 in the Event Display
area by dragging the gray dot that is at the left of the test to the event input, as shown in
Figure 17-28.



17-30 Autodesk 3ds Max 2015: A Comprehensive Guide

PF Source 001 €&

Event 001 £2

=h¥) Collision 001 (SDeflectord0)

At Transform

9| Speed By Surface 001 (Sa...
'm| Display 002 (Ticks) L

Figure 17-27 The Time Configuration Figure 17-28 The Event 002 wired to the
dialog box Collision 001 test

Creating Forces for the Particles
In this section, you will create force to control the movement of the particles.

1.

Switch from the Top viewport to the Bottom viewport. Choose Create > Space Warps >
Forces in the Command Panel. Next, choose the Wind tool from the Object Type rollout
and then press and hold the left mouse button and drag the cursor in the Bottom viewport;
the wind space warp icon is displayed.

Choose the Modify tab in the Command Panel and set the values in the Parameters
rollout of the Wind001 space warp as follows:

Force area
Strength: 50

Wind area
Turbulence: 2 Scale: 3

Display area
Icon Size: 72

Switch from the Bottom viewport to the Top viewport and then choose the Zoom Extents
All tool to view Wind00I in the viewports.
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10.

Make sure Wind001 is selected. Now, right-click on the Select and Move tool from the Main
Toolbar; the Move Transform Type-In dialog box is displayed. In the Absolute:World
area, set the value 86.044 in the X spinner, 33.995 in the Y spinner, and 384.713 in the
Z spinner; Wind 001 is moved to the set position. Close the Move Transform Type-In
dialog box.

Next, you need to apply gravity to the particles using the Gravity space warp.

Choose Create > Space Warps > Forces rollout in the Command Panel. Choose the
Gravity tool from the Object Type rollout.

Press and hold the left mouse button and drag the cursor in the Top viewport; the Gravity
space warp icon is displayed with the name Gravity001.

Make sure Gravity001 is selected and right-click on the Select and Move tool from the Main
Toolbar; the Move Transform Type-In dialog box is invoked. In the Absolute:World area,
set the value 108.229 in the X spinner, 44.613 in the Y spinner, and 0 in the Z spinner;
Gravity001 is moved to the set position. Close the Move Transform Type-In dialog box.

Choose the Modify tab in the Command Panel and set the values in the Parameters
rollout of the Gravity space warp as follows:

Force area
Strength: 0.8

Display area
Icon Size: 41.0

Next, you need to connect the gravity and wind space warps to the Force operator.

In the Particle View window, right-click on the area between the Speed By Surface 001
(Sandman_skin) operator and the Display 002 (Ticks) operator; a shortcut menu is
displayed. Choose Insert > Operator > Force from the shortcut menu; the Force 001
operator is inserted below the Speed By Surface 001 (Sandman_skin) operator.

Select the Force 001 (None) operator in the Event 002; the Force 001 rollout is displayed
on the right in the Parameters panel. Next, in the Force Space Warps area, choose the By
List button; the Select Force Space Warps dialog box is displayed. Select the Gravity001
and Wind001 from the list and choose the Select button; the Gravity001 and Wind001
are added to the Force Space Warps area, as shown in Figure 17-29.
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Adding New Operator and Test to the Event B Force 001

In this section, you will add more operators and tests to Event002, | Feree SpaceWarps: 77 1
so that the particles are visible at render time. pratyont

1. Press and hold the left mouse button on the Shape operator in

the Depot area and then drag this operator to Event 002 below
the Force 001 (Gravity001 + 1) operator; a blue line appears
below the Force 001 operator. Next, release the left mouse
button; the Shape 002 (Cube 3D) operator is displayed below
the Force 001 (Gravity001 + 1) operator in Event 002 of the Influence % [1000.0 | 3|
Event Display area. - Offset Influence:

Sync By: IAbsqute v

Add |B'5|r List | Remaove

r~Force Field Overlapping:
@& Addiive ¢ Maximum

Select the Shape 002 (Cube 3D) operator in the Event 002; the
Shape 002 rollout is displayed on the right of the Particle View

window. In this rollout, select the Sphere 20-sides option from

the drop-down list on the right side of the 3D radio button.

Next, set the value 2 in the Size spinner. Select the check box

preceding the Scale % spinner and set the value 50 in the spinner. Set the value 20 in the
Variation % spinner and select the Generate Mapping Coords. check box.

Figure 17-29 The Force
001 rollout

Press and hold the left mouse button on the Material Static operator in the Depot area and
then drag the cursor on Event 002 below the Shape 002 (Sphere 20-sides 3D) operator;
a blue line appears below the Shape 002 (Sphere 20-sides 3D) operator. Next, release
the left mouse button; the Material Static 002 (None) operator is displayed below the
Shape 002 (Sphere 20-sides 3D) operator in Event 002 in the Event Display area.

Select the Material Static 002 (None) operator in Event 002; the Material Static 002
rollout is displayed on the right of the Event Display area. Choose the None button below
the Assign Material check box; the Material/Map Browser dialog box is displayed. In the
Sample Slots rollout, select Character_Particle (Standard) and choose the OK button;
the Character_Particle label is displayed on the None button.

Next, you need to add rotation, spin, and direction to the particles. To do so, you will add
the Rotation operator, the Spin operator, and the Split Amount test before the Material
Static (Character_Particle) operator.

Drag the Rotation operator from the Depot area to Event 002 below the Shape 002 (Sphere
20-sides 3D) operator as discussed in the above steps. Select the Rotation 001 (Random
3D) operator in the Event 002; the Rotation 001 rollout is displayed on the right. In the
drop-down list available in the Orientation Matrix area, select the World Space option.
Set the values in the X, Y, and Z spinners as -90, 90, and 1, respectively.

Now, drag the Spin operator from the Depot area to Event 002 below the Rotation 001
(World Space) operator as discussed in the above steps. Select the Spin 001 (Random 3D
360) operator in Event 002; the Spin 001 rollout is displayed on the right. In the Spin
Rate spinner, set 299, and in the Variation spinner, set 20. In the Spin Axis area, select
the Speed Space Follow option from the drop-down list. Now set the value of the X, Y,
and Z spinner to 1.
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Now, drag the Split Amount test from the Depot area to the Event 002 below the Spin 001
(Speed Follow 299 *+ 20) operator as discussed in the above steps, refer to Figure 17-30.
Select the Split Amount 001 (50%) test in Event 002; the Split Amount 001 rollout is
displayed on the right. In the Test True For area, select the Every Nth Particle radio
button and set the value 5 in the N spinner located below it.

Creating Deflector and Colliding the Particles
In this section, you will create a deflector to prevent the particles moving beneath the

ground.
1. Make sure the Top viewport is activated. Make sure that FL P

Create > Space Warps is chosen in the Command Panel.
Select the Deflectors option from the drop-down list
below the Space Warps button. Next, choose the e
Deflector tool from the Object Type rollout. ] Feten Osiec o (sana.

[ Shape001 (Sohere 20sidss...
| Mateis! Staiic001 (Charad...

In the Top viewport, press and hold the left mouse button, Dipla 001 i)
drag the cursor from one point to another; and then [T ===
release the left mouse button; the deflector space warp
icon is displayed in viewports.

Speed By Surfsce 001 {San

Force 001 (Gravin001 +1)

Make sure the deflector space warp icon is selected. Next, Shapa 02 Spham 20 ..
choose the Modify tab in the Command Panel. Set the o
value 3000 in the Width spinner and 2000 in the Length <] Spameun: 01 vy 311

| Msterial Sttic002 (Charad:

spinner in the Parameters rollout.

Display 002 (Ticks} -

Now, right-click on the Select and Move tool from the Figure 17-30 The Split Amount
Main Toolbar; the Move Transform Type-In dialog box is 001 test added to the Event 002
invoked. In the Absolute:World area, set the value 98.042

in the X spinner, 38.558 in the Y spinner, and 4.698 in the Z spinner; the Deflector 001
is transformed to the set position. Close the Move Transform Type-In dialog box.

Drag the Collision test from the Depot area to Event 002 below the Split Amount 001
(Every 5th) test as discussed in the above steps. Select the Collision 002 (None) test in
Event 002; the Collision 002 rollout is displayed on the right. Next, in the Deflectors
area, choose the By List button; the Select Deflectors dialog box is displayed. Select the
Deflector 001 from the list and choose the Select button; the Deflector 001 is added to
the Deflectors area. Next in the Test True If Particle area, select the Stop option from
the Speed drop-down list located below the Collides radio button.

Select the Display 002 (Ticks) operator in Event 002; the Display 002 rollout is displayed
on the right. In the Type drop-down list, select the Geometry option.
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Now, the Particle Flow has been created, refer to
Figure 17-31.

Playing the Simulation

Activate the camera viewport and choose the Play Animation
button to play the animation from the Animation Playback
Controls. After playing the entire animation choose the Play
Animation button again to stop the animation.

You will notice that the particles are now emitting from the
character, refer to Figure 17-32.

Saving and Rendering the Scene

In this section, you will save the scene and then render
it. You can also view the final rendered image sequence
by downloading the file ¢17_3dsmax_2015_rndr.
zip from www.cadcim.com. The path of the file is as
follows: Textbooks > Animation and Visual Effects > 3ds Max >
Autodesk 3ds Max 2015: A Comprehensive Guide

PF Source 001 ©

gl Material Static001 (Charad.
Display 001 (Ticks)
Callision 001 {SDeflectar01)

Figure 17-31

Birth 001 {4t 0 T:100000)

Pasition Objec 001 (Sandm.

B Speed By Suface 001 (San.
Force 001 (Gravity001 +1)
[ Shepe 002 (Sphere 20-sides..
Rotation 001 (Warld Spacs)
Spin 001 (Speed Follow 295
SplitAmount 00 1 (Every Sth)
Callision 002 (Deflacir001)
| Materisl Static002 (Charsct...

Display 002 (Geomety) %

The Particle Flow

HBEima X

[e[ee]e o [ ] R -] [

Figure 17-32 The Particles emitting from the character

1. Choose Save from the Application menu.

2. Choose the Render Setup tool from the Main Toolbar; the Render Setup: Default
Scanline Renderer dialog box is displayed. In this dialog box, the Common tab is chosen
by default. Also, various rollouts are displayed in the Common tab.
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In the Common Parameters rollout, select the Active Time Segment radio button in the
Time Output area.

Make sure the Custom option is selected in the drop-down list in the Output Size area.

In the Render Output area, choose the Files button; the Render Output File dialog box
is displayed. Enter a name for the file in the File name text box and then select the AVI
File (*.avi) file type from the Save as type drop-down list and specify the location of the
file in the Save in text box. Next, choose the Save button; the AVI File Compression
Setup dialog box is displayed. Accept the default settings and choose the OK button to
exit the dialog box.

Make sure that the Quad 4 - Camera001 option is selected in the View drop-down list at
the bottom of the Render Setup: Default Scanline Renderer dialog box. Next, choose
the Render button; both the Camera001, frame# window and the Rendering dialog box
are displayed showing the rendering process.

After the completion of the rendering process, the final output of the animation is saved
at the specified location in the *.avi format. You can view the final output of the animation
by opening the corresponding *.av file.

Tutorial 2

In this tutorial, you will create a scene in which particles animate with sound, as shown in
Figure 17-33. (Expected time: 30 min)

Figure 17-33 Particles emitting as the sound is played at frame 118
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The following steps are required to complete this tutorial:

TETITTR e a0 o

Cr
1.

Create the project folder.

Open the file.

Assign audio controller to the Object.
Assign sound to the animation.

Create the PF source icon.

Add functions to the Particle View window.
Create Forces for the particles.

Generate more Particles from the existing one.
Create new event.

Add material to the Particle.

Play the animation

Save and render the scene.

eating the Project Folder

Create a project folder with the name ¢17_tut2 in the 3dsmax2015 and then save the file
with the name ¢I7tut2, as discussed in Tutorial 1 of Chapter 2.

Open the Windows Explorer and then browse to the ¢17_3dsmax_2015_tut folder. Next,
copy the Sound.wav file from this folder to |Documents\3dsmax2015\c17_tut2\sceneassets\
sounds.

Opening the File

1.

Choose Open from the Application menu; the Open File dialog box is displayed. In
this dialog box, browse to the location \Documents\c17_3dsmax_2015_tut and select the
c17_tut2_start.max file from it. Choose the Open button to open the file.

Choose Save As from the Application menu; the Save File As dialog box is displayed.
Browse to the location \Documents\3dsmax2015\c17 tut2\scenes. Save the file with the
name ¢l 7tut2.max at this location.

Assigning Audio Controller to the Object

In this section, you will assign audio to the objects so that they can animate with the audio.

1.

Choose the Time Configuration button at the bottom of the screen; the Time Configuration
dialog box is displayed. In the Animation area of this dialog box, set the value 720 in the
End Time spinner and press the ENTER key; the number of frame increases in the track
bar. Choose the OK button to exit the dialog box.

Activate the Front viewport and select Equalizer I object and right-click on it; a quad menu
is displayed. Choose the Curve Editor option from the quad menu; the Track View - Curve
Editor window is displayed.

In this window, make sure the Scale option is selected in Equalizer 1 and right-click on
it; a quad menu is displayed. Choose the Assign Controller option; the Assign Scale
Controller dialog box is displayed. In this dialog box, select AudioScale from the list
displayed and choose the OK button; the Audio Controller dialog box is displayed.
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10.

In this dialog box, choose the Choose Sound button; the Open Sound dialog box is
displayed. Select Sound from the list and choose the Open button; the location of the file
appears in place of <none> label.

In the Target Scale area, set the values in the spinners as given next:

X: 400 Y: 600 Z: 400

In the Sample area, set. the value 5 in the [T G- contraller e
Oversampling spinner, refer to | -audeFie
Figure 17-84. Next, choose the Close E:\c17_tut?\sceneassets\sounds\Sound. wav

button to close the dialog box. | Remove Sound absalutevaue: [

Next, select Equalizer 2 in the viewport | | ReaTime Contra e

and right-click; a quad menu is displayed. || I~ Enable Real-Time Device Threshold: [0.0— 3
Repeat steps 2, 3 and 4. Now, in the || [Mirophone [Realek High Defi + Oversampling: [5 H
Target Scale area. set the values in the Fast TrackView: [

spinners as given next: Base Scale Channel

xif[wo.o 2 ¥:[woo 3 @00 i || ¢ e

X: 600 Y: 1000 .
7: 600 ~Target Scale Right

w:[a00.0 2| v:[eoon 2| z[a0.0 2 || ® Mx

In addition, set 12 in the Oversampling
spinner. Choose the Close button to
close the dialog box.

Close

Figure 17-34 The value of the Oversampling
Now, select Equalizer 3 in the viewport spinner set to 5 in the Audio Controller dialolg
and right-click; a quad menu is displayed ~ box
and repeat steps 2, 3 and 4. Now, in the Target Scale area. set the values in the spinners
as given next:

X:-500 Y: -700 7:-500

Next, choose the Close button to close the dialog box.

Next, select Equalizer 4 in the viewport and right-click; a quad menu is displayed and
repeat steps 2, 3, and 4. Now, in the Target Scale area. set the values in the spinners as
given next:

X:-700 Y: -1200 7:-700

Choose the Close button to close the dialog box. Minimize the Track View - Curve Editor
window.

Next, choose the Play Animation button to play the animation. After, playing the entire
animation, choose the Play Animation button again to stop the animation.
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Assigning Sound to the Animation
In this section, you will assign the sound to the animation so that the sound is audible and
matches the animation.

Choose Customize > Preferences from the menu bar; the Preference Settings dialog box
is displayed. In the dialog box, choose the Animation tab and then choose the Assign
button in the Sound Plug-In area of this tab; the Choose Sound Plug-In dialog box
is displayed. Now, select ProSound from the list and choose the OK button. Close the
Preference Settings dialog box.

Choose Graph Editors > Track View - Dope Sheet from the menu bar; the Track
View - Dope Sheet window is displayed. In this window, double-click on the Sound option;
the ProSound dialog box is displayed. Click on the Add button located at the top right
corner; the Open dialog box is displayed. Select Sound from the list in the File name and
then choose the Open button; the name of the sound file along with its path is displayed
in the Input Files (1) area. Next, close the ProSound dialog box by choosing the Close
button, refer to Figure 17-35.

ProSound [===]
rInput Files (1)
E:\c17_tut2\sceneassets\sounds\Sound. wav
Delete Mave Down
Replace Arrange
Reload | Sequence ‘
Convert Path
[ T r Path Manager Diagnostics
File Details
EI Sound.wav [ Mapped Start
! romt T Blate @ drene
orma
Length [30.00s (300.07) O Fronticenter O loops [T 5
Statistics [44100 Hz, 166, Stereo [ Replaceable Duration 200,000
Playback Render
Permit Playback Narmaize Permit Save on Render Normalize

Chanel: ® Orly on averfow Chnnels ® orlyon averfiow
) Before master volume > Before master volume
Sample Rote:  Hfer mactr vokme | | SamPeRate: e

Audio Quality: O Never Audio Quality: |—|Mad‘um - O Never
Trackwithin [0:5__|2] seconds when scrubbing Export Audie

[ Permit Backwards Scrubbing

[ Flay Once O Active
O specifyPlayRange [0 [to Beats Per Minute Tone [0z || close

O Ping Pang Beats Per Measure Tone [1000_[fHe

Figure 17-35 The ProSound dialog box

Now, choose the Play Animation button to play the animation; the sound is audible with
the animation.

Creating the PF Source Icon
In this section, you will create the PF Source icon

1.

Active the Top viewport. Choose Create > Geometry in the Command Panel. Next, select
the Particle Systems option from the drop-down list displayed below the Geometry button.
Choose the PF Source tool from the Object Type rollout; various rollouts are displayed
in the Command Panel.
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2. Inthe Top viewport, press and hold the left mouse button, drag the cursor from one point
to another, and release the left mouse button; the emitter is created for the PF source
Particle System.

Adding the Operator to the Particle View Window

In this section, you will add operators to the Particle Flow in the Particle View window.

1. Select Graph Editors > Particle View from the menu bar; the Particle View window is
displayed. Alternatively, press 6 to open it. In the Event Display area, Standard Flow is
displayed.

2. Select the Birth 001 (0-30 T:200) operator; the Birth 001 rollout is displayed in the
Parameters panel. In this rollout, set the value of the Emit Stop spinner to 720 and select
the radio button at the left of the Rate spinner.

3. Press and hold the left mouse button on the Position Object operator in the Depot area
and then drag the cursor to the Position Icon 001 (Volume) operator in the Event 001;
a red line appears on the Position Icon 001 (Volume) operator. Next, release the left
mouse button; the Position Object 001 (None) operator replaces the Position Icon 001
(Volume) operator.

4. Select the Position Object 001 (None) operator; the Position Object 001 rollout is displayed
on the right side. In the Position Object 001 rollout, select the Lock On Emitter check
box. In the Emitter Objects area, choose the By List button; the Select Emitter Objects
dialog box is displayed. Select Equalizer 1, Equalizer 2, Equalizer 3, and Equalizer 4
and choose the Select button; Equalizer 1, Equalizer 2, Equalizer 3, and Equalizer 4 are
displayed in the Emitter Objects area. Next, select the Animated Shape check box.

PF Source 001 &
[i¥ Render 001 (Geometry)

5. Press and hold the left mouse button on the Speed By Surface
operator in the Depot area and then drag the cursor to the
Speed 001 (Along Icon Arrow) operator in the Event 001;
a red line appears on the Speed 001 (Along Icon Arrow)
operator. Next, release the left mouse button; the Speed By
Surface 001 (None) operator replaces the Speed 001 (Along
Icon Arrow) operator, refer to Figure 17-36.

Event 001 &
Birth 001 (0-720 T:200)

1| Position Object 001 (Equaliz...
Speed By Surface 001 (No...
Rotation 001 (Random 30
Shape 001 (Cube 3D}

| Display 001 (Ticks)

6. Select the Speed By Surface 001 (None) operator; the Speed
By Surface 001 rollout is displayed on the right side. In
the Speed by Surface 001 rollout, set the value to 10 in the
Variation spinner. In the Surface Geometry area, choose
the By List button; the Select Surface Objects dialog box is
displayed. Select Equalizer 1, Equalizer 2, Equalizer 3 and Figure 17-36 The Speed by
Equalizer 4 from the list and choose the Select button. Also, Surface 001 (None) operator
in the Direction area, set the value 10 in the Divergence in the Event Display area
spinner.
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Next, select the Rotation 001 (Random 3D) operator in Event 001; the Rotation 001
rollout is displayed on the right side. In the Orientation Matrix area, select the Speed
Space option from the drop-down list. Set the value in the X, Y and Z spinners as 1, 0.5
and 0.5 respectively. Set the Divergence spinner value to 10.

Select the Shape 001 (Cube 3D) operator in Event 001; the Shape 001 rollout is displayed
on the right side. Select the Star 6-point option from the drop-down list next to the 3D
radio button. Set the value 20 in the Size spinner. Now, select the check box located before
the Scale % spinner and set the value 50 in this spinner. In the Variation % spinner, set
the value 20. Also, select the Generate Mapping Coords check box.

Select the Display 001 (Ticks) operator in Event 001; the Display 001 rollout is displayed
on the right. Select the Geometry option from the Type drop-down list. Also, minimize
the Particle View window.

Creating Forces for the Particles
In this section, you will create force so that you can control the movement of the particles.

1.

Activate the Top viewport. Choose the Drag tool from Create > Space Warps >
Forces > Object Type rollout in the Command Panel.

Press and hold the left mouse button and drag the cursor from one point to another in the
Top viewport. Next, release the left mouse button; the Drag space warp icon is displayed.

Make sure Drag001 is selected and right-click on the Select and Move tool from the Main
Toolbar; the Move Transform Type-In dialog box is displayed. In the Absolute:World
area, set the value -0.284 in the X spinner, 0.377 in the Y spinner, and 0.518 in the Z
spinner, as shown in Figure 17-37; Drag001 is moved to the defined position. Close the
Move Transform Type-In dialog box.

Choose the Modify tab in the Command Panel [|@ wiove Transform Type-in (o] = |[=]
and set the values in the Parameters rollout of the | _ o o Offest:Sereen
Drag space warp as follows: o e T o

¥: IFQ T IUU—Q
Timing area Zfosie |2 || ZJoo  |Z
Time off : 720

Figure 17-37 The Move Transform

In the Damping Characteristics area, clear the Type-In dialog box

Unlimited Range check box.
Set the following Linear Damping parameters below the Linear Damping radio button:

X Axis: 1 Range: 50 Falloff: 500
Y Axis: 0 7 Axis: 0

Display area

Icon Size: 38
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Maximize the Particle View window and select the Display 001 (Geometry) operator.
Next, right-click on it; a shortcut menu is displayed. Choose Append > Operator > Force
from the shortcut menu; the Force 001 (None) operator is added below the Display 001
(Geometry) operator.

Select the Force 001 (None) operator in Event 001; the Force 001 rollout is displayed on
the right in the Parameters panel. Next, in the Force Space Warps area, choose the By List
button; the Select Force Space Warps dialog box is displayed. Select Drag001 from the list
and choose the Select button; Drag001 is added to the Force Space Warps area. Next, in
the Offset Influence area, select the Particle Age option from the Sync By drop-down list.

Generating more Particles from the Existing Ones
In this section, you will generate more particles from the existing one by using the Spawn test.

1.

Make sure the Force 001 (Drag001) operator is selected
and right click; a shortcut menu is displayed. Choose
Append > Test > Spawn from the shortcut menu; the
Spawn 001 (Once) test is added below the Force 001
(Drag001) operator, as shown in Figure 17-38.

PF Source 001 £
|5 Render 001 (Geometry)

Event 001 &

2. Select the Spawn 001 (Once) test in the Event Display gy Dirth 001 (0-720 T-200)

area; the Spawn 001 rollout is displayed on the right | E R (E T

side. In the Spawn Rate And Amount area, select the By gl Spoed By Surface 001 (Fqu...

Travel Distance radio button. Next, set the value 10 in the Rotation 001 (Speed Space)

Variation % spinner. Select the Particle Age option from [j| Shape 001 (Star 6-point 30)

the Sync By drop-down list. Next, in the Speed area, set | Display 001 (Geometry)

the value of the Variation % spinner to 1. In the Size area, Force 001 (Drag001)

set the value of Scale Factor % and Variation % to 50 and = &</ "> Spawn 001 (Oncs}

10, respectively.

Figure 17-38 The Spawn

Creating New Event test in Event 001

In this section, you will create a new event so that the particle
are emitted and visible in rendering.

1.

Press and hold the left mouse button on the Shape operator in the Depot area and then
drag the cursor to the Event Display area. Next, release the left mouse button; Event
002 is created and the Shape 002 (Cube 3D) operator is displayed under Event 002 in
the Event Display area.

Select the Shape 002 (Cube 3D) operator in Event 002; the Shape 002 rollout is displayed
on the right of the Event Display area. Select the Star 6-point option from the drop-down
list next to the 3D radio button. Set the value 20 in the Size spinner. Now, select the check
box preceding the Scale % spinner and set the value in this spinner to 50. In the Variation
% spinner, set the value to 20 and select the Generate Mapping Coords check box.

Connect the Spawn 001 (By Travel) test from Event 001 to Event 002 in the Event Display
area by dragging the gray dot that is at the left of the test, to the input of Event 002, as
shown in Figure 17-39.
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10.

Select the Display 002 (Ticks) operator and right-click; a
shortcut menu is displayed. Choose Insert > Operator >
Scale from the shortcut menu; the Scale 001 (Overwrite
Once) operator is inserted below the Shape 002 (Star
6-point 3D) operator.

PF Source 001 £
[&¥| Render 001 (Geometry)

Select the Scale 001 (Overwrite Once) operator; the Scale =a3) Birth 001 (0-720 T:200)
001 rollout is displayed on the right of the Event Display 13| Position Object 001 (Equaliz...
area. In the Type drop-down list, select the Absolute option. 5| Speed By Surface 001 (Equ...
Next, in the Scale Factor area, set the value to 80 in the Rotation 001 (Speed Space)
X %, Y %, and Z %, respectively. In the Scale Variation [ Shape 001 (Star 6-point 30)
area, set the value 25 in the X %, Y %, and Z % spinners I Display 001 (Geometry)
and then select the Towards Minimum option in the Bias Force 001 (Drag001)
drop'down liSt' @ Spawn 001 (By Travel)

Right-click in the area between the Scale 001 (Absolute)
operator and the Display 002 (Ticks) operator; a shortcut
menu is displayed. Choose Insert > Operator > Spin Event 002 ©
from the shortcut menu; the Spin 001 (Random 3D
360) operator is inserted below the Scale 001 (Absolute)
operator.

Shape 002 (Star 6-point 3D)
Dizplay 002 (Ticks)

O

) . Figure 17-39 The Spawn lest
Select the Spin 001 (Random 3D 360) operator; the Spin ;51 g 007

001 rollout is displayed on the right. Next, set the value 10

in the Variation spinner. Now, in the Spin Axis area, select

the Speed Space option from the drop-down list and set the value 1, 0.5, and 0.5 in the
X, Y, and Z spinners, respectively. Set the value of the Divergence spinner to 10.

Select the Display 002 (Ticks) operator in Event 002; the Display 002 rollout is displayed
on the right. In the Type drop-down list, select the Geometry option.

Make sure the Display 002 (Geometry) operator is selected and right-click; a shortcut
menu is displayed. Choose Append > Operator > Delete from the shortcut menu; the
Delete 001 (All) operator is added below the Display 002 (Geometry) operator.

Select the Delete 001 (All) operator; the Delete 001 rollout is displayed on the right.
Next, in the Remove area, select the By Particle Age radio button and set the value 10
in the Life Span spinner.

Adding Material to the Particles

In this section, you will add material to the particles.

1.

Select the Render 001 (Geometry) operator in PF Source 001 and right-click; a shortcut
menu is displayed. Choose Append > Operator > Material Dynamic from the shortcut
menu; the Material Dynamic 001 (None) operator is added below the Render 001
(Geometry) operator.
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Select the Material Dynamic 001 (None) operator; the Material Dynamic 001 rollout is
displayed on the right. Next, choose the None button below the Assign Material check
box; the Material/Map Browser dialog box is displayed. In the Sample Slots rollout, select
Color (Standard). Choose the OK button to close the Material/Map Browser dialog box;
the Color name is displayed on the None label. Also, the Material Dynamic 001 (None)
operator changes to the Material Dynamic 001 (color), refer to Figure 17-40. Next, close

the Particle View window.

Playing the Animation

Activate the camera viewport. Next, choose the Play Animation
button from the animation playback controls to play the
animation.

You will notice that the particles are animated with colors, refer
to Figure 17-41.

Saving and Rendering the Scene

In this section, you will save the scene and then render it. You can
also view the final rendered image sequence by downloading the
file c17 3dsmax_2015_rndr.zip from www.cadcim.com. The path of
the file is as follows: Textbooks > Animation and Visual Effects > 3ds
Max > Autodesk 3ds Max 2015: A Comprehensive Guide

PF Source 001 &

| Render 001 (Geometry)

ia amic 001 (colo
RenderParticles

Event 001 &
Ea3) Birth 001 (0-720 T:200)

| Position Object 001 (Equaliz...
B | Speed By Surface 001 (Equ.
Rotation 001 (Speed Space)
(]| Shape 001 (Star 6-point 30}
| Display 001 (Geometry)
Force 001 (Drag001)

0 Spawn 001 (By Travel}

Event 002 &

[C]| Shape 002 (Star 6-point 30}

Scale 001 (Absolute)

1. Choose Save from the Application menu. _
Spin 001 (Speed Space 360...
o Dizplay 002 (Geometry)
2. Choose the Render Setup tool from the Main Toolbar; the Delete 001 (By Age 10:10)
Render Setup: Default Scanline Renderer dialog box is
displayed. In this dialog box, the Common tab is chosen by Figure 17-40 The Material
default. Also, various rollouts are displayed in the Common Dynamic operator in PF
tab. Source 001
3. In the Common Parameters rollout, select the Active Time Segment radio button in the
Time Output area.
4. In the Output Size area, choose the 640x480 button.
5. In the Render Output area, choose the Files button; the Render Output File dialog box

is displayed. Enter a name for the file in the File name text box and then select the AVI
File (*.avi) file type from the Save as type drop-down list. Next, choose the Save button;
the AVI File Compression Setup dialog box is displayed. Use the default settings and
choose the OK button to exit the dialog box.



17-44 Autodesk 3ds Max 2015: A Comprehensive Guide

6. Make sure that the Quad 4 - Camera001 option is selected in the View drop-down list at
the bottom of the Render Setup: Default Scanline Renderer dialog box. Next, choose
the Render button; the Camera001, frame# window and the Rendering dialog box are
displayed showing the rendering process.

After the completion of the rendering process, the final output of the animation is saved
at the specified location in the *.avi format. You can view the final output of the animation
by opening the corresponding *.av: file.

Figure 17-41 Puarticles animating on frame 259

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. Which of the following spinners appears in the Emission rollout when the Circle or Sphere
option is selected from the Icon Type drop-down list?

(a) Length (b) Width
(c) Height (d) Diameter

2. Which of the following buttons is used to convert the selection from the Event sub-object
level into the Particle sub-object level?

(a) ID (b) Remove
(c) Get from Event level (d) Add
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Which of the following rollouts is used to adjust the size and appearance of the Particle
Flow icon in the viewport?

(a) Selection (b) Emission

(c) System Management (d) Script
Which of the following areas is used to examine each frame in the viewport or render
output after the last integration step has taken place?

(a) Script (b) Every Step Update Area
(c) System Management (d) Final Step Update Area

The area in the Particle View window displays all Particle Flow as the particle
diagram setup and runs all events and actions in a Particle System.

The is used set initial stage for the Particle System using the Maya nCache
files from the cache memory.

The Preset Flow is used to merge a saved Particle Flow setup with current scene. (1/F)

The Keep Apart operator is used to define a number of groups of particles according to
the location, age, speed, and size of the particle. (1/F)

The tests in the Particle Flow are used to determine whether particles satisfy one or more
conditions. (T/F)

Review Questions

Answer the following questions:

1.

Which of the following check boxes when selected runs a script in memory at each
integration step?

(a) Enable Script (b) None
(c) Use Script File (d) Edit

Which of the following operators is used to attach the UVW map to the entire surface of
the particles?

(a) Material Dynamic (b) Remove
(c) Material Static (d) Mapping

Which of the following flows consists of a single global event which further contains the
Render operator?

(a) Preset Flow (b) Empty Flow
(c) Standard Flow (d) One Click Flow
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4.

10.

Which of the following tools is used to zoom a particular region in the Event Display
area?

(a) Zoom Region Tool (b) Pan Tool
(¢) Zoom Tool (d) Zoom Extents
The operator is used to define the material to the particles in an event and

list the relative frequency of each sub-material that appears on the particles.

The operator is used to record and store particle states in the system
memory.
The test is used to define the collision of the particles with one or more

deflectors in the Space Warps.

The Find Target test is used to define the smooth transition of the rotation value of the
particle from the current rotation value to the specific value over the specified period of
time. (T/F)

The Spawn test is used to create new particles from the existing ones. (1/F)

The Split Selected test is used to split the particle according to the particles selection
status. (1/F)

EXERCISE

The rendered output of the scene used in the following exercise can be accessed by downloading
the ¢17_3dsmax_2015_exrzip file from www.cadcim.com. The path of the file is as follows:
Textbooks > Animation and Visual Effects > 3ds Max > Autodesk 3ds Max 2015: A Comprehensive Guide

Exercise 1

Create a scene in which the simulation of leaves is done using the Particle Flow, refer to

Figure 17-42.

(Expected time: 30 min)

Figure 17-42 Leaves simulation

Answers to Self-Evaluation Test
1.d, 2. ¢, 3. b, 4. d, 5. Event Display, 6. One Click Flow, 7.'T; 8. F, 9. T



