
Chapter 1

 Introduction to 
NX 9.0

Learning Objectives

After completing this chapter, you will be able to:
• Understand different environments in NX. 
• Understand the system requirements for NX.
• Start a new fi le in NX.
• Understand the important terms and defi nitions used in NX. 
• Understand functions of the mouse buttons.
• Understand the use of various hot keys. 
• Modify the color scheme in NX.
• Know about dialog boxes in NX.
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 INTRODUCTION TO NX 9.0  
Welcome to NX 9.0 (commonly referred to as NX). As a new user of this software package, you 
will join hands with thousands of users of this high-end CAD/CAM/CAE tool. If already familiar 
with the previous releases, you can upgrade your designing skills with tremendous improvement 
in this latest release.

NX 9.0, a product of SIEMENS Corp., is a completely re-engineered, next-generation 
family of CAD/CAM/CAE software solutions for Product Life Cycle Management. Through 
its exceptionally easy-to-use and state-of-the-art user interface, NX delivers innovative 
technologies for maximum productivity and creativity from the basic concept to the fi nal 
product. NX reduces the learning curve by allowing fl exibility in the use of feature-based and 
parametric designs.

The subject of interpretability offered by NX includes receiving legacy data from other CAD 
systems and even between its own product data management modules. The real benefi t is that 
the links remain associative. As a result, any changes made to this external data are notifi ed 
to you and the model can be updated quickly.

When you open an old file or start a new file in NX, you will enter the Gateway 
environment. It allows you to examine the geometry and drawing views that have been created. 
In the Gateway environment, you can invoke any environment of NX. 

NX serves the basic design tasks by providing different environments. An environment is 
defi ned as a specifi ed environment, consisting of a set of tools, which allows the user to 
perform specifi c design tasks in a particular area. You need to start the required environment 
after starting a new part fi le. As a result, you can invoke any environment of NX in the same 
working part fi le. The basic environments in NX are the Modeling environment, Shape 
Studio environment, Drafting environment, Assembly environment, Sheet metal environment 
and the Manufacturing environment. These environments are discussed next.

 Modeling Environment
The Modeling environment is a parametric and feature-based environment in which you can 
create solid models. The basic requirement for creating solid models in this environment is a 
sketch and you can draw the sketch directly in the Modeling environment by using the tools 
available in the Direct Sketch group of the Home tab. The sketch can also be drawn in the 
Sketch environment. The Sketch environment can be invoked by choosing the Sketch tool from 
the Direct Sketch group of the Home tab or by choosing the Sketch in Task Environment tool 
from the Curve tab. While drawing a sketch, various applicable constraints and dimensions are 
automatically applied. Additional constraints and dimensions can also be applied manually. 
After drawing the sketch, you need to convert the sketch into a feature. The tools to convert a 
sketch into a feature are available in the Modeling environment. You can also create features 
such as fi llets, chamfers, taper, and so on by using other tools available in this environment. 
These features are called the placed features. You can also assign materials to the model in 
the Modeling environment.



Introduction to NX 9.0         1-3

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

 Shape Studio Environment
The Shape Studio environment is also a parametric and feature-based environment in which 
you can create surface models. The tools in this environment are similar to those in the 
Modeling environment. The only difference is that the tools in this environment are used to 
create basic and advanced surfaces. You are also provided with the surface editing tools, which 
are used to manipulate the surfaces to obtain the required shape. This environment is useful 
for conceptual and industrial design.

 Assembly Environment
The Assembly environment is used to assemble the components using the assembly constraints 
available in this environment. There are two types of assembly design approaches in NX, 
Bottom-up and Top-down.

In the bottom-up approach of the assembly, the previously created components are 
assembled together to maintain their design intent. In the top-down approach, components 
are created in the Assembly environment.

In the Assembly environment you can also assemble an existing assembly with the current 
assembly. The perform analysis provides the facility to check the interference and clearance 
between the components in an assembly.

 Drafting Environment
The Drafting environment is used for the documentation of the parts or assemblies created 
earlier in the form of drawing views and their detailing. There are two types of drafting 
techniques, generative drafting and interactive drafting.

The generative drafting technique is used to automatically generate the drawing views of the 
parts and assemblies. The parametric dimensions added to the component in the Modeling 
environment during its creation can also be generated and displayed automatically in the 
drawing views. The generative drafting is bidirectionally associative in nature. If you modify 
the dimensions in the Drafting environment, the model will automatically update in the 
Modeling environment and vice-versa. You can also generate the Bill of Material (BOM) and 
balloons in the drawing views.

In interactive drafting, you need to create the drawing views by sketching them using the 
normal sketching tools and then adding the dimensions.

Sheet Metal Environment
The Sheet Metal environment is used for the designing the sheet metal components. Generally, 
the sheet metal components are created to generate the fl at pattern of a sheet, study the 
design of the dies and punches, study the process plan for designing, and the tools needed 
for manufacturing the sheet metal components.
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 SYSTEM REQUIREMENTS
The following are the system requirements to ensure the smooth running of NX:

• Operating System: Windows Vista, Windows Vista X 64 bit (Professional, Ultimate, and 
Enterprise Editions), Windows 7, Windows 8 or UNIX.

• Memory: 2 GB of RAM is the minimum requirement for all the applications and 4GB of 
RAM is recommended for DMU applications.

• Disk drive: 10 GB Disk Drive space (Minimum recommended size)
• Internal/External drives: A DVD-ROM drive is required for the program installation.
• Display: A graphic color display compatible with the selected platform-specifi c graphic 

adapter is required. The minimum recommended monitor size is 17 inches.
• Graphics adapter: A graphics adapter with a 3D OpenGL accelerator is required with a 

minimum resolution of 1024x768 for Microsoft Windows workstations and 1280x1024 
for UNIX workstations.

 GETTING STARTED WITH NX
Install NX on your system and then start it by double-clicking on the shortcut icon of NX 9.0 on 
the desktop of your computer. After the system has loaded all the required fi les to start NX, 
the initial screen will be displayed, as shown in Figure 1-1.

Figure 1-1  The initial screen that appears after starting NX 9.0

Choose File > New from the Ribbon; the New dialog box will be displayed as shown in 
Figure 1-2. Make sure that Model template is selected in the Templates rollout of the dialog 
box. Next, enter the name of the fi le in the Name edit box and choose the OK button; the 
Modeling environment will be displayed on the screen, refer to Figure 1-3. 
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Figure 1-2  The New dialog box

Figure 1-3  The Modeling environment displayed on screen
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IMPORTANT TERMS AND DEFINITIONS
Some important terms and defi nitions of NX are discussed next.

 Feature-based Modeling
A feature is defi ned as the smallest building block that can be modifi ed individually. A model 
created in NX is a combination of a number of individual features and each feature is related 
to the other directly or indirectly. If a proper design intent is maintained while creating the 
model, then these features automatically adjust their values to any change in their surroundings. 
This provides a great fl exibility to the design.

 Parametric Modeling
The parametric nature of a software package is defi ned as its ability to use the standard 
properties or parameters in defi ning the shape and size of a geometry. The main function of 
this property is to derive the selected geometry to a new size or shape without considering 
its original dimensions. You can change or modify the shape and size of any feature at any 
stage of the designing process. This property makes the designing process an easy task. For 
example, consider the design of the body of a pipe housing, as shown in Figure 1-4. 

To change the design by modifying the diameter of the holes and their number on the front, 
top, and bottom face, you need to select the feature and change the diameter and the number 
of instances in the pattern. The modifi ed design is shown in Figure 1-5.

Figure 1-4  Body of a pipe housing Figure 1-5  Modifi ed body of the pipe housing

Bidirectional Associativity
As mentioned earlier, NX has different environments such as the Modeling environment, 
Assembly environment, and the Drafting environment. The bidirectional associativity that exists 
between all these environments ensures that any modifi cation made in the model in any of 
the environments of NX is automatically refl ected in the other environments immediately. For 
example, if you modify the dimension of a part in the Modeling environment, the change will 
be refl ected in the Assembly and the Drawing environments as well. Similarly, if you modify 
the dimensions of a part in the drawing views generated in the Drafting environment, the 
changes will be refl ected in the Modeling and Assembly environments. Consider the drawing 
views of the pipe housing shown in Figure 1-6. When you modify the model in the Modeling 
environment, the changes will be refl ected in the Drafting environment automatically. Figure 1-7 
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shows the drawing views of the pipe housing after increasing the diameter and the number 
of holes.

Figure 1-6  The drawing views of a pipe housing

Figure 1-7  The drawing views of pipe housing after making the modifi cations

*.prt 
*.prt is a fi le extension associated with all fi les that are created in the Modeling, Shape Studio, 
Assembly, Sheet Metal, and Drafting environments of NX.

 Resource Bar
The Resource Bar combines all the navigator windows, the history palette, the integrated web 
browser, and the parts template at one common place for a better user interface. By default, the 
Resource Bar is located on the left side of the NX window.

 Roles
Roles are a set of system customized tools and toolbars used for different applications. In NX, 
you have different roles for different industrial applications. The Roles tab in the Resource Bar 
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is used to activate the required role. In this book, the Essentials role has been used, as it 
contains all the required tools. To activate this role, choose the Roles tab from the Resource 
Bar and click on the System Defaults option, if it is not expanded already; a fl yout will 
be displayed. Click on the Essentials icon to activate that role. Figure 1-8 shows the Roles 
navigator that appears when you choose the Roles tab in the Resource Bar.

 Part Navigator
The Part Navigator keeps a track of all the operations that are carried out on the part. 
Figure 1-9 shows the part navigator that appears when you choose the Part Navigator tab in 
the Resource Bar.

 Constraints
Constraints are the logical operations that are performed on the selected element to defi ne 
its size and location with respect to the other elements or reference geometries. There are 
three types of constraints in NX: Geometric, Dimensional, and Assembly. The constraints in 
the sketch are called geometric and dimensional constraints and these are used to precisely 
defi ne the size and position of the sketched elements with respect to the surroundings. The 
assembly constraints are available in the Assembly environment and are used to defi ne the 
precise position of the components in the assembly. These constraints are discussed next.

Figure 1-8  The  Roles navigator Figure 1-9  The Part Navigator
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 Geometric Constraints
These are the logical operations performed on the sketched elements to defi ne their size 
and position with respect to the other elements. Geometric constraints are applied using two 
methods, automatic constraining and manual constraining. While drawing the sketch, some 
constraints are automatically applied to it.

 Dimensional Constraints
After creating the sketch, you need to apply different types of dimensional constraints to it. 
Various types of dimensions in NX are:

1. Linear Dimensions
2. Radial Dimensions
3. Angular Dimensions
4. Perimeter Dimensions

NX is a parametric software and therefore, you can modify the dimensions of a sketch at any 
time. You will learn more about modifying dimensions of the sketch in the later chapters.

 Assembly Constraints
The constraints in the Assembly environment are the logical operations performed to 
restrict the degrees of freedom of the component and to defi ne its precise location and 
position with respect to the other components of the assembly. 

  Solid Body
The solid body contains all the features such as extrude, pad, pocket, hole, and so on. 

  Sheet Body or Surfaces
Surfaces are geometric features that have no thickness. They are used to create complex shapes 
that are diffi cult to be created using the solid features. After creating the surface, you can assign 
a thickness to it in order to convert it into a solid body. Surfaces are created in the Modeling 
environment. No separate environment is required to create the surfaces.

Features
A feature is defi ned as the basic building block of a solid model. The combination of various 
features results in a solid body. In the Modeling environment of NX, the features are of two 
types:

1. Sketch-based features
2. Placed-features 

The sketch-based features are the ones that require a sketch for their creation. The 
placed-features do not require a sketch for their creation.
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 WCS (Work Coordinate System)
The WCS is a local coordinate system and can be repositioned to a convenient location while 
making a model. The XC-YC plane of the WCS is used to perform many operations. When you 
create a new fi le, by default the WCS is positioned at origin of the Datum Coordinate System, 
which is (0,0,0). By default, the display of WCS is turned on. To turn off the display of WCS, 
choose the Display WCS tool from the Tools > Utilities > More > WCS in the Ribbon; the 
WCS will be turned off from the drawing window. Note that it is a toggle button. 

 UNDERSTANDING THE FUNCTIONS OF THE MOUSE 
BUTTONS
To work in the NX environment, it is necessary that you understand the functions of the 
mouse buttons. The effi cient use of the three buttons of the mouse, along with the CTRL key 
can reduce the time required to complete the design task. The different combinations of the 
CTRL key and the mouse buttons are listed below:

1. The left mouse button is to make a selection by simply selecting a face, surface, sketch, 
or an object from the geometry area or from the Part Navigator. For multiple selections, 
select the entities using the left mouse button. 

2. The right mouse button is used to invoke the shortcut menu, which has different options 
such as Zoom, Fit, Rotate, Pan, and so on.

 
3. Press and hold the middle and the right mouse buttons to invoke the Pan tool. Next, 

drag the mouse to pan the model. You can also invoke the Pan tool by fi rst pressing and 
holding the SHIFT key and then the middle mouse button. Figure 1-10 shows the use of 
a three button mouse in performing the pan functions.

4. Press and hold the middle mouse button to invoke the Rotate tool. Next, drag the mouse 
to dynamically rotate the view of the model in the geometry area and view it from different 
directions. Figure 1-10 shows the use of the three button mouse in performing the rotate 
operation.

5. Press and hold the CTRL key and then  the middle mouse button to invoke the Zoom tool. 
Alternatively, press and hold the left mouse button and then the middle mouse button to 
invoke the Zoom tool. Next, drag the mouse dynamically to zoom in or out the model in 
the geometry area. Figure 1-10 shows the use of the three mouse buttons in performing the 
zoom functions.
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Figure 1-10  Functions of the mouse buttons

Various screen components of NX are discussed next.

 QUICK ACCESS TOOLBAR
This toolbar is common to all the environments of NX. Figure 1-11 shows the Quick Access 
toolbar. The buttons in this toolbar are used to start a new fi le, open an existing fi le, save a 
fi le of the current document, cut and place the selection on a temporary clipboard, copy a 
selection, paste the content from the clipboard to a selected location, undo, redo, search a 
tool, and invoke the help topics.

Figure 1-11  The Quick Access toolbar

RIBBON
NX offers a user-friendly design interface by providing the Ribbon. The Ribbon 
comprises a series of tabs. In tabs, the various tools and options are grouped together based 
on their functionality in different groups and galleries. The display of these tabs and their 
groups depends upon the environment invoked. The different environments and some of 
their respective tabs and groups are discussed next.

 Modeling Environment
The Modeling environment can be invoked by selecting the Modeling template from the 
New dialog box. You can also invoke the Modeling environment from any other opened 
environment. To do so, choose File > Applications > Modeling from the Ribbon. Some of 
the tabs of the Modeling environment are discussed next. 

Home Tab
The Home tab consist of a series of groups and galleries and are discussed next.



1-12                                                    NX 9.0 for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Direct Sketch Group
It is one of the most important groups of the Home tab. The tools available in this group 
are used to draw and edit sketches. You can apply constraints to geometric entities and 
assign dimension to a sketch using the tools of this group. The sketching tools available 
in this group are grouped together in the Sketch Curve gallery, refer to Figure 1-12. 
Note that by default, the Sketch Curve gallery is in collapse form. As a result, some of 
the tools are not visible by default. To expand this gallery, click on the lower down arrow 
available in front of this gallery, see Figure 1-13. Note that some of the tools such as Rapid 
Dimension, Geometric Constraints, Fillet, Chamfer, Quick Trim, and Quick Extend 
are still not available in the expanded Sketch Curve gallery. To access all the tools of the 
Sketch Curve gallery, choose the Sketch tool available in the Direct Sketch group; the 
Create Sketch dialog box will be displayed. The options available in this dialog box are 
discussed in later chapters. Select the required sketching plane and then choose the OK 
button, the Sketch Curve gallery expanded such that it contains all the sketching tools 
including dimensioning and geometric constraints, see Figure 1-14.

Figure 1-12  The Direct Sketch group

Figure 1-13  Expanded 
Sketch Curve gallery

Figure 1-14  The expanded Sketch Curve gallery of the Direct Sketch group 
after invoking Sketching environment

Feature Group
The tools in this group are shown in Figure 1-15 and are used to convert a sketch drawn 
in the Sketching environment into a feature. This group contains sketch-based feature 
tools and placed-feature tools. You can create datum plane, axis, and points using the 
tools in this group. 
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Synchronous Modeling Group
The Synchronous modeling technology is one of the latest enhancements in NX. This 
technology is used to modify the parts even if the modeling history is not available. The 
tools available in the Synchronous Modeling group are used to modify and improve an 
existing design in less time. Figure 1-16 shows the Synchronous Modeling group. 

Figure 1-16  The Synchronous Modeling group

Curve Tab
The Curve tab comprises a series of groups and galleries. You can invoke Sketching environment 
by using the Sketch in Task Environment tool of this tab. Figure 1-17 shows the Curve tab.

Figure 1-17  The Curve tab

Surface Tab
You can create surface design in the Modeling environment as well as in the Shape Studio 
environment. The tools used to create solid bodies are also used to create surface bodies. The 
Surface group under the Surface tab, which have tools to create the surface design and is 
discussed next. Note that this tab is not available by default.

 Surface Group
The tools in the Surface group are used to create complex surfaces. Figure 1-18 shows 
the Surface group.

Figure 1-18  The Surface group
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Tip: By default, all tools are not available in a group. Therefore, you may need to 
customize the group to add those tools that are not available by default. To customize a 
group, click on the down arrow at the bottom right corner of the group; a drop-down 
will be displayed. Click on the tool to be added or removed from the group. Note 
that a tick mark available on the left of a tool indicates that it is already added to 
the group. 

Similarly, you can add or remove groups from the Ribbon by using Ribbon Options 
arrow available at the bottom right corner of the Ribbon.

Some of the tabs that are available in the Modeling environment as well as common to other 
environments of NX are discussed next. 

 Application Tab
Using the Application tab, you can invoke any other environment from the currently invoked 
environment. By default, the Application tab is not available in the Ribbon. Therefore, you 
need to customize to add it. To do so, right-click on the Ribbon and select the Application 
option from the shortcut menu displayed. You can add this tab to all environments of NX. 
Figure 1-19 shows the Application tab.

Figure 1-19  The Application tab

Tip: Some of the tabs are, by default, available in their respective environments. 
However, you can add more tabs to an environment. To do so, right-click on the 
Ribbon; a shortcut menu will be displayed. You will observe that the tools that are 
not available in the graphics window are not selected in the shortcut menu. Select 
any unselected option; it will become available as a tab in the Ribbon.        

 View Tab
The tools in the View tab, as shown in Figure 1-20, are used for manipulating the views of the 
model. The View tab is available in all the environments. Some of the tools in the View tab 
are not available in the Drafting environment.

Figure 1-20  The View tab
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Assembly Environment
In NX, you can invoke the assembly environment within the Modeling environment and 
create assemblies by using different assembly tools. The tools for assembling are available in 
the Assembly tab and are discussed next.

 Assemblies Tab
The tools that are used to create an assembly are grouped together in the Assembly tab. To add 
this tab, choose File > Applications > Assemblies check box from the Ribbon. Alternatively, 
choose the Assemblies button from the Application tab. The tools of the Component group 
available in this tab are used to insert an existing part or assembly in the current assembly 
fi le. You can also create a new component in the assembly fi le using the tools in this group. 
Figure 1-21 shows the tools in this group.

Figure 1-21  The Component group

Drafting Environment
To invoke the Drafting  environment, choose File > Applications >  Drafting from the 
Ribbon. Alternatively, this environment can be invoked by choosing the Drafting tool from 
the Application tab. You can also invoke this environment by using the Drawing template of 
the New dialog box. The groups in the Drafting environment are discussed next.

View Group
This group is displayed in the Home tab after invoking the Drafting environment. The tools 
in the View group are used to insert a new sheet, create a new view, generate an orthographic 
view, section view, and detail view for a solid part or an assembly. Figure 1-22 shows the View 
group.

Figure 1-22  The View group

 Dimension Group
The tools in the Dimension group are used to generate various dimensions in the drawing views. 
Figure 1-23 shows the Dimension group.
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Figure 1-23  The Dimension group

 Annotation Group
The tools in the Annotation group are used to generate the GDT parameters, annotations, 
symbols, and so on. Figure 1-24 shows the Annotation group.

Figure 1-24  The Annotation group

Sheet Metal Environment
The tools in the Sheet Metal environment are used to create a sheet metal component. 
Figure 1-25 shows the groups and tools of Sheet Metal environment.

Figure 1-25  Tools in the Sheet Metal environment

STATUS BAR
The Status Bar that appears at the bottom of the drawing window comprises of two areas and 
buttons, as shown in Figure 1-26. These are discussed next.

Figure 1-26  The Status Bar 

Cue Line Area
The cue line area is the prompt area. In this area, you will be prompted to select the entities 
for completing the tool task.

Status Area
This area gives information about the operations that can be carried out. 

View NX in Full Screen
If you choose this button, the graphics area will be maximized and will give you a full screen 
display. For getting the default screen display, you need to choose this button again.
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 HOT KEYS
NX is more popularly known for its icon driven structure. However, you can still use the keys 
on the keyboard to invoke some tools. These keys are called hot keys. The hot keys, along with 
their functions, are listed in the table given next. 
 
  Hot Key  Function

  CTRL+Z  Invokes the Undo tool

  CTRL+Y  Invokes the Repeat tool

  CTRL+S  Saves the current document

  F5   Refreshes the Drawing window
  
  F1   Invokes the NX Help tool  
  
  F6   Invokes the Zoom tool

  F7   Invokes the Rotate tool 

  CTRL+M  Invokes the Modeling environment

  CTRL+SHIFT+D Invokes the Drafting environment
   

 COLOR SCHEME
NX allows you to use various color schemes as the background screen color and also for 
displaying solid bodies on the screen. To change the background color scheme, choose Menu 
> Preferences > Background from the Top Border Bar; the Edit Background dialog box 
will be displayed. 

Select the Plain radio button from the Shaded Views and Wireframe Views areas. Next, choose 
the color swatch available on the right side of the Plain Color option; the Color dialog box 
will be displayed. Select the White color swatch from the Color dialog box and choose the 
OK button twice to apply the new color scheme to the NX environment. 

Note
For the purpose of printing, this book in general will follow the white background of the NX 
environment. However, for better understanding and clear visualization, at various places other 
color schemes are also followed.

DIALOG BOXES IN NX
To create any feature, you need to follow certain steps in an order. These steps are placed in 
a top-down order in the dialog boxes. This layout of dialog boxes will help you throughout 
the feature creation operation, refer to Figure 1-27.
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In a dialog box, the current selection step will be highlighted in orange. The required steps 
are marked with red asterisks, and the completed steps are marked with green check marks. 
The advanced options are collapsed and hidden in the rollouts. The button highlighted in 
green indicates next default action. 

The Reset button is used to reset the dialog box to its initial settings. The Hide Collapsed 
Groups option from the Dialog Option button is used to hide all the collapsed rollouts to 
simplify the dialog box. To view all the collapsed rollouts, choose the Show Collapsed Groups 
option from the Dialog Option button, which will be available only after choosing the Hide 
Collapsed Groups option from the Dialog Option button. The Close button is used to exit 
the dialog box. 

Figure 1-27  The Extrude dialog box

 SELECTING OBJECTS
When no tool is invoked in the current environment, the select mode will be activated. You can 
ensure that the select mode is active by pressing the ESC key. In this mode, you can select a wide 
range of objects from different environments such as individual features, part bodies, surface 
bodies, planar and non-planar faces, sketched entities, sketch and assembly constraints, and 
so on by clicking on them. Alternatively, press and hold the left mouse button and drag a box 
around the objects; all objects that lie completely inside the box are selected.
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 DESELECTING OBJECTS
By default, the selected objects are displayed in orange color. If you want to deselect 
any specifi c object from the selection, press and hold the SHIFT key and click on it; the 
object will be deselected. If you want to deselect all the selected entities, press the ESC key. 
Alternatively, press and hold the SHIFT key and drag a box around the entities; all the entities 
that lie completely inside the box are deselected. Also, you can choose the Deselect All button 
from the Selection Group to deselect all the selected entities.

 SELECTING OBJECTS USING THE QuickPick DIALOG 
BOX
If objects are close to each other, then it may be diffi cult to select the required object. In such 
cases, move the cursor over the object to be selected and wait for two seconds; the cursor will 
be changed to ‘+’ sign with three dots. Next, press the left mouse button; the QuickPick 
dialog box will be displayed. This dialog box will list all the objects near the selected object 
in the drawing window. Move the cursor over the objects listed; the corresponding objects will 
be highlighted in the drawing window. Select the required object from the QuickPick dialog 
box; the specifi ed object will get selected.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. The Modeling environment of NX is a parametric and feature-based environment. 
(T/F)

2. You can modify an existing design quickly using the Synchronous Modeling tools. (T/F)

3. The generative drafting technique is used to automatically generate the drawing views of 
parts and assemblies. (T/F)

4. By default, the Resource Bar is located on the left side of the NX window. (T/F)

5. The __________ analysis is used to check the interference and clearance between the 
components in an assembly.

6. The __________ is a fi le extension associated with all the fi les that are created in different 
environments of NX.

7. The __________keeps a track of all the operations that are carried out on the part. 

8. The  __________constraint is used to fi x a selected entity in terms of its position with 
respect to the coordinate system of the current sketch. 
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9. You can invoke the _______ tool by pressing and holding the middle mouse button.

10. The __________group is used to generate the GDT parameters, annotations, and 
symbols.

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. T, 5. Perform, 6. *.prt, 7. Part Navigator, 8. Fixed, 9. Rotate, 
10. Annotation


