
Chapter 2

Drawing Sketches for 
Solid Models

After completing this chapter, you will be able to:
• Understand various sketching tools.
• Understand various drawing display tools.
• Use various selection methods.
• Delete sketched entities.

Learning Objectives
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SKETCHING IN THE PART ENVIRONMENT
Most solid models consist of closed sketches, placed features, and reference features. A closed 
sketch is a combination of a number of two-dimensional (2D) entities such as lines, arcs, circles, 
and so on. The features based on a closed sketch are created by using these entities. Generally, 
a closed sketch-based feature is the base feature or the first feature. For example, the solid 
model shown in Figure 2-1 is created by using the sketch shown in Figure 2-2. 

Figure 2-1  Solid model Figure 2-2  Profile of the solid model

In most designs, you first need to draw a sketch, add relationships and dimensions to it, and 
then convert it into a base feature. After doing so, you can create advanced features like cuts, 
holes, ribs, shells, rounds, chamfers, and so on, on the base feature.

There are two methods to start a new document in the Part environment. The first one is to 
use the welcome screen to start a new file in the Part environment. The second one is to start 
a new part document by using the New dialog box. These methods are discussed next.

Starting a New Document in the Part Environment 
To start the Part environment, first you need to start Solid Edge. To do so, double-click on 
the shortcut icon of Solid Edge ST7 on the desktop of your computer.

The system will prepare to start Solid Edge ST7. Once all files have been loaded, the Solid 
Edge ST7 window along with the welcome screen will be displayed, as shown in Figure 2-3.

By default, the ISO Metric standard templates are available in the Create area of the welcome 
screen. To start a new part file in the default template, choose ISO Metric Part from the Create 
area of the welcome screen; the Synchronous Part environment will be invoked. To start a 
part in other templates, you need to invoke the New dialog box.

Note
If  the ANSI Metric templates is available in the Create area, you can change it to the ISO Metric 
templates. To do so, choose the Edit List option from the welcome screen of ST7; the Template 
List Creation dialog box will be displayed. In this dialog box, select the ISO Metric template 
from the Standard Templates drop-down list and then choose the OK button.
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Figure 2-3  Welcome screen of Solid Edge ST7

Starting a New Part File by Using the New Dialog Box  
You can start a new part file by using the New dialog box. To invoke this dialog 
box, choose the New tool from the Quick Access toolbar of the welcome 
screen. If the New tool is not available by default, then you need to add it to the Quick 

Access toolbar. To do so, click on the down arrow in the Quick Access toolbar; a flyout will 
be displayed. Choose the New option from the flyout; the New tool will be added to the Quick 
Access toolbar. Next, choose the New tool from the Quick Access toolbar; the New dialog 
box will be displayed, as shown in Figure 2-4. Alternatively, you can choose Application Button 
> New to invoke the New dialog box. 

Figure 2-4  The New dialog box

The left pane of the New dialog box contains Standard Templates such as ANSI Metric, GB 
Metric, ISO Metric, and so on. In this list, the ISO Metric standard template is selected 
by default. In the ISO Metric standard template, the default templates for starting various 
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environments are displayed in the area adjacent to the Standard Templates in the New dialog 
box. 

To open a new document in the Synchronous Part environment of Solid Edge ST7, select the 
iso metric part.par template and then choose the OK button from the New dialog box. 
Alternatively, double-click on iso metric part.par; the new document will open in the 
Synchronous Part environment as it is the default environment. The options in the New 
dialog box are discussed next.

Edit List Button
The Edit List button is available adjacent to the Standard Templates drop-down list. When 
you choose this button; the Template List Creation dialog box will be displayed, as shown in 
Figure 2-5.  

Figure 2-5  The Template List Creation dialog box

In this dialog box, you can change the position of the templates displayed in the Templates 
area. To do so, choose the Move Up or Move Down button, respectively to move the selected 
template up or down. These changes will also reflects in the Create area of the welcome screen. 
You can also create a new customized standard template and also rename and delete it by 
choosing the corresponding button available at the left corner of the Template List Creation 
dialog box. The newly created standard template name will be displayed under the Custom 
Templates drop-down list available on the left pane of the dialog box. The newly created custom 
standard templates will also be displayed in the Custom Templates drop-down list in the New 
dialog box.  

Note
You can also create a customized standard template in the dialog box by creating a folder with the 
name Custom Template at the location Program File > Solid Edge ST7 > Template and then 
saving a customized template in it. This template will automatically be added to the Custom 
Templates drop-down list.
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Large Icon 
The Large Icon button is used to display the templates in various tabs of the New dialog box 
in the form of large icons.

List 
The List button is used to display the templates in various tabs of the New dialog box in the 
form of a list.

Detail 
The Detail button is used to list the details of the templates in various tabs of the New dialog 
box. When you choose this button, the area on the left will be divided into four columns. The 
first column lists the names of the templates, the second column lists the sizes, the third column 
lists the type of the template files, and the last column lists the dates when the templates were 
last modified.

Preview Area
The Preview area shows a preview of the selected template.

Figure 2-6 shows a new Solid Edge document in the Synchronous Part environment. This 
figure also shows various components in the part document of Solid Edge. On invoking this 
environment, two triads are displayed. Also, the Sketching tab is added to the Ribbon. This 
tab is used to create sketches.

Figure 2-6  New document in the Part environment
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Note
1. In the Synchronous Part environment, the basic drawing tools are available in the Home 
tab as well as in the Sketching tab.

2. You can start Solid Edge directly in a particular template file. To do so, choose the Application 
Button from the top left of the application window; a flyout will be displayed  Choose the Solid 
Edge Options button from the flyout; the Solid Edge Options dialog box will be displayed. In 
this dialog box, choose Helpers and then select the required template from the drop-down list 
next to the Start using this template radio button.

 

TRANSITION BETWEEN PART ENVIRONMENTS
In Solid Edge ST7, there are two modeling environments coexisting in the same file, the 
Synchronous Part environment and Ordered Part environment. The Synchronous Part 
environment is used to create synchronous features whereas the Ordered Part environment is 
used to create ordered features. Note that the Ordered Part environment was earlier referred as 
the traditional environment. By default, a new Solid Edge document starts in the Synchronous 
environment. In Solid Edge  ST7, you can work in both the environments in the same file. 
You can switch between the Synchronous and Ordered environments at any time during 
the modeling process. To do so, right-click in the graphics window; a shortcut menu will be 
displayed. Choose the Transition to Ordered or Transition to Synchronous option from the 
shortcut menu to switch from Synchronous Part environment to Ordered Part or vice-versa. 
You can also switch between environments by choosing the required modeling environment 
from the Model group of the Tools tab.

STARTING A SKETCH IN THE PART ENVIRONMENT
In the Synchronous Part environment, a triad representing the base coordinate system is 
displayed at the center of the graphics area. You can draw sketches on any of the principal 
planes of the base coordinate system. To draw a sketch, invoke a sketching tool from the Draw 
group; two green lines of infinite length get attached to the cursor. Move the cursor toward  the 
axis of the base coordinate system; you will notice that the respective plane gets highlighted 
and a Lock symbol is displayed on it. 

You can also select the required plane by using the QuickPick listbox. To do so, move the cursor 
toward the base coordinate system and wait for a while; a mouse symbol will be displayed near 
the cursor. Next, right-click; the QuickPick list box will be displayed with a list of alternate 
planes that can be selected for drawing the sketches, as shown in Figure 2-7. Now, you can 
select the required plane for sketching.

Figure 2-7  The QuickPick list box with the list 
of planes
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Note
In Solid Edge, the base reference planes are hidden by default. You can display the base reference 
planes individually or in group by selecting the Base Reference Planes check box in the 
PathFinder.

Locking and Unlocking Sketching Plane 
If you want all input commands to be in the same plane, you can lock that sketch plane. It 
implies that all the sketches and their dimensions are drawn on the same plane. To lock the 
plane, click on the Lock symbol that will be displayed on selecting any principal plane or 
face of the solid. On doing so, the sketch plane will get locked and the Lock symbol will be 
displayed at the upper right corner of the drawing window. Now, you can draw sketches, add 
dimensions to them, and so on. In this case, you will notice that the sketches along with their 
relationships and dimensions are on the same plane, and will be added as a single sketched 
entity under the Sketches node of the PathFinder. The plane will remain locked until you 
unlock it by clicking on the Lock symbol again. If you want to draw a sketch in some other 
plane, first you need to unlock the plane and then invoke a sketching tool again. Next, select 
the required plane. 

However, to draw a sketch in the Ordered Part environment, switch to the Ordered Part 
environment and choose the Sketch tool from the Sketch group of the Home tab; you will be 
prompted to click on a planar face or a reference plane. Select a reference plane, the selected 
plane will be oriented parallel to the screen and the sketching environment will be invoked. 
Now, you can draw the sketch using various sketching tools that are discussed next.

SKETCHING TOOLS
In the Synchronous Part environment, the sketching tools are available in the ribbon of the 
synchronous part environment. But in the Ordered Part environment, you first need to invoke 
the sketch environment to use a sketching tool. All the tools required to create a profile or a 
sketch in Solid Edge are available in the Draw group and are discussed next.

Drawing Lines
 Ribbon: Home > Draw > Line 

In any design, lines are the most widely used sketched entities. In Solid Edge, the 
Line tool is used to draw straight lines as well as to draw the tangent or normal arcs 
originating from the endpoint of a selected line. The properties of the line are displayed 

in the command bar, as shown in Figure 2-8.

Figure 2-8  The Line command bar

Drawing Straight Lines
To draw a straight line, choose the Line tool; you will be prompted to select the first point for 
the line. Specify the point (click) in the drawing window by pressing the left mouse button; a 
rubber-band line will be attached to the cursor. Also, you will be prompted to select the second 
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point for the line. Note that on moving the cursor in the drawing window, the length and 
angle of the line also gets modified accordingly in the Line command bar. Next, specify the 
endpoint of the line in the drawing window by pressing the left mouse button. Alternatively, 
you can draw a line by specifying its length and angle in the Line command bar.

While drawing a line, you will notice that some symbols are displayed on the right of the 
cursor. For example, after specifying the start point of the line, if you move the cursor in the 
horizontal direction, a symbol similar to a horizontal line will be displayed. This symbol is 
called the relationship handle and it indicates the relationship that will be applied to the entity 
being drawn. In the above-mentioned case, the horizontal relationship handle is displayed 
on the right of the cursor. This relationship will ensure that the line you draw is horizontal. 
These relationships are automatically applied to the profile while drawing a line.
 

Note
Relationships are also applied between the sketched entities and the reference planes. You will 
learn more about relationships in the later chapters.

The process of drawing lines does not end after defining the first line. You will notice that as 
soon as you define the endpoint of the first line, another rubber-band line starts. The start 
point of this line becomes the endpoint of the first line and the endpoint of the new line is 
attached to the cursor. 

The process of drawing consecutive lines continues until you right-click to terminate it. 
However, even after right-clicking, the Line tool will remain active and you will be prompted 
to specify the first point of the line. You can terminate the Line tool by choosing the Select tool 
from the Select group or by pressing the ESC key. Figures 2-9 and 2-10 show the continuous 
lines being drawn.

Figure 2-10  Horizontal relationship handle 
displayed while drawing the horizontal line

Figure 2-9  Vertical relationship handle displayed 
while drawing the vertical line

While drawing lines, you will notice that if the cursor is horizontally or vertically aligned with 
the endpoint or midpoint of a line or reference plane, then the dashed lines are displayed. 
These dashed lines are called alignment indicators and are used to indicate the horizontal 
or vertical alignment of the current location of the cursor with a point. Figure 2-11 shows 
the alignment indicators originating from the endpoints of the existing lines.
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Tip. If the alignment indicator is not displayed, move the cursor over the entity from 
which you want the alignment indicator to originate; the entity will turn orange in color 
and the alignment indicator will be displayed.

Drawing Tangent and Normal Arcs
As mentioned earlier, you can draw a tangent or a normal arc by using the Line tool. To draw an 
arc when the Line tool is active, press the A key or choose the Arc button from the command bar. 
On doing so, you will notice that the Length and Angle edit boxes in the command bar are 
replaced by the Radius and Sweep edit boxes, respectively. These edit boxes can be used to 
define the radius and the included angle of the resulting arc.

Also, a small circle will be displayed at the start point of the arc. This circle is divided into 
four regions. These regions are called intent zones and are used to define the type of the arc 
to be created. To create an arc tangent to a line, move the cursor through a small distance in 
the zone that is tangent to the line; the tangent arc will be displayed. Next, click to specify the 
endpoint of the arc. Similarly, if you move the cursor in the zone that is normal to the line, 
the normal arc will be displayed. Next, click to specify the endpoint of the arc. After drawing 
the required arc, the system will automatically switch back to the line mode. You can activate 
the line mode or the arc mode by pressing the L or the A key, respectively. Figure 2-12 shows 
a tangent arc being drawn using the Line tool.

Tip. If you have selected an incorrect point as the start point of a line, right-click to 
cancel it; you will again be prompted to specify the first point of the line.

Figure 2-11  The alignment indicators originating 
from the endpoints of the existing lines

Figure 2-12  A tangent arc drawn using 
the Line tool
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The buttons in the Line command bar are used to specify the color, type, and width of lines. You 
can also draw a projection line of infinite length by choosing the Projection Line button from 
the Line command bar. Projection lines are generally used in the Draft environment.

Placing Sketched Points
  Ribbon: Home > Draw > Line drop-down > Point  

Points are generally used as references for drawing other

Figure 2-13  The Line 
drop-down

 
sketched entities. To place a point, choose the Point tool 
from the Line drop-down in the Draw group, as shown in 

Figure 2-13; you will be prompted to click for the point. Place the 
point by defining its location in the drawing window or by entering 
its coordinates in the Point command bar.

FreeSketch           
 Ribbon: Home > Draw > Line drop-down > FreeSketch 

The FreeSketch tool enables you to draw lines, arcs, rectangles, and circles by converting
a rough sketch into a precision drawing. When you choose the FreeSketch tool from the  
Line drop-down, the FreeSketch command bar will be displayed, as shown in Figure 2-14. 
The commonly used button in the FreeSketch command bar are discussed next.

Figure 2-14  The FreeSketch command bar

Adjust On
This button is chosen  by default. As a result, when you draw a rough line sketch, the software 
recognizes the sketch and adjusts its orientation as horizontal or vertical. When you draw a 
rough curve, the sketch is automatically recognized as an arc.

Adjust Off    
When you choose this button, the software does not recognize the rough sketch and the sketch 
will remain the same as drawn.

Drawing Circles       
In Solid Edge, circles can be drawn by using three tools.

Figure 2-15 The Circle drop-down

These tools and the tools to draw ellipses are grouped 
together in the Circle drop-down of the Draw group, as 
shown in Figure 2-15. The tools used to draw circles are 
discussed next.
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Drawing a Circle by Specifying the Center Point and the Radius
  Ribbon: Home > Draw > Circle drop-down > Circle by Center Point  

This is the most widely used method of drawing circles. In this method, you need to 
specify the center point for the circle and a point on it. The point on the circle defines 
the radius of the circle. To draw a circle using this 

Figure 2-16 Circle drawn using the 
Circle by Center Point tool

method, choose the Circle by Center Point tool from the 
Draw group; the Circle by Center Point command bar will 
be displayed and you will be prompted to specify the center 
point of the circle. Specify the center point of the circle in 
the drawing window. Next, you will be prompted to specify 
a point on the circle. Specify a point on the circle to define 
the radius. Alternatively, you can enter the value of the 
diameter or radius in the command bar. Figure 2-16 shows 
a circle drawn using this method.

Drawing a Circle by Specifying Three Points
 Ribbon: Home > Draw > Circle drop-down > Circle by 3 Points 

This method is used to draw a circle by specifying three points lying on it. To draw a 
circle using this method, choose the Circle by 3 Points tool in the Draw group; you 
will be prompted to specify the first point and then the second point for the circle. 

Specify these two points; small reference circles will be displayed on these two points, as shown 
in Figure 2-17. Also, you will be prompted to specify the third point. Specify the third point 
for the circle to create it. 

Drawing a Circle by Using the Tangent Circle Tool
 Ribbon: Home > Draw > Circle drop-down > Tangent Circle 

This method is used to draw a circle tangent to one or two existing entities. To draw 
a circle using this method, choose the Tangent Circle tool from the Circle drop-down in 
the Draw group; you will be prompted to specify the first point on the circle. The 

circle will be drawn using two or three points, depending upon how you specify the first point 
of the circle. If you specify the first point on an existing entity, then you will be prompted to 
specify the second point and the circle will be drawn using these two points. However, if you 
do not specify the first point on any existing entity, then you need to define the circle using three 
points.

When you move the cursor close to an existing entity to specify the second or third point, 
the tangent relationship handle will be displayed. Now, if you specify the point, the resulting 
circle will be tangent to the selected entities. Also, small reference circles will be displayed 
at the points where the circle is tangent to the selected entities. Figure 2-18 shows a circle 
tangent to two lines.
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Figure 2-17  Circle drawn using the Circle 
by 3 Points tool

Figure 2-18  Circle drawn using the Tangent Circle 
tool

Drawing Ellipses
In Solid Edge, you can draw ellipses using two methods that are discussed next.      
    
Drawing an Ellipse by Specifying Center Point
 Ribbon: Home > Draw > Circle drop-down > Ellipse by Center Point 

This method is used to draw a center point ellipse. In this method, first you need to 
define the center point of an ellipse. On doing so, you will be prompted to specify 
the endpoint of the primary axis. Specify the endpoint of the primary axis; you will 

be prompted to specify the endpoint of the secondary axis. Specify the endpoint of the 
secondary axis; the ellipse will be created. You can also draw an ellipse by entering the required 
dimensions in the command bar and then specifying its center point.

Drawing an Ellipse by Specifying Three Points
 Ribbon: Home > Draw > Circle drop-down > Ellipse by 3 Points 

This method is used to draw an ellipse by specifying

Figure 2-19  An ellipse drawn 
by specifying three points

 
three points. The first two points are the first and 
second endpoints of the primary axis of the ellipse 

and the third point is a point on the ellipse. To draw an ellipse 
by using this method, choose the Ellipse by 3 Points 
tool from the Draw group; you will be prompted to specify 
the first endpoint. Specify the first endpoint, you will be 
prompted to specify the second endpoint of the primary axis 
of an ellipse. Specify the second point; a reference ellipse will 
be displayed and you will be prompted to specify a point on 
the ellipse. The primary axis will act as the major axis or the 
minor axis, depending upon the location of point specification. 
Figure 2-19 shows a profile in which the cursor is moved to 
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define the third point on the ellipse to create it. Note that you can also draw an ellipse by 
specifying values in the Ellipse by 3 Points command bar, which is displayed on invoking this 
tool.

Drawing Arcs
In Solid Edge, tools to draw an arc are grouped together in the Arc drop-down, as shown in 
Figure 2-20. You can draw arcs using three methods. These methods are discussed next.
 
Drawing an Arc by Using the Tangent Arc Tool
 Ribbon: Home > Draw > Arc drop-down > Tangent Arc 

The method of drawing an arc using the Tangent Arc tool is 
similar to drawing the tangent and normal arcs using the 
Line tool. To draw a tangent arc, choose the Tangent Arc 

tool from the Arc drop-down, refer to Figure 2-20. On doing so, you 
will be prompted to specify the start point of the arc. Move the cursor 
close to the endpoint of the entity where you want to start the tangent 
arc. You will notice that the endpoint relationship handle is displayed 
to the right of the cursor. This handle has a small inclined line with 
a point at the upper end, which suggests that if you select the point now, the endpoint of the 
entity will be snapped. Select the endpoint and then move the cursor; the intent zones will be 
displayed. Move the cursor through a small distance in the required intent zone and then 
specify the endpoint of the arc. Alternatively, you can enter the radius and the included angle 
of the arc in the Tangent Arc command bar, which is displayed when you invoke this tool.

Drawing an Arc Using the Arc by 3 Points Tool
 Ribbon: Home > Draw > Arc drop-down > Arc by 3 Points 

This method is used to draw an arc by specifying its start point, endpoint, and the third 
point on its periphery. The third point is used to specify the direction in which the arc 
will be drawn. You can specify the radius of this arc in the command bar. Figure 2-21 

shows a three-points arc drawn by this method.

Drawing an Arc by Using the Arc by Center Point Tool
 Ribbon: Home > Draw > Arc drop-down > Arc by Center Point 

This method is used to draw an arc by specifying its center point, start point, and 
endpoint. Invoke the Arc by Center Point tool; you will be prompted to specify the 
center point of the arc. Specify the center point of the arc; you will be prompted to 

specify its start point and then the endpoint. Note that when you specify the start point of the 
arc, the radius will be automatically defined. And on specifying the endpoint of the arc, the 
length of the arc will be defined. Figure 2-22 shows an arc drawn by using this method.

Figure 2-20 The Arc 
drop-down
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Figure 2-21  An arc drawn by specifying 3 
points

Figure 2-22  An arc drawn by specifying 
center point

Drawing Rectangles
In Solid Edge, you can draw rectangles using three methods that are discussed next.

Drawing a Rectangle by Specifying its Center
 Ribbon: Home > Draw > Rectangle drop-down > Rectangle by Center 

In Solid Edge, you can draw a rectangle by specifying its center point and any of its 
vertices. To draw a rectangle by using this method, choose the Rectangle by Center 
tool from the Rectangle drop-down, refer to Figure 2-23; you will be prompted to 

specify the center point of the rectangle.

Click in the drawing window to specify the center point of the rectangle and move the cursor; 
the dynamic preview of the rectangle will be displayed in the graphics window, as shown in 
Figure 2-24 and you will be prompted to specify a point to create a rectangle. Specify a point; 
the point specified will define the height and width of the rectangle. Alternatively, you can 
specify the width, height, and angle of the rectangle in the command bar. 

Figure 2-23  The Rectangle 
drop-down

Figure 2-24  Dynamic preview of the rectangle 
displayed on specifying its center
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Tip. You can also draw a rectangle by pressing and holding the left mouse button at a 
point and dragging the cursor across to define the opposite corner of the rectangle. When 
you release the left mouse button, the rectangle will be drawn.

Drawing a Rectangle by Specifying Two Points
  Ribbon: Home > Draw > Rectangle drop-down > Rectangle by 2 Points  

You can also draw a rectangle by specifying two diagonally opposite corners. To draw 
a rectangle by using this method, choose the Rectangle by 2 Points tool; you will be 
prompted to specify the first corner of the rectangle. Click in the drawing window to 

specify the first corner of the rectangle; the dynamic preview of the rectangle will be displayed 
in the graphics window, as shown in Figure 2-25, and you will be prompted to click in the 
drawing window to specify the second corner. Click in the drawing window or specify the 
values width and height values in the Rectangular by 2 Points command bar to specify the 
diagonally opposite corner; a rectangle will be created.

Drawing a Rectangle by Specifying Three Points
 Ribbon: Home > Draw > Rectangle drop-down > Rectangle by 3 Points 

You can also draw rectangles by specifying three points. The first two points define 
the width and orientation of the rectangle and the third point defines its height. To 
draw a rectangle by specifying three points, invoke the Rectangle by 3 Points tool; 

you will be prompted to specify the first corner. Specify a point in the drawing window to 
define the start point of the rectangle; you will be prompted to specify the second point. This 
point will define the width of the rectangle. You can also define this point at an angle. On 
doing so, the rectangle will be drawn at an angle. After specifying the width of the rectangle, 
you will be prompted to specify a point that will define the height of the rectangle. Specify 
the point; the rectangle will be created. Alternatively, you can specify the width, height, and 
angle of the rectangle in the Rectangle by 3 points command bar. Figure 2-26 shows a rectangle 
drawn at an angle.

Figure 2-25  Drawing a rectangle by specifying two 
diagonally opposite corners

Figure 2-26 Rectangle drawn at an angle 
by using the Rectangle by 3 points
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Drawing Polygons
  Ribbon: Home > Draw > Rectangle drop-down > Polygon by Center  

The polygons drawn in Solid Edge are regular polygons. A regular polygon is a 
geometric figure with many sides, and in it the length of all sides and the angle between 
them are the same. In Solid Edge, you can draw a polygon with the number of sides 

ranging from 3 to 200. To create a polygon, choose the Polygon by Center tool from the 
Rectangle drop-down of the Draw group; you will be prompted to specify the center point of 
the polygon. Click in the graphics window to specify the center point of the polygon; the 
dynamic preview of the polygon will be displayed. In the preview, you will notice that an 
imaginary circle is drawn such that all its vertices touch the circle. This imaginary circle will 
be used as the construction geometry for creating the polygon. 

Note that if the By Midpoint button is chosen in the Polygon by Center command bar, you 
can specify the midpoint of an edge of the polygon, as shown in Figure 2-27. If you choose 
the By Vertex button from the Polygon by Center command bar, you can specify the vertex 
of the polygon, as shown in Figure 2-28. 

Figure 2-27  Drawing a polygon by using 
the By Midpoint button

Figure 2-28  Drawing a polygon by using 
the By Vertex button

Next, in the Polygon by Center command bar, specify the number of sides of the polygon in 
the Sides spinner. In the Distance edit box, specify the distance between the two specified 
points of the polygon. In the Angle edit box, specify the orientation of the polygon with 
respect to the horizontal axis.

Drawing Curves         
  Ribbon: Home > Draw > Curve  

 To draw the curve, choose the Curve tool from the Draw group of the Home tab; the 
Curve command bar will be displayed. The Curve tool allows you to draw curves by 
using two methods: by specifying points in the drawing window, and by dragging the 
cursor in the drawing window. These methods are discussed next.



Drawing Sketches for Solid Models                                     2-17

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Drawing a Curve by Specifying Points in the Drawing Window
In this method, you need to continuously specify points in the drawing area to draw a curve 
passing through them. After specifying the first point, move the cursor and specify the second 
point. Continue specifying points until you have specified all the points required for drawing 
the curve. Figure 2-29 shows a curve drawn by using this method.

Drawing a Curve by Dragging the Cursor 
In this method, you need to press and hold the left mouse button and drag the cursor to create 
a curve. A reference curve will be displayed in the drawing window as you drag the cursor. 
Once you release the left mouse button, a curve will be drawn that has approximately the same 
shape as that of the reference curve. Figure 2-30 shows a curve drawn by using this method.

Figure 2-29  Curve drawn by specifying points 
in the drawing window

Figure 2-30  Curve drawn by dragging the cursor 
in the drawing window

You can also create a closed curve by using the Curve tool. To do so, invoke the Curve tool 
from the Draw group and then choose the Close Curve button from the Curve command 
bar. Next, specify the first point to start the curve; a rubber line will get attached to the cursor. 
Specify the end point and move the cursor in the drawing area and click for the third point 
to create the closed curve. 

Clean Sketch
  Ribbon: Home > Draw > Clean Sketch 

The Clean Sketch command is used to remove unnecessary or overlapping elements 
from the sketch. To remove the overlapping entities, choose the Clean Sketch tool from 
the Draw group in the Home tab; the Clean Sketch command bar will be displayed, 

refer to Figure 2-31. Now, choose the Clean Sketch - Clean Sketch Options button from this 
command bar; the Clean Sketch Options dialog box will be displayed, refer to Figure 2-32. 
The options in this dialog box are discussed next.
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Figure 2-31 The Clean Sketch 
command bar

Figure 2-32 The Clean Sketch 
Options dialog box

Clean B-Spline curves
The Clean B-Spline curves check box in the Clean Sketch Options dialog box is selected to 
delete the B-spline curves from the sketch, refer to Figure 2-32.

Delete elements
The Delete elements radio button in the dialog box is selected to delete the duplicate entities.

Move elements to
The Move elements to radio button is selected to move the duplicate entities to a separate 
layer. To move the duplicate entities, select this radio button from the Clean Sketch Options 
dialog box; the Move elements to drop-down list and the New Layer button on its right will 
be activated, refer to Figure 2-33. Next, choose the New Layer button to create a new layer; 
the New Layer dialog box will be displayed, refer to Figure 2-34. Enter the required layer 
name in the New Layer name edit box and choose the OK button, a new layer will be created 
and displayed in the Layer drop-down list. Now, you can select the required layer from this 
drop-down list.

Figure 2-33  The Move elements to 
radio button selected

Figure 2-34 The New Layer 
dialog box

Identical elements
The Identical elements check box is selected to remove the identical entities in the sketch.

Point elements
The Point elements check box is selected to remove the point entities in the sketch. 
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Line and arc lengths less than
The Line and arc lengths less than check box is selected to remove the line and arc entities 
of a value lesser than the user defined value from the sketch.

Note
You can not move or delete the sketched entities using this command on which any relationship 
is applied.

Converting Sketched Entities into Curves
  Ribbon: Sketching > Draw > Convert to Curve  

In Solid Edge, you can convert the sketched entities such as lines, arcs, circles, and 
ellipses into bezier spline curves by using the Convert to Curve tool. On invoking this 
tool, you will be prompted to select an element to be converted into a curve. As soon 

as you select the element, it will be converted into a bezier spline curve. Note that you may 
not be able to view the changes in the sketched entity unless you select it. When you select the 
sketched entity, you will notice that the number of handles in it has increased and the control 
polygon is displayed on that entity. If you drag the converted entity using any of its handles, 
it will become a curve. 

Filleting Sketched Entities   
 Ribbon: Home > Draw > Fillet drop-down > Fillet 

Filleting is a process of rounding sharp corners of a profile. 

Figure 2-35 The Fillet 
drop-down 

You can create a fillet by removing sharp corners and 
then replacing them with round corners. In Solid Edge, you 

can create a fillet between any two sketched entities. To create a fillet, 
choose the Fillet tool from the Fillet drop-down in the Draw group, 
refer to Figure 2-35; the Fillet command bar will be displayed. Enter 
the radius of the fillet in the Radius edit box of the command bar 
and press ENTER. Next, select the two entities that you want to fillet; the fillet will be created. 
You can also directly select the sharp corners to be filleted. The two entities comprising the 
corner will be highlighted in orange when you move the cursor over the corner. Select the 
corners at this stage to create the fillet. Figure 2-36 shows a profile before and after filleting 
the corner.

You can retain the sharp corner even after creating the fillet. To do so, choose the No Trim 
button from the Fillet command bar and then select the corner to be filleted; the fillet will be 
created and the sharp corner will be retained. Figure 2-37 shows a profile in which the fillet 
is created with the sharp corner retained.

Note 
Ideally, the profiles that have the fillet created with the sharp corners retained may not give the 
desired result when used for creating features. Therefore, they should be avoided.

 



2-20         Solid Edge for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 2-37  Sharp corner retained 
after creating the fillet

Figure 2-36  Sketch before and after creating 
the fillet

Chamfering Sketched Entities
 Ribbon: Home > Draw > Fillet drop-down > Chamfer 

Chamfering is a process of beveling the sharp corners of a profile to reduce the stress 
concentration. You can create a chamfer only between two linear entities. A chamfer 
can be created by defining the distance of the corner being chamfered from the two 

edges of the profile, or by defining the angle of the chamfer and the distance along one of 
the edges. To create a chamfer, invoke the Chamfer tool; the Chamfer command bar will be 
displayed. In this command bar, the Angle, Setback A, and Setback B edit boxes are available. 
The Setback A and Setback B values define the chamfer distance along the first and second 
edges, respectively. The Angle edit box defines the inclination angle of the chamfer. Note that 
you can specify any two of the three values. The third value is automatically updated on the 
basis of the two values that you defined.

After setting any two values in the Chamfer command bar, select the first line and the second 
line to be chamfered; the preview of the resulting chamfer will be displayed. Next, click to 
create the chamfer. Note that the first line is taken as the setback A element and the second 
line is taken as the setback B element, by default. If you want to reverse the order, move the 
cursor over the first line. You will notice that now the second line is taken as the setback A 
element, and the first line is taken as the setback B element. Consequently, the preview will 
also change. By default, the setbacks A and B are displayed in orange. Figure 2-38 shows the 
preview of the chamfer. 

Figure 2-38 Preview of the chamfer



Drawing Sketches for Solid Models                                     2-21

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

THE DRAWING DISPLAY TOOLS
The drawing display tools are an integral part of any solid modeling tool. They enable you 
to zoom, fit and pan the drawing so that you can view it clearly. The drawing display tools 
available in Solid Edge are discussed next.

Zooming an Area
  Ribbon: View > Orient > Zoom Area   
  Status Bar: Zoom Area        

The Zoom Area tool allows you to zoom into a particular area by defining a box around 
it. You can invoke this tool from the Orient group in the View tab or directly from the 
Status bar. On invoking this tool, a plus sign (+) of infinite length will be attached to 

the tip of the cursor and you will be prompted to click to define the first corner or drag to 
specify the box. Specify a point on the screen to define the first corner of the zoom area. Next, 
move the cursor and specify another point to define the opposite corner of the zoom area. 
The area defined inside the box will be zoomed and displayed on the screen.

Zooming Dynamically
 Ribbon: View > Orient > Zoom  
 Status Bar: Zoom   

The Zoom tool enables you to dynamically zoom in or out the drawing. You can also 
use this tool to increase the display area to double the current size. To zoom into the 
drawing, press and hold the left mouse button in the center of the screen and then 

drag the cursor down. To zoom out the drawing, press and hold the left mouse button in the 
center of the screen and drag the cursor up. 

To increase the drawing display area to double of the current size, invoke this tool and click 
anywhere in the drawing window. On doing so, the drawing display area will increase such that 
the point at which you clicked will be moved to the center of the screen. Alternatively, you can 
zoom in and zoom out of the drawing area by scrolling the mouse, when no other tool is active. 

Fitting All Entities into the Current Display
 Ribbon: View > Orient > Fit  
 Status Bar: Fit   

The Fit tool enables you to modify the drawing display area such that all entities in 
the drawing fit in the current display.

Panning the Drawings
 Ribbon: View > Orient > Pan  
 Status Bar: Pan   

The Pan tool allows you to dynamically pan the drawing in the drawing window. When 
you invoke this tool, the arrow cursor will be replaced by a hand cursor and you will 
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be prompted to click to select the origin or drag the cursor for the dynamic pan. Press and 
hold the left mouse button in the drawing window, and then drag the cursor to pan the draw-
ing. You can also pan the drawing by specifying two points in the drawing window. First, 
specify a point anywhere in the drawing window and then move the cursor. You will notice 
that a rubber-band line is displayed. One end of this line will be fixed at the point you specified 
and the other end will be attached to the hand cursor. Move the cursor and specify another 
point in the drawing window to pan the drawing. Alternatively, you can press the SHIFT key 
and drag the mouse by pressing the middle mouse button for panning.

Restoring the Original Orientation of the Sketching Plane
 Ribbon: View > Views > Sketch View  
 Status Bar: Sketch View              

Sometimes while using the drawing display tools, the orientation of the sketching 
plane may change. The Sketch View tool enables you to restore the original orientation 
that was active when you invoked the sketching environment. Note that this tool is 

available only in the sketching environment.

Tip. You can also use the keyboard to modify the drawing display area. To do so, the 
following combination of keys can be used:

CTRL+ Bottom arrow key = Zoom out
CTRL + SHIFT+ Bottom arrow key = Pan downward
SHIFT+ Top/Right arrow key = Rotate clockwise
SHIFT+ Bottom/Left arrow key = Rotate counter clockwise

SELECTING SKETCHED ENTITIES
You can select the sketched entities available in the drawing window by invoking the Select 
mode. To do so, choose the Select tool from the Select group; the Select mode will be invoked. 
Next, click on the required entity to select it. Note that you can exit from any active tool by 
activating the Select mode or by pressing the ESC key. The other tools available in the Select 
group are discussed next.

Overlapping
This selection option ensures that all the entities that either lie partially inside the boundary 
or even touch the boundary are selected. 

Selection Filter
This option is used to control whether the element type can be selected or not. A check mark 
is displayed adjacent to the element types that can be selected.

DELETING SKETCHED ENTITIES
To delete sketched entities, select them using any one of the object selection methods discussed 
above; the selected entities will turn green in color. Next, press the DELETE key; all the 
selected entities will be deleted. 
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GRID
In Solid Edge, you can display the grid while creating a sketch. Also, you can configure the 
grid settings using the grid tools available in the Draw group of the Sketching tab. These 
tools are discussed next.

Show Grid
 This button is used to toggle the grid display on/off in the Solid Edge drawing area. To 
turn the grid display on, choose the Show Grid button from the Draw group in the 

Sketching tab. Figure 2-39 shows the rectangle drawn after turning the grid display on. Choose 
the Show Grid button again; the grid display turns off. 

Figure 2-39  Sketch drawn when the Show Grid button display is on 

Snap to Grid
When this button is chosen, the cursor will snap to grid points.

XY Key-in
This button is used to move the drawn entity up to the required length by specifying the 
values in the X and Y edit boxes. To specify the value, choose the XY key-in button from 

the Sketching tab; the X and Y edit boxes will be displayed, as shown in Figure 2-40.

Figure 2-40  X and Y edit boxes displayed
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Grid Options
You can also configure the grid settings by using the Grid Options dialog box. To invoke this 
dialog box, choose Sketching > Draw > Grid Options from the Ribbon. Figure 2-41 shows the 
Grid Options dialog box. The options in this dialog box are used to control the grid settings.

Figure 2-41 The Grid Options dialog box displayed 

REPOSITION ORIGIN
Using this tool you can change the position of the origin point. Note that this tool will 
be available only when the sketching plane is locked. On choosing this tool, the steering 
wheel will be displayed, as shown in Figure 2-42. You can use the steering wheel to change 

the location of the origin point. To change the location of the origin point, select the origin 
knob of the steering wheel and move the cursor to the required location, refer to  Figure 2-43. 
You can select a part edge, a keypoint, a grid point, or another type of point to define the new 
location of the origin.

Figure 2-42  Steering wheel displayed in 
the drawing area 

Figure 2-43  Specifying the new location of 
the origin

ZERO ORIGIN
On choosing this tool, the origin point is reset to the default location.
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TUTORIALS
Tutorial 1               Synchronous 

In this tutorial, you will draw the profile of the model shown in Figure 2-44. The 
profile to be drawn is shown in Figure 2-45. Do not dimensions the profile as they are 
for reference only.              (Expected time: 30 min)

Figure 2-45  Profile for Tutorial 1Figure 2-44  Model for Tutorial 1

 The following steps are required to complete this tutorial:  

a. Start Solid Edge ST7 and then start a new file in the Synchronous Part environment.
b. Draw the outer loop of the profile using the Line tool.
c. Fillet the sharp corners of the outer loop by using the Fillet tool.
d. Draw circles using the centers of fillets to complete the profile.
e. Save the file and close it.

Starting a Solid Edge Document
 You will create the profile of the model using the tools in the Sketching tab of the 

Synchronous Part environment of Solid Edge. To create this profile, first you need to 
start a new part file.

1. Double-click on the shortcut icon of Solid Edge ST7 on the desktop of your computer. 

 Now, you need to start a new part file to draw the sketch of the given model.

2. Click on the ISO Metric Part template in the Create area of the welcome screen; a new 
Solid Edge part file gets started.

Creating the Outer Loop of the Profile
 You need to draw the outer loop of the profile by using the Line tool. The sharp corners 

of the outer loop will be rounded by using the Fillet tool. In this tutorial, you will use the 
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dynamic edit box displayed in the drawing area to enter the exact dimension of the 
 sketched entities.

1. Choose the Line tool from the Draw group of the Home tab; the Line command  
bar is displayed and the alignment lines are attached to the cursor. 

2. Next, you need to define the plane on which you want to draw the profile of the base 
feature. Hover the cursor on the base coordinate system until a mouse symbol is displayed, 
and then right click; the QuickPick list box is displayed with the possible nearest selection. 
Next, choose the XZ plane for sketching.

3. By default, the view orientation of the part document is set to Diametric. Choose 
Sketch View from the Views group of the View tab; the sketching plane orients 
parallel to the screen.

4. Move the cursor towards the origin and click when an endpoint snap is displayed at the 
origin; the start point of the line is specified.

 The point specified by you is selected as the start point of the line and an endpoint of 
the line is attached to the cursor. As you move the cursor on the screen, the line stretches 
and its length and angle values get dynamically modified in the command bar.

 Next, you need to specify other points to define the first line whereas the remaining lines 
by using the Length and Angle dynamic edit boxes.  

5. Enter 200 in the Length dynamic edit box and press ENTER. Next, enter 0 in the Angle 
dynamic edit box and press ENTER. 

 On specifying the length and angle values, you will notice that the line is drawn, but it is 
not completely displayed. To include it into the current display, you need to modify the 
drawing display area by using the Fit tool. 

6. Choose the Fit tool from the Status bar; the current drawing display area is modified  
and the complete line is displayed in the current view. Also, the Line tool still 
remains active, and you are prompted to specify the second point of the line. 

7. Enter 90 in the Length dynamic edit box and press ENTER. Next, enter -90 in the Angle 
dynamic edit box and press ENTER; a vertical line of length 90 mm is drawn. You can 
use the Fit tool to modify the current drawing display area as discussed earlier.

8. Enter 40 in the Length dynamic edit box and press ENTER. Enter 180 in the Angle 
dynamic edit box and press ENTER; a horizontal line of 40 mm is drawn toward the left 
of the last line.

9. Enter 40 in the Length dynamic edit box and press ENTER. Enter 90 in the Angle dynamic 
edit box and press ENTER; a vertical line of 40 mm is drawn downward.
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10. Enter 120 in the Length dynamic edit box and press ENTER. Enter 180 in the Angle 
dynamic edit box and press ENTER; a horizontal line of 120 mm length is drawn.

11. Move the cursor vertically upward; a rubber-band line is displayed with its start point at 
the endpoint of the previous line and the endpoint attached to the cursor. When the line 
becomes vertical, the vertical relationship handle is displayed.

12. Move the cursor vertically upward until the horizontal alignment indicator (dotted line) 
is displayed at the top endpoint of the vertical line of 40 mm length. If the horizontal 
alignment indicator is not displayed, move the cursor once to the top end-point of the 
vertical line and then move it back to its original position. Note that at this point, the 
value in the Length dynamic edit box is 40 and the value in the Angle dynamic edit box 
is -90. Next, click  on the dotted line to specify the endpoint of this line.

13. Move the cursor horizontally toward the left above the vertical plane, and then make sure 
that the horizontal relationship handle is displayed. Next, move the cursor once on the 
vertical plane and then vertically upward. Click when the intersection relationship handle 
is displayed.

14. Move the cursor vertically downward towards the origin. If the first line is not highlighted 
in orange, move the cursor once over it and then move it back to the origin. The 
endpoint relationship handle is displayed. This relationship ensures that this line ends 
at the start point of the first line.

15. Click to specify the endpoint of the line when the endpoint relationship handle is displayed. 
Choose the Fit button to fit the sketch into the drawing window.

16. Choose the Select tool from the Select group of the Home tab to exit the Line 
tool. On doing so, the profile gets shaded, indicating that it is a closed region. 
The sketch after drawing the lines is shown in Figure 2-46.

Figure 2-46  Sketch after drawing the lines

Filleting Sharp Corners
 Next, you need to fillet sharp corners so that the sharp edges are not there in the final 

model. You can fillet corners by using the Fillet tool.

1.  Invoke the Fillet tool from the Draw group; the Fillet command bar is displayed.

 To fillet a sharp corner, you first need to specify the fillet radius. You can fillet the lower 
left and lower right corners first and then the remaining corners. This is because the fillet 



2-28         Solid Edge for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

radii of the bottom left and bottom right corners are equal. Also, the fillet radii of the 
remaining corners are equal.

2. Enter 15 in the Radius edit box in the Fillet command bar and press ENTER. Next, 
move the cursor over the lower left corner of the sketch; the two lines forming a corner 
are highlighted in orange.

3. Click to select this corner; a fillet is created at the lower left corner of the sketch.

4. Similarly, move the cursor over the lower right corner and click to select it when the two 
lines forming this corner are highlighted in orange. 

 Next, you need to modify the fillet radius value and fillet the remaining corners.

5. Enter 10 in the Radius edit box in the command bar and press ENTER.

6. Select the remaining corners of the sketch one by one and then fillet them with a radius of 
10. The sketch after creating fillets is shown in Figure 2-47.  Next, exit the tool by choosing 
the Select tool from the Select group of the Home tab.

Figure 2-47  Sketch after creating fillets

Drawing Circles
 Finally, you need to draw circles by using the Circle by Center Point tool to complete the 

profile. You will use the center points of fillets as the center points of the circles. 

1. Choose the Circle by Center Point tool from the Draw group of the Home tab; the 
Circle by Center Point command bar is displayed and you are prompted to select 
the center point of the circle.

2. Enter 15 in the Diameter edit box of the Circle by Center Point command bar and press 
ENTER. 

3. Move the cursor over the fillet at the lower left corner; the fillet is highlighted in orange 
and the center point of the Fillet arc is displayed. The center point is represented by a 
plus sign (+).

4. Move the cursor over the center point of the fillet represented by a plus sign (+); the fillet 
is highlighted in orange color and the concentric relationship handle is displayed on the 
right of the cursor.
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5. Click to specify this point as the center point of the circle; a circle is drawn at this point 
and you are prompted again to specify the center point of the circle. Also, a circle of the 
specified diameter is attached to the cursor.

6. Move the cursor over the lower right fillet arc so that its center point is also displayed.

7. Move the cursor over the center point of the lower right fillet and click when the concentric 
relationship handle is displayed. The final profile for Tutorial 1 is shown in Figure 2-48.

8. Press the ESC key to exit the tool.

Figure 2-48  Final profile for Tutorial 1

Saving the File
1. Choose the Save tool from the Quick Access toolbar; the Save As dialog box is displayed. 

 It is recommended that you create a separate folder for every chapter in the textbook.

2. Browse to the C drive and then create a folder with the name Solid Edge in it. In the 
Solid Edge folder, create a folder with the name c02. 

3. Make the c02 folder and save the file with the name c02tut1.par. 

4. To close the file, choose the Application Button; a flyout is displayed. Next, choose Close 
from the flyout.

Tutorial 2                     Synchronous
In this tutorial, you will draw the profile of the model shown in Figure 2-49. The profile to be 
drawn is shown in Figure 2-50. Do not dimensions the profile as they are for reference only. 
         (Expected Time: 30 min)

       

Figure 2-50  Profile for Tutorial 2Figure 2-49  Model for Tutorial 2
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 The following steps are required to complete this tutorial:

a. Start a new part file.
b. Draw the profile of the model by using the Line tool.
c. Save the file and close it.

Starting a New Part File and Selecting the Sketching Plane
 You can start a new part file by choosing the New tool from the Quick Access toolbar, 

which will be available on the screen after you close all the files.

1. Choose the New tool from the Quick Access toolbar; the New dialog box is  
displayed, as shown in Figure 2-51.

Figure 2-51  The New dialog box to start a new file in ST7

2. In this dialog box, select the iso metric part.par template, refer Figure 2-51.  Next, choose 
OK to start a new part file.

Drawing the Profile
 You need to draw the  profile by using the Line and Arc tools.

1. Choose the Line tool from the Draw group of the Home tab; the Line command bar is 
displayed and the alignment lines are attached to the cursor. 

2. Next, you need to define the plane on which you want to draw the profile of the base 
feature. To do so, hover the cursor on the base coordinate system until a mouse symbol 
is displayed and then right-click; the Quick Pick list box is displayed with the possible 
nearest selections. Next, choose the YZ plane for sketching.

 Alternatively, you can select the YZ plane from the PathFinder. To do so, click on the plus 
sign(+) located on the left of the Base Reference Planes in the PathFinder to expand it. 
Next, select the YZ plane from it. 

Note 
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The base reference planes are hidden by default. You can display them in the graphics window by selecting 
the check box located on the left of the Base Reference Planes in the PathFinder.

3. By default, the view orientation of the part document is set to Dimetric. Choose Sketch 
View from the status bar; the sketching plane is oriented parallel to the screen.

4. Click when an endpoint snap is displayed at the origin to specify the start point of the 
line.

 
 The point specified is selected as the start point of the line and the endpoint is attached 

to the cursor. When you move the cursor on the screen, the line stretches and its length 
and angle values vary dynamically in the command bar.

5. Enter 12 in the Length dynamic edit box and press ENTER. Next, enter 0 in the Angle 
dynamic edit box and press ENTER. 

 The first line is drawn and another rubber-band line with the start point at the endpoint 
of the previous line and the endpoint attached to the cursor is displayed. But as the next 
entity is an arc, you need to invoke the arc mode.

6. Press the A key to invoke the arc mode. On doing so, a rubber-band arc with the start point 
fixed at the endpoint of the last line and the endpoint attached to the cursor is displayed. 
Also, the intent zones are displayed at the start point of the arc. 

7. Move the cursor to the start point of the arc and then move it vertically upward through 
a small distance. Next, move the cursor toward the right. You will notice that a normal 
arc starts from the endpoint of the last line.

8. Enter 12 and 180 in the Radius and Sweep dynamic edit boxes respectively; the preview 
of the resulting arc is displayed. To draw the arc, you need to specify a point on the screen 
for defining the direction of the arc.

9. Move the cursor horizontally toward the right and then click; the arc is drawn and the 
line mode is invoked again. Zoom out the drawing area.

10. Enter 12 and 0 in the Length and Angle dynamic edit boxes, respectively, and then press 
 ENTER. 

11. Enter 30 and 90 in the Length and Angle dynamic edit boxes, respectively, and then press 
ENTER.

12. Move the cursor horizontally toward the left. Make sure the horizontal relationship handle 
is displayed. Click to specify the endpoint of the line when the vertical alignment indicator 
is displayed at the endpoint of the arc. If the alignment indicator is not displayed, move 
the cursor once on the endpoint of the arc and then move it back.

 Next, you need to draw an arc. To do so, you need to invoke the arc mode.
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13. Press the A key to invoke the arc mode; a rubber-band arc is displayed with its start point 
fixed at the endpoint of the last line. 

14. Move the cursor to the start point of the arc and then move it vertically downward through 
a small distance. When the normal arc appears, move the cursor toward the left.

15. Move the cursor once over the lower arc and then move it toward the left, in line with the 
upper right horizontal line from where this arc starts. On doing so, a horizontal dotted 
line originating from the upper right horizontal line is displayed. At the point where the 
cursor is vertically in line with the start point of the lower arc, a vertical dotted line appears 
from the start point of the lower arc, as shown in Figure 2-52.

16. Click to define the endpoint of the arc at the intersection of the horizontal and vertical 
alignment dotted lines displayed; the arc is drawn and the line mode is invoked again.

17. Move the cursor horizontally toward the left and click to define the endpoint of the line 
when the vertical reference plane is highlighted in orange. 

18. Move the cursor to the start point of the first line; the endpoint relationship handle is 
displayed and the first line is highlighted in orange. 

19. Click to define the endpoint of this line when the endpoint relationship handle is displayed. 
The final profile of the model is shown in Figure 2-53.

20. Press the ESC key to exit the current tool.

Saving the File
1. Choose the Save button from the Quick Access toolbar and save the file with name c02tut2 

at following location:
  C:\Solid Edge\c02

Figure 2-52  Horizontal and vertical dotted lines 
displayed to define the endpoint of the arc

Figure 2-53  Final profile for Tutorial 2

2. Choose the Application Button; a flyout is displayed. In this flyout, choose Close to close 
the file.

Tutorial 3                                                    Ordered
In this tutorial, you will draw the profile of the base feature of the model shown in Figure 2-54. 
The profile to be drawn is shown in Figure 2-55. Do not dimensions the profile as they are for 
reference only.                                    (Expected time: 30 min)
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Figure 2-54  Model for Tutorial 3 Figure 2-55 Profile for Tutorial 3

The following steps are required to complete this tutorial:

a. Start a new part file.
b. Switch to the ordered environment.
c. Invoke the sketching environment.
d. Draw the profile of the model by using the Line tool.
e. Fillet the two corners of the outer loop and then draw the inner circle.
f. Save the file and close it.

Starting a New Part File and Selecting the Sketching Plane
 As mentioned earlier, you need to start a new part file by choosing the New button from 

the Quick Access toolbar.

1. Choose the New button from the Quick Access toolbar; the New dialog box is displayed.

2. In this dialog box, select the iso metric part.par template and then choose OK to start a 
new part file. 

3. Select the Ordered radio button from the Model group of the Tools tab; the Ordered 
Part environment is invoked. Next, select the Base Reference Planes check box from the 
PathFinder to view the reference planes.

4. Choose the Sketch tool from the Sketch group of the Home tab; the Sketch  
command bar is displayed and you are prompted to select a planar face or a 
reference plane.

5. Next, move the cursor toward the YZ plane and select it when it is highlighted in 
orange color; the plane gets oriented parallel to the screen. Also, the Line tool is 
invoked automatically.
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Drawing the Profile
 As the Line tool is active, its command bar is displayed in the graphics window and you 

are prompted to specify the start point of the line. You can start drawing the line from 
the origin.

1. Move the cursor close to the origin; one of the two axes is highlighted and the endpoint 
relationship handle is displayed.

2. Click when the endpoint relationship handle is displayed to specify the start point of the 
line.

 The point you specify is selected as the start point of the line and the endpoint is attached 
to the cursor.

3. Enter 150 in the Length dynamic edit box and press ENTER. Enter 0  in the Angle dynamic 
edit box and press ENTER; a line of 150 mm length is drawn. 

 If this line is not completely visible on the screen, then to display the complete line,you 
need to modify the drawing display area by using the Fit tool.

4. Choose the Fit tool from the status bar; the line is completely visible in the current  
view.

5. Enter 40 and 90 in the Length and Angle dynamic edit boxes of the command bar, 
respectively. Next press ENTER; a vertical line of 40mm is drawn.

 Next, you need to draw a tangent arc from the end point of this line.
6. Press the A key to invoke the arc mode. Move the cursor back to the start point of the arc 

and then move it vertically upward through a small distance.

7. Move the cursor toward the left when the tangent arc is displayed. Enter 30 and 180 in 
the Radius and Sweep dynamic edit boxes, respectively. Next, press ENTER.

8. Specify a point in the drawing window to place the arc; the arc is drawn and the line mode 
is invoked again.

9. Enter 20 and -90 in the Length and Angle dynamic edit boxes, respectively, and then 
press ENTER. 

10. Move the cursor horizontally towards the left and make sure that the horizontal relationship 
handle is displayed. Click to define the endpoint of the line when the vertical plane is 
highlighted in orange color. 

11. Move the cursor to the first line to highlight it 

Figure 2-56  Outer loop of the profile for 
Tutorial 3

and then move it to the start point of the first 
line; the first line is highlighted in orange 
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color and the endpoint relationship handle is displayed. 

12. Click to specify the endpoint of the line. The profile after drawing the outer loop is dis-
played in Figure 2-56. Next, press ESC to exit the tool.

Filleting Sharp Corners
 Next, you need to fillet sharp corners so that  sharp edges are not there in the final model. 

You can fillet corners by using the Fillet tool.

1.  Choose the Fillet tool from the Draw group of the Home tab; the Fillet command bar  
is displayed.

2. Enter 4 in the Radius edit box of the Fillet command bar and press ENTER. Now, move 
the cursor over the corner where the outer left vertical line and the upper horizontal line 
intersects; the two lines forming this corner are highlighted in orange.

3. Next, click to select this corner; a fillet is created at this corner.

4. Similarly, move the cursor over the corner where 

Figure 2-57  Fillets created in the model

the upper horizontal line intersects the vertical 
line originating from the left endpoint of the 
arc. Now, click to select this corner; a fillet is 
created at this corner. Figure 2-57 shows the 
fillets created in the model. 

Drawing the Circle
 Next, you need to draw a circle to complete the profile. The circle will be drawn by using 

the Circle by Center Point tool. 

1. Choose the Circle by Center Point tool from the Draw group of the Home tab; 
the Circle by Center Point command bar is displayed.

2. Enter 30 in the Diameter edit box of the command bar and press ENTER; a circle of 
30 mm is attached to the cursor. 

3. Move the cursor over the arc of radius 30 units; the arc is highlighted in orange  color 
and its center point is displayed, which is represented by a plus sign (+).

4. Move the cursor over the center point of the arc and click to define this point as the center 
point of the circle when the concentric relationship handle is displayed. This completes 
the profile. The final profile for Tutorial 3 is shown in Figure 2-58.

Figure 2-58 Final profile for Tutorial 3



2-36         Solid Edge for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

5. Press the ESC key to exit the current tool.

6. Choose the Close Sketch tool from the Close group; the sketching environment is  
closed and the Sketch command bar is displayed. Also, the current view is 
automatically changed to the dimetric view.

Saving the File
1. Choose the Save button from the Quick Access toolbar and save the file with name c02tut3 

at the following location:
  C:\Solid Edge\c02 

2.   Choose the Application Button; a flyout is displayed. Next, choose Close from the flyout 
to close the file.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. In the Synchronous Part environment, the reference planes are not displayed by 
default. (T/F)

2. When you open a new ISO Metric Part document, two triads are displayed in the graphics 
window. (T/F)

3. In the Synchronous modeling, you can create sketches as well as develop 
features in the same environment. (T/F)

4. You can use the command bar to specify the exact values of the sketched entities. (T/F)

5. You can restore the original orientation of the sketching plane by using the __________ 
tool in the status bar.

6. You can invoke the arc mode while the Line tool is already active by pressing the __________ 
key. 

7. You can bevel corners in a sketch by using the __________ tool. 

8. You can retain sharp corners even after filleting them by choosing the __________ button 
from the Fillet command bar. 

9. In Solid Edge, you can draw a polygon of sides ranging from 3 to __________.

10. The __________ tool is used to draw an arc by specifying its start point, endpoint, and the 
third point in the drawing area.
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 Review Questions 
Answer the following questions:

1. Which of the following options is selected from the New dialog box to start a new part 
file?

  
  (a) iso metric assembly.asm  (b) iso metric draft.dft 
  (c) iso metric part.par    (d) iso metric sheet metal.psm

2. Which of the following tools is used to round sharp corners in a sketch?
  
  (a) Fillet    (b) Chamfer 
  (c) Round     (d) None of these

3. Which of the following edit boxes in the arc mode replaces the Angle edit box in the Line 
command bar?

  
  (a) Arc     (b) Sweep
  (c) Value     (d) None of these

4. Which of the following tools is used to convert an existing sketched entity into a bezier 
spline curve?

  
  (a) Convert to Sketch   (b) Convert to Arc
  (c) Convert     (d) Convert to Curve

5. You can use the __________ key to lock or unlock a plane. 

6. To invoke the sketching environment, invoke a sketching tool from the Draw group in the 
Home tab and then select a reference plane. (T/F)

7. The part file in Solid Edge is saved with a .prt extension. (T/F)

8. You can select entities by dragging a box around them. (T/F)

9. If Overlapping is the current selection mode, all entities that lie inside the box or even 
intersect the box will be selected. (T/F)

10. In Solid Edge, you can create fillets or chamfers by simply dragging the cursor across the 
entities that you want to fillet or chamfer. (T/F)

 Exercises 

Exercise 1
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Draw the profile of the base feature of the model shown in Figure 2-59. The profile to be 
drawn is shown in Figure 2-60. Do not dimension the profile as they are for reference only. 
                                              (Expected time: 30 min)

Figure 2-60 Profile for Exercise 1Figure 2-59  Model for Exercise 1

Exercise 2
Draw the profile of the base feature of the model shown in Figure 2-61. The profile to be 
drawn is shown in Figure 2-62. Do not dimension the profile as they are for reference only. 
                                 (Expected time: 30 min)

Figure 2-62  Profile for Exercise 2Figure 2-61  Model for Exercise 2
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Exercise 3
Draw the profile of the base feature of the model shown in Figure 2-63. The profile to be 
drawn is shown in Figure 2-64. Do not dimensions the profile as they are for reference only. 
          (Expected time: 30 min)

Figure 2-64 Profile for Exercise 3Figure 2-63  Model for Exercise 3
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om Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. T, 5. Sketch View, 6. A, 7. Chamfer, 8. No Trim, 9. 200, 10. Arc by  3 points


