
Chapter 3

Adding Relationships 
and Dimensions to 

Sketches
Learning Objectives

After completing this chapter, you will be able to:
• Understand different types of geometric relationships.
• Force additional geometric relationships to sketches.
• View and delete geometric relationships from sketches.
• Understand the methods of dimensioning.
• Modify the values of dimensions.
• Add automatic dimensions to sketches while drawing them.
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GEOMETRIC RELATIONSHIPS
Geometric relationships are the logical operations performed on the sketched entity to relate 
it to the other sketched entities using the standard properties such as collinearity, concentricity, 
tangency, and so on. These relationships constrain the degrees of freedom of the sketched 
entities and stabilize a sketch so that it does not change its shape and location unpredictably 
at any stage of the design. Most of the relationships are automatically applied to the sketched 
entities while drawing.

All geometric relationships have separate relationship handles associated with them. These 
handles can be seen on the sketched entities when relationships are applied to them. In 
the sketching environment of Solid Edge, you can add eleven types of relationships. These 
relationships are discussed next.

Connect Relationship
 Ribbon:	  Home > Relate > Connect 

The Connect relationship is used to connect the keypoints such as endpoint, midpoint, 
or center point of a sketched entity to another sketched entity or to its keypoints. When 
the keypoint of the first entity is connected to the keypoint of the second entity, it is 

called a two-point connect. It is represented by a square with a dot inside it on the geometry. 
However, when the keypoint of the first entity is directly connected to the second entity, it is 
called a one-point connect and is represented by a cross on the geometry.

To add this relationship between the two keypoints of two different sketched entities, choose 
the Connect tool from the Relate group of the Home tab. Next, move the cursor over the 
keypoint of the first sketched entity and then click to select the entity when the handle of the 
keypoint is displayed. After selecting the keypoint of the first entity, move the cursor over the 
other sketched entity. Depending on whether you connect the keypoint of the first entity to the 
keypoint of the second entity or to the second entity itself, the relationship will be a one-point 
connect or a two-point connect. Figure 3-1 shows the entities selected for one-point connect. 
Figure 3-2 shows the relationship handle displayed after adding the relationship. 

Figure 3-2  Entities after adding the 
one-point connect relationship

Figure 3-1  Selecting entities for one-point 
connect relationship
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Note 
If the handles that represent the relationship are not displayed in the drawing area by default, 
you need to choose the Relationship Handles button from the Relate group of the Home tab 
to display them. 

Figure 3-3 shows the endpoint of the first entity being connected to the endpoint of the second 
entity. This is a two-point connect. Therefore, the relationship handle shows a dot inside the 
square, as shown in Figure 3-4.

Figure 3-4  Entities after adding the 
two-point connect relationship

Figure 3-3  Entities selected for two-point 
connect relationship

Concentric Relationship
 Ribbon:	 Home > Relate > Concentric 

The Concentric relationship forces 

Figure 3-5  Sketch before and after applying the 
concentric relationship

two arcs and two circles, or an arc 
and a circle to share the same 

center point. If there are two arcs, two 
circles, or an arc and a circle with center 
points at different locations, this 
relationship will force the first selected arc 
or circle to move such that its center point 
is placed over the center point of the 
second arc or circle. The handle of this 
relationship is represented by two 
concentric circles. Figure 3-5 shows two 
circles before and after applying this 
relationship.

Horizontal/Vertical Relationship
 Ribbon:	 Home > Relate > Horizontal/Vertical 

The Horizontal/Vertical relationship forces an inclined line to become horizontal or 
vertical. If the angle of the inclined line is less than 45 degrees, it will become horizontal. 
But if the angle is equal to or greater than 45 degrees, it will become vertical. You can 

also select two points and force them to be placed horizontally or vertically. The handle of 
this relationship is a plus sign (+).
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Collinear Relationship
 Ribbon:	 Home > Relate > Collinear 

The Collinear relationship forces the selected line segment(s) to be placed in a straight 
line. To add the collinear relationship, invoke the Collinear tool; you will be prompted 
to click on the first line. After making the first selection, you will be prompted to click 

on the next line. The first line segment is automatically forced to be placed in line with the 
second line segment. The handle of this relationship is represented by circles, which appear 
on the collinear lines.

Parallel Relationship
 Ribbon:	  Home > Relate > Parallel 

The Parallel relationship forces a selected line segment to become parallel to 
another line segment. On invoking the Parallel tool, you will be prompted to click on 
a line. Click on a line; you will be prompted to click on the next line. After you click 

on the second line, the first line will become parallel to the second line. The handle of this 
relationship is represented by two parallel lines.

Perpendicular Relationship
 Ribbon:	 Home > Relate > Perpendicular 

The Perpendicular relationship forces a selected line to become perpendicular to 
another line, arc, circle, or ellipse. When you invoke the Perpendicular tool, you will 
be prompted to click on the first line to make it perpendicular. On clicking the first 

line, you will be prompted to click on the second line, arc, circle, or ellipse to make it 
perpendicular. On clicking the second entity, the first line will become perpendicular to the 
second entity. The handle of this relationship is a perpendicular symbol. 

Lock Relationship
 Ribbon:	 Home > Relate > Lock 

The Lock constraint is used to fix the orientation or the location of the selected 
sketched entity or the keypoint of the sketched entity. If you apply this constraint to 
the keypoint of a sketched entity, the entity will be fixed at that keypoint and you will 

not be able to modify the entity using that keypoint. However, you can modify the entity from 
other keypoints. 

 Note 
A keypoint that has a lock on it cannot be modified during recomputation by changing the value 
of  dimension manually or by dragging, but it can be modified by manipulation commands such 
as Move, Rotate, Mirror, and so on, and will be fixed at the new location after manipulations.
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Rigid Set Relationship
 Ribbon:	 Home > Relate > Rigid Set 

The Rigid Set relationship is used to group the selected sketched entities into a rigid 
set. When the entities are grouped in a rigid set, they behave as a single entity. 
Therefore, if you drag one of the entities, all entities in the rigid set are 

automatically dragged. Note that you cannot include dimensions or a text entity in a rigid 
set.

Note
The Rigid Set and Lock tools will only be enabled when the Maintain Relationships button 
in the Relate group of the Home tab is chosen.

Tangent Relationship
 Ribbon:	 Home > Relate > Tangent 

The Tangent relationship forces a selected sketched entity to become tangent to 
another sketched entity, refer to Figure 3-6. Note that one of the two entities selected 
should be an arc, circle, curve, or an ellipse. The handle of this relationship is a circle 
that appears at the point of tangency. 

To select a curve for adding the tangent relationship, press and hold the SHIFT or CTRL key, 
and then select a chain of end to end connected tangent entities to ensure that the curve remains 
tangentially connected to the chain, as shown in Figure 3-7. After making the entities tangent, 
if you drag the curve, it will remain tangentially connected to the chain of tangent entities.

Figure 3-7  Making a curve tangent to a chain                 
of tangentially connected entities

Figure 3-6  Adding the Tangent relationship

Equal Relationship
 Ribbon:	 Home > Relate > Equal 

The Equal relationship can be used for line segments, ellipses, arcs ,or circles. If you 
select two line segments, this relationship will force the length of the first selected line 
segment to become equal to the length of the second selected line segment. In case 
of arcs or circles, this relationship will force the radius of the first selected entity to 
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become equal to the radius of the second selected entity. Similarly, you can force two ellipses 
to become equal in size using this relationship. The handle of this relationship is an equal 
sign (=). 

Symmetric Relationship
 Ribbon:	 Home > Relate > Symmetric 

The Symmetric relationship is used to force the selected sketched entities to become 
symmetrical about a symmetry axis, which can be a sketched line or a reference plane. 
This relationship is used in the sketches of the models that are symmetrical about a 

line. When you invoke the Symmetric tool, you will be prompted to click on the symmetry 
axis. Click on the symmetry axis; you will be prompted to click on an entity. Note that you 
can select only one entity at a time to apply this relationship. Once you have selected the first 
sketched entity, you will be prompted to click on the entity. Remember that the second entity 
should be the same as the first element. This means that if the first element is a line, the 
second entity should also be a line. As soon as you select the second entity, the first selected 
entity will be modified such that its distance and orientation from the axis of symmetry becomes 
equal to the distance and orientation of the second selected entity. After you have applied this 
constraint to one set of entities, you will be prompted to click on the next set of first and second 
entities. However, this time you will not be prompted to select the axis of symmetry. The last 
axis of symmetry will be automatically be selected to add this relationship.

Figure 3-8 shows the sketched entities and the symmetry axis before applying the 
symmetric relationship and Figure 3-9 shows the sketch after applying the relationship.

Figure 3-9  Entities after applying the symmetric 
relationship

Figure 3-8  Selecting the entities to apply the 
symmetric relationship

Setting the Symmetry Axis (Ordered Environment)
 Ribbon:	 Home > Relate > Symmetry Axis 

In Solid Edge, you can set the symmetry axis before invoking the Symmetric 
relationship. After doing that, when you invoke the Symmetric tool, you will not be 
prompted to select the axis of symmetry. The symmetry axis set earlier will be 
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automatically selected as the axis of symmetry. To set the axis of symmetry, choose the Symmetry 
Axis tool from the Relate group; you will be prompted to click on the symmetry axis. The 
line that you select will be automatically changed to the symmetry axis along with its line type.

Note
You may need to apply a number of relationships to constrain all degrees of freedom of a sketch. 
Generally, while applying relationships to the sketched entities, the first selected entity is modified 
with respect to the second one. However, if all degrees of freedom of the first entity are restricted, 
then the second entity is modified.

Controlling the Display of Relationship Handles
 Ribbon:	 Home > Relate > Relationship Handles 

The Relationship Handles button is used to turn on or off the display of relationship 
handles in the sketch. If the Relationship Handles button is chosen in the Relate 
group, the handles of all relationships will be displayed in the sketch. You can turn 
off the display of the relationship handles for better visualization by choosing this 
button again.

CONFLICTS IN RELATIONSHIPS
Sometimes when you try to apply multiple relationships to an entity and the entity is not able 
to accommodate all those changes, then the Solid Edge ST7 information box is displayed, 
as shown in Figure 3-10. 

Figure 3-10  The Solid Edge ST7 information box

This box informs you that applying this relationship will create conflicts in the existing 
relationships. Therefore, you may need to delete the existing relationships before applying the 
new ones, depending upon the requirement of the design. For example, if you want to apply 
the vertical relationship to a horizontal line, you need to delete the horizontal relationship 
before applying the vertical relationship.  

DELETING RELATIONSHIPS
As mentioned earlier, whenever a relationship is applied to a sketched entity, the relationship 
handle is displayed on the entity. You can delete the applied relationship by selecting that 
handle and pressing the DELETE key. 
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DIMENSIONING THE SKETCHED ENTITIES
In Solid Edge, you can use different types of dimensions to dimension the sketched entities. 
You can create these dimensions using their individual tools or by using the Smart Dimension 
tool. You can also use the options available in the respective command bars that are displayed 
for these dimensions. As mentioned earlier, Solid Edge is parametric by nature. Therefore, 
irrespective of the original size of the entity, you can enter a new value in the Dimension Value 
edit box to modify the size of the entity to the required value. 

The methods of dimensioning the entities using these dimensions are discussed next.

Adding Linear Dimensions					           
 Ribbon:	 Home > Dimension > Smart Dimension / Distance Between 

Linear dimensions measure the linear distance of a line segment or the distance 
between two points. To add this dimension, you can use the Smart Dimension tool 
or the Distance Between tool. The points that you can select to add dimension 
include all the keypoints such as endpoints, midpoints, and so on of lines, curves, 
arcs, circles, or ellipses. You can add linear dimensions to a vertical or a horizontal 
line by choosing the Smart Dimension tool or the Distance Between tool and then 

directly selecting the line. Once you have selected the line, the linear dimension will be attached 
to the cursor. Now, you can place the dimension at any desired location.

Figure 3-11  Linear dimensioning of points

To place the dimension between two points, 
invoke the Smart Dimension tool or the 
Distance Between tool and select the points 
one by one. Now, move the cursor vertically 
to place the horizontal linear dimension or 
move the cursor horizontally to place the 
vertical linear dimension. Figure 3-11 shows 
the linear dimensioning between the center 
points of an arc and a circle. 

To add linear dimensions between arcs and circles by using the Smart Dimension tool, you 
can directly select the arc and the circle. However, to create these dimensions by using the 
Distance Between tool, first you need to move the cursor over the entities to highlight their 
center points and then select the center points to create the dimensions. 

Note 
In order to highlight the center points of the entities, you must select the Center check box in 
the IntelliSketch group of the Sketching tab in the Synchronous Part environment. The 
IntelliSketch group is available in the Home tab of the sketching environment in the Ordered 
Part environment.

  
You can also add the horizontal or vertical dimension to the inclined lines, see Figure 3-12. If you 
select an inclined line after invoking the Smart Dimension tool to add a linear dimension, the 
aligned dimension will be attached to the cursor by default. You need to press and hold the 
SHIFT key to add the horizontal or vertical dimension. But if you are using the Distance 
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Between tool, you can select the endpoints of the inclined line and move the cursor in the 
horizontal or vertical direction to place the dimension.

Figure 3-12  Linear dimensioning of inclined lines

Command Bar Options
While dimensioning the sketched entities, the corresponding command bars are displayed. 
Figure 3-13 shows the command bar displayed on invoking the Smart Dimension tool. This 
command bar has some additional options and buttons, which should be set before creating 
dimensions. These options are discussed next.

Figure 3-13  The command bar options

Dimension Style
This drop-down list shows the dimension styles, namely ANSI(ft), ANSI (in), ISO(cm), 
ISO(m), and ISO(mm). By default, ISO(mm) is selected in the drop-down list. You can 
select the required dimension style from it.  If this drop-down list is not activated in the 
command bar, then you need to choose the Dimension Style Mapping button in the 
command bar to activate it.

Driving
The Driving button is chosen by default. This means the applied dimension is a driving 
dimension. A driving dimension is the dimension that drives the size of an entity and 
is displayed in red color. Therefore, if this button is chosen and you modify the value 
of an applied dimension in the edit box that is displayed on selecting the entity to be 
dimensioned, then the size of the entity will change accordingly. If you deactivate the 
Driving button while placing the dimension, the dimension will be called as driven 
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dimension and will be displayed in blue color. If you modify its value, the size of the entity 
will not change and the value of dimension will be displayed underlined. The Dimension 
Round-off drop-down list adjacent to the Driving button is also used to set the round off 
precision for dimensions. The default round off precision is two decimal places. You can 
select any other round off precision from this drop-down list.

Advanced Round-Off
The Advanced Round-Off button is used to specify

Figure 3-14  The Round-Off dialog box

 
the round off options. When you choose this 
button, the Round-Off dialog box will be 
displayed, as shown in Figure 3-14. The options 
in this dialog box are discussed next.

	 Primary linear
The Primary linear drop-down list is used 
to define the round-off value for the primary 
linear dimension.

	 Primary linear tolerance
This drop-down list is used to define the 
round-off value for the primary linear 
tolerance.

	 Secondary linear
This drop-down list is used to define the round-off value for the secondary linear 
dimension.

	 Secondary linear tolerance
This drop-down list is used to define the round-off value for the secondary linear 
tolerance.

	 Angular
	 This drop-down list is used to define the round-off value for the angular dimension.

	 Angular tolerance
This drop-down list is used to define the round-off value for the angular tolerance.

Properties
	 The options in the Properties area are used to specify the orientation of the dimension and 

also the other properties. Note that the Orientation drop-down list in this area will 
not be available if you choose the Smart Dimension tool. But if you have chosen the 
Distance Between tool, specify the orientation by selecting an appropriate option from 
the Orientation drop-down list. Select the Horizontal/Vertical option if you need to 
dimension the horizontal or vertical distance. Select the By 2 Points option, if you need 
to measure the aligned dimension. Select the Use Dimension Axis option, if you need 
to measure the entity from a baseline. 

The other buttons in this area have to be chosen based on the specific segment. The 
Tangent button is discussed next. The remaining buttons will be discussed later.
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	 Tangent
This button allows you to add a dimension between the tangent points of two entities. If 
you choose this button before selecting entities, the dimension will be tangent to both 
the entities. But if you first select an arc or a circle, then choose this button and finally 
select the second arc or circle, the dimension will be tangent to only the second entity.

Note
The remaining options of the command bar will be available for the other dimensioning techniques.

Tolerance
The options in this area are used to specify the dimension type and the related 
tolerances. These options are discussed next.

	 Dimension Type
This button is chosen to specify the type of dimension to be applied. When you choose 
this button from the Tolerance area of the command bar, a flyout with options such 
as Nominal, Unit Tolerance, Alpha Tolerance, Class, Limit, Basic, and so on is 
displayed. These options are used to specify the type of dimensions. For example, to 
add a tolerance dimension to a sketch, you can choose the Unit Tolerance or Alpha 
Tolerance option from this flyout.

You can specify the parameters related to the type of dimensions to be applied in 
the edit boxes displayed in the Tolerance area. Similarly, you can specify the limit 
dimensions of the selected entity by choosing the Limit option. On doing so, the 
Upper Tolerance and Lower Tolerance edit boxes will be displayed. You can enter 
the upper and lower tolerance values in these edit boxes. Figure 3-15 shows a sketch 
dimensioned by using the limit and tolerance dimensions.

Figure 3-15  Sketch dimensioned by using the limit and unit 
tolerance dimension types

	 Inspection
This button is chosen from the Tolerance area of the command bar to add an oblong 
around the dimension for inspection.

      Prefix
This button is chosen to add a prefix, suffix, superfix, or subfix to a dimension. If you  
choose this button from the Tolerance area of the command bar, the Dimension Prefix 
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dialog box will be displayed, as shown in Figure 3-16. You can use this dialog box to 
add a special symbol or add your own text to the dimension. You can toggle between 
enabling and disabling the data defined in this dialog box by using the Enable Prefix 
button which is also available in the Tolerance area of the command bar. 

Figure 3-16  The Dimension Prefix dialog box

Adding Aligned Dimensions
 Ribbon:	 Home > Dimension > Smart Dimension 

Aligned dimensions are used to dimension the lines that are not parallel to the 
X-axis or the Y-axis. This type of dimensioning measures the actual distance of the 
aligned lines. You can invoke the Smart Dimension tool and directly select the 
inclined line to apply this dimension. When you select the line, an aligned 

dimension will be attached to the cursor. Move the cursor and place the dimension at the 
required location. 

You can also select two points to apply the aligned dimensions. The points that can be used 
include the endpoints of lines, curves, or arcs and the center points of arcs, circles, or ellipses. 
If you select these two points, the linear dimensions will be displayed by default. To add the 
aligned dimensions, press and hold the SHIFT key; the aligned dimension will be displayed. 
Move the cursor and place the dimension at the desired location. Figures 3-17 and 3-18 show 
the aligned dimensions applied to various objects.

Figure 3-18  Aligned dimensioning of pointsFigure 3-17  Aligned dimensioning of lines
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Note
If you are using the Distance Between tool, select the By 2 Points option from the Orientation 
drop-down list in the command bar to add the aligned dimension.

Adding Angular Dimensions
 Ribbon:	   Home > Dimension > Smart Dimension / Angle Between 

Angular dimensions are used to dimension angles. You can directly select two line 
segments or use three points to apply the angular dimensions. You can also use angular 
dimensioning to dimension an arc. The options for adding angular dimensions are 
discussed next.

Angular Dimensioning by Using Two Line Segments 
You can directly select two line segments to apply angular dimensions between them. Invoke 
the Smart Dimension tool and then select a line segment; a linear or an aligned dimension will 
be attached to the cursor. Instead of placing the dimension, select the second line segment. If 
a linear dimension is displayed, then choose the Angle button from the command bar. Next, 
place the dimension to measure the angle between the two lines. While placing the dimension, 
you need to be careful about its point of placement of the dimension because depending on 
this point of the placement, the interior or the exterior angle will be displayed. Figure 3-19 
shows the angular dimensioning between two lines and Figure 3-20 shows the exterior angle 
between same two lines.

Figure 3-19  Angular dimensioning between 
two lines

Figure 3-20  Exterior angle between two lines

After selecting the two lines, if you choose the Angle and Major-Minor buttons from the 
command bar, you can specify the angle between the lines or its complimentary angle. 
Figure 3-21 shows the major angle dimension between two lines.



3-14			                 				    Solid Edge for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Tip. After placing the dimension, you can drag it to a new location. To do so, exit 
the dimensioning tool and then select the dimension lines or the dimension text. 
The dimension lines are the ones between which the dimension text is placed. After 
selecting the dimension lines or the dimension text, press and hold the left mouse 
button and drag the cursor to a new location. The dimension will be placed at the 
new location. Also, note that you cannot change the dimension type by dragging. For 
example, you cannot drag a major angle dimension to a new location to make it a 
minor angle dimension.

Angular Dimensioning by Using Three Points
You can also add angular dimensions by using three keypoints. The keypoints should be 
selected in the clockwise or counterclockwise direction. 

Note that while selecting the points, the vertex of the angle should be selected last. Also, make 
sure that the By 2 Points option is selected in the Orientation drop-down list of the command 
bar. Figure 3-22 shows the angular dimensioning by using three points. 

Figure 3-22  Angular dimensioning by using 
three points

Figure 3-21  Major angle between two lines

Angular Dimensioning of the Sweep Angle of an Arc
You can use angular dimensions to dimension the sweep angle of an arc. To do so, invoke the 
Smart Dimension tool and select an arc. Next, choose the Angle button from the command bar; 
the angular dimension of the sweep angle of the arc will be displayed, as shown in Figure 3-23.

 

Adding Diameter Dimensions
 Ribbon:	 Home > Dimension > Smart Dimension 

Diameter dimensions are applied to dimension a circle or an arc in terms of its 
diameter. In Solid Edge, when you select a circle to dimension, the diameter 
dimension is applied to it by default. However, if you select an arc to dimension, 
the radius dimension will be applied to it. You can also apply the diameter dimension 

to an arc. To do so, invoke the Smart Dimension tool and then select the arc. Now, choose 
the Diameter button from the command bar to apply the diameter dimension. Figure 3-24 
shows an arc and a circle with the diameter dimensions.



Adding Relationships and Dimensions to Sketches				                                  3-15

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-24  Diameter dimensioning of an 
arc and a circle

Figure 3-23  Dimensioning the sweep angle 
of an arc

Adding Radial Dimensions
 Ribbon:	 Home > Dimension > Smart Dimension 

Radial dimensions are applied to dimension an arc, a circle, a curve, or an ellipse 
in terms of its radius. As mentioned earlier, by default, the circles will be assigned 
the diameter dimensions and the arcs will be applied the radius dimensions. However, 
you can also apply the radius dimensions to a circle. To do so, invoke the 
Smart Dimension tool and then select the circle. Now, choose the Radius button 

from the command bar to apply the radius dimension. Figure 3-25 shows an arc and a circle 
with the radius dimensions.

Adding Symmetric Diameter Dimensions
 Ribbon:	 Home > Dimension > Symmetric Diameter 

Symmetric diameter dimensioning is used to dimension the sketches of the revolved 
components. The sketch for a revolved component is drawn using the simple sketching 
entities. For example, if you draw a rectangle and revolve it, it will result in a cylinder. 

Now, if you dimension the rectangle using the linear dimension, the same dimensions will be 
displayed when you generate the drawing views of the cylinder. Also, the same dimensions 
will be used while manufacturing the component. But these linear dimensions will result in 
a confusion while manufacturing the component. This is because while manufacturing a 
revolved component, the dimensions have to be in terms of the diameter of the revolved 
component. The linear dimensions will not be acceptable during the manufacturing of a 
revolved component. 

To overcome this confusion, the sketches of the revolved features are dimensioned using the 
symmetric diameter dimensions. These dimensions display the distance between the two 
selected line segments in terms of diameter, which is double of the original length. Also, the Ø 
symbol is placed as a prefix to the dimension. For example, if the original dimension between 
two entities is 10, the symmetric diameter dimension will display it as Ø20. This is because 
when you revolve a rectangle with a 10 mm width, the diameter of the resultant cylinder will 
be 20 mm. 
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To add these dimensions, choose the Symmetric Diameter tool from the Dimension group 
of the Home tab; you will be prompted to click on the dimension origin element. Note that 
the dimension origin element should be the line or the axis in the sketch about which the 
sketch will be revolved. After selecting the axis or the line, you will be prompted to select the 
dimension measurement element. Select the line or the keypoint in the sketch to which you want 
to add the linear diameter dimensions. Now, choose the Half/Full button from the command 
bar. You will notice that a dimension, which is twice the measured distance, is attached to the 
cursor. Place the dimension at the desired location. Figure 3-26 shows the dimension value 
preceded by the Ø symbol which indicates the symmetric diameter dimension.

Figure 3-25  Radial dimensioning of an arc 
and a circle

Figure 3-26  Symmetric diameter dimensioning 
of a sketch

Adding Coordinate Dimensions
 Ribbon:	 Home > Dimension > Coordinate Dimension drop-down 	  
                        > Coordinate Dimension					  

Coordinate dimensions are used to dimension a sketch with respect to a common origin 
point, which can be one of the vertices in the sketch. Figure 3-27 shows the coordinate 
dimensions of a sketch. In this case, the lower left corner of the sketch is taken as the 
common origin. The remaining entities are dimensioned with respect to this point.

To add this dimension, choose the Coordinate Dimension tool from the Coordinate Dimension 
drop-down in the Dimension group of the Home tab; you will be prompted to click on the 
common origin element. Select a vertex, keypoint, or a line segment that you want to use as 
the common origin. Note that if you select a vertex or a keypoint, you can take it as a common 
origin for the horizontal or the vertical coordinate dimension. But in case of line segments, 
the vertical line will be taken as the origin for the horizontal dimensions and the horizontal 
line will be taken as the origin for the vertical dimensions.

After selecting the common origin, move the cursor horizontally or vertically to place the 
common origin dimension, which is 0, refer to Figure 3-27. If you have placed zero for the X 
direction, which is represented by a vertical dimension line, move the cursor in the horizontal 
direction and select a point or a line segment. Next, move the cursor in the direction of the 
zero dimension and place it. Follow this procedure to place the remaining dimensions along 
that direction.



Adding Relationships and Dimensions to Sketches				                                  3-17

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Next, right-click to place the coordinate dimensions along the second direction; you will 
be prompted again to click on the common origin element. Select the origin element and 
place the dimension along the second direction and then select the points to place the 
coordinate dimensions along that direction.

Change Coordinate Origin
 Ribbon:	 Home > Dimension > Coordinate Dimension drop-down 	  
		  > Change Coordinate Origin			               

After dimensioning the sketch by using the Coordinate Dimension tool, you can also       
change the common origin element. To change the common origin element, choose 
the Change Coordinate Origin tool from the Coordinate Dimension drop-down in 

the Dimension group of the Home tab; you will be prompted to click on the dimension. Now, 
choose the dimension where you want to place the new common origin element 
by moving the cursor horizontally or vertically.  

Adding Angular Coordinate Dimensions
 Ribbon:	 Home > Dimension > Angular Coordinate Dimension 

As the name suggests, this tool is used to add angular coordinate dimensions 
with respect to a common origin point, as shown in Figure 3-28. On invoking this tool, 
you will be prompted to click on the group center element. This point will be taken 

as the center point and the angular coordinate dimensions will be created around this point. 
After selecting this point, you will be prompted to select the common origin element. This is 
the element that will be taken as the origin for the angular coordinate dimensions. Select the 
origin point and move the cursor to place the zero dimension; you will be prompted to click 
on the dimension measurement element. Select the point to which you want to add the 
angular coordinate dimension. After selecting the element, the preview of the angular 
coordinate dimension will be displayed. If the dimension is placed clockwise, you can display 
the counterclockwise dimension by choosing the Counterclockwise button from the command 
bar. Move the cursor and place the dimension. Continue this process to add all angular 
coordinate dimensions.

Figure 3-28  Angular coordinate dimensioning 
of a sketch

Figure 3-27  Coordinate dimensioning of a sketch



3-18			                 				    Solid Edge for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

ADDING AUTOMATIC DIMENSIONS 
(ORDERED ENVIRONMENT) 
 Ribbon:	  Home > Dimension > Auto-Dimension 

The Auto-Dimension tool is used to add dimensions to the sketched entities 
automatically when you draw them. You can set options for the automatic display of 
dimensions while drawing an entity by choosing the Intellisketch Options button 

from the Intellisketch group of the Home tab. When you choose this button, the Intellisketch 
dialog box will be displayed with the Auto-Dimension tab chosen by default, as shown in 
Figure 3-29. The options in this tab are discussed next.

Automatic Dimensioning Options Area
The options in this area are used to specify the 

Figure 3-29  The IntelliSketch dialog box

automatic dimensions. These options are 
discussed next. 

Automatically create dimensions 
for new geometry
If this check box is selected then the dimensions 
will be created automatically in the newly 
created geometry. The other options in this 
dialog box will be activated only if this check 
box is selected. These options are discussed 
next.

When geometry is drawn
This radio button is selected by default. As a 
result, the automatic dimensions are applied as you draw the sketched entities.

Only when geometry is created with keyed-in values
If this radio button is selected, the automatic dimensions will be applied only to the entities 
that are created by entering the values in the command bar.

Do not create dimensions for fully defined geometry
This radio button is selected by default. As a result, the automatic dimensions are not added 
if the sketch is already fully defined.

Create driven dimensions for fully defined geometry
If this radio button is selected, the automatic driven dimensions will be added for the fully 
defined sketches.

Use dimension style mapping
If this check box is selected, the placed dimensions automatically inherit the dimension style 
specified in the Dimension Style tab of the Solid Edge Options dialog box.
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UNDERSTANDING THE CONCEPT OF FULLY 
CONSTRAINED SKETCHES
A fully constrained sketch is the one in which all the entities are completely constrained to their 
surroundings using constraints and dimensions. It has a definite shape, size, orientation, and 
location. Whenever you draw a sketched entity, it becomes blue in color. If you add dimensions 
and constraints to fully constrain it, the entity will turn black. If it does not turn black, choose 
the Relationship Colors button from the Evaluate group of the Inspect tab. Note that while 
creating the base sketch in Solid Edge, you need to relate or dimension it with respect to the 
reference planes in order to fully constrain it.

MEASURING SKETCHED ENTITIES
In Solid Edge, you can measure the distance between the sketched entities, the total length of 
a closed loop or an open entity, and the area of a loop. To do so,choose the Smart Measure 
tool from the 2D Measure group of the Inspect tab. This tool works similar to the Smart 
Dimension tool. You can also calculate the area properties of the sketched entities. The 
techniques to measure the area properties  are discussed next. 

Measuring Distances
 Ribbon:	 Inspect > 2D Measure > Distance 

The Distance tool is used to measure the linear distance between any two selected 
points. To measure the linear distance, choose the Distance tool from the 2D Measure 
group of the Inspect tab; you will be prompted to click on the first point. Select the 

first point to measure the linear distance; you will be prompted to click on the next point. If 
you move the cursor over a keypoint to select it as the second point, the linear distance, the 
∆X distance, and the ∆Y distance between the two points will be displayed on the right of the 
cursor without even selecting the point, as shown in Figure 3-30. If the second point is not a 
keypoint, the values will not be displayed on the side of the cursor. You need to click on the 
left mouse button to display the distance value. In this case, the delta values will not be 
displayed. You can continue to select multiple points to measure the distance between any two 
points.

Figure 3-30  Measuring the distance between the two keypoints

 



3-20			                 				    Solid Edge for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Measuring the Total Length of a Closed Loop or an Open 
Sketch
 Ribbon:	 Inspect > 2D Measure > Total Length 

The Total Length tool is used to measure the total length of a closed loop or an open 
sketch. When you invoke this tool, the command bar will be displayed and you will be 
prompted to click on the element(s) to be measured. By default, the Chain option is 

selected from the drop-down list in the command bar. As a result, the complete chain of entities 
will be selected and the total length of the chain will be displayed. You can also select the 
Single option from this drop-down list to measure the total length of a single entity. 

The total length is displayed in the Length edit box of the command bar. If you want to measure 
the total length of a new set of entities, then choose the Deselect button from the command 
bar. This will clear the currently selected set and allows you to select a new set of entities.

Measuring an Area
 Ribbon:	 Inspect > 2D Measure > Area 

The Area tool is used to measure the

Figure 3-31  Measuring the area of a closed loop

 
area inside a closed loop. To do so, 
invoke the Area tool; you will be 

prompted to click on the area. Click inside 
the closed loop; the area will be highlighted 
in the drawing window and will be displayed 
on the right of the cursor. You will notice that 
all the closed loops inside the selected area 
get removed automatically and are not 
highlighted, as shown in Figure 3-31.

If you also want to include the inner closed 
loops for measuring, then press and hold the 
CTRL key and click inside the inner closed 
loop. The area inside the inner closed loop will also get highlighted and two values will be 
displayed on the right of the cursor. The first value will be the area of the second loop and the 
other value will be the second or combined area of the two loops. You can continue to add or 
remove the closed loops by pressing and holding the CTRL key and then clicking inside them. 

Calculating the Area Properties
 Ribbon:	 Inspect > Evaluate > Area 

The Area tool is used to calculate the properties of a selected area. On invoking this 
tool, you will be prompted to click on an area. Click inside a closed loop; the area of 
that loop will be highlighted. Accept the inputs in the command bar and right-click 

in the area; a shortcut menu will be displayed. Choose the Properties option from it to display 
the Info dialog box. This dialog box lists all the properties of the selected area, as shown in 
Figure 3-32.
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Figure 3-32  The Info dialog box

TUTORIALS
You will use relationships and parametric dimensions to complete the models in the following 
tutorials.

Tutorial 1                                             Synchronous
In this tutorial, you will draw the profile of the model shown in Figure 3-33. The profile shown 
in Figure 3-34 should be symmetric about the origin. You need not use the edit boxes available 
in the command bar to enter the values of the entities. Instead, you can use the parametric 
dimensions to complete the sketch.		                                  (Expected time: 30 min)

Figure 3-34  Profile to be drawn for Tutorial 1Figure 3-33  Model for Tutorial 1
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The following steps are required to complete this tutorial:

a.	 Start Solid Edge and then start a new part file.
b.	 Draw the outer loop of the profile by using the Line tool, refer to Figure 3-35.
c.	 Add relationships and dimensions to the outer loop, refer to Figure 3-36 and Figure 3-37.
d.	 Draw a rectangle inside the outer loop by using the Rectangle tool and add dimensions 

and relations to it, refer to Figures 3-38 and 3-39.
e.	 Save the sketch and close the file.

Starting a Solid Edge Document
	 The profile of the model will be created using the tools in the Home tab of 

Solid Edge’s Synchronous Part environment. Therefore, you need to start a new part file 
first.

1.	 Double-click on the Solid Edge ST7 shortcut icon on the desktop of your computer.

	 Next, you need to start a new part file to draw the sketch of the given model.

2.	 Click on the ISO Metric Part template in the Create area of the welcome screen; a new 
Solid Edge part file get started.

Drawing the Outer Loop and Adding Relationships
	 If the sketch consists of more than one closed loop, it is recommended to draw the outer 

loop first and then add the required relationships and dimensions to it. This makes it 
easier to draw and dimension the inner loop.

1.	 Choose the Line tool from the Draw group of the Home tab; the Line command bar is 
displayed and the alignment lines are attached to the cursor. 

2. 	 Next, you need to define the plane on which you want to draw the profile of the base 
feature. To do so, select the Base Reference Planes check box in the PathFinder and 
move the cursor towards the XZ plane, and then select it for sketching.

3.	 The view orientation of the part document is set to 

Figure 3-35  Outer loop of the profile

Dimetric by default. Choose Sketch View from 
the status bar to view the horizontal and vertical 
settings properly.

4.	 Draw the sketch of the outer loop, as shown in 
Figure 3-35. It is evident from this figure that the 
sketch is drawn around the origin and It is not 
symmetric at this stage. It will become symmetric 
after adding all relationships and dimensions to 
it. You can use the alignment indicators to draw 
the sketch. For your reference, the lines in the 
sketch are indicated by numbers.
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	 Next, you need to add relationships to the sketch. First, you need to apply the Equal 
relationship and then the Symmetric relationship to the sketch.

Note
1. If the relationship handles are not visible by default, choose the Relationship Handles 
button from the Relate group of the Home tab; the relationship handles will be displayed. As 
the Relationship Handles button is a toggle button, you can hide the relationship handle by 
choosing the button again. 

2. Make sure that in the Relationships tab of the IntelliSketch dialog box, the Extension 
(point-on and tangent) check box is selected. Also, ensure  that the Maintain Relationships 
button is chosen in the Relate group of  the Home tab.

5.	 Choose the Equal tool from the Relate group; you are prompted to click on an  
element. 

6.	 Select line 2; the color of this line is changed and you are prompted to select the next 
line. Select line 6; the Equal relationship is applied to lines 2 and 6, and you are again 
prompted to click on an element. Select line 6 as the first line and then line 8 as the second 
line.

	 If the Solid Edge ST7 information box is displayed while applying any of these constraints, 
choose OK to exit the information box.

7.	 Similarly, select lines 8 and 12, 1 and 7, 3 and 5, 5 and 9, 9 and 11, and then lines 4 and 10. 
The Equal relationship is applied to all these pairs of lines.

	 Next, you need to make this sketch symmetric about the two reference planes that appear 
as the vertical and horizontal lines in this view.

8.	 Choose the Symmetric tool from the Relate group; you are prompted to click on  
the symmetry axis.

9.	 Select the Z axis as the symmetry axis; a symmetry axis is created over the reference plane 
and you are prompted to click on an element.

10.	 Select lines 2 and 12. 

	 Similarly, select lines 3 and 11, 4 and 10, 5 and 9, and 6 and 8. Next, you need to make 
lines 1 and 7 symmetric about the horizontal reference axis. Note that you need to set 
the symmetry axis again because the vertical reference axis has already been set as the 
symmetry axis.

11.	 Choose the Symmetric tool from the Relate group; you are prompted to click on an 
element. Specify the X axis as the symmetry axis; you are prompted to click on an 
element.

12.	 Select lines 1 and 7 to add the Symmetric relationship between them.
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13.	 Press the ESC key to exit the current tool. The sketch after adding all relationships is shown 
in Figure 3-36. Notice that all the relationships handles are displayed on the sketch.

Figure 3-36  Profile after adding relationships

Dimensioning the Sketch
	 Once all the required relationships have been added to the profile, you can dimension it. 

As mentioned earlier, when you add dimensions to a sketch and modify the value of the 
dimension, the entity is also modified accordingly. 

	 Before dimensioning the sketch, it is recommended that you turn on the option to display 
the text in black color once it is fully constrained.

1.	 Choose the Relationship Colors button from the Evaluate group of the Inspect tab,  
if not chosen earlier; the relationship option turns on.

2.	 Choose the Smart Dimension tool from the Dimension  group  of  the  Sketching 
tab; you are prompted to click on the element(s) to dimension. Next, select 
line 1. 

	 As soon as you select line 1, a linear dimension to measure the length of line 1 is attached 
to the cursor. 

3.	 Place the dimension below line 1; the Dimension Value edit box is displayed below the 
dimension. Enter 80 in this edit box and press ENTER. 

	 The length of the line is forced to 80 units, and as the sketch is symmetric, the line is 
modified symmetrically.

4.	 As the Smart Dimension tool is still active, you are again prompted to click on the 
element(s) to dimension. Select line 2 and place the dimension on the left of this line. 
Enter 10 in the Dimension Value edit box and press ENTER. 

	 You will notice that the length of lines 6, 8, and 12 is also forced to 10 units each because 
the Equal relationship has been applied to all these lines.

5.	 Select line 3 and place the dimension below this line. Next, enter 15 in the Dimension Value 
edit box and press ENTER.
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6.	 Select line 4 and place it along the previous

Figure 3-37  Profile after adding the relationships 
and dimensions

 
dimension and relationships; the color 
of the sketch turns black, indicating that 
it is fully constrained. Modify the 
dimension value to 30 in the Dimension 
Value edit box and press ENTER. Notice 
that the length of line 10 is also modified.

	 This completes the dimensioning of the 
outer profile. The profile after adding 
these dimensions is shown in Figure 3-37.

Drawing the Inner Loop and Adding Relationships
	 Next, you need to draw the inner loop, which is a rectangle, and add relationships to the 

base feature.

1.	 Choose the Rectangle by Center tool from Home > Draw > Rectangle drop-down; you 
are prompted to click for the first point.

2.	 Click on the origin to specify it as the center point of the rectangle; a dynamic preview of 
the rectangle is displayed and you are prompted to click to create a rectangle.

3.	 Click on the graphics window to create a rectangle. Refer to Figure 3-34 for the location 
of the rectangle.

4.	 Choose the Symmetric tool from the Relate group of the Home tab and set X axis 
as the symmetry axis.

5.	 Select the upper and lower horizontal lines of the rectangle to add symmetric relationship 
between them.

	
	 Next, you need to change the symmetry axis to make the vertical lines symmetrical.

6.	 Choose the Symmetric tool from the Relate group; you are prompted to click on an 
element. Select the Z axis as the symmetry axis.

7.	 Select the two vertical lines of rectangle to make them symmetrical about the Z axis.

	 This completes the process of adding relationships to the inner loop. The sketch at this 
stage will look similar to the model shown in Figure 3-38.

Dimensioning the Inner Loop
1.	 Choose the Smart Dimension tool from the Dimension group of the Home tab and select 

the upper horizontal line of the inner loop.
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2.	 Place the dimension above the sketch. Enter 30 in the Dimension Value edit box and 
press ENTER.

3.	 Next, select the right vertical line of the inner loop and place the dimension on the right 
of the sketch. Enter 20 in the Dimension Value edit box and then press ENTER; the inner 
loop turns black, indicating that it is fully constrained. This completes the dimensioning 
of the profile. The final profile, after adding all dimensions, is shown in Figure 3-39.

Figure 3-38  Profile after adding 
relationships to the inner loop

Figure 3-39  Final profile after adding all 
dimensions

	 As mentioned in the previous chapter, it is recommended that you exit the sketching 
environment before saving or closing the file because you cannot close a file in the sketching 
environment. 

4.	 Press the ESC key to exit the current tool.

Saving the File
1.	 Choose the Save button from the Quick Access toolbar; the Save As dialog box is displayed. 

	 As mentioned in the previous chapter, you need to create a separate folder for every 
chapter in the textbook.

2.	 Browse to the C > Solid Edge folder and then create a folder with the name c03. 

3.	 Double-click on the c03 folder to open it and save the file with the name c03tut1. 

4.	 Choose the Application Button; a flyout is displayed. In this flyout, choose Close to close 
the file.

Tutorial 2	                                                Ordered
In this tutorial, you will create the profile for the model shown in Figure 3-40. The profile to 
be drawn is shown in Figure 3-41. You will use relationships and parametric dimensions to 
complete the sketch.		    			     	   (Expected time: 30 min)
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Figure 3-41  Profile to be drawn for Tutorial 2Figure 3-40  Model for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Start a new part file.
b.	 Switch to the Ordered Part environment.
c.	 Invoke the sketching environment.
d.	 Draw the required profile by using the Line and Circle by Center Point tools, refer to 

Figure 3-42.
e.	 Add the required relationships and dimensions to the sketch, refer to Figure 3-44.
f.	 Save the file and close it.

Starting a New Part File and Selecting the Sketching Plane
1.	 Choose the New tool from the Quick Access toolbar; the New dialog box is displayed.

2.	 In this dialog box, select iso metric part.par and choose OK to start a new part file. 

3.	 Select the Ordered radio button from the Model group of the Tools tab; the Ordered 
Part environment is invoked.

4.	 Select the check box adjacent to the Base Reference Planes node under PathFinder; the 
visibility of the reference plane is turned on.	

5.	 Choose the Sketch tool from the Sketch group of the Home tab; the Sketch command 
bar is displayed and you are prompted to select a planar face or a reference plane.

6.	 Select the top plane to draw the profile; the selected plane gets oriented to the normal 
view.

Drawing the Profile
	 It is recommended that you draw the first entity in the sketch by entering its exact values 

in the command bar. This allows you to modify the drawing display area to fit the first 
entity. You can draw the other entities taking the reference of the first entity. This also 
helps you dimension the entities at a later stage.
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1.	 Using the Line tool and options in the command bar, draw a line of length 40 units with 
its start point at the origin.

2.	 Taking the reference of the first line, draw the remaining entities in the profile to complete 
it. Use the arc mode of the Line tool to draw the tangent arcs in the profile.

Figure 3-42  Profile after drawing all entities

	 Now, draw the circle by using the Circle by 
Center Point tool while drawing the circle, if 
the center point of the arc is not displayed, 
then move the cursor over the arc to display 
its center point. Use this center point to 
define the center point of the circle. The 
profile after drawing all entities is shown in 
Figure 3-42. For your reference, the entities 
in the sketch are indicated by numbers.

Adding Relationships to the Profile
	 Next, you need to add relationships to the 

profile. As lines 6 and 10 overlap with the vertical reference plane, you may need to use 
the QuickPick list box to select these lines. To use the QuickPick list box, move the cursor 
over the entity that overlaps other entities and pause for a moment. On doing so, three 
dots are displayed on the right of the cursor. Next, right-click; the QuickPick list box 
with the names of the overlapping entities is displayed. Move the cursor over the entities 
and select when the desired entity is highlighted.

1.	 Choose the Equal tool from the Relate group of the Home tab and add this 
relationship between lines 1 and 5, 2 and 4, 6 and 10, and 7 and 9.

	 Next, you need to make the two arcs in the sketch tangent to the lines to which they are 
connected. The tangent relationship could have been applied to the sketch while drawing it. 
To check this relationship, see whether a small circle is displayed at all points where the arcs 
and the lines meet. The small circle is the relationship handle of the tangent relationship. 
Ideally, this handle must be displayed at four locations: the points where arc 3 meets lines 
2 and 4 and the points where arc 8 meets lines 7 and 9.

2.	 Choose the Tangent tool from the Relate group of the Home tab and add the tangent 
relationship between the entities where it is missing. 

Note
If you add a relationship that has already been added, the Solid Edge ST7 message box is 
displayed, informing that the requested change conflicts with the existing relationships.

	 Next, you need to horizontally align the center point of arc 8 with the center point of the 
circle by using the Horizontal/Vertical relationship.

3.	 Choose the Horizontal/Vertical tool from the Relate group of the Home tab. Move the 
cursor over arc 8 to display its center point. Select the center point when it is displayed. 
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Similarly, select the center point of the circle; a horizontal dashed line is displayed between 
the two centers, indicating that they are horizontally aligned. 

	 This completes the process of adding relationships to the profile. The profile after adding 
all relationships is shown in Figure 3-43.

Figure 3-43  Profile after adding all relationships

Dimensioning the Profile
	 After adding relationships, you need to dimension the profile.

1.	 Choose the Smart Dimension tool from the Dimension group of the Home tab; 
you are prompted to click on the elements to dimension. 

2.	 Select line 9 and place the dimension below the profile. Modify the value of the dimension 
to 20 in the Dimension Value edit box displayed with the dimension and then press 
ENTER.

                        
3.	 Select line 1 and place the dimension below the previous dimension. Enter 40 in the 

Dimension Value edit box.

4.	 Select line 6 and the circle. Next, place the dimension above the profile and modify the 
value of the dimension to 80 in the Dimension Value edit box.

5.	 Select line 10 and place the dimension on the left of the profile. Enter 20 in the Dimension 
Value edit box. 

6.	 Select lines 5 and 1, and place the dimension on the left of the previous dimension. Enter 
60 in the Dimension Value edit box. 

7.	 Select arc 3 and place the dimension on the right of the sketch. Enter 10 in the Dimension 
Value edit box. 

8.	 Select the circle and place the dimension on the right of the sketch. Enter 12 in the 
Dimension Value edit box. 
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	 This completes the dimensioning of

Figure 3-44  Profile after adding all dimensions

 
the profile. The profile after adding 
all required dimensions is shown in 
Figure 3-44.

9.	 Choose the Select tool from the 
Select group of the Home tab to exit 
the active sketching tool.

10.	 Choose the Close Sketch tool from the 
Ribbon; the sketching environment 
is closed and the Sketch command 
bar is displayed. Also, the current 
view is automatically changed to 
the isometric view.

11.	 Enter Base Sketch as the name of the sketch in the Name edit box of the command bar. 
Choose the Finish button and then the Cancel button to exit the sketching environment; 
the sketch is displayed by the specified name in the PathFinder.

Saving the File
1.	 Choose the Save button from the Quick Access toolbar and save the file with the name 

c03tut2 at the location given below.
	
	 C:\Solid Edge\c03 

2.	 Choose the Application Button; a flyout is displayed. In this flyout, choose Close from 
the flyout to close the file.

Tutorial 3				                             Ordered
In this tutorial, you will create the profile for the revolved model shown in Figure 3-45. The 
profile is shown in Figure 3-46. You will use the parametric dimensions to complete the 
sketch.			     			     		    (Expected time: 30 min)

	 The following steps are required to complete this tutorial:

a.	 Start a new part file.
b.	 Switch to the Ordered Part environment.
c.	 Invoke the sketching environment.
d.	 Draw the required profile by using the Line tool, refer to Figure 3-47.
e.	 Add the required dimensions to the sketch.
f.	 Save the file and close it.
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Figure 3-46  Profile to be drawn for Tutorial 3Figure 3-45  Model for Tutorial 3

Starting a New Part File and Selecting the Sketching Plane
You can start a new part file by choosing the New tool from the Quick Access 
toolbar, which remains on the screen after you close all the files.

1.	 Choose the New tool from the Quick Access toolbar to display the New dialog box.

2.	 Select iso metric part.par and choose OK to start a new part file. 

3.	 Select the Ordered radio button from the Model group of the Tools tab; the Ordered 
Part environment is invoked.

4.	 Select the check box adjacent to the Base Reference Planes node in the PathFinder; the 
visibility of the reference plane is turned on.	

5.	 Choose the Sketch tool from the Sketch group of the Home tab; the Sketch command 
bar is displayed and you are prompted to select a planar face or a reference plane.

6.	 Select the front plane to draw the profile; the selected plane is oriented normal to the 
viewing direction. Also, the Line tool will be invoked by default.

Drawing the Profile Using the Line Tool
To draw the profile, you need to draw the sketch from the lower left corner. The bottom 
horizontal line will be the first entity to be drawn.

1.	 Move the cursor to the origin and specify it as the start point of the first line.

2.	 Enter 60 as the value of length and 0 as the value of angle for the first line in the 
dynamic edit box. Then, press ENTER to draw the first line segment. 

3.	 Pan the drawing by using the Pan tool available in the status bar such that the origin is 
moved close to the middle of the bottom edge of the drawing window.
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4.	 Complete the sketch of the revolved model by drawing the

Figure 3-47  Profile for the 
revolved model

 
remaining lines by taking the reference of the first line, 
refer to Figure 3-47. The lines in this sketch have been 
numbered for your reference.

Adding Dimensions to the Profile
	 Next, you need to add dimensions to the profile. Since it is 

a profile for the revolved model, you need to add symmetric 
diameter dimensions to define the diameter of the revolved 
feature, refer to Figure 3-46.

1.	 Make sure that the Relationship Colors button is chosen in 
the Evaluate group of the Inspect tab. 

2.	 Choose the Symmetric Diameter button from the  
Dimension group of the Home tab ; you are 
prompted to select the dimension origin element, 
which acts as the axis of revolution. In this profile, line 8 is 
the dimension origin element.

3.	 Select line 8 and then select the right endpoint of line 1. Choose the Half/Full button 
from the command bar, if it has not been chosen. 

4.	 Place the dimension below the sketch. You may need to change the drawing display area 
by choosing the Zoom button. 

5.	 Enter 120 as the value of the dimension in the Dimension Value edit box.

	 Line 8, which was selected as the dimension origin element, is not required to be selected 
again. You can directly select other dimension measurement elements to add symmetric 
diameter dimensions.

6.	 Select the lower endpoint of line 4 and place the dimension below the sketch. Modify the 
value of dimension to 80 in the Dimension Value edit box. 

	 You will notice that as you place this dimension, the previous symmetric dimension also 
moves. Now, if you add the symmetric dimension to line 7 in the same sequence, the first 
two dimensions will also move while placing the third dimension. Therefore, you first 
need to exit the current sequence of dimensioning.

7.	 Right-click to exit the current sequence of dimensioning; you are again prompted to select 
the dimension origin element. 

8.	 Select line 8 and then the right endpoint of line 7; the symmetric diameter dimension is 
attached to the cursor. 
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9.	 Place the dimension above the sketch and modify its value to 70. Then, press ENTER.
	 Next, you need to add the linear and angular dimensions to the remaining entities by 

using the Smart Dimension tool.

10.	 Choose the Smart Dimension tool from the Dimension group of the Home tab;  
you are prompted to click on the element(s) to dimension. 

11.	 Select line 2; an aligned dimension is attached to the cursor. Press and hold the SHIFT 
key and move the cursor to the right of the sketch. The vertical dimension of line 2 is 
displayed.

12.	 Place the dimension on the right of the sketch and modify its value to 12 in the Dimension 
Value edit box. Next, press ENTER.

13.	 Select lines 1 and 2, and then choose the Angle button from the command bar. Move the 
cursor to the right of the sketch to display the major angle dimension. Place the dimension 
on the right of the sketch and enter 117 in the Dimension Value edit box. 

14.	 Select line 3 and choose the Angle button from the command bar, and then select line 
4. Next, move the cursor to the left of line 4 to display the angular dimension. Place the 
dimension on the left of line 4 and enter 77 in the Dimension Value edit box. 

15.	 Select line 5 and press and hold the SHIFT key to display the vertical dimension of line 5. 
Place the dimension on the right of the sketch and enter 30 in the Dimension Value edit 
box. 

Figure 3-48  The final model with all dimensions

16.	 Select line 6 and place the dimension on 
the right of the sketch in line with the 
previous dimension. Modify the value of 
dimension to 40. 

17.	 Select line 8 and place the dimension 
on the left of the sketch. Modify the 
dimension value to 150. 

	 This completes the dimensioning of 
the sketch. The sketch after adding all 
dimensions is shown in Figure 3-48. 
Notice that as the option for displaying 
the fully constrained sketch in a different 
color was chosen from the Evaluate group 
of the Inspect tab, the sketch will turn 
black after placing the last dimension.
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Saving the File
1.	 Choose the Select tool from the Select group of the Home tab.

2.	 Choose the Close Sketch tool from the Close group of the Home tab; the sketching 
environment is closed and the Sketch command bar is displayed. Also, the current view 
is automatically changed to the isometric view.

3.	 Choose the Save button from the Quick Access toolbar and save the file with the name 
c03tut3 at the location given below:

	
	 C:\Solid Edge\c03 

4.	 Choose the Application Button and then the Close button to close the file.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 All geometric relationships have the same relationship handles associated with them. (T/F)

2.	 You can set the symmetry axis before invoking the Symmetric tool in the Ordered Part 
environment. (T/F)

3.	 The Coordinate Dimensions tool is used to dimension a sketch with respect to a common 
origin point. (T/F)

4.	 The symmetric diameter dimensions are used to dimension the sketches of the revolved 
components. (T/F)

5.	 The __________ relation forces two arcs, two circles, or an arc and a circle to share the 
same center point.

6.	 The __________ dimensions are applied to dimension a circle or an arc in terms of its 
diameter.

7.	 The tools available in the __________ drop-down are used to specify the orientation of 
dimensions.

8.	 The __________ dimensions measure the actual distance of the inclined lines.

9.	 The __________ constraint is used to fix the orientation or the location of the selected 
sketched entity or the keypoint of the sketched entity.

10.	 By default, circles are assigned to the __________ dimensions.
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 Review Questions 
Answer the following questions:

1.	 Which of the following dimensions is applied to the arcs by default?

		  (a) Radial			   (b) Diameter 
		  (c) Angular 			   (d) Linear

2.	 Which of the following dimensions is used to create angular coordinate dimensions with 
respect to a common origin point?

		  (a) Angular			   (b) Angular Coordinate 
		  (c) Linear 			   (d) Coordinate

3.	 Which of the following relationships is used to fix the orientation or location of a selected 
sketched entity or a keypoint of the sketched entity?

		  (a) Fix				    (b) Lock
		  (c) Hide 			   (d) None of these

4.	 Which of the following relationships is used to force the selected sketched entities to 
become symmetrical about a symmetry axis?

		  (a) Symmetrical		  (b) Collinear
		  (c) Coincident			   (d) Horizontal

5.	 Which of the following relationships forces a selected line to become normal to another 
line, arc, circle, or ellipse?

		  (a) Symmetrical		  (b) Collinear
		  (c) Coincident			   (d) Perpendicular

6.	 You cannot modify a dimension after placing it. (T/F)

7.	 While placing the angular dimensions, you can select the option to display the major or  
minor angular value. (T/F)

8.	 You can add a prefix or a suffix to the dimension values. (T/F)

9.	 In Solid Edge, you can also add tolerance to dimensions in the sketching environment 
(T/F)

10.	 The aligned dimensions cannot be used to dimension the lines that are not parallel to 
the 	X axis or the Y axis. (T/F)
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 Exercises 

Exercise 1
Draw a profile for the base feature of the model shown in Figure 3-49. The profile to be drawn 
is shown in Figure 3-50. Use the relationships and parametric dimensions to complete the 
profile. 						         		    (Expected time: 30 min)

Figure 3-50  Profile for Exercise 1Figure 3-49  Model for Exercise 1

Exercise 2
Draw the sketch of the model shown in Figure 3-51. The sketch is shown in Figure 3-52. After 
drawing the sketch, add the required relations and dimensions to it.
								          (Expected time: 30 min)

Figure 3-52  Sketch for Exercise 2Figure 3-51  Model for Exercise 2
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Exercise 3
Draw the profile for the base feature of the model shown in Figure 3-53. The profile to be 
drawn is shown in Figure 3-54. Use the relationships and parametric dimensions to complete 
the profile. 						          	   (Expected time: 30 min)

Figure 3-53  Solid model for Exercise 3 Figure 3-54  Sketch for Exercise 3

Exercise 4
Draw the profile for the revolve feature of the model shown in Figure 3-55. The profile to be 
drawn is shown in Figure 3-56. Use the relationships and parametric dimensions to complete 
the profile. 						          	   (Expected time: 30 min)

Figure 3-55  Solid model for Exercise 4 Figure 3-56  Sketch for Exercise 4
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Exercise 5
Draw the profile for the base feature of the model shown in Figure 3-57. The profile to be 
drawn is shown in Figure 3-58. Use the relationships and parametric dimensions to complete 
the profile. 						          	    (Expected time: 30 min)

Figure 3-58  Profile for Exercise 5Figure 3-57  Model for Exercise 5

Answers to Self-Evaluation Test
1. F, 2. T, 3. T, 4. T, 5. Concentric, 6. Diameter, 7. Orientation, 8. Aligned, 9. Lock , 
10. Diameter


