
Chapter 3

Creating Sketches in 
the Sketch Mode-II

Learning Objectives

After completing this chapter, you will be able to:
• Use various options to dimension a sketch. 
• Create fillets.
• Place a user-defined coordinate system.
• Create, dimension, and modify splines.
• Create text.
• Move and resize entities.
• Copy a sketch.
• Import 2D drawings.



3-2  						              PTC Creo Parametric for Designers 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Dimensioning the sketch
In Chapter 2, you learned dimensioning a sketch using the Normal tool from the Dimension 
group. In this chapter, you will learn the use of the Baseline tool for dimensioning a sketch.

Dimensioning a Sketch Using the Baseline Tool
  Ribbon:  Sketch > Dimension > Baseline     

In PTC Creo Parametric, the Baseline tool is used to create dimensions in terms of horizontal 
and vertical distance values of an entity with respect to a specified baseline. This type of 
dimensioning in a drawing makes writing a CNC program for manufacturing a component 
easy. 

The Baseline tool is available in the Dimension group. Using this tool, you can dimension 
a line, arc, conic, and so on. The following steps explain the procedure to create dimensions 
using the Baseline tool:

1.	 Choose the Baseline tool from the Dimension group, refer 

Figure 3-1 The Dimension 
group

to Figure 3-1.

2.	 Select the entity that will act as the baseline (origin or 
reference). Press the middle mouse button to place the 
dimension; the dimension 0.00 will be displayed where you 
place the dimension. Note that since the location value of the baseline is taken as the 
origin, the dimension value of the baseline entity will become 0.00. The dimension values 
of all other entities dimensioned with reference to the baseline will be measured from this 
origin.

	 Depending upon the entity selected as the baseline, the horizontal or vertical location 
values of the entity will be placed. For example, if you select a vertical line, the value of 
its location will be placed vertically. Similarly, if you select a horizontal line, the value of 
its location will be placed horizontally.

	 You can dimension arcs, circles, and splines by using the

Figure 3-2  The Dim Orientation 
dialog box

 
two options that are displayed on invoking the 
Baseline tool. If you select the center of a circle or an 
arc for baseline dimensioning and press the middle 
mouse button, the Dim Orientation dialog box will 
be displayed, as shown in Figure 3-2. Also, you will be 
prompted to select the orientation. Select the required 
radio button from this dialog box and choose the 
Accept button; the dimension will be placed based on 
the orientation selected. 

3.	 Next, choose the Normal tool from the Dimension group. Select the baseline dimension 
that was placed earlier and then select the entity to dimension. Now, press the middle 
mouse button to place the dimension.
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	 The orientation of the dimension will depend upon the baseline dimension and the entity 
selected. Figure 3-3 shows a sketch dimensioned using the above-mentioned method. In 
this figure, the two baselines are dimensioned using the Baseline tool. Therefore, the 
dimensions of these lines are displayed as 0.00. The remaining lines are dimensioned by 
selecting the baseline dimension and then the required entity by using the Normal 
tool.

Figure 3-3  Baseline dimensioning of a sketch

Replacing the Dimensions of a Sketch Using the Replace 
Tool
  Ribbon:  Sketch > Operations > Replace     

The Replace tool is used to replace a dimension with a new dimension in a sketch. To use this 
option, you must have a  dimensioned sketch. The following steps explain the procedure to 
dimension a sketch using the Replace tool:

1.	 Choose the Replace tool from the menu displayed on clicking the down arrow adjacent 
to the Operations group; you will be prompted to select the dimension to be replaced.

 
2.	 Select the dimension to be replaced; the selected dimension will be deleted and you will be 

prompted to create a replacement dimension. Select the entities between which you want to 
create a new dimension; the previous dimension will be replaced by a new dimension.

Creating Fillets
In the sketcher environment, you can create the following two types of fillets:

1.	 Circular fillets
2.	 Elliptical fillets

Creating Circular Fillets
  Ribbon:  Sketch > Sketching > Fillet > Circular     

A circular fillet is the arc formed at the intersection of two lines, a line and an arc, or 
two arcs. This type of fillet is controlled by the radius or diameter dimension of the 
fillet. The resulting fillet will depend on the location where the elements are selected. 
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Figure 3-4 shows two non-parallel lines and Figure 3-5 shows the circular fillet created between 
them. The circular fillet thus created is an arc with its endpoints tangent to the two lines. This 
is evident from the T symbol that is automatically applied to the endpoints of the fillet arc.

Figure 3-5  Fillet created between the two linesFigure 3-4  Two lines that do not join

Figure 3-6 shows two lines that join at a point and Figure 3-7 shows the circular fillet created 
at the joint.
 

Figure 3-7  Filleted cornerFigure 3-6  Two lines joining at a point

Figure 3-8 shows two sets of arcs and Figure 3-9 shows the circular fillet created between the 
two arcs. The location where you select the arcs to create the fillet is important. The fillet is 
created tangent to the selection points on the arcs. Here, the endpoints of the arcs are selected 
to create the fillet.

If the points of selection on the two arcs are away from the endpoints of the arcs, then the fillet 
is created at the selection points. The portion of the arc that extends beyond the fillet should be 
manually deleted or trimmed. Figure 3-10 shows the points at which the two arcs are selected and 
Figure 3-11 shows the fillet created at the selection points.
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Figure 3-9  Fillet created by selecting the endpointsFigure 3-8  Two sets of arcs

Figure 3-11  Fillet created Figure 3-10  Points selected on arcs

To create circular fillets, there are two options named Circular and Circular Trim. These 
options are available in the Fillet drop-down. These options are discussed next.

As mentioned earlier, the Circular option is used to create circular fillets. When you create 
fillet using this option, the filleting entities do not get trimmed but the part of entity after the 
fillet converts into construction geometry.

The Circular Trim option is also used to create circular fillets, but in this case the portion 
extending beyond the entities get trimmed automatically. 

Procedure to create circular fillets using both the options is same and it is discussed next.

1.	 Choose the Circular or Circular Trim option from the Fillet drop-down in the Sketching 
group; you will be prompted to select two entities.

2.	 Select the first entity for filleting by using the left mouse button; the red color of the first 
entity changes to green. Now, select the second entity. It will be drawn between the two 
selected entities as soon as you select the second entity.
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3.	 Repeat step 2 until you have created all fillets.  

Creating Elliptical Fillets
  Ribbon:  Sketch > Sketching > Fillet > Elliptical     

An elliptical fillet is the arc in the form of an ellipse that joins two lines, two arcs, or 
a line and an arc. The geometry of the elliptical fillet depends on the location where 
you select the entities to create a fillet.

The advantage of elliptical fillets over circular fillets is that the geometry of elliptical fillets can 
be controlled by dimensions in two directions. Therefore, when an elliptical fillet is dynamically 
modified, its geometry can be controlled in either the x-direction or the y-direction resulting 
in more curved geometric shape than a circular fillet.

Figures 3-12 and 3-13 illustrate the elliptical fillet. Notice that a strong tangent constraint T 
is automatically applied when you create a fillet.

Figure 3-13  Elliptical fillet createdFigure 3-12  Arcs to be filleted

Similar to circular fillet, there are two options to create elliptical fillet, Elliptical and Elliptical 
Trim. The procedure to create elliptical fillets using any of these options is same. The procedure 
to create elliptical fillets is discussed next.

1.	 Choose the Elliptical or Elliptical Trim tool from the Fillet drop-down; you will be 
prompted to select two entities.

2.	 Select the first entity by clicking; the color of the entity changes to green.

3.	 Select the second entity. As soon as you select the second entity, the elliptical fillet is 
created. The shape of the elliptical fillet depends upon the specified points. After the 
fillet is created, you will be again prompted to select two entities for elliptical fillet.
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Figure 3-14 The Ellipse Rad 
dialog box

4.	 Repeat steps 2 and 3 until you have created all fillets.

When you select an elliptical fillet to dimension, the Ellipse Rad 
dialog box will be displayed, as shown in Figure 3-14. There 
are two radio buttons in this dialog box. When the Major Axis 
radio button is selected, the elliptical fillet will be dimensioned 
radially along the X-direction. The Minor Axis radio button, 
when selected, dimensions the elliptical fillet radially in the 
Y-direction.

Creating A Reference Coordinate System 
There are two types of coordinate systems, construction and geometric. As discussed earlier, 
the construction entities cannot be referenced outside the Sketcher environment whereas, the 
geometric entities can be. The Coordinate System tool in the Datum group is used to create a 
coordinate system that will act as a reference for dimensioning. You can dimension the splines 
using the coordinate system. Thus, it provides you the flexibility to modify the spline points 
by specifying different coordinates with respect to the coordinate system.

The user-defined coordinate system is used in blend features to align different sections 
in a blend. It is also used in the Assembly and Manufacturing modes of 
PTC Creo Parametric.

The following steps explain the procedure to create a coordinate system:

1.	 Choose the Coordinate System tool from the Datum group; you will be prompted to select 
the location for the coordinate system. The coordinate system symbol is attached to the 
cursor.

2.	 Place the coordinate system at the desired points on the screen by clicking the left 
mouse button. The coordinate system will be placed at as many places as you click in the 
graphics window. You can end the coordinate system creation by using the middle mouse 
button.

Note
If you add a coordinate system to a sketch, it must be dimensioned. But if the coordinate system 
is placed at the endpoints of a line, an arc, a spline, or at the center of an arc or a circle, it 
need not be dimensioned. In other words, a coordinate system must be referenced to an entity 
in a sketch.

Working with Splines 
Splines are curved entities that pass through a number of intermediate points. Generally, 
splines are used to define the outer surface of a model. This is because the splines can provide 
different shape to curves and the flexibility to modify the surfaces that result from the splines. 
Splines find application in automobile and aeroplane body designing.
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Creating a Spline
  Ribbon:  Sketch > Sketching > Spline     

To draw a spline, choose the Spline tool from the Sketching group. The steps to create 
a spline are discussed next.

1.	 Choose the Spline tool from the Sketching group; you will be prompted to select the 
location for spline.

2.	 Use the left mouse button to select the start point for the spline. Similarly, select additional 
points in the graphics window; a spline will be drawn passing through all specified points. 
Press the middle mouse button to end the creation of spline. All points through which the 
spline passes are called interpolation points.

Dimensioning of Splines
When a spline is drawn, the weak dimensions are automatically applied to the spline. A spline 
can be dimensioned manually by: 

1.	 Dimensioning the endpoints
2.	 Radius of curvature dimensioning
3.	 Tangency dimensioning
4.	 Coordinate dimensioning
5.	 Dimensioning the interpolation points

Dimensioning the Endpoints
To dimension a spline by selecting the endpoints, you need to follow the steps given below:

1.	 Choose the Normal tool from the Dimension group.

2.	 Select the two endpoints of the spline and place the horizontal or vertical dimension by 
pressing the middle mouse button. Figure 3-15 shows a spline that is dimensioned by 
selecting the endpoints. 

Radius of Curvature Dimensioning
The radius of curvature of a spline can be dimensioned only if its tangency is defined. In 
other words, radius of curvature of a spline can be dimensioned only if the spline is tangent 
to an entity. For dimensioning the radius of curvature of a spline, you need to follow the steps 
given below:

1.	 Choose the Normal tool from the Dimension group.

2.	 Select the endpoint of the spline where the tangency is defined.

3.	 Press the middle mouse button to place the dimension. Figure 3-16 shows the radius of 
curvature dimensioning of a spline.
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Figure 3-15  Endpoint dimensioning Figure 3-16  Radius of curvature dimensioning

Tangency or Angular Dimensioning
A spline can be dimensioned angularly with respect to a line tangent to it. This type of 
dimensioning is also called angular dimensioning. To angular dimension a spline and a line 
tangent to it, you need to follow the steps given below:

1.	 Choose the Normal tool from the Dimension group.

2.	 Select the spline by clicking the left mouse button.

3.	 Select the entity tangent to the spline by clicking the left mouse button.

4.	 Select the interpolation point of the spline that is to be dimensioned tangentially.

5.	 Press the middle mouse button to place the dimension.

Coordinate Dimensioning
The spline can be dimensioned with respect to a user-defined coordinate system. Choose the 
Coordinate System tool from the Sketching group. The coordinate system is attached to the 
cursor. Place the coordinate system in the graphics window. Now, the spline can be dimensioned 
with respect to the coordinate system.

Dimensioning the Interpolation Points
A spline can be dimensioned by dimensioning its interpolation points or vertices. This type 
of dimensioning is used when the designer wants the spline to be standard for all designs. 
This is because the exact curve can be duplicated if the interpolation points or the vertices of 
a spline are dimensioned.

Tip: A dimension can be moved by choosing the One-by-One button from the 
Operations group and then pressing and holding the left mouse button on the 
dimension and moving it. The dimension text is replaced by a green colored box. You 
can drag the dimension to the desired location in the graphics window and release 
the left mouse button to place the dimension at that point.
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Modifying a Spline
In PTC Creo Parametric, a spline can be modified by:

1.	 Moving the interpolation points of the spline.
2.	 Adding points to a spline.
3.	 Deleting points of a spline.
4.	 Creating a control polygon and moving its control points.
5.	 Modifying the dimensions of the spline.

Moving the Points of a Spline
The position of the interpolation points can be dynamically modified. To modify a spline, select 
an interpolation point on the spline and then drag it to modify the shape of the spline.

Alternatively, select the spline and hold the right mouse button to invoke the shortcut menu. 
Choose the Modify option from the shortcut menu or double-click on the spline; the Spline 
tab will be displayed in the Ribbon with the options and buttons to modify a spline.

The interpolation points of the spline appear in black crossmarks in the graphics window. 
Drag the interpolation points to modify the shape of the spline. 

Adding Interpolation Points to a Spline
To add interpolation points to a spline, choose the Spline tab. Now, right-click on the spline 
to invoke a shortcut menu. Next, choose the Add Point option; a point is added to the spline 
where the spline was selected. The new point appears in black crossmark. You cannot increase 
the length of the spline by adding points before the start point and after the endpoint of the 
spline.

Deleting Interpolation Points of a Spline
To delete a point or a vertex, choose the Spline tab. Next, right-click on the vertex to be 
removed to invoke the shortcut menu. Choose the Delete Point option from the shortcut 
menu; the selected point is deleted. You can continue deleting vertices or points from a spline 
until only two end points are left in the spline.

Creating a Control Polygon and Moving its Control Points
When you draw a spline, it is associated with a control frame. The vertices of this frame 
are called control points. To create a control polygon, choose the Modify spline using 
control points button from the Spline tab. The control polygon will be displayed in 

the graphics window. The control points of this polygon can be moved by dragging to modify 
the spline shape.

Tip: To dynamically modify the shape of the sketch, you need to select an entity of the 
sketch and drag the mouse to modify the sketch. Remember that if the selected entity 
is constrained, then you cannot modify it. You can modify it only after disabling the 
constraints. 
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Modifying the Dimensions of the Spline
The shape of the spline is controlled by the position of its interpolation points. Hence by 
modifying the dimensions, the position of the interpolation points are changed, which results in 
modification of the shape of the spline.

Writing text in the sketcher environment
  Ribbon:  Sketch > Sketching > Text     

There are various instances when a designer needs to write text on the model. For example, 
for creating a label, model number, company name, and so on. In PTC Creo Parametric, you 
can write this text in the sketcher environment. 

In the sketcher environment, the text is written using the Text tool from the Sketching 
group. The following steps explain the procedure to write text in the sketcher 
environment:

1.	 Choose the Text tool from the Sketching group; you will be prompted to select the start 
point of line to determine the text height and orientation.

2.	 Specify the start point on the screen by clicking the left mouse button; you will be prompted 
to select the second point of line to determine the text height and orientation. 

Figure 3-17  The Text dialog box

3.	 Note that to write the text upright, the 
second point should be above the start 
point and in a straight line. If the second 
point is below the start point, the text will 
be written  down from right to left. Specify 
the second point on the screen by clicking 
the left mouse button; the Text dialog box 
will be displayed, as shown in Figure 3-17.

	 After specifying the second point, a 
construction line is drawn having height 
equal to the distance between the two 
points. The height and orientation of the 
text depends on the height and angle of 
the construction line. If the construction 
line is drawn at an angle, then the text will 
be written at that angle.

4.	 Enter the text in the Text line edit box, 
which can be up to 79 characters. As you 
enter the text, the text will be displayed dynamically in the graphics window. You can 
choose the desired font of the text from the Font drop-down list. The aspect ratio and 
the slant angle of the text can be controlled by using the slider bars.

5.	 Choose the OK button in the Text dialog box to exit it.
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Note
In later chapters of this book, you will learn that there are other methods also to enter in to 
sketcher environment, besides entering through the sketch mode.

rotating and resizing entities
  Ribbon:  Sketch > Editing > Rotate Resize     

The sketches can be scaled or rotated by using the Rotate Resize tool available in the 
Editing group. Select a sketch and then choose the Rotate Resize tool from 
the Editing group. On choosing this tool, the sketch, which consists of various entities, 

will act as a single entity. Also, the sketch appears green in color and is enclosed within a 
boundary box, as shown in Figure 3-18.

Figure 3-18  Selected entities enclosed within a boundary box with three handles

There are three handles that facilitate in scaling, rotating, and moving the selected sketch. 
The rotate handle is used to dynamically rotate the selected entities. The scale handle is used 
to dynamically scale the selected entities. The base point handle is used to pick the sketch 
and place it at any other location in the graphics window. To change the location of any of the 
three handles, right-click on the handle and drag it by pressing and holding the right mouse 
button; the selected handle will move along with the cursor. Place the symbol at the desired 
location. The following steps explain the procedure to move and resize a sketch:

1.	 Select the sketch to be rotated and scaled, and then choose the Rotate Resize tool; the 
Rotate Resize tab will be activated in the Ribbon. The options in these areas are used to 
move, scale, and rotate the sketch dynamically or by entering a value in the respective 
edit boxes. You can also select a reference about which you want to translate, rotate, or 
scale the sketch.

2.	 To move the sketch dynamically, select the move handle and then drag the handle to the 
required location; the sketch will be repositioned at the new location. You can also select 
a reference from the drawing area about which you want to move the sketch and the 
reference will be displayed in move collector of the dashboard.
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3.	 To dynamically rotate the sketch, select the rotate handle and then move the cursor; the 
sketch will rotate as you move the cursor. You can also enter the rotation angle in the 
Rotate edit box.

4.	 To scale the sketch, select the scale handle and then move the cursor. As you move the 
cursor, the sketch is scaled dynamically in the graphics window. You can also enter the 
scale value in the Scale edit box.

5.	 After the sketch has been moved and resized, choose the Done button from the Rotate 
Resize tab. 

Importing 2D Drawings in the sketch mode
  Ribbon:  Sketch > Get Data > File System     

The two-dimensional (2D) drawings when opened in the 

Figure 3-19  File formats

sketcher environment can be saved in the .sec format. The 
.sec file can be used to create a solid model. You can use a 

prestored sketch by importing it in the modeling environment. The 
File System button in the Get Data group is used to import 2D 
sketches. Using this button, you can save time in drawing the same 
or similar section again. The file formats from which the data can 
be imported are shown in Figure 3-19. 

When you choose the File System button from the Get Data group; the Open dialog box 
will be displayed, as shown in Figure 3-20. You can use this dialog box to select and open the 
file.

Figure 3-20  The Open dialog box
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In the Open dialog box, if you select a drawing file created in the Drawing mode of 
PTC Creo Parametric, the draft entities of that file will be imported and selected drawing will be 
opened in a window. Also, you will be prompted to select the entities to copy from the window. 
Select the draft entities and then press the middle mouse button; the window disappears and 
a plus sign gets attached to the cursor indicating that you need to select a point on the PTC 
Creo Parametric screen to insert the file. Select a point on the screen; the selected entities get 
inserted and are displayed within an enclosed boundary. Also, the Import Section tab will be 
displayed. Use this dialog box to set the position, scale, and orientation of the sketch. Note 
that if the .drw file does not consist of draft entities, no data will be imported.

In the Open dialog box, if you select a .sec file that will be created in the sketcher environment, 
the sketch will be displayed in the graphics window enclosed within a boundary.

The section imported using the File System button in the current sketch is an independent 
copy. The imported section will be no longer associated with the source section. The units, 
dimensions, grid parameters, and accuracy are acquired from the current sketch.

Tip: You can turn on or off  the display of the vertices of the section, the dimensions, and 
the constraints from the Sketching group.

Tutorials
Tutorial 1

In this tutorial, you will import an existing sketch that you had drawn in Tutorial 3 of 
Chapter 2. After placing the sketch, draw the keyway, as shown in Figure 3-21.			 
								          (Expected time: 15 min)

Figure 3-21  Sketch for Tutorial 1

	 The following steps are required to complete this tutorial:

a.	 Start PTC Creo Parametric.
b.	 Set the working directory and create a new object file.
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c.	 Import the section by using the File System button, refer to Figure 3-22.
d.	 Draw the keyway and dimension it, refer to Figures 3-23 and 3-24.
e.	 Modify the dimensions, refer to Figure 3-25.
f.	 Save the sketch and exit the sketcher environment.

  Starting PTC Creo Parametric
1.	 Start PTC Creo Parametric by double-clicking on the PTC Creo Parametric icon on the 

desktop of your computer.

Setting the Working Directory
	 When the PTC Creo Parametric session starts, the first task is to set the working directory. 

As mentioned earlier, working directory is a directory on your system where you can save 
the work done in the current session of PTC Creo Parametric. You can set any existing 
directory on your system as the working directory. Since this is the first tutorial of this 
chapter, you need to create a folder named c03 in the C:\Creo-3.0 folder.

1.	 Choose Manage Session > Select Working Directory option from the File menu; the 
Select Working Directory dialog box is displayed. 

2.	 Select C:>Creo-3.0. If this folder does not exist, then first create it and then set the working 
directory. Alternatively, you can use the Folder Tree available on the bottom left corner 
of the screen to set the working directory. To do so, click on the Folder Tree node; the 
Folder Tree will expand. In the Folder Tree, browse to the desired location using the nodes 
corresponding to the folders and select the required folder. After selecting the folder, the 
Folder Content window will be displayed. Close this window and the selected folder will 
become your current working directory.

3.	 Choose the Organize button from the Select Working Directory dialog box or right-click 
in this dialog box to display a shortcut menu. From the shortcut menu, choose the New 
Folder option; the New Folder dialog box is displayed.

4.	 Enter c03 in the New Directory edit box of the New Folder dialog box and then choose 
OK; a folder with the name c03 is created at C:\Creo-3.0.

5.	 Choose OK from the Select Working Directory dialog box; C:\Creo-3.0\c03 is set as the 
working directory.

Starting a New Object File 
1.	 Choose the New button from the Data group; the New dialog box is displayed. Select the 

Sketch radio button from the Type area of the New dialog box; the default name of the 
sketch appears in the Name edit box.

2.	 Enter c03tut1 in the Name edit box and choose the OK button.
 
	 You are in the sketcher environment of the Sketch mode. When you enter the sketcher 

environment, the Navigator is displayed on the left of the graphics window. Slide-in the 
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Navigator by clicking on the sash present on its right edge. Now, the drawing area is 
increased.

Importing the Section
1.	 Choose Get Data > File System from the Ribbon; the Open dialog box is displayed with 

the working directory as the current directory.

2.	 Click on the black arrow beside the Creo-3.0 option in the address bar and choose c02 
from the flyout displayed. Make sure the Sketch (*.sec) option is selected in the Type 
drop-down list. Select c02tut3.sec and choose the Open button from the Open dialog 
box.

3.	 Move the cursor in the drawing area. Notice that the cursor is attached with a plus mark. 
Now, click anywhere in the drawing area to place the sketch. The sketch is displayed in 
the drawing area and the Import Section tab is displayed in the Ribbon. 

4.	 Enter 1 as a scale factor in the respective edit box and choose the Done button to complete 
importing the sketch. 

5.	 Choose the Refit button from the Graphics toolbar. The sketch, similar to the one shown 
in Figure 3-22, is displayed in the drawing area.

Figure 3-22  Sketch imported and placed in the current file

Drawing the Keyway
	 To create the keyway, you need to sketch a small rectangle and then remove the portion 

of the circle that lies between the rectangle.

1.	 Choose the Line Chain tool from Line drop-down in the Sketching group.  

2.	 Draw the keyway, as shown in Figure 3-23; the weak dimensions and constraints are 
automatically applied to the sketch of the keyway.
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	 The horizontal lines of the keyway and the circle intersect at the points where the lines 
meet the circle. The portion of the circle that lies between the two horizontal lines of the 
keyway needs to be deleted from the circle.

3.	 Choose the Zoom In button from the Orientation group of the View tab; the  
cursor is converted into a magnifying glass symbol.

4.	 Draw a window around the keyway to zoom in it. Now, the display of the keyway is 
enlarged.

5.	 Choose the Delete Segment tool from the Editing group.		     

6.	 Click to select the part of the circle that lies between the two horizontal lines; the selected 
part is deleted.

7.	 Choose the Refit button from the Graphics toolbar to view the full sketch.	    

Dimensioning the Keyway
	 Now, you need to apply dimensions to the keyway.

1.	 Choose the Normal tool from the Dimension group.			     

2.	 Dimension the keyway, as shown in Figure 3-24.

Figure 3-24  Sketch after dimensioning the       
keyway

Figure 3-23  Sketch of the keyway with weak 
dimensions and constraints

Modifying the Dimensions
	 The dimensions of the keyway need to be modified as per the given dimension values.
 
1.	 Select the three dimensions of the keyway by pressing CTRL+left mouse button.

2.	 Choose the Modify tool from the Editing group; the Modify Dimensions dialog 
box is displayed.
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3.	 Clear the Regenerate check box and then modify the dimensions of the keyway. When 
you clear the check box, the sketch does not regenerate as you modify the dimensions.

	 The dimension that you edit in the Modify Dimensions dialog box gets enclosed in a blue 
box in the sketch.

4.	 Modify all dimensions. Refer to Figure 3-21 for dimension values.

5.	 After the dimensions are modified, choose the Regenerate the section and close 
the dialog button from the Modify Dimensions dialog box; the message Dimension 
modifications successfully completed is displayed in the message area.

	 The sketch after modifying the dimension values of the sketch is shown in Figure 3-25.

Figure 3-25  Sketch after modifying the dimensions

Saving the Sketch
	 As you may need the sketch later, you must save it.

1.	 Choose the Save button from the File menu; the Save Object dialog box is displayed  
with the name of the sketch entered earlier. 

2.	 Choose the OK button; the sketch is saved.

3.	 After saving the sketch, choose the Close button from the Quick Access toolbar to exit 
the Sketch mode.

Tutorial 2

In this tutorial, you will draw the sketch for the model shown in Figure 3-26. The sketch is 
shown in Figure 3-27.						          (Expected time: 30 min)
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Figure 3-27  Sketch of the modelFigure 3-26  Model for Tutorial 2

	 The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new object file.
b.	 Draw the sketch using sketcher tools, refer to Figures 3-28 and 3-29.
c.	 Apply the required constraints and dimensions to the sketched entities, refer to 

Figure 3-32.
d.	 Modify the dimensions of the sketch, refer to Figure 3-33.
e.	 Save the sketch and exit the Sketch mode.

Setting the Working Directory
	 The working directory was selected in Tutorial 1, and therefore there is no need to select 

the working directory again. But if a new session of PTC Creo Parametric is started, then 
you need to set the working directory again by following the steps given next.

1.	 Open the Navigator by choosing the Show Navigator button on the bottom left 
corner of the PTC Creo Parametric screen; the Navigator slides out. In the 
Navigator, the Folder Tree is displayed at the bottom. Click on the black arrow, 
which is available on the right of the Folder Tree; the Folder Tree expands.

2.	 Click on the node adjacent to the Creo-3.0 folder in the Navigator; the contents of the 
Creo-3.0 folder are displayed.

3.	 Now, right-click on the c03 folder to display a shortcut menu. From this shortcut menu, 
choose the Set Working Directory option; c03 is set as the working directory.

4.	 Close the Navigator by clicking the sash on the right edge of the Navigator; the Navigator 
slides in.

Starting a New Object File
1.	 Start a new object file in the Sketch mode. Name the file as c03tut2.
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Drawing the Sketch
	 To draw the outer loop, you need to draw three circles and then draw lines tangent to 

them. 

1.	 Choose the Center and Point tool from the Circle drop-down. Draw the circles 
in a horizontal line, as shown in Figure 3-28. 

2.	 Choose the Line Tangent tool from the Line drop-down in the Sketching 
group.

3.	 Select the left and middle circles on their respective top points; a tangent is drawn from 
the top of the left circle to the top of the middle circle. 

4.	 Next, select the right and middle circles on their respective top points; a tangent is drawn 
from the top of the right circle to the top of the middle circle.

5.	 Similarly, using the Line Tangent tool, draw the other tangents through the bottom-most 
points of the left, middle, and right circles, as shown in Figure 3-29.

Figure 3-29  Tangent lines drawn on the 
circles 

Figure 3-28  Three circles with weak 
dimensions and constraints

Trimming the Circles
	 The inner portions of the circles are not required. Therefore, you need to trim them.

1.	 Choose the Delete Segment tool from the Editing group.			      

2.	 Move the cursor close to the right portion of the left circle; the right part of the circle 
turns green in color. Next, click on it to delete it.

3.	 Similarly, trim the parts of the middle and right circles that are not required. The sketch 
after trimming the circles is shown in Figure 3-30.
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Drawing the Circles
1.	 Choose the Concentric tool from the Circle drop-down in the Sketching group; you are 

prompted to select an arc.

2.	 Click on the left arc and move the mouse; a circle appears. Select a point inside the sketch 
to complete the circle. Press the middle mouse button.

Tip: While drawing a concentric circle, sometimes the circle snaps to the other circle or 
arc and it becomes difficult to draw a circle of the size you need. In such a case, you can 
disable the snapping of the circle to the other circle or arc. To do so, hold the SHIFT 
key to disable the snapping or to disable the equal radii constraint that the system tends 
to apply while drawing the circle.

Note
You may need to zoom in drawing to select the top arc in the next step.

3.	 Click on the top arc and move the mouse; a circle appears. Select a point inside the sketch 
to complete the circle. Press the middle mouse button to end the creation of circle. 

4.	 Click on the right arc and move the mouse; a circle appears. Select a point inside the sketch 
to complete the circle. Press the middle mouse button to end the creation of circle.

	 The sketch after drawing all three circles is shown in Figure 3-31.

Figure 3-31  Sketch after drawing all three circlesFigure 3-30  Sketch after trimming the circles

Applying the Constraints 	
1.	 Choose the Equal tool from the Constrain group. 			                

2.	 Select the left arc and then select the right arc to apply the equal radius constraint.

3.	 Select the left circle and the right circle to apply the equal radius constraint.
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4.	 Choose the Parallel tool from the Constrain group.		    	    

5.	 Click to select the tangent line that connects the left arc and the middle arc at the top and 
then click to select the tangent line that connects the right arc and the middle arc at the 
bottom. It is evident from the parallel constraint symbol that the parallel constraint has 
been applied to the two tangent lines in the sketch.

	
Dimensioning the Sketch
	 PTC Creo Parametric applies weak dimensions to the sketch automatically. These 

dimensions are not the needed dimensions because these dimensions do not help in 
machining the model. Therefore, you need to dimension the sketch with the dimensions 
that will be used to machine the model. To do so, follow the steps given next.

1.	 Choose the Normal tool from the Dimension group. 			      

2.	 Select the center of the right and left circles; the centers of the circles turn black in color. 
Now, using the middle mouse button, place the dimension below the sketch. The sketch 
after applying constraints is shown in Figure 3-32.

	 The rest of the weak dimensions are the needed dimensions.

Modifying the Dimensions
	 All constraints and dimensions have been applied to the sketch. Now, you need to  

modify the dimensions.

1.	 Select all dimensions using the CTRL+ALT+A keys.

2.	 Choose the Modify tool from the Editing group; the Modify Dimensions dialog 
box is displayed.

3.	 Clear the Regenerate check box and then modify the values of the dimensions, refer to 
Figure 3-27 for dimension values. 

	 When you clear the check box, the sketch does not regenerate while modifying the 
dimensions. The dimension that you edit in the Modify Dimensions dialog box is enclosed 
in a blue box in the sketch.

4.	 After the dimensions are modified, choose the OK (Regenerate the section and close 
the dialog) button from the Modify Dimensions dialog box; the message Dimension 
modifications successfully completed is displayed in the message area.

	 The sketch after modifying the dimension values is shown in Figure 3-33.
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Figure 3-32  Sketch with constraints Figure 3-33  Sketch after modifying the dimensions

Saving the Sketch
1.	 Choose the Save button from the File menu and save the sketch.

Exiting the Sketch Mode
1.	 Choose the Close button from the Quick Access toolbar to exit the Sketch.

 

Tutorial 3
In this tutorial, you will draw the sketch of the model shown in Figure 3-34. The sketch is 
shown in Figure 3-35.						         (Expected time: 30 min)

Figure 3-35  Sketch of the modelFigure 3-34  Model for Tutorial 3

	

The following steps are required to complete this tutorial:

a.	 Set the working directory and create a new object file.
b.	 Draw the sketch using sketcher tools, refer to Figures 3-36 and 3-37.
c.	 Apply fillets at two corners of the sketch, refer to Figures 3-38 and 3-39.
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d.   	Dimension the sketch, refer to Figure 3-40.
e.	 Modify dimensions of the sketch, refer to Figure 3-41.
f.	 Save the sketch and exit the Sketch mode.

Setting the Working Directory
	 The working directory was selected in Tutorial 1, and therefore there is no need to select 

the working directory again. But if a new session of PTC Creo Parametric start, then you 
have to set the working directory again by following the steps given next.

1.	 Open the Navigator by clicking on the sash in the left edge of the PTC Creo Parametric 
window; the Navigator slides out. In the Navigator, the Folder Tree is displayed at the 
bottom. Click on the black arrow that is available at the right-side of the Folder Tree; to 
expand it.

2.	 Click on the node adjacent to the Creo-3.0 folder in the Navigator to display the content of 
this folder.

3.	 Now, right-click on the c03 folder to display a shortcut menu. From this shortcut menu, 
choose the Set Working Directory option; c03 is set as the working directory.

4.	 Close the Navigator by clicking on the sash on the right edge of the Navigator; the 
Navigator slides in.

Starting a New Object File
1.	 Start a new object file in the Sketch mode. Name the file as c03tut3.

Drawing the Sketch
1.	 Choose the Line Chain tool from the Line drop-down of the Sketching group.

2.	 Draw the lines with constraints, as shown in Figure 3-36.

3.	 Choose the 3-Point / Tangent End tool from the Arc drop-down available in the 
Sketching group.

4.	 Select the endpoint of the left vertical line as the start point of the arc. Complete the arc 
at the endpoint of the right vertical line.

5.	 Choose the Concentric tool from the Circle drop-down available in the Sketching 
group; you are prompted to select an arc. 

6.	 Click on the arc; a rubber-band circle appears. Size the circle by moving the 
cursor and click to complete it. The sketch after drawing the circle is shown in 
Figure 3-37.
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Figure 3-37  Sketch after drawing the arc 
and the circle

Figure 3-36  Lines in the sketch with the 
dimensions turned off for clarity

Note
1. Choose the Disp Dims button from the Display group in the View tab to turn the dimensions 
on or off.

2. PTC Creo Parametric does not have the options like midpoint, endpoint, or center of an 
arc or a circle. However, while drawing a sketch, these options are applied in the form of weak 
constraints. For example, while drawing an entity, the endpoint of the entity snaps to the cursor. 
The middle point constraint appears when you bring the cursor near to the middle point of the 
line to draw another line.

Filleting the Corners
1.	 Choose the Circular Trim option from the Fillet drop-down in the Sketching 

group; you are prompted to select the two entities to be filleted. The corners that 
you need to fillet are shown in Figure 3-38.

2.	 Select the two entities one by one using the left mouse button to fillet the corners of these 
entities.

	 The sketch after creating the fillets is shown in Figure 3-39.

Figure 3-39  Sketch after creating filletsFigure 3-38  Corners to be filleted
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Applying the Constraints
1.	 Choose the Equal tool from the Constrain group.

2.	 Click to select the fillets and apply the equal constraint to all fillets.

Dimensioning the Sketch
	 The weak dimensions are applied to the sketch automatically. These are not the required 

dimensions and therefore, you need to dimension the sketch manually.

1.	 Choose the Normal tool from the Dimension group.

2.	 Dimension the sketch, as shown in Figure 3-40.

Modifying the Dimensions
	 You need to modify the dimension values that are assigned to the sketch.

1.	 Select all dimensions using CTRL+ALT+A.

2.	 Choose the Modify tool from the Editing group; the Modify Dimensions dialog box is 
displayed.

3.	 Clear the Regenerate check box and then modify the values of the dimensions. If this 
check box is cleared, the sketch does not regenerate while modifying the dimensions.

	 The dimension that you edit in the Modify Dimensions dialog box is enclosed in a blue 
box in the sketch.

4.	 Modify all dimensions. Refer to Figure 3-35 for dimension values.

5.	 Choose the OK (Regenerate the section and close the dialog) button from the Modify 
Dimensions) dialog box. 

	 The sketch after modifying the dimension values is shown in Figure 3-41.

Saving the Sketch
1.	 Choose the Save button from the File menu and save the sketch.

Exiting the Sketch Mode
1.	 Choose the Close button from the Quick Access toolbar to exit the Sketch mode.
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Figure 3-41  Sketch after modifying the dimensionsFigure 3-40  Sketch after dimensioning

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The __________ dialog box is used to modify dimensions.

2.	 The display of dimensions and constraints can be turned on/off by choosing the __________ 
and __________ buttons respectively from the Display group.

3.	 The __________ tool is used to rotate selected entities.

4.	 You can delete entities by selecting them and then using the __________ key on the 
keyboard.

5.	 The shape of a spline can be modified dynamically. (T/F)

6.	 You can increase the length of the spline by adding points before the start point and after 
the endpoint of the spline. (T/F)

7.	 While copying the sketched entities, the Paste tab is also displayed. (T/F)

8.	 When you modify a weak dimension, it becomes strong. (T/F)

9.	 You can dimension the length of a centerline. (T/F)

10.	 The font of the text written in the sketcher environment cannot be modified. (T/F)
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Review Questions
Answer the following questions:

1.	 How many handles are displayed in the graphics window while rotating and resizing 
entities?

		  (a) one			               	(b) two
		  (c) three			   (d) four

2.	 Which of the following mouse buttons is used to place the dimension?

		  (a) left			   	 (b) middle
		  (c) right		 		  (d) mouse is not used for dimensioning

3.	 Which of the following is the default font for the text in the sketcher environment?

		  (a) font				    (b) filled
		  (c) font3d			   (d) isofont 

4.	 Which of the following groups is used to toggle the display of dimensions and constraints 
in the sketcher environment?

		  (a) Sketching			   (b) Constrain
		  (c) Display	 		  (d) Dimension

5.	 In which type of dimensioning, the Dim Orientation dialog box is displayed while 
dimensioning the arcs and circles?

		  (a) Normal		  	 (b) Perimeter
		  (c) Baseline			   (d) None of the above

6.	 For placing a section in a new sketch, you can use the right mouse button. (T/F)

7.	 You can create elliptical fillets in PTC Creo Parametric. (T/F)

8.	 While creating text in the sketcher environment, you need to draw a construction line that 
will define the height of the text. (T/F)

9.	 You can modify the dimensions dynamically. (T/F)

10.	 You can modify a spline by moving its interpolation points. (T/F)
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Exercises

Exercise 1

In this exercise, you will draw the sketch of the model shown in Figure 3-42. The sketch to be 
drawn is shown in Figure 3-43.					     (Expected time: 30 min)

Figure 3-43  Sketch of the modelFigure 3-42  Solid model for Exercise 1

Exercise 2
In this exercise, you will draw the sketch of the model shown in Figure 3-44. The sketch to be 
drawn is shown in Figure 3-45.					     (Expected time: 15 min)

Figure 3-45  Sketch of the modelFigure 3-44  Solid model for Exercise 2
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Exercise 3
In this exercise, you will draw the sketch of the model shown in Figure 3-46. The sketch to be 
drawn is shown in Figure 3-47.					       (Expected time: 30 min)

Figure 3-47  Sketch of the modelFigure 3-46  Solid model for Exercise 3

Answers to Self-Evaluation Test
1. Modify Dimensions, 2. Disp Dims, Disp Constr, 3. Rotate Resize, 4. DELETE, 5. T, 6. F, 
7. T, 8. T, 9. F, 10. F


