
Chapter 2

 Working with Splines

 Learning Objectives 
After completing this chapter, you will be able to:
• Work with spline primitives
• Understand spline modeling techniques
• Create geometries using Generators
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INTRODUCTION
In computer graphics, a spline is a line formed by connecting a sequence of vertices lying 
in 3D space. Although, it is formed in 3D space, it has no depth. A spline is not visible on 
rendering. You can create complete parametric spline primitives (with pre-defined shapes) as 
well as empty splines whose shapes can be defined interactively in the viewport. You can use 
splines to create complex geometries using Generator objects in CINEMA 4D. Generators 
are CINEMA 4D’s most powerful modeling tools. 

TUTORIALS
Before you start tutorials of this chapter, you need to download the c02_cinema4d_r16_tut.zip 
file from www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual 
Effects > MAXON CINEMA 4D > MAXON CINEMA 4D R16 Studio: A Tutorial Approach

Next, you need to extract the contents of the zip file. To do so, navigate to the Documents folder 
and create a new folder in it with the name c4dr16. Next, you need to browse to \Documents\
c4dr16 and create a new folder in it with the name c02. Then, extract the contents of the zip 
file in this folder.

 Tutorial 1                                                                             
In this tutorial, you will create the 3D model of a door lock system with the help of splines 
and Generators. The final output of the model is shown in Figure 2-1.	   
								              (Expected time: 35 min)

Figure 2-1  The model of door lock system

The following steps are required to complete this tutorial:

a.	 Set the viewport background.
b.	 Create the base of the door lock system.
c.	 Create the key hole.
d.	 Create the handle. 
e. 	 Change the background color of the scene.  
f.   	Save and render the scene. 
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Setting the Viewport Background
In this section, you will set the background image in the Front viewport.

1.	 Choose File > New from the main menu; a new scene is displayed.

2. 	 Press the middle mouse button in the Perspective viewport; all viewports are displayed. 
Next, hover the cursor over the Front viewport and then press MMB to maximize it. 
Alternatively, choose Cameras > Front from the Menu in editor view, as shown in 
Figure 2-2; the Front viewport is maximized.  

3. 	 Choose Options > Configure from the Menu in editor view, as shown in Figure 2-3; the 
Viewport [Front] settings are displayed in the Attribute Manager. In the Attribute Manager, 
choose the Back button; the Back area is displayed. In this area, choose the browse button 
next to the Image text box, as shown in Figure 2-4; the Open File dialog box is displayed. 
Browse to \Documents\c4dr16\c02\keyhole.jpg. Next, choose the Open button; the keyhole.jpg 
is opened as the background image in the Front viewport.

Figure 2-2 Choosing the Front option from the 
Menu in editor view

Figure 2-3  Choosing the 
Configure option from 
the Menu in editor view

4.	 In the Back area, clear the Keep Aspect Ratio check box and then set the parameters as 
follows:

	
	 Offset X: 122		  Offset Y: 2                  Size X: 445		        		

Size Y: 500

	 The Configure option available in the Options menu of the Menu in editor view is used 
to edit the settings of the respective viewport. It applies to all viewports. The options in 
the Back area are used to place the reference image at the desired location as the viewport 
background. The Image text box displays the location of the loaded file. Any image with 
a recognizable format can be loaded in CINEMA 4D.
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	 The Offset X option is used to move the reference image horizontally.		
	
	 The Offset Y option is used to move the reference image vertically. The Size X and Size Y 

options are used to scale the reference image.

Figure 2-4  Choosing the browse button next to the Image text box

 

Creating the Base of the Door Lock System
In this section, you will create the base of the door lock system using the Rectangle tool. 

1. 	 Press F1; the Perspective viewport is maximized. Alternatively, choose 

Figure 2-5  Choosing 
Rectangle from the 
Create menu

Cameras > Perspective from the Menu in editor view, refer to 
Figure 2-2. Choose Create > Spline from the main menu; a cascading 
menu is displayed. Next, choose Rectangle from it, as shown in 
Figure 2-5; a rectangle is created in the Perspective viewport. Also, 
Rectangle is added to the Object Manager.

Note
The spline primitives are parametric in nature as their attributes such 
as height, radius, and so on can be altered in the Attribute Manager.

2.	 Make sure that Rectangle is selected in the Object Manager. In the 
Attribute Manager, make sure the Object button is chosen and then 
enter 121 and 465 in the Width and Height spinners, respectively, 
of the Object Properties area, refer to Figure 2-6.	

	 By default, the value of these parameters is set to 400. As a result, 
a square is created in the viewport.	

	 Next, you will extrude the rectangle.
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Figure 2-6  Setting the width and height of the rectangle

Note
You can change the units of parametric objects. To do so, choose Mode > Project in the Attribute 
Manager; the Project area is displayed in the Attribute Manager. Make sure the Project Settings 
button is chosen in this area. In the Project Settings area, by default Centimeters is selected 
in the drop-down list located next to the Project Scale spinner. You can select any other unit 
from the drop-down list as per your requirement.

3.	 Press and hold the left mouse button on the Subdivision Surface tool in the Command 
Palette; a flyout is displayed. Next, choose the Extrude tool from it, as shown in Figure 2-7; 
Extrude is added to the Object Manager, refer to Figure 2-8.

Figure 2-8  Extrude added to the Object 
Manager

Figure 2-7  Choosing Extrude from the flyout

4.	 Select the Rectangle in the Object Manager. Press and hold the left mouse button on 
Rectangle and drag the cursor to Extrude in the Object Manager; the Rectangle is connected 
to Extrude in the Object Manager. Also, Rectangle is extruded in the Perspective viewport, 
as shown in Figure 2-9.

	 On pressing and holding the left mouse button on Subdivision Surface, a flyout is displayed 
with various tools. You can use these tools to create complex models with relatively less 
number of control points. Models created using these tools can be converted into polygons. 
The Extrude tool is used to extrude the spline in any direction. The effect of this tool is 
only visible when the spline is connected to the Extrude object.
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Figure 2-9 Rectangle extruded in 
the Perspective viewport

Figure 2-10  Choosing B-Spline 
from the main menu

Creating the Keyhole
In this section, you will create a keyhole using the B-Spline tool.

1.	 Press F4; the Front viewport is maximized. 
Choose Create > Spline from the main menu; 
a cascading menu is displayed. Now, choose 
B-Spline from it, as shown in Figure 2-10. 
Alternatively, press and hold the left mouse 
button on the Freehand tool in the Command 
Palette; a flyout is displayed. Choose B-Spline 
from the flyout; the shape of the cursor is 
changed, as shown in Figure 2-11.

2.	 In the Front viewport, draw the shape of the 
keyhole on the reference image, as shown in 
Figure 2-12. You will notice that Spline is also 
added to the Object Manager. 

3.	 Invoke the Move tool from the Command 
Palette and select the points of Spline. Next, edit the shape of Spline to give it the shape 
of a keyhole, as shown in the reference image, refer to Figure 2-12.

Figure 2-11  The changed shape of the cursor



Working with Splines	        2-7

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Figure 2-12  Shape of the keyhole

4.	 Select the Spline in the Object Manager. In the Attribute Manager, make sure that the 
Object button is chosen. In the Object Properties area, make sure the Close Spline check 
box is selected. Next, choose the Basic button; the Basic Properties area is displayed. In 
this area, enter keyhole in the Name text box; Spline is renamed as keyhole in the Object 
Manager, as shown in Figure 2-13. 

Note     
The spline also closes if you click on the first point of the spline.

Figure 2-13  Spline renamed as keyhole

5.	 Press F1; the Perspective viewport is maximized. Press and hold the left mouse button on 
the Subdivision Surface tool in the Command Palette; a flyout is displayed. Next, choose 
Extrude from it, as shown in Figure 2-14; Extrude.1 is added to the Object Manager. Next, 
drag keyhole on Extrude.1 in the Object Manager; keyhole is connected to Extrude.1.

 
6.	 Select Extrude.1 in the Object Manager. Next, choose the Object button in the Attribute 

Manager, if it is not already chosen; the Object Properties area is displayed. In this area, 
enter 40 in the Z spinner of the Movement parameter; the keyhole is extruded.
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7.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 
In this area, enter -5.409 in the P . Z spinner. Figure 2-15 displays keyhole extruded in the 
Perspective viewport.

Figure 2-15  keyhole extruded in the Perspective viewport

8.	 Press and hold the left mouse button on the Array tool in the Command Palette; a flyout 
is displayed. Next, choose Boole from the flyout, as shown in Figure 2-16; Boole is added 
to the Object Manager. Now, select Extrude.1 and drag the cursor to Boole; Extrude.1 is 
connected to Boole.

Figure 2-16  Choosing Boole from the flyout

9.	 In the Object Manager, select Extrude and press and hold the left mouse button; the shape 
of the cursor is changed. Next, drag Extrude on Boole; Extrude is connected to Boole, as 
shown in Figure 2-17. Also, keyhole is subtracted from Extrude and a hole is created in the 
Perspective viewport, as shown in Figure 2-18.

	 The Array tool is used to create duplicates of an object. You can also arrange the duplicates 
in a spherical or wave form. The wave can be animated using the Amplitude attribute of 



Working with Splines	        2-9

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

the Array tool. The Boole tool is used to subtract two or more objects to create a hole in 
the object. Mostly it is used to perform operations on splines and polygon primitives.

	
										        

Figure 2-17  Extrude connected to Boole

  Figure 2-18  The hole created in the Perspective viewport

Creating the Handle
In this section, you will create the handle of the door using the B-Spline tool.

1.	 Press F4; the Front viewport is maximized. Choose Create > Spline from the main menu; a 
cascading menu is displayed. Choose B-Spline from it; the shape of the cursor is changed. 
Alternatively, press and hold the left mouse button on the Freehand tool in the Command 
Palette; a flyout is displayed. Choose B-Spline from the flyout; the shape of the cursor is 
changed. 	

							     
	 The Freehand tool is used to draw free hand curves or splines in the viewport. The B-Spline 

tool is used to create smooth curves.
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2.	 In the Front viewport, draw the shape of the door handle on the reference image. You 
will notice that Spline is added to the Object Manager. Make sure that Close Spline check 
box is selected in the Object Properties area in the Attribute Manager.

3.	 In the Attribute Manager, choose the Basic button; the Basic

Figure 2-19  Handle placed 
in the viewport

Properties area is displayed. In this area, type Handle in the 
Name text box; the name of Spline changes to Handle in the 
Object Manager. 		

			 
	 Figure 2-19 displays Handle placed in the Front viewport.

4.	 Press F1; the Perspective viewport is maximized. Next, press 
and hold the left mouse button on the Subdivision Surface tool 
in the Command Palette; a flyout is displayed. Next, choose 
Extrude from it; Extrude is added to the Object Manager. 
Now, select Handle in the Object Manager and drag Handle to 
Extrude; the Handle is connected to Extrude and it is extruded 
in the Perspective viewport, as shown in Figure 2-20. 

Figure 2-20  Handle extruded in the Perspective viewport

5.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 
In this area, set the parameters as follows:

	
	 P . X: -30.7		  P . Y: 18.1 	     P . Z: -45 
	
	 P . X, P . Y, and P . Z parameters are used to specify the position values of X, Y, and Z 

axes. The S . X, S . Y, and S . Z  parameters are used to specify the scale values of X, Y, and 
Z axes. Similarly, the R . X, R . Y, and R . Z parameters are used to specify the rotational 
values of X, Y, and Z axes.	

	 Next, you will create the joint behind the handle and the base of the door.
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6.	 Press F2; the Top viewport is maximized. Next, choose Create > Spline from the main 
menu;  a cascading menu is displayed. Choose Circle from it, as shown in Figure 2-21; a 
circle is created in the Top viewport and Circle is added to the Object Manager.

7.	 Make sure that Circle is selected in the Object Manager. Next, in 

Figure 2-21 Choosing Circle 
from the main menu

the Attribute Manager, choose the Basic button. In the 
Basic Properties area, type Joint in the Name text box; 
Circle is renamed as Joint in the Attribute Manager. Next, 
choose the Coord button; the Coordinates area is displayed. 
In this area, set the parameters as follows:

	
	 P . Y: 81.591	        R . P: 90

8.	 Choose the Object button in the Attribute Manager; the 
Object Properties area is displayed. In this area, enter 20 
in the Radius spinner.

9.	 Press F1; the Perspective viewport is maximized. Make sure 
that Joint is selected in the Object Manager. Now, create 
a copy of Joint by pressing both the CTRL key and the 
left mouse button. Now, drag the cursor and release the 
left mouse button; a copy of Joint is created in the Object 
Manager with the name Joint.1.

10.	 Make sure that Joint.1 is selected in the Object Manager. 

Figure 2-22  The position of Joint and 
Joint.1 displayed in the Perspective 
viewport

In the Attribute Manager, make sure that the 
Coordinates area is displayed. In this area, enter 
-24.05 in the P . Z spinner. Figure 2-22 shows the 
position of Joint and Joint.1 in the Perspective 
viewport.

	 Next, you will create the surface of the joints.

11.	 Press and hold the left mouse button on the 
Subdivision Surface tool in the Command Palette; 
a flyout is displayed. Next, choose the Loft tool from 
it; Loft is added to the Object Manager. 

12.	 Press F5; all viewports are displayed. Select Joint and  
Joint.1 in the Object Manager by using the SHIFT 
key and then press and hold the left mouse button and drag the cursor on Loft; the Joint 
and Joint.1 are connected to the Loft in the Object Manager. Also, a surface is created. 
Figure 2-23 displays the surface in all viewports. 

	 Next, you will group the surfaces together.
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Figure 2-23  Joint and Joint.1 lofted to create a surface  

13.	 In the Object Manager, select Boole, Extrude, and Loft by using the SHIFT key. Next, 
choose Group Objects from Objects menu in the Object Manager, refer to Figure 2-24; 
all selected objects are grouped and Null is added to the Object Manager. Rename the 
Null as Door Lock by double-clicking its label in the Object Manager.

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1. 	 Choose Create > Environment from the main menu; a cascading menu is displayed. 
Choose the Background option from it, as shown in Figure 2-25.; Background is added to 
the Object Manager.

Figure 2-24  Choosing Group Objects 
from the Objects menu

Figure 2-25  Choosing the Background 
option from the main menu
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	 The Background option is used to change the background with the color or image which 
is only visible in the render view. 

	 Next, you will change the background color to white.

2.	 Make sure Background is selected in the Object Manager, as shown in Figure 2-26. In the 
Attribute Manager, choose the Basic button; the Basic Properties area is displayed. In 
this area, select On from the Use Color drop-down list. On doing so, the Display Color 
parameter is activated, as shown in Figure 2-27. By default, the white color is selected in 
this spinner. As a result, the background color changes to white.

Figure 2-27  The Display Color 
parameter activated

Figure 2-26  The Background Object 
selected in the Object Manager

	 The options in the Use Color drop-down list  are used to determine whether the selected 
objects in the viewport use the color assigned to them or not. You need to select the On 
option from the Use Color drop-down list to ensure that the display color is used even if 
the materials are applied to it.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the 
scene by downloading the file c02_cinema4d_r16_rndr.zip from www.cadcim.com. The path of 
the file is mentioned at the beginning of the chapter. 

1. 	 Choose File > Save from the main menu; the Save File dialog box is displayed. In this 
dialog box, browse to the location \Documents\c4dr16\c02.

2. 	 Enter c02tut1 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools 
located at the top right of the Perspective viewport. Next, choose the Render to Picture 
Viewer tool from the Command Palette. Alternatively, press SHIFT+R; the Picture Viewer 
window is displayed, as shown in Figure 2-28.

	 The Render to Picture Viewer tool is used to render the scene in the Picture Viewer 
window. The Picture Viewer window is also known as the output window in CINEMA 4D. 
It is used to view the output of the scene as well as to save it.

	 Next, you will save the rendered image.
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 Figure 2-28 The Picture Viewer window

4.	 In the Picture Viewer window, choose File > Save as, as shown in Figure 2-29; the Save  
dialog box is displayed, as shown in Figure 2-30.

Figure 2-29  Choosing the Save as option from the File menu

	 The Save as option is used to save a scene or an image sequence in the format based on 
your requirement. The Save dialog box is displayed with specific parameters which helps 
you in saving the still image or image sequence in an uncompressed format.

5.	 In the Save dialog box, choose the OK button; the Save Dialog dialog box is displayed. 
Next, browse to \Documents\c4dr16\c02. In the File Name text box, type c02_tut1_rndr. 
Next, choose the Save button; the rendered image is saved at the desired location.

	 The output of the model is shown in Figure 2-1. 
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Figure 2-30  The Save dialog box

 Tutorial 2                                                                             
In this tutorial, you will create a guitar with the help of the splines and Generators. The final 
output of the model is shown in Figure 2-31.			         (Expected time: 40 min)

The following steps are required to complete this tutorial:				  
	
a. 	 Set the viewport background.
b. 	 Create the body of the guitar.
c. 	 Create the neck of the guitar.  
d.  	Create the design on the body of the guitar.
e. 	 Create strings supports of the guitar.
f.  	 Create the strings of the guitar.
g.    Change the background color of the scene.	
h.	 Save and render the scene.    
				  
Setting the Viewport Background
In this section, you will set a background image in the Front viewport.

1. 	 Choose File > New from the main menu, a new scene is displayed. Press F4; the Front 
viewport is maximized.

2. 	 In the Front viewport, choose Options > Configure from the Menu in editor view; the 
Viewport [Front] settings are displayed in the Attribute Manager. In the Attribute Manager, 
make sure the Back button is chosen; the Back area is displayed. In this area, choose the 
browse button next to the Image text box; the Open File dialog box is displayed. Browse 
to \Documents\c4dr16\c02\frontGuitar.jpg. Next, choose the Open button; the frontGuitar.jpg 
is placed as the background image in the Front viewport.
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Creating the Body of the Guitar
In this section, you will create the body of the guitar by using 
the B-Spline tool. 

1. 	 Choose Create > Spline from the main menu; a cascading 
menu is displayed. Choose B-Spline from the cascading 
menu. 

2.	 Draw the body of the guitar on the reference image, in the 
Front viewport. Figure 2-32 displays the complete shape of 
the body of the guitar. In the Attribute Manager, make sure 
the Object button is chosen and in the Object Properties 
area, the Close Spline check box is selected. Next, press 
SPACEBAR to exit the B-Spline tool.

3.	 In the Front viewport, edit the points of Spline using the 
Move tool. 

Note
You can also add new points to an existing spline. To do so, 
right click on the spline; a shortcut menu is displayed. Next, 
choose the Create Point option from the shortcut menu and 
click on the spline to create new points.

4.	 Press  and hold the lef t  mouse button on the 
Subdivision Surface tool in the Command Palette; a flyout 
is displayed. Choose Extrude from it; Extrude is added to 
the Object Manager, as shown in Figure 2-33. 

 Figure 2-32  The shape of the body of guitar Figure 2-33  Extrude added to the Object 
Manager

5.	 Press F1; the Perspective viewport is maximized. In the Object Manager, select Spline and 
drag it to Extrude and release the left mouse button; Spline is connected to Extrude and it 
is extruded in the Perspective viewport. Figure 2-34 shows the extruded shape.

	 The X, Y, and Z spinners corresponding to the Movement parameter of the Extrude object 
are used to define the amount of extrusion along the X, Y, and Z axes, respectively.

Figure 2-31  The model of 
guitar



Working with Splines	        2-17

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Creating the Neck of the Guitar
In this section, you will model the neck of the guitar using the B-Spline tool.

1.	 Press F4; the Front viewport is maximized. Choose Create > Spline from the main menu; 
a cascading menu is displayed. Choose the B-Spline tool from the cascading menu and 
then draw the neck of the guitar, as shown in Figure 2-35. In the Attribute Manager, make 
sure that the Close Spline check box is selected in the Object Properties area. Next, press 
SPACEBAR to exit the tool. 

Figure 2-34  The extruded body of the guitar Figure 2-35  Spline for the neck of the 
guitar in the Front viewport

2.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Extrude from it; Extrude.1 is added to the Object Manager. Next, select Spline of 
the neck.

3.	 Press and hold the left mouse button and drag Spline on Extrude.1. Next, release the 
left mouse button; Spline is connected to Extrude.1 in the Object Manager, as shown in 
Figure 2-36. You can view the extruded shape of the neck in the Perspective viewport.

    

Figure 2-36  Spline connected to Extrude.1 in the Object Manager

Creating Design on the Body of the Guitar
In this section, you will create a design piece on the body of the guitar using the B-Spline 
tool and Extrude generator.

1.	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
B-Spline from it. Next, create a shape in the Front viewport, as shown in Figure 2-37.
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2.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Extrude from it; Extrude.2 is added to the Object Manager. Next, select Spline you 
have created in the step 1.

3.	 Press and hold the left mouse button and drag Spline on Extrude.2 and release the left 
mouse button; Spline is connected to Extrude.2 in the Object Manager.

4.	 Make sure Spline connected with Extrude.2 is selected in the Object Manager. Next, in 
the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In 
this area, enter -2 in the P . Z spinner. Figure 2-38 shows the extruded design part in the 
Perspective viewport.

Figure 2-37  The spline for the design piece Figure 2-38  The extruded design part

Creating Strings Supports of the Guitar
In this section, you will create blocks that will support the strings of the guitar using different 
splines and Extrude generator.

1. 	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
Rectangle from the cascading menu; Rectangle is added to the Object Manager.

2.	 In the Attribute Manager, choose the Object button and then enter 28 and 14 in the 
Width and Height spinners, respectively, Also, make sure XY is selected from the Plane 
drop-down list.

3.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 
In this area, set the parameters as follows:

	
	 P . X: 12.856		  P . Y: -111.854 	   		    P . Z: -4

4.	 Choose Display > Gouraud Shading (Lines) option from the Menu in editor view to 
properly view the guitar in the viewport.

5.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Extrude from it; Extrude.3 is added to the Object Manager. Next, select Rectangle 
you have created in the step 1.

6.	 Press and hold the left mouse button and drag Rectangle on Extrude.3 and release the left 
mouse button; Spline is connected to Extrude.3 in the Object Manager. Figure 2-39 shows 
the extruded rectangle in the Perspective viewport.
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7. 	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
Circle from the cascading menu; Circle is added to the Object Manager. 

8.	 In the Attribute Manager, choose the Object button and then enter 1 in the Radius 
spinner. Also, make sure XY is selected from the Plane drop-down list.

9.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 
In this area, set the parameters as follows:

	
	 P . X: 3.225			  P . Y: -108.137 	   		    P . Z: -6.103

10.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Extrude from it; Extrude.4 is added to the Object Manager. Next, select Circle 
which you created in step 7.

11.	 Press and hold the left mouse button and drag Circle on Extrude.4. Next, release the left 
mouse button; Circle is connected to Extrude.4 in the Object Manager. Figure 2-40 shows 
the extruded circle in the Perspective viewport.

Figure 2-39  The extruded Rectangle Figure 2-40  The extruded Circle

12.	 Make sure Extrude.4 is selected in the Object Manager. Next, press L to activate the Enable 
Axis tool in the Tools Palette and then reposition the axis at the center of Extrude.4. Next, 
press L again to deactivate the Enable Axis tool.

13.	 Make sure Extrude.4 is selected in the Object Manager. Next, choose Tools > Arrange 
Objects > Duplicate from the main menu; the Duplicate tool is activated and its attributes 
are displayed in the Attribute Manager.

14.	 In the Attribute Manager, choose the Duplicate button; the Duplicate area is displayed. 
In this area, enter 5 in the Copies spinner.  

15.	 In the Attribute Manager, choose the Options button; the Options area is displayed. In 
this area, select Linear from the Mode drop-down list. Next, enter 4 and 0 in the first 
two edit boxes corresponding to the Move parameter. Also a new node, Extrude.4_copies 
is created in the Object Manager.

16.	 In the Object Manager, select Extrude.4 and Extrude.4_copies and then press ALT+G to 
create a group; a group with the name Null is created in the Object Manager.
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17.	 Create a copy of Null by pressing the CTRL key and then dragging the cursor in the Object 
Manager. Next, align the new group as shown in Figure 2-41.

18.	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
B-Spline from it. Next, create a shape in the Front viewport, as shown in Figure 2-42.

Figure 2-41  Copies of Extrude.4 aligned Figure 2-42  The B-Spline shape displayed

19.	 Make sure Spline is selected in the Object Manager. Next, in the Attribute Manager, choose 
the Coord button; the Coordinates area is displayed. In this area, enter -4 in the P . Z 
spinner. 

20.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Extrude from it; Extrude.4 is added to the Object Manager. Next, select Spline 
that you have created in step 19.

21.	 Press and hold the left mouse button and drag Spline on Extrude.4 and release the left 
mouse button; Spline is connected to Extrude.4 in the Object Manager. Figure 2-43 shows 
the extruded geometry in the Perspective viewport.

22.	 Create a copy of Null and then align them with Extrude.4, as shown in Figure 2-44. 

Figure 2-43  The extruded spline Figure 2-44  Copies of Null aligned

23.	 Select Extrude.4 in the Object Manager and then reposition the axis to its center, as discussed 
earlier. In the Object Manager, select Extrude.4 and Null.2 and then create copies by CTRL 
dragging. Next, align the copies, as shown in Figure 2-45.

24.	 In the Object Manager, expand Null and then select Extrude.4. Press and hold CTRL and 
then drag the Extrude.4 to the empty area of the Object Manager. Similarly, create five 
copies of Extrude.4 and align them with the top part of the guitar, as shown in Figure 2-46. 
Next, collapse Null in the Object Manager.
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aligned

25. 	Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
Rectangle from the cascading menu; Rectangle is added to the Object Manager.

26.	 In the Attribute Manager, make sure the Object button is chosen and then enter 21 and 
1 in the Width and Height spinners, respectively. Also, make sure XY is selected from the 
Plane drop-down list.

27.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 
In this area, set the parameters as follows:

	
	 P . X: 9.72			   P . Y: -38.052  	   		    P . Z: -1.023

	 After entering the values, Rectangle is placed, as shown in Figure 2-47.

Figure 2-46  Copies of Extrude.4 aligned 
with top part of the guitar

Figure 2-47  The Rectangle aligned

28.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Extrude from it; Extrude.11 is added to the Object Manager. Next, select Rectangle.

29.	 Press and hold the left mouse button and drag Rectangle on Extrude.11 and release the 
left mouse button; Rectangle is connected to Extrude.11 in the Object Manager. 

30.	 Make sure Extrude.11 is selected in the Object Manager and Object button is chosen in 
the Attribute Manager. Next, enter 2 in the Z spinner corresponding to the Movement 
parameter. Figure 2-48 shows the extruded rectangle in the Perspective viewport.

31.	 Move the axis to the center of Extrude.11 using the Enable Axis tool, as discussed earlier.
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32.	 Create twenty copies of Extrude.11 and then place them, as shown in Figure 2-49. Use the 
Scale tool to adjust the size of the copies.

Figure 2-48  The extruded rectangle Figure 2-49  Copies of Extrude.6 placed 
and aligned

Creating the Strings of the Guitar
In this section, you will create the strings of the guitar by using the B-Spline tool and Sweep 
generator.

1.	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
B-Spline from it. Next, create a shape in the Front viewport, as shown in Figure 2-50. 
Figure 2-51 shows the shape in the Perspective viewport.

Figure 2-50  The spline shape displayed in 
the Front viewport

Figure 2-51  The spline shape displayed in 
the Perspective viewport

2.	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
Circle from it; Circle is added to the Object Manager.

3.	 Make sure the Object button is chosen in the Attribute Manager and then enter 0.3 in 
the Radius spinner.

4.	 Press and hold the left mouse button on the Subdivision Surface tool; a flyout is displayed. 
Choose Sweep from it; Sweep is added to the Object Manager.

5.	 In the Object Manager, select Circle and Spline. Next, press and hold the left mouse button 
and drag the selected objects on Sweep and release the left mouse button; selected objects 
are connected to Sweep in the Object Manager, as shown in Figure 2-52.

Figure 2-52  The Circle and Spline objects connected to Sweep
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6.	 Create five copies of Sweep and align them, as shown in Figure 2-53. Figure 2-54 shows 
the strings in the Perspective viewport. You need to adjust the points of the splines using 
the Move and Scale tools to align strings with the knobs of the top part of the guitar.

Figure 2-53  The copies of the Sweep displayed 
in the Front viewport

Figure 2-54  The copies of the Sweep displayed 
in the Perspective viewport

Changing the Background Color of the Scene
In this section, you will set the background color.

1. 	 Choose Create > Environment from the main menu; a cascading menu is displayed. 
Choose the Background option from the menu; Background is added to the Object Manager.

	 Next, you will change the background color to white.

2.	 Make sure that Background is selected in the Object Manager; the Background Object 
[Background] settings are displayed in the Attribute Manager. Choose the Basic button, 
if it not already chosen; the Basic Properties area is displayed. In this area, select 
the On option from the Use Color drop-down list; the Display Color parameter is 
activated. Make sure the white color is set for the this parameter.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the 
scene by downloading the file c02_cinema4d_r16_rndr.zip from www.cadcim.com. The path of 
the file is mentioned at the beginning of the chapter. 

1. 	 Choose File > Save from the main menu; the Save File dialog box is displayed. In this 
dialog box, browse to the location \Documents\c4dr16\c02.

2. 	 Enter c02tut2 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools. 
Next, choose the Render to Picture Viewer tool from the Command Palette. Alternatively, 
press SHIFT+R; the Picture Viewer window is displayed, as shown in Figure 2-55.

4.	 In the Picture Viewer window, choose File > Save as; the Save dialog box is displayed.

5.	 In the Save dialog box, choose the OK button; the Save Dialog dialog box is displayed. 
Next, browse to the \Documents\c4dr16\c02. In the File Name text box, type c02_tut2_rndr. 
Next, choose the Save button; the rendered image is saved at the desired location. The 
output of the model is shown in Figure 2-31.
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Figure 2-55  The Picture Viewer window

 Tutorial 3                                                                             
In this tutorial, you will create a hand bag with the help of splines and Generators. The final 
output of the model is shown in Figure 2-56.			        (Expected time: 25 min)

The following steps are required to complete this tutorial:

a.	 Create the shape of the hand bag.
b.	 Create the handles of the hand bag.
c.	 Create text on the hand bag.   
d.	 Change the background color of the scene.
e.	 Save and render the scene.

Creating the Shape of the Hand Bag
In this section, you will create the shape of the hand bag using the Spline tool.

1. 	 Choose File > New from the menu bar; a new scene is started. Next, choose Create > 
Spline from the main menu; a cascading menu is displayed. Choose Rectangle from the 
menu; a rectangle is created in the Perspective viewport and Rectangle is added to the 
Object Manager.

2.	 Make sure that Rectangle is selected in the Object Manager. In the Attribute Manager, 
choose the Object button; the Object Properties area is displayed. In this area, set the 
values of parameters as follows:

	
	 Width: 980			   Height: 340
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3.	 In the Object Properties area, select the Rounding 
check box and enter 55 in the Radius spinner. Next, 
select the XZ option from the Plane drop-down list.

4.	 In the Attribute Manager, choose the Coord button; 
the Coordinates area is displayed. In this area, set the 
parameters as follows:

	 P . X: 1.6			   P . Z: -4

	 After entering the values, Rectangle is placed in the 
Perspective viewport, as shown in Figure 2-57.

5.	 Make sure that Rectangle is selected in the Object 
anager. Press and hold the left mouse button and the CTRL key and then drag and drop 
the cursor in the empty space above it; the copy of Rectangle is created in the Perspective 
viewport and added to the Object Manager with the name Rectangle.1, as shown in 
Figure 2-58.

Figure 2-57  Rectangle placed in the 
Perspective viewport

Figure 2-58  Rectangle.1 added to the Object 
Manager

6.	 Make sure that Rectangle.1 is selected in the Object Manager. In the Attribute Manager, make 
sure that the Object button is chosen. In the Object Properties area, set the parameters 
as follows:

	 Width: 730			   Height: 129
7.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 

In this area, enter 286.8 in the P . Y spinner.

  	 After entering the values, Rectangle.1 is placed in the Perspective viewport, as shown in 
Figure 2-59.

Figure 2-56  Model of a hand bag
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8.	 Make sure that Rectangle.1 is selected in the Object Manager. 

Figure 2-59  Rectangle.1 placed in 
the Perspective viewport

Press and hold the left mouse button and the CTRL 
key and then drag and drop the cursor in the empty 
space; the copy of the Rectangle.1 is created and 
added to the Object Manager with the name 
Rectangle.2, as shown in Figure 2-60.

9.	 Make sure that Rectangle.2 is selected in the Object 
Manager. In the Attribute Manager, make sure that 
the Object button is chosen. In the Object Properties 
area, set the parameters as follows:

	 Width: 815			   Height: 165

	 Make sure that the Rounding check box is selected 
and enter 82.5 in Radius spinner.

  Figure 2-60  Rectangle.2 added to the Object Manager

10.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. In 
this area, enter -3.66 in the P . Y spinner. After entering the values, Rectangle.2 is placed 
in the Perspective viewport, as shown in Figure 2-61.

11.	 Make sure that Rectangle.2 is selected in the Object Manager. Next, press and hold the 
left mouse button and the CTRL key and then drag and drop the cursor in the empty 
space; the copy of Rectangle.2 is created and added to the Object Manager with the name 
Rectangle.3, as shown in Figure 2-62.

12.	 Make sure that Rectangle.3 is selected in the Object Manager. In the Attribute Manager, make 
sure that the Object button is chosen. In the Object Properties area, set the parameters 
as follows:

	 Width: 527			   Height: 55
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	 Clear the Rounding check box. 

Figure 2-61  Rectangle.2 placed in the Perspective viewport

13.	 In the Attribute Manager, choose the Coord button; the Coordinates area is displayed. 
In this area, set the parameters as follows:

	 P . X: -1.9			   P . Y: 647.4	
	
	 After entering the values, Rectangle.3 is placed in the Perspective viewport, as shown in 

Figure 2-63.

Figure 2-63  Rectangle.3 placed in 
the Perspective viewport

Figure 2-62  Rectangle.3 added to the Object 
Manager

14.	 Press and hold the left mouse button on the Subdivision Surface tool in the Command 
Palette; a flyout is displayed. Choose the Loft tool from the flyout, as shown in Figure 2-64; 
Loft is added to the Object Manager.
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15.	 In the Object Manager, select Rectangle.2. Next, drag and drop Rectangle.2 on Loft; 
Rectangle.2 is connected to Loft, as shown in Figure 2-65. Also, Rectangle.2 is lofted with a 
surface in the Perspective viewport.

Figure 2-64  Choosing Loft from the flyout

Figure 2-65  Rectangle.2 connected to Loft in the Object Manager

16.	 Connect Rectangle.1, Rectangle.3, and Rectangle to Loft in the Object Manager, as shown in 
Figure 2-66. The order of the rectangle should be the same, as shown in Figure 2-66. On 
doing so, a lofted surface resembling the shape of a hand bag is created in the Perspective 
viewport, as shown in Figure 2-67.

Figure 2-67  All Rectangles lofted in 
the Perspective viewport

Figure 2-66   Rectangle, Rectangle.1, and Rectangle.3 
connected to Loft
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Creating the Handles of the Hand Bag
In this section, you will create the handles of the bag using the Lathe tool.

1.	 Choose Create > Spline from the main menu; a cascading menu is displayed. Choose 
Circle from it; a circle is created in the Perspective viewport and Circle is added to the 
Object Manager.

2.	 Make sure Circle is selected in the Object Manager. In the Attributes Manager, make sure 
that the Object button is chosen. In the Object Properties area, enter 8 in the Radius 
spinner. Also, make sure that the XY option is selected in the Plane drop-down list. Next, 
choose the Coord button; the Coordinates area is displayed. In the Coordinates area, set 
the parameters as follows:

	 P . X: 242.63		  P . Y: 293.5		  P . Z: -110.8	        

3.	 Press and hold the left mouse button on the Subdivision Surface tool in the Command 
Palette; a flyout is displayed. Choose the Lathe tool from the flyout, as shown in Figure 2-68; 
Lathe is added to the Object Manager, refer to Figure 2-69. 

Figure 2-68  Choosing Lathe from the flyout

4.	 In the Object Manager, drag Circle and drop it on Lathe; Circle is connected to Lathe, as 
shown in Figure 2-69.

Figure 2-69  Circle connected to Lathe in the Object Manager

	 The Lathe tool is used to rotate the profile curve on the Y-axis of the local axis system of 
the shape. It is used to generate a revolved surface. 
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5.	 Select Lathe in the Object Manager. In the Attribute Manager, choose the Object button; 
the Object Properties area is displayed. In this area, enter 75 in the Subdivision spinner 
and 227 in the Angle spinner.

6.	 Choose the Coord button; the Coordinates area is displayed. In this area, set the parameters 
as follows:

	
	 P . X:  5.715		  P . Y: 634.142		  P . Z:  291.176       
	 S . X:  0.87			   S . Z: 1.62	   	 R . H: 90	    
	 R . P:  90	       		  R . B: -90

	 Figure 2-70 displays the hand bag with its handle. Next, you will create a copy of the 
handle.

7.	 Select Lathe in the Object Manager. Press and hold the left mouse button along with the 
CTRL key; the shape of the cursor is changed, as shown in Figure 2-71. Next, drag Lathe 
in the empty space above it and then release the left mouse button; a copy of Lathe is 
added with the name Lathe.1 to the Object Manager.

Figure 2-70   The handle of the 
hand bag created

Figure 2-71  The changed shape of the cursor 
in the Object Manager

8.	 Make sure that Lathe.1 is selected in the Object Manager and the Coord button is chosen 
in the Object Manager. In the Coordinates area of Attribute Manager, enter 282.25 in the 
P . Z spinner.

Creating Text on the Hand Bag
In this section, you will create text on the hand bag using the Extrude tool.

1.	 Press and hold the left mouse button on the Freehand tool in the Command Palette; a 
flyout is displayed. Choose the Text tool from the flyout; Text is created in the Perspective 
viewport and added to the Object Manager.
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2.	 Make sure that Text is selected in the Object Manager. In the Attribute Manager, choose 
the Object button. In the Object Properties area, set the parameters as follows:

	 Text: S&S	 		  Height: 274 		  Horizontal Spacing: 5	
	 Vertical Spacing: 11

	 The Text edit box in the Object Properties area is 
used to write the text in the viewport. You can also 
type multiple lines. The Height parameter is used to 
determine the height of the text written in the viewport. 
The Horizontal Spacing parameter is used to determine 
the horizontal spaces or gaps between the characters. 
The Vertical Spacing parameter is used to determine 
the vertical spaces or gaps between the characters.

3.	 In the Attribute Manager, choose the Coord button; 
the Coordinates area is displayed. In this area, set the 
parameters as given next:

	 P . X: -249.402		  P . Y: 354.604		
	 P . Z: -109.475		  R . P: -12

	 The text is placed in the Perspective viewport, as shown 
in Figure 2-72. Next, you will extrude the text.

4.	 Press and hold the left mouse button on the Subdivision Surface tool in the Command 
Palette; a flyout is displayed. Choose the Extrude tool from it; Extrude is added to the 
Object Manager. 

	
5.	 In the Object Manager, drag Text and drop it on Extrude; Text is connected to Extrude, as 

shown in Figure 2-73. Also, Text is extruded in the Perspective viewport, refer to Figure 2-74.

Figure 2-73  Text connected to Extrude in 
the Object Manager

Figure 2-74  The extruded text on the 
hand bag

Figure 2-72  The text placed in the 
Perspective viewport
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Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps 
given in Tutorial 1 of Chapter 2.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the 
scene by downloading the file c02_cinema4d_r16_rndr.zip from www.cadcim.com. The path of 
the file is mentioned at the beginning of the chapter. 

1. 	 Choose File > Save from the main menu; the Save File dialog box is displayed. In this 
dialog box, browse to the location \Documents\c4dr16\c02.

2. 	 Enter c02tut3 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools 
located on the extreme top right of the Perspective viewport. Next, you need to render 
the scene. For rendering, refer to Tutorial 1.

	
	 Figure 2-56 displays the final output.

Tutorial 4                                                                             
In this tutorial, you will create a cigar pipe with the help of splines and the Loft generator. 
The final output of the model is shown in Figure 2-75.		    (Expected time: 25 min)

Figure 2-75  The model of the cigar pipe

The following steps are required to complete this tutorial:

a.	 Set the viewport background.
b.	 Define the shape of the pipe.
c. 	 Create geometry of the pipe.
d.	 Change the background color of the scene.
e.	 Save and render the scene.
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Setting the Viewport Background
In this section, you will set a background image in the Front viewport.

1. 	 Choose File > New from the main menu, a new scene is displayed. Press F4; the Front 
viewport is maximized.

2. 	 In the Front viewport, choose Options > Configure from the Menu in editor view; the 
Viewport [Front] settings are displayed in the Attribute Manager. In the Attribute Manager, 
choose the Back button, if it is not already chosen; the Back area is displayed. In this 
area, choose the browse button next to the Image text box; the Open File dialog box is 
displayed. Browse to \Documents\c4dr16\c02\pipe.jpg. Next, choose the Open button; the 
pipe.jpg is placed as the background image in the Front viewport.

3.	 Enter 75 in the Transparency spinner.

Defining the Shape of the Pipe 
In this section, you will define the shape of the pipe using the Circle spline.

1.	 Choose Create > Spline > Circle from the main menu bar; Circle is displayed in the Front 
viewport.

2.	 Make sure Circle is selected in the Object Manager and the Object button is chosen in 
the Attribute Manager. In the Object Properties area of the Attribute Manager, select XZ 
from the Plane drop-down list.

3.	 In the Attribute Manager, select the Ellipse check box and then enter 7 and 27.846 in 
the Radius and Radius Y spinners, respectively.

4.	 Choose the Coord button and then specify the values for the following parameters:

	 P . X: 375.332		  P . Y: 168.154		  R . B: 89.613

	 After entering the values Circle is placed at the end of the pipe, as shown in Figure 2-76.

5.	 Double click on Circle in the Object Manager and rename the object as Ellipse. 

6.	 In the Object Manager, create a copy of Ellipse using CTRL; a duplicate copy of Ellipse is 
created with the name Ellipse.1.

7.	 Make sure Ellipse.1 is selected in the Object Manger. In the Attribute Manager, choose 
the Object button and then enter 8 and 24.818 in the Radius and Radius Y spinners, 
respectively.

8.	 In the Attribute Manager, choose the Coord button and then specify the following values 
for the following parameters:

	 P . X: 344.115		  P . Y: 167.142		  R . B: 89.613
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	 After entering the values Ellipse.1 is next to the Ellipse, as shown in Figure 2-77.

Figure 2-76  Ellipse displayed in the 
Front viewport

Figure 2-77  Ellipse.1 displayed in the 
Front viewport

9.	 Create a Circle spline as done in steps 1 through 2. In the Attribute Manager, make sure 
the Object button is chosen and then enter 18.477 in the Radius spinner. Choose the 
Coord button and then specify the values for the following parameters:

	 P . X: 313.585		  P . Y: 165.525		  R . B: 89.613		

	 After entering the values Circle is displayed in the Front viewport, as shown in Figure 2-78.

Figure 2-78  Circle displayed in the Front viewport

10.	 Create more copies of Circle and then use the values given in Table 2-1 to create the profile 
of the pipe:

Table 2-1  Values used for creating the profile of the pipe

Spline Radius P . X P . Y R . B

Circle.1 20.934 220.543 152.49 70.072

Circle.2 28.328 87.649 73.091 55.525

Circle.3 32.124 83.145 66.897 55.525

Circle.4 36.397 78.077 59.577 55.525

Circle.5 41.459 17.261 8.334 50.255
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Spline Radius P . X P . Y R . B

Circle.6 46.102 9.377 3.829 50.255

Circle.7 42.322 4.309 -2.365 50.255

Circle.8 49.721 -95.667 -82.505 57.328

Circle.9 86.573 -179.395 -115.462 111.91

Circle.10 117.524 -254.216 -66.472 149.363

Circle.11 90.684 -253.325 41.306 180.75

	 After entering the values the profile of the pipe is completed, as shown in Figure 2-79.

Figure 2-79  The profile of the pipe displayed
Creating Geometry of the Pipe
In this section, you will set create the shape of the pipe using the Loft generator.

1.	 Choose Create > Generator > Loft from the menu bar; Loft is displayed in the Object 
Manager.

2.	 Select Ellipse in the Object Manager and then press and hold down SHIFT. Next, click on 
Circle.11 to select all splines and then release SHIFT.

3.	 Press and hold the left mouse button and then drag the splines to Loft; all splines are 
connected to Loft, refer to Figure 2-80. Also, shape of the pipe is displayed in the scene, 
as shown in Figure 2-81.

4.	 Press F1 to activate the Perspective viewport.

5.	 Make sure Loft is selected in the Object Manager and then choose the Caps button in the 
Attribute Manager; the Caps and Rounding area is displayed. 
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Figure 2-80  The splines connected with Loft

Figure 2-81  The shape of the pipe displayed

6.	 In this area, select Fillet from the Start and End drop-downs. Next, select the Constrain 
check box. Select Half Circle from the Fillet Type drop-down. 

7.	 Enter 10 and 1 in the Steps and Radius spinners, respectively, corresponding to the Start 
drop-down. Similarly, enter 10 and 6 in the Steps and Radius spinners, respectively, 
corresponding to the End drop-down. After entering the values, the cigar pipe is displayed 
with the fillet caps, as shown in Figure 2-82.

	 Next, you will modify the end part of the pipe to maintain the flow of the geometry.

8.	 Select Circle in the Object Manager and then make sure the Object button is chosen in 
the Attribute Manager. Set the value 9.652 for the Radius parameter.



Working with Splines	        2-37

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Figure 2-82  The pipe with the fillet caps displayed

9.	 Select Ellipse in the Object Manager and make sure the Object button is chosen in the 
Attribute Manager. Next, set the values 1.757 and 12.231 for the Radius and Radius Y 
spinners, respectively. Similarly, set the values 4.178 and 12.962 for the Radius and Radius 
Y spinners, respectively, for Ellipse.1. After entering the values, the modified shape of the 
pipe is displayed, refer Figure 2-75.

Changing the Background Color of the Scene
To change the background color of the scene to white in the final output, follow the steps 
given in Tutorial 1.

Saving and Rendering the Scene
In this section, you will save and render the scene. You can also view the final render of the 
scene by downloading the file c02_cinema4d_r16_rndr.zip from www.cadcim.com. The path of 
the file is mentioned at the beginning of the chapter. 

1. 	 Choose File > Save from the main menu; the Save File dialog box is displayed. In this 
dialog box, browse to the location \Documents\c4dr16\c02.

2. 	 Enter c02tut4 in the File name text box and then choose the Save button.

3.	 In the Perspective viewport, set the camera angle using the Viewport Navigation Tools 
located on the extreme top right of the Perspective viewport. Next, you need to render 
the scene. For rendering, refer to Tutorial 1.

	
	 Figure 2-75 displays the final output.
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. 	 Which of the following tools is used to create complex models using relatively less number 
of control points?

		  (a) Freehand 			   (b) Subdivision Surface
  		  (c) Move	 		  (d) None of these

2.	 Which of the following tools is used to extrude a spline object or curve?

		  (a) Freehand 			   (b) Loft
  		  (c) Extrude	 		  (d) All of these

3.	 Which of the following combinations of shortcut keys is used to render a scene?	
	

		  (a) ALT+Q			   (b) CTRL+D
  		  (c) SHIFT+R			   (d) None of these

4.	 The __________ tool in the Command Palette is used to subtract two or more objects from 
an object to create a hole in that object. 

5.	 The __________ option in the Options menu is used to edit the settings of the respective 
viewport.

6.	 The Angle parameter in the __________  area of the Attribute Manager is used to define 
the angle of rotation of the B-Spline.

7.	 The Viewport Navigation Tools are located at the top right corner of the viewport. (T/F)

8.	 The three spinners corresponding to the Movement parameter are used to specify the 
extrusion taking place along the X, Y, or Z axis. (T/F)

9.	 The Background tool is used to change the foreground with the color or the image which 
is visible only in the render view. (T/F)

10.	 The R . P parameter in  the Attribute Manager is used to determine the rotational values 
of the X axis. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following tools is used to revolve a profile curve about the Y axis of the local 
axis system of the spline shape?

		  (a) Lathe		   	 (b) Subdivision Surface
  		  (c) B-Spline	 		  (d) None of these

2.	 Which of the following tools is used to create text in the viewport in CINEMA 4D?

		  (a) Lathe		   	 (b) Text
  		  (c) Freehand			   (d) Render to Picture Viewer

3.	 The __________ parameter of the Background object is used to select the background 
color of the scene for the rendering purpose.

4.	 By default, the height of a rectangle spline primitive is set to __________ .

5.	 The __________ dialog box consists of specific parameters which help you in saving a still 
image or image sequence in an uncompressed format.

6.	 CINEMA 4D consists of default predefined curves known as spline primitives. (T/F)

7.	 The Render to Picture Viewer tool is used to render a scene or model in a separate 
window. (T/F)

8.   The Picture Viewer window is also known as the output window in CINEMA 4D. (T/F)

9. 	 The default units of measurement in CINEMA 4D can be changed from the drop-down 
list located next to the Project Scale spinner in the Project Settings area. (T/F)

10.	 The ALT+G key combination is used to group objects in the Object Manager. (T/F)

 EXERCISES 
The rendered output of the model used in the following exercises can be accessed by 
downloading the c02_cinema4d_r16_exr.zip file from www.cadcim.com. The path of the file is as 
follows: Textbooks > Animation and Visual Effects > MAXON CINEMA 4D > MAXON CINEMA 
4D R16 Studio: A Tutorial Approach
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 Exercise 1                                                                      
 
Using various Generators and spline modeling tools, create the model of a chair, as shown in 
Figure 2-83. 		   		       		                     (Expected time: 25 min)

 Exercise 2                                                                      

Using various Generators and spline modeling tools, create the model of a table watch, as 
shown in Figure 2-84. 	     					          (Expected time: 45 min)

 Figure 2-83  The model of a chair  Figure 2-84  The model of a table watch

 

Answers to Self-Evaluation Test
1. b, 2. c, 3. c, 4. Boole, 5. Configure, 6. Object Properties, 7. T, 8. T, 9. F, 10. T


