
Chapter 2

Drawing Sketches 
for Solid Models

 Learning Objectives
After completing this chapter, you will be able to:
• Start a new template file to draw sketches.
• Set up the sketching environment.
• Use various drawing display tools.
• Understand the sketcher environment in the Part module.
• Get acquainted with sketcher entities.
• Specify the position of entities by using dynamic input.
• Draw sketches by using various sketcher entities.
• Delete sketched entities.
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THE SKETCHING ENVIRONMENT
Most of the designs created in Autodesk Inventor consist of sketched and placed features. A 
sketch is a combination of a number of two-dimensional (2D) entities such as lines, arcs, circles, 
and so on. The features such as extrude, revolve, and sweep that are created by using 2D sketches 
are known as sketched features. The features such as fillet, chamfer, thread, and shell that are 
created without using a sketch are known as placed features. In a design, the base feature or the 
first feature is always a sketched feature. For example, the sketch shown in Figure 2-1 is used 
to create the solid model shown in Figure 2-2. In this figure, the fillets and chamfers are the 
placed features.

Figure 2-1  The basic sketch for the solid model Figure 2-2  A solid model created using the 
sketched and placed features

Once you have drawn the basic sketch, refer to 
Figure 2-1, you need to convert it into a solid model using solid modeling tools.

You can create sketches in Sketching environment. This environment of Autodesk Inventor 
can be invoked at any time in the Part module or in the Assembly module. Unlike other solid 
modeling programs, here you just need to invoke the Start 2D Sketch tool and specify the 
plane to draw sketch; the Sketching environment will be invoked. You can draw a sketch in this 
environment and then proceed to the part modeling environment for converting the sketch into 
a solid model. The options in the Sketching environment will be discussed later in this chapter.

Initial Interface of Autodesk Inventor
When you start Autodesk Inventor, the initial interface is displayed with the Get Started 
tab chosen by default, as shown in Figure 2-3. The Launch panel of this tab contains 
options such as New, Open, Projects, and Open Samples. These options will be discussed later. 
By choosing the Home option from the My Home panel, you can start and open the recent file. 
The Team Web option allows you to attach any required website or HTML file for easy access. 
You can access the Autodesk help by using the Help option and can navigate to the previous page 
with the help of the Back option. By choosing the What’s New option from the New Feature 
panel of the Ribbon, you can view all the enhancements in Autodesk Inventor 2016. You can 
watch the introductory videos, import files from other CAD Systems, and access resources from 
the web in the Videos and Tutorials panel of the Get Started tab of the Ribbon. 
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The initial interface of inventor consists of the New and Recent Documents areas and various 
tabs. Using the options  in the New area, you can start new part, assembly, drawing, and 
presentation file. On choosing the Configure Default Template button from this area, the 
Configure Default Template dialog box will be invoked, as shown in Figure 2-4. You can choose 
measurement units and drawing standards from this dialog box. The area on the right side of 
the New area consists of the Projects, Shortcuts, and File Details tabs. You can click on the 
Projects tab to set the active project file. Similarly, click on the Shortcuts tab to create shortcuts 
for fast access to project locations, files, and folders. The File Details tab is used to view the file 
information. The Filter option in the Recent Documents area is used to filter the project and 
file types according to user’s requirements. 

Note
If any of the panels is not available by default in the Get Started tab of the Ribbon, you need to 
customize the Ribbon to add them. 

Figure 2-3  The initial interface of Autodesk Inventor 2016

Figure 2-4  The Configure Default Template dialog box
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Starting a New File 
In Autodesk Inventor, you can start a new file by choosing the New tool from the Launch 
panel in the Get Started tab of the intial interface. On doing so, the Create New File 

dialog box will be displayed, refer to Figure 2-5. Alternatively, you can start a new file by choosing 
the New tool from the Quick Access Toolbar or by choosing the Start a new file button from 
the Open dialog box. You will learn more about the Open dialog box later in this chapter.

The options in the Create New File dialog box are used to select a template file for starting a 
design. You can select a template of English, Metric, or Mold Design standard. To start a new 
metric part file, select the Metric option that is available under the Template node of the dialog 
box, as shown in Figure 2-5. The templates that are available on selecting the Metric option 
are discussed next. 

Figure 2-5  The Create New File dialog box with the Metric 
node selected

.ipt Templates 
Select any .ipt template to start a new part file for creating a solid model or a sheet metal 
component. 

.iam Templates
Select a .iam template to start a new assembly file for assembling various parts. Note that if you 
select the Weldment.iam template, the Weldment module of Autodesk Inventor will be started. 

.ipn Templates
Select a .ipn template to start a new presentation file for animating the assembly. The 
Presentation module marks the basic difference between the Autodesk Inventor and other design 
tools. This module allows you to animate the assemblies created in the Assembly module. For 
example, you can create a presentation in the Presentation module that shows a Drill Press Vice 
assembly in motion. 
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.idw Templates
Select a .idw template to start a new drawing file for generating the drawing views. You can use 
the drawing templates of various standards that are provided in this tab, such as ANSI, ISO, 
DIN, GB, JIS, GOST, and BSI.

.dwg Templates
Select a .dwg template for creating AutoCAD drawing files. You can use the drawing templates of 
standards such as JIS, ISO, GB, DIN, BSI, and ANSI.

The Project File drop-down list in the Create New File dialog box displays the active project 
in which the new file has been started. The Projects dialog box can be invoked by choosing the 
Projects button from the Create New File dialog box.

The Open Dialog Box
The Open dialog box is used to open an existing file. To invoke this dialog box, choose the 
Open tool from the Launch panel of the Get Started tab. Figure 2-6 shows the Open dialog box. 

Figure 2-6  The Open dialog box

The options in the Open dialog box are used to open existing files. You can browse and select the 
file that you want to open from the list displayed in the dialog box. The preview of the selected file 
is displayed in the preview window located at the lower left portion in this dialog box, as shown in 
Figure 2-7. By default, you can open any file created in Autodesk Inventor. This is because, the Files 
of type drop-down list displays the Autodesk Inventor Files (*.iam; *.idw; *.dwg; *.ipt; *.ipn, and 
*.ide) option, By default. You can also open the files created in other solid modeling programs such 
as AutoCAD, Pro/ENGINEER and Creo Parametric, Alias, Catia V5, SolidWorks, NX, and so on 
by selecting the respective options from the Files of type drop-down list. 
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Figure 2-7  The Open dialog box showing the preview of the selected file

In addition to open an existing file, you can also start new files and setup a project by using the 
Open dialog box. To open an existing file, choose the Start a new file button from this dialog 
box. Note that on starting a new session in Autodesk Inventor, the Start a new file button will 
be active in the Quick Launch area of the Open dialog box. Choose this button; the Create 
New File dialog box will be displayed, as shown in Figure 2-8. 

Figure 2-8  The Create New File dialog box
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By using the Open dialog box, you can also invoke the Project dialog box to setup a new project. 
To invoke the Project dialog box, choose the Project button available on the right of the Project 
File drop down list in the Open dialog box. You will learn more about setting a project later in 
this chapter.

Setting a New Project 
In Autodesk Inventor, a project defines all the files related to a design project you are working 
on. You can create new projects or retrieve the previously created projects by choosing the 
Projects tool from the Launch panel in the Get Started tab of initial interface of Autodesk 
Inventor. When you choose the Projects tool, the Projects dialog box will be displayed, as 
shown in Figure 2-8. All the project folders will be displayed in the upper half of the dialog box 
and the options regarding the selected project folder will be displayed in the lower half of the
dialog box. To add another project folder to this list, choose the New button; the Inventor project 
wizard dialog box will be displayed. The New Vault Project radio button is selected by default in 
this dialog box. Choose the Next button from the Inventor project wizard dialog box. Specify 
the name of the project in the Name text box and the location in the Project (Workspace) Folder 
text box. You can also choose the Browse for project location button to specify the location of 
the project. Next, choose the Finish button. Once you have specified the project folder, it will 
be added to the upper part of the Projects dialog box and its location will be displayed. When 
you select a project, the options related to it will be shown in the lower part of the dialog box. 
The Projects dialog box with various projects is shown in Figure 2-9. Choose the Done button 
to close the Projects dialog box.

Figure 2-9  The Projects dialog box
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To view help about topics, press F1; the Autodesk Inventor Help window will be displayed. 
In this window, you will find help topics explaining how to use a particular tool or option of 
Autodesk Inventor.

Import DWG
In Autodesk Inventor, you can import AutoCAD files. To do so, choose Open > Import 
DWG from the Application Menu; the Import dialog box will be displayed. Browse 
to the desired folder and import the required AutoCAD file. 

INVOKING THE SKETCHING ENVIRONMENT
To invoke the Sketching environment, choose the Start 2D Sketch button from the Sketch panel 
in the 3D Model tab; three different planes namely XY, YZ, and XZ will be displayed in the 
graphics window, as shown in Figure 2-10. Select the required plane from the graphic window 
to invoke the Sketching environment.

Figure 2-10  Three different planes displayed in the graphics window

INTRODUCTION TO THE SKETCHING ENVIRONMENT
The initial interface appearance in the Sketching environment of a Standard (mm).ipt file after 
selecting the XY plane as the sketching plane is shown in Figure 2-11. By default, the Ribbon 
is placed at the top of the graphics window, refer to Figure  2-11. You can move this Ribbon 
anywhere in the graphics window. To do so, right-click on the Ribbon; a shortcut menu will 
be displayed. Choose the Undock Ribbon option from the shortcut menu; the Ribbon will be 
undocked. Now, you can drag the Ribbon anywhere in the graphics window. It is recommended 
to place (dock) the Ribbon at the top of the graphics window so that you can use the space 
efficiently. To do so, right-click on the Ribbon and choose Docking Position > Top from the 
shortcut menu. Alternatively, double-click on the title bar of the Ribbon to dock it.
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Figure 2-11  Initial  interface appearance in the sketching environment

SETTING UP THE SKETCHING ENVIRONMENT
It is very important to first set up the sketching environment. This has to be done before you 
start drawing a sketch. Setting up the sketching environment includes modifying the grids of a 
drawing. It is unlikely that the designs that you want to create consist of small dimensions. You 
will come across a number of designs that are large. Therefore, before starting a drawing, you 
need to modify the grid settings. These settings will depend on the dimensions of the design. 
The process of modifying the grid settings of a drawing is discussed next.

Modifying the Document Settings of a Sketch
Before  sketching, you may need to modify the settings of the Sketching environment as per your 
requirement. You can change the snapping distance, grid spacing, and various attributes related 
to line display of the sketching environment. You must have noticed that the drawing window in 
the sketching environment consists of a number of light and dark lines that are normal to each 
other. These normal lines are called Grid lines. The Grid lines help you locate an entity, thereby 
helping you to draw a sketch correctly or modify an existing sketch precisely. 

You can modify the document settings of a sketch. To do so, choose the Document Settings 
tool from the Options panel of the Tools tab; the Part1 Document Settings dialog box will be 
displayed. In this dialog box, choose the Sketch tab to display the options related to the Sketching 
environment, refer to Figure 2-12. The options under this tab are discussed next.
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Figure 2-12  The Part1 Document Settings dialog box with the Sketch 
tab chosen

Snap Spacing Area
The options under this area are used to specify the snap distances.

X Edit box
This edit box is used to specify the snap spacing in the X direction. 

Y Edit box
This edit box is used to specify the snap spacing in the Y direction. 

Grid Display Area
The options in this area are used to control the number of major and minor lines. The minor 
lines are the light lines that are displayed inside the dark gray lines. The dark gray lines are 
called the major lines. 

Snaps per minor
This spinner is used to specify the number of snap points between each minor line.
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Major every minor lines
This spinner is used to specify the number of minor lines between two major lines.

Line Weight Display Options Area
The options in the Line Weight Display Options area allow you to control the line weight in the 
sketching environment. The Display Line Weights check box is selected by default and displays 
the sketches with the set line weights. If this check box is cleared, then the differences in the 
line weights will not be displayed in the sketch. The Display True Line Weights radio button, 
if selected, displays the line weights on screen as they would appear on paper when printed. 
The Display Line Weights by Range (millimeter) radio button, if selected, displays the line 
weights according to the values entered.

Note
You will have to increase the drawing display area after increasing the grid spacing. 

Tip. You can also turn off the display of the major and minor grid lines and the axes. To turn 
off the display of the grid line and the axes, choose the Application Options tool from the 
Options panel; the Application Options dialog box will be displayed. Next, choose the Sketch 
tab and clear the Grid lines, Minor grid lines, and Axes check boxes from the Display area.

SKETCHING ENTITIES
Getting acquainted with the sketching entities is an important part of learning Autodesk 
Inventor. The major part of a design is created using the sketch entities. Therefore, this section 
can be considered as one of the most important sections of the book. In Autodesk Inventor, the 
sketched entities are of two types: Normal and Construction. The normal entities are used to 
create a feature and become a part of it, but the construction entities are drawn just for reference 
and support, and cannot become a part of the feature. By default, all the drawn entities are 
normal entities. To draw construction entities, choose the Construction tool from the Format 
panel of the Sketch tab. All the entities drawn after choosing the Construction tool will be the 
construction entities. Deselect this tool by choosing it again to draw normal entities.	
 

POSITIONING ENTITIES BY USING DYNAMIC INPUT
In Autodesk Inventor, you can specify the position of sketching entities by using the Dynamic 
Input which consists of two components: Pointer Input and the Dimension Input. The 
Pointer Input is displayed when you invoke the sketching tools such as Line, Rectangle, Arc, 
and it displays the coordinates of the current location of the cursor. As you move the cursor, 
the coordinates change dynamically. When you specify the first point, the Pointer Input is 
displayed. The Pointer Input is displayed in the form of Cartesian Coordinates (X and Y). If 
you specify the second point or the subsequent points of entities, the Dimension Input will be 
displayed. The Dimension Input is displayed in the form of polar coordinates (Length and Angle).  
To specify the position of sketching entities dynamically, invoke the required sketching tool and 
then move the cursor in the graphics window; the location of the cursor will be displayed in the 
cartesian coordinate in the Pointer Input. Press the TAB key and enter the X and Y coordinate 
values in the Pointer Input to specify the first point; you will be prompted to specify the endpoint 
or second point of the entity. Alternatively, you can specify the first point of the entity by clicking 
in the graphics window. On doing so, the Pointer Input will be modified to the Dimension Input 



2-12	             		 Autodesk Inventor for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om
and the polar coordinate input fields will be displayed. To specify the endpoint or second point 
of the entity, enter the length and angle values in the input fields. To toggle between the length 
and angle input fields, use the TAB key. If you specify input values by using the Dimension 
Input and then use the TAB key, lock icons will be displayed on the right of the input fields. 
The lock icons indicate that the values defined are constrained. Figure 2-13 shows the Pointer 
Input of a line and Figure 2-14 shows the Dimension Input of the endpoint of a line of length 
20 mm at an angle of 45 degrees. 

Figure 2-14  Dimension Input of the endpoint 
of a line of length 20 mm at 45 degrees 

Figure 2-13  Pointer Input of a line

If some sketched entities exist in the drawing window and you start creating new entities in the 
drawing window, an appropriate constraint symbol will be displayed near the cursor. You can 
control the display of the Pointer Input and Dimension Input by using the Application Options 
dialog box. This dialog box can be invoked by choosing the Application Options tool from 
the Options panel of the Tools tab. To control the display of Pointer Input and Dimension 
Input, choose the Sketch tab in the Application Options dialog box. Clear the Enable the 
Heads-Up Display (HUD) check box from the Sketch tab and choose the OK button from this 
dialog box. As a result, the display of Pointer Input and Dimension Input will be turned off and 
now you cannot enter the input values of the entities dynamically. 

The sketcher entities in Autodesk Inventor are discussed next.

Drawing Lines
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Line  

Lines are the basic and one of the most important entities in the sketching environment. 
As mentioned earlier, you can draw either normal lines or construction lines. A line is 
defined as the shortest distance between two points. The two points are the start point 
and the endpoint of the line. Therefore, to draw a line, you need to define these two 

points. The parametric nature of Autodesk Inventor allows you to draw the initial line of any 
length or at any angle by just picking the points on the screen. After drawing the line, you can 
drive it to a new length or angle by using parametric dimensions. You can also create the line 
of actual length and angle directly by using the Inventor Precise Input toolbar. Both the methods 
of drawing the lines are discussed next.	
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Drawing a Line by Picking Points in the Drawing Window
This is a very convenient method to draw lines and is used extensively while sketching. When 
you invoke the Line tool from the Create panel, the cursor (which was initially an arrow) is 
replaced by crosshairs with a yellow circle at the intersection. Alternatively, you can choose the 
Create Line tool from the Marking Menu which is displayed when you right-click anywhere in 
the graphics window. On doing so, you are prompted to select the start point of the line or drag 
off the endpoint for the tangent arc. In addition, the coordinates of the current location of the 
cursor are displayed in the Pointer Input and also at the lower right corner of the Autodesk 
Inventor window. The point of intersection of the X and Y axes (black lines among grid lines) is 
the origin point. If you move the cursor close to the origin, it will snap to the origin automatically. 
To draw a line, specify a point anywhere in the drawing window; the Pointer Input will display 
both length and angle values as zero. Move the cursor; a rubber-band line will start from the 
specified point and the length and angle values will change accordingly in the Pointer Input. 
One end of this rubber-band line is fixed at the point specified in the drawing window and the 
other end is attached to the yellow circle in crosshairs. As you move the cursor after specifying 
the start point of the line, the Pointer Input will display the length and angle of the current 
location of the line. Click at the required position in the drawing window. Alternatively, enter 
the required length and angle values in the Pointer Input to specify the endpoint of the line. 
You can use the TAB key to toggle between the length and angle values in the Pointer Input. 

After specifying the endpoint of the line, a line is drawn and a new rubber-band line starts. The start 
point of the new rubber-band line is the endpoint of the last line and you are again prompted to 
specify the endpoint of the line. You can continue specifying the endpoints to draw continuous lines. 

When you draw entities in Autodesk Inventor, valid constraints are applied automatically to the 
entities. Therefore, when you draw continuous lines, the horizontal, vertical, perpendicular, and 
parallel constraints are automatically applied to them. The symbol of the applied constraint 
is displayed on the line while drawing it. You can exit the Line tool by pressing the ESC key. 
Alternatively, you can exit the Line tool by right-clicking anywhere in the graphics window; a 
Marking Menu will be displayed. Next, choose OK from the Marking Menu. Figures 2-15 and 
2-16 display the Perpendicular Constraint and Parallel Constraint, respectively being applied 
to the lines while they are being drawn. 
 

Figure 2-15  Drawing a line using the 
Perpendicular Constraint

Figure 2-16  Drawing a line using 
the Parallel Constraint
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Note
The default screen appearance in the Sketching environment can be modified for clarity. To do so, 
choose the Application Options tool from the Options panel of the Tools tab; the Application 
Options dialog box will be displayed. In the dialog box, choose the Colors tab and then select the 
Presentation option from the Color scheme list box. Next, select 1 Color from the Background 
drop-down list, and then choose the Apply button from the Application Options dialog box. The 
default appearance of the screen is changed in the Sketching environment.

In Inventor, you can close a sketch that has two or more than two lines. To do so, if you have 
drawn two or more than two continuous lines in the drawing area then on selecting the Close 
option from the Marking menu; a line joining the endpoint of the current line and the start 
point of the first line will be created and the sketch will be closed. Figure 2-17 shows the Close 
option being chosen from the Marking menu to close the sketch and Figure 2-18 shows the 
closed sketch created. Note that the Close option will not be displayed in the Marking menu 
once you terminate the creation of continuous lines. 
 

Figure 2-18  Closed sketch createdFigure 2-17  Choosing the Close option from 
the Marking Menu 

Drawing a Line by using the Inventor Precise Input toolbar
This is another method of drawing lines in Autodesk Inventor. In this method, you use the 
Inventor Precise Input toolbar to define the coordinates of the start point and the endpoint of 
lines. To display the Inventor Precise Input toolbar for the line, first invoke the Line tool. Next, 
click on the down arrow displayed at bottom of the Create panel in the Sketch tab; the Create 
panel will expand. Choose the Precise Input tool from this panel. As mentioned earlier, the 
origin of the drawing lies at the intersection of the X and Y axes. The X and Y coordinates of 
this point are 0, 0. You can take the reference of this point to draw lines. There are two methods 
to define the coordinates using this toolbar. Both the methods are discussed next.

Specifying Coordinates with respect to the Origin
The system that define the coordinates with respect to the origin of the drawing is termed 
as the absolute coordinate system. By default, the origin lies at the intersection of the X 
and Y axes. All the points in this system are defined with respect to this origin. To define 
the points, you can use the following four methods.
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Defining the Absolute X and Y Coordinates: In this method, you will define the X and 
Y coordinates of the new point with respect to the origin. To invoke this method, select 
the Indicate a point location by typing X and Y values option from the drop-down 
list in the Inventor Precise Input toolbar. The exact X and Y coordinates of the point 
can be entered in the X and Y edit boxes provided in this toolbar.

Defining the Absolute X Coordinate and the Angle from the X Axis: In this method, 
you will define the absolute X coordinate of a point with respect to the origin and the 
angle that this line makes with the positive X axis. The angle will be measured in the 
counterclockwise direction from the positive X axis. To invoke this method, select the 
Specify a point using X coordinate and angle from X axis option from the drop-down 
list. The X coordinate of the new point and the angle can be defined in the respective 
edit boxes in the Inventor Precise Input toolbar.

Defining the Absolute Y Coordinate and the Angle from the X Axis: In this method, you 
will define the absolute Y coordinate of a point with respect to the origin and the angle 
that this line makes with the positive X axis. To invoke this method, select the Specify 
a point using Y coordinate and angle from X axis option from the drop-down list. 
The Y coordinate of the new point and the angle can be defined in the respective edit 
boxes in the Inventor Precise Input toolbar.

Specifying the Distance from the Origin and the Angle from the X Axis: In this 
method, you will define the distance of the point from the origin and the angle that 
this line makes with the X axis. To invoke this method, select the Specify a point using 
distance from the origin and angle from X axis option from the drop-down list. The 
distance and the angle can be defined in the respective edit boxes.

Specifying Coordinates with respect to the Last Point
This system of specifying the coordinates with respect to the previous point is termed as the 
relative coordinate system. Note that this system of defining the points cannot be used for 
specifying the first point (the start point of the line). All absolute coordinate methods for 
specifying a point with respect to the origin can also be used with respect to the last specified 
point by choosing the Precise Delta button along with the respective method. This button 
will be available only after you specify the start point of the first line. The Reset To Origin 
button moves the triad to the origin of the sketch (0,0,0). The Precise Redefine button is 
used to enter a point relative to the coordinate origin.

Note
1. While drawing continuous lines, when you move the cursor close to the start point of the first 
line, the color of yellow circle changes to green and the cursor snaps to the start point. On selecting 
the point at this stage, the loop will be closed and you will exit the current line chain.

2. To draw center lines, first choose the Centerline tool from the Format panel and then create 
lines. Alternatively, select the required entities from the drawing window and then choose the 
Centerline tool; the selected entities will become center lines.  
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Restarting a Line
To restart a line, right-click in the graphics window and choose Restart from the Marking Menu; 
the start point of the line is cancelled and you are prompted to select the start point of the line.

Drawing Circles
In Autodesk Inventor, you can draw circles by using two methods. You can draw a circle by 
defining the center and the radius of the circle or by drawing a circle that is tangent to three 
specified lines. Both these methods of drawing the circle are discussed next.

Drawing a Circle by Specifying the Center Point and Radius
 Ribbon:	 Sketch > Create > Circle drop-down > Circle Center Point    

This is the default method of drawing circles. In this method, you need to define the center 
point and radius of a circle. To draw a circle using this method, choose the Circle Center Point 
tool from the Create panel, refer to Figure 2-19; you will be prompted 

Figure 2-19  Tools in the 
Circle drop-down

to select the center of the circle. Specify the center point of the circle 
in the drawing window; you will be prompted to specify a point on 
the circle. Click at the required location in the drawing window to 
specify a point on the circumference of the circle. This point will 
define the radius of the circle. Alternatively, enter the required value 
in the Pointer Input to specify the diameter of the circle. You can 
also specify the center and the radius using the Inventor Precise 
Input toolbar. Figure 2-20 shows a circle drawn by using the center 
and the radius.

Drawing a Circle by Specifying Three Tangent Lines
 Ribbon:	 Sketch > Create > Circle drop-down > Circle Tangent    

The second method of drawing circles is used to draw it tangent to three selected 
lines. To draw a circle using this method, choose the Circle Tangent tool from the 
Draw panel, refer to Figure 2-19; you will be prompted to select the first, second, and 
third line, sequentially. As soon as you specify the third line, a circle tangent to all the 
three specified lines will be drawn, as shown in Figure 2-21.

Figure 2-20  Circle drawn using the center 
point and radius

Figure 2-21  Circle drawn using three tangent 
lines
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Drawing Ellipses
 Ribbon:	 Sketch > Create > Circle drop-down > Ellipse    

To draw an ellipse, choose the Ellipse tool from the Create panel; you will be 
prompted to specify the center of the ellipse. Select a point to specify the center 

of the ellipse; you will be prompted to specify the first axis point. Specify a point to define the 
first axis of the ellipse; you will be prompted to select a point on the ellipse. Select a point on 
the ellipse; the ellipse will be created. You can also 

Figure 2-22  An ellipse drawn in 
the Sketching environment

specify these points using the Inventor Precise Input  
toolbar. However, remember that you cannot use the 
relative options for defining the points of the ellipse. 
Therefore, if you use the Inventor Precise Input toolbar 
for drawing the ellipse, all the values will be specified 
from the origin. However, you can redefine the origin 
by choosing the Precise Redefine button and placing 
it at the point that you want to define at the origin. 
Figure 2-22 shows an ellipse drawn in the Sketching 
environment. 

Drawing Arcs
Autodesk Inventor provides three methods for drawing arcs. These methods are discussed 
next.

Drawing an Arc by Specifying Three Points
 Ribbon:	 Sketch > Create > Arc drop-down > Arc Three Point    

This is the default method of drawing arcs. To create an arc 

Figure 2-23  Tools in the 
Arc drop-down

with three points, choose the Arc Three Point tool from the 
Create panel, see Figure 2-23, and then specify three points. 

The first point is the start point of the arc, the second point is the 
endpoint of the arc, and the third point is a point on the arc. You 
can define these points by specifying them in the drawing window 
or by using the Inventor Precise Input toolbar. You can also use the 
Pointer Input for specifying the second and the third point of the 
arc. Figure 2-24 shows an arc drawn using this method.

Drawing an Arc Tangent to an Existing Entity
 Ribbon:	 Sketch > Create > Arc drop-down > Arc Tangent    

This method is used to draw an arc that is tangent to an existing open entity. The open 
entity can be an arc or a line. To draw an arc using this method, choose the Arc Tangent 
tool from the Create panel (see Figure 2-23); you will be prompted to select the start 

point of the arc. The start point of the arc must be the start point or endpoint of an existing 
open entity. Once you specify the start point, a rubber-band arc will start from it. Note that this 
arc is tangent to the selected entity. Now, you will be prompted to specify the endpoint of the 
arc. Click on the drawing window to specify the endpoint of the arc. Alternatively, enter the 
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radius and the angle values in the Pointer Input to specify the endpoint of the arc. Here, it is 
very important to mention that the Inventor Precise Input toolbar or the Pointer Input cannot 
be used to select the start point of this arc. However, you can use this toolbar to specify the 
endpoint of this arc. Figure 2-25 shows an arc drawn tangent to the line.

Figure 2-25  Drawing the tangent arcFigure 2-24  Drawing the three points arc

Drawing a Tangent/Normal Arcs by Using the Line Tool
You can also draw a tangent or a normal arc when the Line tool is activated. At least a line or 
an arc should be drawn before drawing an arc using this method. To do so, draw a line or an 
arc and then invoke the Line tool; you are prompted to select the start point of the line. Move 
the cursor close to the point from where you want to start the tangent or normal arc, the yellow 
circle in the cursor turns green. Select the point at this stage; the green circle in the cursor turns 
gray. Press the left mouse button and drag the mouse; four construction lines appear at the start 
point displaying the normal and tangent directions. If you drag along the tangent direction, a 
tangent arc is drawn. But if you drag along the normal direction, an arc normal to the selected 
entity is drawn.

Drawing an Arc by Specifying the Center, Start, and End points
 Ribbon:	 Sketch > Create > Arc drop-down > Arc Center Point    

This method is used to draw an arc by specifying the center point, start point, and 
endpoint of the arc. To draw an arc using this method, choose the Arc Center Point 
tool from the Create panel (see Figure 2-23). On doing so, you will be prompted to 
specify the center point of the arc. Once you specify the center point of the arc, you 

will be prompted to specify the start point and then the endpoint of the arc, refer to Figure 2-26. 
You can also specify the start point and endpoint of the arc by using the Pointer Input. In case 
of start point, you need to specify the radius and angle of the arc from the center point. Whereas, 
in case of endpoint, you need to specify the arc length in terms of angle value. You can use the 
TAB key to toggle between the input values of the Pointer Input. As you define the center point 
and the start point, the radius of the arc will be defined automatically. So, the third point is just 
used to define the arc length. An imaginary line is drawn from the cursor to the center of the 
arc. The point at which the arc intersects the imaginary line will then be taken as the endpoint 
of the arc, see Figure 2-27. You can also use the Inventor Precise Input toolbar to specify these 
three points of the arc. 
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Figure 2-26  The arc created by specifying 
the center, start, and end points

Figure 2-27  The imaginary line created 
while drawing the center point arc

Drawing Rectangles							     
In Autodesk Inventor, rectangles can be drawn by using various0 methods that are discussed next.

Drawing a Rectangle by Specifying Two Opposite Corners
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Two Point    

This is the default method used to draw a rectangle

Figure 2-28  Tools in the 
Rectangle/Slot drop-down

 
specifying its two opposite corners. To draw a rectangle 
by using this method, choose the Rectangle Two Point 

tool from the Create panel, see Figure 2-28; you will be prompted 
to specify the first corner of the rectangle and the Pointer Input will 
be displayed. Click at the required location to specify the first corner 
of the rectangle. Once you specify the first corner, you will be 
prompted to specify the opposite corner of the rectangle and the 
Pointer Input will be modified. Click to specify the second corner or 
enter the length and height of the rectangle in the Pointer Input. 
Figure 2-29 shows a rectangle drawn using the Rectangle Two Point 
tool.

Drawing a Rectangle by Specifying Three Points 
on a Rectangle
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Three Point    

You can draw a rectangle by specifying its three points. In this method, the first two 
points are used to define the length and angle of one of the sides of the rectangle and 

the third point is used to define the length of the other side. To create a rectangle by using this 
method, choose the Rectangle Three Point tool from the Rectangle/Slot drop-down of the 
Create panel of the Sketch tab, see Figure 2-28; you will be prompted to specify the first corner 
of the rectangle. Once you specify it, you will be prompted to specify the second corner of the 
rectangle. Both these corners are along the same direction. As a result, you can use these points 
to define the length of one side of the rectangle. After specifying the second corner, you will be 
prompted to specify the third corner. This corner is used to define the length of the other side 
of the rectangle. Note that if you specify the second corner at a certain angle, then the resultant 



2-20	             		 Autodesk Inventor for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om
rectangle will also be inclined. You can also specify the first, second, and third points of the 
rectangle by using the Pointer Input. In case of second point, you need to specify the length 
and angle of rectangle in the input value fields of the Pointer Input. Whereas, in case of endpoint, 
you need to specify the height of the rectangle. You can use the TAB key to toggle between the 
input values of the Pointer Input. You can also specify the three points for drawing the rectangle 
using the Inventor Precise Input toolbar. Figure 2-30 shows an inclined rectangle drawn by 
using the Three Point Rectangle tool.

Figure 2-29  Drawing a rectangle using two points Figure 2-30  An rectangle draw using 
the Three-Point Rectangle tool

Drawing a Rectangle by Specifying its Two Points
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Two Point Center   

You can also draw a rectangle by specifying its two points. In this method, the 
first point is used to define the center of the rectangle and the second point is 

used to define the length and width of the rectangle. To create a rectangle by using this method, 
choose the Rectangle Two Point Center tool from the Rectangle/Slot drop-down of the Create 
panel in the Sketch tab, refer to Figure 2-28; you will be prompted to specify the center of the 
rectangle. Click in the Graphics window to specify it and move the cursor toward left or right; 
the Pointer Input will be displayed. Enter the length and width of the rectangle in the Pointer 
Input. Figure 2-31 shows a rectangle drawn using the Rectangle Two Point Center tool.

Drawing a Rectangle by Specifying Three Different Points on 
a Rectangle
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Rectangle Three Point Center 

You can also draw a rectangle by specifying its three points. In this method, the 
first point is used to define the center of the rectangle, the second point is used 
to define the length and orientation of the rectangle, and the third point is used 

to define the width of the rectangle. To create a rectangle by this method, choose the Rectangle 
Three Point Center tool from the Rectangle/Slot drop-down in the Create panel of the Sketch 
tab, refer to Figure 2-28; you will be prompted to specify the center of the rectangle. Click at 
the required location to specify the center; Pointer Input will be displayed. Now, move the cursor 
and click to specify the first corner point and orientation of the rectangle. Again, move the 
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cursor to specify the second corner point of the rectangle. Figure 2-32 shows a rectangle drawn 
using the Rectangle Three Point Center tool.

Figure 2-31  Drawing a rectangle by using the 
Rectangle Two Point Center tool

Figure 2-32  Drawing a rectangle by using 
the Rectangle Three Point Center tool

Drawing Polygons
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Polygon    

The polygons drawn in Autodesk Inventor are regular

Figure 2-33  The Polygon 
dialog box

 
polygons. A regular polygon is a multi-sided geometric 

figure in which the length of all sides and the angle between them 
are same. In Autodesk Inventor, you can draw a polygon with the 
number of sides ranging from 3 to 120. When you invoke the Polygon 
tool, the Polygon dialog box will be displayed, as shown in Figure 
2-33, and you will be prompted to select the center of the polygon. 
The options in this dialog box are discussed next.	

Inscribed
This is the first button in the Polygon dialog box and is chosen by default. This option 
is used to draw an inscribed polygon. An inscribed polygon is the one that is drawn inside 

an imaginary circle such that its vertices touch the circle. Once you have specified the polygon 
center, you will be prompted to specify a point on the polygon. In case of an inscribed polygon, 
the point on the polygon specifies one of its vertices, see Figure 2-34.

Circumscribed
This is the second button in the Polygon dialog box and is used to draw a circumscribed 
polygon. A circumscribed polygon is the one that is drawn outside an imaginary circle 

such that its edges are tangent to the imaginary circle. In case of a circumscribed polygon, the 
point on the polygon is the midpoint of one of the polygon edges, see Figure 2-35.

Number of Sides
This edit box is used to specify the number of sides of the polygon. The default value is 6. You 
can enter any value ranging from 3 to 120 in this edit box.
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Note
The rectangles and polygons are a combination of individual lines. All the lines can be separately 
selected or deleted. However, when you select one of the lines and drag, the entire rectangle or 
polygon will be considered as a single entity. As a result, the entire object will be moved or stretched.

Figure 2-35  Drawing a five-sided 
circumscribed polygon

Figure 2-34  Drawing a six-sided inscribed 
polygon

Drawing Slots                                             	        
In Autodesk Inventor, you can draw linear or arched slots by using the Slot tools available in the 
Rectangle/Slot drop-down of the Create panel in the Ribbon, refer to Figure 2-36.The methods 
of drawing slots are discussed next.

Drawing a Center to Center Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Center To Center   

To create a center to center slot, choose the Slot 

Figure 2-36  The Slot drop-down

Center to Center tool from the Rectangle/Slot 
drop-down; you will be prompted to specify the start center 
point. Click in the graphics window to specify the start 
center point, you will be prompted to specify the end center 
point. Now, you can specify the end point by specifying 
distance in dynamic prompt or by clicking in the graphics 
window to specify the point. Specify the end center point; 
you will be prompted to specify the diameter or width of 
the slot. Specify the width or diameter in the dynamic 
prompt; the slot will be created. This type of slot is called 
the linear slot. Figure 2-37 shows a Center to Center Slot 
created.

Drawing an Overall Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Overall    

To create an Overall Slot, choose the Slot Overall tool from the Rectangle/Slot 
drop-down; you will be prompted to specify the start point. Click in the graphics window 
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to specify the start point; you will be prompted to specify the end point. Now, you can specify 
the end point by specifying the distance in dynamic prompt or clicking in the graphics window. 
Specify the end point; you will be prompted to specify the diameter or width of the slot. Specify 
the width or diameter in the dynamic prompt; the slot will be created. This type of slot is also 
called the linear slot. Figure 2-38 shows an Overall Slot created.

Figure 2-37  Center to Center Slot              Figure 2-38  Overall slot

Drawing a Center Point Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Center Point   

To create a Center Point Slot, choose the 

Figure 2-39  Center Point Slot created

Slot Center Point tool from the 
Rectangle/Slot drop-down; you will be 

prompted to specify the center point of the slot. 
Click in the graphics window to specify the 
center point of the slot; you will be prompted 
to specify the second point. You can specify the 
distance of the second point either by using the 
dynamic prompt or clicking in the graphics 
window. Specify the second point; you will be 
prompted to specify the diameter or width of 
the slot. Specify the width or diameter in the dynamic prompt; the slot will be created. This type 
of slot is also called a linear slot. Figure 2-39 shows a Center Point Slot created.

Drawing a Three Point Arc Slot 
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Three Point Arc   

To  create  a Three  Point  Arc  slot,  choose 

Figure 2-40 Three Point Arc Slot created

 
the Slot Three Point Arc tool from the 
Rectangle/Slot drop-down; you will be 

prompted to specify the start point of the center 
arc. Click in the graphics window to specify the 
start point of center arc; you will be prompted to 
specify the end point. Now you can specify the 
end point either by specifying length in the 
dynamic prompt or by clicking in the graphics 
window; you will be prompted to specify the third 
point of the center arc. Specify the third point; 
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you will be prompted to specify the diameter or width of the slot. Specify the width or diameter 
in the dynamic prompt; the slot will be created. This type of slot is called the arc slot. Figure 
2-40 shows a Three Point Arc slot created.

Drawing a Center Point Arc Slot
 Ribbon:	 Sketch > Create > Rectangle/Slot drop-down > Slot Center Point Arc   

To create a Center Point Arc slot, choose the 

Figure 2-41  Center Point Arc Slot created

Slot Center Point Arc tool from the 
Rectangle/Slot drop-down; you will 

be prompted to specify the center of the Center 
Point Arc. Specify the center; you will be 
prompted to specify the start point of the arc. 
Specify  the start point by entering angle value 
in the dynamic prompt; you will be prompted 
to specify the end point. Specify  the end point 
by entering angle value in the dynamic prompt; 
you will be prompted to specify the diameter 
or width of the slot. Specify the width or diameter in the dynamic prompt; the slot will be created. 
This type of slot is also called the arc slot. Figure 2-41 shows a Center Point Arc slot created.

Placing Points
 Ribbon:	 Sketch > Create > Point    

In Autodesk Inventor, you can place the sketched points in a sketch by using the Point 
tool. To place a point, choose the Point tool from the Create panel of the Sketch tab; 

you will be prompted to select the center point. Specify the center point; a point will be placed. 
You can specify the location of a point in the sketch by picking a point from the graphics window 
or by entering the value in the Inventor Precise Input toolbar.

Creating Fillets
 Ribbon:	 Sketch > Create > Fillet/Chamfer drop-down > Fillet   

Filleting is defined as the process of rounding the sharp 

Figure 2-43  The 2D 
Fillet dialog box

Figure 2-42  Tools in the Fillet/
Chamfer drop-down

corners of a sketch. This is done to reduce the stress 
concentration in the model and for smooth handling. Using the 
Fillet tool, you can round the corners of the sketch by creating 
an arc tangent to both the selected entities. The portions of the 
selected entities that comprise the sharp corners are trimmed 
when the fillet is created. When you invoke this tool from the 
Fillet/Chamfer drop-down, refer to Figure 2-42, the 2D Fillet 
dialog box will be displayed with the default fillet radius, as shown 
in Figure 2-43, and you will be prompted to select the lines or 
the arcs to be filleted. If you have already created some fillets, 
their radius values will be stored as preset values. You can select 
these preset values from the list that is displayed when you choose 
the arrow provided on the right of the edit box.
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You can create any number of fillets of similar or dissimilar radii. If the Equal button in the 2D 
Fillet dialog box is chosen, the dimension of the fillet will be placed only on the first fillet and 
not on the other fillets created by using the same sequence, see Figure 2-44. On modifying the 
dimension of the first fillet, all instances of fillet will be modified. To create fillets of independent 
radii values, deactivate the Equal button before creating fillets. The fillets thus created will show 
individual dimensions, see Figure 2-45. As a result, you can modify the dimension of one fillet 
without affecting the other. You can fillet two parallel or perpendicular lines, intersecting lines 
or arcs, non-intersecting lines or arcs, and a line and an arc.

Figure 2-44  Rectangle filleted using the same 
radius with the Equal button chosen

Figure 2-45  Rectangle filleted using different 
radii with the Equal button deactivated

Creating Chamfers
 Ribbon:	 Sketch > Create > Fillet/Chamfer drop-down > Chamfer   

Chamfering is defined as the process of

Figure 2-46  The 2D Chamfer 
dialog box

 
beveling the sharp corners of a sketch. This is 

the second method of reducing stress concentration. To 
chamfer sketched entities, choose the Chamfer tool from the 
Create panel (see Figure 2-42); the 2D Chamfer dialog box 
will be displayed, as shown in Figure 2-46. Also, you will be 
prompted to select the lines to be chamfered. Select the lines; 
the chamfer will be created. The options in the 2D Chamfer 
dialog box are discussed next.

Create Dimensions
The Create Dimensions button is chosen to show the dimensions of the chamfer on the 
sketch. When you chamfer two lines, the dimensions of the chamfer are shown in the 
sketch. If you choose this button again, the chamfer dimensions will not be displayed in 

the sketch when you create another chamfer.

Equal
The Equal button is chosen to create multiple chamfers with the same parameters. This 
button is enabled only if the Create Dimensions button is chosen.
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Equal Distance	          		       	

The Equal Distance button is chosen to create 

Figure 2-47  Chamfer with dimension values

an equal distance chamfer. The distance of 
the vertex along the two selected edges is 

the same. As a result, a 45-degree chamfer is created 
using this method. The distance value is specified 
in the Distance edit box. If the Create Dimension 
button is chosen, two dimensions of the same value 
will be shown in the sketch, as shown in Figure 2-47.

Unequal Distances
The Unequal Distances button is chosen to create a chamfer with two different distances. 
The distance values are specified in the Distance1 and Distance2 edit boxes. The distance 
value specified in the Distance1 edit box is measured along the edge selected first. 

Similarly, the value in the Distance2 edit box is measured along the edge selected next. 
Figure 2-48 shows a chamfer created by using the Unequal Distances button.

Distance and Angle
The Distance and Angle button is chosen to create a chamfer by specifying a distance 
and an angle. On choosing this button, the distance needs to be specified in the Distance 
edit box and the angle in the Angle edit box. The specified angle is measured from the 

first edge selected to chamfer, see Figure 2-49.

Figure 2-49  The chamfer created using the 
Distance and Angle button

Figure 2-48  The chamfer created using the 
Unequal Distances button

Tip. 1. If multiple chamfers are created with same values, the dimension value is displayed 
only at the first instance. At the remaining chamfers, the dimension will be displayed as fx of 
the value, which means the function of the original value.

2. You can also select the vertex to create a fillet or chamfer. The two entities forming the selected 
vertex will be filleted or chamfered using the current parameters.
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Drawing Splines
Autodesk Inventor provides various methods for drawing splines. These methods are discussed 
next.

Drawing a Spline by Using the Spline Interpolation Tool
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Spline Interpolation   

To draw a spline, choose the Spline Interpolation tool from the Line/
Spline drop-down of the Create panel, refer to Figure 2-50; you will be prompted 

to specify the first point of the spline. Specify the first point; you will be

Figure 2-50  Tools in the 
Line/Spline drop-down

 
prompted to specify the next point of the spline. This process 
will continue until you terminate the spline creation. To end the 
spline at the current point, double-click in the drawing window 
or right-click to display the Marking Menu and choose Create. 
Note that if you choose Cancle(ESC) from the Marking Menu, 
the spline will not be drawn. You can also end the spline creation 
by pressing the ENTER key. Note that after creating a spline, the 
square and diamond points will be displayed on the spline along 
with the tangent handles, as shown in Figure 2-51. You can drag 
these square and diamond points to modify the shape of the 
spline. To exit the command, press the ESC key or choose 
Cancle(ESC)  from the Marking Menu.

You can undo the last drawn spline segment while drawing a spline. This can be done by choosing 
the Back option from the Marking Menu which is displayed when you right-click anywhere in the 
graphics window. You can also draw a spline tangent to an existing entity. To draw the tangent 
spline, select the point where the spline should be tangent. Next, hold the left mouse button 
and drag it; a construction line will be drawn, displaying the possible tangent directions for the 
spline. Drag the mouse in the required direction to draw the tangent spline and release the left 
mouse button. Figure 2-52 shows a spline drawn tangent to an existing line.

Tip. Autodesk Inventor allows you to invoke the last used tool by right-clicking anywhere in the 
drawing window and choosing the Repeat option (name of the last used tool) from the Marking 
menu. For example, the Repeat Line option will be available in the Marking Menu, if the line tool 
was the last used tool. Alternatively, you can press the SPACEBAR key to invoke the last used tool.
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Figure 2-52  A spline drawn tangent to a lineFigure 2-51  A spline drawn by specifying different 
points

Drawing a Spline by Specifying Control Vertices
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Spline Control Vertex    

To draw a spline, choose the Spline Control Vertex

Figure 2-53 Spline Control 
Vertex tool to be chosen in the 
Line/Spline drop-down

 
tool from the Line/Spline drop-down in the Create 

panel, see Figure 2-53; you will be prompted to specify the first 
point of the spline. Specify the start point; you will be prompted to 
specify the next point of the spline. This process will continue until 
you terminate the spline creation. To end the spline at the current 
point, double-click in the drawing window or right-click to display 
the Marking Menu and choose Create. Note that if you choose 
Cancel (ESC) from the Marking Menu, the spline will not be 
drawn. You can also end the spline creation by pressing the 
ENTER key. Note that after creating a spline, the control vertices 
will be displayed on the spline along with the tangent handles, 
as shown in Figure 2-54. You can drag these control vertices to 
modify the shape of the spline. These control vertices act as poles 
for controlling the shape of the splines. Figure 2-55 shows a spline 
drawn tangent to a line. To exit the command, press the ESC key 
on the keyboard or choose OK from the Marking menu.

Figure 2-55  A spline drawn tangent to a lineFigure 2-54  A spline drawn by specifying different 
control vertices
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Creating a Smooth Curve between the Two Existing Curves
 Ribbon:	 Sketch > Create > Line/Spline drop-down > Bridge Curve  

In Autodesk Inventor, you can create a smooth (G2) continuous curve between two 
existing curves. The existing curves can be arcs, lines, splines, or projected curves. To 

create a smooth curve, choose the Bridge Curve tool from the Line/Spline drop-down in the 
Create panel of the Sketch tab, refer to Figure 2-53; you will be prompted to select the curves 
one after the other. Select the two curves; a smooth G2 continuous curve, known as bridge curve, 
will be created between the selected curves. The profile of the bridge curve depends on the 
position of the points selected on the existing curves. Figure 2-56 shows two points selected on 
the two curves and the resulting bridge curve. Figure 2-57 shows two different points 
selected on the curves shown in Figure 2-56 and the resulting bridge curve.	   

Figure 2-57  Bridge curve created between two 
different points on the curves shown in Figure 2-56 

Figure 2-56  Bridge curve created between two  
points selected on two curves

DELETING SKETCHED ENTITIES
To delete a sketched entity, first ensure that no drawing tool is active. If any of them is active, 
press the ESC key for deactivating. Now, select the entity you want to delete using the left mouse 
button and then right-click to display the Marking Menu. Choose the Delete option from this 
Marking Menu. You can also press the DELETE key to delete the selected entities. To delete 
more than one entity, you can use a window or a crossing as discussed next.

Deleting Entities by Using a Window
A window is defined as a box created by pressing and holding the left mouse button and dragging 
the cursor from left to right in the drawing window. The window has a property that all the 
entities that lie completely inside the window will be selected. The box defined by the window 
consists of continuous lines. All the selected entities will be displayed in cyan color. After selecting 
the entities, right-click and choose Delete from the Marking menu or press the DELETE key 
to delete all the selected entities. 
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Deleting Entities by Using a Crossing
A crossing is defined as a box created by pressing and holding down the left mouse button and 
dragging the cursor from right to left in the drawing window. The crossing has a property that all 
entities that lie completely or partially inside the crossing or the entities that touch the crossing 
will be selected. The box defined by the crossing consists of dashed lines. Once the entities are 
selected, right-click and choose Delete from the Marking menu. 

Tip. You can add or remove an entity from the selection set by pressing the SHIFT or the 
CTRL key and then selecting the entity by using the left mouse button. If the entity is already 
in the current selection set, it will be removed from the selection set. If not, it will be added 
to the set.

FINISHING A SKETCH
After creating the required sketch, you need to save it. But before you save the sketch, you 
need to finish the sketch and come out of the sketching environment. To do so, choose the 
Finish Sketch tool from the Exit panel of the Sketch tab; the sketch will be finished and you 
will switch to the Home view. You can also exit the sketching environment by choosing the 
Finish 2D Sketch option from the Marking menu. The Home view enables you to view and 
create the modeling features with ease. After switching to the Modeling environment, you can 
save the document.

UNDERSTANDING THE DRAWING DISPLAY TOOLS
The drawing display tools or navigation tools are an integral part of any design software. These 
tools are extensively used during the design process. These tools are available in the Navigation 
Bar located on the right in the graphics window and in the Navigate panel of the View tab. Some 
of the drawing display tools in Autodesk Inventor are discussed next. The rest of these tools will 
be discussed in the later chapters.

Zoom All
 Ribbon:	     View > Navigate > Zoom drop-down > Zoom All	  
 Navigation Bar:    Zoom flyout > Zoom All	 			 

The Zoom All tool is used to increase the drawing display area to display all the sketched 
entities in the current display.

 

Zoom
 Ribbon:	     View > Navigate > Zoom drop-down > Zoom	  
 Navigation Bar:    Zoom flyout > Zoom				  

The Zoom tool is used to interactively zoom in and out of the drawing view. When you 
choose this tool, the default cursor is replaced by a zoom cursor. You can zoom in the 

drawing by pressing the left mouse button and dragging the cursor down. Similarly, you can 
zoom out the drawing by pressing the left mouse button and then dragging the cursor up. You 
can exit this tool by choosing another tool or by pressing ESC. You can also choose Done [Esc] 
from the Marking menu, which is displayed on right-clicking. You can also zoom in the drawing 
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by rolling the scroll wheel of the mouse in the downward direction. Similarly, you can zoom out 
the drawing by rolling the scroll wheel in the upward direction.

Tip. If you need to increase the drawing display area then zoom out the drawing by using the 
Zoom tool after increasing the grid spacing.

Zoom Window
 Ribbon:		  View > Navigate > Zoom drop-down > Zoom Window	  
 Navigation Bar:	 Zoom flyout > Zoom Window	 			 

The Zoom Window tool is used to define an area to be magnified and viewed in the 
current drawing. The area is defined using two diagonal points of a box (called window) 
in the drawing window. The area inscribed in the window will be magnified and displayed 

on the screen.

Tip. 1. The size of the dimension text always remains constant even if you magnify the area 
that includes some dimensions. 

2. To switch to the previous view, right-click in the drawing window and then choose Previous 
View from the shortcut menu or press the F5 key. You can restore nine previous views in the 
current sketching environment by using this option.

Zoom Selected
 Ribbon:		  View > Navigate > Zoom drop-down > Zoom Selected	  
 Navigation Bar:	 Zoom flyout > Zoom Selected	 			 

When you choose the Zoom Selected tool, you will be prompted to select an entity to 
zoom. Select an entity from the drawing area; it will magnified to the maximum extent 
and will be placed at the center of the drawing window. This tool can also be invoked by 

pressing the END key.

Pan
 Ribbon:		  View > Navigate > Pan	  
 Navigation Bar:	 Pan	 		

The Pan tool is used to drag the current view in the drawing window. This option is 
generally used to display the contents of the drawing that are outside the display area 

without actually changing the magnification of the current drawing. It is similar to holding the 
drawing and dragging it across the drawing window. You can also invoke the Pan tool by pressing 
and holding the middle scroll wheel of the mouse. 
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Orbit
 Ribbon:		  View > Navigate > Orbit drop-down > Orbit	  
 Navigation Bar:	 Orbit flyout > Orbit	 			 

The Orbit tool is used to rotate a model freely about any axis. It is useful when you want 
to rotate a model to any position. It is a transparent tool as it can be invoked inside any 

other command. You can invoke this tool by choosing the Orbit tool from the Navigate panel 
in the View tab. On doing so, an arcball will be displayed. This arcball is a circle with four small 
lines placed such that they divide the arcball into quadrants. The orbit axis is parallel to the 
screen and if you rotate an object by dragging the mouse pointer outside the arcball, the object 
will rotate about the orbit axis. Figure 2-58 shows the model to be rotated and Figure 2-59 shows 
the same model rotated about the vertical axis by using the Orbit tool.

 

Figure 2-59  Position 2: Model rotated about 
the vertical axis

Figure 2-58  Position 1: Default view of the 
model

Note
While working with the Orbit Tool the viewport adjusts for better visibility and understanding.
 

Constrained Orbit	
 Ribbon:		  View > Navigate > Orbit drop-down > Constrained Orbit	  
 Navigation Bar:	 Orbit flyout > Constrained Orbit	 			 

The Constrained Orbit tool is used to visually maneuver around the 3D objects to 
obtain different views. This is one of the most important tool used for advanced 3D viewing. 

Figures 2-60 and 2-61 show the default view of the model, and the view after one complete 
rotation, respectively. When the Constrained Orbit tool is invoked, the cursor changes and looks 
like a sphere encircled by two arc-shaped arrows. This cursor is known as the Orbit mode cursor. 
You can click and drag the mouse to rotate the model freely. You can move the Orbit mode 
cursor horizontally, vertically, and diagonally. In this case, the axis is normal to the top and 
bottom faces of the ViewCube. This is also a transparent tool as it can be invoked inside any 
other tool.
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Tip. 1. Press and hold the SHIFT key and the middle mouse button to temporarily enter the 
Constrained Orbit mode. 

Figure 2-60  Position 1: Default view of the 
model

Figure 2-61  Position 2: Model after a 
complete rotation 

TUTORIALS
Although Autodesk Inventor is parametric in nature yet in this chapter you will use the 
Inventor Precise Input toolbar and the Dynamic Input method to draw objects. This is to ensure 
that you are comfortable while using various drawing options in Autodesk Inventor. In the later 
chapters, you will use the parametric feature of Autodesk Inventor to size or draw the entities 
as per the desired dimension values.

Note
You can also choose the tools displayed by default in the Status Bar at the bottom of the graphics 
window. 

Tutorial 1
In this tutorial, you will draw the sketch of the model shown in Figure 2-62. The sketch to 
be drawn is shown in Figure 2-63. Do not dimension it, as the dimensions are given only for 
reference. 							         (Expected time: 30 min)
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Figure 2-62  Model for Tutorial 1 Figure 2-63  Sketch of the model

The following steps are required to complete this tutorial: 
a.	 Start a new Autodesk Inventor session and then start a new metric part file.
b.	 Invoke the Line tool and draw the sketch by specifying the coordinates of the points in the 

Dynamic Input.
c.	 Save the sketch with the name Tutorial1 and close the file.

Starting Autodesk Inventor
1.	 Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop of your 

computer; a new session of Autodesk Inventor is started.

2.	 Choose the New tool from the Launch panel of the Ribbon; the Create New File dialog 
box is displayed. 

3.	 Choose Metric and then double-click on the Standard (mm).ipt icon to start a standard 
metric template; a new metric standard part file starts.

4.	 Choose the Start 2D Sketch button from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

5.  	 Choose the Home button from the ViewCube; the current orientation of the sketch plane 
is changed.

6.	 Now, select the YZ plane as the sketching plane from the graphics window; the Sketching 
environment is invoked and the YZ plane becomes parallel to the screen. 

Note
1. If the orientation of the ViewCube is not the same as the orientation of the selected plane (Top/
Front) then click on the down arrow available next to the ViewCube; a flyout is displayed. Next, 
choose Set Current View as > Top/Front from the flyout.
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2. If by default the Grid lines are not displayed in the sketching environment, choose the Application 
Options button from the Options panel of the Tools tab; the Application Options dialog box will be 
invoked. Now, select the Grid lines check box from the Display area of the Sketch tab.

3. For the purpose of accuracy, Grid lines are kept ON in all the tutorials.

Drawing the Sketch	
	 As mentioned earlier, Autodesk Inventor is parametric in nature. Therefore, you can draw 

the sketch from any point in the drawing window. In this tutorial, Dynamic Input has been 
used to enter dimensions while drawing the sketch.

1.	 Choose the Line tool from the Create panel in the Sketch tab. Alternatively, choose the 
Create Line tool from the Marking Menu that is displayed on right-clicking in the drawing 
/ Graphics window. On doing so, you are prompted to select the first point for the line. 
Next, choose Precise Input from the expanded Create panel of the Sketch tab; the Inventor 
Precise Input toolbar is displayed. Double-click on the title bar of this toolbar to dock it. 
If required, you can also leave this toolbar floating on the screen.

	 Initially, the Precise Input button is not enabled. This button is enabled only when you 
invoke a sketching tool. Since all initial settings are configured, you can now start drawing 
the sketch.

	 When you invoke the Line tool, the cursor is replaced by a drawing cursor that has a yellow 
circle at the intersection of crosshairs. When you move the crosshair in the drawing window, 
this circle snaps to the point that is closer to it. Also, coordinates of the current location of 
the cursor are displayed at the status bar.

2.	 To specify the first point, enter 0 in both the X and Y edit boxes of the Inventor Precise 
Input toolbar and then press ENTER; you are prompted to specify the endpoint of the line.

3.	 In the Inventor Precise Input toolbar, enter -3 and 3 in the X and Y edit boxes, respectively. 
Next, press ENTER to define the endpoint of the line. On doing so, the first line of the 
sketch is drawn and you are prompted to select the endpoint of the line. 

	 You will notice that the dimensions of the sketch are very small but the drawing display 
area is large. Therefore, you need to modify the drawing display area by using the drawing 
display tools. To do so, you can use the Zoom tool. 

Tip. You can use the TAB key to switch from the X edit box to the Y edit box and vice versa 
in the Inventor Precise Input toolbar.

4.	 Choose the Zoom tool from the Navigation Bar; the drawing cursor is changed to an 
arrow cursor.

5.	 Move the cursor to the top of the drawing window, press and hold the left mouse button 
and then drag the cursor downward till the display is adjusted.
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6.	 Right-click to display the shortcut menu, and then choose Done to exit the Zoom tool. 

7.	 Again, right-click in the graphics window and then choose Cancel (ESC) from the Marking 
Menu to exit the Line tool. Also, close the Inventor Precise Input toolbar.

8.	 Invoke the Line tool again. From this step onward, you will use the Dynamic Input to create 
lines in this tutorial. Select the end point of the first line that was created with the help of 
the Inventor Precise Input toolbar. Move the cursor toward left, and enter 0.5 in the length 
input field and 180 in the angle input field and then press ENTER. Use the TAB key to 
toggle between the input fields.

9.	 Now, you need to create the third line between points 3 and 4, refer to Figure 2-64. To do 
so, move the cursor downward in the graphics window. Enter 3 in the length input field, 
press TAB to switch to the angle input field, and enter 90 and then press ENTER; a line is 
created between the 3 and 4 points.

 10.	Move the cursor toward left in the graphics window. Enter 2 in the length input field, press 
TAB to switch to the angle input field, and enter 90 in it, and then press ENTER; a line is 
created between points 4 and 5, refer to Figure 2-64.

  
11.	 Move the cursor downward in the graphics 

Figure 2-64  Sketch for Tutorial 1

window. Enter 1 in the length input field, 
press TAB, and enter 90 in the angle input 
field and then press ENTER; a line is 
created between points 5 and 6, refer to 
Figure 2-64.

12.	 Move the cursor toward right in the 
graphics window. Enter 3 in the length 
input field, press TAB, and enter 90 in the 
angle input field and then press ENTER; 
a line is created between points 6 and 7.

13. Move the cursor downward in the graphics window. Enter 0.75 in the length input field, 
press TAB, and enter 90 in the angle input field and then press ENTER; a line is created 
between points 7 and 8, refer to Figure 2-64.

14.	 Move the cursor toward right in the graphics window. Enter 0.5 in the length input field, 
press TAB, and enter 90 in the angle input field and then press ENTER; a line is created 
between points 8 and 9, refer to Figure 2-64.

15.	 Move the cursor upward in the graphics window. Enter 0.25 in the length input field,  press 
TAB, and enter 90 in the angle input field and then press ENTER; a line is created between 
points 9 and 10, refer to Figure 2-64.
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16.	 Move the cursor toward right in the graphics window. Enter 4 in the length input field, 
press TAB, and enter 90 in the angle input field and then press ENTER; a line is created 
between points 10 and 11, refer to Figure 2-64.

17.	 Move the cursor downward in the graphics window. Enter 0.25 in the length input field, 
press TAB, and enter 90 in the angle input field and then press ENTER; a line is created 
between points 11 and 12, refer to Figure 2-64.

18.	 Move the cursor toward right in the graphics window. Enter 0.5 in the length input field, 
press TAB and enter 90 in the angle input field and then press ENTER; a line connecting 
points 12 and 13 is created, refer to Figure 2-64.

19.	 Move the cursor upward in the graphics window. Enter 0.75 in the length input field, press 
TAB, and enter 90 in the angle input field and then press ENTER; a line connecting points 
13 and 14 is created, refer to Figure 2-64.

20.	 Move the cursor toward right in the graphics window. Enter 3 in the length input field and 
90 in the angle input field and then press ENTER; a line connecting points 14 and 15 is 
created, refer to Figure 2-64.

21.	 Move the cursor upward in the graphics window. Enter 1 in the length input field, press 
TAB, and enter 90 in the angle input field and then press ENTER; a line connecting points 
15 and 16 is created, refer to Figure 2-64.

22.	 Move the cursor toward left in the graphics window. Enter 2 in the length input field, press 
TAB, and enter 90 in the angle input field and then press ENTER; a line connecting points 
16 and 17 is created, refer to Figure 2-64.

23.	 Move the cursor upward in the graphics window. Enter 3 in the length input field, press 
TAB, and enter 90 in the angle input field and then press ENTER; a line connecting points 
17 and 18 is created, refer to Figure 2-64.

24.	 Move the cursor toward left in the graphics window. Enter 0.5 in the length input field, 
press TAB, and enter 90 in the angle input field and then press ENTER; a line connecting 
points 18 and 19 is created, refer to Figure 2-64.

25.	 Now, to close the geometry, click on the point 1 that you created with the help of the 
Inventor Precise Input toolbar. 

26.	 Next, right-click in the Graphics window and choose Cancel (ESC) from the Marking menu 
displayed to exit the Line tool.

Note
The method of applying additional constraints and using them to fully constrain the sketch will 
be discussed in Chapter 3. 
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Saving the Sketch
	 Remember that you cannot save a sketch in the Sketching environment. This is because 

the Sketching environment is just a part of the Part module in Autodesk Inventor. This 
environment is used only for drawing the sketches of features. Therefore, you need to exit the 
Sketching environment to save the sketch for further use. The sketches in the Part module 
are saved in the .ipt format.

1.	 Right-click in the graphics window and then choose the Finish 2D Sketch button from 
the Marking Menu displayed; the Sketching environment is closed and you switch to the 
Part modeling environment. Now, choose the Home button of the ViewCube; the current 
orientation of the sketch is changed to Isometric. Also, notice that the 3D Model tab is 
activated in place of the Sketch tab. The options in the 3D Model tab are used to create 
features. The options under this tab will be discussed in later chapters.

2.	 Choose Save from Quick Access Toolbar; the Save As dialog box is displayed. 
 

3.	 Create a new folder with the name Inventor_2016 in the C drive of your computer. In this 
folder, create another folder with the name c02.

4.	 Enter Tutorial1 as the file name in the File name edit box, refer to Figure 2-65, and then 
choose the Save button from the Save As dialog box to save the sketch.

Figure 2-65  The Save As dialog box

5.	 Choose Close > Close from the Application Menu to close this file.
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Tutorial 2
In this tutorial, you will draw the sketch for the model shown in Figure 2-66. The sketch to 
be drawn is shown in Figure 2-67. Do not dimension it, as the dimensions are given only for 
reference.					       		        (Expected time: 30 min)

Figure 2-67  Dimensioned sketch for Tutorial 2Figure 2-66  Model for Tutorial 2

	

The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file.
b.	 Draw the outer loop by specifying the length and angle lines by using the Dynamic 

Input method, refer to Figure 2-68.
c.	 Draw the inner closed loop by using the Dynamic Input method, refer to Figure 2-69.
d.	 Save the sketch with the name Tutorial2.ipt and close the file.

Starting a New File
1.	 Choose the New tool from the Launch panel of the Get Started tab; the Create New File 

dialog box is displayed. In this dialog box, choose Metric, and then double-click on the 
Standard (mm).ipt icon to start a standard metric template.

Drawing the Sketch
	 As evident from Figure 2-66, the sketch consists of two nested loops: inner loop and outer 

loop. While extruding a nested loop, the inner loop can be subtracted from the outer loop. 
In this way, a cavity will be created automatically in the model when you extrude the sketch. 
This reduces the time and effort required in creating the inner cavity as another feature. 
Therefore, you can draw both the loops together for this tutorial.

1.	 Choose the Start 2D Sketch button from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

2.	 Choose the Home button of the ViewCube; the current orientation of the sketch plane is 
changed.
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3.	 Now, select the XY plane as the sketching plane from the graphics window; the Sketching 

environment is invoked and the XY plane becomes parallel to the screen. 

Note
If the orientation of the ViewCube is not the same as the orientation of the selected plane (Top/
Front) then click on the down arrow available next to the ViewCube; a flyout is displayed. Next, 
choose Set Current View as > Top/Front from the flyout.

4.	 Choose the Line tool from the Create panel. Next, move the cursor and click when  
the cursor displays -40 and -25 in the Pointer Input or press the TAB key and then 
enter the X and Y coordinate values in the Pointer Input. As you specify the first 
point, you are prompted to specify the endpoint of the line and the Pointer Input 
is changed to Dimension Input. 

5.	 Enter 80 in the length input field of the Dimension Input and press the TAB key; the angle 
input field becomes active. Enter 0 and then press ENTER; the first line is created and the 
Dimension Input is displayed again.

6.	 Move the cursor up and then enter 10 in the length input field of the Dimension Input. 
Next, press the TAB key and enter 90 in the angle input field and then press ENTER; the 
second line is created and the Dimension Input is displayed again. 

7.	 Move the cursor toward the left and then enter 15 in the length input field. Next, press the 
TAB key and enter 90 in the angle input field. Next, press ENTER; the third line is created 
and the Dimension Input is displayed again. 

8.	 Move the cursor up and then enter 30 in the length input field. Next, press the TAB key 
and enter 90 in the angle input field. Next, press ENTER; the fourth line is created and 
the Dimension Input is displayed again. 

9.	 Move the cursor toward the right and then enter 15 in the length input field. Next, press the 
TAB key and enter 90 in the angle input field. Next, press ENTER; the fifth line is created 
and the Dimension Input is displayed again. 	

10.	 Move the cursor up and then enter 10 in the length input field. Next, press the TAB key 
and enter 90 in the angle input field. Next, press ENTER; the sixth line is created and the 
Dimension Input is displayed again. 

11.	 Move the cursor toward the left and then enter 80 in the length input field. Next, press 
the TAB key and enter 90 in the angle input field. Next, press ENTER; the seventh line is 
created and the Dimension Input is displayed again.

12.	 Move the cursor down and then enter 10 in the length input field. Next, press the TAB key 
and enter 90 in the angle input field. Next, press ENTER; the eighth line is created and 
the Dimension Input is displayed again. 

13.	 Move the cursor toward the right and then enter 15 in the length input field. Next, press 
the TAB key and enter 90 in the angle input field. Next, press ENTER; the ninth line is 
created and the Dimension Input is displayed again.
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14.	 Move the cursor down and then enter 30 in the length input field. Next, press the TAB key 
and enter 90 in the angle input field. Next, press ENTER; the tenth line is created and the 
Dimension Input is displayed again.

15.	 Move the cursor toward the left and then enter 15 in the length input field. Next, press 
the TAB key and enter 90 in the angle input field. Next, press ENTER; the eleventh line is 
created and the Dimension Input is displayed again.   

16.	 Move the cursor down and then enter 10 in the length input field. Next, press the TAB key 
and enter 90 in the angle input field. Next, press ENTER; the twelfth line is created and 
the Dimension Input is displayed again. 

17.	 Right-click to display the Marking Menu and choose OK from it to exit the Line tool. 
The sketch of the outer loop is shown in Figure 2-68. You need to arrange the positions of 
dimensions in the sketch by dragging them to view the sketch clearly.

	 Next, you need to draw the inner loop. You can draw the loop by using the Two Point 
Rectangle tool. 

18.	 Choose the Rectangle Two Point tool from the Sketch > Create > Rectangle/Slot drop-down; 
you are prompted to specify the first corner of the rectangle. 

19.	 Press the TAB key and then enter -15 and -10 in the Pointer Input. Alternatively, move the 
cursor and click when the cursor displays -15 and -10 in the Pointer Input. As you click to 
specify the first corner, you are prompted to specify the opposite corner of the rectangle 
and the Pointer Input is changed to Dimension Input.  

20.	 Move the cursor diagonally upward in the right direction and enter 30 and 20 in the 
horizontal and vertical input fields of the Dimension Input, respectively, and then press 
ENTER. 

21.	 Next, right-click on the graphics window; a Marking Menu is displayed. Choose Cancel (ESC) 
from the Marking Menu; the sketch is created, as shown in Figure 2-69. 

Figure 2-69  Completed sketch for Tutorial 2Figure 2-68  Sketch of the outer loop
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Note
The angular dimensions have not been shown in Figures 2-68 and 2-69 for clarity of sketches. 
You can control the display of the linear and angular dimensions of the sketch. To do so, 
choose Application Options from the Options panel of the Tools tab; the Application 
Options dialog box is displayed. In the Sketch tab of the Application Options dialog 
box, choose the Settings button; the Constraint Settings dialog box is displayed. Clear the 
Create dimensions from input values check box in the Dimensions area of the Constraint 
Settings dialog box and then choose OK. Next, choose the Apply and Close buttons from the 
Application Options dialog box to turn off applying dimensions automatically during sketching. 

Saving the Sketch
	 Next, you need to save the sketch. As mentioned earlier, you cannot save the sketch in the 

sketching environment. First, you need to exit the Sketching environment and then save it.

1.	 Choose the Finish Sketch button from the Exit panel; the Sketching environment is closed 
and you will switch to the Home view of the part modeling environment.

2.	 Choose the Save tool and save the sketch with the name Tutorial2 at the location given below:
	 C:\Inventor_2016\c02

3.	 Choose Close > Close from the Application Menu to close this file.

Tutorial 3
In this tutorial, you will draw the sketch for the model shown in Figure 2-70. The sketch of the 
model is shown in Figure 2-71. Do not dimension the sketch as the dimensions are given only 
for reference.	                                                         	                    (Expected time: 30 min)

Figure 2-71  Sketch for Tutorial 3Figure 2-70  Model for Tutorial 3
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	 The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file.
b.	 Draw the sketch by using the Arc and Line tools, refer to Figure 2-71.
c.	 Save the sketch with the name Tutorial3 and close the file.

Starting a New File
1.	 Choose the New tool from the Launch panel of the Get Started tab to invoke the Create 

New File dialog box.

2.	 Start a new metric standard part file by double-clicking on Standard (mm).ipt in the Metric.

3.	 Choose the Start 2D Sketch button from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

4.	 Choose the Home button from the ViewCube; the current orientation of the sketch plane 
is changed.

5.	 Now, select the YZ plane as the sketching plane from the Graphics window; the Sketching 
environment is invoked and the YZ Plane becomes parallel to the screen. 

Note
If the orientation of the ViewCube is not the same as the orientation of the selected plane (Top/
Front) then click on the down arrow available next to the ViewCube; a flyout is displayed. Next, 
choose Set Current View as > Top/Front from the flyout.

Drawing the Sketch
	 The upper arc of the sketch can be drawn by specifying its center, start, and endpoint. 

Therefore, you need to use the Center Point Arc tool to draw it.

1.	 Choose the Center Point Arc tool from the Sketch > Create > Arc drop-down; you are 
prompted to specify the center of the arc. 

2.	 Press the TAB key and enter 0 in the X coordinate edit field of the Dynamic Input. Again, 
press TAB and enter 15 in the Y coordinate edit field. Next, press ENTER to specify the 
center of the arc; the center of the arc is created and you are prompted to specify the start 
point of the arc.

3.	 Enter 12 in the length input field. Next, press TAB and enter 180 in the angle input field 
of the Dynamic Input and press ENTER.

	 The first point on the arc is defined. Now, you need to specify the endpoint of the arc.

4.	 As you are trying to draw the upper arc, you need to move the mouse cursor in the 
counter-clockwise direction and enter 180 in the angle input field and press ENTER. The 
upper arc is drawn.
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	 Next, you need to draw lines in the sketch.

5.	 Choose the Line tool from the Create panel; you are prompted to specify the start 
point of the line. 

6.	 Move the cursor close to the start point of the arc; the yellow circle snaps to the 
endpoint of the arc and turns green indicating that the cursor has snapped to the endpoint 
of the arc. Press the left mouse button to select this point as the start point of the line. 

	
7.	 Move the cursor toward left in the graphics window. Enter 12 in the length input field, press 

the TAB key, and then enter 180 in the angle input field in the Dynamic Input; the line 
between points 2 and 3 is created. Refer to Figure 2-72 for point numbers. 

Figure 2-72  Sketch showing different points for Tutorial 3

8.	 Move the cursor downward in the graphics window. Enter 30 in the length input field and 
90 in the angle input field in the Dynamic Input; a line between points 3 and 4 is created. 

9.	 Move the cursor toward right in the graphics window. Enter 12 in the  length input field and 
90 in the angle input field of the Dynamic Input; a line is created between points 4 and 5. 

	 Now, you need to draw the lower arc of the sketch. You can use the Line tool to draw the 
arc.

10.	 Move the cursor close to the endpoint of the last line until the yellow circle snaps to that 
point. When the yellow circle snaps to the endpoint, it turns gray. Now, press and hold the 
left mouse button and drag the mouse through a small distance in the upward direction. 
On doing so, four imaginary lines are displayed, showing the four directions in which you 
can draw the arc. 

11.	 As you need to draw the arc normal to the line, drag the cursor vertically upward along 
the vertical imaginary line to a small distance and then drag the cursor close to the right 
endpoint of the upper arc; the cursor snaps to the endpoint of the arc and turns green.
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12.	 Move the cursor downward, you will notice a point where both the vertical and horizontal 
imaginary lines intersect each other, see Figure 2-73. This point is the endpoint of the lower 
arc. The cursor automatically snaps to that point. Do not release the left mouse button until 
the entire process is completed.

 
13. 	When the cursor snaps to the intersection of the imaginary lines, release the mouse button 

to complete the lower arc.

Note
1. In Figure 2-72, the major and minor grid lines, and the triad have not been displayed for a 
better display of the sketch and the imaginary lines.

2. While using the temporary tracking option to draw lines, you do not need to press and hold the 
left mouse button and drag it. You just need to click once to select the endpoint of the line after 
you get the intersection point of the imaginary lines, refer to Figure 2-73.

Figure 2-73  Use of the temporary tracking option to draw an arc

	 Next, you need to draw the remaining lines to complete the sketch.

14.	 Move the cursor toward right in the graphics window. Enter 12 in the length input field and 
0 in the angle input field in the Dynamic Input; a line between points 7 and 8 is created.

15.	 Move the cursor upward in the graphics window. Enter 30 in the length input field and 90 
in the angle input field in the Dynamic Input; a line between points 8 and 9 is created.

16.	 Move the cursor toward left in the graphics window. Enter 12 in the length input field and 
90 in the angle input field in the Dynamic Input; a line between points 9 and 10 is created.

17.	 Exit the Line tool.
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	 The final sketch for Tutorial 3 is shown in Figure 2-74.

Figure 2-74  Final sketch for Tutorial 3

Note
In Figure 2-74, the automatic applied dimensions have not been shown for clarity of sketches. 

Saving the Sketch
1.	 As it is not possible to save the file in the Sketching environment, therefore you need to 

exit the Sketching environment and then save the file. To do so, right-click anywhere in the 
graphics window; a Marking Menu will be displayed. Choose the Finish 2D Sketch option 
from the Marking menu; the Sketching environment is closed and you switch to the part 
modeling environment. Now, choose the Home button of  ViewCube; the current orientation 
of the sketch is changed to Isometric.

2.	 Choose the Save button from Quick Access Toolbar and save this sketch with the name 
Tutorial4 at the location given below.

	 C:\Inventor_2016\c02

3.	 Choose Close > Close from the Application Menu to close this file.

Tutorial 4
In this tutorial, you will draw the basic sketch of the revolved solid model shown in Figure 2-75. 
The sketch for creating this model is shown in Figure 2-76. Do not dimension the sketch as the 
dimensions are given only for reference. Use Dynamic Input to draw the feature. 			
			                                           	                    (Expected time: 30 min)

The following steps are required to complete this tutorial:

a.	 Start a new metric standard part file.
b.	 Invoke the Line tool and draw the sketch with the help of Dynamic Input. 
c.	 Save the sketch with the name Tutorial4 and close the file.
d.	 Draw fillets
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Figure 2-76  Sketch for the revolved modelFigure 2-75  Revolved model for Tutorial 4

Starting a New File
1.	 Choose the New tool from the Launch panel of the Get Started tab to invoke the Create 

New File dialog box.
	
2.	 Choose  Metric to display the standard metric templates. Double-click on Standard (mm).ipt 

to start a new metric part file.

3.	 Choose the Start 2D Sketch button from the Sketch panel of the 3D Model tab; the default 
planes are displayed and you are prompted to select the sketching plane.

4.	 Choose the Home button from the ViewCube; the current orientation of the sketch plane 
is changed. 

5.	 Now, select the YZ plane as the sketching plane from the graphics window; the Sketching 
environment is invoked and the YZ Plane becomes parallel to the screen. 

Note
If the orientation of the ViewCube is not the same as the orientation of the selected plane (Top/
Front) then click on the down arrow available next to the ViewCube; a flyout is displayed. Next, 
choose Set Current View as > Top/Front from the flyout.

Drawing the Sketch
1. 	 Choose the Line tool from the Create panel in the Sketch tab or from the Marking  

Menu. On doing so, you are prompted to select the first point of the line to be 
created. In the Dynamic Input, press TAB and enter 0 in the X co-ordinate field. 
Next, press TAB, and enter 0 in the Y coordinate field and press ENTER. 

2.	 Now, you need to draw the line 1. Move the cursor toward left, enter 22 in the length input 
field, and enter 180 in the angle input field of the Dynamic Input; the line 1 is drawn.

3.	 Move the cursor upward in the graphics window. Next, enter 4 in the length input field, 
press TAB, and enter 90 in the angle input field; the line 2 is drawn, as shown in Figure 2-77.
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Figure 2-77  Sketch after drawing the lines

4.	 Move the cursor toward left in the Graphics window. Next, enter 14 in the length input field, 
press TAB, and enter 90 in the angle input field in the Dynamic Input; line 3 is drawn. 

5.	 Move the cursor upward in the graphics window. Next, enter 6 in the length input field, 
press TAB, and enter 90 in the angle input field in the Dynamic Input; line 4 is drawn.

6.	 Move the cursor toward the left in the graphics window. Next, enter 8 in the length input 
field, press TAB, and enter 90 in the angle input field in the Dynamic Input; line 5 is drawn.

7.	 Move the cursor upward in the graphics window. Next, enter 6 in the length input field, 
press TAB, and enter 90 in the angle input field in the Dynamic Input; line 6 is drawn.

8.	 Move the cursor toward the right in the graphics window. Next, enter 40 in the length input 
field, press TAB, and enter 90 in the angle input field; line 7 is drawn.

9.	 Move the cursor upward in the graphics window. Next, enter 9 in the length input field, 
press TAB, and enter 90 in the angle input field; line 8 is drawn.

10.	 Move the cursor toward left in the graphics window. Next, enter 16 in the length input field, 
press TAB, and enter 90 in the angle input field; line 9 is drawn.

11.	 Move the cursor upward in the graphics window. Next, enter 5 in the length input field, 
press TAB, and then enter 90 in the angle input field; line 10 is drawn.

12.	 Move the cursor toward the right in the graphics window. Next, enter 20 in the length input 
field, press TAB, and enter 90 in the angle input field; line 11 is drawn.

13.	 Move the cursor downward in the graphics window. Next, enter 30 in the length input field 
and 90 in the angle input field; line 12 is drawn.

14.	 The initial sketch is drawn. Exit the Line tool by choosing OK from the Marking menu. 
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Drawing Fillets
1.	 Choose the Fillet tool from the Sketch > Create > Fillet/Chamfer drop-down;  

the 2D Fillet dialog box is displayed. Enter 1.5 in the Radius edit box of this 
dialog box. Do not press ENTER.

2.	 Select the line 8 and then line 9, refer to Figure 2-76; a fillet is created between these lines 
and the radius of the fillet is displayed in the sketch.

3.	 Similarly, select lines 7 and 8 and then lines 4 and 5 to create a fillet between these lines. 
Next, right-click, and choose OK from the Marking Menu to exit the Fillet tool after creating 
all fillets. 

	 As all the lines are filleted with the same radius value, the radius of the fillet is not 
displayed on other fillets. This completes the sketch. The final sketch for this tutorial after 
filleting all the sketches is shown in Figure 2-78.

Figure 2-78  Final sketch after filleting

Note
In Figure 2-78, the display of axes and grids have been turned off for a better visibility of the 
lines of the sketch.

Saving the Sketch
1.	 Choose the Finish 2D Sketch button from the Marking Menu.

2.	 Choose the Save button from Quick Access Toolbar and save this sketch with the name 
Tutorial4 at the location given below.

	 C:\Inventor_2016\c02

3.	 Choose Close > Close from the Application Menu to close this file.
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 Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of 
this chapter:

1.	 In Autodesk Inventor, the two types of sketching entities that can be drawn are __________ 
and __________.

2.	 In the Sketching environment, the __________ tool is used to place a sketch point or a center 
point.

3.	 Filleting is defined as the process of __________ the sharp corners and sharp edges of models.

4.	 You can toggle between the length and angle input fields by using the _____________ key.

5.	 You can use the  _____________ toolbar to precisely enter coordinates of the points in the 
graphics window.

6.	 You can also delete the sketched entities by pressing the __________ key.

7.	 In Autodesk Inventor, rectangles are drawn as the combination of __________ entities.

8.	 You can undo the last drawn spline segment when you are still inside the spline drawing 
option by choosing __________ from the Marking Menu displayed.

9.	 You can exit the Line tool by pressing the _____________ key or by choosing ___________ 
from the ________________ menu.

10.	 Most of the designs created in Autodesk Inventor are a combination of sketched features 
and placed features. (T/F)

11.	 Whenever you start a new file in the Part module, the Sketching environment is invoked by 
default. (T/F)

12.	 You cannot turn off the display of grid lines. (T/F)

13.	 You cannot draw an arc while the Line tool is active. (T/F

 Review Questions
Answer the following questions: 

1.	 Which of the following tools in the Tools tab is used to invoke additional toolbars?

		  (a) Application Options		 (b) Customize
		  (c) Document Setting		  (d) None of these
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2.	 Which of the following drawing display options is used to interactively zoom in and out a 
drawing?

		  (a) Zoom All			   (b) Pan
		  (c) Zoom			   (d) Zoom Window

3.	 Which of the following keys is used to restore the previous view?

		  (a) F5	 			   (b) F6
		  (c) F7	 			   (d) F4

4.	 Which of the following drawing display options prompts you to select an entity whose 
magnification has to be increased?

		  (a) Zoom			   (b) Pan
		  (c) Zoom Selected		  (d) None of these

5.	 In most of the designs, generally the first feature or the base feature is the placed feature. 
(T/F)

6.	 You can invoke the options related to sheet metal parts from the .ipt file. (T/F)

7.	 You can change the current project directory and the project files by choosing Projects from 
the Open dialog box. (T/F)

8.	 You can specify the position of entities dynamically by using the Dynamic Input. (T/F)

9.	 In Autodesk Inventor, you can save a file in the Sketching environment. (T/F)

10.	 In Autodesk Inventor, you can start a new file by using the Open dialog box. (T/F) 

 Exercises

Exercise 1
Draw the basic sketch of the model shown in Figure 2-79. The sketch to be drawn is shown in 
Figure 2-80. Do not dimension it as the dimensions are given only for reference.			 
					     	     	                    (Expected time: 30 min)
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Figure 2-80  Sketch for Exercise 1Figure 2-79  Model for Exercise 1

Exercise 2
Draw the basic sketch of the model shown in Figure 2-81. The sketch to be drawn is shown in 
Figure 2-82. Do not dimension it as the dimensions are given only for reference.
							       	    	       (Expected time: 45 min)

Figure 2-82  Sketch for Exercise 2Figure 2-81  Model for Exercise 2

Exercise 3
Draw the sketch of the model shown in Figure 2-83. The sketch to be drawn is shown 
in Figure 2-84. Do not dimension it as the dimensions are given only for reference.
 	   	                                                                                                  (Expected time: 45 min)
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Figure 2-84  Sketch for Exercise 3Figure 2-83  Model for Exercise 3

Exercise 4
Draw the sketch of the model shown in Figure 2-85. The sketch to be drawn is shown 
in Figure 2-86. Do not dimension it as the dimensions are given only for reference.
 	   	                                                                                                  (Expected time: 45 min)

Figure 2-86  Sketch for Exercise 4Figure 2-85  Model for Exercise 4
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Answers to Self-Evaluation Test
1. normal, construction, 2. Point, 3. rounding, 4. TAB, 5. Inventor Precise Input, 6. DELETE, 
7. individual, 8. Back, 9. ESC, Cancel (ESC), Marking menu, 10. T, 11. F, 12. F, 13. F


