
Chapter 2

Polygon Modeling

 Learning Objectives 
After completing this chapter, you will be able to:
• Create polygon primitives
• Edit polygon primitives
• Modify the components of polygon primitives
• Create models using polygon primitives
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INTRODUCTION
In this chapter, you will learn to create and edit polygon shapes using polygon modeling 
techniques. A polygon is made up of different closed planar shapes having straight sides. The 
most commonly used shapes in 3D polygons are triangles and quadrilaterals. These shapes are 
formed by vertices, edges, and faces. An edge is a straight line formed by joining two vertices. 
In a polygon, three vertices join to each other by three edges to form a triangle and four vertices 
join to each other by four edges to form a quadrilateral. By modifying faces, edges, and vertices 
of an object, you can create a polygon model as per your requirement.

POLYGON PRIMITIVES
In Maya, you can create objects interactively. By default, the Interactive Creation is turned off. To 
enable the Interactive creation, choose Create > Objects > Polygon Primitives > Interactive 
Creation from the menubar. When the Interactive Creation option is turned on, multiple click 
drag operations can be performed in the viewport. The number of click drag operations vary 
depending on the type of the primitive object you are creating. If the Interactive Creation is 
turned off, Maya creates objects at the center of the grid.

Creating a Sphere
Menubar:	 Create > Objects > Polygon Primitives > Sphere   
Shelf:		  Polygons > Polygon Sphere 

A sphere is a solid object in which every point on its surface is 
equidistant from its centre, as shown in Figure 2-1. The sphere 
can be created dynamically, or by entering the values using the 
keyboard. Both the methods are discussed next.

Creating a Sphere Dynamically
To create a sphere dynamically, choose Create > Objects > 
Polygon Primitives > Sphere from the menubar; you will be 
prompted to drag the cursor on the grid to draw the sphere in the viewport. Press and hold 
the left mouse button, and drag the cursor up or down to define the radius of the sphere. Now, 
release the left mouse button to get the desired radius; the sphere will be created and is visible 
in the Smooth Shade All mode. 

Note
By default, polygon primitives are displayed in the Smooth Shade All mode. Press 4 to change 
the display to Wireframe. Alternatively, choose Shading > Wireframe from the Panel menu. 
You can also switch back to the Smooth Shade All mode by pressing 5 or by choosing Shading > 
Smooth Shade All from the Panel menu.

Creating a Sphere by Using the Keyboard
To create a sphere by using the keyboard, choose Create > Objects > Polygon Primitives > 
Sphere > Option Box from the menubar; the Tool Settings (Polygon Sphere Tool) window will 
be displayed, as shown in Figure 2-2. In this window, set the properties of the sphere using the 
keyboard and then click in the viewport; the sphere will be created. Choose Reset Tool at the 
top of the Tool Settings (Polygon Sphere Tool) window to reset the default values of the sphere. 

Figure 2-1  A polygon sphere
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It is recommended that you reset the values while creating

Figure 2-2  The Tool Settings (Polygon 
Sphere Tool) window

 
a new polygon primitive.  

Modifying the Name and other 
Parameters of a Sphere
You can modify the name and other parameters of a 
sphere. To do so, select the sphere; the Channel Box / 
Layer Editor is displayed on the right of the viewport. 
If the Attribute Editor is displayed on the right of the 
viewport, press Ctrl+A to switch to the Channel Box / 
Layer Editor, as shown in Figure 2-3. Now, click on the 
pSphere1 label in the Channel Box / Layer Editor; the 
pSphere1 label is converted into an edit box. Next, enter 
the desired name in the edit box and press ENTER. To 
modify the properties of the sphere, expand the 
polySphere1 node in the INPUTS area; various options 
will be displayed. Enter the required values in the edit 
boxes; the changes will be dynamically reflected on the 
sphere in the viewport. Alternatively, select the label of 
the parameter of the sphere that you want to change; 
the corresponding label of the parameter will be 
highlighted in the Channel Box / Layer Editor. Now, 
press and hold the middle mouse button and drag the cursor

Figure 2-3  The Channel 
Box / Layer Editor

 
horizontally in the viewport to change that particular value of the 
corresponding parameter. 

Creating a Cube
Menubar:	 Create > Objects > Polygon Primitives > Cube
Shelf:		  Polygons > Polygon Cube 

A cube is a three-dimensional shape with six sides or rectangular faces, 
as shown in Figure 2-4. A cube can be created dynamically or by 
entering values using the keyboard. Both these methods are 
discussed next.

Creating a Cube Dynamically
To create a cube dynamically, choose Create > Objects > Polygon 
Primitives > Cube from the menubar; you will be prompted to 
drag the cursor on the grid to draw the cube in the viewport. Press

Figure 2-4  A polygon cube

 
and hold the left mouse button, and drag the cursor on the grid to 
define the base of the cube. Next, release the left mouse button to 
get the desired base. Now, press and hold the left mouse button 
again and drag the cursor up to set the height of the cube and then 
release the left mouse button; the cube will be created.
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Creating a Cube by Using the Keyboard 
To create a cube by the using the keyboard, choose Create >

Figure 2-5  The Tool Settings (Polygon 
Cube Tool) window

 
Objects > Polygon Primitives > Cube > Option Box 
from the menubar; the Tool Settings (Polygon Cube Tool) 
window will be displayed, as shown in Figure 2-5.

 In this window, set the properties of the cube by using the 
keyboard and then click in the viewport; the cube will be 
created in all viewports. Choose Reset Tool at the top of 
the Tool Settings (Polygon Cube Tool) window to reset 
the settings of the cube to their default values.

Creating a Prism
Menubar:	 Create > Objects > Polygon 	
		  Primitives > Prism

A prism is a polyhedron that has two polygonal faces 
lying in parallel planes as bases and the other faces as 
parallelograms, as shown in Figure 2-6. You can create a prism dynamically or by using the 
keyboard. Both these methods are discussed next.

Figure 2-6  A polygon prism

Creating a Prism Dynamically
To create a prism dynamically, choose Create > Objects > 

Figure 2-7  The Tool Settings 
(Polygon Prism Tool) window 

Polygon Primitives > Prism from the menubar; you will be 
prompted to drag the cursor on the grid to draw the prism in 
the viewport. Press and hold the left mouse button and drag 
the cursor; the base of the prism is created. 

Now, release the left mouse button to get the desired base. 
Again, press and hold the left mouse button and drag the 
cursor up to set the height of the prism. Next, release the left 
mouse button; the polygon prism will be created.

Creating a Prism by Using the Keyboard 
To create a prism by using the keyboard, choose Create > 
Objects > Polygon Primitives > Prism > Option Box from 
the menubar; the Tool Settings (Polygon Prism Tool) window 
will be displayed, as shown in Figure 2-7. 
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In this window, set the properties of the prism by using the keyboard and then click in the 
viewport; the prism will be created in all viewports. Choose the Reset Tool button at the top 
of the Tool Settings (Polygon Prism Tool) window to reset the settings of the prism to their 
default values.

Creating a Pyramid
Menubar:	 Create > Objects > Polygon Primitives > Pyramid
Shelf:       	 Polygons > Polygon Pyramid 

A pyramid is a geometric shape with a polygonal base and a point called apex. 

Figure 2-8  A polygon 
pyramid

The base and the apex are connected through triangular faces, as shown 
in Figure 2-8. You can create a pyramid dynamically or by entering values 
using the keyboard. Both these methods are discussed next.
 
Creating a Pyramid Dynamically
To  create  a  pyramid  dynamically,  choose  Create  > Objects >

Figure 2-9  The Tool Settings (Polygon 
Pyramid Tool) window

Polygon Primitives > Pyramid from the menubar; you 
will be prompted to drag the cursor on the grid to draw 
the pyramid in the viewport. Press and hold the left mouse 
button, and drag the cursor up or down to define the shape 
of the pyramid, and then release the left mouse button; 
the pyramid will be created. 

Creating a Pyramid by Using the Keyboard
To create a pyramid by using the keyboard, choose Create > 
Objects > Polygon Primitives > Pyramid > Option Box 
from the menubar; the Tool Settings (Polygon Pyramid 
Tool) window will be displayed, as shown in Figure 2-9. 
In this window, set the properties of the pyramid by using 
the keyboard and then click in the viewport; the pyramid 
will be created in all viewports. Choose Reset Tool at the 
top of the Tool Settings (Polygon Pyramid Tool) window 
to reset the settings to default values. 

Creating a Pipe
Menubar:	 Create > Objects > Polygon Primitives > Pipe
Shelf:      	 Polygons > Polygon Pipe 

Figure 2-10  A polygon pipe

A pipe is similar to a cylinder polygonal shape with thickness, as  
shown in Figure 2-10. You can create a pipe either dynamically or 
by entering values using the keyboard. Both these methods are 
discussed next.

Creating a Pipe Dynamically
To create a pipe dynamically, choose Create > Objects > Polygon Primitives > Pipe from 
the menubar; you will be prompted to drag the cursor on the grid to draw the pipe in the 
viewport. Press and hold the left mouse button and drag the cursor; the base of the pipe is 
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created. Next, release the left mouse button to get the desired base. Now, press and hold the 
left mouse button and drag the cursor up to set the height of the pipe. Next, release the left 
mouse button. Again, press and hold the left mouse button to set the thickness of the polygon 
pipe; the polygon pipe will be created.  

Creating a Pipe by Using the Keyboard 
To create a pipe by using the keyboard, choose Create >

Figure 2-11  The Tool Settings 
(Polygon Pipe Tool) window

 
Objects > Polygon Primitives > Pipe > Option Box from 
the menubar; the Tool Settings (Polygon Pipe Tool) window 
will be displayed, as shown in Figure 2-11. 

In this window, set the properties of the pipe by using the 
keyboard and then click in the viewport; the pipe will be 
created in all viewports. Choose the Reset Tool button at the 
top of the Tool Settings (Polygon Pipe Tool) window to reset 
the settings to default values.  

Creating a Helix
Menubar:	 Create > Objects > 	                   	
		  Polygon Primitives > Helix

A helix is a geometry in three dimensional space that lies on a cylinder

Figure 2-12  A polygon helix

 
and subtends a constant angle to a plane perpendicular to its 
axis, as shown in Figure 2-12. You can create a helix dynamically 
or by entering values using the keyboard. Both these methods 
are discussed next. 

Creating a Helix Dynamically
To create a helix dynamically, choose Create > Objects > 
Polygon Primitives > Helix from the menubar; you will be 
prompted to drag the cursor on the grid. Press and hold the left 
mouse button and drag the cursor on the grid to define the 

Figure 2-13  The Tool Settings 
(Polygon Helix Tool) window

diameter of the helix and then release the left mouse button. 
Again, press and hold the left mouse button and drag the cursor 
up to set the height of the helix, and then release the left mouse 
button. Next, press and hold the left mouse button and drag 
the cursor to set the number of coils in the helix and then 
release the left mouse button. Again, press and hold the left 
mouse button and drag the cursor to set the section radius; the 
helix will be created.

Creating a Helix by Using the Keyboard 
To create a helix by using the keyboard, choose Create > 
Objects > Polygon Primitives > Helix > Option Box from 
the menubar; the Tool Settings (Polygon Helix Tool) window 
will be displayed, as shown in Figure 2-13. In this window, set 
the properties of the helix by using the keyboard and then click 
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in the viewport; the helix will be created in all viewports. Choose Reset Tool at the top of the 
Tool Settings (Polygon Helix Tool) window to reset the settings to their default values.

Creating a Soccer Ball
Menubar:	 Create > Objects >  Polygon Primitives > 	
		  Soccer ball 

A soccer ball polygon primitive created in Maya is very much similar 

Figure 2-14  A soccer ball

to a real-world soccer ball, as shown in Figure 2-14. A soccer ball 
is formed by an alternate arrangement of hexagons and pentagons. 
It has total thirty two faces. You can create a soccer ball 
dynamically or by entering values using the keyboard. Both these 
methods are discussed next.

Creating a Soccer Ball Dynamically
To create a soccer ball dynamically, choose Create > Objects > Polygon Primitives > Soccer 
Ball from the menubar; you will be prompted to drag the cursor on the grid to draw the soccer 
ball in the viewport. Press and hold the left mouse button and drag the cursor on the grid; the 
soccer ball will be created. 

Tip. By default, the Polygon Helix Tool is not available in the shelf. To add it to the shelf, 
choose the Custom shelf tab from the Shelf. By default, the Custom shelf tab is empty. This 
tab can be used to add tools that are frequently used. Press and hold the SHIFT and CTRL 
keys and choose Create > Objects > Polygon Primitives > Helix from the main menubar; 
a helix icon is formed in the Custom shelf. Similarly, you can add other tools in the Custom 
shelf tab for quick access.

Creating a Soccer Ball by Using the Keyboard
To  create  a soccer ball by using the keyboard,  choose  Create >

Figure 2-15  The Tool Settings 
(Polygon Soccer Ball Tool) window

 
Objects > Polygon Primitives > Soccer Ball > Option 
Box from the menubar; the Tool Settings (Polygon Soccer 
Ball Tool) window will be displayed, as shown in 
Figure 2-15. In this window, set the properties of the soccer 
ball by using the keyboard and then click in the viewport; 
the soccer ball will be created. Choose Reset Tool at the 
top of the Tool Settings (Polygon Soccer Ball Tool) 
window to reset the settings to their default values.

Creating a Platonic Solid
Menubar:	 Create > Objects > Polygon 		
		  Primitives > Platonic Solids

You can create various types of platonic solids such as 
tetrahedron, octahedron, dodecahedron, and icosehedron. 
Platonic solids have identical faces and its all sides are 
equal, refer to Figure 2-16. You can create a platonic 
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solid dynamically or by entering values using the keyboard. Both

Figure 2-16  A platonic solid

these methods are discussed next.

Creating a Platonic Solid Dynamically
To create a platonic solid dynamically, choose Create > Objects > 
Polygon Primitives > Platonic Solids from the menubar; you will 
be prompted to drag the cursor on the grid to draw the platonic 
solid in the viewport. Press and hold the left mouse button and 
drag the cursor on the grid; the platonic solid will be created.

Creating a Platonic Solid by Using the Keyboard 
To create a platonic solid by using the keyboard, choose Create > Objects > Polygon Primitives > 
Platonic Solids > Option Box from the menubar; the Tool Settings (Polygon Platonic Solid 
Tool) window will be displayed, as shown in Figure 2-17. In this window, set the properties of 
the platonic solid by using the keyboard and then click in the viewport; the platonic solid will be 
created. Choose the Reset Tool button at the top of the Tool Settings (Polygon Platonic Solid 
Tool) window to reset the settings of the platonic solid, to their default values.

POLYGON EDITING TOOLS
In Maya 2016, the tools are grouped according to the function they perform. For example, the 
Boolean, Combine, and Separate tools are combined in the Combine group, refer to Figure 2-18. 
The polygon editing tools are used to perform different operations on the polygon objects. These 
editing tools are available in the Mesh, Edit Mesh, and Mesh Tools menus of the Modeling 
menu set. Figure 2-18 displays different tools in the Mesh menu. The most commonly used 
tools under this menu are discussed next. 

Figure 2-17  The Tool Settings (Polygon 
Platonic Solid Tool) window

Figure 2-18  The Mesh menu
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Booleans
Menubar:	 Mesh > Combine > Booleans

The booleans tools are used to combine the polygon objects to

Figure 2-19  The booleans tools

 
create a new object. Using these tools, you can perform 
three different operations to modify the shape of the new 
object. The booleans tools are show in Figure 2-19. The 
three options of this tool are discussed next.

Union
Menubar:	 Mesh > Combine > Booleans > Union

The Union tool is used to combine the volume of two polygon meshes. To understand the function 
of this tool, create a sphere and torus and place them in the viewport, as shown in Figure 2-20. 
Using the SHIFT key, select the torus and then the sphere. Next, choose Mesh > Combine > 
Booleans > Union from the menubar; both the objects will be merged, and the intersecting 
geometry between them will be deleted, refer to Figure 2-21.

Figure 2-20  A torus and a sphere placed in the viewports

 

Difference
Menubar:	 Mesh > Combine > Booleans > Difference

The Difference tool is used to subtract the last selected geometry from the geometry that was 
selected first. To understand the function of this tool, create a sphere and a torus and place them 
in the viewport, refer to Figure 2-20. Using the SHIFT key, select the torus and then the sphere. 
Next, choose Mesh > Combine > Booleans > Difference from the menubar; the geometry will 
be deleted, as shown in Figure 2-22.
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Figure 2-21  The Union operation carried 
out on the torus and the sphere

Figure 2-22  The Difference operation 
carried out on  the torus and the sphere

Intersection
Menubar:	 Mesh > Combine > Booleans > Intersection

The Intersection tool is used to keep the intersecting

Figure 2-23  The Intersection operation 
carried out on the torus and the sphere

 
geometry between two objects and delete the remaining 
geometry. To understand the function of this tool, create 
a sphere and torus and place them in the viewport, refer 
to Figure 2-20. 

Using the SHIFT key, select the torus and the sphere. Next, 
choose Mesh > Combine > Booleans > Intersection 
from the menubar; the intersecting geometry will be 
displayed and the remaining parts will be deleted, as 
shown in Figure 2-23.

Combine
Menubar:	 Mesh > Combine > Combine

The Combine tool is used to group two or more polygon objects into a single polygon object. 
To do so, select the polygon objects to be combined in the viewport and then choose Mesh > 
Combine > Combine from the menubar; the selected polygon objects are combined into a 
single polygon object.

Separate 
Menubar:	 Mesh > Combine > Separate

The Separate tool is used to ungroup the combined

Figure 2-24  The selected face separated 
from the polygon object

 
polygon objects into separate polygon objects. To do 
so, select the group in the viewport and then choose 
Mesh > Combine > Separate from the menubar; the 
selected group of polygon objects are separated, refer 
to Figure 2-24.
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Conform
Menubar:	 Mesh > Remesh > Conform

The Conform tool is used to wrap the vertices of an objects onto the surface of another 
object. To understand the function of this tool, you need at least two wrap polygon objects, refer 
to Figure 2-25. Next, select the object on which you want to wrap the vertices and then choose 
Modify > Objects > Make Live from the menubar to make the selected object live. Now, select 
the geometry that you want to wrap and then choose Mesh > Remesh > Conform from the 
menubar; the wrapper mesh will automatically wrap around the target geometry, refer to 
Figure 2-26.

Figure 2-25  The polygon objects Figure 2-26  Planer1 mesh snap to Sphere1

Fill Hole
Menubar:	 Mesh > Remesh > Fill Hole

The Fill Hole tool is used to fill a hole in an object by adding a face to it. To understand the 
function of this tool, press and hold the right mouse button over an object; a marking menu 
will be displayed. Next, choose Edge from the marking menu. Now, select the boundary edge, 
refer to Figure 2-27. Next, choose Mesh > Remesh > Fill Hole from the menubar; the empty 
space will be filled, as shown in Figure 2-28. 

Figure 2-27  Edges of the deleted face selected Figure 2-28  Filled hole of the cube

 

Tip 
1.  You can use the shortcut keys for displaying or activating various components of an object. 
For example, press F8 for object mode, F9 for vertices, F10 for edges, and F11 for faces. 

2.  To select the four surrounding edges of a deleted face, choose one of the edges and then 
press the right arrow key on your keyboard; all the four edges will be selected.
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Reduce
Menubar:	 Mesh > Remesh > Reduce  

The Reduce tool is particularly useful in reducing the number of polygons in a particular area 
of the mesh. You can also use the UVs or vertex colors to select an area on the mesh. To reduce 
polygons, select an area and then choose Mesh > Remesh > Reduce from the menubar. 

Smooth
Menubar:	 Mesh > Remesh > Smooth

The Smooth tool is used to make a polygon object smooth by adding divisions to it. To do so, 
create a polygonal object in the viewport and then choose Mesh > Remesh > Smooth from the 
menubar; the selected polygonal object will be smoothened. 

Triangulate
Menubar:	 Mesh > Remesh > Triangulate

The Triangulate tool is used to convert the polygon faces into triangles.

Quadrangulate
Menubar:	 Mesh > Remesh >Quadrangulate

The Quadrangulate tool is used to convert the polygon faces into quadrangles.

EDITING THE POLYGON COMPONENTS
In the previous section, you learned to modify simple polygon primitives. In this section, you 
will learn to edit the components of polygon primitives to create complex objects from it. To 
do so, select a polygon object in the viewport and then press and hold the right mouse button 
over it; the marking menu of the corresponding object will display various components of the 
object such as vertex, edge, face, and UV, refer to Figures 2-29 to 2-32. 

To access various tools for editing the polygon primitives, select Modeling from the Menuset 
drop-down list in Status Line. Next, choose the Edit Mesh menu from the menubar. The most 
commonly used component editing tools are discussed next.

Note
1. The face selection mode in the marking menu allows you to select the faces of the active object. 
When you move the cursor on a face, the face will be highlighted in red. Next, when you click on 
the highlighted face, its color will change to green, indicating that it is now selected. In this way, 
you can identify the selected and the unselected faces.

2. The Multi option allows you to select all components at a time without switching between 
components. To select all components, press and hold the right mouse button on the already selected 
component, and then choose the Multi option from the marking menu. Next, select a face on the 
object, press and hold the SHIFT key, and then select the next required component.
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Figure 2-32  UVs of the sphereFigure 2-31  Faces of the sphere

Figure 2-30   Edges of the sphereFigure 2-29  Vertices of the sphere

 

Add Divisions							                   
The Add Divisions tool is used to subdivide the edges or faces of a polygon object to 
smaller components. To add divisions, select that edges or faces that you wan to divide and then 
choose Edit Mesh > Components > Add Divisions > Option Box from the menubar; the Add 
Divisions to Face Options dialog box will be displayed. Set the required attributes in this dialog 
box and then choose the Add Divisions button to subdivide the selected area.

Bevel
Menubar:	 Edit Mesh > Components > Bevel

The Bevel tool is used to expand the vertex or the face of a polygon object. This adds smoothness 
to a sharp object by adding fillets on the edges. The bevel operation adds fillet to the edges 
by creating new faces on the selected polygon object. To do so, create a polygon object in the 
viewport and select it. Next, choose Edit Mesh > Components > Bevel from the menubar; the 
selected polygon object will be beveled, as shown in Figure 2-33.

The Bevel tool is also used to bevel the components such as face, vertex, and edge of a polygon 
object individually. Create a polygon object in the viewport and right-click on it; the marking 
menu will be displayed. Next, choose Edge from the marking menu; the edge selection mode will 
be activated. Now, select any edge of the object and then choose Edit Mesh > Components > 
Bevel from the menubar; the selected edge will be beveled, refer to Figure 2-34. 
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Figure 2-33  Selected polygon object beveled Figure 2-34  Selected edge beveled
 
To adjust the bevel parameters, select the object in

Figure 2-35  Various bevel attributes in the 
Attribute Editor

 
the viewport; the Channel Box / Layer Editor is 
displayed on the right of the viewport. Next, expand 
polyBevel1 in the INPUTS area of the Channel Box 
/ Layer Editor and then set the bevel parameters; 
the changes will be reflected on the selected object in 
the viewport. Alternatively, select the object in the 
viewport. 

Choose Windows > Attribute Editor from the 
menubar; the Attribute Editor will be displayed on 
the right side of the viewport. 

Next, choose the polyBevel1 tab from the Attribute 
Editor; the bevel parameters will be displayed in the 
Attribute Editor, as shown in Figure 2-35. Set the 
parameters as per your requirement.

Note
Choose the Show/Hide Channel Box button from the Status Line, if the Channel Box / Layer 
Editor is not displayed in the viewport. Alternatively, you can press Ctrl+A.

Bridge
The Bridge tool is used to construct faces between pair of the border edges. The connection 
between the edges or faces can be straight or curved, depending on the options, you choose 
from the Bridge Options dialog box.
 
To create a bridge between the border edges of an object, select the edges and then choose 
Edit Mesh > Components > Bridge > Option Box from the menubar; the Bridge Options 
dialog box will be displayed. In this dialog box, choose the type of bridge you want to create 
by selecting the a radio button corresponding to the Bridge type attribute and then choose the 
Bridge or Apply button; a bridge will be created, as shown in Figure 2-36.

Note
To create a bridge between two separate objects, you need to combine the two objects by choosing 	
Mesh > Combine > Combine from the menubar.
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Figure 2-36  The Bridge connection between two edges

Collapse
Menubar:	 Edit Mesh > Components > Collapse

The Collapse tool use to collapse edges on a component and component basis and then it 
merges the associated vertices for each collapsed edge separately. To collapse the edges of an 
object, select the required edges and then choose Edit Mesh > Components > Collapse from 
the menubar; the selected edges will be collapsed and their vertices will be merged.

Note
This tool also works on faces. But it generates unpredictable results. If  you want to merge the faces, 
use the Merge to Center option which is available in the Edit Mesh menu.

Connect									              
Menubar:	 Edit Mesh > Components > Connect

The Connect tool is used to connect the selected vertices or faces via edges. To use this tool, 
select faces or edges on an object and then choose Edit Mesh > Components > Connect from 
the menu bar to connect the selected component, refer to Figure 2-37.

Figure 2-37  The connected edge displayed

Detach
Menubar:	 Edit Mesh > Components > Detach

The Detach tool is used to split a vertex into multiple vertices. To understand working of 
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this tool, create a polygon object in the viewport and press and hold the right mouse button 
over it; a marking menu will be displayed. Choose Vertex from the marking menu; the vertex 
selection mode will be activated. Select a vertex of the object that needs to be split. Next, 
choose Edit Mesh > Components > Detach from the menubar; the selected vertex gets split 
into multiple vertices, refer to Figure 2-38. This tool also detaches the faces. When faces of an 
object are selected and you use this tool, it detaches the face selection along its perimeter edges.

Figure 2-38  Selected vertex gets split into 
multiple vertices

Extrude
Menubar:	 Edit Mesh > Components > Extrude

The Extrude tool is used to extrude various components such as vertex, face, or an edge of a 
polygon object inward or outward.

To extrude a vertex, select the vertex that needs to be extruded. Next, choose Edit Mesh > 
Components > Extrude from the menubar; the selected vertex will be extruded and the 
polyExtendedVertex# In-View Editor will be displayed. You can change the width, length, and, 
division of the extruded vertex by entering the values in the Width, Length, and Divisions edit 
boxes, as shown in Figure 2-39.

To extrude an edge, select it and then choose Edit Mesh > Components > Extrude from the 
menubar; the polyExtendedEdge# In-View Editor will be displayed. Enter the desired value 
in the Thickness edit box of the polyExtendedEdge# In-View Editor. If the value in the edit 
box is negative, the face will be extruded inward and for a positive value, it will be extruded 
outward, refer to Figure 2-40.

Figure 2-39  The extruded vertex Figure 2-40  The extruded edge
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To extrude a face, select it and then choose Edit Mesh > Components > Extrude from the 
menubar; the polyExtrudeFace# In-View Editor will be displayed. Enter the desired value in 
the Thickness edit box of the polyExtrudeFace# In-View Editor. If the value in the edit box is 
negative, the face will be extruded inward and for a positive values, it will be extruded outward, 
as shown in Figure 2-41.

Merge
Menubar:	 Edit Mesh > Components > Merge

The Merge tool is used to merge two vertices. To merge two vertices, select a object in the 
viewport and press and hold the right mouse button over it; a marking menu will be displayed. 
Choose Vertex from the marking menu; the vertex selection mode will be activated. Next choose 
Edit Mesh > Components > Merge > Option Box from the menubar; the Merge Vertices 
Options will be activated. Now, select four vertices of top polygon, choose Merge from displayed 
dialog box; the selected vertex is merged, refer to Figure 2-42. If vertices not merged; increase 
Threshold value, now choose Merge; the vertices will be merged.

Figure 2-41  The extruded face Figure 2-42  Top vertices to be merged

You can also use the Merge to Center tool for merging

Figure 2-43  Center vertices to be merged

 
the selected vertices. To do so, choose Edit Mesh > 
Components > Merge to Center; the vertices will be 
merged to the center of the two vertices, refer to 
Figure 2-43.

Average Vertices
Menubar:	 Edit Mesh > Vertex > Average Vertices

The Average Vertices tool is used to control the level of smoothing applied to the selection, 
refer to Figure 2-44. You can set the amount of smoothing from the Average Vertices Options 
dialog box.
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Figure 2-44  Selected vertices smoothend

Chamfer Vertices
Menubar:	 Edit Mesh > Vertex > Chamfer Vertices

The Chamfer Vertices tool is used to replace a vertex

Figure 2-45  A new polygon face created using 
the Chamfer Vertices tool

to create a chamfered corner. To use this tool, create 
a polygon object in the viewport and press and hold 
the right mouse button over it; a marking menu will 
be displayed. Choose Vertex from the marking menu; 
the vertex selection mode will be activated. Select a 
vertex (or vertices) of the object. Next, choose Edit 
Mesh > Vertex > Chamfer Vertices from the 
menubar; a new polygon faces will be created, refer 
to Figure 2-45.

Delete Edge/Vertex
Menubar:	 Edit Mesh > Edge > Delete Edge/Vertex

The Delete Edge/Vertex tool is used to delete the selected edges or vertices of a polygon object. 
To do so, select vertices of an object that you want to delete and then choose Edit Mesh > Edge > 
Delete Edge/Vertex from the menubar; the selected vertices will be deleted. Similarly, using the 
Delete Edge/Vertex tool, you can delete the selected edges of the polygon object.

Tip You can also delete the selection using the DEL key. However, you can not delete a 
vertex when it shares more than two edges. 

Edit Edge Flow

Menubar:	 Edit Mesh > Edge > Edit Edge Flow

The Edit Edge Flow tool is used to modify the position of edges along the curve of the surrounding 
mesh. To do so, select the two non-adjacent edges of an object and choose Edit Mesh > Edge > 
Edit Edge Flow from the menubar; the edges move along the curvature of the object. Now, to 
see the duplicate face, move it away from the centre using the Move tool.    
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Duplicate
Menubar:	 Edit Mesh > Face > Duplicate

The Duplicate tool is used to create the duplicate copies of the selected faces. To use this tool, 
create a cube in the viewport. Select the polygon cube created and then press and hold the right 
mouse button on it; a marking menu will be displayed. Next, choose Face from the marking 
menu; the face selection mode will be activated. Choose Move Tool from the Tool Box. Next, 
select a face on the polygon cube and choose Edit Mesh > Face > Duplicate from the menubar; 
a duplicate copy of the selected face will be created in the viewport. Now, to see the duplicate 
face, move it away from the centre using the Move tool.

EDITING THE POLYGON COMPONENTS USING 
MESH TOOLS
In the previous section, you learned to modify simple polygon primitives. In this section, you 
will learn to edit the polygon objects using the polygon components such as face, vertex, and 
edge. To access various tools for editing the polygon components, select Modeling from the 
Menuset drop-down list in Status Line. Next, choose the Mesh Tools menu from the menubar. 
The most commonly used tools under this menu are discussed next.

Create Polygon
Menubar:	 Mesh Tools > Tools > Create Polygon

The Create Polygon tool is used to create polygons by placing 

Figure 2-46  A shape created using the 
Create Polygon tool

vertices in the viewport. To do so, choose Mesh Tools > 
Tools > Create Polygon tool from the menubar. Next, click 
in the viewport; a vertex point will be created in the 
viewport. 

Next, depending on the shape required, keep on clicking in 
the viewport to connect the points; a shape will be created, 
refer to Figure 2-46. 

Insert Edge Loop
Menubar:	 Mesh Tools > Tools > Insert Edge Loop

The Insert Edge Loop tool is used to add segments to the selected object. The segment created 
by using this tool ends at the same point from where it starts, thus forming a loop. To use this 
tool, create a polygon object in the viewport and choose Mesh Tools > Tools > Insert Edge 
Loop tool from the menubar; the edges of the object will turn blue. Next, click on an edge; a 
new segment will be created on the selected object, as shown in Figure 2-47. Note that the Insert 
Edge Loop tool works only with objects that have quads (quads are faces with four sides). If the 
sides of a face are more or less than four, then this tool will not work. To set the properties of 
this tool, choose Mesh Tools > Insert Edge Loop > Option Box from the menubar; the Tool 
Settings (Insert Edge Loop tool) window will be displayed, refer to Figure 2-48.
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Figure 2-47  A new segment created 
using the Insert Edge Loop

Figure 2-48  The Tool Settings 
(Insert Edge Loop tool) window

Multi-Cut                                                               
Menubar:	 Mesh Tools > Tools > Multi-Cut

The Multi-Cut tool is used to manually add segments

Figure 2-49  Segments added using the 
Multi-Cut tool

 
between two edges of an object. To add segments between 
two edges, select the polygon object and then choose Mesh 
Tools > Tools > Multi-Cut from the menubar. 

Click on the edge to choose the starting point of the 
segment. Next, click on the edge where you want to end 
the segment and press ENTER; a segment will be added 
between the two edges, refer to Figure 2-49.

Offset Edge Loop
Menubar:	 Mesh Tools > Tools > Offset Edge Loop

The Offset Edge Loop tool works similar to Insert

Figure 2-50  New segments created using 
the Offset Edge Loop tool

 
Edge Loop tool with the only difference that it creates 
segments on both sides of the selected edges. To use 
this tool, create a polygon object in the viewport and 
choose Mesh Tools > Tools > Offset Edge Loop tool 
from the menubar. Next, click and drag the cursor to 
the already existing edges to create new segments on 
both sides of the selected object, as shown in Figure 2-50.
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TUTORIALS
 Tutorial 1                                                                                     
In this tutorial, you will create the model of a coffee mug, as shown in Figure 2-51, using the 
polygon modeling techniques.                                                              (Expected time: 20 min)

Figure 2-51  The model of a coffee mug

The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create the basic shape of the mug.
c.	 Create the handle of the mug.
d.	 Change the background color of the scene.
e.	 Save and render the scene.

Creating a Project Folder
Before starting a new scene, it is recommended that you create a project folder. It helps you 
keep all the files of a project in an organized manner. Open Windows Explorer and browse to 
the Documents folder. In this folder, create a new folder with the name maya2016. The maya2016 
folder will be the main folder and it will contain all the projects folders that you will create 
while doing tutorials of this textbook. Now, you will create a project folder for Tutorial 1 of this 
chapter. To do so, you need to follow the steps given next.

1. 	 Start Autodesk Maya 2016 by double-clicking on its icon on the desktop.

2.	 Choose File > Project Window from the menubar; the Project Window is displayed. Choose 
the New button; the Current Project and Location text boxes are enabled. Now, enter 
c02_tut1 in the Current Project text box. 

3.	 Click on the folder icon next to the Location text box; the Select Location dialog box is 
displayed. In this dialog box, browse to the \Documents\maya2016 folder and choose the 
Select button to close the dialog box. Next, choose the Accept button in the Project Window 
dialog box; the \Documents\maya2016\c02_tut1 folder will become the current project folder.

4.	 Choose Save Scene from the File menu; the Save File As dialog box is displayed.
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Note
The scenes created in Maya are saved with the .ma or .mb extension. As the project folder is already 
created, the path \Documents\maya2016\c02_tut1\scenes is displayed in the Look in drop-down 
list of the Save As dialog box. 

Tip After setting the project folder when you open or save a scene, Maya uses the scenes folder 
inside the project folder, by default.

5.	 Enter c02tut1 in the File name edit box and then choose the Save As button to close the 
dialog box.

Note
It is recommended that you frequently save the file while you are working on it by pressing the 
CTRL+S keys.

Creating the Basic Shape of the Mug
In this section, you will use the Cylinder polygon primitive to create the basic shape of the mug.

1.	 Choose Create > Objects >Polygon Primitives > Cylinder > Option Box from the 
menubar; the Tool Settings (Polygon Cylinder Tool) window is displayed in the viewport. 
Enter the values in the Tool Settings (Polygon Cylinder Tool) window, as shown in 
Figure 2-52.

2.	 Click in the persp viewport; the cylinder is created, refer to Figure 2-53.

Figure 2-53  The cylinder created 
in the viewport

Figure 2-52   The Tool Settings (Polygon 
Cylinder Tool) window

3.	 In the Channel Box / Layer Editor, click on the pCylinder1 tab; a text box is activated. 
Next, type mug in the text box and press ENTER; the pCylinder1 tab is renamed as mug.
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4. 	 Hover the cursor in the persp viewport and press SPACEBAR;

Figure 2-54  Bottom vertices 
of the cylinder selected

 
the four viewports are displayed. Next, hover the cursor on the 
front viewport and press SPACEBAR; the front viewport is 
maximized. 

	 Select mug, if it is not selected, and then press and hold the right 
mouse button; a marking menu is displayed. 

 
5.	 Choose Vertex from the marking menu; the vertex selection 

mode is activated.

6.	 Select the vertices at the bottom of mug, refer to Figure 2-54. 
Next, invoke Scale Tool by pressing the R key.

7. 	 Scale down the selected vertices of mug inward, uniformly, as shown in Figure 2-55. Similarly, 
select the top vertices and scale the vertices to form the shape of a mug, refer to Figure 2-56.  

Figure 2-56  Basic shape of the mug 
created 

Figure 2-55  Bottom vertices of the 
cylinder scaled

	 Next, you need to add segments at the top and bottom. 

8.	 Make sure the Modeling menuset is selected in the Menuset drop-down list. Choose Mesh 
Tools > Tools > Insert Edge Loop from the menubar. Next, click at the top and bottom 
region of mug; two edges are inserted, refer to Figure 2-57. Deactivate the Insert Edge Loop 
tool by pressing the W key and then press 3 to view mug in the smooth mode. 

9.	 Maximize the persp viewport. Press 1 to switch back to the original mode. Make sure mug 
is selected and then press and hold the right mouse button; a marking menu is displayed. 
Choose Face from the marking menu; the face selection mode is activated. Now, select 
the top faces of mug using the SHIFT key, refer to Figure 2-58. Next, choose Edit Mesh > 
Components > Extrude from the menubar. 

10.	  Invoke the Scale Tool and scale down the selected faces uniformly, refer to Figure 2-59. 

11.	 Again, choose Edit Mesh > Components > Extrude from the menubar; the 
polyExttrudeFace2 In-View Editor is displayed in the viewport, refer to Figure 2-60. Enter 
-0.3 in the Thickness edit box of the polyExttrudeFace2 In-View Editor, refer to Figure 2-60; 
the shaded faces are extruded. 
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Figure 2-57  Two edges inserted at the top 
and bottom of the cylinder

Figure 2-58  Top faces of the cylinder 
selected

Figure 2-59  Selected top faces of the 
mug scaled down using Scale Tool

Figure 2-60  The polyExtrudeFace2 In-View 
Editor displayed

12.	 Press the G key to invoke the Extrude tool again and enter the value -1.6 in the Thickness 
edit box; the top faces of mug are extruded downward.

Note
The G key is used to repeat the last performed action in Maya.

13.  Press G again to invoke the Extrude tool, and enter the value -2 in the Thickness edit box. 
Next, enter 0.8 in the Offset edit box; the selected polygon is extruded inward.

14.  Maximize the top viewport such that you can view the inner area of mug. Press 3 to view 
the object in the smooth mode. To rectify the distortion in the geometry, you need to add 
edges. Press 1 and, choose Mesh Tools > Tools > Insert Edge Loop tool; the shape of the 
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cursor changes and then insert two edges inside the mug, refer to Figure 2-61. Deactivate the 
Insert Edge Loop tool by pressing W.

Figure 2-61  Two edge loops added inside the mug

Creating the Handle of the Mug
In this section, you need to create the handle of the mug.

1.	 Maximize the side viewport. Move the cursor over mug and then press and hold the right 
mouse button; a marking menu is displayed. Choose Edge from the marking menu; the 
edge selection mode is activated.

2.	 Select two edges of mug, refer to Figure 2-62. Next, choose Edit Mesh > Components > 
Bevel > Option Box; the Bevel Options dialog box is displayed. Now, enter the value 1 
in the Width edit box and choose the Bevel button; the selected edges will be beveled, as 
shown in Figure 2-63. 

3.	 Move the cursor over mug and then press and hold the right mouse button; a marking menu 
is displayed. Choose Face from the marking menu; the face selection mode is activated. 
Next, select a face of mug, as shown in Figure 2-64. 

Figure 2-62  Two edges of mug selected Figure 2-63  Selected edges beveled

4.	 Choose Edit Mesh > Components > Extrude from the menubar. Next, invoke Scale Tool 
by pressing the R key and scale down the selected face of mug uniformly upto 70%. You can 
check the scale size in the status line, as shown in Figure 2-65. 
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Figure 2-64  A face of mug selected Figure 2-65  Face of the mug scaled down

5.	 Select the face of mug, as shown in Figure 2-66. Repeat the procedure as done in Step 4 to 
scale down the face, refer to Figure 2-67.

Figure 2-66  A face of the mug selected Figure 2-67  A face of the mug scaled down

6.	 Maximize the persp viewport. Make sure that both the scaled faces are selected, and then 
invoke the Extrude tool by pressing the G key. Next, enter the value 0.8 in the Thickness 
edit box of the polyExtrudeFace4 In-View Editor.

7.	 Deactivate the Extrude tool by pressing the W key. Make sure the two extruded faces are 
selected. Next, choose Edit Mesh > Components > Bridge > Option Box from the 
menubar; the Bridge Options dialog box is displayed. Enter the values in the Bridge 
Options dialog box, as shown in Figure 2-68. Next, choose the Apply button and close the 
dialog box; the extruded faces are connected to each other.

8.	 Make sure mug is selected and then press and hold the right mouse button on it; a 
marking menu is displayed. Next, choose Object Mode from the marking menu; the 
object selection mode is activated.

9.   	Select mug and then choose Mesh > Remesh > Smooth from the menubar; the mesh of 
mug is smoothened. Press SPACEBAR; the four viewports display the mug after applying 
Smooth Tool, as shown in Figure 2-69.
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Figure 2-68  The Bridge Options dialog box

Figure 2-69  The mug displayed in all viewports

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Windows > Outliner from the menubar; the Outliner window is displayed. Select 
the persp camera in the Outliner window; the perspShape tab is displayed in Attribute 
Editor. 

2.	 In the perspShape tab, expand the Environment node and drag the Background Color 
slider bar toward right to change the background color to white. 
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Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the scene by downloading the c02_maya_2016_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Maya > 
Autodesk Maya 2016: A Comprehensive Guide

1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport. Choose the Render the current frame button from the Status 
Line; the Render View window is displayed. This window shows the final output of the scene, 
refer to Figure 2-51.

 Tutorial 2             
In this tutorial, you will create the model of a skateboard, as shown in Figure 2-70, using the 
polygon modeling techniques.                                                              (Expected time: 30 min)

Figure 2-70  The model of a skateboard

The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create the deck.
c.	 Create the base.
d.	 Create the wheels.
e.	 Change the background color of the scene.
f.	 Save and render the scene.

Creating a Project Folder
Create a new project folder with the name c02_tut2 at \Documents\maya2016 and then save the 
file with the name c02tut2, as discussed in Tutorial 1. 

Creating the Deck	
In this section, you need to create the deck of the skateboard using the Cube tool.

1.	 Maximize the top viewport. Choose Create > Objects > Polygon Primitives > Cube > Option 
Box from the menubar; the Tool Settings (Polygon Cube Tool) window is displayed on the left 
of the viewport. Enter the required values in the Tool Settings (Polygon Cube Tool) window, 
as shown in Figure 2-71. Next, click in the top viewport; a cube is created in the top viewport, 
as shown in Figure 2-72.
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Figure 2-71  The Tool Settings (Polygon 
Cube Tool) window

Figure 2-72  A cube created

2.	 In the Channel Box / Layer Editor, click on pCube1. Next, enter deck in the text box and 
press ENTER; the pCube1 is renamed as deck.

3.	 In the top viewport, press and hold the right mouse button on deck; a marking menu is 
displayed. Choose Vertex from the marking menu; the vertex selection mode is activated. 
Next, select the vertices, as shown in Figure 2-73. Next, choose Scale Tool by pressing the 
r key and scale the vertices uniformly, refer to Figure 2-74.

4.	 Similarly, scale the other vertices to create the basic shape of deck, as shown in Figure 2-75.

    

Figure 2-74  The selected 
vertices scaled

Figure 2-73  The vertices selected Figure 2-75  The basic 
shape of  the deck

5.	 Press and hold the right mouse button on deck; a marking menu is displayed. Next, choose 
Object Mode from the marking menu; the object selection mode is activated. Select deck 
and maximize the front viewport. 

6.	 Make sure the Modeling menuset is selected from the Menuset drop-down list in the Status 
Line. Next, choose Mesh Tools > Tools > Insert Edge Loop tool from the menubar; the 
shape of the cursor changes. Click on the top and bottom vertical edge and create two new 
segments on deck, as shown in Figure 2-76.
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7. 	 Maximize the top viewport and repeat the previous step to create two segments on deck, as 
shown in Figure 2-77. Choose the Select Tool to deactivate the Insert Edge Loop tool.

Figure 2-77  Two segments 
created in the top viewport

Figure 2-76  Two new segments created in 
the front viewport

8.	 Press and hold the right mouse button on deck; a marking menu is displayed. Choose Object 
Mode from the marking menu; the object selection mode is activated.

9.	 Make sure deck is selected and choose Mesh > Remesh > Smooth > Option Box from 
the menubar; the Smooth Options dialog box is displayed. In the Smooth Options dialog 
box, make sure the Division levels value is set to 1. Now, choose the Smooth button; the 
geometry of deck is smoothened.

Creating the Base
In this section, you need to create the base of the skateboard using the Cube polygon primitive.

1.	 Maximize the front viewport. Choose Create > Objects > Polygon Primitives > Cube > 
Option Box from the menubar; the Tool Settings (Polygon Cube Tool) window is displayed 
in the viewport. Enter the required values in the Tool Settings (Polygon Cube Tool) window, 
as shown in Figure 2-78. Next, click in the front viewport; a cube is created in the front 
viewport, as shown in Figure 2-79.

Figure 2-79  The cube createdFigure 2-78   The Tool Settings 
(Polygon Cube Tool) window
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2.	 In the Channel Box / Layer Editor, click on pCube1 tab. Next, enter base in the text box 
and press ENTER; pCube1 tab is renamed as base.

3.	 In the front viewport, press and hold the right mouse button on base; a marking menu is 
displayed. Choose Vertex from the marking menu; the vertex selection mode is activated. 
Next, select the two bottom center vertices and then choose the Move Tool from the Tool 
Box. Now, adjust the vertices on base to get the result shown in Figure 2-80.

4.	 Maximize the side viewport. Select the left most vertices in the side viewport and then drag 
them along the -Z axis to reduce the size of base, as shown in Figure 2-81.

Figure 2-81  Dragging the 
selected vertices along the -Z axis

Figure 2-80  The adjusted vertices of 
the base

5.	 Press and hold the right mouse button on base; a marking menu is displayed. Next, choose 
Object Mode from the marking menu; the object selection mode is activated.

6.	 Select base and maximize the front viewport. Next, choose Mesh Tools > Tools > Insert 
Edge Loop tool from the menubar. Using this tool, insert four new segments, as shown in 
Figure 2-82. Choose the Select Tool to deactivate the Insert Edge Loop tool.

Figure 2-82  Four new segments inserted in 
the front viewport

7.	 Press and hold the right mouse button on base; a marking menu is displayed. Choose Object 
Mode from the marking menu; the object selection mode is activated.

	
8.	 Select base and choose Mesh > Remesh > Smooth from the menubar; the geometry of base 

is smoothened. 

	 Next, you need to create the bolts.



2-32				                         Autodesk Maya 2016: A Comprehensive Guide
E

va
lu

at
io

n 
C

op
y.

 D
o 

no
t r

ep
ro

du
ce

. F
or

 in
fo

rm
at

io
n 

vi
si

t w
w

w
.c

ad
ci

m
.c

om

9.	 Choose Create > Objects > Polygon Primitives > Cylinder > Option box from the 
menubar; the Tool Settings (Polygon Cylinder Tool) window is displayed. Enter the required 
values in the Tool Settings (Polygon Cylinder Tool) window, as shown in Figure 2-83. Click 
in the front viewport; a cylinder is created. 

10.	 In the Channel Box / Layer Editor, click on

Figure 2-83  The Tool Settings (Polygon 
Cylinder Tool) window

 
pCylinder1. Next, enter bolt in the text box and 
press ENTER; pCylinder is renamed as bolt.

11.	 Choose Move Tool from the Tool Box and align 
bolt with base in all viewports. Next, choose the 
Rotate Tool from the Tool Box to rotate and align 
it with both front and side viewports, as shown in 
Figures 2-84 and 2-85.

12.	 Activate the side viewport. Make sure bolt is selected 
and press CTRL+D; a duplicate copy of bolt is created 
with the name bolt1. Set the following parameters in 
the Channel Box / Layer Editor of bolt1:

     	 Rotate X: 90	 	 Rotate Z: 0	

Figure 2-84  The cylinder rotated and 
aligned in the front viewport

Figure 2-85  The cylinder rotated 
and aligned in the side viewport

13.	 Choose Scale Tool from the Tool Box and scale bolt1 uniformly. Next, choose Move Tool 
from the Tool Box and align it in all viewports, as shown in Figure 2-86.

	 Next, you need to create truck.

14. Maximize the front viewport. Choose Create > Objects > Polygon Primitives > Cylinder > 
Option box from the menubar; the Tool Settings (Polygon Cylinder Tool) window is 
displayed in the viewport. In the Tool Settings (Polygon Cylinder Tool) window, set the 
parameters as follows:

	 Radius: 0.65		  Height: 1 			   Axis: Z
	 Axis divisions: 10 		  Height divisions: 3 		  Cap Divisions: 10
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Figure 2-86  Aligning bolt1 in all viewports

	 Next, click in the viewport; the cylinder is created, as shown in Figure 2-87.

Figure 2-87  The wheel aligned with bolt1 in all viewports

15.	 In the Channel Box / Layer Editor, click on pCylinder1. Next, enter truck in the text box 
and press ENTER; the pCylinder1 is renamed as truck.

16.	 Maximize the persp viewport. Press and hold the right mouse button over truck and choose 
Face from the marking menu displayed; the face selection mode is activated. Select the 
faces 1 and 5 of truck, refer to Figure 2-88. Next, choose Edit Mesh > Components > 
Extrude from the menubar; the polyExtrudeFace2 In-View Editor is displayed. Enter 1 in 
the Thickness edit box; the faces of truck are extruded, as shown in Figure 2-89. 
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Figure 2-89  The cylinder after 
extrusion in the persp viewport

Figure 2-88  The cylinder after 
extrusion in the persp viewport

17.	 Maximize the front viewport. Choose the Mesh Tools > Tools > Insert Edge Loop tool 
from the menubar and add new segments to truck, as shown in Figure 2-90. Choose Select 
Tool to deactivate Insert Edge Loop tool.

18.	 Press and hold the right mouse button on truck; a marking menu is displayed. Choose 
Object Mode from it; the object selection mode is activated. Next, select the truck and choose 
Mesh > Remesh > Smooth > Option Box from the menubar; the Smooth Options dialog 
box is displayed.

19.	 In the dialog box, enter 2 in the Division levels edit box and then choose the Smooth 
button; the geometry of truck is smoothened. Next, align truck, base, bolt and bolt1 in all 
viewports using the Move Tool, the Rotate Tool, and the Scale Tool uniformly, refer to 
Figure 2-91. 

Figure 2-90   New segments added to truck Figure 2-91  The parts aligned 
with base in the front viewport

20.	 Press and hold the SHIFT key and select base, truck, bolt, and bolt1 in the persp viewport. Next, 
choose Mesh > Combine > Combine from the menubar; the selected parts are combined 
and a group with the name base1 is created.

21. 	In the base1 area of the Channel Box / Layer Editor, enter 90 in the Rotate Y edit box and 
then press the ENTER key.

22.	 Align base1 in all viewports using Move Tool and Scale Tool from the Tool Box to make it 
proportional with the deck, as shown in Figure 2-92.
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Figure 2-92  The base1 aligned in all viewports

Creating Wheels
In this section, you need to create wheels for the skateboard using the Torus polygon primitive.

1.	 Choose Create > Objects >  Polygon Primitives > Torus from the menubar. Next, click 
in the top viewport to create a torus.

2. 	 In the INPUTS area of the Channel Box / Layer Editor, expand polyTorus1 node and set 
the following parameters:

	 Radius:  0.1		 Section radius:  0.1	

3.	 In the pTorus1 area of the Channel Box/Layer Editor, enter 90 in the Rotate Z edit box.

4.	 In the Channel Box / Layer Editor, rename pTorus1 as wheel, as done earlier. 

5.	 Scale and align wheel with bolt1 in all viewports using Move Tool from the Tool Box, as shown 
in Figure 2-93.

6.	 Maximize the front viewport. Make sure the wheel is selected and then press CTRL+D; a 
duplicate copy of wheel is created with the name wheel1. Next, move wheel1 in the opposite 
direction to wheel, as shown in Figure 2-94. 

7.	 Maximize the persp viewport. Select base1, wheel, and wheel1 by using the SHIFT key and then 
choose Mesh > Combine > Combine from the menubar; the selected parts are combined 
to form a single polygon object with the name base2.
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Figure 2-93  The wheel aligned with bolt1 in all viewports

8. 	 Choose Modify > Pivot > Center Pivot from the menubar; the pivot point of the combined 
base2 is set to center. Next, press CTRL+D; a duplicate copy of the selected mesh is created 
in the viewport.

9.	 Maximize the side viewport. Next, move base3 along the Z axis to align with deck and also 
enter 180 in the Rotate Y edit box to rotate base3, refer to Figure 2-95.

Figure 2-94  The wheel1 moved to 
opposite direction to wheel

Figure 2-95  The base3 moved and rotated

10. Select deck. Press and hold the right mouse button on deck; a marking menu is displayed. 
Choose Vertex from the marking menu; the vertex selection mode is activated. Next, select 
the vertices and move up along the Y axis using Move Tool, as shown in Figure 2-96.

11.	 Press and hold the right mouse button on deck; a marking menu is displayed. Choose Object 
Mode from the marking menu; the object selection mode is activated.

12.	 Maximize the persp viewport and select all parts of the skateboard in the persp viewport. 
Next, choose Mesh > Combine > Combine from the menubar; the selected parts are 
combined.
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Figure 2-96  Moving the selected vertices up along the Y axis

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Windows > Outliner from the menubar; the Outliner window is displayed. Select 
the persp camera in the Outliner window; the perspShape tab is displayed in the Attribute 
Editor. 

Note
If the Attribute Editor is not visible in the interface, press CTRL + A to make it visible.

2.	 In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view the 
final rendered image of the model by downloading the c02_maya_2016_rndr.zip file from www.
cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Maya > 
Autodesk Maya 2016: A Comprehensive Guide.

1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport, if it is not already maximized. Choose the Render the current 
frame button from the Status Line; the Render View window is displayed. This window 
shows the final output of the scene, refer to Figure 2-70.

 Self-Evaluation Test  
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following geometric shapes is formed by connecting a polygonal base and an 
apex?

		  (a) Prism			   (b) Pyramid
		  (c) Sphere	 		  (d) Cube
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2. 	 Which of the following shortcuts can be used to display an object in the object selection mode?
	
		  (a) F8	 			   (b) F9
		  (c) F10	 			   (d) F11

3.	 The __________ is used to merge two vertices together by dragging the source vertex toward 
the target vertex.

4.	 The __________ option is used to subtract the last selected geometry from the geometry 
that was selected first.

5.	 A __________ is a curve in three dimensional space such that its angle to a plane perpendicular 
to the axis is constant.

6. 	 The __________ solids are those primitives, in which all sides and angles are equal, and all 
faces are identical.

7.	 The __________ tool is used to reduce the number of polygons in the selected region of an 
object.

8. 	 The Insert Edge Loop Tool is used to create beveled transition surfaces on a profile curve. 
(T/F)

9. 	 The Chamfer tool is used to merge the selected edges and vertices that are within a 
numerically specified threshold distance from each other. (T/F)

10. 	The Bridge tool is used to connect two edges or two faces of a polygon object. (T/F)
 

 Review Questions 
Answer the following questions:

1.	 Which of the following tools is used to add smoothness to a sharp edge?

		  (a) Extrude			   (b) Duplicate face
		  (c) Bevel			   (d) Merge to Center

2. 	 Which of the following primitives is formed by an alternate arrangement of hexagons and 
pentagons?

		
		  (a) Prism			   (b) Helix
		  (c) Soccer ball			   (d) Sphere

3.	 The __________ option is used to create a duplicate copy of a selected face.

4.	 The __________ tool is used to add segments on both the sides of a selected edge.
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5.	 The __________ tool is used to ungroup the combined polygon objects into separate polygon 
objects.

6. 	 The __________ tool is used to make a polygon object smooth by adding divisions to it. 

7.	 The __________ operation is used to merge two intersecting objects by deleting the 
intersecting geometry between them. 

8. 	 The Combine tool is used to group two or more polygon meshes into a single polygon 
object. (T/F)

9. 	 The Multi-Cut tool is used to manually add segments between two edges of an object. (T/F)

10.	 The Detach tool is used to split a vertex into multiple vertices. (T/F)

EXERCISES 
The rendered output of the models used in the following exercises can be accessed by downloading 
the file c02_maya_2016_exr.zip from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > Maya > Autodesk Maya 2016: A Comprehensive Guide.

 Exercise 1                                                                      
Using various polygon modeling techniques, create the model of a USB cable, as shown in 
Figure 2-97.					                                        (Expected time: 30 min)

Figure 2-97  Model to be created in Exercise 1
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 Exercise 2                                                                   
Using various polygon modeling techniques, create a scene, as shown in Figure 2-98.		
	                                                                                                   (Expected time: 30 min)

Figure 2-98  Scene to be created in Exercise 2

 Exercise 3                                                                      
Using polygon primitive modeling techniques, create a scene, as shown in Figure 2-99.                                                       	
								              (Expected time: 30 min)
                                                								      
	  

Figure 2-99  Scene to be created in Exercise 3

 

Answers to Self-Evaluation Test
1. b, 2. a, 3. Merge Vertex Tool, 4. Difference, 5. helix, 6. platonic, 7. Reduce, 8. F, 9. F, 10. T


