
Chapter 3

 NURBS Curves and 
Surfaces

 Learning Objectives 
After completing this chapter, you will be able to:
• Create NURBS Primitives
• Create NURBS curves 
• Create surfaces
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INTRODUCTION
In Maya, there are three different types of modeling: NURBS, polygon, and subdivision surface. 
NURBS, which stands for Non-Uniform Rational B-Splines, is an industry standard for designing 
and modeling surfaces. NURBS modeling is suitable for modeling surfaces with complex curves. 
NURBS surfaces can be manipulated interactively with ease. Before modeling an object, you 
need to visualize it in 3D terms. Visualization of an object in 3D terms helps you in determining 
the type of modeling that you need to use for creating the object. In this chapter, you will learn 
about various NURBS modeling tools and techniques. 

NURBS PRIMITIVES
In this chapter, you will learn about NURBS curves and surfaces. NURBS (Non-Uniform Rational 
B-Spline) is a mathematical representation of 3D geometry that can describe any shape accurately. 
NURBS modeling is basically used for creating curved shapes and lines.

In Maya, there are default NURBS objects that resemble various geometrical objects. These 
NURBS objects are grouped together under the NURBS Primitives group in the menubar. 
To access the NURBS primitives, choose Create > Objects > NURBS Primitives from the 
menubar; a cascading menu will be displayed with all the default NURBS primitives. Some of 
the NURBS primitives can also be accessed from the Shelf, refer to Figure 3-1. In order to access 
the NURBS modeling tools for the NURBS primitives, make sure that the Curves/Surfaces 
Shelf tab is chosen from the Shelf. You need to turn on the Interactive Creation menu before 
creating the NURBS Primitives by click-drag method. To do so, choose Create > Objects > 
NURBS Primitives > Interactive Creation from the menubar. The different types of NURBS 
Primitives are discussed next.

Figure 3-1  Accessing NURBS primitives from the Shelf

Creating a Sphere
Menubar:	 Create > Objects > NURBS Primitives > Sphere 
Shelf:		  Curves / Surfaces > NURBS Sphere

A sphere is a solid object and every point on its surface is equidistant

Figure 3-2  The NURBS sphere

 
from its center, as shown in Figure 3-2. To create a sphere, 
choose Create > Objects > NURBS Primitives > Sphere from 
the menubar; the instructions to create a sphere will be 
displayed on the grid. Alternatively, choose the NURBS Sphere 
tool from the Curves/Surfaces Shelf tab. You can create a sphere 
either dynamically or by entering values using the keyboard. 
Both the methods are discussed next.
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Creating a Sphere Dynamically
To create a sphere dynamically, choose Create > Objects > NURBS Primitives > Sphere from 
the menubar; you will be prompted to drag the cursor on the grid to draw the sphere in the 
viewport. Press and hold the left mouse button, and drag the cursor up or down to define the 
radius of the sphere as required. Now, release the left mouse button; the sphere will be created 
in all viewports and will be visible in the Smooth Shade all mode. Press the numeric key 4 to 
change the display to the Wireframe mode. Alternatively, you can choose Shading > Wireframe 
from the Panel menu to change the display to the Wireframe mode. Press the numeric key 5 
or choose Shading > Smooth Shade All from the Panel menu to revert to the Smooth Shade 
all mode.

Creating a Sphere by Using the Keyboard
To create a sphere by using the keyboard, double-click on

Figure 3-3  The Tool Settings (NURBS 
Sphere Tool) window

 
the NURBS Sphere tool in the Curves/Surfaces Shelf 
tab; the Tool Settings (NURBS Sphere Tool) window 
will be displayed, as shown in Figure 3-3. In this 
window, set the properties of the sphere by using the 
keyboard and then click in the viewport; the sphere 
will be created in all viewports. Alternatively, choose 
Create > Objects > NURBS Primitives > Sphere > 
Option Box from the menubar; to invoke Tool 
Settings (NURBS Sphere Tool) window. Choose Reset 
Tool at the top of the Tool Settings (NURBS Sphere 
Tool) window to reset the settings of the NURBS 
Sphere tool. The most commonly used options in this 
window are discussed next.

Description Area
	 The text in the Description area gives you 

information about the method of creating sphere 
in the viewport.

Create Settings Area
The options in the Create Settings area of the Tool Settings

Figure 3-4  Partial sphere created

 
(NURBS Sphere Tool) window are used to adjust the 
parameters of the NURBS sphere. The options in this area 
are discussed next.

	 Start sweep angle and End sweep angle: The Start sweep 
angle and End sweep angle options are used to specify the 
start and end angles for a sphere. Move the sliders on the 
right of these parameters to change the values or enter the 
values in their respective text boxes. The values in these 
sliders range from 0 to 360 degrees. You can create partial 
sphere, as shown in Figure 3-4 by changing the values in 
the Start sweep angle and End sweep angle edit boxes.
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	 Surface degree: The Surface degree attribute is used to create a sphere with a faceted or 
smooth appearance. This attribute consists of two radio buttons: Linear and Cubic. The 
Linear radio button is used to give a faceted appearance to the sphere. The Cubic radio 
button is selected by default and gives a smooth appearance to the sphere, refer to Figure 3-5. 
Note that the number of segments remains the same on the sphere while using any of these 
two radio buttons.

Figure 3-5  The faceted and smooth appearances of spheres

	 Use Tolerance: The Use Tolerance attribute is used to improve the accuracy of the primitive’s 
by increasing or decreasing the number of sections and spans. If the Use Tolerance attribute 
is set to None, you can make the number of sections and spans on a sphere separately. If the  
Use Tolerance attribute is set to Local, you can change the number of sections and spans 
uniformly by moving the slider on the right of the attribute. If the Use Tolerance attribute 
is set to Global, you can change the number of sections and spans by moving the slider 
on the right of the Positional attribute in Windows > Editors > Settings/Preferences > 
Preferences.

	 Number of sections and Number of spans: The Number of sections and Number of 
spans edit boxes are used to adjust the surface curves on a sphere, refer to Figure 3-6. The 
more the number of sections or spans on a NURBS object, the more will be its smoothness. 
Surface curves are also known as Isoparms. You can enter the values directly in these edit 
boxes to set the number of sections/spans on a NURBS object. Alternatively, you can move 
the sliders on the right of these edit boxes.

Figure 3-6  The number of sections and spans on spheres
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After Creation Settings Area
	 The options in this area are used to adjust the number of sections and spans on a sphere 

after it is created in the viewport. To do so, select the Adjust sections and spans check box 
from this area and drag the cursor to create a sphere in the viewport. Next, you can drag 
the cursor to add or reduce sections in the sphere.

Single-click Settings Area
The options in this area are used to set the radius and axis of formation of the NURBS 
sphere. The settings of this area will be applicable only if the sphere is created using the 
single-click method. The options in this area are discussed next.

	 Radius: The Radius attribute is used to set the radius of the sphere by entering the required 
value in the Radius edit box. Alternatively, you can drag the slider on the right of the 
attribute. 

	 Axis: The Axis attribute is used to set the axis for creating a NURBS sphere. It has three 
radio buttons: X, Y, and Z. By default, the Y radio button is selected. You can use these 
radio buttons to set the axis for creating a NURBS sphere. Figure 3-7 shows the NURBS 
spheres created on the X, Y, and Z axes.

Figure 3-7  Spheres created on X, Y, and Z axes

Modifying the Names and other Parameters of the Sphere
You can change the name and parameters of a sphere in the

Figure 3-8  The Channel Box / 
Layer Editor

 
viewport. To do so, select a sphere in the viewport; the Channel 
Box / Layer Editor will be displayed, refer to Figure 3-8. Now, 
to change the name of the selected sphere, click on nurbsSphere# 
in the Channel Box / Layer Editor; an edit box will appear. 
Specify a new name for the sphere and then press ENTER. You 
can also modify the sphere by using the parameters in the 
INPUTS area of the Channel Box / Layer Editor; the change 
will be reflected on the sphere in the viewport. To dynamically 
modify the parameters in the INPUTS area, select the attribute 
label in the Channel Box / Layer Editor. Next, place the cursor 
in the viewport, press and hold the middle mouse button, and 
then drag it horizontally in the viewport to make the changes.
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Creating a Cube
Menubar:	 Create > Objects > NURBS Primitives > Cube 
Shelf:		  Curves / Surfaces > NURBS Cube

A cube is a three-dimensional shape with six

Figure 3-9  The NURBS cube

 
sides, as shown in Figure 3-9. To create a NURBS 
cube, choose Create > Objects > NURBS 
Primitives > Cube from the menubar; the 
instructions to create the cube will be displayed 
on the grid. Alternatively, to create a cube, you 
can choose the NURBS Cube tool from the 
Curves/Surfaces Shelf tab. You can also create 
a cube dynamically or by entering values using 
the keyboard. Both the methods are discussed 
next.

Creating a Cube Dynamically
To create a cube dynamically, choose Create > Objects > NURBS Primitives > Cube from the 
menubar; you will be prompted to drag the cursor on the grid to draw a cube in the viewport. 
Press and hold the left mouse button and drag the cursor on the grid to define the base of the 
cube, as required. Now, release the left mouse button to get the desired base. Next, press and 
hold the left mouse button again and drag the cursor up to set the height of the cube and then 
release the left mouse button; the cube will be created in all viewports.

Creating a Cube by Using the Keyboard 
To create a cube by using the keyboard, double-click on

Figure 3-10   The Tool Settings (NURBS 
Cube Tool) window

 
the NURBS Cube tool in the Curves/Surfaces Shelf 
tab; the Tool Settings (NURBS Cube Tool) window will 
be displayed on the left of the viewport, as shown in 
Figure 3-10. In this window, set the properties of the 
cube by using the keyboard and then click in the 
viewport; a cube will be created in all viewports. 
Alternatively, choose Create > Objects > NURBS 
Primitives > Cube > Option Box from the menubar; 
to invoke the Tool Settings (NURBS Cube Tool) 
window. Choose Reset Tool at the top of the Tool 
Settings (NURBS Cube Tool) window to reset the 
settings of the NURBS Cube tool. The most commonly 
used options in this window are discussed next.

	 Description Area
	 The Description area displays the information 

about the method of creating the cube in the 
viewport.

Create Settings Area
The options in the Create Settings area of the Tool 
Settings (NURBS Cube Tool) window are used 
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to set the parameters of the NURBS cube. Various options in this area are discussed next.

	 Surface degree: The radio buttons in the Surface degree attribute are used to create a cube 
with a faceted or smooth appearance. This attribute consists of five radio buttons: 1Linear, 
2, 3Cubic, 5, and 7.

	 U patches and V patches: The U patches and V patches edit boxes are similar to the 
Number of sections and Number of spans edit boxes in the Tool Settings (NURBS Sphere 
Tool) window and are used to create surface patches on the cube.

	 Single-click Settings: The options in this area are used to set the width, height, and depth 
for creating the NURBS cube. The settings will be applicable only if the cube is created 
using the single-click method.

Width, Height, and Depth: You can adjust the width, height, and depth of the NURBS cube 
by entering values in the Width, Height, and Depth edit boxes, respectively. Alternatively, 
you can set these values by moving the slider on the right of these edit boxes.

Modifying the Names and Other Properties of the Cube
You can modify the name and other properties of the cube using the Channel Box / Layer 
Editor, as discussed in the NURBS sphere section.

Creating a Cylinder 
Menubar:		  Create > Objects > NURBS Primitives > Cylinder 
Shelf:			   Curves / Surfaces > NURBS Cylinder

A cylinder is a solid geometry with straight parallel sides

Figure 3-11  The NURBS cylinder

 
and circular sections, as shown in Figure 3-11. To create 
a cylinder in the viewport, choose Create > Objects > 
NURBS Primitives > Cylinder from the menubar; the 
instructions to create the cylinder will be displayed on 
the grid in the viewport. Alternatively, you can choose 
the NURBS Cylinder tool from the Curves/Surfaces 
Shelf tab. You can create a cylinder either dynamically 
or by entering values using the keyboard. Both the 
methods of creating the cylinder are discussed next.

Creating a Cylinder Dynamically
To create a cylinder dynamically, choose Create > Objects > NURBS Primitives > Cylinder 
from the menubar; you will be prompted to drag the cursor on the grid. Press and hold the left 
mouse button and drag the cursor on the grid to define the base of the cylinder. Next, release 
the left mouse button to get the desired base. Now, press and hold the left mouse button again, 
drag the cursor up to set the height of the cylinder and then release the left mouse button; the 
cylinder will be created in all viewports.
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Creating a Cylinder by Using the Keyboard 
To create a cylinder by using the keyboard, double-click on the NURBS Cylinder tool in the 
Curves / SurfacesShelf tab; the Tool Settings (NURBS Cylinder Tool) window will be displayed, 
as shown in Figure 3-12. Set the properties of the cylinder to be created in the viewport 
using various options available in the Tool Settings (NURBS Cylinder Tool) window and click in 
the viewport; a cylinder will be created in all viewports. Alternatively, choose Create > Objects > 
NURBS Primitives > Cylinder > Option Box from the menubar to invoke the Tool Settings 
(NURBS Cylinder Tool) window. Choose Reset Tool at the top of the Tool Settings (NURBS 
Cylinder Tool) window to reset the settings of the NURBS Cylinder tool. The options in the 
Tool Settings (NURBS Cylinder Tool) window are similar to those of the NURBS Sphere tool.

Figure 3-12  The Tool Settings (NURBS Cylinder Tool) window

Modifying the Names and other Properties of the Cylinder
You can modify the name and properties of the cylinder by using the Channel Box / Layer 
Editor, as discussed in the NURBS sphere section.

Creating a Cone
Menubar:	 Create > Objects >NURBS Primitives > Cone 
Shelf:		  Curves / Surfaces > NURBS Cone

A cone is an object with a circular base and its sides tapered

Figure 3-13  The NURBS cone

 
up to a point, as shown in Figure 3-13. To create a cone, 
choose Create > Objects > NURBS Primitives > Cone from 
the menubar. Alternatively, you can create a cone by invoking 
the NURBS Cone tool from the Curves / Surfaces Shelf tab. 
You can create a cone either dynamically or by entering values 
using the keyboard. Both the methods of creating a cone are 
discussed next.
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Creating a Cone Dynamically
To create a cone dynamically, choose Create > Objects > NURBS Primitives > Cone from the 
menubar; you will be prompted to drag the cursor on the grid. Press and hold the left mouse 
button and drag the cursor on the grid to define the base of the cone. Next, release the left 
mouse button to get the desired base. Now, press and hold the left mouse button again and 
drag the cursor up to set the height of the cone. Next, release the left mouse button; the cone 
will be created in all viewports.

Creating a Cone by Using the Keyboard 
To create a cone by using the keyboard, double-click on

 Figure 3-14  The Tool Settings (NURBS 
Cone Tool) window

 
the NURBS Cone tool in the Curves / Surfaces Shelf 
tab; the Tool Settings (NURBS Cone Tool) window 
will be displayed on the left of the viewport, as shown 
in Figure 3-14. In this window, set the properties of 
the cone by using the keyboard and then choose the 
Create Button click in the viewport; the cone will be 
created in all viewports. Alternatively, choose Create > 
Objects > NURBS Primitives > Cone > Option Box 
from the menubar to invoke the Tool Settings (NURBS 
Cone Tool) window. Choose Reset Tool at the top of 
the Tool Settings (NURBS Cone Tool) window to 
reset the settings of the NURBS Cone tool. The 
options in the Tool Settings (NURBS Cone Tool) 
window are similar to those of the NURBS Sphere 
tool.

Creating a Plane
Menubar:	 Create > Objects > NURBS Primitives > Plane 
Shelf:		  Curves / Surfaces > NURBS Plane

A plane is a two-dimensional flat surface, as shown in

Figure 3-15  The NURBS plane

 
Figure 3-15. To create a NURBS plane, choose Create > 
Objects > NURBS Primitives > Plane from the 
menubar. Alternatively, you can create a plane by 
invoking the  NURBS Plane  too l  f rom the 
Curves / Surfaces Shelf tab. You can create a plane either 
dynamically or by entering values using the keyboard. 
Both the methods of creating a plane are discussed next.

Creating a Plane Dynamically
To create a plane dynamically, choose Create > Objects > NURBS Primitives > Plane from 
the menubar; you will be prompted to drag the cursor on the grid. Next, press and hold the 
left mouse button and drag the cursor on the grid; the plane will be created in all viewports.
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Creating a Plane by Using the Keyboard  

Figure 3-16  The Tool Settings (NURBS 
Plane Tool) window

 
To create a plane by using the keyboard, double-click on 
the NURBS Plane tool in the Curves / Surfaces Shelf 
tab; the Tool Settings (NURBS Plane Tool) window 
will be displayed on the left of the viewport, as shown 
in Figure 3-16. Next, in this window, set the properties 
of the plane by using the keyboard and then click in 
the viewport; the plane will be created in all viewports. 
Alternatively, choose Create > Objects > NURBS 
Primitives > Plane > Option Box from the menubar to 
invoke the Tool Settings (NURBS Plane Tool) window. 
Choose Reset Tool at the top of the Tool Settings 
(NURBS Plane Tool) window to reset the settings of the 
NURBS Plane tool. The options in the Tool Settings 
(NURBS Plane Tool) window are similar to those of the 
NURBS Cube tool.

Creating a Torus
Menubar:	 Create > Objects > NURBS Primitives > Torus 
Shelf:		  Curves / Surfaces > NURBS Torus

A torus is created by revolving a circular profile around a circular or an 

Figure 3-17  The NURBS 
torus

elliptical path, as shown in Figure 3-17. To create a NURBS torus, 
choose Create > Objects > NURBS Primitives > Torus from the 
menubar. Alternatively, you can create a torus by choosing the NURBS 
Torus tool from the Curves / Surfaces Shelf tab. You can create a 
torus either dynamically or by entering values using the keyboard. 
Both the methods of creating a torus are discussed next.

Creating a Torus Dynamically
To create a torus dynamically, choose Create > Objects > NURBS 
Primitives > Torus from the menubar; you will be prompted to drag the cursor on the grid 
to create a torus in the viewport. Press and hold the left mouse button, drag the cursor on the 
grid to define the radius of the torus, and then release the left mouse button. Now, press and 
hold the left mouse button again and drag the cursor to edit the section radius. Next, release 
the left mouse button; the torus will be created in all viewports.

Creating a Torus by Using the Keyboard 
To create a torus by using the keyboard, double-click on the NURBS Torus tool in the Curves / 
Surfaces Shelf tab; the Tool Settings (NURBS Torus Tool) window will be displayed, as shown in 
Figure 3-18. In this window, set the properties of the torus by using the keyboard and then click 
in the viewport to create a torus. Alternatively, choose Create > Objects > NURBS Primitives > 
Torus > Option Box from the menubar to invoke the Tool Settings (NURBS Torus Tool) window. 
Choose the Reset Tool button at the top of the Tool Settings (NURBS Torus Tool) window to 
reset the settings of the NURBS Torus tool. The options in the Tool Settings (NURBS Torus 
Tool) window are similar to those of the NURBS Sphere tool.
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Figure 3-18  The Tool Settings (NURBS Torus Tool) window

Creating a Circle
Menubar:	 Create > Objects > NURBS Primitives > Circle 
Shelf:		  Curves / Surfaces > NURBS Circle

A circle is a closed plane curve in which every point on the curve

Figure 3-19  The NURBS circle

 
is equidistant from the center, as shown in Figure 3-19. To 
create a circle, choose Create > Objects > NURBS 
Primitives > Circle from the menubar. Alternatively, you can 
create a circle by choosing the NURBS Circle tool from the 
Curves / Surfaces Shelf tab. You can create a circle either 
dynamically or by entering values using the keyboard. Both 
the methods of creating a circle are discussed next.

Creating a Circle Dynamically
To create a circle dynamically, choose Create > Objects > NURBS Primitives > Circle from 
the menubar; you will be prompted to drag the cursor on the grid. Press and hold the left mouse 
button and drag the cursor on the grid and then release the left mouse button; the circle will 
be created in all viewports. 

Creating a Circle by Using the Keyboard
To create a circle by using the keyboard, double-click on the NURBS Circle tool in the Curves 
Shelf tab; the Tool Settings (NURBS Circle Tool) window will be displayed, as shown in 
Figure 3-20. In this window, set the properties of the circle by using the keyboard and then click 
in the viewport to create a circle in all viewports. Alternatively, choose Create > Objects > 
NURBS Primitives > Circle > Option Box from the menubar to invoke the Tool Settings 
(NURBS Circle Tool) window. Choose the Reset Tool button at the top of the Tool Settings 
(NURBS Circle Tool) window to reset the settings of the NURBS Circle tool. The options in 
this window are similar to those of the NURBS Sphere tool.
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       Figure 3-20  The Tool Settings (NURBS Circle Tool) window

Creating a Square
Menubar:	 Create > Objects > NURBS Primitives > Square 
Shelf:		  Curves / Surfaces > NURBS Square

A square is a four-sided regular polygon with equal sides,

Figure 3-21  The NURBS square

 
as shown in Figure 3-21. To create a square, choose 
Create > Objects > NURBS Primitives > Square from the 
menubar. Alternatively, you can create a square by 
invoking the NURBS Square tool from the Curves Shelf 
tab. You can create a square either dynamically or 
by entering values by using the keyboard. Both the methods 
of creating a square are discussed next.

Creating a Square Dynamically
To create a square dynamically, choose Create > Objects > NURBS Primitives > Square from 
the menubar; you will be prompted to drag the cursor on the grid. Press and hold the left mouse 
button and drag the cursor on the grid. Next, release the left mouse button; the square will be 
created in all viewports.

Creating a Square by Using the Keyboard
To create a square by using the keyboard, double-click on the NURBS Square tool in the Curves 
Shelf tab; the Tool Settings (NURBS Square Tool) window will be displayed on the left of the 
viewport, as shown in Figure 3-22. Set the properties of the square using various options available 
in the Tool Settings (NURBS Square Tool) window and click in the viewport to create a square 
in all viewports. Alternatively, choose Create > NURBS Primitives > Square > Option Box 
from the menubar to invoke the Tool Settings (NURBS Square Tool) window. Choose the  Reset 
Tool button at the top of the Tool Settings (NURBS Square Tool) window to reset the settings 
of the NURBS Square tool. The options in this window are similar to those discussed in the 
NURBS Cube tool.
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     Figure 3-22  The Tool Settings (NURBS Square Tool) window

Interactive Creation
Menubar:	 Create > Objects > NURBS Primitives > Interactive Creation

The Interactive Creation option is used to create objects dynamically. It is a toggle option in the 
NURBS Primitives cascading menu. The Interactive Creation option is not selected by default. To 
select this option, choose Create > Objects > NURBS Primitives > Interactive Creation from 
the menubar. It allows you to edit an object as required. If you clear this option, you need to 
modify the object using the Channel Box. 

Exit on Completion
Menubar:	 Create > Objects > NURBS Primitives > Exit on Completion

The Exit on Completion option is used to exit the Nurbs Primitive command after the 
creation of a primitive in the viewport. To do so, choose Create > NURBS Primitives > Exit on 
Completion from the menubar. Deselect this option to interactively create multiple primitives of 
the same type until another tool is chosen. This option is activated only when the Interactive 
Creation option is selected.

WORKING WITH NURBS COMPONENTS
Each NURBS object has certain components such as Isoparm, Hull, Surface Patch, Surface UV, 
Control Vertex, and Surface Point, refer to Figures 3-23 to 3-28. To view the components of a 
NURBS object, select the NURBS object in the viewport and choose Display > NURBS from 
the menubar; a cascading menu will be displayed. Choose the component that you want to 
modify from the cascading menu; the selected component will be displayed in the viewport. 
Alternatively, press and hold the right mouse button over the object and choose the required 
component from the marking menu. 
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Figure 3-26  Control Vertex of the NURBSFigure 3-25  Isoparm of the NURBS

Figure 3-23  Surface Patch of the NURBS Figure 3-24  Surface Point of the NURBS

 Figure 3-28  Surface UV of the NURBSFigure 3-27  Hull of the NURBS

TOOLS FOR CREATING NURBS CURVES
In Maya, you can create NURBS curves using various tools. The tools used to create NURBS 
curves are discussed next.

CV Curve Tool
Menubar:	 Create > Objects > CV Curve Tool 

The CV Curve Tool is used to create curves in the viewport. A CV curve comprises of 
control vertices or CVs. To create a CV curve, choose Create > Objects > Curve Tools > 
CV Curve Tool from the menubar; the cursor will change into a plus sign. Next, click 

on different places in the viewport to create a curve. The first CV of the curve will be displayed 
as a box, and the second CV will be displayed as letter U. The box defines the starting point of 
the curve, and the letter U defines the direction of the curve. Press ENTER to finish the curve 
creation process. To edit the properties of a curve, choose Create > Objects > Curve Tools > 
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CV Curve Tool Option Box from the menubar; the Tool Settings (CV Curve Tool) window will 
be displayed, as shown in Figure 3-29. The options in the window are discussed next.

Figure 3-29  The Tool Settings (CV Curve Tool) window

Curve degree
The radio buttons corresponding to the Curve degree attribute are used to define the smoothness 
of a curve. By default, the 3 Cubic radio button is selected in the Curve degree area. The higher 
the degree of curve, the smoother it will be. 

Knot spacing
The radio buttons corresponding to the Knot spacing attribute are used to define the distribution 
of the knots on the curve. Knots are the parametric locations(u) along the curve. The Knot 
spacing attribute has two radio buttons: Uniform and Chord length. The Uniform radio button 
is selected by default and is used to create the U parametric location values that are easier to 
predict. The Chord length radio button is used to distribute the curvature in such a way that 
the surface displays a symmetrical texture applied over it.

Tip  By default, CV Curve Tool is not present in the Curves Shelf tab. To add CV Curve 
Tool to the Shelf, press and hold CTRL+SHIFT and choose Create > CV Curve Tool 
from the menubar; CV Curve Tool icon will be displayed in the Shelf.

EP Curve Tool
Menubar:	 Create > Objects > Curve Tools > EP Curve Tool 
Shelf:		  Curves/Surfaces > EP Curve Tool

The EP Curve Tool is also used to create an outline of a curve by placing edit points on 
it. To create an outline, choose Create > Objects > Curve Tools > EP Curve Tool from 
the menubar; the cursor sign will change into a plus sign. Now, click on different places 

in the viewport to create a curve. Next, press ENTER to finish the curve creation process. To 
modify the properties of the EP curve, choose Create > Objects > Curve Tools > EP Curve 
Tool > Option Box from the menubar; the Tool Settings (EP Curve Tool) window will be 
displayed. Alternatively you can invoke this window form the Curve / Surfaces Shelf tab by 
double-click on the icon in the Shelf tab; the Tool Settings (EP Curve Tool) window will be 
displayed. The options in the Tool Settings (EP Curve Tool) window are similar to those discussed 
in the Tool Settings (CV Curve Tool) window.
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Note
The process of creating a curve using EP Curve Tool is different from that of CV Curve Tool. In 
both the cases, if 3 cubic is selected from the Curve degree attribute, then the curve created using 
CV Curve Tool will create a smooth curve in the fourth segment, whereas in case of EP curve Tool, 
a smooth curve will be created in the third segment.

Pencil Curve Tool
Menubar:	 Create > Objects > Curve Tools > Pencil Curve Tool 
Shelf:		  Curves / Surfaces > Pencil Curve Tool

The Pencil Curve Tool works similar to the brush tool available in other softwares. This 
tool is used to draw a freehand NURBS curve. To do so, choose Create > Objects > 
Curve Tools > Pencil Curve Tool from the menubar; the cursor will change into a pencil 

sign. Next, press and hold the left mouse button and drag the cursor in the viewport to create 
a curve. To set the properties of the curve, choose Create > Objects > Curve Tools > Pencil 
Curve Tool > Option Box from the menubar; the Tool Settings (Pencil Curve Tool) window 
will be displayed. Alternatively you can invoke this window form the Curves/Surfaces Shelf tab 
by double-click on the icon in the Curves/Surfaces Shelf tab; the Tool Settings (Pencil Curve 
Tool) window will be displayed. The options in the Tool Settings (Pencil Curve Tool) window 
are similar to those discussed in the Tool Settings (EP Curve Tool) window.

Arc Tools
Menubar:	 Create > Objects > Curve Tools 
Shelf:		  Curves / Surfaces > Three Point Circular Arc           

The Arc Tools are used to create arc curves by specifying points in the viewport. In Maya, 
there are two types of arc tools: Three Point Circular Arc and Two Point Circular Arc. 
To create an arc, choose Create > Objects > Curve Tools from the menubar; a cascading 

menu will be displayed. Choose Two Point Circular Arc from the cascading menu to create an 
arc by defining the start and end points of the arc. Similarly, choose the Three Point Circular 
Arc from the cascading menu to create an arc by defining the start point, the curve point, and 
the end point.

TOOLS FOR CREATING SURFACES
Maya provides a number of tools to create complex three dimensional

Figure 3-30  The Surface 
floating menu

 
surface models. To view the tools that are used to create various 
surfaces, select the Modeling option from the Menuset 
drop-down list in the Status Line. Next, choose the Surfaces menu 
to display all the surfacing tools in Maya, refer to Figure 3-30.  

Loft Tool
Menubar:	 Surfaces > Create > Loft 

The Loft tool is used to skin a surface along the profile curves. While 
using this tool, at least two profile curves are required to create a 
NURBS surface. To create a NURBS surface by using this tool, 
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create three curves, as shown in Figure 3-31. Next, press and hold the SHIFT key and select the 
curves in the viewport. Now, choose Surfaces > Create > Loft from the menubar; the NURBS 
curves are lofted with a surface in the viewport, as shown in Figure 3-32. To set the properties of 
the lofted surface created, choose Surfaces > Create > Loft > Option Box from the menubar; 
the Loft Options dialog box will be displayed, as shown in Figure 3-33. The options in the Loft 
Options dialog box are discussed next.

Figure 3-32  The lofted surface created 
after applying the Loft tool

Figure 3-31  The NURBS curves before 
applying the Loft tool

Figure 3-33  The Loft Options dialog box

Parameterization
The radio buttons corresponding to the Parameterization attribute are used to modify the 
parameters of the lofted surface. The Uniform radio button is used to set the number of control 
points uniformly along the curve. The Chord length radio button is used to parameterize the 
curve such that its value is proportional to the chord length. The Auto reverse check box is 
selected by default and is used to create a NURBS surface in the reverse order of selection 
of NURBS curves. Figure 3-34 shows the surface created with the Close check box cleared. 
Figure 3-35 shows the surface created with the Close check box selected. 
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Figure 3-35  Surface created with the Close check 
box selected

Figure 3-34 Surface created with the Close 
check box cleared

Surface degree
The Surface degree attribute is used to specify the smoothness 

Figure 3-36  NURBS curves for 
creating a surface

of a NURBS surface. The Cubic radio button corresponding to 
this attribute is selected by default. The Linear radio button is 
used to create the surface with edgy facets. To create a NURBS 
surface, choose Create > Objects > Curve Tools > CV Curve 
Tool from the menubar and then create NURBS curves in the 
viewport, as shown in Figure 3-36. Next, select the Linear or 
Cubic radio button corresponding to the Surface degree 
attribute in the Loft Options dialog box; the NURBS surfaces 
will be displayed, as shown in Figures 3-37 and 3-38.

Figure 3-38  Surface created on selecting the 
Cubic radio button

Figure 3-37 Surface created on selecting the 
Linear radio button

Section spans
The Section spans edit box is used to specify the number of spans on the NURBS surface. To 
do so, enter a value in the edit box to specify the number of sections in the NURBS surface. 
Alternatively, adjust the slider on the right of the Section spans edit box. More the number of 
spans, more will be the smoothness of the NURBS surface.



NURBS Curves and Surfaces		         3-19

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Output geometry
The options in the Output geometry are used to specify the type of outputs of the NURBS 
surface. Select the required radio button to get the output surface as NURBS, Polygons, or 
Bezier. After setting the options in the Loft Options dialog box, choose the Loft button to 
create a NURBS surface. 

Alternatively, choose the Apply button to create a NURBS surface. The function of the Loft 
and the Apply buttons is quite similar. On choosing the Loft button, the loft command will be 
applied to the NURBS curves and the Loft Options dialog box will be closed. On the other 
hand, on choosing the Apply button, the loft command will be applied to the NURBS curves 
without closing the Loft Options dialog box. 

Planar Tool
 Menubar:	 Surfaces > Create > Planar 

The Planar tool is used to create a NURBS surface with all the vertices lying on the same plane. 
To create a NURBS surface using this tool, create a close curve using a curve tool. The curve 
should form a close loop and should at least have three sides. Next, choose Surfaces > Create > 
Planar from the menubar; a NURBS surface will be created. To set the properties of the NURBS 
surface, choose Surfaces > Create > Planar > Option Box from the menubar; the Planar 
Trim Surface Options dialog box will be displayed, as shown in Figure 3-39. The options in 
this dialog box are discussed next.

Figure 3-39  The Planar Trim Surface Options dialog box

Degree
The radio buttons corresponding to the Degree attribute are used to add smoothness to the 
edges of the surface created. By default, the Cubic radio button is selected. As a result, a planar 
surface with smooth edges is created. You can select the Linear radio button to create a planar 
surface with rough edges.
 
Curve range
The radio buttons corresponding to the Curve range attribute are used to set curves for creating 
a planar surface. The Complete radio button is selected by default and is used to create a planar 
surface along the selected curve. The Partial radio button is used to display manipulators on the 
planar surface using Show Manipulator tool and edit the plane along the input curve.  
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Output geometry
The Output geometry attribute specifies the type of geometry to be created. Select the NURBS 
radio button to set the output geometry as NURBS. Select the Polygons radio button to set the 
output geometry as polygon.

Revolve Tool
Menubar:	 Surfaces > Create  > Revolve 

The Revolve tool is used to create a surface around a profile curve along a selected axis. The axis 
of revolution depends on the location of the pivot point of an object. To create a revolved surface, 
choose Create > Objects > Curve Tools > EP Curve Tool from the menubar and then create 
a profile curve in the front viewport, refer to Figure 3-40. Select the profile curve and choose 
Surfaces > Create > Revolve from the menubar; the profile curve will rotate around its pivot 
point, thus creating a revolved surface, as shown in Figure 3-41. Alternatively, you can choose 
Surfaces > Create > Revolve > Option Box from the menubar; the Revolve Options dialog 
box will be displayed, as shown in Figure 3-42. The options in this dialog box are discussed next.

Figure 3-41  The NURBS surface
created after using the Revolve tool

Figure 3-40  The profile curve created

Figure 3-42  The Revolve Options dialog box
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Axis preset 
The options corresponding to the Axis preset parameter are used to set the axis about which 
the curve will revolve. You can select the required radio button to set the axis of revolution of 
the curve. By default, the revolution axis is Y. You can also select the Free radio button to enter 
the value of the axis manually.

Axis
The edit boxes corresponding to the Axis attribute are inactive by default. On selecting the 
Free radio button in the Axis preset attribute, the Axis edit boxes will be enabled. Now, you 
can specify the axis about which you want to revolve the NURBS curve in the viewport.

Pivot
The options corresponding to the Pivot attribute are used to define the rotation of the object 
from the default pivot location. It has two radio buttons: Object and Preset. The Object radio 
button is selected by default and is used to rotate an object at the default pivot location (0, 0, 0). 
Select the Preset radio button to change the X, Y, and Z location of the pivot point. 

Surface degree
The Surface degree attribute is used to determine whether the direction of the surface created 
will be linear or cubic. It has two radio buttons: Linear and Cubic. If you select the Linear radio 
button, the surface will be formed with edgy facets. If you select the Cubic radio button, the 
edgy facets of the surface will become smooth. 

Start sweep angle and End sweep angle 
The Start sweep angle and End sweep angle edit boxes are used to define the degree of revolution 
of a curve. By default, the values in these edit boxes are set to 0 and 360, respectively. You can 
drag the slider next to these edit boxes to change the values as required.

Use tolerance
The radio buttons corresponding to the Use tolerance attribute are used to define the accuracy 
of the revolved NURBS surface. There are three radio buttons in this area: None, Local, and 
Global. By selecting the None radio button, you can make changes in the number of segments of 
the NURBS surface. The more the number of segments, the more will be the smoothness of 
the NURBS surface.

Segments
The Segments attribute is used to set the number of segments that are used to create the 
revolved surface. More the number of segments, more will be the smoothness of the surface. 
Either enter the required value in the attribute or drag the slider next to it. The default value 
in this attribute is 8.

Curve range
The Curve range attribute is used to determine whether the entire profile will be revolved or 
only a part of profile curve will be revolved about its pivot point. There are two radio buttons 
corresponding to the Curve range attribute: Complete and Partial. The Complete radio button 
is selected by default and is used to revolve the entire profile curve about the pivot point. The 
Partial radio button is used to create a revolved surface by revolving a part of profile curve about 
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its pivot point. You can also edit the curve range for rotation. To do so, 

Figure 3-43  Dragging the 
Curve Segment Manipulator

select the revolved surface in the viewport; the Channel Box / 
Layer Editor will be displayed. Next, choose subCurve1 from the 
INPUTS area; the subCurve1 options will be displayed in the 
Channel Box / Layer Editor. Set the Min Value and the Max 
Value of subCurve1 in the Channel Box / Layer Editor. Alternatively, 
you can edit subCurve1 by using the Show Manipulator Tool. Choose 
Modify > Transform > Transformation Tools > Show Manipulator 
Tool from the menubar. Next, drag the Curve Segment Manipulator 
to set the partial curve range, refer to Figure 3-43, and then choose 
the Revolve tool to create the NURBS surface.

Output geometry
The Output geometry parameter is used to define the type 
of geometry to be created using the NURBS curve. The radio 
buttons in this area are used to convert the NURBS curve into four 
different types of geometries: NURBS, Polygons, Subdiv, and Bezier 
(Subdiv refers to subdivision surfaces). Select the required geometry 
to set the type of output geometry.

Birail Tool
Menubar:	 Surfaces > Create > Birail 

The Birail tool works similar to the Extrude tool. This tool is used to create surfaces using one  
curve or two profile curves along two path curves. You can create complex NURBS surfaces 
using this tool. Maya has three different types of Birail tools: Birail 1 Tool, Birail 2 Tool, and 
Birail 3+ Tool. Before creating a NURBS surface using different Birail tools, the following 
points should be kept in mind:

1. 	 The profile curves and the path curves must touch each other and have continuity.

2. 	 All profile curves should have the same number of CVs.

3. 	 All path curves should also have the same number of CVs.

4. 	 Press V to snap the vertex of the profile curve and the path curve together.

5. 	 If the profile curve and the path curve do not have the same number of CVs, you will have 
to draw the curves again.

Extrude Tool
Menubar:	 Surfaces > Create > Extrude 

The Extrude tool is used to extrude a particular object by sweeping its profile curve along the 
path curve. To extrude a surface, two curves are required: a profile curve and a path curve. The 
profile curve gives shape to a surface, whereas the path curve defines the path on which the 
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shape will sweep to create a surface. To create an extruded surface, select the two curves in the 
viewport. The first curve selected will act as the profile curve, whereas the second curve will act 
as the path curve. Now, choose Surfaces > Create > Extrude from the menubar to extrude 
the surface. You can use this method to create objects such as curtains, parts of a vehicle, and 
so on. To adjust the properties of the Extrude tool, choose Surfaces > Create > Extrude > 
Option Box from the menubar; the Extrude Options dialog box will be displayed, as shown in 
Figure 3-44. The options in this dialog box are discussed next.

Figure 3-44  The Extrude Options dialog box

Style
The Style attribute consists of three radio buttons: Distance, Flat, and Tube. The Tube radio 
button is selected by default and is used to maintain a cross-section along the path, with the 
reference vector remaining tangent to the path. The Distance radio button is used to extrude 
the profile in a straight line. The Flat radio button is used to maintain the orientation path of 
the profile curve.

 
Result position
The radio buttons corresponding to the Result position attribute are used to set the position 
at which the extruded surface will be created. By default, the At profile radio button is selected. 
It is used to position the extruded surface along the profile curve. The At path radio button is 
used to set the position of the extruded surface along the path curve. This attribute is available 
only if you set the Style to Tube or Flat.

Pivot
The Pivot attribute is used to set the pivot point of an extruded surface and will be 
activated only when the Tube radio button is selected in the Style attribute. The two radio 
buttons corresponding to the Pivot attribute are: Closest end point and Component. By default, 
the Closest end point radio button is selected. As a result, an extruded surface is created close 
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to the center of the bounding box of the profile curves. The Component radio button is used 
to create an extruded surface along the components of the profile curve. Figure 3-45 shows a 
profile curve and a path curve to create an extruded surface. Figures 3-46 and 3-47 show extruded 
surfaces created on selecting the Closest end point and Component radio buttons, respectively. 

Figure 3-45  The profile curve and the path 
curve for creating an extruded surface

Figure 3-46  Extruded surface created on selecting the Closest end point radio button 

Figure 3-47  Extruded surface created on selecting the Component radio button

Orientation
The radio buttons corresponding to the Orientation attribute are used to set the orientation of 
an extruded surface. The Orientation attribute is available only when the Tube radio button is 
selected in the Extrude Options dialog box. The Path direction radio button is used to extrude 
the profile curve along the direction of path curve. By default, the Profile normal radio button 
is selected. The Profile normal radio button is used to extrude the surface such that the path 
curve is created normal to the profile curve.

Rotation
The Rotation attribute is used to rotate the profile curve along path. To do so, specify the angle 
of rotation in this attribute.
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Scale
The Scale attribute is used to scale the profile while extruding it along the path curve. To do 
so, specify the scale factor in this attribute.

Curve range and Output geometry
The radio buttons corresponding to the Curve range and Output geometry attributes are the 
same as discussed in the revolved surface section. On selecting the Distance radio button from 
the Style attribute, some other options are displayed, as shown in Figure 3-48. These options 
are discussed next.

Figure 3-48  The Extrude Options dialog box with the Distance 
radio button selected

Extrude length
The Extrude length attribute is used to define the length of extrusion.

Direction
The radio buttons corresponding to the Direction attribute is used to define the direction of 
extrusion. It consists of two radio buttons: Specify and Profile normal. The Profile normal 
radio button is used to set the direction of the path to normal. The Specify radio button is used 
to manually set the direction for creating the surface in a particular axis. For example, if you 
select the X-axis, the extrusion will take place only in the X-direction.

Surface degree
The Surface degree attribute is used to give smoothness or sharpness to the surface created. This 
attribute consists of two radio buttons: Linear and Cubic. The Linear radio button is used to 
create sharp edges near the isoparms. The Cubic radio button is used to create smooth surfaces. 
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Boundary Tool
Menubar:  	 Surfaces > Create > Boundary 

The Boundary tool is used to create a surface by filling the boundary curves. This tool creates a 
NURBS surface by filling the space between the curves. It is not necessary for the curves to have a 
closed loop, but they should intersect with each other at some point. To apply the Boundary tool, 
create four curves in the viewport, as shown in Figure 3-49. Press and hold the SHIFT key and 
select all the curves in opposite pairs to maintain continuity. Now, choose Surfaces > Create > 
Boundary from the menubar to create the NURBS surface. To adjust the properties of the 
Boundary tool, choose Surfaces > Create > Boundary > Option Box from the menubar; the 
Boundary Options dialog box will be displayed, as shown in Figure 3-50. The options in this 
dialog box are similar to those discussed in other surfacing tools.

Figure 3-49  Four NURBS curves created

Figure 3-50  The Boundary Options dialog box

Square Tool
Menubar:  	 Surfaces > Create > Square 

The Square tool is used to create a four-sided NURBS surface from the intersecting curves. 
On choosing this tool, a NURBS surface is created by filling the region defined by four 
intersecting curves. This tool is similar to the Boundary tool with the only difference that in the 
Boundary tool, you can select curves in any order, whereas in the Square tool, you need to select 
them in clockwise or counterclockwise direction. To use this tool, create four intersecting curves 
in the viewport. Next, press and hold the SHIFT key and select the curves either in clockwise 
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or counterclockwise direction. Now, choose Surfaces > Create > Square from the menubar; 
the NURBS surface will be created.

Bevel Tool
Menubar:	 Surfaces > Create > Bevel 

The Bevel tool is used to create a NURBS surface by using the 

Figure 3-51  A NURBS circle

three-dimensional edge effect applied on the selected curves. 
The surface created by the Bevel tool has an open area that can 
be filled by using the Planar tool. To create a surface by using 
the Bevel tool, create a NURBS circle in the top viewport, as 
shown in Figure 3-51. Next, choose Surfaces > Create > Bevel 
from the menubar; a beveled surface will be created, as shown 
in Figure 3-52. You can adjust the properties of the beveled 
surface in the Channel Box / Layer Editor by changing the 
values in the bevel1 node of the INPUTS area as required, refer 
to Figure 3-53.

Figure 3-52  The bevel surface created
Figure 3-53  The bevel1 node in 
the INPUTS area

Bevel Plus Tool
Menubar:	 Surfaces > Create > Bevel Plus 

The Bevel Plus tool is used to extrude the closed curves

Figure 3-54  A NURBS circle created in 
the top viewport

 
and add beveled transition to the extruded surface. 
To create a surface by using this tool, create a NURBS 
circle in the top viewport, as shown in Figure 3-54 and 
then choose Surfaces > Create > Bevel Plus from the 
menubar; a beveled surface will be created, as shown in 
Figure 3-55. You can adjust the properties of the beveled 
surface in the Channel Box / Layer Editor by changing 
the values in the bevelPlus1 node of the INPUTS area 
as required, refer to Figure 3-56.

You can also create the beveled text by using the Bevel Plus tool. To do so, choose Create > 
Text > Option Box from the menubar; the Text Curves Options dialog box will be displayed, 
as shown in Figure 3-57. By default, Maya is displayed in the Text attribute. Replace it with the 
text that you want to display in the viewport in the attribute. You can also set the font of the text. 
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To do so, choose the arrow shaped button on the right of the Font attribute; the Select Scalable 
Font dialog box will be displayed, as shown in Figure 3-58. Set the font, font style, size, and other 
font attributes in this dialog box and choose the OK button to close the dialog box. Next, choose 
the Create button from the Text Curves Options dialog box; the text will be displayed in the 
Wireframe mode in the viewport, as shown in Figure 3-59. Next, select the letter curves one by 
one and choose Surfaces >  Create > Bevel Plus from the menubar. Repeat this step for every 
letter; the text in the wireframe mode will be extruded and a NURBS surface is added to it, as 
shown in Figure 3-60.

Figure 3-55  The beveled surface created 
using the Bevel Plus tool

Figure 3-56  The bevelPlus1 node 
displayed in the INPUTS area

Figure 3-57  The Text Curves Options dialog box Figure 3-58  The Select Scalable Font 
dialog box

Figure 3-59  Text displayed in the 
wireframe mode

Figure 3-60  The text displayed on 
choosing the Bevel Plus tool
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TUTORIALS
 Tutorial 1                                                                            
In this tutorial, you will create 3D model of a teapot, as shown in Figure 3-61, using the curve 
tools and the surface tools.	   		                                  (Expected time: 15 min)

The following steps are required to complete this tutorial:
a.	 Create a project folder.
b.	 Create the body of the teapot.
c.	 Create the handle of the teapot.
d.	 Create the spout of the teapot
e.	 Create the lid of the teapot.
f.	 Change the background color of the scene.
g.	 Save and render the scene.

Figure 3-61  The teapot model

Creating a Project Folder
Create a new project folder with the name c03_tut1 at \Documents\maya2016 and then save the 
file with the name c03tut1, as discussed in Tutorial 1 of Chapter 2. 

Creating the Body of the Teapot
In this section, you will create the body of the teapot using the NURBS Circle and Loft tools.

1.	 Select the Modeling menuset from the Menuset drop-down list in the Status Line. Choose 
the Four View button from the Tool Box to switch to four views. Move the cursor to the top 
viewport and then press the SPACEBAR key to maximize the top viewport.

2.	 Choose Create > Objects > NURBS Primitives > Circle from the menubar and click in 
the top viewport; a NURBS Circle is created in the viewport.

3.	 In the Channel Box / Layer Editor, expand the makeNurbCircle1 area of the INPUTS 
area and enter 3 in the Radius edit box, refer to Figure 3-62.

4.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor to 
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the front viewport and then press the SPACEBAR key to

Figure 3-62  The Channel Box 
/ Layer Editor for the circle

 
maximize the front viewport. In the front viewport, make sure 
the NURBS Circle is selected and choose Edit > Duplicate > 
Duplicate from the menubar; another copy of the circle is 
created. Next, choose Move Tool from the Tool Box and move 
the duplicate circle up along the Y-axis, refer to Figure 3-63.

5.	 Make sure the duplicate circle is selected and then press 
CTRL+D; a copy of the circle is created. Next, choose Move 
Tool from the Tool Box and move the third circle and place 
it in the middle of the first and second circles, as shown in 
Figure 3-64.

6.	 Invoke Scale Tool and scale the third circle uniformly, refer 
to Figure 3-65. 

Figure 3-63  Duplicate copy of the circle 
created in the front viewport

Figure 3-64  Third copy of the circle placed 
between the first and second circles

	 Next, you will create a NURBS surface.                  

7.	 Press and hold the SHIFT key and select the first, third and second circles. Choose Surfaces > 
Create > Loft from the menubar; the lofted surface is created in the viewport, refer to 
Figure 3-66. 

Figure 3-65  The third circle scaled using Scale 
Tool in the front viewport

Figure 3-66  The three circles lofted using 
the Loft tool



NURBS Curves and Surfaces		         3-31

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

8.	 Choose Windows > Editors > Outliner from the menubar; the Outliner window is displayed. 
Now select the NURBS Circle. Select the first circle and choose Surfaces > Create > Planar 
from the menubar; a flat surface is created at the bottom. 

Creating the Handle of the Teapot
In this section, you will create the handle of the teapot by using the Three Point Circular Arc 
and Extrude tools.

1.	 Choose Create > Objects > Curve Tools > Three Point Circular Arc from the menubar 
and create an arc in the front viewport by defining the start point, the curve point, and the 
endpoint, refer to Figure 3-67. Choose Create > Objects > NURBS Primitives > Circle 
from the menubar and click in the front viewport; a circle is created in the viewport. In the 
Channel Box / Layer Editor, expand the makeNurbCircle2 node in the INPUTS area. 
Next, enter 0.25 in the Radius edit box. 

2.	 Make sure the circle is selected. Enter 90 in the Rotate X edit box in the Channel Box / 
Layer Editor. Figure 3-68 displays the circle created in the front viewport.

Figure 3-67  An arc created using the Three 
Point Circular Arc tool

Figure 3-68  A circle created in the front viewport

3.	 Make sure the circle is selected and then select the arc by using the SHIFT key. Next, choose 
Surfaces > Create > Extrude > Option Box from the menubar; the Extrude Options 
dialog box is displayed. In this dialog box, set the parameters, as shown in Figure 3-69. 
Next, choose the Apply button and then the Close button; the circle is extruded along the 
arc. 

Figure 3-69  The Extrude Options dialog box
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4.	 Choose the Four View button from the Tool Box to 

Figure 3-70  Handle aligned with the teapot

switch to four views. Move the cursor to the 
persp viewport and then press the SPACEBAR 
key to maximize the persp viewport. Press 5 to 
view the surface in the shaded mode, if not in 
the shaded mode. Choose Move Tool and 
Rotate Tool, if required. Next, align the handle 
on the body of the teapot, as shown in 
Figure 3-70.

Creating the Spout of the Teapot
In this section, you will create the spout of the teapot 
by using the EP Curve Tool and the Extrude tool.

1.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor to 
the front viewport and then press the SPACEBAR key to maximize the front viewport. Choose 
Create > Objects > Curve Tools > EP Curve Tool > Option Box from the menubar; the 
Tool Settings (EP Curve Tool) window is displayed. Select the 5 radio button corresponding 
to the Curve degree attribute.

2.	 Create a profile curve in the front viewport from bottom to top, as shown in Figure 3-71 and 
then press ENTER.

3.	 Choose Create > Objects > NURBS Primitives > Circle from the menubar and click in 
the front viewport; a circle is created in the viewport. Make sure the circle is selected in the 
viewport. In the Channel Box / Layer Editor, expand the makeNurbCircle3 node in the 
INPUTS area and enter 0.4 in the Radius edit box and 90 in the Rotate X edit box; the 
circle is rotated in the front viewport, as shown in Figure 3-72.

Figure 3-71  Profile curve created for the spout Figure 3-72  A circle created in the front viewport

Tip: To get the exact shape of the curve, you need to modify it. To do so, select the curve 
and then right click on it. Next, choose Control Vertex from the marking menu displayed. 
Now, you can select a vertex and modify the shape of the curve using Move Tool. 

4.	 In the front viewport, make sure the circle is selected and then select the profile curve of the 
spout by using the SHIFT key. Next, choose Surfaces >  Create > Extrude > Option Box 
from the menubar; the Extrude Options dialog box is displayed. In this dialog box, set the 
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parameters, refer to Figure 3-73. Choose the Apply button and then the Close button; the 
profile curve of the spout is extruded.

Figure 3-73  The Extrude Options dialog box 

5.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor to 
the persp viewport and then press the SPACEBAR key to maximize the persp viewport. Place 
the spout on the body of the teapot using Move Tool if required, as shown in Figure 3-74.

Figure 3-74  The spout placed on the teapot

6.	 Make sure the spout is selected. Press and hold the right mouse button over the spout; a 
marking menu is displayed. Choose Control Vertex from the marking menu; vertex selection 
mode is activated.

7.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor to 
the front viewport and then press the SPACEBAR key to maximize the front viewport. Select 
the vertices of the spout, as shown in Figure 3-75. Next, invoke Scale Tool and scale the 
selected vertices uniformly, as shown in Figure 3-76.
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Figure 3-75  Vertices of the spout selected Figure 3-76  Selected vertices scaled

8.	 Modify the shape of the spout to refine it using Scale Tool and Move Tool, as shown in 
Figure 3-77.

Figure 3-77  The refined shape of the spout

Creating the Lid of the Teapot
In this section, you will create the lid of the teapot using EP Curve Tool and the Revolve tool.

1.	 Choose Create > Objects > Curve Tools > EP Curve Tool > Option Box from the menubar; 
the Tool Settings (EP Curve Tool) window is displayed. Select the 3 Cubic radio button 
corresponding to the Curve Degree attribute.

2.	 In the front viewport, create a profile curve from bottom to top for the lid of the teapot 
using EP Curve Tool, as shown in Figure 3-78 and press ENTER. Next, press and hold the 
D key and set the pivot point of the curve, as shown in Figure 3-79.

3.	 Make sure the profile curve is selected. Next, choose Surfaces >Create > Revolve from the 
menubar; the profile curve rotates at 360 degrees and the lid is created.

4.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor 
to the persp viewport and then press the SPACEBAR key to maximize the persp viewport. 
Scale and align the lid on the body of the teapot using Move Tool and Scale Tool, as shown 
in Figure 3-80.
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Figure 3-78  Profile curve created 
for the lid

Figure 3-79  Pivot point of the 
curve aligned

Figure 3-80  The lid placed on the teapot
Note
To set the pivot point of any surface, press the INSERT key; the shape of the gizmo will change. 
Before applying the Revolve tool on the selected curve, adjust the pivot point at the center of the 
curve from where the new surface will be created. If you delete the profile curve after applying the 
Revolve tool, you cannot modify the shape.

Changing the Background Color of the Scene

In this section, you will change the background color of the scene.

1.	 Choose Windows > Outliner from the menubar; the Outliner window is displayed. Select 
the persp camera in the Outliner window; the perspShape tab is displayed in the Attribute 
Editor. 

2.	 In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the scene by downloading the c03_maya_2016_rndr.zip file from 
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 
Maya > Autodesk Maya 2016: A Comprehensive Guide.
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1.	 Choose File > Save Scene from the menubar. 

2.	 Maximize the persp viewport, if it is not already maximized. Choose the Render the current 
frame button from the Status Line; the Render View window is displayed. This window 
shows the final output of the scene, refer to Figure 3-61.

 Tutorial 2                                                                      
In this tutorial, you will create the 3D model of a tea cup, as shown in Figure 3-81, using curve 
tools and surface methods.                                	     	                   (Expected time: 30 min)

Figure 3-81  The tea cup

The following steps are required to complete this tutorial:

a.	 Create a project folder.
b.	 Create a profile curve.
c.	 Create the tea cup using the Revolve tool.
d.	 Create creases in the tea cup.
e.	 Create the handle of the tea cup.
f.	 Change the background color of the scene.
g.	 Save and render the scene.

Creating a Project Folder
Create a new project folder with the name c03_tut2 at \Documents\maya2016 and then save the 
file with the name c03tut2, as discussed in Tutorial 1 of Chapter 2. 

Creating a Profile Curve
In this section, you will create a profile curve for the tea cup using CV Curve Tool.

1.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor 
to the front viewport and then press the SPACEBAR key to maximize the front viewport. 
Choose Create > Objects > Curve Tools > EP Curve Tool from the menubar.

 2.	 In the front viewport, create a profile curve starting from the origin, as shown in Figure 3-82. 
Next, press the ENTER key.
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Creating the Tea Cup Using the Revolve Tool

Figure 3-82  The profile curve for 
the tea cup

In this section, you will create the tea cup using the Revolve 
tool.

1.	 Choose the Four View button from the Tool Box to switch 
to four views. Move the cursor to the persp viewport and 
then press the SPACEBAR key to maximize the persp 
viewport. Select the profile curve in the viewport. Next, 
choose Surfaces > Create > Revolve from the menubar; 
the tea cup is created, as shown in Figure 3-83.

Creating Creases in the Tea Cup
In this section, you will add creases to the tea cup to give it 
the required shape.

1.	 In the persp viewport, make sure the tea cup is

Figure 3-83  The tea cup created

 
selected. Next, press and hold the right mouse button 
over the tea cup; a marking menu is displayed. 
Choose Isoparm from the marking menu.

2.	 Choose a vertical isoparm of the tea cup and then 
drag the cursor; a dotted impression of the isoparm 
is created on the cup, refer to Figure 3-84.

3.	 Press and hold the SHIFT key and similarly create 
dotted impression of other vertical isoparms, as 
shown in Figure 3-84. You may need to rotate the 
viewport to select the vertical isoparms.

4.	 Make sure that Surfaces menuset is selected from the Menuset drop-down list in the Status 
Line. Curves > Insert Knot from the menubar; the new isoparms are created on the tea 
cup, as shown in Figure 3-85. 

Figure 3-84  Dotted impression of the isoparms Figure 3-85  New isoparms created

5.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor to 
the front viewport and then press the SPACEBAR key to maximize the front viewport.
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6.	 Press and hold the right mouse button over the tea cup; a marking menu is displayed. Choose 
Control Vertex from the marking menu; the vertex selection mode is activated. Next, press 
and hold the SHIFT key to select the vertices, as shown in Figure 3-86.

7.	 Choose Move Tool from the Tool Box and move the selected vertices downward along the 
Y-axis; creases are created in the tea cup, as shown in Figure 3-87.

Figure 3-87  Crease created in the tea cupFigure 3-86  Vertices selected

8.	 Choose the Four View button from the Tool Box

Figure 3-88  Selected vertices scaled outward

 
to switch to four views. Move the cursor to the 
top viewport and then press the SPACEBAR key 
to maximize the top viewport.

9.	 Make sure that the vertices are selected in the top 
viewport. Next, choose the Scale Tool from the 
Tool Box and scale the selected vertices outward 
uniformly, as shown in Figure 3-88.

Creating the Handle of the Tea Cup
In this section, you will create the handle of the cup 
by using CV Curve Tool.

1.	 Choose the Four View button from the Tool Box 
to switch to four views. Move the cursor to the front viewport and then press the SPACEBAR 
key to maximize the front viewport. Choose Create > Objects > Curve Tools > CV Curve 
Tool from the menubar and draw a profile curve, as shown in Figure 3-89 and then press 
the ENTER key.

2.	 Choose the Four View button from the Tool Box to switch to four views. Move the cursor to 
the top viewport and then press the SPACEBAR key to maximize the top viewport. Choose 
Create > Objects > NURBS Primitives > Circle from the menubar and create a circle in 
the top viewport.
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Figure 3-89  The profile curve drawn 

3.	 Make sure the NURBS Circle is selected in the viewport.

Figure 3-90  The nurbsCircle1 area 
in the Channel Box / Layer Editor 

 
Set the parameters in the nurbsCircle1 area of the 
Channel Box / Layer Editor, as shown in Figure 3-90.

4.	 In the Channel Box / Layer Editor, expand the 
makeNurbCircle1 node in the INPUTS area and enter 
0.2 in the Radius edit box.

5.	 Choose the Four View button from the Tool Box to 
switch to four views. Move the cursor to the persp 
viewport and then press the SPACEBAR key to maximize 
the persp viewport. 

6.	 Make sure the NURBS circle is selected and then select 
the profile curve using the SHIFT key. Next, choose 
Surfaces >  Create > Extrude from the menubar; the extruded surface is created, refer to 
Figure 3-91. Next, select the extruded surface. In the extrude1 tab of the Attribute Editor, 
make sure the Component Pivot is selected from the Use Component Pivot drop-down list.

7.	 Choose Move Tool and Rotate Tool to adjust the handle with the tea cup to get the final 
output, as shown in Figure 3-92.

Figure 3-92  Final output of the cupFigure 3-91  The extruded surface displayed

Changing the Background Color of the Scene
In this section, you will change the background color of the scene.

1.	 Choose Windows > Outliner from the menubar; the Outliner window is displayed. Select 
the persp camera in the Outliner window; the perspShape tab is displayed in the Attribute 
Editor. 
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2.	 In the perspShape tab, expand the Environment area and drag the Background Color 
slider bar toward right to change the background color to white.

Saving and Rendering the Scene
In this section, you will save the scene that you have created and then render it. You can view 
the final rendered image of the scene by downloading the c03_maya_2016_rndr.zip file from 
www.cadcim.com. The path of the file is mentioned in Tutorial 1.
 
1.	 Choose File > Save Scene from the menubar.

2.	 Maximize the persp viewport, if it is not already maximized. Choose the Render the current 
frame button from the Status Line; the Render View window is displayed. This window 
shows the final output of the scene, refer to Figure 3-81.

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this
chapter:

1.	 Which of the following objects has a circular base and its sides tapered to a point?

		  (a) Cone			   (b) Cylinder
		  (c) Torus	 		  (d) Square

2.	 Which of the following objects has every point equidistant from its center?

		  (a) Plane			   (b) Circle
		  (c) Torus	 		  (d) Sphere

3.	 The options in the __________ area are used to define the distribution of the knots on the 
curve. 

4.	 NURBS stands for __________.

5.	 The default NURBS objects in Maya are grouped together under __________.

6.	 The __________ tool is used to create a surface around a profile curve along a selected axis.

7.	 You can switch from the wireframe mode to the object mode by pressing 4 on the keyboard. 
(T/F)

8.	 A cube is a two-dimensional shape with six square or rectangular sides. (T/F)

9.	 A square is a six-sided regular polygon with six equal sides and six right angles. (T/F)

10.	 The Boundary tool is used to create a surface by filling a surface between the boundary 
curves. (T/F)
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 Review Questions 
Answer the following questions:

1.	 Which of the following is not a component of NURBS surface?

		  (a) Isoparm			   (b) Vertex
		  (c) Hull				   (d) Surface patch

2.   Which of the following tools works similar to the brush tool in other software?

       (a) EP Curve Tool                       (b) CV Curve Tool
       (c) Pencil Curve Tool                  (d) Arc Tool

3.    Which of the following keys is required to adjust the center pivot of an object?

       (a)  SPACEBAR                              (b) HOME
       (c)  CTRL                                       (d) INSERT

4.    ___________ is a four-sided regular polygon with equal sides.

5.	 The __________ option is used to determine that whether the direction of the surface created 
will be linear or cubic.

6.	 __________ is the addition of surface between two or more specified curves.

7.	 The __________ option is used to create a sphere with a faceted or a smooth appearance.

8.	 The __________ is a solid object in which the surface is at an equal distance from the center. 

9.	 The Square tool is used to create a surface from the intersecting NURBS curves. (T/F)

10.	 The NURBS curves, which are used to create the NURBS surfaces by using the Loft tool, 
should have curves with equal number of vertices. (T/F)

EXERCISES 
The rendered output of the models used in the following exercises can be accessed by downloading 
the c03_maya_2016_exr.zip file from www.cadcim.com. The path of the file is as follows: Textbooks > 
Animation and Visual Effects > Maya > Autodesk Maya 2016: A Comprehensive Guide.
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 Exercise 1                                                                        
Create the model of an apple, as shown in Figure 3-93. 		        (Expected time: 15 min)

			 

Figure 3-93  Model of an apple

       

 Exercise 2                                                                        
Create the model of a lantern, as shown in Figure 3-94.                      (Expected time: 15 min)

                                                                                              

Figure 3-94  Model of a lantern

 Exercise 3                                                                        
Create the model of a castle, as shown in Figure 3-95.                          (Expected time: 30 min)
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Figure 3-95  Model of a castle

 Exercise 4                                                                        
Create the model of a candle stand, as shown in Figure 3-96.             (Expected time: 15 min)

 Exercise 5                                                                                  
Create the model of a table, as shown in Figure 3-97.               (Expected time:15 min)

Figure 3-96  Model of a candle stand Figure 3-97  Model of a Table
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Answers to Self-Evaluation Test
1. a, 2. d, 3. Knot Spacing, 4. Non uniform rational B-Spline, 5. NURBS Primitives, 6. Revolve, 
7. F, 8. F, 9. F, 10. T


