
Chapter 3
Selecting,Controlling, 

and Reviewing Objects

Learning Objectives

After completing this chapter, you will be able to:
• Use direct selection tools
• Use different types of windows for selecting objects
• Save selected objects
• Analyze object properties
• Link databases to objects
• Control visibility of objects
• Control the appearance of model
• Control object attributes
• Use Measure and Redline tools
• Add tags and comments
• Use links
• Use the Appearance Profiler window
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INTRODUCTION
In the previous chapter, you learned to use various navigation tools in a project. In this chapter, 
you will learn various methods and tools to select, control, and review objects. In Navisworks, there 
are several types of tools which are used for selecting objects in a model. After selecting objects, 
you can control their transformation and appearance. You can also use various measuring tools 
to measure distances, angle, and area. Using the Link tool, you can attach any file or geometry 
to the model. All these tools and methods are discussed in detail in this chapter. Various methods 
for selecting objects are discussed next.

OBJECT SELECTION METHODS
In order to work on  an object or a group of objects, you need to select them. In Navisworks, 
you can do so by using the Direct Selection method. You can also select an object or group of 
objects by using the Selection Tree window and the Find Items window. Various methods for 
selecting objects in Navisworks are discussed next.

Direct Selection Method
In the Direct Selection method, you can select an object or group of objects directly from the 
Scene View by using the direct selection tools. The direct selection tools are available in the 
Select & Search panel of the Home tab. These tools are discussed next.

Select Tool
The Select tool is used to select an object(s) directly from the Scene View. To 
select an object, choose this tool from Home > Select & Search > Select 
drop-down, as shown in Figure 3-1. On doing so, a selection cursor will be 

displayed in the Scene View. Next, click on the desired object; the object will be selected and 
highlighted in blue color. To select more than one object at a time, press and hold the CTRL 
key while clicking on the objects.

 Figure 3-1  Choosing the Select tool

Note
Sometimes, instead of selecting a single object, either the entire model or a particular layer will 
be selected in the Scene View. In this case, choose the Last Object option from the Resolution 
drop-down list located at Options Editor > Interface > Selection. 
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Select Box Tool
The Select Box tool is used to select object(s) by drawing a window in the Scene 
View. To select an object, invoke this tool from Home > Select & Search >  Select 
drop-down, refer to Figure 3-1. On doing so, a selection cursor will be displayed 

in the Scene View. Next, click at a desired location in the Scene View and then drag the cursor 
to form a rectangle. You will notice that on dragging the cursor, a rectangle is formed in dashed 
lines and the objects that are completely inside it are selected.

Select All Tool
The Select All tool is used to select all the objects in the Scene View. To select 
objects, invoke this tool  from Home > Select & Search > Select All 
drop-down, as shown in Figure 3-2. On doing so, all objects will be selected 

in the Scene View. Notice that all the selected objects will be highlighted in blue color.

Figure 3-2  Invoking the Select All tool

Select None Tool
The Select None tool is used for deselecting the selected objects. Before using 
this tool, ensure that the objects are selected in the Scene View. Next, invoke 
this tool from Home > Select & Search > Select All drop-down, refer to 

Figure 3-2; all the selected objects will be deselected in the Scene View.

Invert Selection Tool
The Invert Selection tool is used for reversing the selection. To do so, first 
select an object in the Scene View. Next, invoke this tool from the 
Home > Select & Search > Select All drop-down, refer to Figure 3-2. On 
doing so, the selected objects will be deselected and the deselected objects 

will be selected in the Scene View.

In a project, you can also select multiple objects based on the their properties, type, name, and 
so on. To do so, first you need to select an object in the Scene View. After selecting the object, the 
Select Same drop-down will be enabled in the Select & Search panel. This drop-down contains 
various tools that are discussed next.

Same Name Tool
The Same Name tool is used to select multiple objects in a model with the 
same name as the currently selected objects. Before invoking this tool, 
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ensure that an object is selected in the Scene View. To select the object with the same name, 
choose the Same Name tool from Home > Select & Search > Select Same drop-down, as shown 
in Figure 3-3; the objects with the same name as the currently selected object will be selected 
and highlighted in blue color. For example, if you have selected a wall named as Basic Wall in 
the model and you want to select all the walls named as Basic Wall in the model, then use the 
Same Name tool.

 Figure 3-3  Choosing the Same Name tool

Same Type Tool
The Same Type tool is used to select objects of the same type as the currently 
selected object. Before invoking this tool, ensure that an object is selected 

in the Scene View. To select objects of the same type, choose the Same Type tool from 
Home > Select & Search > Select  Same drop-down, refer to Figure 3-3. On doing so, the 
objects of the same type as the currently selected object will be selected and highlighted in blue 
color in the Scene View. For example, if you have selected an object of polygon geometry and 
you want to select all the objects with the polygon type, then you need to invoke the Same Type 
tool.

Same <Property> Tool
The Same <Property> tool is used to select objects whose properties such as element, element 
ID, and link are same as that of the currently selected object. To select the object, choose the 
Same <Property> tool from Home > Select & Search > Select Same drop-down, refer to Figure 
3-3. On doing so, the objects that have the same properties as that of the current selected objects 
will be selected and highlighted in blue in the Scene View. For example, if you have selected an 
object in which glass material has been used and you want to select all the objects in which glass 
material is used, then you need to choose the Select Same Material tool.

The Selection Tree Window
In Navisworks, you can select the object(s) from the Selection Tree window. To use this window, 
choose the Selection Tree button from the Select & Search panel in the Home tab; the Selection 
Tree window will be displayed, as shown in Figure 3-4. Alternatively, to display the Selection 
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Tree window, select the Selection Tree check box from the View > Workspace > Windows 
drop-down. The Selection Tree window is a dockable window which contains a list of objects. 
These objects are arranged in a hierarchy. The arrangement of objects in the hierarchy is same 
as the sequence of object creation of the model in the native application. When you select an 
object from the Selection Tree window, the selected object will also be selected in the Scene View 
and highlighted in blue color, both in the Scene View as well as in the Selection Tree window.

You can control the display of hierarchy in the Selection Tree window by selecting the required 
option from the drop-down list displayed at the top in the Selection Tree window. The options 
available in the drop-down list are discussed next.

Figure 3-4  The Selection Tree window

Standard Option
In the Selection Tree window, select the Standard option from the drop-down list; the default 
hierarchy will be displayed which includes all the levels and parts of the model. You can arrange 
the displayed hierarchy in an alphabetical order. To do so, right-click on any of the items in 
the Selection Tree; a shortcut menu will be displayed. Choose Scene > Sort from the shortcut 
menu; the list will be arranged in an alphabetical order. 

Compact Option
In the Selection Tree window, select the Compact option from the drop-down list; a simplified 
hierarchy will be displayed. 

You can customize the level of details displayed on selecting the Compact option. To do so, 
choose the Options button in the Application Menu; the Options Editor dialog box will be 
displayed. Expand the Interface node in the left pane of the dialog box; several options will be 
displayed. Select the Selection option under the Interface node; various options related to the 
Selection option will be displayed in the right pane of the dialog box, as shown in Figure 3-5. 
In the right pane, select the required options from the Compact Tree drop-down list, refer to 
Figure 3-5. The options in the drop-down list are discussed next.
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To display the model file only in the Selection Tree window, select the Model option from the 
drop-down list. To expand the hierarchy to layer level in the Selection Tree window, select the 
Layers option from the list. To expand the list to the objects level in the Selection Tree window, 
select the Objects option from the list.

 Figure 3-5  Various options in the Options Editor dialog box

Properties Option
In the Selection Tree window, select the Properties option from the drop-down list; a hierarchy 
based on the properties of items will be displayed. Now, in the Selection Tree window, you can 
select the objects based on their properties from the displayed hierarchy.

Sets Option
In the Selection Tree window, choose the Sets option from the drop-down list;  all the saved 
selections and search sets will be displayed in a hierarchy. Note that if no sets are defined, then 
the Sets option will not be available in the drop-down list of the Selection Tree window. The 
method of saving the selections and search sets is discussed later in this chapter.

Setting Selection Resolution
In Navisworks, at times, when you select an object in the Scene View, then either the entire model 
or a particular layer will be selected but not the single entity. In such a case, you can customize 
the selection resolution. To do so, choose the Options button in the Application Menu; the 
Options Editor dialog box will be displayed. In the left pane of the Options Editor dialog box, 
expand the Interface node and select the Selection option; several options will be displayed 
in the right pane of the dialog box, refer to Figure 3-5. In the right pane, select the required 
options from the Resolution drop-down list. The options in this drop-down list are used to 
define the level of selection. These options are discussed next.



Selecting, Controlling, and Reviewing Objects				                      3-7

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

To select all objects in the current file, select the File option from the Resolution drop-down list 
in the right pane of the Options Editor dialog box. Next, click on an object in the Scene View; 
all objects will be selected in the Scene View. To select objects within a layer, select the Layer 
option from the drop-down list. Next, click on the required object in the Scene View; all objects 
of the corresponding layer will be selected. To select the first group of objects under the layer 
in a model, select the First Object option from the drop-down list. Next, click on an object in 
the Scene View; the object will be selected in the Scene View and the corresponding composite 
object will be highlighted in the Selection Tree window. To select the last branch of object in 
a model, select the Last Object option from the drop-down list. Next, click on the required 
object in a model; the object will be selected in the Scene View and the corresponding item will 
be highlighted in the Selection Tree window. By default, the Last Object option is selected in 
the Resolution drop-down list. Similarly, select the Last Unique and Geometry options from 
the Resolution drop-down list.

You can also access these options from the ribbon. To do so, expand the Select & Search panel 
by clicking on the down arrow. Next, select the required options from the Selection Resolution 
drop-down list.

Find Items Window
In a project, you may need to select or search an object on the basis of its property. To do so, 
choose the Find Items button from the Select & Search panel in the Home tab; the Find Items 
window will be displayed, as shown in Figure 3-6. Alternatively, to display the Find Items window, 
select the Find Items check box from the View > Workspace > Windows drop-down list. The 
Find Items window is a dockable window in which you can search for objects having common 
properties. These searched objects will be selected and highlighted in the Scene View and in 
the Selection Tree window.

Figure 3-6  The Find Items window

The left pane of the Find Items window contains objects arranged in a hierarchy. In this pane, 
you can define the level of search by selecting the options from the drop-down list available at 
the top in the Find Items window. The options in this drop-down list are same as in the Selection 
Tree window. Using these options, you can control the levels of display of objects in the window.
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Using the options available in the right pane of the Find Items window, you can specify the 
parameters for searching objects in the model. These options are discussed next.

Category
In the Category column, you can specify the category name for the object(s) to be searched. 
To do so, click in the Category column; a drop-down list will be displayed. This drop-down list 
contains the list of categories that are available in the model such as Item, Element, Material, 
and so on. You can select the required category name from the list.

Property
In the Property column, you can specify the property name for the object(s) to be searched. 
To do so, click in the Property column; a drop-down list will be displayed. This drop-down list 
contains the list of properties of the selected category. You can select the required property from 
the drop-down list.

Condition
In the Condition column, you can specify the condition operator for the objects such as =, 
not equals, <, >, and so on. To do so, click in the Condition column; a drop-down list will be 
displayed. You can select the required condition operator from it.

Value
In the Value column, you can specify the property value manually or select the required value 
from the drop-down list. To do so, click in the Value column; a drop-down list will be displayed. 
Select the required value from it. The values available in the drop-down list depend upon the 
selected category and property.

Match Case, Match Character Widths, and Match Diacritics
The Match Case check box is used to check the case sensitivity for the search statements. You 
can select the Match Character Widths check box to match character widths while searching. 
Select the Match Diacritics check box to match the diacritics terms while searching.

Prune Below Result
Select the Prune Below Result check box to stop the search when the first object is found.

Search
This drop-down list contains the following options: Default, Below Selected Paths, and Selected 
Paths Only. The Default option is used to search all items selected in the left pane of the window. 
The Below Selected Paths option is used to search only below the selected objects in the left 
pane of the window. The Selected Paths Only option is used to search from the objects selected 
in the left pane of the window.

The Find First Button
The Find First button is used to find the first object which will satisfy the search criteria. To find 
the first qualified object, choose the Find First button; the search results will be selected and 
highlighted in the Scene View as well as in the Selection Tree window.
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The Find Next Button
The Find Next button is used to find the next object which will satisfy the search criteria. To 
find the next qualified object, choose the Find Next button; the search results will be selected 
and highlighted in the Scene View as well as in the Selection Tree window.

The Find All Button
The Find All button is used to find all objects that will satisfy the search criteria. To find all the 
qualifying objects, choose the Find All button; the search results will be selected and highlighted 
in the Scene View as well as in the Selection Tree window.

The Import Button
The Import button is used to import the previously saved search criteria. On choosing this button, 
the Import dialog box will be displayed. In this dialog box, browse and select the required file 
and then choose the Open button; the selected file will be imported.

The Export Button
The Export button is used to export the current search to an .xml file. On choosing this button, 
the Export dialog box will be displayed. In this dialog box, specify the file name and location 
and then choose the Save button; the file will be saved in the specified location.

Quick Find
The Quick Find text box is used to quickly find and select objects in a model. This text 
box is available in the Select & Search panel of the Home tab, as shown in  Figure 3-7.  To 

search an object, specify the related keywords in the Quick Find text box, and then choose the 
button in the text box; the objects matching the entered text will be selected and highlighted 
in the Scene View as well as in the Selection Tree window.

Figure 3-7  The Quick Find tool in the Select & Search panel

After selecting the required objects in a model, you can save the selection. The various methods 
of saving the selected objects are discussed next.

SAVING SELECTIONS
After selecting an object or a group of objects, you can save them as sets. They can be saved either 
by creating selection sets or by creating search sets. These two types of sets are discussed next.

Selection Sets
The selection sets are a group of objects selected either from the Scene View or from the Selection 
Tree window. To save the selected object, choose the Save Selection button from the Select & 
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Search panel in the Home tab; the Sets window will be displayed, as shown in Figure 3-8. The 
selected object will be saved as a selection set in this window. Alternatively, to display the Sets 
window, choose the Manage Sets option from the Home > Select & Search > Sets drop-down. 
This window displays a list of all the saved selections. The buttons located at the top of the Sets 
window are discussed next.

Figure 3-8  The Sets window

Save Selection
The Save Selection button is used to save the current selection. To save the current selected 
object, choose the Save Selection button; a text box with Selection Set written in it will be 

displayed in the Sets window. Specify a new name in the text box and press ENTER; the selection 
set with the new name will be displayed in the Sets window. The selection sets are represented 
by a  symbol, refer to Figure 3-8. 

Save Search
The Save Search button is used to save the currently searched object. To save the currently 
searched object, choose the Save Search button; a text box with Search Set written in it will 

be displayed in the Sets window. Specify a new name in the text box and press ENTER; the 
search set with the new name will be displayed in the Sets window. Search sets are represented 
by a   symbol, refer to Figure 3-9.

New Folder
The New Folder button is used to create a new folder. In the Sets window, you can create 
a new folder and group all the sets under it. To do so, choose the New Folder button; a 

folder with the text New Folder will be created in the Sets window. Specify a new name in the 
text box and press ENTER; the folder with the new name will be created. Next, drag and place 
the desired sets in this folder.

Duplicate
The Duplicate button is used to create a copy of the saved items. To do so, first select the 
desired set in the Sets window and then choose the Duplicate button; the duplicate set will 

be created with the same name and content.

Add Comment
The Add Comment button is used to add comments to the saved objects. To do so, select 
the desired set in the Sets window and then choose the Add Comment button; the Add 

Comment dialog box will be displayed. Specify a comment in the Add Comment area and choose 
the OK button; the comment will be added to the selected set.
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Sort
The Sort button is used to arrange the saved sets in an alphabetical order. To do so, choose 
the Sort button; the content in the Sets window will be arranged alphabetically.

Import/Export
The Import/Export button is used to import and export the saved search sets. To export 
the saved search set, first select the desired set in the Sets window. Next, choose the Import/

Export button; a drop-down list will be displayed. Select the Export Search Sets option from 
the list; the Export dialog box will be displayed. In this dialog box, specify the file name and 
location of the exported file and then choose the Save button; the file will be exported and saved 
at the specified location. Similarly, to import the search sets, select the Import Search Sets 
option from the drop-down list; the Import dialog box will be displayed. In this dialog box, 
browse and select the required file and then choose the Open button; the file will be imported 
to the Sets window.

Delete
The Delete button is used to delete a selected set. To do so, select the set to be deleted and 
choose the Delete button; the selected set will be removed from the Sets window.

Search Sets
The search sets are a group of searched objects. When you 

Figure 3-9  The search sets in the 
Sets window

run a search in the Find Items window, the searched objects 
will be selected and highlighted in blue color in the Scene 
View as well as in the Selection Tree window. To save these 
selected objects, choose the Save Search button in the Sets 
window; the objects will be saved as a search set, refer to 
Figure 3-9.

The Selection Inspector Window
In a project, when you select an object or a group of objects, they will be displayed in the 
Selection Inspector window along with their properties. To invoke this window, choose the 

Selection Inspector button from the Select & Search panel in the Home tab; the Selection 
Inspector window will be displayed, as shown in Figure 3-10. Alternatively, to display the Selection 
Inspector window, select the Selection Inspector check box from the View > Workspace > Windows 
drop-down. The Selection Inspector is a dockable window. Select the object(s) from the Scene 
View or from the Selection Tree window; the selected items will be displayed in the Selection 
Inspector window, as shown in Figure 3-10. The buttons in this window are discussed next.

Show Item
The Show Item button is used to view the selected object in the Scene View. On choosing 
this button, the selected object will be zoomed in the Scene View.

Deselect
The Deselect button is used to remove an object from the Selection Inspector window. On 
choosing this button, the selected object will be removed from the Selection Inspector 

window.



3-12			                                               	      Exploring Autodesk Navisworks
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-10  The Selection Inspector window

Export
The Export button is used to export the selected object to a csv file. To do so, click on the 
Export button; a drop-down list will be displayed. Select the Export CSV option from the 

drop-down list; the Export to CSV dialog box will be displayed. In this dialog box, specify the 
file name and location of the file to be exported and then choose the Save button; the selected 
object will be saved at the specified location.

Save Selection
The Save Selection button is used to save the selected objects as a selection set. 
To do so, select the required object displayed in the Selection Inspector window. 

Next, choose the Save Selection button in the Selection Inspector window; the Sets window 
will be displayed and the selected object will be saved and added to the list of the Sets window. 
Specify the name of the saved object in the Sets window and press ENTER. 

Quick Property Definitions
This button is used to add desired properties to the selected objects in 
the Selection Inspector window. To do so, select the desired object from 

the Scene View or from the Selection Tree window. Next, invoke the Selection Inspector window. 
Now, choose the Quick Properties Definitions button from this window; the Options Editor 
dialog box will be displayed with the Quick Properties options in the right pane. Specify the 
property definitions such as category and choose the OK button.

OBJECT PROPERTIES
In a project, you can analyze the properties of the selected object by using the Properties 
window. You can also customize the properties of selected object in the Properties window. The 
Properties window is discussed next.



Selecting, Controlling, and Reviewing Objects				                      3-13

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Properties Window
After selecting an object in the Scene View, you need to 

Figure 3-11  The Properties window

invoke the Properties window for analyzing the object 
properties. To do so, choose the Properties button from 
the Display panel in the Home tab; the Properties 
window will be displayed, as shown in Figure 3-11. 
Alternatively, to display the Properties window, select the 
Properties check box from the View > Workspace > 
Windows drop-down. The Properties window is a 
dockable window. In this window, there are separate tabs 
for each property of the selected object. You can use these 
tabs to navigate between the available property categories. 
You can also create the custom tabs known as User Data 
tabs in this window. The method of creating a User Data 
tab is discussed next.

Creating the User Data Tab
In a project, you can also create custom tabs in 

Figure 3-12  Choosing the Add New User 
Data Tab from the shortcut menu

which you can define the custom properties of a 
selected object in the Scene View. To create a 
custom tab, select an object from the Scene View 
and then right-click in the Properties window; a 
shortcut menu will be displayed, as shown in Figure 
3-12. Choose the Add New User Data Tab option 
from the shortcut menu; the new User Data tab 
will be added to the Properties window. To rename 
this tab, right-click in the Properties window in the 
created User Data tab; a shortcut menu will be 
displayed. Choose the Rename Tab option from 
the menu; the Autodesk Navisworks Manage 2016 dialog box will be displayed. Specify a new 
name for the tab in the Rename Tab text box and then choose the OK button; the name of the 
tab will be changed. You can also delete the added User Data tab. To do so, select and right-click 
on the required tab; a shortcut menu will be displayed. Next, choose the Delete User Data Tab 
option from the shortcut menu; the selected tab will be deleted.

You can also add the properties to this User Data tab. The procedure to do so is discussed next. 

Adding Properties in the User Data Tab
After creating the user data tab you can add properties to it. To do so, right-click in the User 
Data tab in the Properties window; a shortcut menu will be displayed, as shown in Figure 3-13. 
Next, hover the cursor over the Insert New Property option; a flyout will be displayed, refer 
to Figure 3-13. You can choose the property type from this flyout. On doing so, a text box will 
be displayed in the tab. Specify a name for the newly created property in the text box and 
press ENTER. Next, you need to specify a value for the added property. To do so, double-click 
in the Value column corresponding to the required property in the User Data tab; the 
Autodesk Navisworks Manage 2016 dialog box will be displayed. Specify the required value in 
the Enter Property Value edit box and choose the OK button. To rename an added property, 
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right-click on the property to be renamed; a shortcut menu will be displayed, as shown in 
Figure 3-14. Choose the Rename Property option from the menu; a text box will be displayed. 
Specify a new name in the text box and press ENTER.

Figure 3-13  Adding custom properties to the new tab Figure 3-14  The shortcut menu

Similarly, from this menu, you can edit the property value and can also delete an added 
property. To edit a property value, choose the Edit Property Value option from the menu, refer 
to Figure 3-14; the Autodesk Navisworks Manage 2016 dialog box will be displayed. Specify a 
new value in the Enter Property Value edit box and then choose the OK button; the value will 
be changed. To delete a property, choose the Delete Property option from the menu, refer to 
Figure 3-14; the property will be deleted. Similarly, you can delete the User Data tab by choosing 
the Delete User Data Tab option from the menu.

Note
If you have not selected an item in the Scene View then no property will be displayed in the 
Properties window. 

You can also display the property information of an object in a tooltip style. To do so, choose 
the Quick Properties button from the Display panel in the Home tab. Next, move your cursor 
over the object; the property information related to the object will be displayed in a tooltip style 
in the Scene View. The properties to be displayed can be configured from the Options Editor 
dialog box.

LINKING EXTERNAL DATABASES TO OBJECTS 
While working on a project, you may need to add some extra properties to the model object. 
These properties are displayed in the Properties window. These properties can be added by 
linking external databases such as an excel file to the model object. The database links can be 
added in a single Navisworks file (locally) and can also be added globally. Whenever you will 
load a particular file, the link will be established when you select an object. Also, the properties 
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of the object will be displayed in the appropriate database tab in the Properties window. The 
process of adding a database link is discussed next.

Adding Database Link Locally
You can add external databases locally by using the File Options dialog box. You can invoke 
this dialog box by choosing the File Options tool from the Project panel of the Home tab. In 
the File Options dialog box, choose the Data Tools tab. In this tab, choose the New button; 
the New Link dialog box will be displayed. In this dialog box, specify a name in the Name edit 
box; the Connection area will be activated, refer to Figure 3-15.

Figure 3-15  The New Link dialog box

Next, in the Connection area, select the driver connection type from the ODBC Driver drop-down 
list. For example, to link an excel file, select the Microsoft Excel Driver option from the list. 
Now choose the Setup button; the ODBC Microsoft Excel Setup dialog box will be displayed. 
Figure 3-16 shows the dialog box for the Microsoft Excel Driver.

Figure 3-16  The ODBC Microsoft Excel Setup dialog box
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Note
The name of the ODBC setup dialog box and the options displayed in it depend on the driver 
connection type selected from the ODBC Driver drop-down list. For example, if you have selected 
Microsoft Access Driver option from the drop-down list, then the displayed dialog box will be 
ODBC Microsoft Access Setup.

In this dialog box, you need to select the file to be linked and then choose the OK button 
to close the dialog box. For example, to link an excel file, select its version from the Version 
drop-down list and then choose the Select Workbook button; the Select Workbook dialog box 
will be displayed. In this dialog box, browse to the excel file, select it, and then choose the OK 
button. Next, choose the OK button to close the ODBC Microsoft Excel Setup dialog box. 
You will notice that the connection is updated in the text box in the Connection area of the 
New Link dialog box. Now, in the SQL String area of this dialog box, you need to specify the 
selection statement after the text SELECT. You can select the columns that you want to display 
as categories in the Properties window from the Fields area. Double-click in the Field Name 
column, enter the exact name of database column, and then press ENTER; the name will be 
automatically filled in the Display Name column. Similarly, specify the other column names 
and choose the OK button to close the dialog box. Now, select the check box corresponding 
to the links created from the DataTools Links area in the File Options dialog box, and then 
choose the OK button; the File Options dialog box will be closed. You can now select an object 
and view the created database link in the Properties window.

Adding Database Link Globally
To add a database link globally, choose the DataTools tool from the Tools panel of the Home 
tab; the DataTools dialog box will be displayed, as shown in Figure 3-17. In this dialog box, 
some predefined links are available in the DataTools Links area. You can define the new links in 
the same way as discussed previously. These links will be available in all sessions of Navisworks 
and can also be modified.

There are few buttons in the DataTools tab of the File Options dialog box which are also avail-
able in the DataTools dialog box. The usage of these buttons is discussed next.

To modify a database link, select the check box corresponding to that link from the DataTools 
Links area and then choose the Edit button; the Edit Link dialog box will be displayed. In this 
dialog box, you can make the changes as required. You can remove a link from the DataTools 
Links area by first selecting the corresponding check box and then choosing the Delete button. 
To export a database link, select the corresponding check box and then choose the Export button; 
the Save As dialog box will be displayed. In this dialog box, browse to the desired folder and 
save the file with a distinct name. Similarly, to import a database link, choose the Import button; 
the Open dialog box will be displayed. In this dialog box, browse to the required file and choose 
the Open button; the link will be added in the DataTools tab of the File Options dialog box.
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MEASURE TOOLS
In a project, you can perform several functions such as calculating distances, angle, and area. 
To perform these functions, you can use measure tools. Before measuring an object, you need 
to adjust the cursor snapping. To do so, invoke the Options Editor dialog box by choosing the 
Options button from the Application Menu. Expand the Interface node in the left pane of this 
dialog box and select the Snapping option; several options will be displayed in the right pane 
of the dialog box, as shown in Figure 3-18.

In the Picking area, the Snap to Vertex check box is selected by default. As a result, the cursor 
will snap to the nearest vertex while measuring distances. Select the Snap to Edge check box to 
snap the cursor to the nearest triangular edge. The Snap to Line Vertex check box is selected by 
default. As a result, the cursor will snap to the nearest line end. To define the snapping margin, 
specify a value in the Tolerance edit box. By default, the value in the Tolerance edit box is 5. 
In the Rotation area, specify the snapping angle value in the Angles edit box. By default, the 
value displayed in the Angles edit box is 45.00. To define the snapping tolerance, enter the 
value in the Angle Sensitivity edit box. The default value displayed in the Angle Sensitivity 
edit box is 5.00.

Figure 3-18  The Snapping page in the Options Editor dialog box

After defining all the parameters in the Options Editor dialog box, close it by choosing the OK 
button. Next, invoke the measuring tools from the Review > Measure > Measure drop-down. 
The measuring tools in this drop-down are discussed next.

Point to Point Tool
This tool is used to measure the distance between two points in a model. To do so, 
choose the Point to Point tool from the Measure drop-down; the measuring cursor will 

appear on the screen. Click on the required points between which the distance is to be measured; 
the measured distance will be displayed in the Scene View. 
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Point to Multiple Points Tool
This tool is used to measure the distance from a point to several other points in a model. 
To measure the distance between multiple points, choose the Point to Multiple Points 
tool from the Measure drop-down. Click on the start point and the first end point; the 

measured distance will be displayed in the Scene View. Next, click on the end points to be 
measured. 

Point Line Tool
This tool is used to measure the total distance along the route. To measure the total 
distance along the route, choose the Point Line tool from the Measure drop-down. Next, 

click on the start point and then click on the points along the route to be measured; the measured 
distance will be displayed in the Scene View.

Accumulate Tool
This tool is used to calculate the total distance between several point-to-point 
measurements. To do so, choose the Accumulate tool from the Measure drop-down. 
Then, click on the start and end points of the first distance to be measured. Next, click 

on the start and end points of the next distance to be measured; the sum of all point to point 
distances will be displayed in the Scene View. 

Angle Tool
This tool is used to measure an angle between two points. To do so, choose the Angle 
tool from the Measure drop-down. Click on the start point of the first line. Next, click 

on the intersection point of the first and the second line. Click on the end point of the second 
line; the measured angle will be displayed in the Scene View. 

Area Tool
This tool is used to calculate the area of a plane. To do so, choose the Area tool from 
the Measure drop-down. Click on the desired points to define the periphery of the area 

to be calculated; the calculated area will be displayed in the Scene View.

Shortest Distance Tool
This tool is used to measure the shortest distance between two objects in a model. To do 
so, select the required objects in the Scene View. Choose the Shortest Distance tool from 

the Measure panel in the Review tab; the shortest distance will be displayed in the Scene View.

Clear Tool					           
The Clear tool is used to delete the measurements. To do so, choose the Clear tool from 
the Measure panel in the Review tab; the measurements made will be deleted.

Convert to Redline Tool
The Convert to Redline tool is used for converting the measurements displayed in the 
Scene View into redlines. To do so, first take the measurements using any of the Measure 

tools. Next, choose the Convert to Redline  tool from the Measure panel in the Review tab; 
the measurements will be converted into redlines, and saved as a viewpoint in the Saved 
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Viewpoints window. The thickness and color of these lines can be modified. To change the color 
of redline, select the color from the Color drop-down list of the Redline panel in the Review 
tab. To change the thickness of line, enter the thickness value in the Thickness edit box.

When you perform measurements in the Scene View, the measure results, start and end 
coordinates, and difference between the coordinates will be displayed in the edit boxes in the 
Measure Tools dockable window. To display this window, choose the Measure Options button 
from the Measure panel of the Review tab, refer to Figure 3-19.

Figure 3-19  The Measure Tools dockable window

In this window, the Start and End edit boxes will display the coordinates of the start and points 
respectively. The Difference and Distance edit boxes in this window will display the difference 
of coordinates between the start and end points and the distance between them. If we calculate 
area and angle, the Area and Angle edit boxes will be displayed in this window. 

You can also control the display of measurements in the Scene View. To do so, choose the Options 
button from the Measure Tools window; the Options Editor dialog box will be displayed. In 
this dialog box various measuring options are displayed in the right pane. Note that you can 
also access these options by expanding the Interface node in the Options Editor dialog box 
and then clicking on the Measure sub-node.

In the Options Editor dialog box, you can specify the thickness of measurement lines in the Line 
Thickness edit box. You can change the color of measurement lines by selecting an appropriate 
color from the Color flyout. To draw the measurement lines in 3D, select the In 3D check box. To 
clear the measurement values in the Scene View, clear the Show measurement values in Scene 
View check box, which is selected by default. The Use centre lines check box is also selected 
by default. As a result, the shortest distance measurement will snap to the centre lines of the 
parametric object. Additionally, the Auto - zoom when measuring shortest distances check box 
is selected by default. As a result, on calculating the shortest distance between two objects, the 
measured distance will zoom in automatically in the Scene View.
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DIRECTION CONSTRAINTS FOR MEASUREMENTS
In a project, you can constrain the direction of measuring objects. The constraints can be applied 
in X, Y, and Z directions and they can also be applied in a direction parallel or perpendicular 
to the surface of an object. To apply directional constraints, first you need to invoke any of the 
measuring tools from Review > Measure > Measure drop-down. The tools used for constraining 
the direction are discussed next.

X Axis Tool
The X Axis tool is used to constrain the measurement of an object in the X direction. 
To constrain the measurement along the X axis, choose the X Axis tool from the Review 

> Measure > Lock drop-down. Click on the start point of the distance to be measured; the 
measuring line will be displayed in red color indicating that it is locked in the X direction. Next, 
click on the end point; the distance will be displayed in the Scene View.

Y Axis Tool
The Y Axis tool is used to constrain the measurement of an object in the Y direction. To 
constrain the measurement along the Y axis, choose the Y Axis tool from the Review > 
Measure > Lock drop-down. Click on the start point of the distance to be measured; the 

measuring line will be displayed in green color indicating that it is locked in the Y direction. 
Next, click on the end point; the distance will be displayed in the Scene View.

Z Axis Tool
The Z Axis tool is used to constrain the measurement of an object in the Z direction. To 
constrain the measurement along the Z axis, choose the Z Axis tool from Review > 
Measure > Lock drop-down. Click on the start point of the distance to be measured; 

the measuring line will be displayed in blue color indicating that it is locked in the Z direction. 
Next, click on the end point; the distance will be displayed in the Scene View.

Perpendicular Tool
The Perpendicular tool is used to constrain the measurement of an object in a direction 
perpendicular to the surface of the start point. To use the perpendicular lock, choose 
the Perpendicular tool from the Review > Measure > Lock drop-down. Click on the 

start point of the distance to be measured; the measuring line will be displayed in yellow color 
indicating that it is locked in the perpendicular direction. Next, click on the end point; the 
distance will be displayed in the Scene View.

Parallel Tool
The Parallel tool is used to constrain the measurement of an object in a direction parallel 
to the surface of the start point. To use the parallel lock, choose the Parallel tool from 

the Review > Measure > Lock drop-down. Click on the start point of the distance to be measured; 
the measuring line will be displayed in magenta color indicating that it is locked in the parallel 
direction. Next, click on the end point; the distance will be displayed in the Scene View.
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REDLINE TOOLS
In a project, you can mark up the viewpoints and clash results by adding texts and drawing 
revision clouds. These mark ups are added by using the redline tools. The redline tools are 
discussed next.

Adding Text to Redline
In a project, you can mark or annotate a saved viewpoint and clash results by adding text. 
To add text, choose the Text tool from the Redline panel in the Review tab; a pencil 
cursor will be displayed on the screen. Click at the required location in the Scene View; the 
Autodesk Navisworks Manage 2016 dialog box will be displayed. Specify the text in the 
Enter Redline Text text box and choose the OK button; the text will be added at the specified 
location. To move the text, right-click on it; a shortcut menu will be displayed. Choose the 
Move option from the menu, and click at the desired location; the text will be placed at 
the specified location. To edit the text, choose the Edit option from the shortcut menu; the 
Autodesk Navisworks Manage 2016 dialog box will be displayed. Make the required changes 
and choose the OK button to apply the changes. To delete the text, choose the Delete Redline 
option from the shortcut menu.

Note
By default, the redline text is written in a single line. To write it in multiple lines, specify \P after 
the text from where you want to start the next line. To left align the text, leave no space between 
the \P and the succeding text.

Drawing Cloud
In a project, you can mark a saved viewpoint and clash result by drawing cloud, line, ellipse, 
and so on. For example, to draw a cloud, first you need to choose the desired saved viewpoint. 
Next, choose the Cloud tool from the Review > Redline > Draw drop-down; the pencil cursor 
will appear in the Scene View. Now, click in the required direction to create a cloud. Similarly, 
you can use the other tools from the Draw drop-down to mark the saved viewpoints.

You can delete redline clouds and texts as per your requirement. To do so, choose the Erase 
tool from the Redline panel in the Review tab; the erase cursor will appear in the Scene View. 
Now, draw a box around the text or line to be deleted; the redlines will be erased.

TAGS AND COMMENTS
In Navisworks, you can tag anything in the Scene View which allows you to add comments or 
notes to the viewpoints. The comments added to the saved viewpoints and animations can be 
used for reference later. In the next section, you will learn about adding tags.

Adding Tags
In a project, you can tag anything in the Scene View. To do so, choose the Add Tag option from 
the Tags panel in the Review tab; a pencil cursor will be displayed on the screen. In the Scene 
View, first click on the object you want to tag and then click at the point where you want to label 
the tag; the Add Comment dialog box will be displayed. Alternatively, you can click thrice at the 
point where you want to create a tag. Specify the text in the Add Comment area. To set the tag 
status, select the required options from the Status drop-down list and choose the OK button. 
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The tag will be added to that particular object, and it will be saved as a viewpoint in the Saved 
Viewpoints window. The comment which you have added in the Add Comment dialog box will 
be displayed in the Comments window. This window is discussed next. 

The Comments Window
In a project, when you add comments to viewpoints or results, you can view them in the Comments 
window. In this window, you can add all the comments related to the model and can obtain any 
information quickly. The data will be displayed in a separate window rather than the Scene View. 
To display the window, choose the View Comments button from the Comments panel in the 
Review tab; the Comments window will be displayed, as shown in Figure 3-20.

Figure 3-20  The Comments window

In the Comments window, you can view the information related to comments such as the 
author of comments, date on which comment was added, the content of comment, and so on. 
These informations will be displayed in different columns. You can add comments to selection 
and search sets, Viewpoints, Animation, Timeliner, and Clash results. The method of adding 
comment is discussed next.

Adding Comment			         
In a project, you can add comments to a selection and search set,

Figure 3-21  The Saved 
Viewpoints window

 
viewpoints, clash results, animation, and so on. To add a comment 
to a selection/search set, select the required set from the Sets window. 
Choose the Add Comment button; the Add Comment dialog box 
will be displayed. Specify a comment and choose the OK button; the 
comment will be added to the set. Similarly, you can add comments 
to a particular viewpoint. To do so, choose the Saved Viewpoints 
Dialog Launcher button from the Save, Load & Playback panel in 
the Viewpoint tab; the Saved Viewpoints window will be displayed, 
as shown in Figure 3-21. Now, select the desired viewpoint and 
right-click on it; a shortcut menu will be displayed. Choose the Add 
Comment option from the menu; the Add Comment dialog box will be displayed. Enter the 
comment in the dialog box, assign the status from the Status drop-down list, and choose the 
OK button; the comment will be added to the window. Similarly, you can add comments to clash 
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results and timeliner which will be discussed in later chapters. To view the added comments, 
click on the source item to which you have added the comment; the comments will be displayed 
in the Comments window.

You can modify the added comments. The procedure of modifying comments is discussed next.

Modifying Comment
In a project, after adding comments, you can edit them directly in the Comments window. To 
do so, right-click on the comment in the Comment window; a shortcut menu will be displayed. 
Choose the Edit Comment option from the menu; the Edit Comment dialog box will be 
displayed. Next, type the desired comment and choose the OK button; the comment will be 
edited. To delete a comment, choose the Delete Comment option from the shortcut menu; the 
comment will be deleted.

In a project, you may need to search for comments based on data, date, and source. To do so, 
the Find Comments window is used, which is discussed next. 

The Find Comments Window
The Find Comments window is a dockable window, using the options in this window you can 
search for the added comments. To invoke the Find Comments window, choose the Find 
Comments button from the Comments panel in the Review tab; the Find Comments window 
will be displayed, as shown in Figure 3-22.

Figure 3-22  The Find Comments window

This window comprises of three tabs: Comments, Date Modified, and Source. To search for  
a particular Text, Author, ID or Status, choose the Comments tab. To search within a certain 
timeframe, choose the Date Modified tab. To search for the comments attached to the selected 
source, choose the Source tab. After specifying all the search criteria, choose the Find button; 
the results will be displayed at the bottom of the window. 
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You can also use the Quick Find Comments text box from the Comments panel in the 
Review tab to quickly find the comments. To do so, type the keywords in the Quick Find 

Comments edit box in the Comments panel of the Review tab. Next, choose the button next 
to the text box; the Find Comments dialog box will be displayed with a list of all comments that 
match the text.

COMPARING MODELS					        
While working on a project, sometimes you may need to find the differences between two 
elements in a model. Alternatively, you may need to compare two models of different versions. 
In Navisworks, you can find out the differences or compare two models by using the Compare 
tool. To compare two elements in a model, first select the required elements using the CTRL 
key. Next, choose the Compare tool from the Home > Tools panel; the Compare dialog box 
will be displayed, as shown in Figure 3-23. To compare two different versions of the same model, 
first load the first file that you want to compare. Next, append the second file and then select 
both the files in the Selection Tree window using the CTRL key. Next, invoke the Compare tool; 
the Compare dialog box will be displayed. The options in this dialog box are discussed next.

Figure 3-23  The Compare dialog box

Find Differences In
In the Find Differences In area of the dialog box, select the check boxes corresponding to  the 
categories in which you want to find the differences. For example, to find differences in the 
geometry of two model elements, select the Geometry check box. If you have made any changes 
in the model appearance or made any transformation in the model, then you need to select the 
Overridden Material and Overridden Transformation check boxes to compare the elements 
with material and location overrides.

Results
In the Results area, there are various options that allow you to specify how you want to display 
the comparison results. The options in this area are discussed next.



Selecting, Controlling, and Reviewing Objects				                      3-25

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Save as Selection Sets
Select this check box to save the comparison results of matched and unmatched objects as a 
separate selection set in the Sets window. The comments related to the comparison result of the 
matched and unmatched objects will be available in the Comments window.

Save each difference as Set
Select this check box to save the differences that are found while comparing the elements as 
a selection set. The selection set will also contain comments related to the comparison results. 
You can view these comments in the Comments window.

Remove old results
Select this check box to delete the results of old comparison from the Sets window.

Hide Matches
Select this check box to hide the matching objects after the comparison finishes. This will allow 
you to view the differences clearly.

Highlight Results
Select this check box to highlight all the objects that have differences in different color overrides.

After the comparison finishes, the results will be displayed in the Scene View. The matched and 
unmatched items, and the differences in the items will be displayed in different color codes. 
The matching elements will be highlighted in white color. The elements with differences will 
be highlighted in red color. Items found in the first element but not in the second element will 
be highlighted in yellow, and the one found in the second element but not in the first element 
will be highlighted in cyan.

CONTROLLING THE VISIBILITY OF OBJECTS
In a project, you may need to control the visibility of

Figure 3-24  The Unhide All drop-down

 
some objects in the Scene View. In Navisworks, you 
have several options to control the visibility of objects 
in the model. You can hide and display an object or 
a group of objects in the model. To hide an object in 
the model, first select the desired object in the model. 
Next, choose the Hide button from the Visibility 
panel in the Home tab; the selected object will be 
hidden. Notice that the hidden object will appear 
grey in the Selection Tree window. To display the 
hidden object(s), choose the Hide button again. To hide all the unselected objects in the model, 
select the object which you want to display and then choose the Hide Unselected button from 
the Visibility panel in the Home tab; the unselected objects will be hidden. To display all the 
hidden objects, choose Unhide All from the Unhide All drop-down, refer to Figure 3-24. To 
make the object visible during navigation, regardless of the performance setting, select the item 
in the Selection Tree window. Next, choose the Require button from the Visibility panel; the 
required objects will appear red in the Selection Tree window. To make all the objects unrequired, 
select the Unrequire All option from the drop-down list in the Visibility panel, refer to 
Figure 3-24.
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CONTROLLING THE APPEARANCE OF MODEL IN THE 
SCENE VIEW
You can control the appearance of a model in the Scene View. To control the display of your 
model in the Scene View, use the tools available in the Render Style panel of the Viewpoint 
tab. There are four render modes available to control the delivery of items in the Scene View. 
To apply these modes, click on the Mode option in the Render Style panel of the Viewpoint 
tab; a drop-down list will be displayed. Select any of the four options from the drop-down list. 
Select the Full Render option to render the model with smooth shading including the materials 
used. Select the Shaded mode to deliver the model with smooth shading but without textures. 
Select the Wireframe mode to deliver the model in wireframe. Select the Hidden Line mode 
to deliver the model in wireframe but in this case only outline edges will be displayed, as shown 
in Figure 3-25.

            Figure 3-25  The Wireframe view of the model on using the Hidden Line mode

In Navisworks, the 3D scene illumination can be controlled by making it brighter or lighter by 
using four lighting modes available in the Lighting mode drop-down list. To use these options, 
click on the Lighting option in the Render Style panel of the Viewpoint tab; a drop-down list 
will be displayed. You can select any of the following four options: Full Lights, Scene Lights, 
Head Light, and No Lights. 

You can also change the background color and its effects to be used in the Scene View as per 
your choice. To configure the background effects, invoke the Background tool from the Scene 
View panel in the View tab; the Background Settings dialog box will be displayed, as shown 
in Figure 3-26.

Select the type of background effect from the Mode drop-down list, and then choose the color 
from the Color drop-down list. Select the Plain mode to fill the background of the scene with 
the selected color. Select the Graduated mode to fill the background of the scene with two 
colors. Select the Horizon mode to split the scene across the horizontal plane which gives the 
effect of sky and ground.
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Figure 3-26  The Background Settings dialog box

CONTROLLING OBJECT ATTRIBUTES
In a project, you can control the object transformation and its appearance. All these changes 
are displayed in the Scene View. You can alter the object’s position, size, and rotation using the 
visual manipulation tools (Gizmos). You can also make these changes numerically. The method 
of controlling object attributes using various tools will be discussed individually.

Controlling Object Attributes Using Gizmo
You can move, rotate, and resize the objects using gizmo. To move an object to the required 
position in the Scene View, select the required object; you will notice that the Item Tools contextual 
tab appears in the ribbon. This tab contains all the transformation tools which are also called 
gizmos. These gizmos are discussed next. 

Move Gizmo
The Move gizmo is used to adjust the position of the selected 

Figure 3-27  The Move gizmo

object. To do so, choose the Move tool from the Transform panel 
in the Item Tools contextual tab; the Move gizmo will be 
displayed in the Scene View, as shown in Figure 3-27. To move 
the selected object in the X, Y, and Z direction, place the mouse 
over the gizmo; the cursor will change into a hand symbol. Next, 
place the mouse over the required axis; the axis will be 
highlighted. Now drag the gizmo in the required direction. You 
can also change the position of the gizmo in the Scene View. To 
do so, press and hold the CTRL key. Place the cursor on the 
center ball of the gizmo. Next, drag the gizmo and place it at 
the desired location.

Tip: You can also move an object by specifying exact values. To do so, select the object 
and right-click to display a shortcut menu. Next, choose the Override Item > Override 
Transform option from the menu; the Override Transform dialog box will be displayed. 
Specify the coordinates value in the dialog box and choose the OK button; the selected object 
will be moved to the specified location.
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Rotate Gizmo
The Rotate gizmo is used to rotate a selected object with 

Figure 3-28  The Rotate gizmo

gizmo. To do so, choose the Rotate tool from the Transform 
panel in the Item Tools contextual tab; the Rotate gizmo 
will be displayed in the Scene View, as shown in the Figure 
3-28. Now, adjust the center point of rotation. The method 
of adjusting the center point is same as the method for 
adjusting the Move gizmo. Place the mouse over one of the 
curves in the middle, refer to Figure 3-24 and drag the mouse 
to rotate the selected object.

Scale Gizmo						          
The Scale gizmo is used to resize the selected object. To do so,

Figure 3-29  The Scale gizmo

choose the Scale tool from the Transform panel in the Item 
Tools contextual tab; the Scale gizmo will be displayed in the 
Scene View, as shown in Figure 3-29. Now, to resize the object 
along a single axis, drag any of the three axes. To resize the 
object across two axes, drag the colored triangles in the middle 
of the two axes. To resize the object across all the three axes 
at the same time, use the ball in the center of the gizmo. 

Controlling Object Attributes Numerically
You can also move, rotate, and scale the selected objects numerically. To do so, first invoke any 
of the gizmos, and then click on the down arrow in the Transform panel; various edit boxes 
such as Position, Rotation, Scale, and Transformation Centre will be displayed. Now, specify 
the values in the required edit boxes.

You can also change the appearance such as color and transparency of the selected objects. To 
change the color, click on the Color drop-down in the Appearance panel of the Item Tools 
tab; a list of colors will be displayed. Select the desired color; the color of the object will be 
changed. To adjust the transparency, drag the Transparency slider in the Appearance panel 
of the Item Tools tab.

LINKS
Navisworks uses several sources of links such as the links converted from CAD files, links added 
by the users, and links which are automatically generated by the program, like viewpoint links. 
To display these links, choose the Links button from the Display panel in the Home tab; all 
links will be displayed as icons in the Scene View.

Types of Links
There are two types of links: Standard and User Defined. Standard links are hyperlink, label, 
viewpoints, and clash detection. User Defined links are those in which a user can create different 
categories other than the standard ones. You can control the display of both the links. To control 
the display of the Standard links, choose the Options button from the Application Menu; the 
Options Editor dialog box will be displayed. Expand the Interface node in the left pane of 
the dialog box. Next, expand the Links sub node and select Standard Categories, as shown in 
Figure 3-30.
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Figure 3-30  The Standard Categories option selected in the Options Editor dialog box

In the right pane of the dialog box, select the corresponding Visible check box to display the 
links and to hide them clear the check box. To change the appearance of links, select the required 
option from the Icon Type drop-down list for the corresponding link category, and choose the 
OK button to close the dialog box.

Similarly, to control the display of user defined links, select the User Defined Categories option 
from the Links sub node under the Interface node; several options will be displayed in the right 
pane of the dialog box. In this pane, select the Visible check box to display the corresponding 
links and clear the check box to hide them. To change the appearance of links, select the required 
option from the Icon Type drop-down list. Next, choose the OK button to close the dialog box. 
Note that the user defined options will not be available if you have not added the user defined 
categories. You can also search for links by using the Find Items window.

Customizing Appearance of Links in the Scene View
To avoid the confusion arising due to the large number of links displayed in the Scene View, 
you can  customize the appearance of links displayed in the Scene View by using options in the 
Options Editor dialog box. To do so, expand the Links sub node under the Interface node in 
the left pane of the Options Editor dialog box, as shown in Figure 3-31; several options will 
be displayed in the right pane of the dialog box. Specify the value in the Max Icons edit box 
to control the display of icons in the Scene View. Select the Hide Colliding Icons check box to 
hide any overlapping link icon in the Scene View. To specify the distance between camera and 
the drawn links, enter the value in the Cull Radius edit box. 
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Figure 3-31  The Links options in the Options Editor dialog box

Sometimes links can be hidden in the Scene View. To avoid this, select the In 3D check box; the 
links will float in front of their attachment points. To show the leader lines, specify the distance 
in the X Leader Offset and Y Leader Offset edit boxes; links will be displayed with the leader 
lines pointing to the attached items.         

Adding Links				       
The links can be appended from various data sources 

Figure 3-32  The Add Link dialog box

such as spreadsheets, webpages, audio and video files. 
You can attach multiple links to a single object. To add 
a link to an object, select the desired object in the model; 
the Item Tools contextual tab will be displayed in the 
ribbon. Choose the Add Link tool from the Links panel 
in the Item Tools tab; the Add Link dialog box will be 
displayed, as shown in Figure 3-32. Alternatively, 
right-click on the selected object; a shortcut menu will 
be displayed. Choose the Links option from the shortcut 
menu; a flyout will be displayed. Choose the Add Link 
option; the Add Link dialog box will be displayed. 
Specify a desired name for the link in the Name edit 
box. To specify the file to be linked, choose the Browse 
button displayed to the right of the Link to file or URL edit box; the Choose Link dialog box 
will be displayed. Browse to the folder location and select the required file. Next, choose the 
Open button from the Choose Link dialog box; the path of the selected file will be displayed 
in the Link to file or URL edit box. Choose the link category from the Category drop-down 
list. To attach the link to a specified point on the selected item, choose the Add button under 
the Attachment Points area; a pick cursor will be displayed in the Scene View. Click on the 
required location on the selected object in the Scene View. Next, choose the OK button; the 
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dialog box is closed and a link will be added. The link icon will be displayed at the specified 
location in the Scene View. To delete the attached points, choose the Clear All button in the 
Attachment Points area and then choose the OK button.

You can add several links to an object by repeating the above mentioned steps.

Managing Links
In Navisworks, you can edit, reset, and delete all the links except those which are automatically 
generated such as links which points to the clash results, viewpoints, TimeLiner tasks, and so 
on. To edit a link, right-click on the required link; a shortcut menu will be displayed. Choose 
the Edit Link option from the menu; the Edit Links dialog box will be displayed, as shown in 
Figure 3-33. 

Figure 3-33  The Edit Links dialog box

Now in the dialog box, select the link that you want to edit

Figure 3-34  The Edit Link dialog box

 
and choose the Edit button; the Edit Link dialog box 
will be displayed, as shown in Figure 3-34. Enter the 
link details in the Name, Link to file or URL, and 
Category edit boxes. Next, specify the desired 
Attachment Points to change the location of links in 
the Scene View, and choose the OK button to close the 
dialog box.

Similarly, to delete a link, select the required link from 
the Edit Links dialog box, refer to Figure 3-34. Choose 
the Delete button and then the OK button; the link 
will be deleted. To reset all links for an object, select 
the required object. Next, choose the Reset Links tool 
from the Links panel in the Item Tools contextual tab; 
all links will be readjusted to their original state. Similarly, you can reset all links in the Scene 
View to their original state. To do so, select the Links option from the Reset All drop-down list 
in the Project panel of the Home tab; all links will be readjusted.

Tip: You can also display the Edit Links dialog box by choosing the Edit Links tool from 
the Links panel of the Item Tools tab, refer to Figure 3-29.
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THE APPEARANCE PROFILER WINDOW
In a project, you can customize the appearance of a model by defining the custom display settings 
based on the property data or selection/search sets, using the Appearance Profiler window. The 
Appearance Profiler window is a dockable window. You can use this window to differentiate 
between the objects by color coding them and adding transparency in the model. To invoke 
the Appearance Profiler window, choose the Appearance Profiler button from the Tools panel 
in the Home tab; the Appearance Profiler window will be displayed, as shown in Figure 3-35. 
Alternatively, to display the Appearance Profiler window, select the Appearance Profiler check 
box from the View > Workspace > Windows drop-down. The Appearance Profiler window is 
divided in three areas: Selector, Selector list, and Appearance. These areas are discussed next.

 Figure 3-35  The Appearance Profiler window

Selector Area
The left pane of the Appearance Profiler window is the Selector area. In this area, there are two 
tabs: By Property and By Set. In the By Property tab, you can define the search criteria based 
on property. In the By Set tab, you can define the search criteria based on selection and search 
sets. The Test Selection button is used for checking the defined search criteria. On choosing this 
button, the objects satisfying the search criteria will be selected in the model in the Scene View.

To define the selector by the property data, choose the By Property tab from the Appearance 
Profiler window. Enter the property category and property type in the Category and Property 
edit boxes. Select the appropriate condition operator from the equals/does not equals drop-down 
list. After defining the search criteria, choose the Test Selection button; all objects meeting the 
search criteria will be selected in the Scene View.

Similarly, you can define the selector by using the selection/search set. To do so, first ensure that 
a search/selection set is defined in the project. Next, choose the By Set tab in the Selector area. 
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Then select the set from the list. Next, choose the Test Selection button; all objects meeting the 
search criteria will be selected in the Scene View. 

After defining the selector using any of the above discussed methods, you can configure its 
appearance in the Appearance area which is discussed next.

Appearance Area
The Appearance area is located at the right corner in the Appearance Profiler window. In this 
area, you can configure the appearance of the defined selector. The Color button in this area 
is used for selecting colors. On choosing this button, a Color palette will be displayed. Select 
the desired color from it and choose the OK button; the Color palette will be closed and the 
color will be selected. Specify the transparency level value in the Transparency edit box. After 
specifying the color and transparency, choose the Add button; the selector will be added in the 
Selector list area. Next, choose the Run button; the objects in the model will be color coded 
with the new color.

If you make any changes in the added selector, then choose the Update button for saving those 
changes. To remove a selector from the list, choose the Delete button. The Delete All button is 
used to clear the Selector list. The Load button is used to open an existing appearance profile. 
On choosing this button, the Open dialog box will be displayed. In the dialog box, browse to 
the desired file, and choose the Open button; the file will be loaded in the Appearance Profiler 
window. The Save button is used for saving the current appearance profile. On choosing this 
button, the Save As dialog box will be displayed. Specify the name for the file in the File name 
edit box. Choose the file type from the Save as type drop-down list, and choose the Save button; 
the file will be saved as a data file (.DAT file type).

Selector List Area
The right pane of the Appearance Profiler window is the Selector list. This area contains the 
list of all added selectors.

TUTORIALS
General instructions for downloading tutorial files:

1.  Download the c03_tutorial zip file for the tutorial from http://www.cadcim.com. The path of the  file
     is as follows: Textbooks > Civil/GIS > Navisworks > Exploring Autodesk Navisworks 2016.

2.  Now, save and extract the downloaded folder at the following location:
     C:\ Navisworks_2016

Note
The default unit system used in the tutorials is metric. To change the units to imperial, select the 
required units from Options Editor > Interface > Display Units.
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Tutorial 1		                                  Taking Measurements
In this tutorial, you will open the file c03_navisworks_2016_tut1.nwf. Next, calculate the distance 
between mullions in the door by using various measuring tools such as the Point to Point tool, 
the Point Line tool, and the Accumulate tool. 		                      (Expected time: 30min)
  								           
The following steps are required to complete this tutorial:

a.	 Open the file c03_navisworks_2016_tut1.nwf.
b.	 Display the saved views.
c.	 Measure distance using the Point to Point tool.
d.	 Measure distance using the Point Line tool.
e.	 Measure distance using the Accumulate tool.
f.	 Save the project.

Opening the File
In this section, you will open the file in Navisworks.

1.	 Choose the Open button from the Quick Access Toolbar; the Open dialog box is displayed.

2.	 In this dialog box, browse to the following location:
	 C:\nws_2016\c03_nws_2016_tut.

3.	 Select Navisworks File Set (*.nwf) from the Files of type drop-down list.

4.	 Select the file c03_navisworks_2016_tut1.nwf from the displayed list of files; the file name is 
displayed in the File name edit box.

5.	 Choose the Open button from the dialog box; the model is displayed in the Scene View, as 
shown in Figure 3-36.

Figure 3-36  Model opened in Navisworks
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Displaying the Saved Views
In this section, you will display the saved views by using the Saved Viewpoints window.

1.	 Choose the Saved Viewpoints Dialog Launcher button from the Save, Load & Playback 
panel of the Viewpoint tab; the Saved Viewpoints window is displayed, as shown in 
Figure 3-37.

Figure 3-37  The Saved Viewpoints window

2.	 In the Saved Viewpoints window, click on the + icon corresponding to the Saved Views 
viewpoint folder; the folder is expanded, as shown in Figure 3-38.

Figure 3-38  Expanded view of the Saved Views folder

3.	 Select the Measurement option from the Saved Views folder, refer to Figure 3-38; the view 
is displayed in the Scene View, as shown in Figure 3-39. Close the Saved Viewpoints window.

Figure 3-39  The Measurement view in the Scene View
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Measuring Distance Using the Point to Point Tool
In this section, you will measure distance using the Point to Point tool.

1.	 Invoke the Point to Point tool from Review > Measure > Measure drop-down; the cursor 
is displayed on the screen.

2.	 Move and place the cursor at point 1 and click when the snap to vertex cursor appears, as 
shown in Figure 3-40.

Figure 3-40  The cursor placed at point 1 

3.	 Next, place the cursor on point 2 and click when the snap to vertex cursor appears; the 
calculated distance is displayed in the Scene View, as shown in Figure 3-41.

Figure 3-41  Distance calculated between point 1 and 2
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Measuring Distances Using the Point Line Tool
In this section, you will measure distance using the Point Line tool.

1.	 Invoke the Point Line tool from the Review > Measure > Measure drop-down; the cursor 
appears on the screen and the previously calculated distance disappears.

2.	 Place the cursor on point 1 and click when the snap to vertex cursor appears, as shown in 
Figure 3-42.

Figure 3-42  The cursor placed at point 1

3.	 Next, place the cursor on point 2 and click when the snap to vertex cursor appears; the 
calculated distance is displayed in the Scene View, as shown in Figure 3-43.

Figure 3-43  Distance calculated between point 1 and 2

4.	 Repeat the procedure followed in steps 1 through 3 to calculate the total distance between 
1 and 5; the calculated distance is displayed in the Scene View, as shown in Figure 3-44.
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Figure 3-44  The total distance calculated between point 1 and 5

Measuring Distances Using the Accumulate Tool
In this section, you will measure distances using the Accumulate tool.

1.	 Invoke the Accumulate tool from Review > Measure > Measure drop-down; the cursor 
appears on the screen and the previously calculated distance disappears.

2.	 Place the cursor on point 1 and click when the snap to vertex cursor appears, as shown in 
Figure 3-45.

Figure 3-45  The cursor placed at point 1

3.	 Next, place the cursor on point 2 and click when the snap to vertex cursor appears; the 
calculated distance is displayed in the Scene View, as shown in Figure 3-46.
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Figure 3-46  Distance calculated between point 1 and 2

4.	 Again, click on the point 2 and then click on point 3; the calculated distance is displayed 
in the Scene View, as shown in Figure 3-47.

Figure 3-47  Distance calculated between point 1 and 3

5.	 Repeat the procedure followed in step 3 and calculate the distance between point 1 and 4, 
and point 1 and 5, refer to Figure 3-48 and Figure 3-49.
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Figure 3-48  Distance calculated between point 1 and 4

Figure 3-49  Distance calculated between point 1 and 5

Note
To save the dimensions, choose the Convert to Redline tool from the Measure panel in the Review 
tab; the view will be saved in the Saved Viewpoints window.

Saving the Project
In this section, you will save the project.

1.	 Choose Save As from the Application Menu; the Save As dialog box is displayed.

2.	 Browse to Navisworks_2016 folder and enter c03_navisworks_2016_tut01 in the File name 
edit box. 

3.	 Next, select the Navisworks File Set (*.nwf) file format from the Save as type drop-down 
list and then choose the Save button; the project is saved.
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Tutorial 2			      Creating Tags and Calculating Area 
In this tutorial, you will open the file c03_navisworks_2016_tut2.nwf. Next, you will add 
tags to four corners of the roof and calculate the area of roof using the Add Tag and Area 
tools.	                                                                                                   (Expected time: 45min)
								           
The following steps are required to complete this tutorial:

a.	 Open the file c03_navisworks_2016_tut2.nwf.
b.	 Display the saved views.
c.	 Add tags.
d.	 Calculate area.
e.	 Add text.
f.	 Save the project.

Opening the File
In this section, you will open the file in Navisworks.

1.	 Choose the Open button from the Quick Access Toolbar; the Open dialog box is displayed.

2.	 In this dialog box, browse to the following location:
	 C:\nws_2016\c03_nws_2016_tut.

3.	 Select Navisworks File Set (*.nwf) from the Files of type drop-down list.

4.	 Select the file c03_navisworks_2016_tut2 from the displayed list of files; the file name is 
displayed in the File name edit box.

5.	 Choose the Open button from the dialog box; the model is displayed in the Scene View, 
refer to Figure 3-36 ( same as Tutorial 1).

Displaying the Saved Views
In this section, you will display the saved views by using the Saved Viewpoints window.

1.	 Choose the Saved Viewpoints Dialog Launcher button from the Save, Load & Playback 
panel of the Viewpoint tab; the Saved Viewpoints window is displayed, refer to Figure 3-37.

2.	 In the Saved Viewpoints window, click on the + icon corresponding to Saved Views view-
point folder; the folder expands, refer to Figure 3-38.

3.	 Select the Area option from the Saved Views folder, as shown in Figure 3-50; the view is 
displayed in the Scene View, as shown in Figure 3-51. Now, close the Saved Viewpoints 
window.
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Figure 3-50  Expanded view of the Saved Views folder

Figure 3-51  The Area view in the Scene View

Adding Tags
In this section, you will add tags to the four corners of the roof using the Add Tag tool.

1.	 Choose the Add Tag tool from the Tags panel in the Review tab; the shape of the cursor is 
changed to pencil.

2.	 Place the cursor at the corner of Wing A, as shown in Figure 3-52.

3.	 Double-click on the specified location; the tag 6 is created and the Add Comment dialog 
box is displayed.

4.	 In the dialog box, add the comment Corner point 1 in the text box and choose the OK 
button; the dialog box is closed and the tag is created, as shown in Figure 3-53.

Figure 3-52  Placing the Tag cursor Figure 3-53  Tag 1 created at the corner
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5.	 Repeat the procedure followed in steps 1 through 4 and add tags on both the wings, as 
shown in Figure 3-54.

Figure 3-54  Tags created on both the wings

Note
Enter the comment as Corner point 2, Corner point 3, and so on in the Add Comment dialog box.

Calculating Area
In this section, you will calculate area of both the roofs.

1.	 Choose the Area tool from Review > Measure > Measure drop-down.

2.	 Place the cursor on the corner 6 in Wing A and click when the snap to vertex cursor appears.

3.	 Similarly, click on the corners 7, 8, and 9; the calculated area is displayed in the Scene View, 
as shown in Figure 3-55.

Figure 3-55  Area of roof WingA

 Note
Right-click to change the location of cursor while measuring the area.

4.	 Similarly, click on the four corners 10, 11, 12, and 13; the calculated area is displayed and 
which is almost equal to the area of Wing A.
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Saving the Project
In this section, you will save the project.

1.	 To save the project with the current view, choose Save As from the Application Menu; the 
Save As dialog box is displayed.

2.	 Browse to nws_2016\c03_nws_2016_tut folder and enter c03_navisworks_2016_tut02 in the 
File name edit box.

3.	 Next, select Navisworks File Set (*.nwf) file format from the Save as type drop-down list, 
and choose the Save button; the project is saved.

Tutorial 3	              Finding Items and Saving as Search Sets
In this tutorial, you will open the file  c03_navisworks_2016_tut3.nwf and then find items based 
on their types and properties. After finding items, you will save them as search sets. 		
								              (Expected time: 20min)
The following steps are required to complete this tutorial:

a.	 Open the file c03_navisworks_2016_tut3.nwf.
b.	 Display the Find Items and Sets windows.
c.	 Specify the search criteria to find the items and save them as search set.
d.	 Save the project.

Opening the File
In this section, you will open the file in Navisworks.

1.	 Choose the Open button from the Quick Access Toolbar; the Open dialog box is displayed.

2.	 In this dialog box, browse to the following location:
	 C:\nws_2016\c03_nws_2016_tut.

3.	 Select Navisworks File Set (*.nwf) from the Files of type drop-down list.

4.	 Select the file c03_navisworks_2016_tut3 from the displayed list of files; the file name is 
displayed in the File name edit box.

5.	 Choose the Open button from the dialog box; the model is displayed in the Scene View.

Displaying the Dockable Windows
In this section, you will invoke the Find Items and Sets windows and dock them on the left side 
of the interface.

1.	 Choose the Find Items tool from Home > Select & Search panel; the Find Items window 
is displayed.

2.	 Place the cursor on the title bar of the window and double-click; the window is docked at 
the left side of the interface.
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3.	 Choose the Manage Sets option from Home > Select & Search > Sets drop-down list; the 
Sets window is displayed.

4.	 Place the cursor on the Title Bar in the Sets window, press and hold the left mouse button,  
drag the Sets window and over the Title Bar of the Properties window; the two windows are 
grouped together, refer to Figure 3-56.

Figure 3-56  Two windows grouped together

Finding Items and Saving Items
In this section, you will specify the search criteria to find the items and then save them as search 
sets.

1.	 In the Find Items window, click in the Category column; a drop-down list is displayed. 
Select Item from the drop-down list. Similarly, select Type, Contains, and Columns from 
the Property, Condition, and Value columns, respectively, refer to Figure 3-57.

2.	 Choose the Find All button; the columns are selected and highlighted in the Scene View.

3.	 Choose the Hide Unselected tool from Home > Visibility panel; all the selected columns 
are displayed, refer to Figure 3-58.

4.	 Choose the Unhide All tool from Home > Visibility panel; the whole model will be displayed.
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Figure 3-57  The Find Items window displaying various settings for the 
search operation

Figure 3-58  Columns displayed in Scene View

5.	 Choose the Sets tab in the grouped window; the Sets window is displayed. Choose the 
Save Search button; a search set is created. Right-click on the created search set; a shortcut 
menu is displayed. Choose the Rename option from the menu and name the search set as 
Columns and press ENTER.
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6.	 Choose the Find Items tab to display the Find Items window. Now, specify a different search 
criteria, as shown in Figure 3-59.

Figure 3-59  The Find Items window displaying the search criteria

7.	 Choose the Find All button; objects that have the glass material assigned are highlighted 
in the Scene View.

8.	 Repeat the procedure followed in step 5 and save the selected objects as search set with  the 
name Glass and press ENTER.

Saving the Project
In this section, you will save the project.

1.	 To save the project with the current view, choose Save As from the Application Menu; the 
Save As dialog box is displayed.

2.	 Browse to nws_2016/c03_nws_2016_tut folder and enter c03_navisworks_2016_tut03 in the 
File name edit box.  

3.	 Next, select Navisworks File Set (*.nwf) file format from the Save as type drop-down list 
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and then choose the Save button; the project is saved.

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The Selection Tree is invoked from the __________ panel of the Home tab.

2.	 Selection Inspector contains a list of all the __________ objects.

3.	 The  __________ option is used to reverse the selection.

4.	 The properties of an item in the model can be analyzed using the __________ window.

5.	 The __________ gizmo is used to move the selected item.

6.	 The Select tool is used to select a particular item in a model. (T/F)

7.	 The Quick Find tool is used to analyze the properties of an item in the model. (T/F)

8.	 In the Properties window, you cannot add a custom property to a selected item. (T/F)

9.	 You can invoke the transformation gizmo from the Animation tab. (T/F)

10.	 The Accumulate option is used to calculate the area. (T/F)

Review Questions
Answer the following questions:

1.	 Which of the following tabs is part of the Selection Tree window?

           a) Standard 		  b) Compact
           c) Properties		  d) All of these

2.	 Which of the following tools is not a selection tool?

           a) Same Name 		  b) Same Type
           c) Same Timeliner	 d) Require

3.	 Which of the following tools is used to control the visibility of objects in the model?

           a) Append 		  b) Merge
           c) Find Items 		  d) None of these

4.	 Which of the following tools is not a transformation tool?
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           a) Rotate 		   b) Scale
           c) Move  			   d) Text
5.	 Which of the following tools is not used as the Measure tool?

           a) Point to Point 		  b) Area
           c) Add Tag                        d) Angle 

6.	 The Measure tools are invoked from the Item Tools tab. (T/F)

7.	 The Point to Multiple Points tool is used to calculate the total distance between multiple 
points. (T/F)

8.	 The Add Link tool is used to customize the appearance of a model. (T/F)

9.	 The Sets window contains only a list of saved viewpoints. (T/F)

10.	 The Convert to Redlines tool is used to convert measurements to redlines. (T/F) 

Exercise 1						           Measuring Height
EXERCISE

Download the c03_navisworks_2016_ex1 file from http://www.cadcim.com. The path of the file is as 
follows: Textbooks > Civil/GIS > Navisworks > Exploring Autodesk Navisworks 2016. Open the file 
and then calculate the height of the stairs above the ground. Create tags across the four corners 
of the wall and calculate area of the wall. Figure 3-60 shows the Residence Building model to 
be used in this exercise. 					                       (Expected time : 30min)
                                                                                                               
The following steps are required to complete the exercise:

1.	 Open the file c03_navisworks_2016_ex1.
2.	 Display the saved views.
3.	 Calculate distance between point 1 and 2 using the Perpendicular Lock tool.
4.	 Create tags at the corners of the wall.
5.	 Calculate area of the wall.
6.	 Save the project.
7.	 Name of the file to be saved is c03_navisworks_2016_ex01.

Figure 3-60  The Residence Building
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Answers to Self-Evaluation Test
1. Select & Search, 2. selected, 3. Invert Selection, 4. Properties, 5. Move, 6. T, 7. F, 8. F, 9. 
F, 10. F.


