
Chapter 1

Exploring the Black 
Magic Fusion 7 

Studio Interface

 
 Learning Objectives 
After completing this chapter, you will be able to:
• Start the Black Magic Fusion 7 Studio interface
• Work with the Fusion interface
• Understand the functions of various tools in Fusion
• Open, save, and close a composition
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INTRODUCTION TO Blackmagic Design Fusion 7 Studio 
Welcome to the world of Fusion, a node-based compositing software, that helps in creating 
visual effects and digital compositing for an array of films and commercials. Formerly known 
as Digital Fusion, it is used to combine two or more images and video sequences. Fusion has a 
node-based interface in which intricate processes are developed by linking up different nodes, 
called tools. It provides you greater flexibility and helps improve the artistic creativity. This 
software was originally developed by New York Production & Design in 1987 for its in-house use. 
Fusion has found its application in a number of movies, such as Avatar, Terminator Salvation, 
Final Destination II, and so on.
  
In this chapter, you will learn how to start Fusion as well as to load and save an image in Fusion. 
Also, you will explore the interface of Fusion.

Starting Blackmagic Design Fusion 7 Studio
To start Blackmagic Design Fusion 7 Studio, choose Start > All Programs > Blackmagic 
Design > Fusion > Fusion  from the taskbar, refer to Figure 1-1; the default Fusion interface 
will be displayed with its different components, as shown in Figure 1-2.

Figure 1-1  Starting Fusion from the taskbar

Fusion 7 Studio INTERFACE
The Fusion 7 Studio interface consists of menubar, Display Views, Work area, and Time Ruler, 
refer to Figure 1-2. These components of Fusion interface are discussed next.
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Figure 1-2  The Fusion 7 Studio interface

Menubar
The menubar is located on the top of the Fusion 7 Studio interface. It is used to access disk 
operations, editing functions, various tools, built-in scripts, and Fusion documentation.
   

Display View Area
The Display View area is used to view the output of the tools. By default, there are two views, 
namely left Display View and right Display View, refer to Figure 1-2. In this area, you can switch 
between the single view and separate views of a composite image by using the layout buttons 
in the toolbar.

Control Area
The Control area is located on the right of the Fusion interface and has two tabs: Tools 
and Modifiers. In the Tools tab, the attributes of a tool are specified. In the Modifiers tab, 
the modifiers will appear only if they are applied to the tool. The modifiers are used to create 
values for a control.

Work Area
The Work area is available below the Display Views, refer to Figure 1-2. It consists of six tabs. 
These tabs are discussed next.

Flow Tab
The Flow tab is used to create a network of tools. This network is formed by connecting nodes 
of the tools with the help of pipes. This tab is active by default.

Console Tab
The Console tab is used to display errors and status messages. This tab also displays output for 
scripts as well as render statistics.
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Timeline Tab
The Timeline tab is used to adjust the timing of footage in a composition.

Spline Tab
The Spline tab is used to edit the animation curves, paths, and modifiers. 

Comments Tab
The Comments tab is used to store comments and notes about a composition.

Chat Tab
The Chat tab is used to share comments with other users of the composition.

Time Ruler
The Time Ruler is available below the Work area. The Time Ruler consists of total number 
of frames in the current time segment. It consists of Timeline, buttons, and fields which are 
discussed next.

Global Start Time and Global End Time
These fields are used to define the length of a composition in frames. 

Render Start Time and Render End Time
These fields are used to represent the frames of a composition's output for the final and preview 
renders.

Render Button
This button is used for rendering the composition.

Playback Controls
These buttons are used to control the playback of a composition. 

Audio Enable
This is a toggle button is used to enable or disable the audio in the composition. 

Quality Controls
The buttons in this category help you to control the quality of a composition. There are five 
buttons in this category, HiQ(high quality), MB (Motion Blur), Prx (Proxy), APrx (Auto proxy), 
and Some. Generally, Fusion shows a low resolution version of the composition in the Display 
Views to provide faster interactive performance. With default settings, Fusion skips anti-aliasing, 
motion blur, and other computationaly expensive  processes. You can use the buttons in the 
Quality control category to re-enable these features. When the MB and HiQ buttons are chosen, 
Fusion will display the output exactly what is seen during a final render. The Some button is 
a toggle button that you can use to toggle between three modes: Some, None, and All. With 
default mode (Some), Fusion render the tools that are required to display image in the Display 
Views. The None mode is used to prevent interactive rendering of the tools. The All mode is 
used to force all tools to render. 
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Working with the Layout
There are various predefined layout styles available in Fusion. These styles

Figure 1-3  The 
layout buttons

can be accessed by choosing the layout buttons which are located below the 
toolbar, refer to Figure 1-3. In Fusion, you can also make modifications in 
different areas of the layout. The methods to make such modifications are 
discussed next.

1. 	 To change the size of Display Views, move

Figure 1-4  Resizing the Display View

 
the cursor over the divider line between  
them; a double-headed arrow will be 
displayed, as shown in Figure 1-4. You can 
drag the divider line to either side to resize 
the Display Views.

2.   	To change the size of the Work area, move 
the cursor over the divider line between the 

Figure 1-5  Resizing the Work area

D i s p l a y  Vi e w s  a n d  Wo r k  a re a ; a 
double-headed arrow cursor will be 
displayed, as shown in Figure 1-5. Drag to 
resize the Work area. 

3.   To change the size of the Control area, move 
the cursor over the divider line between the 
Display Views and Control area; a double-headed arrow will be displayed, as shown in 
Figure 1-6. Drag the divider line to resize the 

Figure 1-6  Resizing the Control area

Control area. 

USING THE TOOLBAR
The toolbar is located below the menubar. It is 
used to access commonly used tools in Fusion, 
refer to Figure 1-7. You can also access the tools 
in Fusion 7 Studio from the Tools menu in the 
menubar, as shown in Figure 1-8. The tools in 
the Tools menu are discussed next.

Figure 1-7  The Fusion toolbar

3D Tools 
The 3D tools are used to apply light, assign shaders, apply textures, and so on to an object.  
These tools can be accessed by choosing Tools > 3D from the menubar, refer to Figure 1-9.
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Light
The tools under the Light category are used to illuminate a scene. These tools 

Figure 1-8  The Tools 
menu

can be accessed by choosing Tools > 3D > Light from the menubar, refer 
to Figure 1-10. 

	 The tools in this category are discussed next.   
                    
    	 Ambient Light                                               
	 This tool is used to illuminate a 3D scene globally from all directions. 

Directional Light
	 This tool is used to simulate a distant light source which casts parallel 

light rays in single direction.

Point Light
	 This tool is used to illuminate a scene by emitting the light in all 

directions. 

Spot Light
This tool is used to simulate a conical shaped focussed beam of light. 
This is the only light in Fusion which casts shadows.

 

Figure 1-9  The 3D tools Figure 1-10  The Light tools

Material
Materials are used to add realism to a scene. A material defines how a 3D object reflects or 
transmits light. You can apply materials to an object  by using the Material tools. The Material 
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tools can be accessed by choosing Tools > 3D > Material  from the menubar, refer to Figure 1-11. 
The tools used for applying material are discussed next.
						             

Figure 1-11  The Material tools

	
      Blinn                                                            

This tool is used to apply basic illumination 
material on a 3D object.

Channel Boolean
This tool is used to modify the channels of a 3D 
object by using mathematical operations.

CookTorrance
The use of this tool is similar to that of the 
Blinn tool. However, the specular highlights are 
calculated using Fresnal/ Beckham equation when 
this tool is used. This tool is mainly used to shade 
shiny and highly reflective surfaces. 

Mtl Merge 
This tool is used to combine two different 
materials to form a complex shader.

Phong
This tool is used to simulate shiny plastic 
surfaces. It produces highlights similar to that produced by the Blinn tool.

Reflect
This tool is used to add environment map reflection and refraction to the material. It is 
usually connected with basic material to form a reflection or refraction pattern.

Stereo Mix
This tool is used to apply separate materials to the left and right eyes in a stereo pair. 

Ward
This material is applied to a 3D object to give it a brushed metal look. The highlights can 
be adjusted in the U or V direction of the mapping coordinates.

Texture
Texture is a bitmap that can be wrapped on a 3D object to change the appearance of the existing 
texture. The tools in the Texture category can be accessed by choosing Tools > 3D > Texture 
from the menubar, as shown in Figure 1-12. The tools in this category are discussed next.

BumpMap
	 This tool is used to convert a bitmap to a bump material. 
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Catcher					                  	
This tool is used to intercept projections cast from the 

Figure 1-12  The Texture tools

Projector 3D and Camera 3D tools. The 
projections are then converted to a texture map 
and applied by the Catcher material to the 
geometry it is connected to.
						                
CubeMap					  
This tool is used to create texture maps using 
separate images for each face of the cube. It also 
provides coordinates for texture rotation.

Falloff
This tool is used to blend two materials  based on 
the incidence angle between the object on which 
the material is applied and the camera.

Fast Noise Texture
This tool is used to generate a noise texture 
directly as a material on an object.

Gradient
This tool is used to apply texture on an object with a variety of gradients types.

SphereMap
This tool is used to create a spherical texture map from an image.

Texture 2D
This tool is used to convert an image to a 3D material.

Texture Transform
This tool is used to translate, rotate, and scale image textures on the input material along 
the U, V, and W axes.

Alembic Mesh 3D
Alembic is a file format for meshes and animated scenes. You can easily import an Alembic mesh 
in Fusion using this option.

Bender 3D
This tool is used to bend, taper, or twist a 3D geometry. However, it only affects the geometry 
in a 3D scene.

Camera 3D
This tool is used to create a virtual camera through which a 3D scene can be viewed.

Cube 3D
This tool is used to create a simple cube. On using this tool, six additional image inputs for each 
face are displayed. You can apply texture on these faces individually.



Exploring the Blackmagic Design Fusion 7 Studio Interface 	               1-9

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Displace 3D
This tool is used to displace vertices along normals based on a reference image.

Duplicate 3D
This tool is used to duplicate a geometry in a 3D scene. You can create repeating transformation 
patterns using this tool.

FBX Exporter
This tool is used to export a Fusion 3D scene to the FBX interchange format. It also 
supports formats like .3ds, .dae, .dxf, and .obj.

FBX Mesh 3D
This tool is used to import complex polygonal geometry saved using the FBX format. It imports 
geometry in the FBX, OBJ, 3DS, DAE, and DXF file formats.

Note
In Fusion 7’s 3D system you can import geometry from FBX and Alembic file formats, as well as 
OBJ, 3DS, and Collada formats. Now, you can easily import meshes with millions of polygons, 
complex shaders, Ambient Occlusion, Deep Volumetric Atmospherics, Particles Systems, and so on.

Fog 3D
This tool is used to generate depth-based fog in a 3D scene.

Image Plane 3D
This tool is used to used to create a 2D planar geometry in 3D space.
 
Locator 3D
This tool is used to transform, scale, or rotate a point in 3D space along 2D coordinates so that 
other tools can use it as a part of expressions.

Merge 3D
This tool is used to merge 3D elements into 3D environment.

Override 3D
This tool is used to override settings of a 3D object in a 3D scene.

PointCloud 3D
This tool is used to create a point cloud by importing a 3D scene and collects all the null points 
created by a 3D tracking software.

Projector 3D
This tool is used to project an image onto a 3D geometry. 

Renderer 3D
This tool is used to render 3D environment into a 2D image by using one of the cameras present 
in the scene. It supports two render engines: Software and Open GL.
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Replace Material 3D
This tool is used to change the material applied to all geometries in the input scene with its 
own material input. 

Replace Normal 3D
The Replace Normal 3D tool is used to replace the normals on geometry. The geometry must 
have texture coordinates. All geometry in the scene is affected except the lights, camera, point 
clouds, and locators. Other non mesh tools are not affected by this tool. 

Replicate 3D
The Replace 3D tool is used to replicate two or more geometries at the position of 
the target vertices. The geometries can be replicated at the vertices of a mesh. You can also 
replace particles with the geometry. You can apply various transformations for each copy of 
replicated geometry.

Ribbon 3D
Ribbon 3D is used to generate a segments or a line between two points. You can use this tool 
for creating motion graphics art work.

Shape 3D
This tool is used to create a basic primitive 3D shape including planes, spheres, and 
cylinders, which can be transformed, rotated, scaled, and rendered.

SoftClip
This tool is used to fade out the geometry or particles which are close to the camera.

Text 3D
This tool is a 3D version of the 2D Text+ tool. Most of the controls found in this tool are similar 
to that of the Text+ tool except that it supports all shading elements. The Text+ tool will be 
discussed later in this chapter.

Transform 3D
This tool is used to translate, scale, and rotate 3D objects in a scene.

UV Map 3D 
This tool is used to replace the UV texture coordinates on the geometry in a scene.

Weld 3D 
This tool is used to weld adjustment vertices. It does not weld normals, texture coordinates, or 
any other vertex stream. 

Blur Tools   
Blur tools are used to blur or sharpen an image. These tools can be accessed by choosing 
Tools > Blur from the menubar, as shown in Figure 1-13.  The Blur tools are discussed next. 
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Blur
This tool is used to blur the input image.

                                                                                                                                      
Defocus 
This tool is used to defocus an image by simulating an 

Figure 1-13  The Blur tools

out-of-focus camera lens effect. 

Directional Blur
This tool is used to create directional and radial blurs. 
It is also useful in creating motion blur glow.

Glow
This tool is used to generate glow effect on an image 
by blurring an image and then brightening the image 
to produce glow. 

Sharpen
This tool is used to enhance the detail of an image.

Soft Glow
This tool is used to simulate natural and soft glow 
effects in an image.

Unsharp Mask
This tool is used to sharpen only the edges within an 
image.

VariBlur
This tool is used to add per pixel blur to an image. It 
uses a second image to control the magnitude of the 
blur.

Vector Motion Blur
This tool is used to create directional blur on an input image based on the vector channel. 

Color Tools
Color tools are used to adjust the appearance of the images in a composition, make tonal 
adjustment, set gain, make gamma correction, and so on. These tools can be accessed by 
choosing Tools > Color from the menubar, as shown in Figure 1-14. The tools in this category 
are discussed next.

Auto Gain
This tool is used to adjust the color range of an image automatically to set the darkest and brightest 
pixels to the user-specified values.   
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Brightness / Contrast                                        
This tool is used to control the gain, brightness, contrast,

Figure 1-14  The Color tools

 
gamma, and saturation of an input image.

Channel Booleans
This tool is used to perform mathematical and logical 
operations on channels of an image. 

Color Corrector
This tool is used to adjust the appearance of an image. 
It helps to correct the color with the help of histograms, 
levels, curves, and color compression functions.

Color Curves
This tool is used to perform LUT (Look Up Tables) color 
manipulations. It is an animatable spline-based tool.

Color Gain
This tool is used to adjust the gain, gamma, saturation, 
and hue of an image. It renders faster as compared to the 
Color Corrector tool.

Color Matrix
This tool is used to modify values independently in different 
color channels. 

Color Space
This tool is used to convert a color space from one format to another. The default color space 
in Fusion is RGB (Red, Green, Blue). 

Gamut
This tool is used to convert a color from one gamut to another.

Hue Curves                                                          
This tool is used to adjust the color of an image by using spline curves. This tool is different from 
other color correction tools because this tool allows you to manipulate the splines to restrict the 
tools effect to a range of colors. 

OCIO CDLTransform
Fusion supports the OCIO (Open Color IO) workflow specified by Sony Imageworks. The color 
pipeline is made up from a set of color transformations defined by the OCIO-specific cofiguration 
files. The extention of these is .ocio.

OCIO ColorSpace	�    
This tool allows for color space conversions based on an OCIO Configuration file. The RGB 
color space defines a color as the percentages of red, green, and blue hues mixed together.
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OCIO File Transform
This tool is used to control the LUT files.

Set Canvas Color
This tool is used to set the color of the workspace A workspace is the area beyond the defined 
pixels within an image (the DOD).

White Balance
This tool is used to correct the color casts in an image which are usually caused by incorrect 
setup of a camera or lighting conditions.

Composite Tools                                                   
Composite tools are used to combine two images to form a 

Figure 1-15 The Composite tools

single image. The composite tools can be accessed by choosing 
Tools > Composite from the menubar, refer to Figure 1-15. 
The Composite tools are discussed next.      

Dissolve                                            
This tool is used to dissolve/mix two images together, thereby 
providing a gradual transition between the two images. 
It generates a smooth transition between foreground and 
background images.

Merge
This tool is used to combine two images: background and 
foreground. This operation is based on the alpha channel 
associated with the foreground.

Creator Tools
Creator tools are used to produce solid backgrounds, noise, fractal 

Figure 1-16  The Creator 
tools

pattern, and 2D text. These tools can be accessed by choosing 
Tools > Creator from the menubar, as shown in Figure 1-16. The 
Creator tools are discussed next.  

Background                                   
This tool is used to produce color backgrounds and also complex 
loopable gradients.

DaySky     
This tool is used to create a procedural sky pattern based on a 
specific time and location on earth.

FastNoise
This tool is used to create a wide variety of noise effects using 
gradients such as procedural skies.
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Mandelbrot
This tool is used to generate an image based on the Mandlebrot fractal theory set. 

Plasma
This tool is used to create circular shapes, thereby generating a

Figure 1-17  The Deep Pixel tools

 
plasma-like effect. 

Text+
This tool is used to create 2D characters capable of 3D 
transformations. It also provides multiple styles and shading 
options to be applied on the text.

Deep Pixel Tools
Deep Pixel tools are used to generate various effects based on the 
Z-depth of the image. These tools can be accessed by choosing 
Tools > Deep Pixel from the menubar, refer to Figure 1-17. 
The different Deep Pixel tools are discussed next.

Depth Blur                                                                                            
This tool is used to generate the focal length or depth of field 
effects. 
                                                 
Fog
This tool is used to simulate fog effect on a 3D rendered image. It uses Z buffer channel to 
generate the 3D fog effect.

Shader
This tool is used to control lighting, reflection mapping, and 3D shading of elements in the 
rendered image. It uses X, Y, and Z normal maps in the image to control the light.

SSAO
SSAO stand for Screenspace ambient occlusion. It generates global lighting effects in a 3D scenes.

Texture
This tool is used to control the texture mapping of an element in a rendered image. It can also 
be used to replace current texture of an image. It relies on the U and V map channels in the 
rendered image.

Effect Tools
Effect tools are used to generate various effects. These tools can beaccessed by choosing Tools > 
Effect from the menubar, as shown in Figure 1-18. The various Effect tools are discussed next.

Highlight
This tool is used to create star-shaped highlights in the bright areas of an image.   
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Hot Spot
This tool is used to create lens flare, spotlight, and burn/dodge

Figure 1-18  The Effect tools

 
effect on an image.

Pseudo Color
This tool is used to create color variations, based on the waveforms 
generated by the tool controls.

Shadow
This tool is used to generate shadows based on the alpha channel 
information of an image.

Trails
This tool is used to generate trails effect. It first creates a frame 
buffer, then it takes the image data from the previous frames, 
and then merges that data over the current frame.

TV
This tool is used to replicate the flaws seen in analog television 
broadcasts and screens.

Film Tools                                                                                                    
Film tools are used to work with films. These tools can be accessed by choosing Tools > Film 
from the menubar, as shown in Figure 1-19. The various Film tools are discussed next.

Cineon Log                                                                                                    
This tool is used to convert an image data from logarithmic to linear. 

File LUT
This tool is used to apply Look Up Table ( LUT) to the image.

Film Grain
This tool is used to apply grain to an image so that the grain resembles the

Figure 1-19  The Film tools

 
grain profiles of the modern film stocks.

Grain
This tool is used to apply simulated grain to a video or 3D rendered 
image sequence.

Light Trim
This tool is used to emulate film scanner light trims. Generally, it is 
used with linear logarithmic images.

Remove Noise
This tool is used to remove noise from an image sequence. 
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Filter Tools
Filter tools are used to filter the RGB and alpha channels from an 

Figure 1-20  The Filter tools

image. These tools can be accessed by choosing Tools > Filter from 
the menubar, as shown in Figure 1-20. The various Filter tools are 
discussed next.  

Rank Filter
This tool is used to sort the pixel by value and then replace the color 
of all pixels by the color of the pixel with the specified rank.

Flow Tools
Flow tools are used to manage tool tiles in the Flow area. These tools 
can be accessed by choosing Tools > Flow from the menubar, refer 
to Figure 1-21. The various Flow tools are discussed next.

Sticky Note
This tool is used to write notes and comments for the specific area of a composition. 

Underlay
This tool is used to visually organize the tool tiles in the Flow area.

Figure 1-21  The Flow tools

Fuse Tools
The Fuse tools are created by using scripting language (eyeonScript). 
Fuses are like normal tools and they contain scripting commands. 
These tools can be accessed by choosing Tools > Fuses from the 
menubar. 

I/O Tools                                                                                                  
I/O tools are used to load or import and save an image sequence. 
I/O represents Input and Output. These tools can be accessed by 
choosing Tools > I/O from the menubar, refer to Figure 1-22. The 
various I/O tools are discussed next.

Loader
This tool is used to select and load the footage from hard-drive or 
network storage.

Saver
This tool is used to write the render of a composition to disk.

Macro Tools
These tools are used to collapse the complex tool effects into single customized tool.
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Mask Tools
Mask tools are used to mask out an area of an image. Each mask

Figure 1-22  The I/O tools

 
has its own set of controls unique to that mask type. These tools 
can be accessed by choosing Tools > Mask from the menubar, 
as shown in Figure 1-23. The various Mask tools are discussed 
next.

Bitmap 
This tool allows an image from the flow to act as a mask. 

BSpline
This tool is used to create smooth mask by using the B-spline 
handles.

Ellipse
This tool is used to create a mask by using circular shapes. 

Mask Paint
This tool is used to directly paint on the mask images using 
mouse pointer as a brush.

Polygon 						              
This tool is used to mask irregular-shaped objects. 	
	
Ranges
This tool is used to generate masks based on the tonal range.

Rectangle
This tool is used to create a rectangular or square shape mask. 

Triangle
This tool is used to create a mask that has no centre, size, or angle 

Figure 1-23  The Mask tools

control.

Wand
This tool is used  to mask out an image based on the magic wand 
style selection.

Matte Tools
Matte tools are used to generate alpha channels by removing selected 
colors from the footage. These tools can be accessed by choosing 
Tools > Matte from the menubar, as shown in Figure 1-24. The 
Matte tools are discussed next.
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Alpha Divide
This tool is used to divide an input image with it's alpha channel.

Figure 1-24  The Matte tools

Alpha Multiply
This tool is used to multiply an input image with it's alpha channel.

Chroma Keyer
This tool is used to generate an alpha channel by removing selected 
colors from the image.

Difference Keyer
This tool is used to create matte based on the differences between 
the two images.

Luma Keyer
This tool is used to generate an alpha channel by using the 
luminance of an image.

Matte Control
This tool is used to manipulate an existing alpha channel.

Ultra Keyer
This tool is used to pull a key from the images using the bluescreen and greenscreen backgrounds. 

 

Metadata Tools
Metadata tools are used for storing data within the data. These tools 

Figure 1-25  The Metadata 
tools

can be accessed by choosing Tools > Metadata from the menubar, 
refer to Figure 1-25. The Metadata tools are discussed next.

Copy Metadata                               
This tool is used to copy and filter the metadata.

Set Metadata
This tool is used to set the metadata.

Set Time Code
This tool is used to insert dynamic time code values into the meta-
data table based on the FPS settings.

Miscellaneous Tools
These tools can be accessed by choosing Tools >Miscellaneous 
from the menubar, as shown in Figure 1-26. The Miscellaneous 
tools are discussed next.
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Auto Domain
This tool is used to set the Domain of Definition (DoD) of an image 

Figure 1-26  The Miscellaneous 
tools

automatically.

Change Depth
This tool is used to change bits per channel depth of an image.

Custom Tool
This tool is used to create custom expressions and filters to 
modify an image.

Fields
This tool offers several functions related to interlaced video 
frames.

RunCommand
This tool is used to execute external commands or batch files 
at certain points while rendering.

Set Domain
This tool is used to set the active area of an image without 
changing its physical dimension.

Time Speed
This tool is used to speed up, slow down, reverse, or delay the image sequences.

Time Stretcher
This tool is used to animate the speed of the clip.

OpenCL Tools
These tools are OpenCL (Open Computing Language) clones of 

Figure 1-27  The Particles tools

source native compiled tools. Open CL language allows you to 
take the full advantage of modern day graphic cards. 

These tools can be accessed by choosing Tools > OpenCL from 
the menubar.

Paint Tool
This tool is used to paint directly on the image by using brush 
strokes. It is used for cloning, wire removal, and masking. 
This tool can be accessed by choosing Tools > Paint from the 
menubar. 

Particles Tools
Particles are computer generated points in 3D space and help 
in creating a wide variety of effects. These tools can be accessed 
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by choosing Tools > Particles from the menubar, as shown in Figure 1-27. The Particles tools 
are discussed next.

pAvoid
This tool is used to create an area within an image so that the affected particles do not enter 
or cross.

pBounce
This tool is used to create an area wherein the particles will bounce away when they come in 
contact with it. 

pChangeStyle
This tool is used to change the appearance and style of particles when they come in contact with 
a defined region.

pCustom
This tool is used to create custom expressions. These expressions affect the properties of the 
particles.

pDirectionalForce
This tool is used to apply a unidirectional force. As a result, on invoking this tool, particles move 
along the defined direction.

pEmitter
This tool is used to emit particles. It is the first tool in a particle tools network.

pFlock
This tool is used to simulate the behavior of organic systems such as a flock of birds. Each particle 
attempts to stay close to the other particle.

pFriction
This tool is used to apply friction to particles on a specified region.

pGradientForce
This tool is used to increase the speed of particles by a force generated by gradients. Particles 
accelerate from white to black area of the gradient.

pImageEmitter
This tool is used to emit particles from an input image. The color of the particles depends on 
the input image.

pKill
This tool is used to kill the particle, if it crosses or intersects the tool's region. 

pMerge
This tool is used to combine particles from two different emitters.
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pPointForce
This tool is used to attract or repel particles within its sphere of influence by applying a force 
to them.

pRender
This tool is used to convert a particle system to 2D image.

pSpawn
This tool is used to spawn particles from existing particles, thereby making each affected particle 
produce more particles on its own.

pTangentForce
This tool is used to apply a tangential force on particles.

pTurbulence
This tool is used to generate frequency-based turbulence to particles.

pVortex
This tool is used to apply a circular force to each particle in the particle system.

Position Tools
The Position tools are used to work with masks and volumetrics for

Figure 1-28  The Position tools

 
images having XYZ position channels. These tools can be accessed 
by choosing Tools > Position from the menubar, as shown in 
Figure 1-28. The Position tools are discussed next.

Volume Fog
This tool is used to create volumetric fog on images containing 
XYZ Position channels.

Volume Mask
This tool is used to create volumetric masks from images 
containing XYZ Position channels.

Z to WorldPos
This tool is used to either generate a world position pass from a 
Z-channel and a 3D camera or a Z-channel from a world position 
pass and a 3D camera.

Primatte Tool
The Primatte tool is an advanced green/blue screen keyer. It provides advanced techniques for 
extremely fine manipulations of the color regions. This tool can be accessed by choosing Tools > 
Primatte from the menubar. 
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Stereo Tools
Stereo tools are used for creating and processing stereoscopicimages. 

Figure 1-29  The 
Stereo tools

These tools can be accessed by choosing Tools > Stereo from the menubar, 
refer to Figure 1-29. The Stereo tools are discussed next.

Anaglyph
This tool is used to create stereoscopic images by combining the left and 
the right eye images.

Combiner
This tool is used to stack two stereoscopic images side by side or on top 
of each other.

Splitter
This tool takes input of the Combiner tool and provides two output im-
ages one each for the left and right eyes.

Tracking Tool
This tool is used to detect and follow pixel patterns across frames in an 
image sequence. Additionally, you can use this tool for stabilizing and reverse stabilizing an 
image sequence. 

Transform Tools
These tools are used to transform a 2D image by moving, scaling, or 

Figure 1-30   The Transform 
tools

rotating it. These tools can be accessed by choosing Tools > 
Transform from the menubar, refer to Figure 1-30.  The Transform 
tools are discussed next.

Camera Shake
This tool is used to generate a variety of camera shape style motions 
from organic to mechanical.

Crop
This tool is used to crop a portion of an image or offset the image 
into a larger image area.

DVE
This tool is used to transform an image and also to add perspective 
to an image.

Letterbox
This tool is used to change the frame size and aspect ratio of an input image to the frame size 
and aspect ratio of another image.

Resize 
This tool is used to increase or decrease the resolution of an image. 
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Scale 
This tool is similar to the Resize tool but it uses relative dimensions to specify the changes.

Transform
This tool is used for 2D transformations of an image.

Warp Tools
Warp tools are used to distort the input image. These tools can be

Figure 1-31  The Warp tools

 
accessed by choosing Tools > Warp  from the menubar, as shown 
in Figure 1-31. The various Warp tools are discussed next.

Coordinate Space
This tool is used to modify the coordinate space of an input image 
from rectangular to polar and polar to rectangular.

Corner Positioner 
This tool is used to modify the position of four corners of an image 
interactively.

Dent 
This tool is used to distort an image by creating a circular deformation. 

Displace
This tool is used to displace/refract an image based on the 
displacement map.

Drip 
This tool is used to create ripple effects of different shapes in an image such as circular, square, 
and so on.

Grid Warp
This tool is used to deform an image by using a 2D deformation grid which has flexible vertices. 

Lens Distort
This tool is used to add or remove the lens distortion in an image.

Perspective Positioner
This tool is used to modify the position of an image by adjusting corner points to remove the 
perspective from an image.

Vector Distortion 
This tool is used to distort the input image along the X and Y axes individually based on vector 
channel data.
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Vortex 
This tool is used to create a swirling whirlpool effect on the specified region of an image.

OPENING A COMPOSITION
To open a composition in Fusion, choose File > Open from the menubar; the Open dialog box 
will be displayed, as shown in Figure 1-32. In this dialog box, navigate to the desired folder 
and select the composition. Next, choose the Open button; the composition will be displayed. 

Figure 1-32  The Open dialog box
Note
The extension of Fusion file is .comp

SAVING A COMPOSITION
To save a composition, choose File > Save from the menubar. Alternatively, press CTRL+S; the 
Save File dialog box will be displayed, as shown in Figure 1-33. Now, enter the desired name of 
the composition and then choose the Save button.

Figure 1-33  The Save File dialog box
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CLOSING A COMPOSITION
To close a composition, choose File > Close from the menubar; a message box will be displayed, 
as shown in Figure 1-34. Choose the Yes button to save the changes made, the No button to 
discard the changes, or the Cancel button to close the message box.

Figure 1-34  A message box prompting to save the changes made

Using the Undo and Redo Commands in Fusion
In Fusion, you can use the Undo and Redo commands to undo and redo the steps performed 
earlier. To undo a step, choose Edit > Undo from the menubar or press CTRL + Z. To redo 
a step, choose Edit > Redo from the menubar or press CTRL+Y. You can also delete tools by 
first selecting them and then pressing DEL.

General HotKeys
In Fusion, you can invoke some of the commands by using hotkeys. The main hotkeys and their 
functions are given next.

Hotkey Function

CTRL+ N Creates a new composition

CTRL + O Opens an existing composition

CTRL + S Saves the composition

CTRL + Z Used to undo the last action performed

CTRL+ Y Used to redo the last action performed

CTRL + X or SHIFT+DEL Cuts the selected item in the clipboard

CTRL + C Copies the selected tools in the clipboard

CTRL + G Creates a group of selected tools

CTRL + V Pastes the selected tools from the clipboard

[ Moves forward one frame on the timeline

] Moves backward one frame on the timeline

ALT + [ Advances to the next keyframe

ALT + ] Moves back to the previous keyframe

Function Keys 
The function keys are used to perform various functions. The main function keys and their 
functions are given next.
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Key Function

F1 Displays the help for the selected tool

F2 Renames the selected tools

F4 Maximizes and restores the selected area

F5 Activates the Flow area in the Work area

F6 Activates the Console area in the Work area

F7 Activates the Timeline area in the Work area

F8 Activates the Spline area in the Work area

F11 Activates the Modifiers area in the Control area

F12 Displays the Render Settings dialog box

Display Views Keys
These keys are used to view the composition in different channels. These keys and their functions 
are given next.

Key Function

R Displays the red channel in the selected Display View

G Displays the green channel in the selected Display View

B Displays the blue channel in the selected Display View

A Displays the alpha channel in the selected Display View

Z Displays the Z channel in the selected Display View

C Displays full color image in the selected Display View

V Displays the selected sub views in the Display View

SHIFT + V Swaps the content of the Display View and sub view

CTRL + L Locks the Display View

CTRL + Q Toggles quad view in the selected Display View

CTRL + K Toggles the Show Controls button

CTRL + G Toggles the display of guides

SHIFT + H Toggles the display of handles on spline keypoints

, (comma) Switches the view to use the A image buffer

. (period) Switches the view to use the B image buffer

/ Switches the view so that it shows both the A and B buffers and 
enables splitwipe

Flow Area Keys
These keys are used to perform various functions in the Flow area. These keys and their functions 
are given next.
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Key Function

CTRL + F Displays the Find tools dialog box

CTRL + L Toggles the lock mode of the selected tool

V Toggles the display of the navigator

Spline Area Keys
These keys are used to perform various functions in the Spline area. These keys and their 
functions are given next.

Key Function

S Smoothens the curve of the selected points on a spline or polyline

V Reverses the selected keyframes on a spline

CTRL + drag Copies the selected points on a spline

Time Ruler Keys
These keys are used to perform functions in the Time Ruler area. These keys and their functions 
are given next.

Key Function

CTRL + SHIFT+ double-click Sets the render range to the slider range

CTRL + Drag Sets the render range to frames enclosed 
by dragging mouse

 Self-Evaluation Test  
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following components is located at the bottom of the Fusion interface?

	 (a) Control area				   (b) Timeline
	 (c) Toolbar				    (d) Display View

2. 	 The __________ is located on the right of the Fusion interface.

3. 	 The Work area consists of __________ tabs.

4. 	 The __________ tool is used to combine two images. 

5.	 The __________ View displays the output of the tools in a composition.

6. 	 The ___________ tool uses luminance of an image to create the alpha channel.

7. 	 The ___________ tool is used to increase or decrease the resolution of an image.
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8. 	 The __________ tool is used to load a footage.

9. 	 The __________ tool is used to color-correct the image.

10.	  The Dissolve and Merge tools are Composite tools. (T/F). 

 Review Questions  

Answer the following questions: 

1.	 Which of the following Material tools is used to modify 3D material by using mathematical 
operations?

	 (a) Mtl Merge				     (b) Ward
	 (c) Phong				     (d) Channel Boolean

2.	 Which of the following Mask tools is used to mask an irregular shape?

	 (a) Range				    (b) Polygon
	 (c) Triangle				    (d) Ellipse

3.	 Which of the following combinations of shortcut keys is used to open a new composition?

		  (a) CTRL+O	 			   (b) CTRL+S
	 (c) CTRL+N				    (d) CTRL+Z

4.	 The Work area is located below the __________ views.

5.	 The Mask tool comprises of _________ tools.

6.	 The extension of a Fusion file is __________ .

7.	 The __________ tool is used to stabilize or destabilize an image sequence.

8.	 The __________ light emits light in all directions.

9.	 The I/O tools help you load and save an image. (T/F)

10.	 The Soft Glow tool is used to give natural and soft glow effect to an image. (T/F)

Answers to Self-Evaluation Test
1. b, 2. Control area, 3. six, 4. Merge, 5. Display, 6. Luma Keyer, 7. Resize, 8. Loader, 
9. Color Corrector, 10. T


