
Chapter 2

Creating Network
of Tools

 Learning Objectives 
After completing this chapter, you will be able to:
• Set the frame format for the composition
• Merge multiple images
• Load a footage
• Color-correct the footage
• Connect and disconnect connections between tools
• Save and render a composition
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INTRODUCTION
Fusion is an advanced node-based compositing application for visual effects artists. Compositing 
is an art of combining multiple images to create a single image. You can create complex effects 
simply by connecting various nodes together. In this chapter, you will learn to create, save, and 
render a composition. You will also learn how to load and merge images. 

A Fusion composition consists of a network of nodes called tools. These tools are connected 
through pipes to form a composition. You can connect or disconnect pipes easily by using various 
methods which are discussed later in this chapter. 

In this chapter, you will also learn about Bins, where you can store references, compositions, and 
large quantity of data across the network. You can also access tools from this folder. 

TUTORIALS
Before you start the tutorials of this chapter, you need to download the c02_fusion_7_tut.zip file 
from http://www.cadcim.com. The path of the file is as follows:

	 Textbooks > Animation and Visual Effects > Fusion > Blackmagic Design Fusion 7 Studio: A 
Tutorial Approach

Next, you need to extract the contents of the zip file. To do so, navigate to the Documents folder 
and then create a new folder with the name Fusion_7. Next, extract the contents of the downloaded 
zip file to the Fusion_7 folder. 

 Tutorial 1                                                                    
In this tutorial, you will composite three images to create a single image. The final output of 
the composition is shown in Figure 2-1.                                                (Expected time: 25 min)

Figure 2-1  The final output of the composition
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The following steps are required to complete this tutorial:

a.    Set the frame format.
b.	 Download and import images.
c.	 View the output of the tools in Display Views.
d.	 Resize images.
e.    Color-correct the image.
f.	 Merge images.
g. 	 Prepare the composition for rendering.
h.	 Save and render the composition.

Setting the Frame Format
In this section, you will set the frame format for the composition.

1.	 Choose File > New from the menubar; a new composition is displayed in the Fusion 
interface, as shown in Figure 2-2.

Figure 2-2  The new composition displayed

2.	 Choose File > Preferences from the menubar; the Preferences dialog box is displayed, 
as shown in Figure 2-3.

3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed in the right of the Preferences dialog box. Next, 

select the NTSC (Square Pixel) option from the Default format drop-down list and then 
choose the Save button to save the changes made.

Note
If you generally work in a particular frame format, you can set it in the Global and new comp 
defaults preferences tree of the Preferences dialog box. As a result, the next time when you 
create a new composition, Fusion will inherit the preference settings for the new composition 
from the global preferences. 
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Figure 2-3  The Preferences dialog box

	 The Frame Format option allows you to set the various aspects(width, height, frame rate, 
aspect ratio) of the frame format settings for the composition. The footage may be NTSC, 
PAL, HD, or even Multimedia.

	
4.	 In the Time Ruler area, enter 0 in the Global End Time edit box.

	 The Time Ruler area control the playback as well as sets the composition options like current 
frame, quality, proxy level and motion blur.

Downloading and Importing the Images
In this section, you will download the images and import them to the composition.

1.	 Open the link http://www.freeimages.com/photo/1252649; an image is displayed.

2.	 Download the image to /Documents/Fusion_7/c02_tut/c02_tut_01/Media_Files and save it with 
the name sunset.jpg.

Note
Footage Courtesy: Colin Broug (http://www.freeimages.com/profile/ColinBroug).
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3.	 Choose the LD button from the toolbar; the Open File dialog box is displayed, refer  
to Figure 2-4. Next, choose Documents > Fusion_7 > c02_tut > c02_tut_01 > 
Media_Files > sunset. jpg from the dialog box and then choose the Open button; 
the Loader1 tool tile is inserted in the Flow area, refer to Figure 2-5. 

	
	 The Loader tool is used to select and load the footage from hard-drive or network storage.

Figure 2-4  The Open File dialog box

Figure 2-5  The Loader 1 tool tile inserted in the Flow area

Note
You can add the tools in the Flow area using one of the following methods:

1. Using the Tool menu from the menubar.

2. Right click in the Flow area; a shortcut menu is displayed. Choose Add Tool from the shortcut 
menu to add the tools.

3. Press CTRL+SPACEBAR to add the tools in the Flow area.

4. You can access the tools from toolbar.
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Viewing the Output of the Tools in the Display Views
In this section, you will view the output of the tools in the Display Views.

1.	 Make sure the Loader1 tool tile is selected in the Flow area and then press 1; the 
output of the Loader1 tool is displayed in the left Display View. Choose the Fit button 
from the left Display View toolbar to fit the image into the left Display View.

Note
You can create additional Display Views to view the output of the tools. To do so, choose 
Window > New Image View from the menubar; the View1 window is displayed, as shown 
in Figure 2-6. Now, to display the footage in the new Display View, press 3 or drag and drop 
the Loader1 tool tile in the View1 window.

Tip: 1. You can also drag and drop the loader tools into the Display Views to view the output 
of the tools. Alternatively, you can click on the black dots available at the bottom left corner 
of the tool tile to display the footage in the left, right, and additional views that you have 
created, refer to Figure 2-5.

2. If you choose the third dot in the tool tile, Fusion will display the output in full screen 
mode. Press Esc to exit this mode.

2. 	 Click on the empty space in the Flow area to deselect the

Figure 2-6  The View 1 window

 
Loader1 tool tile. Import tree.png from the location 
specified in step 3; the Loader2 tool tile is inserted in 
the Flow area,  as shown in Figure 2-7. 

3.	 Press 2; the output of the Loader2 tool is displayed 
in the right Display View. Next, choose the Fit button 
from the right Display View toolbar to fit the image in 
the right Display View.

4.	 In the control window of the Loader2 tool, choose the Import tab and then select the 
Post-Multiply by Alpha check box, refer to Figure 2-8; the transparency is displayed in the 
Display View. 

	 When you select the Post-Multiply by Alpha check box, the color values of the pixels are 
multiplied by their alpha values, thereby producing clear transparency.

Resizing the Images
In this section, you will resize the images.

1.	 Select the Loader1 tool tile from the Flow area and then choose the Rsz buttonfrom 
the toolbar; the Resize1 tool tile is inserted in the Flow area and a connection between 
Loader1 and Resize1 tools is established.
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Figure 2-8  Choosing the Import tab 
from the Loader2 tool control window

Figure 2-7  The Loader2 tool tile 
inserted in the Flow area

	 The Resize1 tool is used to increase or decrease the resolution of an image. 

Note 
To break the connection between two tools, click on the connecting arrow head and drop it into an 
empty space of the Flow area.

2.	 Select the Loader2 tool tile from the Flow area and then choose the Rsz button from  
the toolbar; the Resize2 tool tile is inserted in the Flow area and a connection between 
the Loader2 and Resize2 tools is established.

3.	 Set the values of the Width and Height parameters in the Resize1 and Resize2 tool control 
windows to 640 and 480, respectively.

Color-Correcting the Image
In this section, you will color-correct the tree image. 

1.  	 Select the Resize2 tool tile from the Flow area and then choose Tools > Color > 
Color Corrector from the menubar; the ColorCorrector1 tool is inserted in the Flow area 
and a connection between the ColorCorrector1 and Resize2 tools is established.

	 The Color Corrector tool is used to set the color of an image. It helps to manipulate the 
colors with the help of histograms, levels, curves, and color compression functions.

2.	 Make sure the ColorCorrector1 tool tile is selected in the Flow area and then press 2; the 
output of the ColorCorrector1 tool is displayed in the right Display View. 
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3.	 In the control window of the ColorCorrector1 tool, set the values of the parameters as 

follows:

	 Master - RGB - Gain: 0.18       Master - RGB - Brightness: -0.64

4.	 Choose the Suppress button in the ColorCorrector1 tool control window; the Suppress 
color wheel is displayed. In this color wheel, move the circles corresponding to yellow and 
green colors to the center of the color wheel, refer to Figure 2-9. 

	 The Suppress button is used to suppress the individual colors on an image. 

Merging the Images
In this section, you will merge the images.

1.	 Drag the red output node of the ColorCorrector1 tool tile 

Figure 2-9  The Suppress color 
wheel in the control window

to the red output node of the Resize1 tool tile; the Merge1 
tool tile is inserted in the Flow area and a connection 
between the Resize1, ColorCorrector1, and Merge1 tools 
is established. 

	 The Merge1 tool is used to combine background and 
foreground images.

Note
If you click on the red output node of a tool and then drag 
the cursor to the red output node of another tool, the Merge 
tool will appear automatically and pipes will be drawn 
between the tools.

 
2.	 Press 2; the output of the Merge1 tool is displayed in the 

right Display View. 

3.	 In the Merge1 tool control window, enter 1.49 in the Size 
edit box.

 
4.	 Click on the empty space in the Flow area to deselect the selected tool tile, if any. Choose the 

LD button from the toolbar; the Open File dialog box is displayed, refer to Figure 2-4. In 
this dialog box, choose Documents > Fusion_7 > c02_tut > c02_tut_01 > Media_Files > 
man standing.png; the Loader3 tool tile is inserted in the Flow area. 

5.	 Press 1; the output of the Loader3 tool is displayed in the left Display View. 

6.	 In the control window of the Loader3 tool, choose the Import tab and then select the 
Post-Multiply by Alpha check box. 

7.	 Make sure the Loader3 tool tile is selected in the Flow area. Next, choose the Rsz 
button from the toolbar; the Resize3 tool tile is inserted in the Flow area and a 
connection between the Loader3 and Resize3 tools is established.
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8.	 Click on the empty space in the Flow area to deselect the selected tool tile, if any. Choose 
the Mrg button from the toolbar; the Merge2 tool tile is inserted in the Flow area. Drag 
the red output node of the Merge1 tool to the orange node of the Merge2 tool to connect 
these tools. Similarly, connect the red output node of the Resize3 tool to the green node 
of the Merge2 tool. Next, press 2; the output of the Merge2 tool is displayed in the right 
Display View. 

9.	 In the control window of the Merge2 tool, set the values of the parameters as follows:

	 Center
	 X: 0.54			   Y: 0.26

	 Size: 0.21

10.	 Make sure the Merge2 tool tile is selected in the Flow area and then choose the CC
button from the toolbar; the ColorCorrector2 tool tile is inserted in the Flow area 
and a connection between the Merge2 and ColorCorrector2 tools is established. Next, 
press 2; the output of the ColorCorrector2 tool is displayed in the right Display View. 

11.	 In the ColorCorrector2 tool control window, set the values of the parameters as follows:

	 Tint: 0.11		  Strength: 0.28		  Master - RGB - Gain: 0.92

	 The Tint option is used to make the original color lighter and the Strength option controls  
the tint applied to the selected range of colors.

 	 After entering the values, the output of the ColorCorrector2 tool is displayed in the right 
Display View, as shown in Figure 2-10.

Figure 2-10  The output of the ColorCorrector2 tool

12. 	Click on the empty space of the Flow area to deselect the selected tool tile, if any. Choose 
Tools > Blur > Blur from the toolbar; the Blur1 tool tile is inserted in the Flow area.

	 The Blur tool is used to blur the input images.
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13.	 Drag the red output node of the ColorCorrector2 tool tile to the orange input node of the 

Blur1 tool tile; a pipe is drawn between the ColorCorrector2 and Blur1 tools to represent 
the connection between them. 

14.	 Press 1; the output of the Blur1 tool is displayed in the left Display View. 

15.	 In the control window of the Blur1 tool, enter 1.05 in the Blur Size edit box.

	 The Blur Size option controls the amount of blur applied to the image. 

Preparing the Composition for Rendering
Next, you will prepare the composition for rendering. 

1.	 Make sure the Blur1 tool tile is selected in the Flow area. Choose the SV button from the 
toolbar; the Save File dialog box is displayed, as shown in Figure 2-11. 

Figure 2-11  The Save File dialog box

2.	 Choose Documents > Fusion_7 > c02_tut > c02_tut_01 from the dialog box. Select JPEG 
Files (*.jpg; *.jpeg) from the File Type drop-down list. Next, enter composite.jpg in the 
File Name edit box. Next, choose the Save button. 

3.   Choose the Format tab in the Saver1 tool control window and move the Quality slider to 100.

Saving and Rendering the Composition
In this section, you will save and render the composition. You can also view the final render of 
the composition by downloading the file c02_fusion_7_rndr.zip from http://www.cadcim.com. The 
path of the file is given at the beginning of the chapter.
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1. 	 Choose File > Save from the menubar; the Save File dialog box will be displayed. In this 
dialog box, choose Documents > Fusion_7 > c02_tut > c02_tut_01 and then enter c02tut1 
in the File Name edit box. Next, choose the Save button to close the dialog box and save 
the composition.

2.	 Choose the Render button from the Time Ruler available below the Flow area, refer to 
Figure 2-12; the Render  Settings dialog box is displayed, as shown in Figure 2-13. Next, 
choose the Start Render button; the rendering process starts. On completion of rendering, 
the c02tut1.comp message box is displayed, as shown in Figure 2-14. Next, choose the OK 
button to close the message box.

Figure 2-12  The Time Ruler showing the Render button

Figure 2-13  The Render Settings dialog box

Figure 2-14  The c02tut1.comp message box informing 
about the completion of the rendering process

3.	 Navigate to /Documents/Fusion_7/c02_tut/c02_tut_01 and double-click on the composite0000.jpg 
file to view the final rendered output.
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 Tutorial 2                                                               
In this tutorial, you will create a composition and then render it. The final output of the 
composition is shown in Figure 2-15.		                                  (Expected time: 20 min)

The following steps are required to complete this tutorial:

a.    Create a new composition.
b.	 Load the footage.
c.	 Color-correct the footage.
d.	 Resize the footage.
e.	 Prepare the composition for rendering.
f.	 Save and Render the composition.

Figure 2-15  The final output of the composition

Creating a New Composition
In this section, you will create a new composition. 

1.  	 Choose File > New from the menubar; a new composition is displayed in the Fusion screen, 
refer to Figure 2-2.

	 Before you start working on the composition, you need to set the frame format, frame rate, 
and other parameters of the composition.

2.   Choose File > Preferences from the menubar; the Preferences dialog box is displayed, 
refer to Figure 2-3.
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3.	 In this dialog box, select Frame Format from the Composition# preferences tree; various
	 frame format settings are displayed in the right of the Preferences dialog box. Next, select 

the Pal / SECAM (D1) option from the Default format drop-down list and then choose the 
Save button to save the changes made.

Loading the Footage
Image or image sequences are loaded into Fusion by using the Loader tool. In this section, you 
will load the footage in the Flow area. 

1.	 Choose the LD button from the toolbar; the Loader1 tool tile is inserted in the Flow 
area and the Open File dialog box is displayed.

2.	 In this dialog box, choose Documents > Fusion_7 > c02_tut > c02_tut_02 > Media_Files > 
beach clip.mov. Next, choose the Open button. 

3.	 Make sure the Loader1 tool tile is selected in the Flow area and then press 1; the output 
of the Loader1 tool is displayed in the left Display View. Similarly, press 2 to display the 
Loader1 tool in the right Display View, refer to Figure 2-16. 

Figure 2-16  The output of the Loader 1 tool displayed in left and Right Display Views

Color-Correcting the Footage
In this section, you will color-correct the footage by using the Color Corrector tool. 

1. 	 Click on the empty space in the Flow area to deselect the selected tool tile, if any. Choose 
the Fit button from the left Display View toolbar to fit the image into the left Display View.

2.   	Choose Tools > Color > Color Corrector from the menubar; the ColorCorrector1 tool 
tile is inserted in the Flow area and its properties are displayed in the control window on 
the right of the interface, refer to Figure 2-17.
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3. 	 Drag the red output node of the Loader1 tool tile to the orange input node of 

the ColorCorrector1 tool tile; a pipe is drawn between the Loader1 and ColorCorrector1 
tools to make a connection between them.

4.  	 Select the ColorCorrector1 tool tile from the Flow area and 

Figure 2-17  The ColorCorrector1 
tool control window

press 2; the output of the ColorCorrector1 tool is displayed 
in the right Display View. Next, choose the Fit button from 
the right Display View toolbar to fit the image into the right 
Display View.

5.  	 In the control window of the ColorCorrector1 tool, set the 
values of the parameters as follows:

	 Tint: 0.33	 			   Strength: 0.072

	 Master - RGB - Contrast: 1.05	

	 Master - RGB - Gain: 1.15

	 Notice the change in the colors of the footage in the right 
Display View.

Resizing the Footage
In this section, you will resize the footage by using the Resize 
tool. 

1.	 Make sure the ColorCorrector1 tool tile is selected in the 
Flow area and then choose the Bins button from the toolbar; 
the Bins window is displayed. Expand Library on localhost 
in the left pane of the Bins window by clicking on the plus 
sign placed before it. 

2.	 Expand the Tools node and then select the Transform node from the left pane in the Bins 
window; the tools under the Transform category are displayed in the right pane. Double-click 
on the Resize tool in the Bins window; the Resize1 tool is connected to the ColorCorrector1 
tool and its properties are displayed in the control window. Next, close the Bins window.

Note
You can also drag and drop tools from the Bins window to the Flow area and then make connections 
between the tools based on your requirement.

3.	 Press 2; the output of the Resize1 tool is displayed in the right Display View. 

4.	 In the control window of the Resize1 tool, set the values of the parameters as follows:

	 Width: 625				    Height: 391

	 After entering the values in the Resize1 tool control window, the output of the tool is dis-
played, refer to Figure 2-18.
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Figure 2-18  The Resize1 tool in the Flow area and its output in the right Display View

Preparing the Composition for Rendering
In this section, you will prepare the composition for rendering. 

1.	 Make sure the Resize1 tool tile is selected in 

Figure 2-19  The Saver1 tool control window

the Flow area and then right-click on it; 
a shortcut menu is displayed. Choose Insert 
Tool > I/O > Saver from the shortcut menu; 
the Saver1 tool tile is inserted in the Flow area 
and the Save File dialog box is displayed.

2.	 Choose Documents > Fusion_7 > c02_tut > 
c02_tut_02 from the dialog box. Select Quick 
Time Movies (*.mov; *.qt; *.gp; *.mp4) from 
the File Type drop-down list. Next, enter 
beach clip in the File Name edit box. Next, 
choose the Save button.

3. 	 Choose the Format tab in the Saver: beach clip.
mov tool control window and select Sorenson 
Video 3 or H.264 from the Compression drop-down list. Next, move the Quality slider to 100,

	 refer to Figure 2-19.

Saving and Rendering the Composition                                       
In this section, you will save and render the composition. You can also view the final render of 
the composition by downloading the file c02_fusion_7_rndr.zip from http://www.cadcim.com. The 
path of the file is given at the beginning of the chapter.

1. 	 Choose File > Save from the menubar; the Save File dialog box is displayed. In this dialog 
box, choose Documents > Fusion_7 > c02_tut > c02_tut_02 and then enter c02tut2 in 
the File Name edit box. Next,  choose the Save button to close the dialog box and save the 
composition.
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2.   Choose File > Start Render from the menubar; the Render Settings dialog box is displayed, 

as shown in Figure 2-20.

Figure 2-20  The Render Settings dialog box

3. 	 Choose the Start Render button; the rendering process is started. On completion of 
rendering, a message box is displayed with the information about the frame range rendered 
and the time taken to render the frame range, as shown in Figure 2-21. Next, choose the 
OK button to close the message box.

Figure 2-21  The c02tut2.comp message box 
informing about the completion of the rendering process

4.	 Navigate to /Documents/Fusion_7/c02_tut/c02_tut_02 and double-click on the beach clip.mov file 
to view the final rendered output, refer to Figure 2-15.

Tip: You can also open the Render Settings dialog box by pressing F12 or by choosing the 
green Render button available in the Time Ruler.
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following combination of shortcut keys is used to access the tools?
		
		  (a) CTRL+H				    (b) CTRL+SPACE
		  (c) CTRL+G				    (d) CTRL+Z

2.	 The ___________ and __________ numeric keys are used to view the output of the tools in 
the primary Display Views.

3.	 The ___________ button in the toolbar is used to load an image or video sequence.

4.	 The ___________ button in the toolbar is used to add the Color Corrector tool to the Flow 
area.

5.	 The __________ is an art of combining multiple images to create a new image.

6.	 The __________ window is used to store references, composition, and various other data 
across the network.

7.	 The Merge tool is used to combine background and foreground images together. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following colors is used to represent the output node of a tool?

	 (a) Green			   (b) Orange
	 (c) Red				    (d) None of these

2.	 The Suppress parameters in the Color Corrector tool control window are used to __________ 
the color of an image.

3.	 The Merge tool is represented as __________ button on the toolbar. 

4.	 A Fusion composition consists of a network of nodes called tools. These tools are connected 
through _________.

5.	 The _________ button in the Time Ruler is used to start the rendering process. 

6.	 The _________ shortcut key is used to lock the Display View.

7.	 On pressing the F12 key, the Render Settings dialog box is displayed. (T/F)

8.	 You can save the composition by using the CTRL + Z keys. (T/F)
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Answers to Self-Evaluation Test
1. b, 2. 1, 2, 3. LD, 4. CC, 5. compositing, 6. Bins, 7. T


