
Chapter 2
Introduction to NX 

Nastran

 Learning Objectives 
After completing this chapter, you will be able to:
• Understand basic concepts of NX Nastran
• Understand different environments in NX Nastran
• Understand the system requirements for NX Nastran
• Start NX Nastran
• Understand important terms and definitions in NX Nastran
• Understand the functions of mouse buttons
• Understand default tabs in different environments
• Use dialog boxes in NX Nastran
• Use the NX Nastran Help
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INTRODUCTION TO NX Nastran
NX Nastran is a premium computer-aided engineering (CAE) tool that manufacturers use 
worldwide for their critical engineering computing needs. For over 30 years, NX Nastran has been 
the analysis solution in almost every major industry including aerospace, defense, automotive, 
shipbuilding, heavy machinery, medical, and consumer products.

In CAE, often you can work with data imported from different CAD softwares. You can easily 
modify a design using NX CAD software and then use the modification as a design variable to 
arrive at an optimal design.

NX Nastran has the following analysis capabilities:

1.	 Linear statics (including inertia relief)
2.	 Normal modes and buckling
3.	 Heat transfer (steady-state and transient)
4.	 Transient response
5.	 Frequency response
6.	 Response spectrum and random response
7.	 Geometric nonlinear static and transient response
8.	 Material nonlinear static and transient response
9.	 Design optimization and sensitivity (including dynamic and shape optimization)
10.	 Composite materials
11.	 Acoustic response
12.	 Aeroelasticity
13.	 Superelements
14.	 Complex eigen analysis
15.	 Axisymmetric analysis
16.	 Cyclic symmetry

In NX Nastran you can analyze the basic and as well as complex geometries using different 
environments. Each environment consists of a set of tools that allows the user to perform specific 
analysis tasks in a particular area. After starting a new part file, you can invoke the required 
environment of NX. 

BASIC ENVIRONMENTS IN NX
The basic environments in NX are Modeling, Shape Studio, Drafting, Assembly, Sheet metal, 
and the Manufacturing. Some of these environments are discussed next.

Modeling Environment
The Modeling environment is a parametric and feature-based environment in which you can 
create solid models. The basic requirement for creating solid models in this environment is a 
sketch which can be drawn directly in this environment by using the tools available in the Direct 
Sketch group of the Home tab. The sketch can also be drawn in the Sketching environment. 
The Sketching environment can be invoked by choosing the Sketch tool from the Direct Sketch 
group of the Home tab or by choosing the Sketch in Task Environment tool from the Curve tab. 
When a sketch is drawn, various applicable constraints and dimensions get automatically applied 
to it. Additional constraints and dimensions can also be manually applied. After drawing the 
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sketch, you need to convert the sketch into a feature. The tools to convert a sketch into a feature 
are available in the Modeling environment. You can also create features such as fillets, chamfers, 
taper, and so on by using the other tools available in this environment. These features are called 
placed features. You can also assign materials to the model in the Modeling environment.

Shape Studio Environment
The Shape Studio environment is also a parametric and feature-based environment in which 
you can create surface models. The tools in this environment are similar to those in the 
Modeling environment with the difference that the tools in this environment are used to 
create surfaces, both basic and advanced. This environment also provides surface editing tools 
that are used to manipulate surfaces to obtain required shape. This environment is useful for 
conceptual and industrial designs.

Assembly Environment
The Assembly environment is used to assemble components using the assembly constraints 
available in this environment. There are two types of assembly design approaches in NX, 
Bottom-up and Top-down.

In the bottom-up approach, you can assemble the components that were created earlier whereas 
in the top-down approach, components are created in the Assembly environment.

In the Assembly environment, you can also assemble an existing assembly with the current 
assembly. The performed analysis in this environment provides the facility to check the 
interference and clearance between the components in an assembly.

SYSTEM REQUIREMENTS
The following are the minimum system requirements to ensure smooth functioning of NX 
Nastran on your system:

•	 Operating System: Windows 64-bit (Windows XP 64 SP2, Windows Vista 64 SP1, Windows 7, 
Windows 8, Windows HPC Server 2008 R2)

•	 Platform: Intel Pentium class, Intel 64 or AMD 64
•	 Memory: 4 GB or more
•	 DVD drive: For installing the software
•	 Graphics adapter: should be capable of supporting 1024x768 High Color (16-bit)
•	 Microsoft Internet Explorer 6.0 or higher

STARTING NX NASTRAN 9.0
To start NX Nastran 9.0, double-click on the shortcut icon of NX 9.0 displayed on the desktop 
of your computer. After the necessary files are loaded and the licenses are verified, the initial 
screen of NX 9 will be displayed.

The default initial screen of NX 9.0 is shown in Figure 2-1. This screen displays information about 
NX 9.0 which helps you learn more about NX 9.0. You can also view other related information 
by moving the cursor over the topics displayed on the left of the NX 9.0 screen.
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Figure 2-1  The initial screen that appears after starting NX 9.0

STARTING A NEW DOCUMENT IN NX NASTRAN 9.0
 Ribbon:	 Home > Standard > New 	  
 Menu:		  File > New			 

To invoke the Advanced Simulation environment of NX Nastran, choose Menu > File > 
New from the Top Border Bar; the New dialog box will be displayed with the Model tab 

chosen, as shown in Figure 2-2. The New dialog box contains tabs to switch between different 
working environments like Modeling, Drawing, Simulation, Manufacturing, and so on.

To enter in NX Nastran, choose the Simulation tab and select NX Nastran from the Name 
column for the FEM type from the Template rollout, if not selected by default, refer to Figure 2-3. 

The rollouts available in the Simulation tab for invoking NX Nastran are discussed next.

Templates Rollout
In this rollout, different FEM and SIM type templates are available for different solvers. You 
can also select the Millimeters or Inches as a unit from the Units drop-down list available in 
the Filters sub-rollout. 

New File Name Rollout
In this rollout, the Name and Folder edit boxes are available. You can enter the name of FEM 
or SIM in the Name edit box and the location to save the file in the Folder edit box.
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Figure 2-2  The New dialog box with the Model tab chosen

Figure 2-3  The New dialog box with the Simulation tab chosen
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After defining the required parameters in these rollouts, choose the OK button; the New FEM 
dialog box with the FEM environment will be displayed, refer to Figure 2-4.

Figure 2-4  The New FEM dialog box with the FEM environment

For importing any NX model in the FEM environment, select the Associate to Master Part 
check box from the CAD Part rollout of the New FEM dialog box; the CAD Part rollout will 
be modified and the Open Part button will be displayed, as shown in Figure 2-5. Choose this 
button; the Open dialog box will be displayed. Select the part to import and choose the OK 
button from the Open dialog box. Next, choose the OK button from the New FEM dialog box; 
the part will get imported in the FEM environment, as shown in Figure 2-6.

Note
1. If you choose a file type other than NX such as *.igs, *.stp, you need to leave the Associate 
to Master Part check box cleared and then choose the OK button from the dialog box; the FEM 
environment window will be displayed, refer to Figure 2-6. Now, open the part from this window 
to import the non-NX model in the FEM environment. 

You will learn more about the importing and exporting of the CAD model in NX in the later 
chapters of this textbook.

2. If you want to create an Idealized Part, then select the Create Idealized Part check box from 
the Idealized Part sub-rollout in the CAD Part rollout of the New FEM dialog box. 

You will learn more about creating an Idealized Part later in the textbook.
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Figure 2-5  The modified New FEM dialog box

Figure 2-6  The part imported in the FEM environment

In the FEM environment, you can define materials, meshing, and other physical properties 
of the model. The model after defining materials and applying mesh is shown in Figure 2-7.
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Figure 2-7  Meshed model in the FEM environment

For applying loads, constraints, and other boundary conditions, you need to switch to the 
Simulation environment. To do so, choose the New Simulation button from the Change 
Window Drop-down of the Home tab; the New Part File window will be displayed. Select the 
NX Nastran template with the Sim type from the Template rollout if not selected by default, 
as shown in Figure 2-8. 

Figure 2-8  The New Part File window

Choose the OK button from the New Part File window; the New Simulation dialog box with 
the Simulation environment will be displayed. Choose the OK button from the New Simulation 
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dialog box; the Solution dialog box will be displayed. In this dialog box, you can describe the 
analysis details. Choose the OK button from the dialog box; you will enter in the Simulation 
environment. The Simulation environment with the meshed model is shown in Figure 2-9. In 
this environment, you can apply boundary conditions, loads, and solve the analysis.

Figure 2-9  The Simulation environment with meshed model

Note
You will learn more about the Simulation environment and its dialog boxes later in the textbook.

IMPORTANT TERMS AND DEFINITIONS
Some important terms used in NX Nastran are discussed next.

Advanced Simulation
The Advanced Simulation is a comprehensive finite element modeling and results visualization 
application. It includes pre- and post-processing and supports a broad range of product 
performance evaluation solutions. Advanced Simulation provides numerous additional features 
that support advanced analysis processes.

1.	 Advanced Simulation provides separate simulation and FEM files that help in the 
development of FE models across a distributed work environment. 

2.	 Advanced Simulation supports a complete range of element types (0D, 1D, 2D, and 3D) 
to control specific part meshing.

3.	 Advanced Simulation includes a number of geometry modification tools to manipulate 
any CAD geometry for making its analysis easier and faster. 

fem
The fem file used in NX Nastran contains information about the nodes and elements in the 
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finite element model. It also includes physical properties, materials, and beam element sections 
of the model. The file contains the idealized (modified) model that you create from the master 
CAD part.

sim
The sim (Simulation) file contains the simulation data such as loads, constraints, and all motion 
objects (such as links, joints, and connectors). You can create multiple simulation files for a 
single fem file.

Note
If any of the properties is missing in the fem or sim file while solving the analysis, the Information 
window will be displayed with errors and warnings, refer to Figure 2-10. 

You will learn more about solving an analysis later in the textbook.

Figure 2-10  The Information window

Resource Bar
The Resource Bar combines all navigation windows, a history palette, an integrated web browser, 
and a part template in one common place for a better user interface. By default, the Resource Bar 
is located on the left side of the interface window.

Simulation Navigator
The Simulation Navigator is located at top of the Resource Bar. It displays the following files 
and steps associated with analysis.

1.	 FEM file
2.	 Associated CAD geometry
3.	 Mesh collectors and meshes
4.	 Loads, constraints, and objects that define boundary conditions
5.	 Solution and results

Using the Simulation Navigator, you can review the structure, content, and status of your analysis. 
You can also show and hide the geometry, meshes, and boundary conditions of the model. A 
partial view of the Simulation Navigator is shown in Figure 2-11.
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Figure 2-11  Partial view of the Simulation Navigator

Simulation File View
The Simulation File View is located below the Simulation Navigator. You can use the Simulation 
File View in the following ways:

1.	 View all the loaded parts as well as all FEM and Simulation files in sequential order, as 
shown in Figure 2-12.

2.	 Create Idealized part without manipulating the master part.

3.	 Create multiple FEM and Simulation files for any design or idealized part.

You can switch to any simulation environment by choosing any option from the Simulation 
File View. To do so, right-click on a simulation step; a shortcut menu will be displayed, refer to 
Figure 2-13. Choose the Make Displayed Part option from the shortcut menu; the simulation 
environment will be invoked. You can also switch to simulation environment by double-clicking.

Figure 2-13  Shortcut menu displayedFigure 2-12  The Simulation File View
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Post Processing Navigator
The Post Processing Navigator is available in the Resource Bar below the Simulation Navigator. 
The Post Processing Navigator is used to manage, view, and interrogate the results of an analysis. 
Using the Post Processing Navigator, you can:

1.	 Create nodal and elemental contour plots of results on the model and also import results.

2.	 Create cross sections in post views to show internal variation in the larger portion of part.

3.	 Annotate results to show maximum and minimum variation points.

4.	 Identify the values of selected nodes and elements and export them for further analysis.

5.	 Create and display graphs of result data across selected nodes.

6.	 Quickly generate a contour plot of the selected results or result components.

7.	 Animate post views.

8.	 Control the display of results based on meshes or groups. 

You can open the Post Processing Navigator to get the current simulation results. To do so, 
right-click on the Results step in the Simulation Navigator; a shortcut menu will be displayed, 
refer to Figure 2-14. From this shortcut menu, choose the Open option from the menu; the Post 
Processing Navigator will be displayed with the current simulation results, refer to Figure 2-15.

Figure 2-14  Shortcut menu displayed on choosing 
the Results step of Simulation Navigator

 

Note
You can also import an existing results file in the Post Processing Navigator using the Imported 
Results option shown in the navigator. You will learn more about importing results in the Post 
Processing Navigator later in the textbook.

Part Navigator
The Part Navigator located in the Resource Bar keeps a track of all the operations related to 
model preparation. Figure 2-16 shows the part navigator that appears when you choose the Part 
Navigator tab in the Resource Bar.
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Figure 2-16  The Part NavigatorFigure 2-15  The Post Processing Navigator

UNDERSTANDING THE FUNCTIONS OF THE MOUSE 
BUTTONS
To work in NX Nastran environments, it is necessary that you understand the functions of mouse 
buttons. The efficient use of the mouse buttons along with the CTRL key can reduce the time 
required to complete any design task. Different combinations of the CTRL key and the mouse 
buttons are described next:

1.	 The left mouse button helps you make a selection by simply selecting a face, surface, 
loads, or constraints from the geometry area or from the Navigators. For multiple selec-
tions, press the CTRL key along with the left mouse button.

2.	 The right mouse button is used to invoke shortcut menu which has different options 
and tools.

 
3.	 Press and hold the middle and right mouse buttons to invoke the Pan tool. Next, drag 

the mouse to pan the model. You can also invoke the Pan tool by first pressing and 
holding the SHIFT key and then the middle mouse button. Figure 2-17 shows the use 
of a three buttons mouse in performing the pan functions.

4.	 Press and hold the middle mouse button to invoke the Rotate tool. Next, drag the 
mouse to dynamically rotate the view of the model in the geometry area and view it from 
different directions. Figure 2-17 shows the use of the three buttons mouse in performing 
the rotate operation.
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Figure 2-17  Functions of the mouse buttons

5.	 Press and hold the CTRL key and then the middle mouse button to invoke the Zoom 
tool. Alternatively, press and hold the left mouse button and then the middle mouse 
button to invoke the Zoom tool. Next, drag the mouse dynamically to zoom in or out 
the model in the geometry area. Figure 2-17 shows the use of three mouse buttons in 
performing the zoom functions.

QUICK ACCESS TOOLBAR
The Quick Access Toolbar toolbar is common to all environments of NX Nastran, refer to 
Figure 2-18. The buttons in this toolbar are used to start a new file, open an existing file, save 
a file of the current document, cut and place the selection on a temporary clipboard, copy a 
selection, paste content from the clipboard to some selected location, undo, redo, search a tool, 
and invoke the help topics.

Figure 2-18  The Quick Access Toolbar

RIBBON
The Ribbon in the NX Nastran interface comprises of a series of tabs which group various tools 
and options based on their functionality. These tabs and groups are displayed depending upon 
the environment invoked. The different environments and some of their respective tabs and 
groups are discussed next.

FEM Environment
In the FEM environment, you can define the type of material, mesh, and other physical properties 
of the model from the Home tab. This tab is discussed next. 
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Home Tab
The tools in the Home tab, as shown in Figure 2-19, are used in the FEM environment to:

1.	 Entering into the Simulation environment
2.	 Assign material to the given model
3.	 Mesh the given model
4.	 Define connection between two or more parts
5.	 Refining the model for better mesh quality
6.	 Check element or mesh quality

Figure 2-19  Partial view of the Home tab in the FEM environment

The Context group of the Home tab is discussed next.

Context Group
This group available in the Home tab and is used to enter in the Simulation environment 
and to create a new simulation file, refer to Figure 2-20. The tools in the Context group will 
be modified in the Simulation environment.

Figure 2-20  The Context group

Simulation Environment
The Simulation environment is used for defining loads, constraints, and other boundary 
conditions. The Home tab of this environment is discussed next. 

Home Tab
The Home tab in the Simulation environment is shown in Figure 2-21. The tools in the Home 
tab are used in the Simulation environment to:

1.	 Activating the Simulation tool to re-enter in the Simulation environment from the FEM 
environment

2.	 Managing materials in the model
3.	 Managing modeling objects
4.	 Defining loads and constraints
5.	 Defining simulation object type and its operational region
6.	 Creating solutions and verify the model analysis steps
7.	 Solving the analysis and create the analysis report
8.	 Checking the element or mesh quality
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Figure 2-21  Partial view of the Home tab in the simulation environment

The Context group of the Home tab is discussed next.

Context Group
After entering in the Simulation environment, the Context group gets modified, as shown 
in Figure 2-22. The tools in the Context group are used to activate meshing and to again 
enter in the FEM environment from the Simulation environment.

Figure 2-22  The Context group

Results Tab
After the analysis of model is performed and results are generated the Post Processing Navigator 
is displayed and the Results tab gets available along with the Post Processing, Animation, 
Manipulation and other groups in the Simulation environment, as shown in Figure 2-23. 

Figure 2-23  The Results tab

The tools in the Results tab are used to:

1.	 Return to the Simulation environment
2.	 Edit the given view and manipulate the result
3.	 Render the result
4.	 Create the annotation
5.	 Animating results

View Tab
The View tab is common to all environments of NX Nastran. The tools in the View tab, as shown 
in Figure 2-24, are used for manipulating the views of the model. 

Figure 2-24  The View tab
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STATUS BAR
The Status Bar appears at the bottom of the drawing window and comprises of two areas and a 
button, as shown in Figure 2-25. These areas and button are discussed next.

Figure 2-25  The Status Bar 

Cue Line Area
The cue line area is the prompt area where prompts appear for completing the tool task.

Status Area
This area provides information about the operations to be carried out in the interface. 

Enters or exits full screen mode
If you choose this button, the graphics window will be maximized and you can get a full screen 
display. For getting the default screen display, you need to choose this button again.

Selection Bar
The Selection bar, as shown in Figure 2-26, appears below the Ribbon. This bar is used for easy 
selection of the model features like faces or edges.

Figure 2-26  The Selection bar 

Tip
By default, all the tools are not available in a group. Therefore, you may need to customize the 
group to add those tools that are not available by default. To customize a group, click on the 
down arrow at the bottom right corner of the group; a drop-down list will be displayed. Click 
on the tool to be added or removed from the group. Note that the tick mark on the left of a tool 
indicates that it is already added to the group. 

Similarly, you can add or remove groups from the Ribbon by using the Ribbon Options arrow 
available at its bottom right corner.

DIALOG BOXES IN NX Nastran
To perform a simulation, you need to follow certain processes in an order. The steps to perform 
these processes are placed in a top-down order in the corresponding dialog boxes, refer to 
Figure 2-27. In the dialog box, the current selection step is highlighted in orange. The required 
steps are marked with asterisks and the completed steps are marked with green check marks.

The Reset button is used to reset the dialog box to its initial settings. The Close button is used 
to exit the dialog box.
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Figure 2-27  The 3D Tetrahedral Mesh dialog box

USING HELP IN NX Nastran
In NX Nastran, there are different ways to access help. These methods are discussed next.

Note
For using the NX Nastran help file, you must install the Documentation file in your system.

NX Help
To access help in NX Nastran, choose Menu > Help > NX Help from the Top Border Bar; 
the NX 9.0 Help menu will open in a browser window, as shown in Figure 2-28.

Figure 2-28  The NX 9.0 Help opened in the browser window
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The help window is divided into two parts: Product area and NX 9 Help. The Product area 
provide with hyperlinks of various topics and the NX 9 Help provide product description with 
summary. Through this browser window, NX provides description of each module provided in the 
software package. You can browse as well as search any description of any related topic. NX also 
provides video tutorials for the description of topic being searched as well as the whole package.

Apart from the NX 9.0 Help browser window, NX offers more ways to access help which are 
discussed next.

On Context Help
The On Context Help option also provides description of the invoked environment. For example, 
if you are in the Simulation environment and choose Menu > Help > On Context from the Top 
Border Bar, the Advanced Simulation Overview will open in the browser window, as shown 
in Figure 2-29.

Figure 2-29  The Advanced Simulation Overview in the browser window

Command Finder
The Command Finder option available in NX Nastran is used to find a particular tool 
or command. Choose Menu > Help > Command Finder from the Top Border Bar; the 

Command Finder dialog box will be displayed, refer to Figure 2-30. You can also invoke this 
dialog box from the Ribbon.
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Figure 2-30  The Command Finder dialog box

To search any tool from the Command Finder, enter the name of tool in the Search box and 
choose the Find Command button adjacent to the Search box. The available tools will be 
displayed in the dialog box. When you hover the mouse on any option, the software will locate 
the particular option in the window, as shown in Figure 2-31.

Figure 2-31  The Command Finder dialog box with the located tool

Note
In the Command Finder dialog box, as you hover the mouse on the tool which is not related to 
the existing environment, the dialog box will not display the location of the tool. But it will only 
display the description of the tool.
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The ________ environment is used to define boundary conditions of the model.

2.	 The ________ environment is used to define material for a model.

3.	 The tools in the ________ tab are used for manipulating the views of the model. 

4.	 In NX Nastran, the FEM environment is used to create mesh in a model. (T/F)

5.	 The Command Finder locates only the tools available in the current working environment. 
(T/F)

6.	 The On Context is used to provide the description of the current working environment in 
the browser window. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following analysis steps cannot be performed in the FEM environment?
		
		  (a) Meshing		  		  (b) Material applying
		  (c) Defining loads	 		  (d) None of these

2.	 Which of the following processes cannot be performed using the Post Processing Navigator?
		
		  (a) Plotting results			   (b) Applying boundary conditions
		  (c) Creating graphs			   (d) None of these

3.	 The tools available in ________ are used to animate the results generated through analysis.

4.	 Using the Simulation File View, you can switch between working environments. (T/F)

5.	 The Post Processing Navigator is used to view and manipulate results. (T/F)
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Answers to Self-Evaluation Test
1. Simulation, 2. FEM, 3. View, 4. T, 5. F, 6. T 


