Chapter 2

Working with Graphics
and Text

Learning Objectives

After completing this chapter, you will be able to:
* Create vector graphics using drawing tools

* Modify the shape and size of the selected objects

* Adjust contours in a graphic

* Add layers to the Timeline

* Apply color to an object

* Create and edit curves

* Create and edit text
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INTRODUCTION

Graphics is a representation of a two-dimensional image in binary format as a sequence of ones
and zeros. It includes both vector and raster images. Vector graphics are the images produced
by using geometrical primitives such as points, lines, curves, and shapes. These graphics are
produced on the basis of mathematical equations, such as a circle that includes the information of
radius. You can create and animate vector graphics in Flash. Vector graphics have two advantages.
The first advantage is that the file size is small and it is downloaded faster and less hard drive
space is utilized to save the file. The second advantage is that the image can be scaled to any
size without affecting the image quality. In Flash, you can create and animate vector graphics.
The other type of graphics is raster graphics. Raster graphics are the images produced by an
array of pixels. Each pixel carries Color information, therefore, they are relatively large files.

TUTORIALS

Before you start the tutorials, you need to download the ¢c02_flash_cc_2015_tut.zip file from
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects >
Flash > Adobe Flash Professional CC 2015: A Tutorial Approach.

Next, navigate to the Documents folder and create a new folder with the name Flash_Projects and
then extract the contents of the zip file to \Documents\Flash_Projects.

Note
The tutorial zip file that you have downloaded from the CADCIM website contains a folder
Resources. This folder contains all resources related to this chapter.

Tutorial 1

In this tutorial, you will create the vector graphic of a honey bee using the drawing tools in Flash
CC, as shown in Figure 2-1. (Expected time: 30 min)

Figure 2-1 The vector graphic of a honey bee
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The following steps are required to complete this tutorial:

Create a new Flash document.
Create the face of honey bee.
Create the body of honey bee.
Create the wings of honey bee.
Create the antennae of honey bee.

o0 T

Creating a New Flash Document
In this section, you will create a new Flash document.

1. Choose File > New from the menubar; the New Document dialog box is displayed.

2. In the New Document dialog box, choose ActionScript 3.0 from the General tab and
then choose the OK button; a new Flash document is displayed. By default, the Essentials
workspace is active in the Flash document.

Creating the Face of Honey Bee
In this section, you will create the face of the honey bee using Oval Tool and other editing tools
from the Tools panel.

1. Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel.

2. In the Fill and Stroke area of the Properties panel, choose the Stroke color swatch; a flyout
is displayed. In this flyout, enter #000000 in the Hexadecimal edit box and press the ENTER
key.

3. Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #FFFF00 in the
Hexadecimal edit box and press the ENTER key. Next, enter 3 in the Stroke edit box.

, Note
@ 1. In this textbook, colors will be referred by their hexadecimal values.

2. The Hexadecimal edit box is also called Hex edit box.

Tip

O You can choose the desired colors for the stroke and fill from the Stroke color and Fill color
swatches in the Tools panel. Alternatively, in the Properties panel, expand the Fill and Stroke
area, and then use the Stroke color and Fill color swatches to choose the colors. In these
panels, select the required color by using the color picker or enter the color value manually
i the Hexadecimal edit box, refer to Figure 2-2. You can also use the Color and Swatches
panels to apply coloy; refer to Figure 2-3. 1o display the Color panel, choose Window >
Color from the menubar or press CTRL+SHIFT+F9. 1o display the Swatches panel, choose
Window > Swatches from the menubar or press CTRL+F9.
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Figure 2-2 Entering the color values in the Hexadecimal edit box
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Figure 2-3 The Color and Swatches panels

Note
The fill and stroke are independent of each other, therefore, you can modify or delete either of
them without affecting the other.

4. Make sure the Object Drawing option in the Options section of the Tools panel is 0
disabled. Press and hold the SHIFT key and drag the cursor to draw a circle.

s

Note

When a drawing tool is in the Object Drawing mode, the stroke and fill of an object are not
separate elements and the shapes that overlap in the same layer do not alter one another if you
move them apanrt, reposition, or rearrange them, refer to Figures 2-4 and 2-5.
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Figure 2-4 The behavior of the objects when the Object Drawing mode is disabled
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Figure 2-5 The behavior of the objects when the Object Drawing mode is enabled

5. Choose Selection Tool and double-click on the circle to select it. In the Position and Size
area of the Properties panel, set the value of X to 225 and the value of Y to 38. Next, set
the W (width) and H (height) values to 100; the circle is positioned and resized in the Stage.

X and Y are the coordinates that define the position of an object in the Stage. Next, you
will create eyes of honey bee.

~—~  Note
" By double-clicking on the fill of an object, you can modify both fill and stroke, whereas by single
click, you can modify only the fill of the object.

6. Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, choose the Stroke
color swatch; a flyout is displayed. In this flyout, make sure #000000 is entered in the Hex
edit box and then press the ENTER key.

7. Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #330033 in the Hex
edit box. Now, create a small vertical oval in the blank area of the stage. Choose Selection
Tool and double-click on the oval to select it. In the Properties panel, set the W (width)
and H (height) values to 10 and 26, respectively.

.~  Note
@ 10 set the value of a particular parameter, click in the respective edit box and then enter the §¥
 required value. Alternatively, move the cursor over the default value; the shape of the cursor
will change into a hand icon called the scrubber. Now, drag the cursor to change the value.
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8. Make sure Selection Tool is chosen in the Tools panel and the oval is selected in the Stage.
Next, press and hold the ALT key and drag the oval; a copy of the oval is created, refer to
Figure 2-6.

Note

1o create a copy of an object in Flash, select the object using Selection Tool. Next, press and hold
the ALT key and drag the object. Alternatively, select the object and choose Edit > Copy from
the menubar. Next, choose Edit > Paste in Center from the menubar.

®

9. Marquee select both the ovals using Selection Tool and position them inside the circle as
the eyes of the honey bee, as shown in Figure 2-7.

O D

Figure 2-6 Copy of the oval Figure 2-7 The eyes placed on the face
of honey bee

Next, you will create the cheeks of the honey bee.

10. Choose Oval Tool from the Tools panel. In the Fill and Stroke area of the Properties =
panel, choose the Stroke color swatch; a flyout is displayed. In this flyout, choose the
No Color button located on the upper right side of this flyout.

11. Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #FF9999 in the Hex
edit box and press the ENTER key.

12. Create a small horizontal oval in the blank area of the Stage and then select it using Selection
Tool. In the Position and Size area of the Properties panel, set the W (width) and H (height)
values of the oval to 21 and 7, respectively.

13. Create a copy of the oval using the ALT key.

14. Using Selection Tool, position the ovals on the
face as the cheeks of honey bee, as shown in

Figure 2-8.

Next, you will create the mouth of honey bee.

Figure 2-8 The face of Honey Bee with cheeks
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15.

16.

17.

18.

Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, choose the Stroke
color swatch; a flyout is displayed. In this flyout, make sure the No Color button is chosen.

Choose the Fill color swatch; a flyout is displayed. In this flyout, make sure #000000 is
entered in the Hex edit box and press the ENTER key. Create a horizontal oval. Next, you
need to change the shape of the oval to make it appear like mouth. In Flash, Selection Tool
can also be used to push and pull the lines and corners of a shape to refine its contours.

Choose Selection Tool and then move the cursor to the upper edge of the oval; a small
curve is displayed below the cursor indicating that the curvature can be changed, refer to
Figure 2-9.

Click on the curvature and drag it inward; the curvature of the shape bends inward, thereby
turning into mouth shape. Now, select the mouth using Selection Tool and place it below
the cheeks, as shown in Figure 2-10.

Figure 2-9 The cursor with the curve Figure 2-10 The face of honey bee
after placing the mouth

Creating the Body of Honey Bee

In this section, you will create the body of honey bee using Line Tool and Paint Bucket Tool.

1.

Choose Line Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, choose the Stroke
color swatch; a flyout is displayed. In this flyout, enter #000000 in the Hex edit box and
press the ENTER key.

In the Fill and Stroke area of the Properties panel,
make sure 3 is entered in the Stroke edit box. Next,
press and hold the SHIFT key and draw a vertical
line segment (stroke) in the blank area of the Stage.
The outline of an object is called stroke. )

Choose Selection Tool. Next, place the cursor over
the stroke and drag it to the left; the curvature bends

outward, as shown in Figure 2-11. Figure 2-11 Changing the curvature of

the stroke
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Select the line segment using Selection Tool and create a copy of the line segment using the
ALT key. Next, select the copy of the line segment and choose Modify > Transform > Flip
Horizontal from the menubar; the copied line segment is flipped horizontally and placed.

Marquee select the upper portion of the line segments using Selection Tool and delete it
by pressing the DEL key, refer to Figure 2-12.

Marquee select both the line segments and position them appropriately below the face using
Selection Tool, as shown in Figure 2-13.

0 6

Figure 2-12 Deleting the upper — Figure 2-13 The honey bee afier
portion of the line segments placing the line segments

Choose Line Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, make sure 3 is entered
in the Stroke edit box.

Draw four horizontal line segments on the body of honey bee, as shown in Figure 2-14. Next,
change the curvature of the line segments using Selection Tool, refer to Figure 2-15.

:

Figure 2-14 The horizontal line Figure 2-15 Changing the curvature
segments of horizontal line segments

Choose Paint Bucket Tool from the Tools panel; the properties of this tool are displayed
in the Properties panel and the options are displayed in the Options section of the Tools
panel.

. In the Properties panel, choose the Fill color swatch; a flyout is displayed. In this flyout,

enter #330033 in the Hex edit box and press the ENTER key.

. In the Options section of the Tools panel, choose the Gap Size button; a flyout is displayed,

as shown in Figure 2-16. In this flyout, choose the Close Large Gaps option, refer to
Figure 2-17.
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Figure 2-16 Choosing the Gap Size button Figure 2-17 Choosing the Close Large
in the Options section of the Tools panel Gaps option

Don't Close Gaps O
Close small Gaps
Close Medium Gaps

Close Largq\gaps

cCCccCOoO

12. Click in the first horizontal section of the body; the color is filled in this section. Choose the
Fill color swatch; a flyout is displayed. In this flyout, enter #FFFF00 in the Hex edit box
and press the ENTER key. Next, apply the color in the second horizontal section. Make sure
there are no open areas left between the intersection points of one or more line segments
as the fill can only be applied in the enclosed areas.

13. Apply the color in the remaining sections as discussed in Steps 9 and 10, refer to Figure 2-18.

Figure 2-18 Filling the color in sections using Paint Bucket Tool

Creating the Wings of Honey Bee

In this section, you will create the wings of honey bee in a new layer.

1. Choose the New Layer button in the Timeline panel; a new layer is created. Next,
double-click on the default layer name and rename it as wings, as shown in Figure 2-19.
Next, rename Layer 1 as face and body.

2. Choose Oval Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, choose the Stroke
color swatch; a flyout is displayed. In this flyout, make sure #000000 is entered in the Hex
edit box and press the ENTER key.

, Note

@ You can hide the body and face of honey bee by hiding the face and body layer in the Timeline
panel. 1o do so, turn off the Show or Hide All Layers option of the face and body layer; as
shown in Figure 2-20.
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Figure 2-19 Naming the layers in Figure 2-20 Hiding the face and body
the Timeline panel layer in the Timeline panel

Choose the Fill color swatch; a flyout is displayed. In this flyout, choose the No Color button.
Next, make sure 3 is entered in the Stroke edit box and draw a horizontal oval in the wings
layer, refer to Figure 2-21.

Choose Selection Tool and select the oval. Next, create a copy of the oval by using the ALT
key.

Make sure the copied oval is selected and choose Free Transform Tool from the Tools
panel; the oval is enclosed inside the transform bounding box. Next, place the cursor on
the upper right transform point and drag it inward; the size of the oval is reduced, as shown
in Figure 2-21.

Select the original oval and choose Free Transform Tool from the Tools panel. Place the
cursor around any corner transform point available outside the transform bounding box; the
cursor is changed to a rotating arrow icon. Now, rotate the oval anti clockwise approximately
to 40 degrees, refer to Figure 2-22. Similarly, using Free Transform Tool rotate the copied
oval clockwise approximately to 30 degrees to get the shape of a wing. Click in the Pasteboard
to deselect Free Transform Tool.

D
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g

Figure 2-21 Resizing the oval Figure 2-22 Rotating the ovals

Choose the small oval using Selection Tool and place it on the large oval. Next, click anywhere
in the Pasteboard such that none of the body parts is selected. Now, delete the stroke of the
large oval that is overlapping the small oval, as shown in Figure 2-23. Figure 2-24 shows the
final shape of the ovals after deleting the stroke.



Working with Graphics and Text 2-11

Figure 2-23 Selecting the Figure 2-24 The ovals
stroke that is to be deleted after deleting the stroke

Marquee select the entire wing and create a copy of the wing using the ALT key, refer to
Figure 2-25. Next, select the copy of the wing using Selection Tool. Now, choose Modify >
Transform > Flip Horizontal from the menubar; the wing is flipped horizontally, as shown
in Figure 2-26.

Drag the face and body layer above the wings layer in the Timeline panel. Next, place the
wings behind the body, refer to Figure 2-27.

Figure 2-25 The copy of Figure 2-26 The copy of the Figure 2-27 The wings
the wing wing flipped horizontally placed behind the body

Creating the Antennae of Honey Bee
In this section, you will create the antennae of honey bee in the face and body layer.

1.

Select the face and body layer. Choose Line Tool from the Tools panel. In the Fill and
Stroke area of the Properties panel, make sure 3 is entered in the Stroke edit box. In the
face and body layer, draw a line segment on the head of the honey bee.

Change the curvature of the line segment using Selection Tool, as shown in Figure 2-28.

Choose Oval Tool from the Tools panel; the tool properties are displayed in the Properties
panel.

In the Fill and Stroke area of the Properties panel, choose the Stroke color swatch; a flyout
is displayed. In this flyout, make sure #000000 is entered in the Hex edit box and press the
ENTER key. Next, choose the Fill color swatch; a flyout is displayed. In this flyout, enter
#FFFF00 in the Hex edit box and press the ENTER key.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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9.

Press and hold the SHIFT key and drag the cursor to create a small circle anywhere in the
Stage. Place the circle on the tip of the line segment using Selection Tool, as shown in
Figure 2-29.

Figure 2-28 Changing the curvature — Figure 2-29 Placing the circle on the tip
of the line segment of the line segment

Select the antenna using Selection Tool. Next, make a copy of the antenna using the ALT
key and then flip it horizontally by choosing Modify > Transform > Flip Horizontal from
the menubar. You can select multiple objects using the SHIFT key.

Position the antennae at appropriate places using the Selection Tool. Figure 2-30 shows the
complete honey bee.

Figure 2-30 The honey bee

Save the flash file with the name c02tut1 at the location \Documents\Flash_Projects\c02_tut\c02_
tut_01.

Press CI'RL+ENTER to view the final output of the vector graphic honey bee. You
can also view the final rendered image of the honey bee by downloading the file
c02_flash_cc_2015_rndrzip from www.cadcim.com. The path of the zip file is mentioned at the
beginning of the TUTORIALS section.
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Tutorial 2

In this tutorial, you will create an advertisement banner with the name “The Coffee Shop’, as
shown in Figure 2-31. (Expected time: 30 min)

Figure 2-31 The advertisement banner with the name “The Coffee Shop’

The following steps are required to complete this tutorial:

me s o

Create a new Flash document.

Set the width and height of the Stage.

Create a coffee bean.

Create a decorative pattern using Line Tool and Oval Tool.
Download the images.

Use bitmaps as fill.

g. Insert text using Text Tool.

Creating a New Flash Document
In this section, you will create a new Flash document.

1. Choose File > New from the menubar; the New Document dialog box is displayed.

2. In the New Document dialog box, choose ActionScript 3.0 from the General tab and then
choose the OK button; a new Flash document is displayed.

Setting the Width and Height of the Stage
In this section, you will set the width and height of the Stage to define the exact area required
for creating “The Coffee Shop’ ad banner.

1. Click in the Stage; the Document properties are displayed in the Properties panel.

2. In the Properties area of the Properties panel, choose the Edit document properties
button, as shown in Figure 2-32; the Document Settings dialog box is displayed, refer to

Figure 2-33.

¥ Properties (|
FPS: 2400 (]
Sze: S0 x 20 px @ o
stage: [ | |Edit document properties
I |

Figure 2-32 Choosing the Edit document properties button
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3.

Enter the values 600 (width) and 250 (height) in the Dimensions edit boxes of the Documents
Settings dialog box and choose the OK button, refer to Figure 2-33.

Document Settings @
Units: | Pixels - |
Stage size: 600 ¥ |250] | px | Match contents |
Scale: [] Scale content
[ Locked and hidden layers
Anchar:
Stage color: |:|

Frame rate: 24,00

|MakeDefauIt| | 0K | | Cancel |

Figure 2-33 Setting the dimensions in the Documents Settings dialog box

Creating a Coffee Bean
The shape of the coffee bean is roughly an oval shape. You will start creating the coffee bean
by drawing an oval.

—

N

©°

Choose Oval Tool from the Tools panel. In the Fill and Stroke area of the Properties panel,
choose the Stroke color swatch; a flyout is displayed. In this flyout, choose the No Color
button.

Choose the Fill color swatch; a flyout is displayed. In this flyout, enter #663300 in the Hex
edit box and press the ENTER key. Next, draw a vertical oval anywhere in the Pasteboard,
as shown in Figure 2-34.

Select half of the oval shape using Selection Tool, refer to Figure 2-35 and then press the
DEL key; the selected fill is deleted.

Figure 2-34 Creating an oval shape Figure 2-35 Selecting half of the oval shape
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4. Select the semi-oval shape.
5. Choose the Color button to display the Color panel.

6. Select the Linear gradient fill style from this Color type drop-down list; the gradient
definition bar is displayed at the bottom of the Color panel, as shown in Figure 2-36. The
pointers below the bar indicate the colors in the Linear Gradient fill. The Linear gradient
fill style is used to blend colors on a linear path.

7. Double-click on the left pointer below the gradient definition bar; a flyout is displayed, as
shown in Figure 2-37. Next, make sure #000000 is entered in the Hex edit box of the flyout
and press the ENTER key. Similarly, double-click on the right pointer; a flyout is displayed.
Next, enter #663300 in the Hex edit box and press the ENTER key; a linear gradient fill
is applied to the semi-oval shape.

Solid calor |-
None
v Solid color
Linear gradient L\) ctr
Radial gradient m | | i
- Alpha:% 100

Bitmap fill

= (000000 Ar 100 %

Figure 2-36 Selecting Linear gradient  Figure 2-37 The flyout displayed on
from the Color type drop-down list double-clicking the left pointer

8. Select the semi-oval shape and make a copy to create the second half of the coffee bean. Next,
flip it horizontally by choosing Modify > Transform > Flip Horizontal from the menubar.
Position it next to the first semi-oval shape of the coffee bean, as shown in Figure 2-38.

Figure 2-38 Positioning semi-ovals to create
coffee bean

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

2-16 Adobe Flash Professional CC 2015: A Tutorial Approach

10.
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. Move the cursor over the gap between the coftee beans, press

Choose Lasso Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel.

Select the outlines of the inner edges of the coffee bean using Lasso Tool, refer to Figure 2-39.
Next, press the DEL key; the selected fill of the inner edges is deleted, refer to Figure 2-40.

Figure 2-39 Selecting the outlines of the Figure 2-40 The coffee bean afier deleting
inner edges of the coffee bean the outlines of the inner edges

. Now, you need to fill the color in the gap between the coftee beans. To do so, choose &

Brush Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, choose the
Fill color swatch; a flyout is displayed. In this flyout, enter #090400 in the Hex edit
box and press the ENTER key. In the Options section of the Tools panel, choose the
Brush Mode button; a flyout is displayed. In this flyout, choose the Paint Behind
mode.

. Choose the Brush size button in the Options section of the . ®

Tools panel; a flyout containing different sizes of the brush is -
displayed. In this flyout, choose the largest size of the brush,
as shown in Figure 2-41.

and hold the left mouse button, and then drag the cursor over
the gap. Next, release the mouse button; the fill automatically 1N
shifts behind the coffee bean as the Paint Behind mode of
Brush Tool was selected.

Figure 2-41 Choosing the
largest size of the brush

The Paint Behind mode of Brush Tool is used to paint the

blank area of the Stage while leaving the strokes and the fills unaffected in the same layer,
refer to Figure 2-42.
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Figure 2-42 The Paint Behind mode of the Brush Tool

14. Select the coffee bean using Selection Tool and then create a copy of it. Next, rotate the
coffee bean by using Free Transform Tool and position it, refer to Figure 2-43.

Next, you will convert the coffee beans into a graphic symbol because it will be used later
to create a decorative pattern using different tools.

15. Select coffee beans using Selection Tool and then choose Modify > Convert to Symbol
from the menubar; the Convert to Symbol dialog box is displayed, as shown in Figure 2-44.

Convert to Symbol @

Name: | STulsl]Bl T I I 0K I

Type: | Movie Clip | * | Registration: §E§

Folder: Library root

» Advanced

Figure 2-43 Rotating and Figure 2-44 The Convert to Symbol dialog box
positioning the coffee bean

16. In this dialog box, type coffee beans as the name of the symbol in the Name text box. Next,
select Graphic as the symbol type from the Type drop-down list and then choose the OK
button; a graphic symbol named coffee bean is saved in the Library panel. You can now delete
the coffee bean instance from the Pasteboard as it is saved in the Library panel.

The Library panel in Flash stores all the media files such as bitmaps, graphics, sound files,
and video clips that you import and symbols that you create in a Flash document. By default,
the Library panel is located next to the Properties panel in the Essentials workspace.
Alternatively, choose Window > Library from the menubar to display the Library panel.

Next, you will create a decorative pattern using Line Tool and Oval Tool. Before creating
the decorative pattern, you will draw a layout of the advertisement banner and divide it into
sections.
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17.

18.

19.

Choose Rectangle Tool from the Tools panel; the properties of this tool are displayed in
the Properties panel.

In the Fill and Stroke area of the Properties panel, choose the Stroke color swatch; a flyout
is displayed. In this flyout, enter #000000 in the Hex edit box and press the ENTER key.
Next, choose the Fill color swatch; a flyout is displayed. In this flyout, choose the No Color
button and make sure 1 is entered in the Stroke edit box.

Draw a rectangle with the dimensions equal to the dimensions of the Stage. Now, choose
Line Tool and draw line segments to divide the rectangle into sections. Figure 2-45 shows the
advertisement banner layout, with the sections named to provide you an idea of positioning
the images and text.

Bitmap 1 section Bitmap 2

section

Drawing section Text section

Bitmap 3 section

Figure 2-45 The layout for “The Coffee Shop’ advertisement banner

Creating Decorative Pattern Using Line Tool and Oval Tool
In this section, you will create complex patterns and decorations easily and quickly by using the
Line Tool and Oval Tool.

1.

Choose Paint Bucket Tool from the Tools panel; the properties of this tool are displayed
in the Properties panel. In the Fill and Stroke area of the Properties panel, choose the
Fill color swatch; a flyout is displayed. In this flyout, enter #E07E33 in the Hex edit box
and press the ENTER key. Next, click in the Drawing section of the advertisement banner
layout in the Stage; the color is applied in this section, refer to Figure 2-46.

Figure 2-46 The color applied in the Drawing section

Choose the Line Tool from the Tools panel; the properties of this tool are displayed in the
Properties panel. In the Fill and Stroke area of the Properties panel, choose the Stroke
color swatch; a flyout is displayed. In this flyout, enter #FFFFFF in the Hex edit box and
press the ENTER key. Make sure 1 is entered in the Stroke edit box.
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3. Next, press and hold the SHIFT key and draw a vertical line segment (stroke) on the

pasteboard, as shown in Figure 2-47.

Figure 2-47 Creating a line segment

Choose Selection Tool. Next, place the cursor over the stroke
and drag it to the right; the curvature bends outward, as shown
in Figure 2-48.

Choose Oval Tool from the Tools panel. In the Fill and Stroke

area of the Properties panel, choose the Fill color swatch; a flyout Ly )
is displayed. In this flyout, choose the No Color button located

on the upper right side of this flyout.

Choose the Stroke color swatch; a flyout is displayed. In this Figure 2-48 Changing the
flyout, make sure #FFFFFF is entered in the Hex edit box curvature of the stroke

and press the ENTER key. Next, create two small ovals on the

pasteboard, as shown in Figure 2-49.

Choose Selection Tool. Marquee select the newly created shapes. Next, choose Modify >
Convert to Symbol from the menubar; the Convert to Symbol dialog box is displayed, as
shown in Figure 2-50.

Convert to Symbol
Name: |T I I 0K I
Type: Registration: EE
Folder: Lib
» Advanced
Figure 2-49 Creating two ovals Figure 2-50 The Convert to Symbol dialog box

on the pasteboard

In this dialog box, type pattern as the name of the symbol in the Name text box. Next,
select Graphic as the symbol type from the Type drop-down list and then choose the OK
button; a graphic symbol named pattern is saved in the Library panel. You can now delete
the pattern instance from the Pasteboard as it is saved in the Library panel.

t www.cadcim.com
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9. Select and drag the pattern symbol from the Library panel and place it in the Drawing section
of the layout, as shown in Figure 2-51. Next, reduce the size of the pattern as required using
the Transform Tool.

Figure 2-51 Pattern symbol placed in the Drawing section

10. Create copies of the pattern using the ALT key and place them randomly in the Drawing
section, as shown in Figure 2-52.

Figure 2-52 Copies of the pattern symbol placed randomly
in the Drawing section

11. Now, you need to select and drag the coffee beans symbol from the Library panel and place
it in the Drawing section of the layout, as shown in Figure 2-53. Next, reduce the size of the
pattern using the Transform Tool as required.

Figure 2-53 Coffee beans symbol placed in the Drawing section
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12. Create copies of the coffee beans using the ALT key and place them randomly in the Drawing

section, as shown in Figure 2-54.

Figure 2-54 Copues of the coffee beans symbol are placed in
the Drawing section

Downloading the Images
In this section, you will download the bitmap images for using them as Bitmap Fill.

1.

Download the images used in this tutorial from the following links:

hittp:/fwww.sxc.hu/photo/128744 1, hitp:/fwww.sxc.hu/photo/1289296, and
hitp:/fwww.sxc.hu/photo/1097233

Save them with the names: cafe latte.jpg, cup.jpg, and beans.jpg, respectively at the location /
Documents/Flash_Projects/c02_tut/Resowrces.

Note
Footage Courtesy: Gareth Weeks (http.//www.sxc.hu/profile/garwee),
ilker (hitp.//www.sxc.hu/profile/ilco), Rob Owen-Wahl (hitp://www.sxc.hu/profile/lockstockd)

Using Bitmaps as Fill

In this section, you will use bitmaps as fill.

1.

Choose Paint Bucket Tool from the Tools panel. Next, choose the Color button; the Color
panel is displayed. In the Color panel, select Bitmap fill from the Color type drop-down
list; the Import to Library dialog box is displayed.

In the Import to Library dialog box, choose Documents > Flash_Projects > c02_tut >
Resources > cup.jpg. Next, choose the Open button; the selected image is displayed in
the Color panel as bitmap swatch, refer to Figure 2-55.

In the Color panel, choose the Import button; the Import to Library dialog box is displayed.
In this dialog box, browse to the location Documents/Flash_Projects/c02_tut/Resowrces tolder and
import cafe latte.jpg, and beans.jpg. These images are displayed in the Color panel as bitmap
swatches, as shown in Figure 2-55, and are saved in the Library panel, refer to Figure 2-56.
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Figure 2-55 The bitmap swatches Figure 2-56 The Library panel

In the Color panel, make sure the Fill color button is
chosen. Next, click on the cup.jpg swatch using the

Colar
|L“_| | Bitmap fill | vl

color picker, as shown in Figure 2-57. Next, move the Y
cursor in the Bitmap 1 section in the Stage and click; _ o Z
the cup.jpg image is applied as fill in this section. Fill color m

For the Bitmap 2 section, choose the cafe latte.jpg
swatch in the Color panel. Figure 2-57 Choosing cup.jpg as fill

For the Bitmap 3 section, choose the beans.jpg swatch in the Color panel.

If the images that are used as fill for Bitmap sections do not fit properly, then you need
to resize the bitmap fill. To resize a bitmap fill, for example the cup fill, choose Gradient
Transform Tool from the Tools panel and click on the cup fill in the Stage; the gradient
bounding box with transform handles is displayed around the cup fill. Move the cursor
over the arrow located at the bottom left handle of the gradient bounding box; the cursor
changes to a double-headed arrow. Drag the double-headed arrow outward to fit the cup
fill, refer to Figure 2-58. Figure 2-59 shows the complete view of Bitmap sections.

Figure 2-58 Scaling the cup.jpg image using Gradient Transform Tool
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Figure 2-59 The Bitmap sections

Inserting Text Using Text Tool
Now, you need to add text to complete this advertisement banner.

1. Choose Insert > Timeline > Layer from the menubar; a new layer is created. Next, rename
the new layer as Text. Alternatively, you can choose the New Layer button in the Timeline
panel to create a new layer.

2. Choose Text Tool from the Tools panel; the properties of Text Tool are displayed in the
Properties panel. In this panel, make sure Static Text is selected in the Text type drop-down
list, refer to Figure 2-60.

3. Make sure the orientation of the text is horizontal. If it is not horizontal, change it to
horizontal by using the Change orientation of text drop-down list in the Properties panel,
refer to Figure 2-60.

Froerie: EScaIE
T

[ Static Text

| Change orientation
of text

Text type

w Position and Size

I

X: 247,95

== w: H:
 Character
Family: |T|rnes New Roman | 7|
Style: [Regular [=][ Embed.. |
Size: 30.0 pt Letter spacing: 0.0
color: [ ™ Auto kern
Anti-alias: | Anti-alias for readability | v|

]

Figure 2-60 Text Tool options in the Properties panel

4. In the Character area of the Properties panel, choose the Gill Sans Ultra Bold font from
the Family drop-down list. Next, set the font size to 30 in the Size edit box. Next, choose
the swatch located on the right to Color; a flyout is displayed. In this flyout, enter #000000
in the Hex edit box.
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5. Click in the Stage; the text box is displayed. In this text box, type The Coffee Shop. Next,
choose Selection Tool and position the text at the center of the Text section, as shown in
Figure 2-61.

A

STV T 7 l-

Figure 2-61 The Coffee Shop advertisement banner

6. Save the flash file with the name c0O2tut2 at the location \Documents\Flash_Projects\c02_tut|
c02_tut_02.

7. Press CTRL+ENTER to view the final output of the advertisement banner. You can also
view the final rendered image of the advertisement banner by downloadlng the file c02_
flash_cc_2015_rndrzip from www.cadcim.com. The path of the zip file is mentioned in the
beginning of the TUTORIALS section.

HOT KEYS

In Flash, you can use the keyboard shortcuts to invoke the commonly used commands. The
shortcut keys are referred as hot keys. With the help of these keys, you can work faster and more
efficiently. Some of the most important keys and their functions are listed below.

Hot keys and their functions

Key Function

CTRL+N Creates a new document
CTRL+O Opens the existing Flash file
CTRL+W Closes the active Flash file
CTRL+S Saves the active Flash file
CTRL+Z To undo the last step
CTRL+Y To redo the last step

Hot keys for invoking tools

Key Tool

Selection Tool

Subselection Tool

Free Transform Tool

Gradient Transform Tool
3D Rotation Tool
3D Translation Tool

Q== |o|> <
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L

Lasso Tool

g

Pen Tool

Add Anchor Point Tool

Delete Anchor Point Tool

Convert Anchor Point Tool

Text Tool

Line Tool

Rectangle Tool and Rectangle Primitive Tool

Oval Tool and Oval Primitive Tool

Pencil Tool

Brush Tool

Paint Bucket Tool

Ink Bottle Tool

Eyedropper Tool

Eraser Tool

Hand Tool

N[z{=|=|e|=]|=|=|oc|=|z][=]c

Zoom Tool

Some Important Hot keys

Key Function

CTRL+R Imports elements to the Stage
CTRL+F8 Creates new symbols

F8 Converts objects to symbols
CTRL+B Breaks apart elements
CTRL+G Groups elements
CTRL+SHIFT+G | Ungroups elements
CTRL+ENTER Tests the movie

CTRL+U Opens preferences settings
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. Which of the following options of the Brush Tool is used to paint behind the strokes and
fills in the same layer?

(a) Paint Fills (b) Paint Behind
(c) Paint Selection (d) Paint Inside
2. The key helps you to draw a perfect circle while using Oval Tool.
3. The graphics are produced by using geometrical primitives such as points, lines,

curves, and shapes.
4. The option provides a platform for colors to blend on the linear path.
5. The option is used to apply bitmap images as a fill.
6. The Linear gradient option is used to create linear gradient strokes. (T/F)
7. You can create a new symbol by pressing CTRL+R. (T/F)
8. You can close the active Flash file by pressing CTRL+W. (T/F)
9. L is the shortcut key for invoking Lasso Tool. (1/F)

10. CTRL+ENTER is used to test a movie. (T/F)

Review Questions

Answer the following questions:

1. Which of the following combinations of shortcut keys is used for creating a new document?

(a) CTRL+N (b) CTRL+B
(c) CTRL+G (d) CTRL+U
2. is the shortcut key for invoking Add Anchor Point Tool.
3. is the shortcut key for invoking Free Transform Tool.
4. The option is used to snap objects along the edges of other objects.

5. is the shortcut key for invoking 3D Rotation Tool.
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6. is the shortcut key for invoking Rectangle Tool and Rectangle Primitive Tool.
7. You can ungroup the elements by pressing CTRL+G. (T/F)

8. You can invoke Text Tool by using the shortcut key “T". (T/F)

EXERCISE

Exercise 1

Using various tools, create the advertisement banner for “The Flower Shop’, as shown in
Figure 2-62. You can view the final rendered image of the banner by downloading the file
c02_flash_cc_2015_exr.zip from www.cadcim.com. The path of the file is as follows: Textbooks >
Animation and Visual Effects > Flash > Adobe Flash Professional CC 2015: A Tutorial Approach.

(Expected time: 30 min)
Download the bitmaps used in this exercise from the following links:

hitp:/fwww.sxc.hu/photo/1340073 (Courtesy: hitp:/fwww.sxc.hu/profile/alex27)
hitp:/fwww.sxc.hu/photo/1338574 (Courtesy: hitp:/fwww.sxc.hu/profile/Roxanne727)
hitp:/fwww.sxc.hu/photo/1284438 (Courtesy: hitp://www.sxc.hu/profile/robby_m)
hitp:/fwww.sxc.hu/photo/1077716 (Courtesy: hitp:/fwww.sxc.hu/profile/bjearwicke)
hittp:/fwww.sxc.hu/photo/1323129 (Courtesy: hitp:/fwww.sxc.hu/profile/misscheeky)

The~
Flower
—~-Shop

Figure 2-62 The advertisement banner with the name “The Flower Shop’
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Answers to Self-Evaluation Test
1. b, 2. SHIFT, 3. vector, 4. Linear Gradient, 5. Bitmap fill, 6. F, 7. F, 8. T, 9. T, 10. T



