Chapter 3

Working with Symbols
and Instances

Learning Objectives

After completing this chapter, you will be able to:
* Create new symbols

* Edit the symbols and instances

* Create and edit button symbols

e Import Adobe Photoshop files in Flash
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INTRODUCTION

In Flash, you can create movies of small file size. One way to keep the file size small is to create
symbols. There are three categories of symbols in Flash namely graphics, buttons, and movie
clips. Once a symbol is created in a Flash document, it is automatically saved in its library and
can be used later in any of the Flash documents.

The Graphic symbols are the basic category of symbols. These symbols are generally used for
static images. They do not support ActionScript, filters, or blending modes.

The Button symbols are used to create buttons for interactivity. A button symbol contains four
keyframes. Each keyframe is used to define the behavior when the mouse pointer interacts with
the button symbol. You can apply filters, blending modes, and color effects to the button symbols.
These symbols require ActionScript to perform an action.

The Movie Clip symbols are the most powerful symbols in Flash and are generally used for
animation. A movie clip symbol contains its own independent Timeline. You can add an animation
to the movie clip Timeline as you do in the main Timeline and play both the animations
simultaneously, making complex animations simpler. You can also apply filters, color effects, and
blending modes to a movie clip and its instances. An instance is the copy of a symbol located in
the Stage or inside a symbol. In addition, you can use ActionScripts to control movie clips and
make them respond to the user.

Creating Symbols

In Flash, you can create symbols in two ways which are discussed next.

1. Create a new Flash document. Next, choose Insert > New Symbol from the menubar; the
Create New Symbol dialog box will be displayed. In this dialog box, specify a name for the
symbol in the Name text box and select the required symbol type from the Type drop-down
list. Next, choose the OK button; the symbol-editing mode will be displayed. In this mode,
you can draw or import the graphics in the symbol.

2. Select an object or existing graphic in the stage that you need to convert into a symbol. Next,
choose Modify > Convert to Symbol from the menubar; the Convert to Symbol dialog
box will be displayed. Next, specify a name for the symbol in the Name text box and select
the required symbol type from the Type drop-down list. Then, choose the OK button; the
selected object or graphic will be converted into a symbol and will be saved in the document
library.

TUTORIALS

Before you start the tutorials, you need to download the ¢03_flash_cc_2015_tut.zip file from
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > Flash >
Adobe Flash Professional CC 2015: A Tutorial Approach.

Next, extract the contents of the zip file to \Documents\Flash_Projects.
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Tutorial 1

In this tutorial, you will create and edit a graphic symbol and its instances.
(Expected time: 15 min)
The following steps are required to complete this tutorial:

Open the Flash document.

Convert the shape into a graphic symbol.
Create and edit the instance of the symbol.
Edit the symbol.

Break the link of the instance from its symbol.

o as ow

Opening the Flash Document
In this section, you will open the Flash document.

1. Choose File > Open from the menubar; the Open dialog box is displayed.

2. Choose Documents > Flash_Projects > c03_tut > c03_tut_01 > c03_tut_01_start.fla.
Next, choose the Open button from the dialog box; the Flash document is displayed, as
shown in Figure 3-1.

FL File Edit View Inset Modify Tect Commands Control Debug Window Help Essentials -

03 tut 01 startfla *

& MR Scenel @ A & &> roperties — .
% i c03_tut_01_startfla
|= | = Publish [~
o Profile: Default
ﬂ __Pubhshsmmgs...
I e —— Y

L —

~ Propertie:

FPS: 24,00

Sze: 53 x40 px N
sages [

~ SWF History.

Timeline

® a0 5 015 0 2% W/ 40 45 S0 55 60 65 7075 @0 @ W 9%

] ball 4

M0 PGAWESNN00E =000 7 ~[F

an s Wb ook [ BBOE |5 ks ges K1 I 51 ’M—‘v
Figure 3-1 The c03_tut_01_start.fla document displayed

Converting the Shape into a Graphic Symbol

In this section, you will convert the object into a graphic symbol.

1. Make sure the Selection Tool is chosen in the Tools panel. Next, marquee select the circular
shape in the Stage and choose Modify > Convert to Symbol from the menubar; the Convert
to Symbol dialog box is displayed, as shown in Figure 3-2.
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Convert to Symbal @
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Folder: Library root
» Advanced
Figure 3-2 The Convert to Symbol dialog box
2. In the Convert to Symbol dialog box, type cricket ball as the name of the symbol in the

Name text box and then select Graphic from the Type drop-down list. Next, choose the
OK button; the graphic symbol with the name cricket ball is created and saved in the Library
and an instance of it is created in the Stage, refer to Figure 3-3.

When you convert a shape or graphic into a symbol, its instance is created in the stage and the
symbol itself is placed inside the Library panel. The graphic symbols are the basic category
of symbols. These symbols are generally used to convert still images or objects into symbol.

Note

Select the cricket ball symbol in the Library panel to view it in the Item preview window if it
is not selected, as shown in Figure 3-3. The Item preview window displays the selected symbol in
the Library panel. The Library in Flash stoves all the files such as bitmaps, graphics, sound files,
and the video clips that yow imponrt. It also stores the symbols that are created in a Flash document.

Library
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Figure 3-3 The cricket ball symbol displayed in the
Item preview window of the Library panel

Creating and Editing the Instance of the Symbol

In this section, you will create and edit the instances of the cricket ball symbol.

1.

Click on the cricket ball symbol icon (4) in the Library panel and drag it to the Stage; the
second instance of the cricket ball symbol is created in the Stage. Alternatively, drag the cricket
ball symbol from the Item preview window of the Library panel to the Stage to create its
instance.
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Place the second instance below the first instance in the Stage.

Make sure the Selection Tool from the Tools panel is selected and select the first
instance of the cricket ball; the properties of the first instance are displayed in the Properties
panel.

In the Color Effect area of the Properties panel,  [ropese enl=
select Alpha from the Style drop-down list; the Alpha

slider is displayed in the Color Effect area, as shown
in Figure 3-4.

| Graphic | r|

Instance of: [ cricket ball | [ swap... |
Set the value of the Alpha slider to 55. Alternatively, [+ position and size
enter 55 in the Alpha edit box and notice the change

X X = X 27245 ¥ 18345

in the transparency of the first instance, as shown in

Figure 3-5 & w750 H: 75.00
 Color Effect

Make sure the Selection Tool from the Tools panel is Style: | Alpha 2

selected and select the second instance in the Stage; RSN — T P

the properties of the second instance are displayed [ opng
in the Properties panel.

In the Color Effect area of the Properties panel,
select Brightness from the Style drop-down list; the  Figure 3-4 The Alpha slider in the
Bright slider is displayed in the Color Effect area.  Color Effect area

Next, set the value of the Bright slider to -60; the

second instance of the symbol turns dark, as shown in Figure 3-6.

Figure 3-5 The first instance Figure 3-6 The second instance

Note

@ You can create any number of instances of a symbol and change their respective propenrties from

the Properties panel without affecting the other instances. 10 edit a symbol’s property and enter
the symbol-editing mode, double-click on the icon of the symbol in the Library panel.

Editing the Symbol

In this section, you will edit the cricket ball symbol in the symbol-editing mode.

1.

Double-click on the icon of the cricket ball graphic symbol (4) in the Library panel to enter
into the symbol-editing mode. Alternatively, double-click on the cricket ball graphic symbol
image in the Item Preview window of the Library panel; the cricket ball graphic symbol is
displayed in the Stage with its Timeline in the symbol-editing mode, refer to Figure 3-7.
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‘ Tip
Q You can also edit a symbol by choosing Edit > Edit Symbols from the menubar or by pressing
CTRL+E.

« B 6, 4 o [7]

Figure 3-7 The cricket ball graphic symbol in the symbol-editing mode

2. Select the upper fill of the cricket ball graphic symbol and choose the Color button

located at the upper left corner of the Properties panel; the Color panel is displayed. ®

3. In this panel, double-click on the left pointer of the gradient definition bar; a flyout is
displayed. In this flyout, enter #FFFFFF in the Hex edit box and press the ENTER key.
Next, double-click on the right pointer; a flyout is displayed. In this flyout, enter #000000
in the Hex edit box and press the ENTER key. Figure 3-8 displays the selected fill and its
gradient definition bar.

4. Repeat Step 2 for the middle and lower fills of the cricket ball. Next, double-click on the
stroke of the border of the cricket ball to select the stroke entirely; the Shape properties are
displayed in the Properties panel.

5. In the Fill and Stroke area of the Properties panel, choose the Stroke color swatch; a flyout
is displayed. In this flyout, enter #000000 in the Hex edit box and press the ENTER key.
Notice that the changes that you make to the symbol also affect the instances of the symbol in
the Stage. The ball will turn black in the Library panel and in the Stage, refer to Figure 3-9.

Figure 3-8 The gradient definition bar of the upper fill inside  Figure 3-9 The cricket ball symbol
the cricket ball symbol after changing the color

6. Click on Scene 1 to return to the main Timeline.
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Breaking the Link of the Instance from its Symbol
In this section, you will break the link of the cricket ball instance from its symbol.

1.

Choose Selection Tool from the Tools panel, if it is not selected and select the first instance
of cricket ball symbol in the Stage.

Choose Modify > Break Apart from the menubar or press CTRL+B; the first instance of
cricket ball 1s delinked from its symbol. The instance is now an independent object and is no
longer linked to the symbol. Now, you can modify the symbol without affecting the instance
or vice-versa.

Double-click on the icon of the cricket ball graphic symbol (4) in the Library panel to enter
into the symbol-editing mode.

Make sure the Selection Tool from the Tools panel is selected and select the upper
fill of the ball. Next, choose the Color button located at the upper left corner of the B
Properties panel; the Color panel is displayed.

In this panel, double-click on the right pointer of the gradient definition bar; a flyout is
displayed. In this flyout, enter #0000CC in the Hex edit box and press the ENTER key;
the color of the cricket ball graphic symbol in the Library panel is changed, as shown in
Figure 3-10.

Click on Scene 1 to return to the main Timeline; the color of the second instance is changed
as it is still linked to the symbol. The first instance remains unchanged as it is no more linked
to the symbol, refer to Figure 3-11.
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Figure 3-10 Displaying the change in color of  Figure 3-11 The first instance without
the cricket ball graphic symbol any change

Save the flash file with the name cO3tut! at the location \Documents\Flash_Projects\ c03_tut\c03_
tut_01.

Press CI'RL+ENTER to view the final output of the instance and the symbol. You can also view
the final rendered image of the instance by downloading the file c03_flash_cc_2015_rndr.zip
from hitp://www.cadcim.com. The path of the zip file is mentioned at the beginning of the
TUTORIALS section.
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Tutorial 2

In this tutorial, you will create a button symbol, as shown in Figure 3-12 and then define its
states. (Expected time: 20 min)

Figure 3-12 The button symbol

The following steps are required to complete this tutorial:
a. Create a new Flash document.

b. Create a shape.
c.  Convert the shape into a button symbol.

Creating a New Flash Document
In this section, you will create a new Flash document.

1. Choose File > New from the menubar; the New Document dialog box is displayed.

2. In the New Document dialog box, choose ActionScript 3.0 from the General tab and then
choose the OK button; a new Flash document is displayed.

Creating a Shape

In this section, you will create the shape of the button symbol.
1. Choose Rectangle Primitive Tool from the Tools panel.
2. Choose the Color button located at the upper left of the Properties panel; the Y
Color panel is displayed. In this panel, select the fill style as Linear gradient from
the Color type drop-down list.
3. Draw a rectangle in the Stage; the tool properties are displayed in the Properties panel.
4. In the Rectangle Options area of the Properties panel, enter 7 in the Rectangle corner

radius edit box and press the ENTER key; the shape of the corners is changed, as shown
in Figure 3-13.
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Figure 3-13 Changing the shape of the corners of the rectangle

5. Choose Gradient Transform Tool from the Tools panel and click on the fill of the rectangle
in the Stage; the gradient transform bars are displayed around the fill.

6. Move the cursor over the rotation handle of the gradient transform bar located at the upper
right corner of the bars and drag the cursor to the left to rotate the gradient transform bars
to approximately 90 degrees, as shown in Figure 3-14.

7. Move the cursor over the arrow located on the gradient transform bar; the shape of the cursor

changes to a double-headed arrow indicating that now you can scale the fill. Next, drag the
cursor inward and scale the gradient fill approximately to 50%, as shown in Figure 3-15.
The rectangular shape of the button symbol is created in the Stage.

Figure 3-14 Rotating the gradient fill

,/” \\\
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Tip

G

Figure 3-15 Scaling the gradient fill

You can also transform gradient 45 degree in one time by using SHIFT key.
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Converting the Shape into a Button Symbol

In this section, you will convert the rectangle into a button symbol and edit it.

1. Double-click on Layer 1 (default layer name) in the Timeline panel and rename it as Buttons.

2. Choose Selection Tool from the Tools panel and make sure the rectangle in the Stage is
selected. Next, choose Modify > Convert to Symbol from the menubar or press the F8 key;
the Convert to Symbol dialog box is displayed.

3. In the Convert to Symbol dialog box, type Home in the Name text box and select Button

from the Type drop-down list. Next, choose the OK button; a button symbol with the name
Home is created and saved in the Library.

Note

In Flash, when you create a new button or convert a shape into a button symbol, a new Timeline
is created for the corresponding button symbol, which is visible only in the button symbol’s editing
mode. 1o make the Timeline visible, double-click on that button symbol.

4. Double-click on the icon of the Home button symbol icon () in the Library panel to
enter into the editing mode. Alternatively, choose Edit > Edit Symbols from the menubar.
Figure 3-16 shows the Home button symbol in editing mode.

L FT |

< I 3

Figure 3-16 Symbol-editing mode of the Home button symbol

Note

Figure 3-17 shows the Timeline of the Home button symbol. This Timeline contains four frames
that define different states of the button symbol. The Up frame is used to define the appearance of
the button when the cursor is not placed over it. Flash automatically places the original button
symbol in the Up frame.
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Figure 3-17 The Timeline of the Home button symbol

In the Timeline panel, select the Over frame. Next, press the F6 key or choose Insert >
Timeline > Keyframe from the menubar; a keyframe is inserted in the blank frame.

The Over frame of the button symbol is used to define the appearance of the symbol when
the mouse pointer is over it.

Note

@ The keyframe is a frame that represents a new symbol instance in the Timeline. You can also add

10.

11.

the ActionScript code to the keyframe to control certain actions in a document.

Make sure the Selection Tool is chosen from the Tools panel and the rectangle in the Stage
is selected.

Choose the Color button located at the upper left corner of the Properties panel;
the Color panel is displayed. In the Color panel, double-click on the right pointer
of the gradient definition bar; a flyout is displayed. In this flyout, enter #999999
in the Hex edit box and press the ENTER key.

®

Select the Down frame and press the F6 key to insert a keyframe. Next, select the fill of the
rectangle in the Stage.

Choose the Color button; the Color panel is displayed. In the Color panel, double-click on
the right pointer of the gradient definition bar; a flyout is displayed. In this flyout, enter
#333333 in the Hex edit box and press the ENTER key.

The Down frame of the button symbol is used to define the appearance of the button, when
the user clicks on it.

Select the Hit frame and press the F7 key to insert a blank keyframe. Create a new layer
above Layer 1 using the New Layer button.

Choose Rectangle Tool from the Tools panel; the properties of this tool are displayed in
the Properties panel. In the Fill and Stroke area of the Properties panel, choose the Stroke
color swatch; a flyout is displayed. In this flyout, make sure #000000 is selected in the Hex
edit box and press the ENTER key. Choose the Fill color swatch; a flyout is displayed. In
this flyout, enter #0000CC in the Hex edit box.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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12. In Layer 2, select the Hit frame and press the F7 key to insert a blank keyframe. Next,
choose the Onion Skin button; the frame range before and after the current frame range
becomes visible. Now, create a rectangle covering the rectangle of the button symbol, as

shown in Figure 3-18.

The Hit frame of the button symbol represents the area of the screen that will respond on

clicking. The rectangle created in this frame defines the hit area of the button.

o

Note
The hit area is not visible in the Stage and in the preview window.
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13. Press CI'RL+ENTER; the preview window is displayed showing the Home button instance.
Move the mouse pointer over the Home button instance to see its Over state and click on
it to see its Down state. Figures 3-19 and 3-20 show the Over and Down states of the Home

Figure 3-18 Rectangle in the Hit frame

button instance, respectively.

Figure 3-19 The Over state of the
button symbol

Notice that the rectangle you created in the Hit frame is not visible in the preview window.
Click anywhere in the preview window, except on the hit area (rectangle) you created in the

button symbol

Hit frame; the button symbol shows no change.

Figure 3-20 The Down state of the



Working with Symbols and Instances 3-13

14.

15.

16.

17.

18.

19.

20.

Close the preview window to return to the Flash document.

In the Layer 2 of the Timeline panel, select the Hit frame; the rectangle in the Stage is
selected.

Choose Selection Tool from the Tools panel and click on the rectangle; the Shape properties
are displayed in the Properties panel.

In the Position and Size area of the Properties panel, set the value of W to 270 and the
value of H to 170. Next, set the value of X to -140 and the value of Y to -86; the rectangle
is positioned and resized, as shown in Figure 3-21.
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Figure 3-21 Increasing the dimensions of the rectangle in the Flash document

Press CITRL+ENTER; the preview window is displayed showing the Home button. In the
preview window, move the cursor over the hit area of the button and notice the changes in
it.

By increasing the dimensions of the rectangle in the Hit frame, you can define the hit area
of the button symbol (instance). Now, the appearance of the button changes not merely by
clicking on the symbol itself, but also on placing the cursor over the hit area and clicking
in the hit area.

Save the flash file with the name c¢03tut2 at the location \Documents\Flash_Projects\c03_tut
c03_tut_02.

Press CI'RL+ENTER to view the final output of the button symbol. You can also view the
final rendered file of the button symbol by downloading the file cO3_flash_cc_2015_rndrzip
from hitp://www.cadcim.com. The path of the zip file is mentioned at the beginning of the
TUTORIALS section.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Tutorial 3

In this tutorial, you will convert the objects into movie clip symbols and apply the Glow filter to
them, as shown in Figure 3-22. (Expected time: 10 min)

Figure 3-22 The Glow filter applied to movie clips symbols

The following steps are required to complete this tutorial:

a. Open the Flash document.
b. Convert the shapes into the movie clip symbols.

Opening the Flash Document
In this section, you will open the Flash document required for this tutorial.

1. Choose File > Open from the menubar; the Open dialog box is displayed. In this dialog
box, choose Documents > Flash_Projects > c03_tut > c03_tut_03 > c03_tut_03_start.fla.
Next, choose the Open button; the Flash document is displayed, as shown in Figure 3-23.

=]o] x
Fl File Edit View Insert Modify Text Commands Control Debug Window Help Essentials +
Untitled 1* % | c03.fig 5la % | Uniitled 2" % | cO3_tut.03 startfla % —
‘ . oo b Library = =
W s L NETRNE [ — o] I
o 9.
2,
: N, T
=
e @
g [Emetyibrey L2 s 7
= Lnkase
& b
&
1 &7
o Q
2]
ol
o5
n
oa0f] s, v BB B 2, 3 B 5, 0B 0 S DB W5 8
2 1 A
iy
1y
iy
c1
—r =}
R AT T [ € B e— > T = I———

Figure 3-23 The c03_tut_03_start.fla document displayed

Converting the Shapes into Movie Clip Symbols

In this section, you will convert the shapes into movie clips symbols.
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1. Select the Moon layer in the Timeline panel; the circle (moon) behind the clouds is selected
in the Stage.

2. Press the F8 key; the Convert to Symbol dialog box is displayed. In this dialog box, type
moon_mc as the symbol name in the Name text box and select Movie Clip as the symbol
type from the Type drop-down list. Next, choose the OK button; the moon shape is converted
into a movie clip symbol with the name moon_mc.

3. In the Filters area of the Properties panel, choose the Add filter button located at | s
the bottom of the Filters area; a flyout is displayed showing various filters, as shown
in Figure 3-24.

4. Choose Glow from this flyout; the Glow area with various properties is displayed in the
Filters area, as shown in Figure 3-25.

Drop Shadow
Blur
Glow
Bevel w Filters
Gradient Glow IE
Gradient Bevel Broperty | Value l
v Glow -]
Adjust Color Blur X 4px ()
- | Blur Y 4 px (=]
Remove All Strength 100%
Enable &ll Quality Lowi licw
. Color .
Disable All P, 0
Inner glow
E =
Figure 3-24 The flyout displayed on Figure 3-25 The Glow area

choosing the Add filter button

ot

In the Glow area, set the value of Blur X and Blur Y to 50 each and Strength value to 150.

6. Click on the swatch on the right to Color; a flyout is displayed. In this flyout, enter #FFFFFF
in the Hex edit box and press the ENTER key.

7. Select High from the Quality drop-down list.
After setting these values, you will notice the glow
effect displayed around the circle (moon) in the
Stage, as shown in Figure 3-26.

8. In the Timeline panel, select the Stars layer; the
dots (stars) are selected in the Stage.

9. Press the F8 key; the Convert to Symbol dialog

box is displayed. In this dialog box, type the Figure 3-26 The effect of the Glow filter on
symbol name as stars in the Name text box and ¢ moon

make sure the symbol type Movie Clip is selected

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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10.

11.

12.

13.

14.

in the Type drop-down list. Next, choose the OK button; the dots are converted into a movie
clip symbol with the name stars.

At the bottom of the Filters area, choose the Add filter button; a flyout is displayed showing
various filters. Choose Glow from this flyout; the Glow area with various properties is
displayed in the Filters area.

In the Glow area, set the Strength value to 150. Click on the swatch on the right of Color; a
flyout is displayed. In this flyout, enter #FFFFFF in the Hex edit box and press the ENTER
key.

Select High from the Quality drop-down list; the glow effect is displayed around the dots
in the Stage, as shown in Figure 3-27.

Figure 3-27 The glow effect on dots

Save the flash file with the name c¢03tut3 at the location \Documents\Flash_Projects\c03_tut
c03 _tut_03.

Press CIRL+ENTER to view the final output of the tutorial. You can also view the final
rendered file of the tutorial by downloading the file c03_flash_cc_2015_rndrzip from
http://www.cadcim.com. The path of the zip file is mentioned at the beginning of the
TUTORIALS section.

Tutorial 4

In this tutorial, you will import Adobe Photoshop artwork into Flash.

(Expected time: 10 min)

The following steps are required to complete this tutorial:

a.

b.

Create a new Flash document.
Import Photoshop file.

Creating a New Flash Document
In this section, you will create a new Flash document.

1.

2.

Choose File > New from the menubar; the New Document dialog box is displayed.

In the New Document dialog box, choose ActionScript 3.0 from the General tab and then
choose the OK button; a new Flash document is displayed.
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Importing the Photoshop File
To create a complex artwork, you may prefer other applications such as Adobe Illustrator or
Adobe Photoshop. In this section, you will import artwork created in Adobe Photoshop to Flash.

1. Choose File > Import > Import to Stage from the menubar; the Import dialog box is
displayed. In this dialog box, choose Documents > Flash_Projects > c03_tut > Resources
> shapes.psd; the Import “Shapes.psd” to Stage dialog box is displayed, as shown in
Figure 3-28.

Import "Shapes.psd” to Stage @

Select Photoshop layer comp:

[ Flatten Photoshop layers to a single bitmap

Layer conversion:

(O Maintain editable paths and effects
@ Single flattened bitmap
Text Conversion:
(O Editable Text
O Vector outline
(%) Flattened bitmap image
Convert layers to:
(@ Flash layers
() single Flash layer

(O Keyframes

[ Match stage size(600 x 500)

Figure 3-28 The Import “shapes.psd” to Stage dialog box

2. Choose the OK button; every object created in separate layers in Photoshop is placed in the
same manner in Flash with name of the layers as Shape 1, Shape 2, Shape 3, and so on, as
shown in Figure 3-29.

3. Save the flash file with the name cO3tut3 at the location |Documents\Flash_Projects\c03_tut)
c03_tut_04.

4. Press CTRL+ENTER to view the final output. You can also view the final rendered file of
the tutorial by downloading the file cO3_flash_cc_2015_rndr.zip from hitp://www.cadcim.com.

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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The path of the zip file is mentioned at the beginning of the TUTORIALS section.
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. Which of the following shortcut keys is used to insert a keyframe?

(a) F2 (b) F4
(c) F8 (d) F6
2. The window displays the selected symbol in the Library panel.
3. An is a copy of a symbol.
4. The symbols are generally used for animating static images.
5. The symbols are used to create buttons for interactivity.

6. A button symbol contains its own independent Timeline. (T/F)

7. The Over state of a button symbol is used to define the appearance of the button when the
cursor is placed over it. (1/F)

8. You can apply blending modes and filters to a graphic symbol. (T/F)
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Review Questions

Answer the following questions:

1. Which of the following combinations of the shortcut keys is used for applying the Break
Apart command?

(a) CTRL+C (b) CTRL+B

(c) CTRL+G (d) CTRL+U
2. The , , and are the three categories of symbols in Flash.
3. The area of a button symbol is not visible in the Stage and in the preview window.
4. , , , and are the four states of a button symbol.
5. The represents a new symbol instance in the Timeline.
6. The state of a button symbol represents how the button will appear when the

user clicks on it.

7. The command is used to delink the instance from its symbol.

EXERCISES
Exercise 1

Create the buttons for a website, as shown in Figure 3-30, using various drawings and editing
tools, functions, and button symbol frames. You can view the final rendered file of the buttons
by downloading the file c03_flash_cc_2015_exr.zip from hitp://www.cadcim.com. The path of the file
is as follows: Textbooks > Animation and Visual Effects > Flash > Adobe Flash Professional CC 2015:

A Tutorial Approach. (Expected time: 20 min)

Figure 3-30 The buttons for website

Exercise 2

Create a night scene, as shown in Figure 3-31, using various tools, functions, and filters. You
can view the final rendered file of the tutorial by downloading the file cO3_flash_cc_2015_exr.zip
trom hitp://www.cadcim.com. The path of the file is mentioned in Exercise 1.

(Expected time: 40 min)

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Figure 3-31 The night scene

Answers to Self-Evaluation Test
1. d, 2. Item preview, 3. instance, 4. graphic, 5. button, 6. F, 7. T, 8. F



