Chapter 1

Introduction to
RISA-3D

Learning Objectives

After completing this chapter, you will be able to:

* Understand the basic features of RISA-3D

* Start RISA-3D software

* Use different components of the user interface of RISA-3D
* Start a new project in RISA-3D

* Import different files to RISA-3D
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INTRODUCTION

RISA-3D is used for creating, analyzing, and designing any type of structure through its flexible
modeling environment and user interface. The three basic activities which are to be carried
out to achieve this goal are: model generation, calculations to obtain the analytical results, and
result verification. All these activities are discussed individually in different chapters. RISA-3D
is designed for engineers who understand the process of modeling, analyzing, and designing
a structure.

BASIC FEATURES OF RISA-3D

The basic features of RISA-3D are listed below:

1) State-of-the art modeling environment such as multiple view interface, and advanced selection
and drawing tools.

2) Ability to perform rapid structural analysis and design of buildings, racks, bridges, tanks,
stadia, arenas, culverts, and so on

3) Ability to generate 2D/3D CAD models

4) Ability to model truss and beam members, plates, solids, linear and non-linear cables, and
curvilinear beams

5) Advanced automatic load generation facilities for wind, seismic, and moving loads
6) Spreadsheet based features

7) Graphical and numerical visualization of results

8) Analysis and design link with Autodesk Revit

9) Ability to import and export files in DXF, STAAD, DESCON, and structural desktop format

STARTING RISA-3D

You can start RISA-3D by double-clicking on the RISA-3D icon available on the desktop.
Alternatively, choose Start > All Programs > RISA 3D > RISA-3D 14.0 from the taskbar (for
Window 7), refer to Figure 1-1; the interface will be displayed.
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Figure 1-1 Starting RISA-3D 14.0 from the task bar

USER INTERFACE

The user interface of RISA-3D consists of main menu, shortcut menus, toolbars, and keyboard
shortcuts, refer to Figure 1-2. The interface elements are exclusively designed to provide an easy
access to the tools and windows. These elements are discussed next.
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Figure 1-2 RISA-3D Interface

The menu bar is located at the top of the interface. It comprises of different menus: File, Edit,
Settings, Units, View, Insert, Modify, Spreadsheets, Solve, Results, Tools, Window, and Help.
The menus in the menu bar are discussed next.

File

The File menu contains the options which are used for performing different file operations such as
creating new files, opening an existing file, saving files, printing files, and so on. Figure 1-2 shows
different options in the File menu.

The New option in the menu is used for creating a new file. On choosing this option, a new file
will be opened in RISA-3D. The Open option is used for opening an existing file. The Append
option is used to append another RISA-3D model into the current model. The Print option is
used to print different files. The Import option is used to import data from other formats, such
as RISA-2D file, DXF file, STAAD file, and Autodesk Revit Exchange file. The Save option is
used to save the file. The Exit option is used to exit RISA-3D graphical environment.

Edit

The Edit menu contains the options that are used to perform editing operations such as copy,
paste, undo, redo, insert new line into a spreadsheet, and so on. Figure 1-3 shows different
options in the Edit menu. You can use the Undo and Redo options to undo/redo an operation.
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The Copy option is used to copy the selected object to clipboard. The Paste option is used to
paste an object from the clipboard into RISA-3D. The Insert Line, Delete Line, Repeat Line,
Mark All Lines, UNMark Lines, Delete Marked Lines options are used to perform operations
in a spreadsheet. The Find option is used to locate an item in the spreadsheet.

Settings  Units  View Insert M

Undo Ctrl-Z
Redo Ctrl-Y
Select All Ctrl-A
Copy Ctrl-C
Paste Ctrl-V
Insert Line

Delete Line

Repeat Line

Mark All Lines

UMNMark Lines

Delete Marked Lines

Find... F5
Sort... 2]
Fill Block... Ctrl-F
Math on Block... Ctrl-M

Figure 1-3 Different options in the Edit menu

Settings
The Settings menu invokes the (Global) Model Settings dialog box. This dialog box is discussed
in detail in further chapters.

Units
The Units menu invokes the Unit Settings dialog box. This dialog box is discussed in detail in
further chapters.

View
The View menu contains the options that affect the visibility or appearance of the model and
various elements of the interface. Figure 1-4 shows different options in the View menu.

The New View option opens up a new model view. The Save or Recall Views option is used to
save a view or recall any previously saved view. The Refresh All option refreshes all the windows
that are open in RISA-3D. The Select and Unselect options are used to select or deselect the
model elements. The Save or Recall Selection States option allows you to save or recall any
previously saved element selections. The Zoom option allows you to zoom in and out the model.
The Rotate option is used to snap the model view to global planes or an isometric view. The
Render option allows you to toggle on or oft between various rendered views of the current
model. The Drawing Grid and Project Grid options are used to toggle the display on or off for
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the drawing and project grids. The Axes, Boundaries, and Loads options are used to toggle on
or off the global axes, boundary conditions, and model loads, respectively. The Joint Labels,
Member Labels, Plate Labels, and Solid Labels options are used to toggle on or off the labels
for joints, members, plates and solids, respectively.

Insert
The Insert menu contains the options that are used to insert new items into the model. Figure 1-5
shows different options in the Insert menu.
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Figure 1-5 Different options in the Insert
menu

Figure 1-4 Different options in the View
menu

Modify
The Modify menu contains the options that are used to modify the existing items in the model.
Figure 1-6 shows different options in the Modify menu.
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Spreadsheets
The Spreadsheets menu contains the options that provides access to all the spreadsheets.
Figure 1-7 shows different options in the Spreadsheets menu.
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Figure 1-6 Different options in the
Modify menu

Figure 1-7 Different options in the
Spreadsheets menu

Solve
The Solve menu is used to invoke the process of the analysis within RISA-3D.

Results
The Results menu contains the options that provide access to result spreadsheets. Figure 1-8
shows different options in the Results menu.
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Tools
The Tools menu contains the miscellaneous tools and options which are used for performing
different tasks such as relabeling the elements, merging the models, aligning, axes swapping,

and so on. Figure 1-9 shows diftferent options in the Tools menu.

Results | Tools Window Help

Window

various options in the Window menu.

Figure 1-8 Different options in the Results menu

Figure 1-9 Different options in the

Tools menu

§ v | Results Buttons Toolbar
g Select List...
eactions trl-Alt-
'S Reacti Ctrl-Alt-R
g Envelope Joint Reactions
Q Joint Deflections Ctrl-Alt-D
§ Envelope Joint Deflections
g Members 3
L Plates 3
-
.ﬂ Solids L
: Seismic Detailing Results Ctrl-Alt-A
(<) ‘Wall Panel Design Results Ctrl-Alt-W
—
"&' Wall Panel Forces
E Diaphragms Ctrl-Alt-G
P . Al
e Story Drift Ctrl-Alt-T m Window Help
Envelope Story Drift
.E nvelope stery Bn Relabel Joints...
3 Frequencies Ctrl-Alt-Q Relabel Members...
W Mode Shapes Ctrl-Alt-0 Relabel Plates...
) TH Joint Trace Relabel Wall Panels...
Q .
3 Material Take-Off Crl-Alt-M Relabel Solids...
e Warning Log Full Model Merge...
‘5. Degenerate Plate Check...
2 Solve Again Using Suggested Shapes Ctrl-Alt-F7 Round Off Joint Coordinates...
-06 Results Presentation 4 Delete All Wall Panel Regions
S Footings Switch Vertical Axes (Y<->Z)...
Q
Q Exclude Results Application Settings...
> N Customize Toolbar...
Y ear Results
8 Envelope Wall Panel Forces Reset All Program Defaults..,
S
Q
—
b
c
=
—y
S
>
w

The options in the Window menu allow you to rearrange the open windows. Figure 1-10 shows
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Help
The Help menu contains different options that are used to access oftline help document, update
services, and about RISA-3D. Figure 1-11 shows various options in the Help menu.

Window | Help
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Arrange Icons
Cascade
Tile Vertical
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Close All Check for Update
v 1 Model View About RISA-3D

Figure 1-10 Options in the Window menu  Figure 1-11 Options in the Help menu

Toolbars

RISA-3D comprises of various toolbars that are available in the interface. These toolbars contains
various tools which are used for creating new file, opening an existing file, changing views,
printing, rotating tools, viewing results, and so on. To know about any particular tool, hover the
cursor over the tool; a pop-up menu will be displayed with the description of the tool.

RISA Toolbar

The RISA toolbar is located on the top of the interface and below the menu bar. It contains
different tools which are used for accessing files and windows. Figure 1-12 shows various tools
available in the RISA toolbar.
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Figure 1-12 Tools in the RISA toolbar

Window Toolbar

The Window toolbar is located just below the RISA toolbar. The tools in this toolbar are displayed
based on the active window. When the model window is active, the Window toolbar displays tools
such as Rotate and Zoom tools. Figure 1-13 shows different tools available in the Window toolbar.
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Figure 1-13 Tools in the Window toolbar

Drawing Toolbar

You can toggle on or off the Drawing toolbar using the Activate the Graphic Editing Toolbar
(Ctrl-G) button located in the Window toolbar. This toolbar is located at the top of the model
view. The tools available in this toolbar are used to draw, load, and modity the given model
graphically. Figure 1-14 shows different tools in the Drawing toolbar.
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Figure 1-14 Tools in the Drawing toolbar

Selection Toolbar

This toolbar is located vertically on the left in the RISA-3D interface. The
options available in this toolbar are used to select and unselect the model
elements. Figure 1-15 shows different tools available in the selection toolbar.
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Model View Area

In RISA-3D, the model view area contains the model. In this area, you can
graphically create and modify the model elements. Figure 1-16 shows the
model view area.

Data Entry Floating Window

The Data Entry floating window can be placed anywhere on the screen.
This window contains the buttons which are used to invoke the spreadsheets
for entering the data. Figure 1-17 shows the Data Entry floating window.
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Figure 1-16 The model view area
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Results Floating Window
The Results floating window contains the buttons which are used to invoke the results
spreadsheets. Figure 1-18 shows the Results floating window.
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Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1. Which of the following formats are supported by RISA-3D?

(a) DXF (b) STAAD
(c) DESCON (d) All the above

2. Which of the following options from the menu bar is used to display the (Global) Model
Settings dialog box?

(a) Units (b) View
(c) Settings (d) Insert

3. When the model window is active, the window toolbar displays tools such as
and
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4. Loads options is used to toggle on or of the global axes. (1/F)

5. The Solid Labels options are used to toggle on or off the label for joints. (T/F)

Review Questions

1. The option allows you to save or recall any previously saved element selection.
2. The Axes option is used to toggle on or off the boundary conditions. (1/F).
3. RISA-3D can generate 2D/3D CAD models. (T/F)

4. RISA-3D provides advanced automatic load generation facilities for wind, seismic, and
moving loads. (T/F)
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Answers to Self-Evaluation Test



