
Chapter 2

Getting Started with 
RISA-3D

Learning Objectives
 

After completing this chapter, you will be able to:
• Start a new project
• Configure application settings
• Configure model settings
• Create and set the grids 
• Save and exit the project
• Open an existing project
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INTRODUCTION
In this chapter, you will learn to start a project, set up global and project parameters, and save 
a project. In RISA-3D, you can do preliminary settings for units, fonts, backup, graphics, result 
printing, analysis steps, and so on. You can also use these custom settings in other projects.
 

STARTING A NEW PROJECT
RISA Menu:     		 File > New
Shortcut Keys:		  CTRL+N

On starting RISA-3D for the first time, the RISA-3D interface is displayed with a new project 
loaded by default. Also, the Starting a Model dialog box will be displayed along with it, refer 
to Figure 2-1.

  

Figure 2-1  The Starting a Model dialog box

The Starting a Model dialog box contains options to open a sample model, launch RISA user’s 
guide, create a new model or reload a previously created model. To open a sample model, choose 
the Open a Sample Model button in the Explore a Sample Model area. Similarly, to launch 
RISA user’s guide, choose the Launch Tutorial in Separate Window button in the Learn how 
to use RISA-3D area. Various quick access buttons are available in the Create a New Model 
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area in the Starting a Model dialog box. These quick access buttons allow you to create or 
sketch new members, wall panels, plates, and also to generate a model using a template. The 
or Reload a Previously Created Model area of this dialog box displays five recently accessed 
files. You can open a file by clicking on it.

CONFIGURING APPLICATION SETTINGS
You can customize any of the parameters, design, and analysis options in RISA-3D and thus 
modify the program to suit you and your work process. These options are discussed below.

Setting up the Application Parameters
RISA Menu:     		 Tools > Application Settings

To configure application settings, choose the Application Settings option from the Tools menu; 
the Application Settings (Preferences) dialog box will be displayed, as shown in Figure 2-2. The 
Application Settings (Preferences) dialog box contains all available options to customize the 
interface and graphics in RISA-3D. This dialog box contains six tabs named General, Data 
Entry, Solution and Results, Fonts, Printing, File Locations. These tabs and their options are 
discussed next.

Figure 2-2  The Application Settings (Preferences) dialog box

General Tab
The General tab in the Application Settings (Preferences) dialog box contains the options related 
to the appearance, sound settings, backup file settings, and so on. Select the Show “Starting a 
Model” Panel when starting a new model? check box to display the “Start a Model” display 
box at startup. 
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You can select the Show Global dialog after loading a file? check box to display the (Global) 
Model Settings dialog box containing the options related to the project details, codes of practice, 
shear ties and stress options for concrete material, seismic parameters, and more. To play the 
startup sound while starting up RISA-3D, select the Play the starting sound when starting up 

the program? check box. The error messages in RISA-3D are accompanied with an error sound. 
You can use the Play the error sound when showing an error message? check box to play or 
mute this sound at the time of display of the error. In RISA-3D, you can automatically update all 
the open windows for any changes made to the data by selecting the Automatically refresh all 
open windows for any data change? check box. The Show the toolbars? check box toggles on/
off the display of all the toolbars. The Show the Data Entry toolbar Loads buttons? check box  
toggles on/off the display of the load buttons in the Data Entry toolbar. The Automatic backup 
timing (minutes) option is used to set the automatic backup frequency. You can manually enter 
any value directly in the edit box or you can use the spinner. The value should be entered in 
minutes.  The Default Region drop-down list contains the list of countries to choose the default 
region for the project. The Reset Customization Options to Their Original Settings button is 
used to reset all the customized settings to its factory defaults. 

Note
The customized settings cannot be rolled back to factory defaults. It is an irreversible process.

Data Entry Tab
In this tab, you can customize the height of the rows by entering a value in the Row height for 
Data Spreadsheet edit box or by increasing or decreasing the value set in the spinners. The 
Decimal Places for Data Entry Fields is used to specify the maximum number of digits to be 
displayed after the decimal point. You can select any value in the range of 1 to 4. In this tab, 
you can also customize the default prefix of joint, member, plate, wall panel, and solid labels.

Solution and Results Tab
If any instability is found in the joints at the time of analyzing the structure, it will be automatically 
locked and the program will be allowed to proceed. Rotational instabilities are commonly 
inconsequential and RISA-3D allows these instabilities to be locked without any warning. Select 
the Lock isolated ROTATIONAL instabilities without notification? check box to lock any 
rotational instability if present, refer to Figure 2-3. To create a warning before clearing the 
previous results, select the Always warn before clearing results? check box. To eliminate the 
slender check for steel structure design, clear the Allow KL/r>200, l/r>300 for LRFD, CAN 
steel design? check box or select it to allow the check for the design. Select the Don’t require 
P-Delta analysis for AISC, CSA, ACI, etc.? check box to waive off the P-Delta analysis for certain 
design codes. 

RISA-3D also warns you if the total of joint reactions is not equal to the summation of applied 
loads. To enable it, select the Warn if total reaction does not equal total load? check box. You 
can also adjust the row height for the result browser by choosing a value from the Row height 
for Results Browsers spinner in the range of 15 to 24. Specify a value in the Decimal Places 
edit box to set the maximum number of digits to be displayed after the decimal point. You can 
group the results under a particular load combination or you can group them under individual 
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items by selecting the Batch results displayed by COMBINATION or Batch results displayed 
by ITEM check box, respectively.

Figure 2-3  The Solutions and Results tab of the Application Settings 
(Preferences) dialog box

Fonts Tab
The Fonts tab contains options to personalize the annotation and spreadsheet formats such as 
font, font style, and font size. In RISA-3D, you can assign different font styles to spreadsheets, 
members and joints labels, reports, graphics, solid labels, and more. To do so, choose the 
button corresponding to the option in which you want to make changes. For example, to change 
format of spreadsheets, choose the Select Spreadsheet Font button from the Fonts tab; the 
Font dialog box will be displayed. The Font dialog box contains three areas for formatting. 
The Font area contains a list of all the fonts available in RISA-3D. Choose any font from 
the list. The Font Style area contains different font styles for the font selected. For example, 
if you choose the Arial font from the Font area, 10 format styles will be available for the 
selected font such as Narrow, Narrow Italic, Regular, Bold, Black, Black Oblique, and so on.  
You can use any of the font styles available in the Font style area. You can also modify the size 
of the font from the Size area in the Fonts dialog box. The list in this area contains default 
sizes available ranging from 8 to 20. You can choose any size from the list box or enter your 

own custom size by clicking in the edit box. The Sample area of the Fonts dialog box shows the 
preview format chosen. 
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Printing Tab 
The Printing tab includes settings for printing graphics and reports. The GRAPHICS 
Preferences area of this tab contains settings for printing graphical sketches in the reports. You 
can select the Portrait or Landscape radio button to change the view orientation of the sketch. 

To print the date and time along with the result, select the Show Date and Time? check box. You 
can also customize the sketch numbers and the prefix of the figures in the result. The Margins 
(Inches) area in the Printing tab is used to set the print margins. You can set the left, right, top, 
and bottom values for the margin in their corresponding edit boxes.

File Location Tab
The locations for files such as model data files, RISA section files, databases, temporary space, 
load combination lists, importing, back up files can be defined separately. To change the location 
of any of these files, choose the corresponding option from the Path and Current Setting, Use 
Browse to Modify drop-down, refer to Figure 2-4. Next, choose the Browse button; the Select 
ANY file to set the path dialog box will be displayed. In this dialog box, specify the path for 
the file location.

Figure 2-4  The options in the Path and Current Setting, Use Browse to Modify 
drop-down list in the Application Settings (Preferences) dialog box

Setting Project Units
RISA Menu:     		 Units

You can set a unit system for your project. To do so, choose the Units menu from the  
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Menu bar; the Units Selection dialog box will be displayed, as shown in Figure 2-5. Alternatively, 
choose the Define units to be used tool from the RISA toolbar.

The Units Selection dialog box contains different drop-down lists having both imperial and 
metric units. You can choose any option from the drop-down lists. For example, you can select 
the inches option from the drop-down list in the Lengths area to change the unit for length 
parameter from feet to inches. Select the Converting Existing Data For Any Units Changes? 
check box to convert the values already present in the current project. You can also save your 
custom unit settings as default. To do so, select the Save these units settings as the default 
settings? check box. To change the entire unit system to imperial or metric, choose the Standard 
Imperial or Standard Metric button, respectively. 

Figure 2-5  The Units Selection dialog box

Note
The Convert Existing Data For Any Units Changes? check box is disabled until you change 
any of the units from the drop-down lists available.

CONFIGURING (GLOBAL) MODEL SETTINGS
You can define the model parameters for a project in RISA-3D. To set the model parameters, 
choose the Settings menu; the (Global) Model Settings dialog box will be displayed with the 
Description tab chosen by default. This dialog box contains six tabs. These tabs are discussed next.
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Description Tab
This tab contains the project information such as Model Title, Company, Designer, Job Number, 
and Checked By, as shown in Figure 2-6. You can add additional information in the Notes text 
box. This information can be saved as default, and then can be used in other projects. You can 

choose the Save as Defaults button to save the settings as default so that the specified settings 
are loaded the next time when you open RISA-3D.

Figure 2-6  The (Global) Model Settings dialog box

Solution Tab
The parameters under the Solution tab are used to control the settings that affect general 
analysis of the model. You can adjust the number of sections defined for a single member. For 
each section defined, the report for member force, stress, torsion, and deflection results will be 
generated. This adds more detail to the output result files without affecting the analysis of the 
model or the code checks. To set the number of sections, choose a number between 2 to 20 from 
the Number of Sections spinner in the Members area, refer to Figure 2-7. 

In the INTERNAL Sections edit box, you can specify the number of internal sections for which 
RISA-3D will calculate and save the results such as forces, stresses, code checks, and more. If you 
want to include the shear deformation and torsional warping in the model analysis, select the 
Shear Deformation and Torsional Warping check boxes. You can define the maximum size of 
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the area load mesh by entering its value in the Area Load Mesh edit box. 

Note
Number of sections affect the analysis and design results. More the number of sections, more will 
be the output result.

In the Wall Panels area of the Solution tab, you can set the base mesh size for the wall panels 
before solving it. To define the base mesh size, enter a value in the Mesh Size edit box. To 
perform the P-Delta analysis on the wall panels, select the Include P-Delta for Walls check box. 

Figure 2-7  The Solution tab of the Global Parameters dialog box

You can also specify whether you want RISA-3D to automatically update the design or stiffness 
of wall panels with iterated solutions. To do so, select the Yes option from the Wall Design drop-
down list in the Wall Optimization area. You can also set the number of iterated solutions you 
want by choosing the Iterations spinner. 

You can set the vertical axis for the model by selecting the X, Y, or Z radio button from the 
Orientation area of the (Global) Model Settings dialog box. To define the default member 

orientation, choose the Member Default Orientation button from the Orientation area; the Set 
Default Member Orientation dialog box will be displayed, as shown in Figure 2-8. 

In this dialog box, if you want the local z axis of the member to be parallel to global XZ plane, 
select the Force member local z axis to be parallel to the global XZ plane radio button. Similarly, 
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if you want the local z axis of the member to be parallel to global XY plane or global YZ plane, 
select the Force member local z axis to be parallel to the global XY plane or Force member 
local z axis to be parallel to the global YZ plane radio button, respectively. After setting the 
default member orientation, choose the OK button to save the setting and close the Set Default 

Member Orientation dialog box. 

In the (Global) Model Settings dialog box, choose the Advanced button; the Set Advanced 
Options dialog box will be displayed. In the P-Delta edit box, specify the percentage tolerance 
for determining the convergence of P-Delta analysis. In the Eigensolution: I.E -edit box, you 
need to specify the volume which indicates that how close a solution must be to the previous 
solution for a model to be considered as converged..

Figure 2-8  The Set Default Member Orientation dialog box

 

Specify the acceleration due to gravity and the model merge tolerance in the Gravity Acceleration 
edit box and Merge Tolerance edit box, respectively. Choose the solver types from the Solvers 
area for static and dynamic solutions. On selecting the Standard Skyline radio button for 
dynamic or static solution, the non-zero terms of the stiffness matrix are clustered around the 
main diagonal of the stiffness matrix. On selecting the Sparse Accelerated radio button from 
the Static area, the matrix size will be reduced to an absolute minimum by eliminating the 
storage of all zero stiffness terms. On selecting the Accelerated Solver radio button from the 
Dynamic area, the accelerated sub-space iteration with Lanzcos starting vector is used. After 
specifying the advanced options, choose the OK button; the Set Advanced Options dialog box 
will be closed. Choose the Save as Defaults button from the Solution tab in the (Global) Model
Settings dialog box to save the settings as default for all further projects.

Codes Tab
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The Code tab contains code options for the HR Steel, Connections, CF Steel, Wood, Concrete, 
Masonry, and Aluminum. You can choose an option from the drop-down list corresponding to 
these sections. You can also adjust the stiffness reduction provision of the defined Hot Rolled 
steel sections. To do so, select Yes (Iterative) or Yes (Tau=1.0) from the Adjust Stiffness drop-
down list corresponding to the HR Steel section. To ignore the section stiffness reduction 
provision in the analysis, choose the No option from this drop-down list. You can also specify 
the temperature for the wood section by choosing an option from the Temperature drop-down 
list corresponding to the Wood section. 

Concrete Tab
The Concrete tab contains options related to the analysis and design of concrete sections, refer 
to Figure 2-9. 

Figure 2-9  The Concrete tab of the (Global) Model Settings dialog 
box

From the # Shear Regions drop-down list of the Shear Tie Options area, choose an option 
from 2 or 4 to specify the number of shear regions you want to consider in analysis. At shear 
regions, you can also specify the shear tie increment to be considered while designing a concrete 

member. To specify it, you need to enter a value in the Region Spacing Incr. edit box of the 
Shear Tie Options area. 

The Biaxial Column Design area of the Concrete tab controls the type of method that will be 
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used to determine the biaxial capacity of the column. If you want to determine the column’s 
biaxial capacity by Exact Integration Method, select the Exact Integration Method radio button. 
To calculate the biaxial capacity by the PCA Load Contour Method, select the PCA Load Contour 
Method radio button. If you have selected the PCA Load Contour Method radio button, you can 

also specify the column’s approximate 3D interaction surface to be considered in the calculation. 
Specify this value in percentage in the Parme Beta Factor edit box of the Biaxial Column 
Design area. You can also modify the value for minimum and maximum percentage of steel in 
a column by specifying desired values in the Minimum % Steel for Columns and Maximum % 
Steel for Columns edit boxes, respectively. As per section 10.9.1 in ACI 318-11, the minimum 
and maximum steel values for a concrete column are set by default to 1% and 8% respectively. 

 

RISAFoot Tab
The options in the RISAFoot tab are used to define parameters for design and analysis 
of the footings. In this tab, you can enter a value for factor of safety against sliding in the                        
OTM/Sliding Safety Factor edit box. To optimize the solutions for OTM (overturning moment)/
sliding forces, select the Optimize for OTM/Sliding check box. The options in the Concrete area 
are used to specify the properties such as Concrete Weight, Concrete fc (strength), Concrete Ec 
(modulus of elasticity), and more. The Steel area of the Footing tab contains options related to 
the strength and minimum and maximum percentage of steel in an RCC member. You can also 
specify the cover for reinforcements in the Footing Top Bar, Footing Bottom Bar, and Pedestal 
Bars edit boxes. The default values for the concrete and steel parameters are as per the codes 
specified in the Codes tab of the (Global) Model Settings dialog box. Figure 2-10 shows the 
RISAFoot tab of the (Global) Model Settings dialog box.

Figure 2-10  The RISAFoot tab of the (Global) Model Settings dialog box
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Seismic Tab 
The RISA-3D Seismic Load Options area of the Seismic tab contains the options for defining 
the earthquake load parameters. You can choose a desired code from the Seismic Code 
drop-down list for defining the earthquake load on the model. The other parameters for the 
design depends upon the code you select. For example, if you select the None option from the 
Seismic Code drop-down list, six basic parameters for the earthquake design will be displayed. 
The Ct(X) and Ct(Z) parameters are building period coefficient, T(X) and T(Z) which is the 
natural time period, and R(X) and R(Z) which is response modification factor in the x and z 
directions, respectively.	

SETTING THE GRIDS
Grids are generally a series of vertical and horizontal reference lines at specified intervals. Grid 
lines are created for member references to facilitate the modeling  process. You can add new 
members, plates, boundaries, and more to a project by drawing them from point to point at the 
grid intersection. In RISA-3D, you can draw two types of grids, project grid and drawing grid. 
These are discussed next in detail.

Project Grid
In RISA-3D, the project grid is part of the model and can be used to move the elements of the 
model simply by moving a grid line. In project grid, any change in the grid intervals is reflected 
in the repositioning of the corresponding hosted elements. You can specify the project grid 
only in the model plan view. The project grid is saved with the model view. Figure 2-11 shows 
project grids in 3D view.  

Figure 2-11  Project grids in 3D view

To define the project grid, choose the Project Grid Spreadsheet button from the RISA  
toolbar; The Horizontal Project Grid Locations dialog box will be displayed, as shown 
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in Figure 2-12. 

Figure 2-12  The Horizontal Project Grid Locations dialog box

The name of the dialog box will change based on the tab chosen. In the Horizontal Project Grid 
Locations dialog box, two tabs are present depending on your model plan view. By default, the 
Z Axis and X Axis tabs are available. This means your model elevation is parallel to Y axis. For 
more details, refer to the previous section of this chapter. In any or both of these available tabs 
you can set the location, label, increment, distance and more parameters defining the grid lines. 
To set the start label of the grid lines along any specific axis, enter a value in the Start Label 
edit box of the Grid Generation area. You can also specify the starting location of the grid with 
reference to the origin by entering a value in the Start Location edit box. The Increments edit 
box is used to specify the increment and the intermediate distance of the grids. For defining 
the grid lines, you can use symbols such as (@), or (,), or (/). 

If you want to generate an equally spaced grid pattern of 8 increment with a distance of 10 units 
each, you should enter 8@10 in the increment edit box of the Grid Generation area. Next, 
choose the Generate button from the Grid Generation area; the pattern will be generated in 
the drawing window. Figure 2-13 shows the grid pattern generated in the plan view. 

Figure 2-13  Generated grid pattern with equal spacing

Note
To generate the grid lines along an axis, you should define minimum one grid along its 
perpendicular axis.

To divide a large increment into smaller equally spaced increment, use the / symbol. For example 
if you want to divide a 10 unit long grid into 5 parts of 2 units each, the entry in the Increments 
edit box of the Grid Location area would be 10/5. Choose the Generate button to generate the 
pattern. Figure 2-14 shows the generated grid pattern using the / symbol.

Figure 2-14  Grid pattern generated using the / symbol
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If you want to generate a grid pattern with variable increments, you can use the , (comma)
symbol. For example, to generate a grid pattern with increment 2, 3, 4, and 5, enter 2,3,4,5 in the 
Increment edit box. This will generate five grid lines with increment 2, 3, 4, and 5 respectively. 
Figure 2-15 shows a grid pattern generated with variable increment.

Figure 2-15  Grid pattern with variable increment generated using the, symbol

Editing the Project Grid
After generating the project grid pattern, you can edit the spreadsheet or the grid pattern. The 
editing tools available for editing a grid appear only when the Horizontal Project Grid Locations 
dialog box is invoked. The tools will be present at the lower left corner below the RISA toolbar. 
Figure 2-16 shows the editing tools used for editing the grid pattern.

Figure 2-16  Editing tools available for editing a grid pattern

To add a new line in the spreadsheet, choose the Insert a New Line Before the Current Line  
(F3) tool from the editing bar or you can also press the F3 key. On choosing this tool, the Insert 
Project Grid Line dialog box will be displayed, as shown in Figure 2-17. In this dialog box, the 
currently selected spreadsheet line number is displayed at the top. You can specify the label of 
the new grid line and also the distance of the grid from the existing grid by entering values in 
the Label for the new line and Distance from current line edit boxes respectively. To add a 
new line before or after the current selected line in the spreadsheet, select the Place new line 
BEFORE the current line or Place new line AFTER the current line radio button respectively. 

Figure 2-17  The Insert Project Grid Line dialog box

To delete a line from the spreadsheet, you can select the line and then choose the Delete the  
Current line tool or you can press F4 key. The Fill the Currently Marked Block tool is used to 
fill enteries in the cells of the spreadsheet. The Mark All the Lines tool is used to mark all the 
rows and columns in the spreadsheet. The Delete the Currently Marked Lines and Unmark 
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All the Lines tools will be active only after selecting all the lines in the spreadsheet.  

Drawing Grid
The drawing grid is yet another type of grid lines that can be created in RISA-3D. The main 
difference between project grid and drawing grid is that drawing grid is independent of the 
model and can be created in any view plane. You can modify the grid lines associated to a 
model anytime during modeling. Note that changing the grid lines will not change the model 
geometry. The drawing grid is available by default on opening a new project file. Figure 2-18 
shows the default available grid pattern.

To define or modify a drawing grid, choose the Modify the drawing grid and snap points
button from the Window toolbar. The Drawing Grids dialog box will be displayed, as shown 
in Figure 2-19. The Drawing Grids dialog box contains three tabs: Drawing Grid, Snap To 
Options, and Import DXF. These tabs and their options are discussed next.

Figure 2-18  The default drawing grid pattern

Drawing Grids Tab
The Drawing Grid tab of the Drawing Grids dialog box contains six areas. These areas contain 
different options to generate or modify the grid lines, refer to Figure 2-19. The options in the 
Drawing Grid Origin area are used to set the origin of 

Figure 2-19  The Drawing Grids 
dialog box

the grid line with respect to the global origin. To set the 
origin, enter the values in the X, Y, and Z edit boxes. You 
can also specify the location of the grid origin by clicking 
at any point in the drawing window. To do so, select the 
Click on a point to relocate Origin check box of the 
Drawing Grid Origin area. Next, choose the OK button 
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and then click in the drawing window to specify the location. The options in the Grid Plane 
area are used to set the plane for placing the grid pattern. You can select the XY, XZ, or YZ 
radio button to set the grid pattern plane. 

In RISA-3D, you can draw grid lines in rectangular and radial patterns. To draw rectangular 
grid lines, select the radio button corresponding to the Rectangular Grid Increments area 
if it is not selected by default. The options in the Rectangular Grid Increments area will be 
activated. The rectangular drawing grid is defined by increments in two directions. To define a 
rectangular grid pattern, you need to specify the number of grid lines and their intermediate 
distance. You can use the symbols such as (@), or (,), or (/) for defining the grid lines in a 
particular global direction. The use of these symbols is already discussed in the previous section 
of this chapter. You can also skew the rectangular grid by specifying the skew angle. The skew 
angle is the inclination of the rectangular grid from the global axis. To specify the angle of skew, 
enter a value in the Skew Angle edit box in the Rectangular Grid Increments area. Figure 2-20 
shows default available rectangular grid pattern and Figure 2-21 shows the grid pattern after 
providing 135 degree skew angle. 

Figure 2-20  The default rectangular drawing 
grid pattern

Figure 2-21  The drawing grid pattern with 135 
degree skew angle

A radial grid pattern is defined by increments in two polar directions. To draw a radial grid, select 
the radio button corresponding to the Radial Grid Parameters area. The options in this area 
will be activated. Radial grids are defined by specifying the angular and radial increments. The 
value in the Angle Increments edit box controls the number and angular spacing of the spokes 
emerging from the origin. The value in the Radial Increments edit box is used to determine 
the number and spacing between the radial concentric grids. By default, the center point of the 
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radial grid pattern is its origin. The Start Angle is used to specify the angle of the first spoke 
from the global axis. The radial grid pattern is shown in Figure 2-22.

The Save and Recall Grid Settings area in the Drawing Grids dialog box contains options to save 

the grid pattern, retrieve a saved pattern, and delete them. You can also display the generated 
grid in the form of continuous lines or in the form of points. Figures 2-23 and 2-24 show the 
grid pattern represented by continuous lines and points respectively. To save the current grid 
settings as default grid setting for further sessions, select the Save Current Settings as Defaults? 
check box next to the Show Grid As area.

Figure 2-22  The Radial grid pattern generated

Figure 2-23  The grid pattern represented by
continuous lines

Figure 2-24  The grid pattern represented by points

Snap To Options Tab
The Snap To Options tab contains the Member Snap Locations area and the Universal Snap 
Increments area. The settings in the Snap To Options tab help in sketching the model without 
using grids. In the Member Snap Locations area, you can select the Quarter Points or Third 
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Points check box to specify the automatic grid snapping with quarter or third point increment 
respectively. The Universal Snap Increments area contains options to draw grid line freely with 
any increment in the space. To enable universal snapping, select the Use Universal Increments 
check box in the Universal Snap Increments area. In RISA-3D, you can use this feature to set 
your own custom snap increments on the basis of the geometry of your model. To set the plane 
in which you want to draw grids, select the XZ, XY, or YZ radio button. For example, if you have 
set XY plane for drawing grids, you can set the snap incremental value in the X Incremental 
and Y Incremental edit boxes. The Z Location edit box defines the location of snap points 
perpendicular to the grid plane selected. For the XY plane selected, you can specify the snap 
location in Z direction. 

Import DXF Tab
In RISA-3D, the Import DXF tab contains advanced options to import DXF drawing files as 
grid pattern. This imported grid pattern then acts as a grids providing snap points at their 
intersections. You can draw grid pattern using lines, polylines, circles, arcs, polylines with arcs, 
and points. In this tab, define the origin to which the imported file will be aligned. To define 
the origin, you can enter values in the X, Y, and Z edit boxes in the Drawing Grid Origin (ft) 
area. Alternatively, you can define the origin by clicking at the desired location. To define the 
origin, select the Click on a location to relocate Origin check box. You can also select the plane 
in which you want to place the grid pattern by selecting the XY, XZ, and YZ radio buttons 
available in the Drawing Plane area. 

The DXF Import Options area contains options to change the scale factor, units of the DXF file, 
angle increment, and DXF plane. In this area, by default the value of DXF scale factor is 1. This 
implies that the objects in the DXF file will be imported on the scale of 1. For example, if an 
object is created on a scale of 1/2” = 12” in DXF file, RISA-3D will import it at the same scale 
factor of 1 by default. To import the object at full scale, enter 24 as the scale factor. Units of 
the imported DXF file can be changed from the DXF Units drop-down list in the DXF Import 
Options area. The value entered in the Angle Increment edit box specifies the number of degrees 
in which the imported arcs or circular objects should be broken into straight line segments. 
These segments allows you to snap points. You can enter the degree range between 0.1 to 10.

In the Select a DXF file area, you can select the recent file from the list. You can choose the 
Browse For File button to import an existing file. On choosing the Browse For File button, 
the Select DXF File to Import for Drawing Grid dialog box will be displayed. Browse to the 
desired file and choose the Open button; the Select Layers for Drawing Grid dialog box will be 
displayed. It has two radio buttons, the Use All Layers and Select Layers From the List to use 
all the default layers of the imported DXF file as grid pattern, select the Use All Layers radio 
button. To select Layer(s) from the list of layers, select the Select Layers From the List radio 
button. Choose the Done button; the objects in the DXF file will be imported as drawing grids. 

SAVING A PROJECT
Before you close or exit a RISA-3D session, it is recommended to save the project file. You can 
save a project file in a permanent storage device, such as a hard disk or a removable storage 
device like CD or USB. Also, you must save your work at regular intervals to avoid data loss due 
to any error in the computer’s hardware or software. 
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Using the Save As Tool
RISA Menu:     		 File > Save As
Shortcut Keys:		  CTRL+S

In RISA-3D, you can save your project file at the desired location. To do so, choose the Save As 
option from the File menu; the Save RISA-3D Data File dialog box will be displayed, as shown 
in Figure 2-25. Alternatively, you can save the project file by choosing the Save the current 
model data to disk button from the RISA toolbar.

In the Save RISA-3D Data File dialog box, the drop-down list at the top displays the current 
drive and path in which the project file will be saved. The File name edit box is used to specify 
the name of the file to be assigned to the project. The list on the left in this dialog box contains 
shortcuts for the folders that are frequently used. 

In the Save as type drop-down, you can select the format in which you want to save your file. 
By default the files are saved in the RISA-3D Data Files format. Choose the Save button to save 
the file at the specified location. 

Figure 2-25  The Save RISA-3D Data File dialog box

EXITING A PROJECT
To exit a project, choose the Exit option from the File menu. If you have already saved the latest 
changes, the project file will be closed. Otherwise, RISA-3D will prompt you to save the changes 
through the Check for Save dialog box. You can save the changes by choosing the Yes button 
or discard them by choosing the No button. You can also choose the Cancel button to return 
to the interface and continue working on the project file. You can also use the Close button in 
the drawing to close the project.
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OPENING AN EXISTING PROJECT
RISA Menu:     		 File > Open
Shortcut Keys:		  CTRL+O

In RISA-3D, there are many options available to open an existing project. These options are 
discussed next.

Opening an Existing Project Using the Open Tool
To open an existing project file, choose File > Open from RISA menu, as shown in Figure 2-26. 
Alternatively, you can open the project file by choosing the Open button from RISA toolbar or 
by pressing the CTRL+O keys. On invoking the Open tool, the Open RISA-3D Data File dialog 
box will be displayed, as shown in Figure 2-27. Using the drop-down list at the top of this dialog 
box, you can access the desired folder and open the desired file. 

Figure 2-26  Choosing the Open option from File menu

Figure 2-27  The Open RISA-3D Data File dialog box

The Change your view button located on the left of the Show the preview pane button, helps 
you select a project file based on its size, type, or date when it was last saved. The location list is 
located on the left side in the Open RISA-3D Data File dialog box. In this list, you can navigate 
to drives and folders available in your system. Choose the file located at the path or enter file 
name in the File Name edit box. Choose the Open button to open the desired file. 

TUTORIALS 
Tutorial 1						        Project Parameters
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In this tutorial, you will create a new project file for a project with the following parameters 
and project specifications:					           (Expected time: 30 min)

1.	 Model Parameters

		  Model Title		  G+1 Concrete Framed Structure
		  Company		  CADCIM Technologies
		  Vertical Axis		  Y
		  Concrete Code		  ACI 318-11
		  Concrete Rebar Set	 ASTM 615
2.	 Application Settings
3.	 Units System : Standard Metric 
4.	 File name to be assigned: c02_concrete_tut1.r3d

The following steps are required to complete this tutorial:

a. 	 Start a new session of RISA-3D.
b.	 Set the model parameters.
c.	 Define application settings.
d.	 Set the units for the project from the Units Selection dialog box.
e.	 Save the project.
f.	 Exit the project.

Starting a New Session of RISA-3D
1.	 Start RISA-3D by choosing Start > All Programs > RISA-3D > RISA-3D 14.0. On doing 

so, the RISA-3D interface window with an active Starting a Model dialog box is displayed, 
as shown in Figure 2-28.

Figure 2-28  RISA-3D interface displaying the Starting a Model dialog box
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2.	 Choose the Close button to close this dialog box.

Setting the Model Settings
1.	 Choose the Settings menu from the RISA-3D interface; the (Global) Model Settings dialog 

box is displayed.

2.	 In the Description tab, enter G+1 Concrete Framed Structure and CADCIM Technologies 
in the Model Title and Company edit boxes, respectively.

3.	 Choose the Solution tab. Next, select the Y radio button in the Orientation area it is not 
selected by default.

4.	 Choose the Codes tab and then select the ACI 318-11 option from the Concrete drop-down 
list if not selected by default.

5.	 In the Concrete Rebar Set area of the Concrete tab, select the ASTM A615 from the 
drop-down list if is not selected by default.

6.	 Choose the Apply and then the OK button; the (Global) Model Settings dialog box is 
closed.

Setting the Application Parameters 
1.	 Choose the Application Settings option from the Tools menu; the Application Settings 

(Preferences) dialog box is displayed with the General tab choosen.

2.	 In the General tab, select the check boxes as represented in Figure 2-29.

Figure 2-29  The application settings in the General tab of the Application Settings 
(Preferences) dialog box
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3.	 Set the Automatic backup timing (minutes) spinner to 10. Also, ensure that the UNITED_
STATES option is selected in the Default Region drop-down list.

4.	 Choose the Data Entry tab and specify the values for the parameter as given below:

Row height for data spreadsheets:	 	 23
Decimal places for data entry fields:	 3

5.	 Ensure that the Lock isolated ROTATIONAL instabilities without notification?, Warn if 
total reaction does not equal total load?, and Always warn before clearing results? check 
boxes are selected in the Solution and Results tab.

6.	 Enter 21 in the Row height for Results Browsers edit box, or you can use the spinners to 
set the value. Ensure that 3 is specified as the value in the Decimal Places edit box. 

7.	 Select the Batch results displayed by COMBINATION radio button. Ensure that the Ask 
before saving results with input data radio button is selected in the Saving Results (Static 
AND Dynamic) area. 

8.	 Choose the Select Spreadsheet Font button from the Fonts tab; the Font dialog box is 
displayed. In this dialog box, choose the Arial font option from the Font area, Regular in 
the Font style area, and 12 in the Size area, as shown in Figure 2-30. Choose the OK button 
to close the Font dialog box.

9.	 Choose the Select Printed Report Font button from the Font tab; the Font dialog box is 
displayed.

10.	 Specify the same settings as in step 8, refer to Figure 2-30 and then choose the OK button; 
the Font dialog box is closed.

11	 Next, in the Application Settings (Preferences) dialog box, choose Apply and then OK 
buttons to save the changes and close the Font dialog box.

Figure 2-30  Specifying the fonts settings in the Font dialog box
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Setting the Units
1.	 Choose the Units menu; the Units Selection dialog box is displayed.

2.	 Choose the Standard Metric button; all the units are converted into standard metric 
format, refer to Figure 2-31.

3.	 Select the kg/m^2 option from the drop-down list in the Surface/Area Loads area.

Figure 2-31 Settings units in the Units Selection dialog box

4.	 Ensure that the Convert Existing Data For Any Units Changes check box is selected. Choose 
the OK button to save the changes and close the Units Selection dialog box.

Saving the Project
The project parameters set in the previous steps are the global settings of the project file. To 
save this project file, use the Save As tool.

1.	 Choose the Save option from the File menu; the Save RISA-3D Data File dialog box is 
displayed. 

 
2.	 In this dialog box, browse to the C: drive and then create a folder with the name 

RISA_Tutorial.

3.	 Open the RISA_Tutorial folder and then create a sub-folder with the name c02. Next, open 
the created folder and enter the file name as c02_concrete_tut01, refer to Figure 2-32.

4.	 Choose the Save button; the dialog box is closed and the file is saved.

Figure 2-32  The Save RISA-3D Data File dialog box
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Exiting the Project
1. 	 To exit the project, choose the Exit option from the File menu.

 

Tutorial 2					            		          	       Grids

In this tutorial, you will create and set up the project grid for the concrete project created in the 
previous tutorial by using the following parameters:                              (Expected time: 20 min)

1.	 Project Grid
	 Horizontal	 2 spans at 5 meters each
	 Vertical	 1 span at 5 meters
	
The following steps are required to complete this tutorial:

a. 	 Open the existing project.
b.	 Create the project grid.
c.	 Save the project.
d.	 Exit the project.

Opening the Existing Project 
1. 	 Start a new RISA-3D session and then choose Open from the File menu; the Open RISA-3D 

Data File dialog box is displayed.

2.	 Browse to c:\RISA_Tutorial\c02 and select the file with the name c02_concrete_tut1.r3d.

3.	 Choose the Open button; the Open RISA-3D Data File dialog box is closed and 
the (Global) Model Settings dialog box is displayed.

4.	 Choose the OK button; the (Global) Model Settings dialog box is closed.

Creating the Project Grid
1.	 Choose the Project Grid Spreadsheet button from the RISA toolbar; the Horizontal  

Project Grid Locations dialog box is displayed.

2.	 In the Z Axis tab, make sure that the Start Label value is set to 1, the Start Location value 
is set to 0, and the Label Order is set to A to Z radio button.

3.	 Enter 2@5 in the Increments edit box and choose the Generate button; the horizontal grid 
entries are generated in the Horizontal Project Grid Locations dialog box.

4.	 Similarly, in the X Axis tab, make sure that the Start Label value is set to A and the Start 
Location value is set to 0, and the Label Order is set to A to Z radio button.

5.	 Enter 1@5 in the Increments edit box and choose the Generate button; a vertical grid 
pattern is generated in the Vertical Project Grid Locations dialog box. Close the dialog box.
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6.	 View the project grid in top view by choosing the Snap to an XZ Planar View button 
from the Window toolbar. The project grid is visible, as shown in Figure 2-33.

Figure 2-33  Viewing the project grid in top view

Saving the Project
1.	 Choose the Save As option from the File menu; the Save RISA-3D Data File dialog box is 

displayed.
 
2.	 In this dialog box, browse to the following location:

		  C:\RISA_Tutorial\c02

3.	 In the File name edit box, enter c02_concrete_tut02.

4.	 Choose the Save button; the file is saved with the name c02_concrete_tut02.r3d at the specified 
location.

Exiting the Project
1. 	 To exit the project, choose the Exit option from the File menu.

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following options is used to move elements of the given model simply by 
moving a grid line?

		  a) Drawing grid					    b) Project grid
		  c) Both the drawing and project grids	 	 d) None

2.	 Which of the following toolbars helps you to select and unselect items in the given model?

		  a) RISA toolbar				   b) Window toolbar
		  c) Selection toolbar			   d) Drawing toolbar	
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3.	 In RISA-3D, the __________ toolbar can be customized.

4.	 The use of the __________ grid is limited to the model plan.

5.	 In a RISA-3D session, you can open only one structural project at a time. (T/F)

6.	 In RISA-3D, you cannot change the font styles used in the spreadsheets. (T/F)

7.	 You can customize the RISA toolbar by double-clicking on the toolbar. (T/F)

8.	 A project file can be opened by double-clicking on the file name in the Windows Explorer. 
(T/F)

Review Questions
Answer the following questions:

1.	 Which of the following file formats can be imported as grid in RISA-3D?

		  a) *.dwg				    b) *.dxf
		  c) *.r3d					    d) None 	

2.	 The __________ dialog box is displayed when a RISA-3D session is initiated.

3.	 You can modify the project unit settings anytime during a project. (T/F)

4.	 The name and path of a project file should be specified each time you save the project. (T/F)

5.	 If you choose the Exit button without saving the changes made in a project file, RISA-3D 
will prompt you to save the changes before getting closed. (T/F).

EXERCISE
Exercise 1			                        

In this exercise, you will create a new project file specifying the following parameters. Figure 2-34 
shows the project grid in top view.				         (Expected time: 20 min)

Figure 2-34  Project grid in top view
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1.	 Model Settings :
		  Model Title	 Steel Roof Truss
		  Company	 CADCIM Technologies
2.	 Units System : 	 Standard Metric 
3.	 Project grid	: 
		  X-axis		  2@2.5, 1@6, and 2@2.5.
		  Z-axis 		  1@8.
4.	 File name to be assigned: c02_steel_ex1.r3d

Answers to Self-Evaluation Test
1. b, 2. c, 3. Window, 4. Project, 5. T, 6. F, 7. F, 8. T
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