
Chapter 2

Starting an 
Architectural Project 

Learning Objectives
After completing this chapter, you will be able to:
• Start a new architectural project
• Set units of various measurement parameters of a project
• Understand the concept of snaps, dimensions, and object snaps
• Save a project
• Modify parameters and settings of a project
• Close a project and exit Revit 2018
• Open an existing project
• Explore the building model using viewing tools
• Use the navigation tools
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INTRODUCTION
In Revit, you can work on structural, architectural, and MEP (Mechanical, Electrical and 
Plumbing) projects on a single platform. The chapters in this textbook are specially written for 
professionals in architectural and space design field. In this chapter, you will learn about the 
tools and the processes involved in starting up a new architectural project

STARTING A NEW ARCHITECTURAL PROJECT             
Shortcut Key:	       CTRL+N
File menu:  New > Project 

						       

In Revit, a project is considered as a single database that contains all information related to 
building design. Starting from geometry to construction data, each project file contains complete 
information of the building design. In a building design, the three dimensional models drawn 
using this software are called BIM (Building Information Model). BIM is a process involving 
the generation and management of digital representation of physical and functional features 
of different infastructure elements.
                                                                               
To start an architectural project, choose New > Project from the File menu, as shown in 
Figure 2-1. On doing so, the New Project dialog box will be displayed, as shown in Figure 2-2. 
Using this dialog box, select an existing .rte template file format that can be used in the new 
project.

Figure 2-1  Choosing the Project option
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Figure 2-2  The  New Project dialog box

                       

A template file can be defined as a template which has various project parameters such as units 
and views, already saved in it. On using the template file, the new project file will adopt the 
same parameters as the template file. The difference between a template file and a project file 
is that the template file has a .rte extension, whereas the project file has a .rvt extension. You 
can either select any of the template files provided in Revit or create your own file. Any project 
file can be saved as a template file.

In the New Project dialog box, select the desired template file from the drop-down list in 
the Template file area. By default, the Construction Template option is selected. To select a 
different template file which is not available in the drop-down list, choose the Browse button. 
On doing so, the Choose Template dialog box will be displayed. In this dialog box, browse to 
the US Imperial or US Metric folder, select a template file, and then choose the Open button; 
the selected template file will be added to the drop-down list in the Template file area.

In the Create new area of the New Project dialog box, two radio buttons will be displayed: 
Project and Project template. The Project radio button is selected by default. As a result, you 
will work on a new project. Alternatively, if you select the Project template radio button, you 
will work on a new project template.

Note
If you select the None option from the drop-down list in the New Project dialog box, a new project 
file will be created without a template file but with the default settings of Revit.  

Ribbon: 	 Manage > Settings > Project Units        
Shortcut Key: 	 UN

PROJECT UNITS 				  

Units are important parameters in a project. While installing Revit, you are 
prompted to set the default unit as Imperial (feet and inches) or Metric (meter). 

The default selection of units helps you open project with the specified/selected unit system. 
However, you can change the default unit set system. To set units, choose the Project Units tool 
from the Settings panel of the Manage tab; the Project Units dialog box will be displayed, as 
shown in Figure 2-3. Project units are grouped into six disciplines: Common, Structural, HVAC, 
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Electrical, Piping, and Energy. Each discipline has a set of measurement parameters. You can 
select any of these disciplines from the Discipline drop-down list of this dialog box. In this 
drop-down list, the Common option is selected by default. As a result, various measurement 
parameters such as Length, Area, Volume, Angle, Slope, Currency, and Mass Density will be 
displayed in the Project Units dialog box. The Format column in the dialog box displays the 
current unit format for the corresponding parameter. You can preview and select the possible 
digit grouping and decimal separators from the Decimal symbol/digit grouping drop-down 
list located at the lower left corner of the dialog box, refer to Figure 2-3. The options for settings 
various measurement units are discussed next. 

Figure 2-3  The Project Units dialog box

Length Unit
To assign a unit for measuring the lengths of building elements in your project, click on the 
Format column corresponding to the Length parameter; the Format dialog box will be displayed, 
as shown in Figure 2-4. This dialog box displays different units of length and their settings. You 
can select the desired unit from the Units drop-down list in the dialog box. After selecting the 
desired unit, you can specify the rounding value for the selected unit. To do so, select the desired 
option from the Rounding drop-down list in the Format dialog box. Note that by default, the 
Rounding increment edit box in the Format dialog box is inactive. To make it active, select 
the Decimal feet or Decimal inches option from the Units drop-down list and then select the 
Custom option from the Rounding drop-down list. The default value in the Rounding increment 
edit box is 1. You can change this value by entering a value in this edit box. Similarly, the Unit 
symbol drop-down list will be inactive for the Feet and fractional inches, Fractional inches, and 
Meters and Centimeters options of the Units drop-down list. From the Unit symbol drop-down 
list, you can select the measurement symbol that will be added to the unit of length. For example, 
you can select ‘m’ as the measurement symbol after all metric length measurement. In case, 
you select Feet and fractional inches from the Units drop-down list in the Format dialog box, 
then you need to select the Suppress spaces check box to remove spaces in the dash when a 
length string is expressed in feet and fractional inches to denote a particular measurement.
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Tip  
While selecting a rounding value from the Rounding drop-down list in the Format dialog 
box, you should consider the extent of detailing that may be required for the project. For projects 
that require too much detailing, a lower rounding value may be set. This parameter, however, 
can be modified at any stage during the project development.

Figure 2-4  The Format dialog box

Area Unit 
To assign a unit for measuring the areas of building elements, click on the Format column 
for the Area parameter; the Format dialog box will be displayed. In this dialog box, you can 
set the unit for measuring an area by selecting an option from the Units drop-down list. This 
drop-down list contains various options such as Square feet, Square meters, acres, and so on. 
By default, the Square feet option is selected in this drop-down list. The settings for rounding, 
rounding increment, and units can be done by selecting the desired option from the respective 
drop-down list and edit boxes.

Volume Unit
The units for volume can be set similar to that of the length and area. You can set the unit for 
the volume measurement by selecting any of the options from the Units drop-down list in the 
Format dialog box of the Volume parameter. 

Angle Unit
The units for angle can be set by using the Units drop-down list in the Format dialog box of 
the Angle parameter. 

Slope Unit
To specify the unit for the slope measurement, click in the Format column for the Slope 
parameter; the Format dialog box will be displayed. In this dialog box, you can specify the 
desired unit settings by selecting the required option from the Units drop-down list. The default 
option for the Imperial unit setting in the drop-down list is Rise /12”.
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Currency Unit
The currency unit is used to set the unit of currency for its usage in the cost and estimation 
schedules. To set the unit of currency, invoke the Project Units dialog box and then choose the 
button displayed in the Format column corresponding to the Currency parameter; the Format 
dialog box will be displayed. From this dialog box, you can select the required type of currency 
symbol from the Unit symbol drop-down list.

Mass Density Unit
The mass density of building elements is required for structural analysis. In Revit, you can 
assign a unit for measuring mass density. To assign the unit of mass density, invoke the Project 
Units dialog box. In the Format column of this dialog box, choose the button corresponding 
to the Mass Density parameter; the Format dialog box will be displayed. In this dialog box, 
you can select different units from the Units drop-down list. Also, you can assign a unit symbol 
for the selected unit. To do so, click on the Unit symbol drop-down list and then select any of 
the options displayed.

Tip
 As soon as you change the units and choose the OK button to close the Format dialog box, the 
numbers and units shown for each measurement parameter in the Project Units dialog box 
are modified to the new settings. You can modify these settings and format them as per your  
requirement.

Note
You can format the display of units represented on the screen using the Project Units dialog box. 
The actual values for these units in the project may be different. For example, if you set the wall 
length rounding to the nearest 1’, the wall may show this rounded value, but the actual length of 
the wall might be in fractional feet.

SNAPS TOOL
Ribbon:		 Manage > Settings > Snaps

The Snaps tool is one of the most productive tools available while creating and 
editing elements in a building model. This tool represents the ability of the cursor to 
snap or jump to the preset increments or specific object properties of various elements 
such as endpoint, midpoint, and so on. Invoke the Snaps tool from the Settings panel 

of the Manage tab; the Snaps dialog box will be displayed, as shown in Figure 2-5. This dialog 
box has three areas: Dimension Snaps, Object Snaps, and Temporary Overrides. These areas 
are discussed next.

Note
The settings in the Snaps dialog box are applied to all the projects opened in the session but are 
saved in the project you are working on.
 

Tip  
The values that you will enter for dimension snapping should be set based on the scale and 
the amount of detailing required for the project. You may set smaller increments for working 
on a detail or a small portion of a building.
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Figure 2-5  The Snaps dialog box

              

Dimension Snaps Area
In this area, you can set increments for placing elements or components in a project view. You can 
set increments for the length and angle dimensions. To set the increment of length dimension, 
select the Length dimension snap increments check box, if it is not selected by default, and 
then enter the increment values in the edit box below it. The default values entered in this edit 
box are: 4’; 0’6”;0’1”; 0’1/4”; for Imperial (1000 ; 100 ; 20 ; 5 ; for Metric). Note that every 
incremental value is separated by a semicolon (;). You can also set increments by typing the 
values separated by a semicolon. For example, to create an interior layout plan in which the 
length of the partitions is in 5’(1524 mm) modules, counter top width is 2’(609.6 mm), and the 
thickness of partitions is 4”(101.6 mm), you can enter the values for the dimension snaps as 5’; 
2’;4” for Imperial (1524; 609.6;101.6 for Metric). This will enable the cursor to move in these 
increments and help create the layout with relative ease.

In the Dimension Snaps area, snap increments for angular dimensions can be set by selecting 
the Angular dimension snap increments check box and then entering suitable values in the 
edit box below this check box. This setting is quite useful for projects that have radial geometry.
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Tip  
The Snaps tool is frequently used not only while creating various building elements but 
also while editing and placing them. By efficiently using this feature, you can improve the 
performance and accuracy of your project besides making modeling much simpler.

Object Snaps Area
In the Object Snaps area, you can specify various object snaps for using them in a project. 
Object snapping refers to the cursor’s ability to snap to geometric points on an element such 
as endpoints, midpoint, perpendicular, and so on. It is useful for creating and editing elements. 
The advantage of using object snapping is that you can locate the appropriate point on a drawing 
object. When enabled, the appropriate object snap is displayed as soon as the cursor is near 
to an element. For example, it is virtually impossible to pick the exact endpoint to start a wall 
from an endpoint of an already drawn wall. But when you enable the Endpoints object snap, 
the cursor automatically jumps or snaps to the endpoint of this wall. This helps to start the 
new wall from the endpoint. This, besides making the drawing accurate, later helps in adding 
dimensions to the project.

Note
The object snapping works only with the objects that are visible on the screen. A tooltip, with the 
same name as the object snap, is also displayed when you bring the cursor close to the snap point.

Various object snaps modes available in the Object Snaps area are: Endpoints, Midpoints, 
Nearest, Work Plane Grid, Quadrants, Intersections, Centers, Perpendicular, Tangents, 
Points, Snap to Remote Objects, and Snap to Point Clouds.

The use of each object snap corresponds to its respective name. The Work Plane Grid snap  
option enables you to snap to a point on a reference plane already defined in the model. For 
example, you can place a furniture component exactly on the floor by snapping to the floor 
level reference plane. You can snap to the object that is closest to the cursor using the Snap to 
Remote Objects option. You can also snap points of a point cloud data object by selecting the 
Snap to Point Clouds check box. Each object snap mode has a geometrical shaped marker to 
identify it from the other object snaps. For example, the endpoint object snap is indicated by 
a square, midpoint by a triangle, nearest by a cross, and so on. To use an object snap mode, 
move the cursor over the object. You will notice a marker that appears as you move it close to 
the snap point. To select the appropriate snap point, click when the corresponding marker or 
tooltip is displayed. 

In Revit, all the enabled object snaps work simultaneously. You can turn off all the snap options 
including the dimension snaps and object snaps by clearing the Snaps Off check box located at 
the top of the Snaps dialog box. Alternatively, you can type SO on the keyboard to turn them 
off and on while using a tool. The Check All and Check None buttons can be used to enable 
or disable the object snaps, respectively.

Temporary Overrides Area
The options in the Temporary Overrides area provide you the alternative of overriding snaps 
setting for a single use only. For example, if you have not selected the Endpoints object snap 
in the Snaps dialog box and you want to use this option while working with a tool, you need 
not open the Snaps dialog box and set this option. You can instead type the shortcut, SE to 
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temporarily activate the endpoint object snap. Once you have used this object snap option, 
snapping to the endpoint is automatically turned off.

You can toggle between various object snap options available at the same location using the TAB 
key on the keyboard. Hold down the SHIFT key to create the elements vertically or horizontally. 
This restricts the movement of the cursor in the orthogonal directions only. Once you release 
the SHIFT key, the cursor resumes its movement in all directions. You can select the Snaps Off 
check box to disable all types of snapping.

SAVING A PROJECT
You must save your work before closing a project or exiting the Revit 2018 session. You have 
the option of saving the project file in a permanent storage device, which may be a hard disk 
or a removable disk. Also, you must save your work at regular intervals to avoid loss due to any 
error in the computer’s hardware or software. 

Saving the Project File
File menu: 	 Save As > Project    
Shortcut Key: 		  CTRL+S                 

To save the project file to the desired location, choose Save As > Project from the File menu; 
the Save As dialog box will be displayed, as shown in Figure 2-6. Alternatively, you can save 
the project file by choosing the Save button from the Quick Access Toolbar. In the Save As 
dialog box, the Save in drop-down list displays the current drive and path in which the project 
file will be saved. The list box below the Save in drop-down list shows all the folders available 
in the current directory. The File name edit box can be used to enter the name of the file to 
be assigned to the project. The Places List area on the left of the Save As dialog box contains 
shortcuts for the folders that are frequently used. 

Figure 2-6  The Save As dialog box
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Tip 
The selection of a large number of backup files for storing may lead to consumption of resources 
in the hard disk.  

Using the Options Button
You can use different features for saving a file by choosing the Options button from the Save 
As dialog box. On choosing this button, the File Save Options dialog box will be displayed, as 
shown in Figure 2-7. Using the Maximum backups edit box from this dialog box, you can specify 
the maximum number of backup files that you need to store for the project. In Revit, by default 
the non-workshared projects have three backup files and the workshared projects have twenty 
backup files. The options in the Thumbnail Preview area enable you to specify the image to be 
used as the preview of the project file that can be used at the time of opening a project file. You 
can specify the view of the model to be used as a preview image by selecting an option from the 
Source drop-down list. The Active view/sheet is the default option for previewing a project file. 
For example, to make the Floor Plan: Level 1 the preview image, select it from the drop-down 
list. Whenever you select this project file, the preview will always show the Floor Plan: Level 1, 
irrespective of the last active view.

Select the Regenerate if view/sheet is not up-to-date check box to see the preview with the latest 
modifications. Selecting this check box will update the preview image on closing the project file.  

Note
Revit updates the preview image continuously. Therefore, selecting the Regenerate if view/sheet 
is not up-to-date check box can consume considerable resources.

Figure 2-7  The File Save Options dialog box 

Using the Save Tool
Once the project is saved using the Save As tool, you do not need to re-enter the file parameters 
to save it again. To save a project to a location, choose the Save tool from the File menu, as shown 
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in Figure 2-8. While saving the project for the first time, the Save As dialog box is displayed, even 
if you invoke the Save tool. Alternatively, you can save your project by choosing the Save button 
from the Quick Access Toolbar. As you save your project file, Revit 2018 updates it automatically 
without prompting you to re-enter the file name and path.

Figure 2-8  Choosing the Save tool from the 
File menu    

CONFIGURING GLOBAL SETTINGS                     	                             
In Revit 2018, you can configure global settings by using the Options dialog box. This dialog box 
can be invoked by choosing the Options button from the File menu. The Options dialog box, 
as shown in Figure 2-9, contains nine tabs: General, User Interface, Graphics, File Locations, 
Rendering, Check Spelling, SteeringWheels, ViewCube, and Macros. The options in these 
tabs are discussed next.

General Tab
The General tab is chosen by default in the Options dialog box. This tab contains the following 
areas: Notifications, Username, Journal File Cleanup, Worksharing Update Frequency, and 
View Options, refer to Figure 2-9. These areas are discussed next.

Notifications Area
The Notifications area provides you the option for setting reminders to save work at regular 
intervals. In this area, you can set the time interval at which Revit will remind you to save the 
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project file. The default value for the Save reminder interval parameter is 30 minutes. You can 
specify the time interval by selecting the interval option from the drop-down list corresponding 
to the Save reminder interval parameter. If you do not want a reminder, you can select the No 
reminders option from the drop-down list. Similarly, you can set the value for the Synchronize 
with Central reminder interval parameter.

Figure 2-9  Various areas in the General tab 
Username Area 
In Revit, if you are not signed in as a user of Autodesk Account, then the system default username 
will be displayed. To enter a name in the Username area, you need to sign in to Autodesk 360. 
When you sign in, your autodesk ID will be used as a username.

Tip
If you are not logged into an Autodesk account, you can directly enter a username.

Journal File Cleanup Area
Journal files are the text files that are used to resolve technical problems that may occur during 
the Revit session and they record every step during the session. Whenever you encounter any 
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technical problem with the software, you can run this file to detect the problem as well as to 
recover the lost files or steps that had caused the problem. In Revit, these files are saved at the 
following default location: C:\Users\<Username>\AppData\Local\Autodesk\Revit\Autodesk Revit 2018\
Journals for Windows 7/8 and for Window Vista users C:\Documents and Settings\<Username>\
Local Settings\Application for Windows XP users. These files are saved each time you close the 
Revit 2018 session. As such the quantity of these files keeps on increasing until you remove these 
files from their location. To retain certain files and clean others, you can use the Journal File 
Cleanup area in the General tab of the Options dialog box. This area contains two spinners: 
When number of journals exceeds then and Delete journals older than (days). You can set 
the required values in these spinners to retain the files that are recently created. For example, 
if you need to delete journal files if their number exceeds 15, then set the value in the When 
number of journal exceeds spinner to 15 and to delete journals older than 30 days, then set 
the value in the Delete journals older than (days) spinner to 30.

Worksharing Update Frequency Area
In this area, you can set the time interval for updating the project in a worksharing environment. 
To set the update frequency for worksharing, you can set the slider between Less Frequent and 
More Frequent. 

View Options Area
In this area, you can set the default view discipline for the project. To do so, select an option 
from the Default view discipline drop-down list. The list of options available in this drop-down 
list are: Architectural, Structural, Mechanical, Electrical, Plumbing, and Coordination. 

User Interface Tab							     
The User Interface tab contains two areas: Configure and Tab Switching Behavior. You 
can specify the options for the display of Revit user interface. You can do so by selecting the 
Dark or Light option from the Active theme drop-down list in this area. To customize the 
use of shortcut keys in a project, you can choose the Customize button corresponding to the 
Keyboard Shortcuts parameter. You can also choose the Customize button corresponding to 
the Double-click Options parameter, the Customize Double-click Settings dialog box will be 
displayed, as shown in Figure 2-10. 

Figure 2-10  The Customize Double-click 
Settings dialog box
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In the Configure area of the Options dialog box, you can select an option from the Tooltip 
assistance drop-down list to set the extent of the tip that will be displayed with the cursor when 
it is close to a tool. The options in this drop-down list are None, Minimal, Normal, and High. 
By default, the None option is selected in this drop-down list. Note that the tooltip will appear 
more frequently in your drawing if you select High in the Tooltip assistance drop-down list. In 
the Configure area, the Enable Recent Files page at startup check box is selected by default. 
As a result, the recent files will be displayed on starting the Revit software. You can clear this 
check box if you do not want to display the recent files at the startup. In the Tab Switching 
Behavior area, you can specify the tab to be displayed once you clear a selection or exit a tool. 
In this area, the Project Environment drop-down list contains two options: Stay on the Modify 
tab and Return to the previous tab options. Select the Stay on the Modify tab option to display 
the options in the Modify tab after exiting a tool or clearing a selection. Alternatively, you can 
select the Return to the previous tab option to display the last used tab after exiting a tool or 
clearing a selection. In the Tab Switching Behavior area, the Display the contextual tab on 
selection check box is selected by default. As a result, the contextual tab is displayed once you 
select a tool from the Revit interface.

Tip
When you rest the cursor on the project file name, a tooltip appears which provides you the 
information regarding the type and size of the project file.

Graphics Tab
The options in the Graphics tab enable you to configure the display card of your computer 
to improve the display performance. You can also use this tab to assign colors to selections, 
highlights and alerts, and enable anti-aliasing for 3D views. In the Graphics Mode area of this 
tab, the Use Hardware Acceleration (Direct 3D) check box is selected by default. As a result, 
the hardware accelerators are enabled. Hardware accelerators help display the larger models 
faster on refreshing the views. In addition, the hardware accelerators help you speed up the 
process of switching between the windows of views. The selection of the check box will result 
in the improvement of the performance of the display while navigating a 2D view or a 3D view 
using the following methods of navigation. Using the tools in the Navigation Bar, you can 
navigate by scrolling the mouse wheel.

In the Graphics Mode area, the Smooth lines with anti-aliasing check box is selected to display 
the views as aliased. On selecting this check box, the Allow control for each view in the Graphics 
Display Options dialog and Use for all views (control for each view is disabled) options will 
be enabled. The selection of the Allow control for each view in the Graphics Display Options 
dialog check box will allow you to control the aliasing using the Graphic Display Options 
dialog box for each view. The Graphic Display Options dialog box can be invoked using the 
options in the Visual Styles menu of the Status Bar, refer to Table 2-1. On selecting the Use 
for all view (control for each view is disabled) option, you can observe the sketched lines as 
smooth lines in all views.
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Table 2-1  The list of features barred for Visual Styles 

Feature Visual Styles 

Hidden Line Shaded Consistent 
Colors

Realistic

Edges    -----------   Barred Barred Barred

Fill Patterns Barred Barred Barred Barred

Shadows Barred Barred Barred Barred

Structural 
Hidden Lines

Barred Barred Barred Barred

Mechanical 
Hidden Lines

Barred Barred Barred Barred

Note
While navigating a camera view in the Wireframe view style, the fill patterns are not displayed in 
the model.

In the Colors area of the Graphics tab, choose the button corresponding to the Background 
parameter to change the color of the background. The Selection parameter specifies a color 
that an element acquires when it is selected. The default color is RGB 000-059-189. To use 
any other color, click the button on the right of the Selection parameter to display the Color 
dialog box and then select the desired color. The Pre-selection parameter specifies the color of 
the highlighted elements. To use any other color for highlighting the element, click the button 
on the right of the Selection parameter and select the desired color from the Color dialog 
box displayed. Revit uses the Alert button to highlight elements when an error occurs. In the 
Colors area, the Semi-transparent check box is selected by default. As a result, you  can make 
the selected elements semi-transparent and you can view the elements behind the selection. 
In the Temporary Dimension Text Appearance area, you can select an option from the Size 
drop-down list to specify the size of the text to be used in temporary dimensions. In this area, 
you can set the background of the text in the temporary dimensions. To do so, select the Opaque 
or Transparent option from the Background drop-down list.

File Locations Tab
The options in the File Locations tab can be used to display the link of the default template files 
present in the project. The options in this tab can also be used to set the path for the template 
files, user files, family template files that are accessed frequently, and the root path for the point 
clouds. Figure 2-11 shows various options in this tab. 

The path for these files is set at the time of installing Revit. However, you can modify the 
location by choosing the corresponding Browse button and specifying a new path. The default 
template file location can be changed, in case you wish to use a custom made template file for 
your projects. Revit uses the default path for user files for saving or opening a project. You 
can also specify the default path for family template files and for the point clouds by using the 
corresponding Browse button.
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Figure 2-11  Options in the File Locations tab

          
Rendering Tab
The Additional Render Appearance Paths section in the Options dialog box specifies the 
path for the additional image files that defines texture, bump map, custom color for the render 
appearance which can be used in the project. These image files are not present in the software 
and therefore, you need to specify their paths to use them. To do so, choose the Add Value 
button in the Additional Render Appearance Paths area and specify the required path in the 
displayed field or choose the Browse button; the Browse for Folder dialog box will be displayed. 
In this dialog box, select the desired path and choose the Open button to add the path to the 
field. In the ArchVision Content Manager Location area of the Rendering tab, you can specify 
the location of the licensed additional RPC content from Archvision. In this area, the Network 
radio button is selected by default. As a result, you can provide the address of the licensed 
Archvision content in a network so that more than one user can access the content. To provide 
the network location of the RPC content, you can specify the IP address or the machine name in 
the Address edit box. Also, you can specify the port used by the Archvision Content Manger in 
the edit box next to the Address edit box. By default, the value entered in the edit box for the 
port is 14931. Alternatively, you can select the Local radio button in the ArchVision Content 
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Manager Location area of the Rendering tab, if the additional RPC content is available in the 
local drive of the computer. On selecting the Local radio button, you can specify the location of 
the local ACM executable file (rcpACMapp.exe) in the Executable Location edit box. To browse 
to the local ACM executable file, you can choose the Browse button; the Browse for Template 
File dialog box will be displayed. Select the desired executable file and then choose the Open 
button; the path of the file will be added and displayed in the Executable Location edit box. In 
the Archvision Content Manager area, you can choose the Get More RPC button to connect to 
http://www.archvision.com page and get additional RPC required for the project.

Check Spelling Tab 
This tab provides you with the option to run spell check in the text and then rectify the errors. 
You can choose the Check Spelling from the Options dialog box to display its options. Various 
self-explanatory settings can be selected from the Settings list. You can choose the Restore 
Defaults button available below the Settings list to revert back to the default settings. In the Main 
Dictionary area of this tab, you can select the type of dictionary to be used as main dictionary 
for the spelling check from the Autodesk Revit drop-down list. Apart from the main dictionary, 
you can also use additional dictionaries such as the personal and building industry dictionaries. 
This facilitates the use of various personal and industry related terms in the text matter of the 
project. There are many words that are not included in the main dictionaries but are frequently 
used in the building industry. For example, the abbreviation for architecture ‘archi’ is not available 
in the main dictionaries. The additional building industry dictionary has many such words and 
abbreviations that can be used in the text matter of the project without being prompted for errors 
while checking spellings. You can also add or remove words from your personal and building 
industry dictionary. Choose any of the Edit buttons available in the Additional Dictionaries area 
to view the list of words. You can enter or remove any word from these lists using the cursor 
and keyboard. To run spell check in your drawing, choose the Check Spelling tool from 
the Text panel in the Annotate tab; the Check Spelling dialog box will be displayed, as 
shown in Figure 2-12, wherein you can rectify the spelling errors in the text by selecting the 
correct spelling and then choosing the Change button in the dialog box, refer to Figure 2-12. 
Alternatively, you can press the F7 key to display the Check Spelling dialog box, refer to 
Figure 2-12, and then make necessary corrections in the text.

Figure 2-12  The Check Spelling dialog box 
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SteeringWheels Tab
The options in the SteeringWheels tab in the Options dialog box are used to control the 
visibility, appearance, and operational tools of different types of SteeringWheels. This tab has 
seven different areas of control to use the SteeringWheels, as shown in Figure 2-13. These areas 
are discussed next. 

Figure 2-13  The SteeringWheels tab of the Options dialog box

Text Visibility Area
You can control the display of tool messages, tooltips, and tool cursor of the SteeringWheels. 
You can do so by using the options in the Text Visibility area of the SteeringWheels tab. In this 
area, the Show tool messages check box is selected by default. As a result, the visibility of tool 
messages in the SteeringWheels is enabled. To display the tooltips along with the SteeringWheels, 
select the Show tooltips check box in this area. Similarly, to control the display of the cursor text 
when a tool is active, use the Show tool cursor text check box. Select this check box to display the 
cursor text when the tool is active. 

Big Steering Wheel Appearance and Mini Wheel Appearance Areas
To set the size of the SteeringWheels, select the required option from the Size drop-down list 
in the corresponding areas and set its size to small, normal, or large. Similarly, you can set 
the transparency of the SteeringWheels by selecting the required option from the Opacity 
drop-down list.



Starting an Architectural Project	                                   2-19 

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Look Tool Behavior and Walk Tool Areas
In the Look Tool Behavior area of the SteeringWheels tab, select the Invert vertical axis check 
box to change the movement of the view along the vertical axis while using the Look tool. Note 
that on selecting the check box, the view will move in the same direction as that of the cursor. 
In the Walk Tool area of the SteeringWheels tab, use the Speed Factor slider to change the 
speed of the walk while using the Walk tool of the SteeringWheels. Select the Move parallel to 
ground plane check box, if it is not selected by default, to constrain the walk movement angle 
to ground plane.

Zoom Tool and Orbit Tool Areas
Select the Zoom in one increment with each mouse click check box in the Zoom Tool area to 
enable the zooming operation with a single click. In the Orbit Tool area, ensure that the Keep 
scene upright check box is selected. This helps maintaining the perpendicularity between the 
sides of the model and the ground plane while using the Orbit tool. 

ViewCube Tab  
The options in the ViewCube tab in the Options dialog box are used to edit various settings 
of the ViewCube. It has four different areas to modify the ViewCube: ViewCube Appearance, 
When Dragging the ViewCube, When Clicking on the ViewCube, and Compass, as shown in 
Figure 2-14. These areas are discussed next.

         

Figure 2-14  The ViewCube tab of the Options dialog box
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ViewCube Appearance Area 
The appearance and display of the ViewCube can be controlled by the ViewCube Appearance 
area in the ViewCube tab.

In the ViewCube Appearance area, the Show the ViewCube check box is selected by default, 
so the ViewCube will be visible. If you clear this check box, the ViewCube will disappear and all 
options of the ViewCube in the ViewCube Appearance area will be deactivated.

In the ViewCube Appearance area, you can use various drop-down lists to align, resize, 
and change the transparency of the ViewCube. You can select an option from the Show in 
drop-down list to specify whether the ViewCube will be displayed in all 3D views or only in 
the active view. The On-screen position drop-down list is used to position the ViewCube on 
the screen. Similarly, you can resize the ViewCube by selecting the required option from the 
ViewCube size drop-down list. You can also set the opacity of the inactive ViewCube by selecting 
various options from the Inactive opacity drop-down list.

When Dragging the ViewCube Area  
In this area, the Snap to closest view check box is selected by default. As a result, the closest 
ViewCube view orientation will be snapped.

When Clicking on the ViewCube Area
Select the Fit-to-view on view change check box in the When Clicking on the ViewCube area to 
fit the view on screen while changing the viewing direction. The Use animated transition when 
switching views check box is selected by default in this area. As a result the view will change 
with animation. Clearing this check box will result in the change of view without any animation. 
Select the Keep scene upright check box to keep the sides of the ViewCube and the sides of the 
view perpendicular to the ground plane. Clear the check box to turn around the model in full 
360-degree swing. Clearing this check box can be useful when you are editing a family.

Compass Area
The Show the compass with the ViewCube check box in the Compass area is selected by default. 
As a result, the compass along with the ViewCube will be visible in the drawing. 

In the ViewCube tab, you can choose the Restore Defaults button to restore the default settings 
that were changed in its different areas.

Macros Tab
The options in the Macros tab can be used to set the security level for the Macros used in the 
project. The options in this tab are available in two areas: Application Macro Security Settings 
and Document Macro Security Settings. The various options in these areas are discussed 
next.

Application Macro Security Settings Area
In this area, the Enable application macros radio button is selected by default. As a result, the 
application macros in the project are enabled. To disable the application macros, select the 
Disable application macros radio button. 
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Document Macro Security Settings Area
In this area, the Ask before enabling document macros radio button  is selected by default.  As 
a result, the document macros are disabled, but you will be prompted to enable them whenever 
you open a project that contains a macro. To enable the document macros, select the Enable 
document macros radio button. Similarly, to disable a document macros in the project, select 
the Disable document macros radio button. 
 

Tip
If you disable the macros by selecting the Disable application macros radio button in the 
Macros tab of the Options dialog box, you will still be able to modify the code, although the 
modifications in the code will not change the current status of the macros.

 

CLOSING A PROJECT					   
To close a project, choose the Close option from the File menu displayed, 

Fi g u r e  2 - 1 5  
C h o o s i n g  t h e 
Close option 

as shown in Figure 2-15. If you have already saved the latest changes, 
the project file will be closed. Otherwise, Revit will prompt you to save 
the changes through the Save File confirmation box. You can save the 
changes by choosing the Yes button or discard them by choosing the 
No button. You can also choose the Cancel button to return to the 
interface and continue working on the project file. You can also use the 
Close button (X) in the drawing window to close the project.

EXITING REVIT
To exit the Autodesk Revit session, choose the Exit Revit button from 
the File menu. Even if the project is open, you can still choose the Exit 
Revit button to close the file and exit Revit 2018. In case, the project 
has not been saved, it enables you to save the work through the Save 
File message box, as shown in Figure 2-16. If you choose the No button, 
all the changes that were not saved will be lost. You can also use the 
Close button (X) in the main Revit window (in the title bar) to end the 
Revit 2018 session.
                                 

Figure 2-16 The Save File message box

                                                                

OPENING AN EXISTING PROJECT
To open an existing project, you can use various options, such as the Open tool or the Windows 
explorer. These options are discussed in detail in the next section.

Opening an Existing Project Using the Open Tool     
To open an existing project file, choose Open > Project from the File menu, as 
shown in Figure 2-17. Alternatively, you can open a project by choosing the Open 
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button from the Quick Access Toolbar or by pressing CTRL+O. On doing so, the Open dialog 
box will be displayed, as shown in Figure 2-18. In this dialog box, you can open a particular 
project file by accessing the appropriate folder using the Look in drop-down list.  

Figure 2-17  Choosing the Project option from the File menu

Figure 2-18  The Open dialog box 



Starting an Architectural Project	                                   2-23 

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Tip
The Preview image acts as a thumbnail to identify a project file. You must select the view that 
will help you identify the project file easily. 

The Preview area of the Open dialog box shows the preview of the selected project file. It helps 
you select a particular file by viewing its contents, even if you are not sure about the file name. 
The window icons such as the Views menu placed along with the Look in drop-down list, help 
you select a project file based on its size, type, and the date when it was last saved. On choosing 
the Thumbnails option from the Views menu, you can preview the contents of the project files 
inside the selected folder in the file list area, refer to Figure 2-19. 
          

Figure 2-19  Previewing the files in the Open dialog box 

                     

The Places list is located on the left in the Open dialog box. You can add or remove folders from 
the Places list by choosing the Options button from the File menu. On doing so, the Options 
dialog box will be displayed. Choose the File Locations tab from the dialog box, and then choose 
the Places button from it; the Places dialog box will be displayed, as shown in Figure 2-20.

           
The Places dialog box contains two columns: Library Name and Library Path. You can add 
or remove folders in the libraries list to create a list of frequently accessed folders. The four 
buttons on the left in the Places dialog box can be used to create or delete a library, or move 
it up and down in the list. To create a new library, choose the Add Value button which is third 
button from the top; a new library will be added to the defined path. By default, the name of 
the new library in the Library Name section will be NewLibrary2. Change the name of the 
new library and then click in the Library Path column to display the browse button. Choose the 
browse button and select the folder to be added in the libraries list using the Browse For Folder 
dialog box. Choose the Open button after selecting the folder; the new folder gets added to the 
list. If required, choose the upward arrow button in the Places dialog box to move the folder 
up to the top of the list.
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Figure 2-20  The Places dialog box

               

Similarly, you can choose the down arrow button to move it down. To delete any library, select 
the library and choose the Remove Value button. Choose the OK button in the Places dialog 
box to exit, and then close the Options dialog box. When you invoke the Open tool next time, 
the new folder icon will be displayed in the places list. 

Once the file to be opened has been selected, its name will be displayed in the File Name edit 
box of the Open dialog box and its preview will be displayed in the Preview area.

Note
If you try opening an already opened file, which has been modified in the Revit session, a message 
box appears, prompting you to close the file first and reopen it. In case you open a file that has been 
created using an older version of Revit, the Program Upgrade message box will be displayed. It 
mentions that the file is being upgraded to the latest file format and that this is a onetime process. 
Once the file is opened, it gets upgraded to Revit 2018 version.

Tip
The names of the recently opened files are displayed in the File menu. On starting Revit, you 
can click on the name of the project file that you wish to open.

Using the Windows Explorer to Open an Existing Project
Apart from using the Open tool from the Revit interface, you can also open files directly from 
the Windows Explorer by using the methods discussed next.

A file can be opened by double-clicking on its icon in the Windows Explorer. It opens the 
project file in the latest Revit session. If Revit is not running, double-click on the file icon to 
start Revit and then open the file. Another method of opening a project file is by dragging the 
project file icon from the Windows Explorer and dropping it into the drawing window of the 



Starting an Architectural Project	                                   2-25 

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Revit interface. You can also select, drag, and drop more than one file in the drawing window. 
In this case, Revit prompts you to open the files in separate windows. Choose the OK button to 
open all the files in the same Revit session.

Tip
By default, the preview of a file is the last active view or sheet at the time it was last saved. You 
can set the preview to a particular view by using the Options button in the Save As dialog box. 

MODEL DISPLAY TOOLS
As described earlier, in Revit, you can create the building model using the 3D parametric elements. 
Various tools are provided to view the building model. Based on the requirement, you can use 
these tools to navigate and edit elements in the building model.

Using the Zoom Tools
The Zoom tools are used to enlarge or reduce a project view in the viewing area. To use these 
tools, you need to display the Navigation Bar in your drawing. Generally, the Navigation Bar 
is displayed by default. If it is not displayed, click on the down arrow on the User Interface 
drop-down in the Windows panel of the View tab; a drop-down list will be displayed, as shown 
in Figure 2-21. From the drop-down list, select the Navigation Bar check box if it is not selected; 
the Navigation Bar will be displayed in the viewing area. In the Navigation Bar, click on the 
down arrow below the Zoom All to Fit tool; a cascading menu will be displayed, as shown in 
Figure 2-22. This cascading menu displays different zooming options which are discussed next. 

Figure 2-21  A drop-down list displayed on 
clicking the User Interface drop-down

Figure 2-22  Different zooming options in 
the cascading menu

Zoom In Region
This tool is used to zoom in a specified area or window. When you invoke the Zoom In Region tool 
from the Navigation Bar, the cursor is replaced by a magnifying glass. To zoom into an area, 
you need to define a rectangular window by picking its diagonally opposite corners. You can 
click at a point to specify the start point of the window. When you move the cursor, a dynamic 
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rectangular window is created whose one corner is the specified point and the other corner is 
attached to the cursor. Move the cursor across the area you want to enlarge. When the area is 
enclosed in the rectangle, click to specify the diagonally opposite corners of the zoom window. The 
specified portion of the current view is enlarged. For example, to work on the stairs of a building 
plan, you can invoke the Zoom In Region tool and click to specify the two opposite corners of 
the window, as shown in Figure 2-23. The resulting enlarged view is shown in Figure 2-24.

Figure 2-24  The resulting enlarged viewFigure 2-23  Specifying the corners 
of the zoom window

Start 
point

Endpoint

Zoom Out(2X)m 
This tool is used to zoom out of the existing view by twice the size of the current view. This 
means, when you invoke this tool, the new view will show twice the length and width of the 
original view.

Zoom to Fit and Zoom All to Fit
The Zoom To Fit tool is used to display all the contents of the project in the current view. On 
invoking this tool, the drawing window will adjust to show all the elements that have been 
created in a view. If there are multiple windows open with different zoom factors, invoke the 
Zoom All to Fit tool to perform Zoom to Fit in all the windows.

Zoom Sheet Size
The Zoom Sheet Size tool is used to fit the drawings in the default sheet size displayed in the 
Paper tab of the printer’s PDF Report Writer’s Properties dialog box. This dialog box will be 
displayed on choosing the Properties button in the Print dialog box. To invoke the Print dialog 
box, choose the Print option from the File menu or enter a shortcut key CTRL+P.

Previous Pan/Zoom and Next Pan/Zoom 
The Previous Pan/Zoom tool reverts back to the last displayed view using zoom or pan, whereas 
the Next Pan/Zoom tool is a toggle tool to show the next displayed view. 
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Using the Orient Options
In Revit, you can view a building model in 3D from the preset viewpoints using the Orient options.

To use the Orient options, activate the 3D view by choosing the Default 3D View tool from 
View > Create > 3D View drop-down. Alternatively, you can activate the 3D view by double-
clicking on {3D} under the 3D Views head in the Project Browser. On doing so, the current 
view will orient to the default 3D view along with the ViewCube displayed at the upper-right 
corner of the drawing area. Now, place the cursor over the ViewCube and right-click; a shortcut 
menu will be displayed, as shown in Figure 2-25. Now, in the shortcut menu, click on the Orient 
to a Direction option; a cascading menu will be displayed, as shown in Figure 2-26. From this 
cascading menu, select the appropriate view that will be displayed in the drawing window.

Figure 2-26  Options in the cascading menu of 
the Orient to a Direction option

Figure 2-25  Options in the shortcut 
menu of the ViewCube

Navigation Tools
Navigation tools in Revit help you navigate and maneuver into your model in different directions 
and views. The two navigation tools, SteeringWheels and ViewCube, are discussed next.

ViewCube
The ViewCube tool is an interactive 3D navigation tool that appears in all 3D views of a Revit 
project. By default, the ViewCube tool is visible at the top right corner of your drawing area.

The ViewCube navigation tool comprises of a cube, a compass ring at the base with various 
directions marked on it, and a home icon that helps you set the default view, as shown in 
Figure 2-27. The ViewCube navigation tool is displayed in your drawing area either in an active 
or an inactive state, as shown in Figures 2-28 and 2-29. By default, the ViewCube is in its inactive 
state and it appears partially transparent over your drawing area. Therefore it prevents the 
obstruction of the view of your model. Whereas, in its active state, the ViewCube appears opaque 
and distinct and obstructs the view of your model. You can change the size, on-screen placement, 
visibility of the compass, and the inactive opacity of the ViewCube as per your requirement. 
To do so, choose the ViewCube tab from the Options dialog box as discussed earlier. In the 
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ViewCube tool, there are twenty-six defined areas comprising faces, edges, and corners. The 
twenty-six defined areas can be divided into three categories; corner, edge, and face, as shown in 
Figure 2-30. Out of the twenty-six defined areas, six areas represent the standard orthographic 
views of a model such as top, bottom, front, back, left, and right. The standard orthographic 
views are set by clicking on one of the faces on the ViewCube. The other twenty areas are defined 
to access the angular views of a model.

Figure 2-28 The ViewCube in active stateFigure 2-27  The ViewCube and its components

Figure 2-29 The ViewCube in the inactive 
state 

Figure 2-30  Different areas on the ViewCube

When you move the cursor on the faces, edges, or vertices of an active ViewCube, the 
corresponding area gets highlighted in dark-gray color. These highlighted regions are called 
hotspots. While using the ViewCube, you can click on these hotspots to orient your view as per 
your requirement.

Tip
You can link the Navigation Bar to the ViewCube. To do so, choose the Customize button 
located at the bottom of the Navigation Bar; a flyout will be displayed. Choose the Docking 
positions option in the flyout; a cascading menu will be displayed. From the cascading menu, 
choose the Link to ViewCube option; the Navigation Bar will get linked to the ViewCube 
displayed.

SteeringWheels  
The SteeringWheels navigation tools are tracking menus that comprise of multiple navigation 
features in a single interface. Using the features in these tools, you can pan, zoom, walk, look, 
and adjust the view of your model as per your requirement. The SteeringWheels tool is divided 
into different sections known as wedges. Each wedge represents a unique function for navigation.
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To activate the SteeringWheels navigation tool in your model, press the F8 key. The 
SteeringWheels tool will appear according to the state of view in which you are working. If you 
are currently working in a 2D view, you can use the 2D SteeringWheels tool. Similarly, you can 
use the 3D SteeringWheels tool when you are working in the 3D view.

In Revit, you can access various types of SteeringWheels from the Navigation Bar. In the 
Navigation Bar, click on the down arrow below the default Full Navigation Wheel tool; a 
shortcut menu with various types of Steering Wheels will be displayed, as shown in Figure 2-31. 
To navigate the 2D view, you can use the 2D navigation wheel, as shown in Figure 2-32. The 
2D navigation wheel has three navigation tools, Zoom, Pan, and Rewind. Zoom is a common 
navigation tool for enlarging or reducing the viewing scale of the model. You can use the Pan 
tool for traversing across the model view. The Rewind tool can be used to see the views of 
the previous zooming states which are saved temporarily.

Figure 2-32  The 2D Steering Wheels 
navigation tool

Figure 2-31  Shortcut menu displaying 
various types of SteeringWheels

The 3D SteeringWheels navigation tools help you navigate through your 3D views. Based on the 
size and appearance, the 3D SteeringWheels is categorized into two groups, Mini Steering Wheels 
and Big SteeringWheels. 

The Mini SteeringWheels are classified into three types, Mini Tour Building Wheel, Mini 
View Object Wheel, and Mini Full Navigation Wheel, as shown in Figure 2-33. The Mini View 
Object Wheel has four distinct navigation tools, Pan, Zoom, Rewind, and Orbit. Similarly, the 
Mini Tour Building Wheel comprises of four unique navigation options,Up/Down, Look, Walk, 
and Rewind. The Full Navigation Wheel comprises of eight wedges with each wedge defining 
a unique navigation function. The Mini Full Navigation Wheel combines all the functions of 
the Mini View Object Wheel and the Mini Tour Building Wheel. The Big SteeringWheels 
has similar classification as that of the Mini SteeringWheels, as shown in Figure 2-34, and it 
has same navigation tools as that in the Mini SteeringWheels with the only difference in their 
appearances on screen.
       
As you put your cursor over any of the navigation tools, the tooltips and messages are displayed, 
as shown in Figure 2-35. The tooltips inform you regarding the tool that you want to use and 
provide instruction for using it. You can control the visibility of the tooltips and the tool messages 
while using the SteeringWheels by using the Options dialog box, as discussed earlier in this 
chapter.  
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While using the SteeringWheels navigation tool, you can activate the available navigation tools 
by clicking and holding the left mouse button over any one of the wedges. After holding the left 
mouse button and dragging it over the drawing area, you can use the selected navigation tool for 
reorienting your view. Now, to exit the selected navigation tool, release the left mouse button.

       

Figure 2-33  Types of Mini SteeringWheels for 3D Views

Figure 2-34  Appearance of Big SteeringWheels 

Figure 2-35  Appearance of the tooltip displayed with the 
SteeringWheels

                          



Starting an Architectural Project	                                   2-31 

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Other Display Options 
Revit provides five options to view the building model in different modes of shading. You can 
select these options by choosing the Visual Style button from the View Control Bar and then 
selecting the desired option from the shortcut menu that will be displayed. There are six options 
that are available in the shortcut menu and are discussed next.

Wireframe 	         :	 Displays the model with all the lines and edges without surfaces.

Hidden Line 	         :	 Displays the model with lines and edges that are visible.

Shaded 	         :	 Displays the building model with the surfaces shaded with respect  	
			   to the material shading and default lighting effect.

Consistent Colors     :	 Displays the building model in different consistent colors, making
			   the model more aesthetic.

Realistic                    :	 Displays the realistic view of the model with textures visible in the 
	                          elements. In this view style, you can specify and visualize the effect of  
			   artificial lights and photographic exposure lighting schemes in the  
			   project. The use of this style is helpful for quick presentation, where  
			   you do not want to render the image using mental ray.

Ray Trace                  :	 Displays the real time ray trace render view. As you select, an option  from 
the View Control Bar, Autodesk Revit starts rendering the model in a 
photorealistic Style. Initially, the render quality is low, but it improves 
after sometime.

 Note
By default, these options affect the current view only. However, you can save the shading effects 
by saving the shaded view in the project file.

TUTORIALS 
In the tutorials of this chapter, you will work on three projects: an apartment complex, a 
club building and a residential building. However, some portions of these three projects 
will be completed in the tutorials and the rest will be given as exercises that need to 
be completed by the students themselves. The tutorials and exercises form a sequence, and 
therefore, to complete these projects, you need to complete both the tutorials and exercises in 
the previous chapters. The following tutorials will familiarize you with the tools and concepts 
discussed in this chapter such as starting Revit, opening a new project, setting units, setting 
snaps, saving, and closing a project.
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Tutorial 1					                          Apartment 1
In this tutorial, you will create a new project file for the Apartment 1 project with the following 
parameters.							            (Expected time: 15 min)

1.	 Template file-
			   For Imperial	  default.rte
			   For Metric	 DefaultMetric.rte
2.	 Project Units- 
		  For Imperial	 Feet and fractional inches  Rounding- To the nearest 1/2”
		  For Metric	 Millimeters		         Rounding- 0 decimal places
3.	 Length dimension snap increment- 
		  For Imperial	 5’ ; 2’6”; 3”; 0’1/2”
		  For Metric	 1500 ; 750 ; 75 ; 10

4.	 File name to be assigned- 
		  For Imperial	 c02_Apartment1_tut1.rvt
		  For Metric	 M_c02_Apartment1_tut1.rvt

	 The following steps are required to complete this tutorial:

a. 	 Start Revit 2018 session.
b.	 Use the template file for the project.
		  For Imperial	 default.rte 
		  For Metric	 DefaultMetric.rte  
c.	 Set the project units using the Format dialog box.
		  For Imperial	 Feet and fractional inches 
		  For Metric	 Millimeters
d.	 Set the length dimension snap increment using the Snaps dialog box.
		  For Imperial	 5’; 2’6”; 3”; 0’1/2” 
		  For Metric	 1500 ; 750 ; 75 ; 10
e.	 Set Endpoint, Midpoint, Nearest, Perpendicular, Work Plane Grid, Snap to Remote 

Objects, and Intersection as the object snaps in the Snaps dialog box.
f.	 Save the project using the Save As tool.
		  For Imperial	 c02_Apartment1_tut1.rvt
		  For Metric	 M_c02_Apartment1_tut1.rvt
g.	 Close the project.

Starting Revit 2018
1.	 Start Revit 2018 by choosing  All Programs > Autodesk > Revit 2018 > Revit 2018 from 

the Start menu (for Windows 7). Alternatively, double-click on the Revit 2018 icon on the 
desktop. As a result, the program is loaded and the user interface screen is displayed.

2.	 Choose New > Project from the File menu; the New Project dialog box is displayed. 

Using the Template File
	 To use the template file for the project, you need to access the appropriate folder and then 

select the required template file.
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1.	 In the New Project dialog box, choose the Browse button from the Template file area; the 
Choose Template dialog box is displayed showing a list of the template files available in 
the US Imperial folder.

2.	 In the Choose Template dialog box, select the default template file from the US Imperial 
Folder (DefaultMetric template file from the US Metric folder), refer to Figure 2-36 and 
then choose the Open button; the Choose Template dialog box closes and the selected   
template file is applied to the new project. 

         

Figure 2-36  The Choose Template dialog box with the default.rte file selected

3.	 Ensure that the Project radio button is selected in the New Project dialog box. Next, choose 
the OK button from the dialog box; the default.rte (for Metric DefaultMetric.rte) template file 
is loaded. Notice that the Project Browser now shows different levels and views that have 
already been created in the selected template.

Setting Units
      To set units for the project,

1.    Choose the Project Units tool from the Settings panel of the Manage tab; the Project Units 
dialog box is displayed. 

2.	 Click on the Format column next to the Length parameter; the Format dialog box is 
displayed. 

3.	 In the Format dialog box, select the required option from the Units drop-down list, if not 
selected by default.

		  For Imperial	 Feet and fractional inches
		  For Metric	 Millimeters
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4. 	 Click on the Rounding drop-down list in this dialog box and select the required option, as 
shown in Figure 2-37.

		  For Imperial	 To the nearest 1/2”
		  For Metric	 1 decimal place

5.	 Choose the OK button; the Project Units dialog box is displayed. Choose the OK button; 
the specified units are applied and the dialog box is closed.

 

Figure 2-37  Selecting the To the nearest 1/2” option in the Format dialog box

Setting the Dimension and Object Snaps
	 To set the dimension and object snaps, use the Snaps tool. These settings are based on the 

type of the project and the amount of detailing required.

1.	 Choose the Snaps tool from the Settings panel of the Manage tab; the Snaps dialog box is 
displayed. In the Length dimension snap increments edit box, enter the following values.

		  For Imperial	  5’; 2’6”; 3”; 0’1/2”;
		  For Metric	  1500 ; 750 ; 75 ; 10;

2.	 In the Object Snaps area, clear the Quadrants, Centers, Tangents, and Points check boxes. 
Leave other check boxes selected. Choose the OK button; the settings are applied and the 
Snaps dialog box is closed.

3.	 Select the Temporary Dimensions option from Manage > Settings > Additional Settings 
drop-down list; the Temporary Dimension Properties dialog box is displayed. In this 
dialog box, ensure that the Centerlines radio button is selected in the Walls and Doors 
and Windows areas.

4.	 Choose the OK button; the Temporary Dimension Properties dialog box is closed.
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Saving the Project
	 The project parameters set in the previous steps are an integral part of the project file. To 

save this project file with these settings, use the Save tool.

1.	 Choose the Save tool from the File menu; the Save As dialog box is displayed.

2.	 In this dialog box, browse to the C drive and then create a folder with the name rvt_2018.

3.	 Open the rvt_2018 folder and then create a sub-folder with the name c02_revit_2018_tut. 
Next, open the created folder and save the file with the following name, refer to Figure 2-38.

		  For Imperial	 c02_Apartment1_tut1
		  For Metric	 M_c02_Apartment1_tut1
	 Notice that the Files of type drop-down list shows Project Files (*.rvt) as the default option.

4.	 Choose the Save button to save the project with the name c02_Apartment1_tut1.rvt. The 
project is saved at the specified location.

Figure 2-38  Saving the project using the Save As dialog box

Closing the Project
1. 	 To close the project, choose the Close option from the File menu.

 

Tutorial 2					                                        Club  
In this tutorial, you will create a new project file for the Club project using the following project 
parameters.							            (Expected time: 15 min)
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1.	 Template file- 
		  For Imperial	 Commercial-Default.rte
		  For Metric	 DefaultMetric.rte
2.	 Project Units- 
		  For Imperial	 Feet and fractional inches
		  For Metric	 Millimeters
3.	 Length dimension snap increment- 
		  For Imperial	 10’;2’6”;1’; 0’3”
		  For Metric	 3000; 750; 300; 75
4.	 Object snaps to be set- all available object snaps
5.	 File name to be assigned-
		  For Imperial	  c02_Club_tut2.rvt
		  For Metric	 M_c02_Club_tut2.rvt

The following steps are required to complete this tutorial:

a. 	 Start Revit 2018 session.
b.	 Use the template file by accessing the US Imperial templates folder. 
		  For Imperial	 Commercial-Default.rte 
		  For Metric	 Construction-DefaultMetric.rte
c.	 Set the project units using the Project Units dialog box.
		  For Imperial	 Feet and fractional inches 
		  For Metric	 Millimeters
d.	 Set the length dimension snap increment in the Snaps dialog box.
		  For Imperial	 10’;2’6”;1’; 0’3” 
		  For Metric	 3000 ; 750 ; 300 ; 75
e.	 Select the option for rounding.
		  For Imperial	 To the nearest 1/4” 
		  For Metric	 2 decimal places
f.	 Enable all the object snaps using the Snaps dialog box.
g.	 Save the project using the Save As tool.
		  For Imperial	 c02_Club_tut2.rvt
		  For Metric	 M_c02_Club_tut2.rvt
h.	 Close the project.

Starting Autodesk Revit 2018 and Opening a New Project 
1. 	 Start a new Autodesk Revit 2018 session by double-clicking on the Revit 2018 shortcut 

icon on the desktop. On doing so, the user interface screen is displayed. In case, the Revit 
2018 session is already running, this step can be ignored and the project file can be opened 
directly.

2.	 Choose New > Project from the File menu; the New Project dialog box is displayed.

Using the Template File
	 As given in the project parameters, you need to use the Commercial-Default.rte template file 

for Imperial and DefaultMetric.rte in this project. 

1.	 In the New Project dialog box, choose the Browse button; the Choose Template dialog box 
is displayed. In this dialog box, select the Commercial-Default template file from the US 



Starting an Architectural Project	                                   2-37 

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Imperial templates folder (DefaultMetric from US Metric folder) and then choose Open; 
the selected template file is assigned to the project. Next, choose OK; the template file is 
loaded. 

	 Notice that the Project Browser now shows several levels that are preloaded in the template 
file.

Setting Units
	 You can set units for various measurement parameters using the Project Units dialog box.

1.	 Choose the Project Units tool from the Settings panel of the Manage tab; the Project Units 
dialog box is displayed, as shown in Figure 2-39. 

Figure 2-39  The Project Units dialog box

                         

2.	 Click on the Format column next to the Length unit; the Format dialog box is displayed. 
In this dialog box, make sure that the Feet and fractional inches option for Imperial or 
Millimeters option for Metric (default option) is selected in the Units drop-down list.   

3.	 Next, select the required option from the Rounding drop-down list. 	
		  For Imperial	 To the nearest 1/4” 
		  For Metric	 2 decimal places

4.	 Choose OK to return to the Project Units dialog box. Next, choose the OK button to apply 
the settings and return to the user interface screen.
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Setting Dimensions and Object Snaps
	 In this section of the tutorial, you need to access and modify the settings in the Snaps dialog 

box. Further, you need to specify the dimension snap increment and enable all the object 
snap options. 

1.	 Choose the Snaps tool from the Settings panel of the Manage tab; the Snaps dialog box is 
displayed, as shown in Figure 2-40.

        

Figure 2-40  The Snaps dialog box

                          

2.	 In the Object Snaps area, ensure that all the check boxes for snapping are selected.

3.	 In the Length dimension snap increments edit box, enter the following values.
		  For Imperial	 10’; 2’6”; 1’; 0’3”; 
		  For Metric	 3000 ; 750 ; 300 ; 75 
	 Choose the OK button; the settings are applied and the Snaps dialog box is closed.
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4.	 Choose the Temporary Dimension option from Manage > Settings > Additional Settings 
drop-down list; the Temporary Dimension Properties dialog box is displayed. In this 
dialog box, ensure that the Centrelines radio button is selected in the Walls and Doors and 
Windows areas.

5.	 Choose the OK button; the Temporary Dimension Properties dialog box is closed.

Saving the Project
	 In this section, you will save the project and the settings using the Save dialog box.
	
1.	 Choose Save As > Project from the File menu; the Save As dialog box is displayed. 

2.	 Browse to the c02_revit_2018_tut sub-folder in the rvt_2018  folder and enter the required 
file name in the File name edit box. Notice that the Files of type drop-down list shows 
Project Files (*.rvt) as the default option. 

		  For Imperial	 c02_Club_tut2
		  For Metric	 M_c02_Club_tut2

3.	 Choose the Save button to save the project. The project is saved at the specified location.

Closing the Project
1.	 Choose the Close option from the File menu. 

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The keyboard shortcut for the Save tool is __________.

2.	 You can use the __________ tab of the Options dialog box to specify the location of the 
default template file.

3.	 The __________ button in the Save As dialog box can be used to specify the maximum 
number of backup(s) for a project file.

4.	 The __________ option of Revit enables you to override the snap settings for a single pick 
only.

5.	 You can add folders to the __________ list in the Save As dialog box to access the frequently 
used folders directly. 

6.	 You can open only one Revit project at a time. (T/F)

7.	 In Revit, all the enabled object snaps work together. (T/F)

8.	 While saving a project file for the first time, the Save As dialog box is displayed on 
choosing the Save tool from the File menu. (T/F)
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9.	 A project file can be opened by double-clicking on the file name in the Windows Explorer. 
(T/F)

10.	 You can save any project file as a template file. (T/F)

Review Questions
Answer the following questions:

1.	 Which of the following options cannot be used for object snapping?

		  (a) Endpoint				    (b) Work Plane Grid
		  (c) Dimension		  		  (d) Centers

2.	 Which of the following keys can be used to toggle between the object snap options available 
at the same point? 

		  (a) TAB					    (b) CTRL
		  (c) ALT					    (d) F3

3.	 Which of the following shortcut keys is used to activate the SteeringWheels?

		  (a) F2				                (b) F6
		  (c) CTRL                                                  (d) F8

4.	 Which of the following conditions are inherited from the new projects of the project template? 

		  (a) Levels 				    (b) Workflow Settings 
		  (c) Families 				    (d) Library Structure

5.	 Which of the following dialog boxes helps to set the units of project?

		  (a) Format 				    (b) Snaps
		  (c) Options				    (d) Project Information

6.	 You can modify the project unit settings anytime while the project is in progress. (T/F)

7.	 The file name and path of a project have to be specified each time you save a project. (T/F)

8.	 You cannot control the visibility of the tooltip assistant. (T/F)

9.	 The Save reminder interval drop-down list available in the General tab of the Options 
dialog box is used to specify the time interval between the reminder prompts to save a 
project file. (T/F)

10.	 If  changes made to a project file have not been saved, Revit prompts you to save the changes 
when you choose the Close tool from the File menu. (T/F)
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11.	 You cannot control the display of tooltips, and tool cursor of the SteeringWheels. (T/F)

12.	 You can add words to revit dictionaries for checking spellings. (T/F)

EXERCISES
Exercise 1			                                        Apartment 2

Create a new project file for the Apartment 2 project with the following parameters:
								              (Expected time: 15 min)
1.	 Template file- 
		  For Imperial	 default.rte
	 	 For Metric	 DefaultMetric.rte
2.	 Project Units- 
		  For Imperial	 Feet and fractional inches	
		  For Metric	 Millimeters
3.	 Length dimension snap increment- 
		  For Imperial	 5’; 2’6”; 3”; 0’1/2”
		  For Metric	 1500 ; 750 ; 75 ; 10
4.	 File name to be assigned- 
		  For Imperial	 c02_Apartment2_ex1.rvt
		  For Metric	 M_c02_Apartment2_ex1.rvt

Exercise 2                                   Elevator and Stair Lobby
Create a new project file for the Elevator and Stair Lobby project with the following 
parameters:							             (Expected time: 15 min)

1.	 Template file- 
		  For Imperial	 default.rte
		  For Metric	 DefaultMetric.rte
2.	 Project Units- 
		  For Imperial	 Feet and fractional inches
		  For Metric	 Millimeters
3.	 Length dimension snap increment- 
		  For Imperial	 5’; 1’; 3”; 0’1”
		  For Metric	 1500 ; 300 ; 75 ; 25
4.	 File name to be assigned- 
		  For Imperial	 c02_ElevatorandStairLobby_ex2.rvt
		  For Metric	 M_c02_ElevatorandStairLobby_ex2.rvt

Exercise 3                                           Residential Building
Create a new project file for the project with the following parameters:				  
			         					          (Expected time: 15 min)
1.	 Template file- 
		  For Imperial	 default.rte
		  For Metric	 DefaultMetric.rte
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2.	 Project Units- 
		  For Imperial	 Feet and fractional inches
		  For Metric	 Millimeters
3.	 Length dimension snap increment- 
		  For Imperial	 4’ ; 0’  6” ; 0’  1” ; 0’  0 1/4” ; 
		  For Metric	 1200 ; 150 ; 25 ; 5
4.	 Name for saving the file- 
		  For Imperial	 c02_residential_ex3.rvt
		  For Metric	 M_c02_residential_ex3.rvt

Answers to Self-Evaluation Test
1. CTRL+S, 2. File Locations, 3. Options, 4. Temporary Overrides, 5. Places, 6. F, 7. T, 8. T, 
9. T, 10. T 


