
Chapter 3

Creating Walls
Learning Objectives

After completing this chapter, you will be able to:
• Understand the concept of walls
• Understand the properties of walls
• Use the sketching tools to create walls
• Create stacked walls
• Create exterior and interior walls based on the given parameters
• Create wall sweeps and wall reveals
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INTRODUCTION
In the previous chapter, you learned about various tools and options to start, open and save 
an architectural project in Revit. In this chapter, you will learn about various tools and options 
to create different types of walls. You will also learn about the functions and parameters of 
different types of walls. Moreover, you will learn various options to modify the properties of an 
architectural wall and its type properties will be discussed in detail. Also, you will learn about 
various tools that are used to add modifiers in a wall, such as sweep and reveal.

CREATING A BUILDING PROJECT
In Revit, the term ‘project’ comprises not only the physical building model but also its associated 
documentation such as drawings, views, schedules, areas, and so on. The first step in creating a 
project is to create the building model. In Autodesk Revit, you can create it using the following 
two methods:

Method 1: 	 Create a building model using individual building elements such as walls, 
		  windows, doors, floors, roofs, and so on.

Method 2:	 Create a conceptual mass of a building model using the massing tools and 
		  conceptualize the overall building shape and volume before working with individual  
		  elements. 

Tip
You can also use a combination of above two methods. You can generate a building mass using 
the massing tools and then convert it into a building model with individual building elements 
using the building maker tools. 

The selection of method depends on different project parameters such as project magnitude, 
building shape, building technology, current documentation stage of a project, industry 
parameters, and so on. The use of the massing tools to create a building geometry and the 
usage of individual building components to develop a building model will be described later. 

Autodesk Revit provides you with several tools to add individual building elements such as wall, 
floor, roof, and so on for creating a building model. Several predesigned element types have been 
provided for each building element in Autodesk Revit libraries. You have the flexibility to either 
use the predesigned element types or create your own element type to create a building model. 

Sequence of Creating a Building Model 
The sequence of using building elements for creating a building model depends on various 
parameters such as building type, building volume, building shape, and so on. For most of the 
building projects, the sequence given below may be adopted.

Step 1:	 Start the model by creating the exterior walls of the building at Level 1 (lowest level).

Step 2:	 Create interior walls at the desired locations.

Step 3:	 Add doors and windows to the exterior and interior walls at the desired location.



Creating Walls						                        3-3

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Step 4: 	Add the floor to the building model.

Step 5:	 Add the roof to the building model.

Step 6:  Add the structural or architectural grid and structural elements.

Step 7:  Add stand-alone components such as furniture items and plumbing fixtures.

Step 8:  Add text and annotations to different spaces.

Step 9:  Create dimensions for different parameters of the project.

Step 10: Create project details and documentation.

Step 11: Create the rendered 3D views and walkthrough.

In Revit, each building element is considered a three-dimensional parametric entity. This means, 
on adding elements to the model, you also add the related information and specification about 
the elements. One of the most important elements in a building model is the wall. It defines the 
basic spatial arrangement of the building that acts as the host for doors and windows. 

Understanding Wall Types
Autodesk Revit provides you with several predefined wall types such as Exterior, Interior, 
Retaining, Foundation, Curtain, and Stacked Wall, based on their usage.
	
Exterior Wall Type
This category constitutes the wall types that are primarily used for generating the exterior skin 
of the building model. It has predefined wall types such as Brick on CMU, Brick on Mtl. Stud, 
CMU Insulated, and so on.

Interior Wall Type
The interior walls are used as the interior partitions in a building project. These walls are  
non-bearing in character. The predefined interior walls provided in Autodesk Revit have a dry 
wall construction with a metal stud frame and varying thickness. 

Retaining Wall Type
As the name suggests, the primary function of the retaining walls is to retain the earth. You 
can either use the retaining walls provided in the program or set the function of any wall type 
as retaining. For example, you can select a wall from the drawing and select Retaining - 12” 
Concrete for Imperial (Retaining 300mm Concrete for Metric) from the Properties palette. 
On doing so, the current wall type will be changed to retaining wall. 

Foundation Wall Type
The walls that form the foundation or substrate of the main building structure belong to this         
category. To create a foundation wall, the Foundation - 12” Concrete option for Imperial 
(Foundation- 300mm Concrete for Metric) is provided as the predefined foundation wall type 
in the Properties palette. 
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Curtain Wall Type
These wall types have predefined curtain walls or screen walls that consist of panels and 
mullions. 

Stacked Wall Type
A stacked wall is a wall that is made of different types of walls stacked vertically on top of each 
other.

This software provides you with the flexibility of creating your own wall type. The walls that you 
will create can have different parameters which can be modified, depending on their usage. 
In Revit, you can create both architectural and structural walls. An architectural wall does not 
contain analytical properties like the structural walls. In the next section, various techniques to 
create and modify architectural walls are discussed.

Creating Architectural Walls
Ribbon: 	 Architecture > Build > Wall drop-down > Wall: Architectural
Shortcut Key: 	 WA

In this section, you will learn the method of creating and editing architectural walls. In          
Autodesk Revit, each wall type has specific predefined properties such as its usage, composition, 
material, characteristics, finish, height, and so on. You can select the wall type based on its 
specific usage in the project. Walls, like most other model elements, can be created in a plan 
view or a 3D view. 
                                   
To create an architectural wall, first you need to invoke the Wall: Architectural tool and then 
select the appropriate wall type and specify various properties. To do so, choose the Wall: 
Architectural tool from the Build panel of the Architecture tab, refer to Figure 3-1; the Modify 
| Place Wall tab with the Options Bar will be displayed. In the Options Bar, you can define the 
direction of the wall by choosing either the Height or Depth option from the Height drop-down 
list. You can select the desired level upto which the wall is to be created from the Unconnected 
drop-down list. If you select the Unconnected option from the drop-down list then the edit box 
next to it will be activated. Enter the desired height upto which you want the wall to be raised. 
Select the reference line for sketching the wall from the Location Line drop-down list.

Select an exterior or interior wall type from the Type Selector drop-down list in the Properties 
palette, as shown in Figure 3-2. Next, from the Properties palette, specify and edit various 
properties of the wall to be created. Various wall properties and the process to specify them are 
discussed next. 

    
Tip
Besides the Properties palette, wall types are also listed under the Families head in the Project 
Browser. Left-click on the arrow sign next to the Families head to view the families available 
in Autodesk Revit. Click the arrow symbol next to the Walls subhead and then the one next to 
the Basic Wall subhead to display various basic wall types. Select and right-click on any wall 
type to display a shortcut menu with the options that can be used for editing. 
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Figure 3-1  Invoking the Wall: Architectural 
tool from the Build panel

Figure 3-2  Selecting the wall type from the 
Type Selector drop-down list 
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Specifying Architectural Wall Properties
In Autodesk Revit, wall has two sets of properties, type and instance. These set of properties 
control the appearance and the behavior of the element concerned.
 

Specifying Instance Properties
	 After invoking the Wall: Architectural tool, the instance

Figure 3-3  The Properties 
palette for the Exterior - Brick 
on Mtl. Stud wall type

properties of the wall will be displayed in the Properties palette, 
as shown in Figure 3-3. 

	 The Properties palette contains the Type Selector 
drop-down list. You can select the family and the type of the 
proposed wall from this drop-down list. This palette shows 
various instance properties and their corresponding values 
for the specified instance of the element. The options in 
this palette depend on the type and instance of the selected 
element or the elements created based on the options selected 
in the Type Selector drop-down list. The properties of exterior 
walls are displayed in different categories such as Constraints, 
Structural, Dimensions, and Identity Data each representing a 
set of properties corresponding to the title. You can use the twin 
arrows on the extreme right of the title to collapse the table of 
properties for each title. Some of the important parameters 
are discussed next.

                             
	 In the Properties palette, the Location Line parameter 

indicates the reference line used for creating a wall. In 3D 
environment, the location line in a wall refers to a plane that 
does not get modified even if the wall parameters are changed. 
To assign a value to the Location Line parameter, click in the 
value field corresponding to this parameter; a drop-down list 
will be displayed. Click on the drop-down list to view the available options. The options in 
the drop-down list are given next.

	 Wall Centerline		  - 	 Center line of the entire composite wall
	 Core Centerline		  - 	 Center line of the structural core of the wall
	 Finish Face: Exterior	 - 	 Exterior face of the wall as the location line
	 Finish Face: Interior	 - 	 Interior face of the wall as the location line
	 Core Face: Exterior		 - 	 Exterior face of the core
	 Core Face: Interior		 - 	 Interior face of the core

	 The location line is indicated by a dashed line, which appears while sketching a wall segment. 
For example, on selecting the Wall Centerline option as the location line, you will notice 
a dashed line in the middle of the wall, as shown in Figure 3-4. When you select the Finish 
Face: Interior option, it appears on the interior face of the wall, refer to Figure 3-5.
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Figure 3-5  Wall on selecting the Finish 
Face: Interior option 

Figure 3-4  Wall on selecting the  
Wall Centerline option 

Note 
When a design is developed, you may need to modify certain parameters of the exterior wall such 
as its thickness and composition, based on the final selection of materials and their specifications. 
Considering this flexibility, the Location Line parameter enables you to create walls.

	 In Autodesk Revit, you can specify the height of walls by applying the base and top constraints 
with respect to the levels defined in the project. This means, if you set the base and height 
parameters of a top storey and apply these constraints, all walls will be sketched with the 
same base and the top. To create a wall segment that is not related to these components and 
levels, you can type the desired height in the column of the Unconnected Height instance 
parameter. The default value for the unconnected height is 20’ 0”.

	 The various instance parameters for walls and their usage are given next. The values of some 
of the instance parameters will be available only after an instance is created. The instance 
parameters of the wall are given in the table below. 

	

Instance Parameter Description

Location Line	 Line or reference plane for sketching the wall

Base Constraint Level or reference plane of the base of a wall

Base is Attached Check box showing whether or not the base of the wall is  	
attached to any other element

Base Offset Height of a wall from its base constraint

Base Extension Distance Distance of the base of the layers in a wall

Top Constraint Specifies whether the wall height is defined by specified 
levels or is unconnected

Unconnected Height Explicit height of a wall

Top Offset Distance of the top of a wall from the top constraint

Top is Attached Check box showing whether the top of the wall is  attached to 
any upper element or not

Top Extension Distance Distance of the top of a layer on a wall

Room Bounding Specifies whether the wall constitutes the boundary of a room

Related to Mass Specifies whether the wall relates to a massing geometry

Structural Usage Defines the specific structural usage of a wall

Length	 Indicates the value of the length of a wall

Area Indicates the value of the surface area of a wall
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Volume	 Indicates the value of the volume of a wall

Image Specifies the image file corresponding to a wall instance. 
This parameter can be used in the wall schedule to display 
the image of the wall instance.

Comments Specific comments that give description of a wall

Mark 	 To add a unique value or label to each wall
   

Tip
The selection for the Location Line parameter should be based on your design intent. For 
example, to create walls defined by exact interior dimensions, you can select the Finish Face: 
Interior option as the location line value. Once this parameter is selected, any addition or 
reduction of wall thickness in the project will be made toward its outer face.

Specifying Type Properties 
	 The type properties of a wall specify the common parameters shared by certain elements in 

a family. Any changes made in the type properties of a wall element will affect all individual 
elements of that family in the project. To modify the type properties of an element, invoke 
the Wall: Architectural tool; the Modify | Place Wall tab will be displayed. In this tab, 
choose the Edit Type tool from the Properties panel; the Type Properties dialog box will 
be displayed, as shown in Figure 3-6. 

Figure 3-6  The Type Properties dialog box with the 
Exterior-Brick on Mtl. Stud wall type
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	 Using this dialog box, you can modify the type properties of the selected wall type such 
as Structure, Function, Coarse Scale Fill Pattern, and so on. In Autodesk Revit, in the 
Type Properties dialog box, you can view the Analytical Properties of the wall such as 
the Thermal Mass, Thermal Resistance, and Heat Transfer Coefficient. The Analytical 
Properties that you can edit are: Absorptance and Roughness. In the Type Properties 
dialog box, you can also define the composition of the wall type. To do so, choose the Edit 
button in the Value column of the Structure parameter; the Edit Assembly dialog box will 
be displayed. In the Edit Assembly dialog box, choose the Preview button; a preview box 
will be displayed. The preview box will display sectional detail of the selected wall type, as 
shown in Figure 3-7. 

Figure 3-7  The Edit Assembly dialog box with the Preview button chosen

	 In Autodesk Revit, a wall is a composite building element and can consist of several layers. 
The Layers area in the Edit Assembly dialog box displays multiple layers of the selected 
wall, each with a specific function, material, and thickness. The layer on the top of the table 
represents the exterior side of a wall and the last layer represents the interior  face. The 
Layers area, refer to Figure 3-7, displays the layers of the selected wall type. In this case, it 
is Exterior- Brick on Mtl. Stud. This wall type has nine layers. Each layer of the composite 
wall is assigned a specific function and priority based on its usage. The layers available in 
Autodesk Revit can be broadly classified into the categories given next.

	 Structure [1] - Consists of main supporting element of the structure such as concrete, brick, 
wood, metal stud, and so on.
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	 Substrate [2] - Consists of material that functions as substructure, such as foundation and 
plywood. 

	 Thermal/Air Layer - Indicates the air cavity or the thermal insulation layer.

	 Membrane Layer - A zero thickness layer primarily for the prevention against water 
vapor penetration.

	 Finish 1 [4] - Exterior finish such as metal, brick, and stone.

	 Finish 2 [5] - Interior finish such as paint, gypsum wall board, and so on.

Note
The numbers placed next to certain layers show the priority set of the layer and enable Autodesk 
Revit to work out the joinery detail of wall segments at corners and intersections according to 
the priority. When joined, a higher priority layer takes precedence over a lower priority layer.

	 In the Edit Assembly dialog box, the Material column displays the material specification, 
whereas the Thickness column displays the thickness of each layer. The total thickness of this 
composite wall is the sum of thickness of all layers. In the present case, the total thickness 
of wall is 1’1 7/8” (350 mm) which is given beside the Total thickness parameter on the 
top of the dialog box. You can click on the View drop-down list and select Section: Modify 
type attributes to view the section of the wall.

Note
The View drop-down list will only be visible if you choose the Preview button in the Edit 
Assembly dialog box.

	 Autodesk Revit enables you to add and remove layers by using the Insert and Delete buttons, 
respectively, provided in the Layers area in the Edit Assembly dialog box. To shift the layers, 
choose the Up and Down buttons. You can also create your own layers. You will learn more 
about materials, layers, and composite walls in the later chapters. The Default Wrapping 
area in the Edit Assembly dialog box has two drop-down lists namely, At Inserts and At 
Ends. The options in these drop-down lists allow wrapping of a compound wall at the end 
and at the inserts (for doors and windows). From the At Inserts drop-down list, you can 
select any of the following options: Exterior, Interior, Both, or Do not wrap. Similarly, from 
the At Ends drop-down list, you can select any of the following options: Exterior, Interior, 
or None. The wrapping in the walls can be viewed in a plan view. Figures 3-8 through 3-11 
illustrate the effects of different types of wrapping options on the wall.
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Figure 3-9  The wall created with the Exterior 
option selected from the At Inserts drop-down 
list in the Default Wrapping area

Figure 3-8  The wall created with the Do 
not wrap option selected from the At Inserts 
drop-down list in the Default Wrapping area

Tip
While creating a new wall type, you can specify whether a wall is an exterior or interior wall. 
To do so, invoke the Type Properties dialog box of the wall to be created and click in the Value 
field of the Function parameter; a drop-down list will be displayed. From this drop-down list, 
you can select the Exterior option to assign exterior wall type function to the selected wall. 
Similarly, you can select the Interior option to assign the interior wall type function to the wall.  

Figure 3-11  The wall created with the Exterior 
option selected from the At Ends drop-down list 
in the Default Wrapping area

Figure 3-10  The wall created with the None 
option selected from the At Ends drop-down list 
in the Default Wrapping area

Sketching Walls
The next step after selecting the wall type from the Properties palette is to select the sketching 
tool. Autodesk Revit provides several sketching tools, such as Line, Rectangle, and others to 
sketch the walls of different shapes. These tools, along with the Options Bar, can be invoked 
from the Draw panel in the Modify | Place Wall tab, as shown in Figure 3-12.
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Using Sketching Tools
	 In Autodesk Revit, you can access different sketching tools from the Draw panel and the 

Options Bar in the Modify | Place Wall tab. On invoking these tools, you can sketch different 
wall profiles. The procedure to do so is discussed next.

 Sketching Straight Wall Profiles. You can sketch straight walls using the Line sketching 
tool by specifying the start point and the endpoint of the wall segment. To specify 
the location of the start point, click anywhere in the drawing area. Now, move the 

cursor in the drawing area, you will notice that a wall segment is starting from the specified 
point and the dimension that changes dynamically appears on it. This dimension is called 
the temporary dimension or listening dimension, and it shows the length and angle of the 
wall segment at any given location of the cursor, as shown in Figure 3-13. Also, notice that 
the cursor moves in increments by the value set in the Dimension Snaps area of the 
Snaps dialog box (See Snaps tool topic, Chapter 2). The angle subtended by the wall on 
the horizontal axis is also displayed and it keeps changing dynamically as you move the 
cursor to modify the inclination of the wall. Also notice that on bringing the cursor near 
the horizontal or the vertical axis, a dashed line will appear on the wall segment. This is 
called the alignment line and it helps you sketch the components with respect to the already 
created components. You will also notice that a tooltip is displayed indicating that the wall 
segment being sketched is horizontal, as shown in Figure 3-14.

Figure 3-13  Length and angle of the  
wall segment

Figure 3-14  Sketching a horizontal wall 

	 Autodesk Revit provides you the flexibility of specifying the length of the walls in different 
ways. The first option is to specify the starting point of the wall, move the cursor in the 
desired direction, and click when the angle and the temporary dimension attain the required 
values. The second option is to sketch the wall and then modify its length and angle to the 
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exact value. For example, to sketch a 18’0”(5486 mm) long horizontal wall after specifying 
the starting point, you can move the cursor to the right until you see a dashed horizontal 
line parallel to the sketched wall. Click when the temporary dimension shows 20’0”(6096 
mm) approximately. Note that the length of the wall may not be exactly 18’0”(5486 mm). 
You can now use the wall controls to modify the dimensions of the wall to its exact value. 

     
	 To modify the wall, select the wall segment and view its control and properties. As you select 

the wall segment, it gets highlighted in blue and the symbols appear in blue above the wall 
segment, as shown in Figure 3-15.

Figure 3-15  Highlighted wall displaying its various controls

              

       The exact dimension of the sketched wall is visible in the dimension text of the temporary 
dimension. The conversion control symbol, which appears below the dimension value, 
is used to convert the temporary dimension into a permanent dimension. The two blue 
arrows which also appear on the upper face of the wall, indicate the flip control symbol for 
the sketched walls. They appear on the side interpreted as the exterior face of the wall. By 
default, the walls drawn from the left to right have the external face on the upper side and 
the walls drawn from the top to bottom have the external face on the right side. You can 
flip the orientation of the wall by clicking on the arrows symbol. Alternatively, you can place 
the cursor over the flip control symbol and notice the change in its color. After the color of 
the flip control changes, press SPACEBAR to flip the wall. The two blue dots that appear at 
the two ends of the wall segments are the drag control symbols. You can use them to stretch 
and resize the walls. To set the wall to the exact length, click on the temporary dimension; 
an edit box will appear showing the current dimension of the wall segment. Now, you can 
change the length of the wall by entering the desired value in the edit box. For example, you 
can enter 14’ 8”(4470 mm) in the edit box, as shown in Figure 3-16. Next, press ENTER; 
the length of the wall will be modified to 14’ 8”(4470 mm).

	 Alternatively, you can create a straight wall by typing the dimension of the length before 
choosing the endpoint. As soon as you start typing the length, an edit box appears above the 
dimension line. Enter the value of the length and press ENTER to create a wall segment of 
the specified length. To sketch a wall at a given angle, sketch it at any angle and then click 
on the angular dimension symbol; an edit box will appear. In the edit box, you can enter 
the exact angular dimension from the horizontal axis to which the wall will be inclined. 

                   

Figure 3-16  Specifying the length of the wall
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Note
The Project Browser shows Level 1 in bold letters. This indicates that the wall has been sketched 
in that level.
	

      Sketching Rectangular Wall Profiles. You can invoke the Rectangle tool from the Draw
 panel in the Modify | Place Wall tab to sketch a rectangular wall profile. After you 
invoke the Rectangle tool, click on the screen to specify the location of one corner of 

the rectangular wall to be drawn. Next, move the cursor away from the point; a rectangular 
wall profile will be displayed along with the temporary dimension between the two parallel 
walls. Now, move the cursor to the desired location and when the temporary dimension 
attains the desired value, click to specify the diagonally opposite corner of the profile; the 
rectangular wall will be created along with the temporary dimensions displayed. Alternatively, 
you can also create a rectangular wall profile by sketching it using some rough dimension 
and then modifying its size. This can be done by clicking on the temporary dimension of 
the sketched profile and entering the exact distance in the edit box, as shown in Figure 3-17. 
The size of the rectangle will be modified to the exact values.

         	

Figure 3-17  Creating and modifying a rectangular wall profile 

      Sketching Polygonal Wall Profiles. You can sketch a polygonal wall profile using either 
the Inscribed Polygon or Circumscribed Polygon tool from the Draw panel in the 
Modify | Place Wall tab. To draw an inscribed polygon, invoke the Inscribed Polygon 
tool or to draw a circumscribed polygon, invoke the Circumscribed Polygon tool. 

When you invoke any of these tools, various options for polygon creation are displayed in 
the Options Bar. In the Options Bar, you can specify the number of sides of the polygon 
in the Sides edit box. The polygonal profile can be created by specifying the radius of the 
inscribed or circumscribed circle. To draw an inscribed polygon, choose the Inscribed 
Polygon tool from the Draw panel in the Modify | Place Wall tab and then specify the 
desired number of sides, height (if unconnected), and offset value in the respective edit 
boxes in the Options Bar. Next, click in the drawing area to specify the center of the polygon. 
Then, drag the cursor and click again to get the desired radius; the inscribed polygon will 
be created. Similarly, a circumscribed polygon can also be created by choosing the 
Circumscribed Polygon tool from the Draw panel in the Modify | Place Wall tab.   
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	 Sketching Circular Wall Profiles. The Circle tool in the list box can be used to sketch  
circular wall profile. To sketch a circular wall profile, invoke the Circle tool from the 
Draw panel of the Modify | Place Wall tab and click in the drawing area to specify 

the center point of the circular wall. You will notice that a circular wall profile is 
extending dynamically with the specified point as the center and the other end attached to 
the cursor, as shown in Figure 3-18. The temporary radial dimension will also be displayed. 
Click when the desired value for the radius is displayed. Alternatively, before clicking on 
the second point, type the value for the radius of the circular profile. As you type, the value 
will be displayed in the edit box. Press ENTER to complete the profile. Notice that the 
dimension that you entered is the distance of the center point to the location line of 
the profile.

Figure 3-18  Sketching the Circular wall profile

	 Sketching Start-End-Radius Arc Profiles. The Start-End-Radius Arc tool in the Draw 
panel of the Modify | Place Wall tab enables you to sketch an arc wall by specifying 
the start point, end point, and the intermediate point that determines the radius of 

the arc. To create an arc wall, invoke the Start-End-Radius Arc tool from the Draw panel 
of the Modify | Place Wall tab; you will be prompted to specify the start point of the 
proposed arc wall. Specify the start point by clicking in the drawing area. Now, you will be 
prompted to specify the endpoint of the curved wall. Specify the endpoint of the curved 
wall; a curved wall with a variable radius stretches dynamically between the two specified 
points. Specify the location of the third point between the two specified points to specify 
the subtended angle or the radius of the arc. As you specify the third point, the angular and 
radial temporary dimensions are displayed along with the curve on the screen. Next, click 
in the drawing area to specify the third point; the curved wall will be sketched. You can also 
modify the sketched wall to the desired curvature parameters such as radius, angle subtended, 
orientation, and so on. To modify the curvature, select the sketched wall, click on the 
parameter such as the angular dimension and enter the new value, as shown in Figure 3-19. 
You can also use the drag controls to increase or decrease the extent of the wall. The central 
blue dot can be used to stretch the wall, keeping the subtended angle constant.
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Figure 3-19  Sketching and modifying a curved wall profile

     

 	 Sketching Center-ends Arc Wall Profiles. You can sketch a curved wall by specifying 
its center point and two endpoints. To do so, choose the Center-ends Arc tool from 
the Draw panel in the Modify | Place Wall tab. Next, click in the drawing area to 

specify the location of the center point and then move the cursor. Click when the desired 
value of the radius is displayed. You can also type the radius value and then press ENTER. 
The point that you specify will be taken as the start point of the wall. Next, click in the 
drawing area again to specify the endpoint of the arc wall. Note that the curved wall segment 
can be extended up to 180-degree. When the angle exceeds 180-degree, the wall will flip 
the side. Once the wall is sketched, you can select it and modify its parameters such as its 
subtended angle and radius. You can also modify the curvature keeping the radius fixed by 
using the drag controls, refer to Figure 3-20.

Figure 3-20  Sketching a curved wall profile using 
the Center-ends Arc sketching tool

                                 
      Sketching Tangent End Arcs Wall Profiles. To sketch a curved wall profile that starts 

tangentially from an existing wall, invoke the Tangent End Arc tool from the Draw 
panel in the Modify | Place Wall tab and click at the endpoint of an existing wall to 

specify the start point. After specifying the start point, move the cursor to the desired distance 
and click to define the curved wall profile.

	
        Sketching Fillet Arc Wall Profiles. To create a curved fillet wall between the two existing 

walls, choose the Fillet Arc tool in the Draw panel of the Modify | Place Wall tab. 
Now, one by one, click on the two walls to create a fillet close to the desired fillet end. 

On doing so, a fillet wall will appear, showing its possible locations, as shown in Figure 3-21. 
Click to specify the location of the fillet. Once the fillet wall is sketched, you can modify its 
radius by clicking on it and typing its value. Notice that the walls are automatically trimmed 
after placing the fillet arc.
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Figure 3-21  Sketching a fillet arc wall profile using the Fillet Arc tool

	
	 Using the Chain Option. Select the Chain check box in the Options Bar to create a 

continuous wall profile with a number of wall segments. It enables you to create a continuous 
wall with wall segments connected end to end. The end point of the previous wall becomes 
the start point of the next wall. To enable the Chain option, select the check box before or 
while sketching the wall profile. You can also use this option while using different sketching 
tools.

	 Using the Offset Option. The Offset edit box can be used to create a wall that starts at a 
specified offset distance from a point defined in an existing element. You can enter the offset 
distance value in the Offset edit box provided in the Options Bar. However, the shape of 
the resulting wall depends on the sketching tool selected. After entering the offset value and 
selecting the sketching option, click near the element to define the offset distance. When 
you move the cursor, the wall will start at the specified distance from the selected point. For 
example, this option can be used for creating boundary walls that are placed at a specific 
distance from the building profile.

	 Using the Radius Option. The Radius edit box in the Options Bar is used to specify the 
radius while sketching a circular, curved, or a fillet wall. You can type the value of the radius 
in the Radius edit box before or after invoking the desired sketching tool.

Tip
An appropriate sketching option should be selected based on the desired wall profile. You can 
also sketch walls using a combination of available sketching tools.

WORKING WITH STACKED WALLS
In Autodesk Revit, besides basic wall and curtain wall there is a special kind of wall called a 
stacked wall. A stacked wall is a wall created using two or more basic walls that are stacked on top 
of another to form a complex design. These walls are assembled in such a way that the entire 
facade acts as a single wall. In the next section, you will learn about various options that are 
used to create a stacked wall and then add it to the project.

Creating a Stacked Wall
To create a stacked wall, choose the Wall: Architectural tool from Architecture > Build > Wall 
drop-down; the Modify| Place Wall tab with the instance parameters in the Properties palette 
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will be displayed. In the Properties palette, select the stacked wall type from the Type-Selector 
drop-down list. After selecting the stacked wall type, choose the Edit Type button from the 
Properties palette; the Type Properties dialog box will be displayed. 

In the Type Properties dialog box, choose the Duplicate button to create a new type of stacked 
wall; the Name dialog box will be displayed. In this dialog box, enter a desired name and choose 
the OK button; the Type Properties dialog box will be displayed and the created type will be 
updated in the Type drop-down list. Now, you are required to edit the structural properties to 
form a new type. Choose the Edit button corresponding to the Structure parameter; the Edit 
Assembly dialog box will be displayed. In this dialog box, select the type of wall from the Name 
column. In the Height column, you need to specify the height of the walls. By default, the height 
of first wall is Variable. If you want to make other wall types as variable, select the desired wall 
type; the Variable button will be activated. Choose the Variable button to change the wall to 
variable. If you want to insert a row then choose the Insert button and to delete a row, choose 
the Delete button. You can use the Preview button to preview the stacked wall. Next, choose 
the OK button twice; the Edit Assembly and the Type Properties dialog boxes will be closed 
and will be selected in the Type Selector drop-down list. Now, you can use the stacked wall to 
create the building.

ADDING INTERIOR WALLS
In Autodesk Revit, interior walls form a separate family of wall types.

Figure 3-22  Selecting the 
interior wall type from the 
Properties palette

 
They differ from the exterior wall types based on their usage, material 
specifications, and non load-bearing character. Several predefined 
interior wall types are provided in the Autodesk Revit libraries.

To view the interior wall types, choose the Wall: Architectural 
tool from Architecture > Build > Wall drop-down; the instance 
parameters of the wall will be displayed in the Properties palette. 
From this palette, you can select different types of walls available in 
Revit. The wall types that may be used as interior walls have been 
assigned the prefix Interior. Based on the project requirement, you 
can select the appropriate interior wall type from the drop-down list. 
For example, Interior- 5” Partition (2-hr) is a type of interior wall 
for Imperial (Interior- 135 mm Partition (2-hr) for Metric) with a 
2-hour fire rating and can be selected from the Properties palette, 
as shown in Figure 3-22.

To view and specify the properties of an interior wall type, you can use 
the Properties palette, as shown in Figure 3-23. This palette shows 
various parameters of the selected wall such as Unconnected Height, 
Location Line, Structural Usage, Top Constraint, and so on. You 
can modify these parameters by entering a new value or selecting 
the required value from the corresponding value field in the Properties palette. 
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Figure 3-23  The Properties palette for the Interior - 5” 
Partition (2-hr) wall type

Tip
After creating a wall, right-click on any end of the wall; a shortcut menu will be displayed. 
Choose the Disallow Join option from the shortcut menu to prevent the wall end from joining 
with other walls.

                  

The sketching tools explained earlier (for exterior walls) can also be used for sketching interior 
walls. When you sketch the interior walls, the top constraint of the interior walls is automatically 
set to a level above the current level. 

Tip
The Location Line parameter in the Properties palette of the selected walls is useful for 
creating interior walls. You can create interior walls at some specified distance from another 
existing wall using the Finish Face: Interior option.

Note
The interior walls do not create a neat junction with the exterior walls as they have different 
composition and characteristics. 

Walls are the host elements for other building elements such as doors and windows. Therefore, 
deleting walls will delete all their dependent elements as well.

The basic composition of an interior wall type can be viewed by choosing the Type Properties 
tool from the Properties panel in the Modify | Place Wall tab. On doing so, the Type Properties 
dialog box will be displayed, showing different type parameters of the selected wall type.
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To view the structural composition of a wall type, choose the Edit button in the Structure type 
parameter; the Edit Assembly dialog box will be displayed, showing layers for the corresponding 
wall type. For example, the Interior-5” Partition (2-hr) for Imperial or (Interior-135 mm 
Partition (2-hr) for Metric) wall type comprises of seven layers with different materials and 
thickness. You can use the Insert and Delete buttons to modify the wall type. You can choose 
the Preview button to display the graphic view of the Interior - 5” Partition (2-hr) for Imperial 
(Interior - 135mm Partition (2-hr) for Metric) wall type in the preview area, as shown in 
Figure 3-24.

Figure 3-24  The Edit Assembly dialog box for the Interior - 5” Partition (2-hr) wall type 

Tip
In Autodesk Revit, you can add a structural wall to a project by choosing the Wall: Structural 
tool from Architecture > Build > Wall drop-down. The structural wall has analytical 
properties that can be used for structural analysis.  

ADDING WALL SWEEPS AND REVEALS                          
In an architectural project, wall sweep and wall reveal act as modifiers in a wall. Each type of  
wall sweep and wall reveal has predefined properties. You can select and use any type of wall 
sweep and wall reveal based on its usage in project. Wall sweep is used to add a baseboard, crown 
molding or other type of decorative horizontal or vertical projections to a wall. Wall reveal is used 
to add a decorative horizontal or vertical cutout to a wall. Wall sweep and wall reveal provide 
advancement to the building model by adding skirtings, projections and cutout to a building.

Note
Wall sweep and wall reveal can be added to a wall only in 3D view or in elevation view.
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Wall Sweeps
Ribbon: 	 Architecture > Build > Wall drop-down > Wall: Sweep 

To add details to a wall, you can add a wall sweep by using the Wall Sweep tool. Wall Sweep can 
be selected either in an elevation view or in 3D view. Choose the 3D View tool from the Quick 
Access Toolbar, the user interface will be displayed. Next, invoke the Wall: Sweep tool from the 
Build panel of the Architecture tab, as shown in Figure 3-25. On doing so, the Modify | Place 
Wall Sweep tab will be displayed. In the Placement panel of this contextual tab, the Horizontal 
tool is selected by default. As a result, the wall sweep will be added horizontally to the face of 
the wall. Select the required type of the wall sweep from the Type Selector drop-down list. Now, 
move the cursor over the face of the wall; a preview of the wall sweep along with the temporary 
dimensions will be displayed on the wall face. Click at the desired level of elevation; a wall sweep 
will be created, as shown in Figure 3-26. After adding the wall sweeps at desired faces of the 
wall, press ESC, or choose the Modify button from the Select panel to exit from the contextual 
tab. Similarly, you can add a vertical wall sweep at the face of the wall. To create a vertical wall 
sweep, choose the Vertical tool from the Placement panel. 

       Figure 3-25  Invoking the Wall: Sweep tool from the Build panel

After adding the wall sweep to the wall, you can change the properties of the sweep such as its 
profile. To change the profile of the sweep, invoke the Edit Type button from the Properties 
palette; the Type Properties dialog box will be displayed. Now, choose the Duplicate button 
from the upper right corner of this dialog box; the Name dialog box will be displayed. In this 
dialog box, enter the desired name in the Name edit box and choose the OK button to return to 
the Type Properties dialog box. In Type Properties dialog box, you can select the desired wall 
sweep type from the Profile drop-down list by clicking on the value field of the corresponding 
parameter. You can edit the Subcategory of Walls by clicking on the corresponding value field 
of the Type Parameter area.
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Tip
You can add more options to the Type-Selector drop-down list by loading more families of 
profile into the drawings. To load more options, choose the Load Family tool from the Load 
From Library panel of the Insert tab; the Load Family dialog box will be displayed. In this 
dialog box, the predefined family profiles are available in Profiles > Wall folder.

The methods to modify other Type Properties are discussed next 

	 Figure 3-26  Wall sweep added to the wall

Modifying Type Properties
The Type Properties dialog box displays various type parameters of wall sweep such as 
Constraints, Construction, Material and Finishes, and Identity Data. To edit the parameters, 
click in the Value field corresponding to any of the parameters under these heads and then 
specify a desired value to it. To edit the material properties of the wall sweep click in the Value 
field corresponding to the Material parameter: a Browse button will be displayed. Choose the 
Browse button; the Material Browser dialog box will be displayed. You can use various options 
in this dialog box to specify the desired material for the wall sweep. Choose the OK button: the 
Material Browser dialog box will be closed and the specified material will be assigned to the 
wall sweep type. 

Now, to create a copy of the original sweep type you can choose the Duplicate button from the 
top right corner in the Type Properties dialog box. On doing so, the Name dialog box will 
be displayed, and you will be prompted to assign a new name to the duplicate copy. Enter a 
name in this edit box and choose the OK button; a new sweep type is created which inherits 
the properties of the parent sweep type. Now, you can modify its parameters, as desired. The 
Rename button is also available on the top right corner. This button is used to give a new name 
to the selected sweep type without changing its properties.  

Now, you will learn to modify the instance properties of the sweep type.  
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Modifying Instance Properties
You can modify various instance properties of the wall sweep by using the parameters in the 
Properties palette. The modification in these properties results in the change of the properties 
of only that particular instance in the project. The descriptions of various instance parameters 
are given next:

 Instance Parameter Description

Offset From Wall	 Copies or moves a selected element to a specified distance 
from Wall face

Level Level or reference plane of the base of a wall sweep and the 
properties shown only for Horizontal Sweep

Offset From Level Specifies distance of sweep from level 

Length Indicates the length of a wall sweep

Image Specifies the image file corresponding to a wall instance. 
This parameter can be used in the wall schedule to display 
the image of the wall instance.

Comments Describes about the Wall Sweep

Mark Add a mark or label to each sweep

Phase Created Phase in which a wall sweep is created

Phase Demolished Phase in which a wall sweep was demolished

Wall Reveals
Ribbon: 	 Architecture > Build > Wall drop-down > Wall: Reveal

To complete the design of our wall, you need to add decorative cutout in the wall. To do so, you 
can use the wall reveal. To add a wall reveal, you need to be in an elevation view or in 3D view 
and then invoke the Wall: Reveal tool from the Build panel of the Architecture tab, refer to 
Figure 3-27; the Modify | Place Reveal tab will be displayed. In this contextual tab, select the 
desired orientation of the wall reveal by choosing either the Horizontal or Vertical tool from 
the Placement panel. Next, select the type of the wall reveal from the Type Selector drop-down 
list and then move the cursor over the face of the wall; a preview of the wall reveal with the 
temporary dimension will be displayed along the wall face. Click at desired level of elevation; 
a wall reveal will be added, as shown in Figure 3-28. You can add the wall reveal to other walls 
by clicking on their faces. After adding the wall reveal at desired faces of the wall, press ESC 
or choose the Modify button from the Select panel to exit the contextual tab. After adding the 
wall reveal to the wall, you can change the properties of the reveal such as its profile. To change 
the profile of the reveal, invoke the Edit Type button from the Properties palette; the Type 
Properties dialog box will be displayed. Choose the Duplicate button from the upper left corner 
of this dialog box; the Name dialog box will be displayed. In this dialog box, enter the desired 
name in the Name edit box and choose the OK button to return to the Type properties dialog 
box. In this dialog box, you can select the desired Wall Reveal type from the Profile drop-down 
list by clicking on the value field of this dialog box. You can edit the Subcategory of Walls by 
clicking on the corresponding value field in the Type Parameter area. 



3-24			                                  Exploring Autodesk Revit 2018 for Architecture 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Figure 3-27  Invoking the Wall: Reveal 
tool from the Build panel

Figure 3-28  Wall reveal added to the wall

Now, you will learn to modify Type Properties and Instance Properties of the wall reveal.

Modifying Type Properties
To modify the type properties of the selected Wall Reveal type, choose the Edit Type button 
from the Properties palette; the Type Properties dialog box for the selected reveal type will 
be displayed. 
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The Type Properties dialog box displays the value of various parameters of Wall Reveal. The 
various type parameters are described in the following table:

 Parameter Description

Default Setback By default, the default setback value in the edit box is 0’0”. Wall 
reveal changes with the change in the value from positive to 
negative. The setback helps in making reveal type near windows 
and door trims.

Profile Wall reveal is created by the profile family.

Modifying Instance Properties
To modify the instance properties of the selected Wall Reveal type, choose the reveal from the 
drawing window the Properties palette displays the Instance Properties of that reveal type. The 
various instance parameters are described next:

 Instance Parameter Description

Offset From Wall	 Copies or moves a selected element to a specified distance from 
Wall face

Level Level or reference plane of the base of a wall reveal and the 
properties shown only for Horizontal Sweep

Offset From Level Specified distance of reveal from level 

Length Indicates the length of a wall reveal

Tip
Wall sweep and wall reveal type can also be used directly by invoking the Edit Type button 
in the Properties palette of the wall. This dialog box is used only when sweep type or reveal 
is required throughout the building model along with the wall.  

TUTORIALS
The following tutorials are designed to familiarize you with the concepts of invoking the Wall: 
Architectural tool, selecting the wall type, modifying the wall properties, using the sketching 
tools, and sketching a wall with the given parameters.

All the files used in the tutorials can be downloaded from the CADCIM website. These files are 
compressed in zip file format and are required to be extracted before using them in the tutorials. 
The path of the files is as follows: Textbooks > Civil/GIS > Revit Architecture > Exploring Autodesk 
Revit 2018 for Architecture. For example, the tutorial file, c02_Apartment_tut1.rvt that is used in 
Tutorial 1 of Chapter 3 is compressed in the c02_rvt_2018_tut.zip file.

 Tutorial 1							            Apartment 1
In this tutorial, you will create the exterior walls of a two-room apartment based on the sketch 
plan shown in Figure 3-29. The dimensions have been given only for reference and are not to 
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be used in this tutorial. The project file and the parameters to be used for creating the exterior 
walls are given next.     			                               	      (Expected time: 30 min)

1.	 Project file- 
		  For Imperial	 c02_Apartment_tut1.rvt
		  For Metric	 M_c02_Apartment_tut1.rvt
2.	 Exterior wall type- Basic Wall: Exterior - Brick on Mtl. Stud.
3.	 Location line parameter- Wall Centerline; Top Constraint- Up to Level 2.

	 The following steps are required to complete this tutorial:

a. 	 Open the Apartment 1 project file created in Tutorial 1 of Chapter 2. 
b.	 Invoke the Wall: Architectural tool from the ribbon.
c.	 Select the exterior wall type Exterior - Brick on Mtl. Stud from the Properties dialog box.
d.	 Modify Top Constraint- Up to level: Level 2 and Location Line - Wall Centerline 		

as wall properties using the Properties palette, refer to Figure 3-30.
e.	 Invoke the Line sketching tool and then sketch the exterior walls based on the given 

parameters, refer to Figures 3-31 through 3-38.
f.     Save the project using the Save As tool.
		  For Imperial	 c03_Apartment1_tut1.rvt
		  For Metric	 M_c03_Apartment1_tut1.rvt
g.	 Close the project.

Figure 3-29  Sketch plan for creating exterior walls for the Apartment 1 project

   

Opening the Project File
	 Choose Open > Project from the File menu and open the c02_Apartment1_tut1.rvt 

(M_c02_Apartment1_tut1.rvt for Metric) project file. You can also download this file from 
http://www.cadcim.com. The path of the file is as follows: Textbooks > Civil/GIS > Revit Architecture 
> Exploring Autodesk Revit 2018 for Architecture.  

Invoking the Wall: Architectural Tool and Selecting the Wall Type
	 To start sketching the wall, you must invoke the Wall: Architectural tool from the ribbon 

and select the wall type to be used (Exterior - Brick on Mtl. Stud in this case). 

1.	 Invoke the Wall: Architectural tool from Architecture > Build > Wall drop-down; the 
Modify | Place Wall tab is displayed.
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2.	 In the Type Selector drop-down list of the Properties palette, select the Exterior - Brick 
on Mtl. Stud wall type.

Modifying Properties of the Exterior Wall 
	 After selecting the wall type, you need to modify the instance properties of the wall type 

using the Properties palette. 

Note
The default.rte or (DefaultMetric.rte for Metric) template file used for this project has two predefined 
levels: Level 1 and Level 2.

1.	 In the Properties palette, ensure that the Location Line 

Figure 3-30  Setting the Top 
Constraint parameter using the 
Properties palette

parameter has Wall Centerline as the default value. Click 
on the column adjacent to the Top Constraint instance 
parameter; a drop-down list is displayed. Select Up to level: 
Level 2 from this drop-down list, and choose the Apply 
button, as shown in Figure 3-30. 

Tip
If the Properties palette is not displayed in the User 
interface screen by default, select the Properties check box 
from View > Windows> User-Interface drop-down.  

Sketching the First Exterior Wall Segment 
	 To sketch a wall, you need to choose an appropriate 

sketching tool from the Draw panel in the Modify | Place 
Wall tab. The exterior walls of the given sketch of the 
Apartment 1 project can be created using the Rectangle tool. 
You will however use the Line tool to learn and understand 
the usage of this tool for sketching the straight walls. 

1.	 Ensure that the Line tool is chosen in the Draw panel in the Modify | Place Wall tab and  
the Chain check box is cleared in the Options Bar.

2.	 Ensure that the Allow option is selected in the Join Status drop-down list.

3.	 Click between the four inward arrow keys to specify the start point of the first wall segment. 
Next, move the cursor toward the right hand side. On doing so, a wall segment starts from 
the specified point with temporary dimension appearing on it. The dimension changes 
dynamically as you move the cursor. This shows the length of the wall segment at any given 
location of the cursor.

4.	 Right-click in the drawing area; a shortcut menu is displayed. Choose the Zoom In Region 
option from the shortcut menu and zoom into the area to get a closer view of the sketched 
wall segment, as shown in Figure 3-31 (for zooming techniques, refer to Chapter 2- Starting 
an Architectural Project).
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Figure 3-31  The temporary dimensions displayed on the wall

5.	 Move the cursor on the horizontal axis such that a dashed line appears at the central axis 
of the wall segment, as shown in Figure 3-32. Notice the two-sided arrow attached to the 
endpoint of the wall. This indicates that the wall segment being sketched is horizontal. A 
tooltip indicating the horizontal alignment is also displayed with two-sided arrow.

Figure 3-32 Sketching a horizontal wall segment

                               

6.	 Move the cursor to the right until the temporary dimension shows a value more than 
40’- 0”(12192 mm), as shown in Figure 3-33. Click at this location as the endpoint of the 
wall segment and press ESC twice; the wall is created. Note that, if the dimension is not 
displayed, you need to click on the created wall to display the dimension. Press ESC.

Figure 3-33  The sketched horizontal wall with its controls

       

Note
You can create a wall of exactly 40’0”(12192 mm) length using the dimension snaps set in the 
Snaps dialog box. The only purpose of creating a wall of length more than the desired length is 
to explain how to modify the length of the sketched wall to the exact value.

Modifying the Length of the Sketched Exterior Wall
      You will now modify the length of the sketched wall to the actual dimension, as given in the 

Apartment 1 sketch.

1.	 Select the created wall and click on its temporary dimension; an edit box appears showing 
the current dimension of the wall segment. 

2.	 Enter 40’ (12192 mm) in the edit box, as shown in Figure 3-34 and then press ENTER; the 
length of the wall is modified to 40’0”(12192 mm). Press ESC to exit the Modify | Walls 
tab. 
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Figure 3-34  Modifying the length of a wall segment using temporary 
dimensions

           

             
Tip
To exit the current tool, you can also right-click and choose Cancel from the shortcut menu 
displayed.

Note
By default, the exterior faces of the walls drawn from the left to right are on the upper face, and 
those drawn from top to bottom are on the right face. Similarly, the exterior faces of the walls drawn 
from right to left are on the lower face, and those drawn from the bottom to top are on the left side. 
Hence, you can minimize the use of the flip tool by sketching the walls in the appropriate direction.

Sketching Other Exterior Wall Segments
	 In this section, you need to create other exterior wall segments using the Endpoint object 

snap tool.

1.	 Choose the Wall: Architectural tool from Architecture > Build > Wall drop-down. Now, 
bring the cursor close to the right endpoint of the first wall segment. When the cursor shows 
a square box at the endpoint (indicating the Endpoint object snap), as shown in Figure 3-35, 
click to specify the start point of the second wall segment. 

Figure 3-35  Starting a second exterior wall segment using the 
Endpoint object snap option

2.	 As you move the cursor, wall starts to get created dynamically, with one end attached to 
the specified point and the other end attached to the cursor. Move the cursor vertically 
downward. A dashed vertical line is visible inside the wall segment. Now, enter 20’0”(6096 
mm) as the value of the length; an edit box is displayed with the dimension that you have 
entered, as shown in Figure 3-36. Press ENTER; the second wall segment is sketched exactly 
to 20’0”(6096 mm) length.

	 Notice that the intersection of the first and second wall segments has been intuitively filled 
or completed.
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Figure 3-36  Creating the second exterior wall segment

3.	 To draw the third wall segment, select the Chain check box from the Options Bar. 

4.	 Move the cursor close to the endpoint of the second wall segment and click when the endpoint 
object snap is displayed. On doing so, the third wall segment starts from this specified point. 
Move the cursor horizontally toward the left. Now, hold the SHIFT key while moving the 
cursor. 

	 Notice that the cursor can now move only in the orthogonal directions (in the horizontal 
and vertical direction). When the length of the wall segment is around 40’0”(12192 mm), a 
vertical dashed line originates from the start point of the first wall segment. The alignment 
line shows the point on the third wall segment that is in plumb with the first point. An 
intersection snap symbol indicated by an X appears at this point, as shown in Figure 3-37. 

Figure 3-37  Creating the third wall segment

5.	 Click to specify the location of the endpoint of the third wall segment when the intersection 
snap symbol is displayed. 

6.	 As you have enabled the Chain option, the next wall segment automatically starts from the 
last specified point. Move the cursor vertically upward and enter 25’(7620 mm), as shown 
in Figure 3-38, and then press ENTER. The fourth wall segment is created.
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Figure 3-38  Sketching the fourth exterior wall segment

7.	 Press ESC twice to exit the Wall: Architectural tool. 

Note
The purpose of creating a wall more than the desired length is only to explain how to stretch the 
wall to the exact length.

Stretching the Wall Segment 
	 You will now stretch the wall segment to change its length to the desired dimension by using 

the drag controls. 

1.	 Select the fourth wall segment to display its controls. The two blue dots at its two endpoints 
are the drag controls. Move the cursor near the upper dot; the color of the drag control 
symbol changes, as shown in Figure 3-39. Press and hold the left mouse button at this point 
and drag the cursor vertically downward and bring it close to the start point of the first wall 
segment. On doing so, the endpoint object snap is displayed at the intersection of two walls 
and the tooltip shows Endpoint and Vertical.

Figure 3-39  Using the drag control to modify the length of wall

2.	 Release the left mouse button at the intersection point and click; the first and fourth wall 
segments are joined at the corner with their ends completed. 
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	 Note that if these wall segments do not join at the corner on releasing the left mouse button, 
you need to click at their intersection. 

3.	 Press ESC to remove the wall segment from the selection set. The external wall profile is 
completed for this tutorial, as shown in Figure 3-40.

Figure 3-40  The completed exterior wall profile

 

Saving the Project
       In this section, you will save the project file using the Save As tool.

1.	 Choose Save As > Project from the File menu; the Save As dialog box is displayed. 
Create a folder with the name c03_revit_2018_tut and then save the file with the name 
c03_Apartment1_tut1 (M_c03_Apartment1_tut1).

2.	 Choose the Close option from the File menu; the file is closed.

Tutorial 2			                                                    Club
Create the exterior walls of the club building and it’s sketch plan is shown in Figure 3-41. The 
dimensions have been given only for reference and are not to be used in this tutorial. The 
parameters to be used for creating the exterior walls of the club building are given next.	         	
								             (Expected time: 30 min)
1.	 Project file- 
		  For Imperial	 c02_Club_tut2.rvt
		  For Metric	 M_c02_Club_tut2.rvt
2.	 Exterior wall type- Exterior - Split Face and CMU on Mtl. Stud.
3.	 Unconnected height of walls- 15’0” (4572 mm).
4.	 All inclined walls are at 45-degree to the horizontal axis.
	
      The following steps are required to complete this tutorial:
a. 	 Open the project file. 
		  For Imperial	 c02_Club_tut2.rvt
		  For Metric	 M_c02_Club_tut2.rvt



Creating Walls						                        3-33

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

b.	 Invoke the Wall: Architectural tool.
c.	 Select the exterior wall type: 
		  For Imperial	 Exterior - Split Face and CMU on Mtl. Stud
		  For Metric	 Exterior - Brick on Mtl. Stud
d.	 Set the unconnected height to 15’0” or 4572mm.
e.	 Change the Location Line parameter to Finish Face: Exterior, refer to Figure 3-41.
f.	 Select the Line sketching option and sketch the inclined wall profile using the Chain option, 

refer to Figures 3-43 through 3-49.
g.	 Use the Center-ends Arc sketching option to create the curved wall, refer to Figures 3-46 

and 3-47. 
h.    Save the project using the Save As tool.
		  For Imperial	 c03_Club_tut2.rvt
		  For Metric	 M_c03_Club_tut2.rvt
i.	 Close the project.

Figure 3-41  Sketch plan for the Club project

Opening an Existing Project 
 	 Choose Open > Project from File menu and open the c02_Club_tut2.rvt (M_c02_Club_tut2.

rvt for Metric) project file created in Tutorial 2 of Chapter 2. You can also download this file 
from http://www.cadcim.com. The path of the file is as follows: Textbooks > Civil/GIS > Revit 
Architecture> Exploring Autodesk Revit 2018 for Architecture.

Invoking the Wall: Architectural Tool and Selecting the Wall Type
	 First, you will invoke the Wall: Architectural tool from the ribbon and then select the 

specified exterior wall type, as given in the project parameters.

1.	 Choose the Wall: Architectural tool from the Architecture > Build > Wall drop-down; 
the Modify | Place Wall tab is displayed.

2.	 In the Properties palette, select the required option from the Type Selector drop-down 
list. 
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		  For Imperial	 Exterior - Split Face and CMU on Mtl. Stud
		  For Metric	 Exterior - Brick on Mtl. Stud

Modifying Properties of the Exterior Wall
	 Next, you will use the Properties palette to modify the unconnected height to 15’0” or 

4572mm. The dimensions given in the sketch are exterior wall face dimensions. Therefore, 
you need to set the Location Line parameter to Finish Face: Exterior. 

1.	 In the Properties palette, click in the value field corresponding to the Unconnected Height 
parameter and replace the current value with 15’0” (4572mm).

2.	 Click in the value field of the LocationLine parameter and select the Finish Face: Exterior 
option from the drop-down list displayed, as shown in Figure 3-42. Choose the Apply button 
to accept the specified values.

Figure 3-42  Selecting the Finish Face : Exterior 
option for the Location Line parameter 

Sketching the Inclined Exterior Walls
	 Start creating the exterior wall profile by first sketching the inclined walls in a sequence such 

that the exterior face of the wall is on the external side. You need to select the Chain check 
box to sketch the continuous wall profile. Once you have created the first inclined wall, the 
other parallel and perpendicular walls can easily be created using the alignment lines and 
different object snaps options. 

1.	 To create the straight wall, choose the Line tool in the Draw panel of the Modify | Place 
Wall tab, if it is not chosen by default.

2.	 In the Options Bar, select the Chain check box, if it is not selected. Also, select the Allow 
option from the Join Status drop-down list.



Creating Walls						                        3-35

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

3.	 To start sketching the first inclined wall segment, click inside the four arrow keys in the 
drawing window and move the cursor upward toward the right and then move it to an 
inclination such that the angle subtended at the horizontal axis is 45 degrees.

4.	 Enter the value 14’ (4267 mm) to specify the length of the first wall segment; the value 
is displayed in the edit box, as shown in Figure 3-43. Press ENTER to create the first wall 
segment of the specified length.

5.	 As the Chain check box is selected in the Options Bar, the second wall segment will start from 
the last specified point. Now, move the cursor downward toward the right and right-click to 
invoke the shortcut menu. Next, choose Snap Overrides > Perpendicular from the shortcut 
menu displayed; the perpendicular snap symbol appears at the end of the wall. Enter 
60’(18288 mm), see Figure 3-44; a wall is created perpendicular to the first inclined wall.

Figure 3-43  Sketching the first inclined wall 
segment

Figure 3-44  Sketching the second inclined wall 
segment

6.	 Similarly, for creating the next wall, move the cursor downward to the left and choose the 
perpendicular snap override as in step 5. Enter 40’(12192 mm) as length, as shown in 
Figure 3-45. Now, press ENTER to create the third inclined wall. 

7.	 To create the next wall, move the cursor upward toward the left and invoke the perpendicular 
snap override as in step 5. Enter 60’ (18288 mm) as the length of the wall segment and 
press ENTER to create the fourth inclined wall segment, as shown in Figure 3-46.

Figure 3-45  Sketching the third inclined wall 
segment

Figure 3-46  Sketching the fourth inclined wall 
segment
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8.	 Similarly, create the fifth inclined wall segment of 60’(18288 mm) length, as shown in 
Figure 3-47.

9.	 Next, create the connected wall segment of 40’(12192 mm) length, as shown in Figure 3-48.

Figure 3-47  Sketching the fifth inclined wall 
segment

Figure 3-48  Sketching the sixth inclined wall 
segment

10.	 Now, create the next two wall segments of lengths 60’(18288 mm) and 14’(4267 mm) to 
complete the inclined wall exterior profile, as shown in Figure 3-49.

Figure 3-49 The sketched inclined wall exterior profile

11.	 Press the ESC key to discontinue the wall at this point and finish sketching the inclined walls.

Sketching the Curved Exterior Wall
	 Next, you will sketch the curved exterior wall profile based on the given parameters. You 

need to use the Center-ends Arc tool to create the curved wall segment.

1.	 Choose the Center-ends Arc tool in the Draw panel of the Modify | Place Wall tab. Move 
the cursor in the drawing window and click on the outer intersection of the inclined walls 
to specify the center of the curved wall, refer to Figure 3-50. 

                                 
2. 	 Move the cursor near the endpoint of the last sketched inclined wall segment. When 

135-degree is displayed as the angular dimension, enter the value 27’ (8100 mm) as the 
radius of the curved wall and press ENTER, as shown in Figure 3-50. On doing so, the 
curved wall with the specified radius starts from the specified point.

Note
While tracking the wall, if the perpendicular or other snapping symbol does not appear, you 
can right-click and choose Snap Overrides; a cascading menu will be displayed. Choose 
any snapping option from the cascading menu. On doing so, the desired snapping symbol will 
appear for the specified point or action. 
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3.	 Move the cursor toward the right and click when the cursor snaps to the endpoint of the 
inclined wall, as shown in Figure 3-51. Now, press ESC twice to complete the exterior wall 
profile, as shown in Figure 3-52.

 

Figure 3-50  Starting the curved wall segment Figure 3-51  Completing the curved wall 
segment

Figure 3-52  Completed layout of the exterior walls for the Club project

4.	 Choose the Default 3D View tool from View > Create > 3D View drop-down; a 3D view 
of the building model is displayed, as shown in Figure 3-53. 

Figure 3-53  3D view of the completed exterior wall profile

5. 	 From View Control Bar, choose the Visual Style button; a flyout is displayed. Choose the 
Shaded option from the flyout.

                           
6.	 Under the Floor Plans head in the Project Browser, double-click on Level 1 to return to 

the plan view.
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Saving the Project
       In this section, you will save the project file using the Save As tool.

1.	 Choose Save As > Project from File menu; the Save As dialog box is displayed. Now, browse 
to the folder c03_revit_2018_tut and enter c03_Club_tut2 (M_c03_Club_tut2 for Metric) 
and choose Save.

2.	 Choose the Close option from the File menu; the file is closed. 

Tutorial 3			                 Apartment 1 - Interior Walls 

In this tutorial, you will add interior walls to the apartment plan created in Tutorial 1 of this chapter.  
The interior walls to be created are the intermediate walls among various rooms, as shown in the 
plan sketch in Figure 3-54. The dimensions and text have been given for reference and are not to be 
created. The project file name and the parameters to be used for different elements are given next. 
								             (Expected time: 30 min)   
1.   Project file- 
		  For Imperial	 c03_Apartment1_tut1.rvt
		  For Metric	 M_c03_Apartment1_tut1.rvt
2.  	 Interior wall type- Interior - 5” Partition (2-hr).
3.	 Location line parameter- Wall Centerline.  
                     
	 The following steps are required to complete this tutorial:

a.	 Open the Apartment 1 project file created earlier in this chapter.
b.	 Invoke the Wall: Architectural tool and select the required interior wall.
		  For Imperial	 Interior - 5” Partition (2-hr)
		  For Metric	 Interior - 135mm Partition (2-hr)
c.	 Set the location line parameter as Location Line- Wall Centerline.
d.	 Select the Line sketching tool to sketch the straight walls. 
e.	 Sketch the interior walls based on the given parameters, refer to Figures 3-56 through 

Figure 3-62.
f.	 Edit the interior walls location to achieve clear internal distances, refer to Figures 3-63 and 

Figure 3-65.
g.   Save the project using the Save As tool.
		  For Imperial	 c03_Apartment1_tut3.rvt
		  For Metric	 M_c03_Apartment1_tut3.rvt
h.	 Close the project.
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Figure 3-54  Layout of internal walls for Apartment 1 project

Opening the Project and Invoking the Wall: Architectural Tool
1.	 Choose Open > Project from the File menu and open the c03_Apartment1_tut1.rvt (M_ 

c03_Apartment1_tut1.rvt) project created earlier in this chapter. You can also download this 
file from http://www.cadcim.com. The path of the file is as follows: Textbooks > Civil/GIS > Revit 
Architecture > Exploring Autodesk Revit 2018 for Architecture.

2.	 Invoke the Wall: Architectural tool from Architecture>

Figure 3-55  Selecting the Basic 
Wall: Interior - 5”Partition 
(2-hr) wall type 	

 
Build > Wall drop-down. 

Selecting the Interior Wall Type
1.	 On invoking the Wall: Architectural tool, the wall instance 

parameters are displayed in the Properties palette. 
In this palette, select the required option from the 
Type Selector drop-down list, as shown in Figure 3-55. 

		  For Imperial	  Interior-5” Partition (2-hr)
		  For Metric	 Interior - 135 mm Partition (2-hr)

2.	 In the Options Bar, select the Wall Centerline option 
from the Location Line drop-down list, if it is not selected 
by default. Also, clear the Chain check box and select the 
Allow option from the Join Status drop-down list in the 
Options Bar.

Sketching the First Interior Wall                   
	 After selecting the interior wall type, start sketching the 

interior walls. Notice that the Line tool is chosen as the 
default tool for sketching the walls.

1.	 Move the cursor near the top right endpoint of the wall 
structure and start moving the cursor toward left along 
the top horizontal wall. You will notice that a temporary 
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dimension appears which changes dynamically as you move the cursor away from it. This 
dimension shows the distance of the cursor from the nearest wall segment.

2.	 Type 15’(4572 mm) from the keyboard, as shown in Figure 3-56. Now, press ENTER; the 
starting point of the first interior wall is specified.

 
3.	 Next, move the cursor vertically downward near the lower exterior wall segment. When the 

Vertical and Nearest symbol appears, as shown in Figure 3-57, click to specify the location of 
the endpoint of the wall segment; the first interior wall segment is sketched.

Sketching Other Interior Walls
	 Next, you will sketch the other horizontal and vertical interior walls by specifying their start 

point and endpoint using different object snap options.

 

Figure 3-56  Specifying the distance for starting the first interior wall segment

            

Figure 3-57  Specifying the endpoint of the first interior wall segment

1.	 To sketch the second interior wall, move the cursor to the upper endpoint of the interior 
wall you just created and then move the cursor horizontally toward the left. When the 
temporary dimension and the intersection object snap appears, enter 7’6”(2286 mm), as 
shown in Figure 3-58. Now, press ENTER; the start point of the second interior wall segment 
is specified on the upper horizontal exterior wall.
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Figure 3-58  Specifying the starting point of the second interior wall 

          

2.	 Press SHIFT and move the cursor downward. You will notice that the cursor moves parallel 
to the vertical axis while moving it downward. Click near the lower external wall when the 
Vertical and Nearest symbol appears, as shown in Figure 3-59.

	 Next, you will sketch the interior walls of the bath. Since the internal dimensions have been 
provided for the interior walls, you will first sketch them using the wall center lines and later 
move them to get the exact clearance distance of the walls.

Figure 3-59  Sketching the second interior wall

3.	 Move the cursor to the lower left corner and then move it vertically upward. When the 
temporary dimension appears, enter 7’0”(2134 mm) and then press ENTER to specify the 
starting point of the third interior wall, as shown in Figure 3-60.

Figure 3-60  Specifying the distance for sketching 
the third internal wall
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4.	 Press SHIFT and move the cursor horizontally toward the right until it reaches the first 
vertical interior wall. When the Horizontal and Nearest object snap symbol appears, click 
to specify the location of the endpoint of the third interior wall, as shown in Figure 3-61, 
the wall segment is created.

	 Figure 3-61  Sketching the third interior wall segment

5.	 Similarly, move the cursor near the lower left corner and then move it horizontally toward the 
right. When the temporary dimension and the intersection object snap appears, enter the 
value 10’0”, as shown in Figure 3-62, and then press ENTER.

6.	 Press and hold the SHIFT key and move the cursor vertically upward until it reaches the 
horizontal interior wall. When the Vertical and Nearest symbol appears, click to specify the 
endpoint of the wall. Now, press ESC twice to finish the sketch of the wall. 

                 

                        Figure 3-62  Sketching the interior walls of the bath

Moving Walls Using Witness Lines
	 As the dimension of the bath walls will be measured from the centerline of the external 

walls, you need to move the interior walls such that the internal dimensions are 7’0”X10’0” 
as specified in the sketch. Use the witness lines and specify these dimensions. 

1.	 Select the last created interior wall from the drawing; the selected interior wall shows the 
centerline distances and its controls.

2.	 Three blue dots define the extents of the dimensions. Click on the dot on the extreme left; 
the dot and the dimension witness line move to the interior face of the exterior wall, as 
shown in Figure 3-63.
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3.	 Similarly, click twice on the next blue dot on the right to move it to the inner face of the 
third interior wall.

4.	 Now, click on the temporary dimension, enter the value 10’(3048 mm), and then press 
ENTER; the interior wall is moved to the desired distance 10’-0” from the interior face of 
the exterior wall, as shown in Figure 3-64. 

      
       

Figure 3-64  The adjusted inner wall 
distance   

   Figure 3-63  The square dot moved

5.	 Similarly, to move the horizontal interior wall (common for the bath, kitchen and the closet), 
select it and move both the witness lines toward the inner face by clicking on the blue dots.

6.	 Now, click on the  blue dots of temporary dimension from the lower external wall and the 
upper interior wall. Enter the value 7’(2134 mm), as shown in Figure 3-65, and press ENTER. 
On doing so, the interior wall is moved to the desired location. Now, press ESC to exit the 
Modify | Walls tab.

	 This completes the interior wall layout for the Apartment 1 project, refer to Figure 3-65.

Figure 3-65  Entering the value to adjust the dimension of the horizontal 
interior wall

7.	 To view the building model in 3D, choose the Default 3D View tool from View > Create > 3D 
View drop-down. On doing so, the 3D view of the building model is displayed alongwith 
the ViewCube tool. 
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8.	 Now, choose the Visual Style button from the View Control Bar; a flyout is displayed. 
Choose the Shaded option from this flyout; the 3D view is displayed with the shading and 
edges visible, as shown in Figure 3-66.  

Figure 3-66  3D view of the Apartment 1 building model

Saving the Project
       In this section, you will save the project file using the Save As tool.

1.	 Choose Save As > Project from File menu; the Save As dialog box is displayed. Now, browse 
to the folder c03_revit_2018_tut and enter c03_Apartment1_tut3 (M_c03_Apartment1_
tut3) in the File name edit box and then choose Save.

2.	 Choose the Close option from the File menu; the file is closed.

Tutorial 4					               Club - Interior Walls
Create the interior walls of the left portion of the club building whose exterior wall profile was 
created in Tutorial 2 earlier in this chapter. Create the walls based on the sketch plan shown in 
Figure 3-67. The dimensions are given for the centerlines of the walls and are displayed only 
for the purpose of drawing. You do not need to dimension or add text to the building. The 
project file name and the parameters to be used for different elements are given below.         	
								             (Expected time: 30 min)
1.   Project file- 
	 For Imperial	 c03_Club_tut2.rvt
	 For Metric	 M_c03_Club_tut2.rvt
2.	 Interior wall type - 
		  For Imperial	 Interior - 6 1/8” Partition (2-hr).
		  For Metric	 Interior - 138mm Partition (1-hr).
3.	 Unconnected height of walls- 12’0”(3658 mm).



Creating Walls						                        3-45

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

4.	 Location Line- Wall Centerline.
5.	 Inclined walls are parallel to the external walls and perpendicular to each other.
	

Figure 3-67  Sketch plan for creating the interior wall of the left 
portion of the Club project

	 The following steps are required to complete this tutorial:

a.	 Open the project file. 
		  For Imperial	 c03_Club_tut2.rvt
		  For Metric	 M_c03_Club_tut2.rvt
b.	 Invoke the Wall: Architectural tool and select the required wall type, refer to Figure 3-68.
		  For Imperial	 Interior - 6 1/8” Partition (2-hr).
		  For Metric	 Interior - 138mm Partition (1-hr).
c.	 Set the unconnected height to 12’0”(3658 mm). 
d.	 Ensure that the location line parameter is set to Wall Centerline.
e.	 Select the Line sketching option to create the straight walls.
f.	 Sketch the interior walls based on the given parameters, refer to Figures 3-69 through 3-75.
g.    Save the project using the Save As tool.
		  For Imperial	 c03_Club_tut4.rvt
		  For Metric	 M_c03_Club_tut4.rvt
h.	 Close the project.

Opening the Existing Project and Invoking the Wall: Architectural tool
1.	 Open the c03_Club_tut2.rvt (M_c03_Club_tut2.rvt) project file by choosing Open > Projects 

from the File menu. You can also download this file from http://www.cadcim.com. The path 
of the file is as follows: Textbooks > Civil/GIS > Revit Architecture > Exploring Autodesk Revit 
2018 for Architecture.

2.	 Click twice on Level 1 under the Floor Plans head in the Project Browser and invoke the                            
Wall: Architectural tool from Architecture > Build > Wall drop-down. 
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Selecting the Interior Wall Type
	 Before creating the interior walls, you need to select 

Figure 3-68  Selecting the interior 
wall type from the Properties palette

the wall type using the Properties palette. 
	
1.	 Select the required option from the Type Selector 

drop-down list in the Properties palette, as shown in 
Figure 3-68.

	 For Imperial   Interior - 6 1/8” Partition (2-hr).
	 For Metric	    Interior - 138mm Partition (1-hr)

2.	 Click in the value field corresponding to the Top 
Constraint parameter to display a drop-down list and 
ensure that the Unconnected option is selected in it. 

3.	 Next, click on the value field corresponding to the 
Unconnected Height parameter, and replace the 
current value by entering the new value 12’0” (3658 
mm) in the cell.

4.	 Choose the Apply button to apply the changes made.

Sketching the Interior Walls
	 The interior walls to be created are straight in nature. 

Therefore you can use the Line tool from the Draw 
panel to create them. 

1.	 Make sure that the Wall Centerline option is selected from the Location Line drop-down 
list in the Options Bar.

2.	 Clear the Chain check box in the Options Bar, if it is selected. Ensure that the Allow option 
is selected in the Join Status drop-down list.

3.	 Move the cursor close to the lower left corner, marked as 6, refer to Figure 3-69, and traverse 
upward along the centerline of extreme left wall of the building profile. When the temporary 
dimension appears, enter the value 10’(3048 mm) and press ENTER to start the interior 
wall profile from the specified point, as shown in Figure 3-69.

Figure 3-69  Specifying the start point of the first interior wall 
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4.	 Move the cursor 45 degrees upward to the right. When a dashed line appears, enter the 
value 59’(17983 mm), as shown in Figure 3-70 and then press ENTER.   

	     Figure 3-70  Sketching the first interior wall of the Club project

5.	 Start the next wall from the endpoint of the last created wall by clicking on its endpoint. 
Move the cursor upward toward the left such that it subtends an angle of 135 degrees with 
the horizontal and reaches the exterior wall displaying the Nearest object snap, as shown 
in Figure 3-71. Click to specify the endpoint of the wall.

 
6.	 Similarly, to start the next interior wall, bring the cursor close to the starting point of the 

last created wall (marked as 10), refer to Figure 3-71. Then, move the cursor away along 
the centerline of the wall until the temporary dimension appears. When the temporary 
dimension appears, enter the value 10’0”(3048 mm) and press ENTER to specify the start 
point of the wall.

               Figure 3-71  Sketching the second interior wall

7.	 Move the cursor upward toward the left such that it subtends an angle of 135 degrees with 
the horizontal until it reaches the exterior wall and the Nearest object snap is displayed, as 
shown in Figure 3-72. Click to specify the endpoint of the wall. 

8.	 Create the next wall by moving the cursor away from the specified point. Next, move it 
downward toward the right. When the temporary dimension appears, enter the value 9’(2743 
mm) and press ENTER to start the wall, as shown in Figure 3-73. 
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Figure 3-72  Sketching the third interior wall Figure 3-73  Specifying the distance of the 
fourth interior wall 

9. 	 Move the cursor upward toward the right. Click on the exterior wall to specify the endpoint 
of the interior wall when the Nearest object snap is displayed.

10.	 To create the next wall, bring the cursor close to the midpoint of the first interior wall until 
the Midpoint object snap appears, as shown in Figure 3-74. Click on the drawing to start 
the wall.

11.	 Move the cursor up toward the left upto the exterior wall such that it subtend an angle of 
135 degrees with the horizontal and click when the Nearest object snap appears on the 
exterior wall, as shown in Figure 3-75. Click to specify the endpoint; the wall is created.

       This completes the interior wall layout for the left portion of the Club project.
 
 

Figure 3-74  Starting the fifth interior wall from 
the midpoint of the first interior wall

Figure 3-75  Completing the interior walls

12.	 Choose the Modify button to exit the tool selection.

Saving the Project
       In this section, you will save the project file using the Save As tool.

1.	 Choose Save As > Project from File menu; the Save As dialog box is displayed. Now, browse 
to the folder c03_revit_2018_tut and enter c03_Club_tut4 (for Metric M_c03_Club_tut4) 
in the File name edit box and then choose Save.

2.	 Now, choose Close from File menu to close the file.
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Tutorial 5			                           House-Stacked Wall  	
In this tutorial, you will create stacked walls and also add interior walls to the house plan.  The 
interior walls to be created are the intermediate walls of the rooms, as shown in the plan sketch 
in Figure 3-76. The dimensions and text have been given for reference and are not to be created. 
The project file name and the parameters to be used for different elements are given next. 
					     			        (Expected time: 45 min)   
1.   Project file-  
		  For Imperial	 default.rte
	 For Metric	 DefaultMetric.rte
2.  	 Interior wall type- 
		  For Imperial	 Interior - 5 1/2” Partition (1-hr)
		  For Metric	 Interior - 138 mm Partition (1-hr)
3.	 Location line parameter- Wall Centerline.  

Figure 3-76  Layout of internal walls for House project

	 The following steps are required to complete this tutorial:

a.	 Open the project file.
		  For Imperial	 default.rte
		  For Metric	 DefaultMetric.rte
b.	 Invoke the Wall: Architectural tool and select the required wall type from the Type Selector 

drop-down list.
		  For Imperial	 Stacked Wall Exterior - Brick over CMU w Metal Stud
		  For Metric	 Render on Brick on Block w Metal Stud
c.	 Edit the wall type as Stacked wall Exterior- EIFS over CMU w Metal Stud. 
d.	 Set the location line parameter as Location Line- Wall Centerline.
e.	 Select the Rectangle sketching tool to sketch the exterior walls. 
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f.	 Sketch the interior walls based on the given parameters.
g.	 Edit the interior walls location to achieve clear internal distances.
h.    Save the project using the Save As tool.
		  For Imperial	 c03_Office_tut5.rvt
		  For Metric	 M_c03_Office_tut5.rvt
i.	 Close the project using the Close tool.

Opening a New Project 
1.	 Choose New > Project from File menu; the New Project dialog box is displayed.

2.	 In this dialog box, choose the Browse button; the Choose Template dialog box is displayed.

3.	 In the Choose Template dialog box, select the required template file. 
		  For Imperial	 default.rte
		  For Metric	 DefaultMetric.rte
	 Then, choose the Open button; the selected template file is loaded in the New Project 

dialog box.

4.	 Now, choose the OK button; the selected template file is loaded.

Invoking the Wall: Architectural Tool and Selecting the Wall Type
	 In this section, you will create a stacked wall type.

1.	 Choose the Wall: Architectural tool from Architecture > Build > Wall drop-down; the 
Modify | Place Wall tab is displayed.

2.	 In the Properties palette, select the required option from the Type Selector drop-down 
list. 

		  For Imperial	 Stacked Wall Exterior - Brick Over CMU w Metal Stud
		  For Metric	 Stacked Wall Exterior - Brick Over Block w Metal Stud

Modifying Exterior Wall Type
	 In this section, you will use the Type Properties dialog box to edit the wall type and the 

Properties palette to modify the unconnected height to 12’0”(3600 mm). 

1.	 In the Properties palette, choose the Edit Type button; the Type Properties dialog box is 
displayed. 

2.	 In this dialog box, choose the Duplicate button; the Name dialog box is displayed. Enter 
required name in the Name edit box.

		  For Imperial	 Exterior- EIFS Over CMU w Metal Stud 
		  For Metric	 Exterior- Render on Brick on Block w Metal Stud 
	 Then, choose the OK button.

3.	 Choose the Edit button corresponding to the Structure parameter; the Edit Assembly 
dialog box is displayed.

4.	 In this dialog box, click on the first row under the value field of the Name column and select 
the required option from the drop-down list displayed.
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		  For Imperial	 Exterior- EIFS on Metal Stud
		  For Metric	 Exterior- Render on Brick on Block
	 Ensure that Variable is selected under the Height column.

5.	 Similarly, click on the second row under the value field of the Name column and select the 
required option from the drop-down list displayed and enter the height as 5’ (1524 mm) 
under the Height column.

		  For Imperial	 Exterior- CMU on Metal Stud
		  For Metric	 Exterior- Block on Metal Stud

6.	 Choose the Preview button to view the wall type; a preview pane is displayed.

7.	 Now, choose the OK button from the Edit Assembly dialog box and the Type Properties 
dialog boxes to close them. 

8.	 In the Properties palette, click in the value field corresponding to the Unconnected Height 
parameter and replace the current value with 12’0”(3600 mm).

9.	 Click in the value field of the Location Line parameter and select the Finish Face: 
Exterior option from the drop-down list displayed. Choose the Apply button to accept the 
specified values.

Sketching the Exterior Walls
	 In this section, you will learn to create the exterior walls. 

1.	 To create the exterior wall, choose the Rectangle tool from the Draw panel of the Modify 
| Place Wall tab, if it is not chosen by default.

2.	 To start sketching the first inclined wall segment, click inside the four arrow keys in the 
drawing window and move the cursor downward toward the right and click again; a rectangle 
is created with temporary dimensions displayed along with it, as shown in Figure 3-77.

Figure 3-77  Rectangle drawn with its temporary dimensions

3.	 Press ESC twice to exit the currently selected tool.
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4.	 Now, select the upper horizontal wall; the Modify| Stacked Wall tab is displayed.

5.	 In the Options Bar, choose the Activate Dimensions button; the dimensions are activated 
for vertical side.

6.	 Click on the vertical temporary dimension and enter 45’ (13716 mm) in the edit box 
displayed, as shown in Figure 3-78 and press ENTER.

Figure 3-78  Entering vertical dimension in the edit box

7.	 Now, select the right wall and then activate the dimension using the Activate Dimension 
button from the Options Bar.

8.	 Click on the horizontal temporary dimension and enter 60’(18288 mm) for the horizontal 
wall, as shown in Figure 3-79. Press ENTER.

Figure 3-79  Entering horizontal dimension in the edit box
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Selecting the Interior Wall Type            
	 Before creating the interior walls, you need to select the wall type using the Properties 

palette. 
	
1.	 Choose the Wall: Architectural tool from 

Figure 3-80  Selecting the interior 
wall type from the Properties palette

Architecture > Build > Wall drop-down. 

2.	 Select the required option from the Type Selector 
drop-down list in the Properties palette, as shown 
in Figure 3-80.

	 For Imperial  Interior - 5 1/2” Partition (1-hr)	
	 For Metric     Interior- 138mm Partition (1-hr)

3.	 Click in the value field corresponding to the Top 
Constraint parameter to display a drop-down 
list and ensure that the Unconnected option is 
selected in it. 

4.	 Next, click on the value field corresponding to the 
Unconnected Height parameter, and replace the 
current value by entering the new value 12’(3658 
mm)  in the cell.

5.	 Choose the Apply button to apply the changes 
made.

                                                
Sketching Interior Walls
	 In this section, you will sketch the horizontal and vertical interior walls by specifying their 

start point and endpoint using different object snap options.
             
1.	 To sketch the interior wall, move the cursor to the upper left corner of the exterior wall and 

then move the cursor horizontally toward the right. Enter 13’(3962 mm) in the edit box 
as shown in Figure 3-81, when the temporary dimension and the intersection object snap 
appears. Now, press ENTER; the start point of the interior wall segment is specified on the 
upper horizontal exterior wall.

           
2.	 Press SHIFT and move the cursor downward. You will notice that the cursor moves parallel 

to the vertical axis while moving it downward. Click near the lower exterior wall, as shown 
in Figure 3-82 when the Vertical and Nearest symbol appears.

	 Next, you will sketch the other interior walls. 
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Figure 3-81  Entering the value in the edit box

Figure 3-82  Straight wall created till the lower exterior wall

3.	 Move the cursor to the bottom of the wall just drawn and then move it vertically upward. 
When the temporary dimension appears, enter 5’0”(1524 mm) and then press ENTER; the 
starting point of the third interior wall is specified, as shown in Figure 3-83.
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Figure 3-83  Specifying the starting point of third interior wall

4.	 Press SHIFT and move the cursor horizontally toward the right. When temporary dimension 
appears, enter 13’(3962 mm) and then press ENTER; the wall segment is created.

5.	 Now, move the cursor vertically upward and click on the upper exterior wall, as shown in 
Figure 3-84.

Figure 3-84  The wall created extended upto the upper exterior wall
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6.	 Move the cursor near the upper right corner and then move it vertically downward. When 
the temporary dimension and the nearest object snap appear, enter the value 10’0”(3048 
mm) and then press ENTER.

7.	 Press and hold the SHIFT key and move the cursor horizontally toward left until it reaches the 
vertical interior wall. Next, click to specify the endpoint of the wall, as shown in Figure 3-85. 
Now, press ESC twice to finish the sketch of the wall.

Figure 3-85  Horizontal wall created at the distance of 10’ from the 
outer exterior wall

                          

8.	 Similarly, sketch other walls, as shown in Figure 3-86.

Figure 3-86  Other interior walls for the project
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9.	 To view the building model in 3D, choose the Default 3D View tool from View > Create 
> 3D View drop-down. On doing so, the 3D view of the building model is displayed along 
with the ViewCube tool. 

10.	 Now, choose the Visual Style button from the View Control Bar; a flyout is displayed. 
Choose the Shaded option from this flyout; the 3D view is displayed with shading and with 
edges visible, as shown in Figure 3-87.  

Saving the Project
       In this section, you will save the project file using the Save As tool.

1.	 Choose Save As > Project from File menu; the Save As dialog box is displayed. Enter 
c03_office_tut5 in the File name edit box and then choose Save.

Figure 3-87  3D view of a building with the shaded edges 

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which value of the Structural Usage parameter will turn a structural wall into an architectural 
wall? 

		  a) Bearing 				    b) Non-bearing 
		  c) Structural combined			   d) Shear 

2.	 A stacked wall is comprised of one or more ________ wall types. 

	 a)  Generic 				    b) Simple 
	 c)  Basic 				    d) Complex

3.	 You can use the _________ to view the instance parameters of an element.

		  a)  Properties palette 			   b) Project Browser 
		  c)  Filter 				    d) Type Selector
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4.	 The __________ option enables you to sketch continuous and end to end connected wall 
segments.

5.	 To create a wall starting at a specified distance from a point on an existing element, you can 
use the __________ option from the Options Bar.

6.	 You can select a wall type from the __________ drop-down list.

7.	 You can modify the instance properties of a wall type in the Properties palette. (T/F)

8.	 When you modify the instance properties of a wall, the instance properties of all the similar 
wall types used in the project are modified. (T/F)

9.	 You can create a wall type of your choice by combining various layers. (T/F)

10.	 By default, when you sketch a wall from left to right, the lower face becomes the external 
face. (T/F)

Review Questions
Answer the following questions:

1.	 Which of the following sketching tools can be used to create a straight wall?

		  a) Lines				    b) Circles
		  c) Fillet Arc		  		  d) Center-ends Arc

2.	 Which of the following keys can be used to constrain the cursor such that it moves along the 
orthogonal direction only?

		  a) TAB					     b) SHIFT
		  c) ALT					     d) F3	

3.	 Which of the following sketching tools can be used to create a curved wall? 

		  a) Polygon				    b) Line
		  c) Fillet Arc		  		  d) Rectangle

4.	 The __________ dimension appears after you specify the start point of a wall and move the 
cursor.

5.	 You can use the __________ option to create a curved wall by specifying the center and the 
endpoints.

6.	 The Location Line parameter is an instance property of a wall. (T/F)

7.	 The value of the Function parameter in the Type Properties dialog box for an exterior wall 
is Exterior. (T/F)
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8.	 You can add or delete layers of a composite wall type to create a new wall type. (T/F)

9.	 Once a wall is sketched, its dimension and angle cannot be modified. (T/F)

10.	 The Chain option can be enabled or disabled without exiting the Wall: Architectural tool. 
(T/F)

11.	 The usage of the wall can be changed by modifying the value of the Function parameter. 
(T/F)

12.	 While using the Wall: Architectural tool, if you invoke any other tool, the Wall: Architectural 
tool will be exited. (T/F)

EXERCISES
Exercise 1						       	      Apartment 2

Create the exterior and interior walls of the Apartment 2, based on Figure 3-88. The thick walls 
are the exterior walls and the thin walls are the interior walls. The dimensions and texts are not 
to be added. The project parameters for this exercise are given next.

  (Expected time: 30 min)
1.	 Project file - 
		  For Imperial	 c02_Apartment2_ex1.rvt.
		  For Metric	 M_c02_Apartment2_ex1.rvt.
2.	 Exterior wall type- Exterior - Brick on Mtl. Stud.
3.	 Interior wall type- 
		  For Imperial	 Basic Wall: Interior - 5” Partition (2-hr).
		  For Metric	 Basic Wall: Interior - 135mm Partition (2-hr).
4. 	 Height of the wall- Top Constraint - Up to Level 2.
5.	 Location line parameter for the exterior walls- Wall Centerline.
6.	 Name of the file to be saved-
		  For Imperial	  c03_Apartment2_ex1
		  For Metric	  M_c03_Apartment2_ex1

Figure 3-88  The sketch plan for creating the exterior and interior walls for the Apartment 2 project
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Exercise 2			                     Elevator and Stair Lobby
Create the exterior walls of the Elevator and Stair Lobby project, based on Figure 3-89. Do not 
add dimensions or texts as they are given only for reference. The project parameters for this 
exercise are given next.			       	                               (Expected time: 30 min)
  							                 
1.	 Project file - 
		  For Imperial	 c02_ElevatorandStairLobby_ex2.rvt
		  For Metric	 M_c02_ElevatorandStairLobby_ex2.rvt
2.	 Exterior wall type - Basic Wall Exterior Brick on Mtl. Stud.
3. 	 Height of the wall - Top Constraint- Up to Level 2.
4.	 Location line parameter - Wall Centerline.
5.	 Name of the file to be saved - 
		  For Imperial	 c03_ElevatorandStairLobby_ex2.
		  For Metric	 M_c03_ElevatorandStairLobby_ex2.

Figure 3-89  Sketch plan for creating the exterior walls for the Elevator and Stair Lobby project

Exercise 3			                              Club-Interior Walls
Create the interior walls of Hall 2 of the Club project based on Figure 3-90. Do not dimension the 
sketch as dimensions are given only for reference. The project parameters for this exercise are 
given next.							            (Expected time: 30 min)

1.	 Project file - 
		  For Imperial	 c03_Club_tut4.rvt
		  For Metric	 M_c03_Club_tut4.rvt
2.	 Interior wall type- 
		  For Imperial	 Basic Wall: Interior - 6 1/8” Partition (2-hr).
		  For Metric	 Basic Wall: Interior - 138mm Partition (1-hr).
3.	 Unconnected height of walls- 12’0”(3658 mm).
4.	 Location Line- Wall Centerline.
5.	 Inclined walls are parallel to the external walls and perpendicular to each other.
6.	 Name for saving the file- 
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		  For Imperial	 c03_Club_ex3.
		  For Metric	 M_c03_Club_ex3.

   

   

Figure 3-90  Sketch plan for sketching the interior walls of right portion for the Club project

Exercise 4			                  Residential Building- Walls    
Create stacked wall type for exterior walls and also create the interior walls for Residential Building- 
Walls project, refer to Figure 3-91. Do not dimension the sketch as dimensions are given only 
for reference. The project parameters for this exercise are given next.				  
	       						           	       (Expected time: 30 min)
1.	 Project file - 
		  For Imperial	 c02_residential_ex3.rvt
		  For Metric	 M_c02_residential_ex3.rvt
2.	 Exterior wall type- 
		  For Imperial	 Stacked Wall: Exterior - Brick Over CMU w Metal Stud		

	 For Metric	 Stacked Wall: Exterior - Brick Over CMU w Metal Stud
3.	 Exterior wall type- 
		  For Imperial	 Generic- 5”
		  For Metric	 Generic- 125mm
4.	 Top Constraint- Level 2.
5.	 Location Line- Wall Centerline.
6.	 Inclined walls are parallel to the external walls and perpendicular to each other.
7.	 Name for saving the file- 
		  For Imperial	 c03_residential_wall_ex4.
		  For Metric	 M_c03_residential_wall_ex4.
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Answers to Self-Evaluation Test
1. c, 2. c, 3. a, 4. Chain, 5. Offset, 6. Type Selector, 7. T, 8. F, 9. T, 10. F

Figure 3-91  Sketch plan for sketching the interior walls of right portion for the Club project


