Chapter 1

Exploring Maya
Interface

After completing this chapter, you will be able to:
* Start Autodesk Maya 2018

* Work with menusets in Autodesk Maya

* Understand various terms related to Maya interface

* Work with tools in Autodesk Maya 2018
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INTRODUCTION TO Autodesk Maya

Welcome to the world of Autodesk Maya 2018. Maya is a 3D software, developed by Autodesk
Inc., which enables you to create realistic 3D models and visual effects with much ease. Although
Maya is quite a vast software to deal with, yet all the major tools and features used in Autodesk
Maya 2018 have been covered in this book.

STARTING Autodesk Maya 2018

To start Autodesk Maya 2018, choose Start > All Programs > Autodesk > Autodesk Maya
2018 > Autodesk Maya 2018 from the taskbar, refer to Figure 1-1; the default interface of Maya
will be displayed with its different components.
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Figure 1-1 Starting Autodesk Maya 2018 using the taskbar

Alternatively, you can start Autodesk Maya 2018 by double-clicking on its shortcut icon displayed
on the desktop of your computer. This icon is automatically created on installing Autodesk Maya
2018 on your computer.

Double-click on the icon; three windows namely, Output Window, the main Autodesk Maya
2018 interface window, and the What’s New Highlight Settings window will be displayed on
the screen. The Output Window is shown in Figure 1-2. By default, all the new tools and icons
are highlighted in green in Maya 2018. The What’s New Highlight Settings window, as shown
in Figure 1-3, is used to toggle the visibility of these highlights.
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Figure 1-2 The Output Window
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Figure 1-3 The What’s New Highlight Settings window

AUTODESK MAYA 2018 SCREEN COMPONENTS

Autodesk Maya interface consists of viewports, title bar, menubar, Status Line, Shelf, Tool Box,
and so on. All these components will be discussed later in this chapter. When you start Autodesk
Maya 2018 for the first time, the persp viewport is displayed by default, refer to Figure 1-4.
Workspace is the part or the work area where you can create a 3D scene. Workspaces are also
known as viewports or views. In this textbook, the workspaces will be referred to as viewports.
Every viewport has a grid placed in the center. The grid acts as a reference that is used in aligning
the 3D objects or 2D curves. A grid is a pattern of straight lines that intersect with each other
to form squares. The center of the grid is intersected by two dark lines. The point of intersec-
tion of these two dark lines is known as the origin. The origin is an arbitrary point, which is
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used to determine the location of the objects. All the three coordinates, X, Y, and Z are set at 0
position on the origin. Note that in Maya, the X, Y, and Z axes are displayed in red, green, and
blue colors, respectively.
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Figure 1-4 The default interface of Autodesk Maya 2018 with persp viewport displayed

Autodesk Maya 2018 is divided into four viewports: top-Y, front-Z, side-X, and persp. These
viewports are classified into two categories, orthographic, and isometric. The orthographic
category comprises the top, front, and side viewports and the isometric category consists of the
persp viewport. The orthographic viewport displays the 2-dimensional (2D) view of the objects
created in it, whereas the isometric viewport displays the 3-dimensional (3D) view of the objects
created. Every viewport can be recognized easily by its name, which is displayed at the bottom
of each viewport. Figure 1-5 shows various components of the Maya interface.
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Figure 1-5 Displaying various screen components of the Maya interface

Every viewport has its own Panel menu that allows you to access the tools related to that specific
viewport. The Axis Direction Indicator located at the lower left corner of each viewport indicates
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about the X, Y, and Z axes. Similarly, every viewport in Maya has a default camera applied to it
through which the viewport scene is visible. The name of the camera is displayed at the bottom
of each viewport. In other words, the name of the viewport is actually the name of the camera
of that particular viewport.

The title bar, which lies at the top of the screen, displays the name and version of the software, the
name of the file, and the location where the file is saved. A Maya file is saved with the .mb or .ma
extension. The three buttons on the extreme right of title bar are used to minimize, maximize,
and close the Autodesk Maya 2018 window, respectively. Various interface components of the
Autodesk Maya 2018 interface are discussed next.

Tip
Q 10 toggle between single viewport and four viewport views, hover the cursor over one of the
viewports and press the SPACEBAR key.

Menubar

The menubar is available just below the title bar. The type of menubar displayed depends on
menusets. In Maya, there are different menusets namely, Modeling, Rigging, Animation, FX, and
Rendering. These menusets are displayed in the Menuset drop-down list located on the extreme
left of the Status Line. On selecting a particular menuset, the menus in the menubar change
accordingly. However, there are nine common menus in Maya that remain constant irrespective
of the menuset chosen. Figure 1-6 shows the menubar corresponding to the Modeling menuset.
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Figure 1-6 Menubar displayed on choosing the Modeling menuset

On invoking a menu from the menubar, a pull-down menu is displayed. On the right of some of
the options in these pull-down menus, there are two types of demarcations, arrows and option
boxes. When you click on an option box, a window will be displayed. You can use this window to
set the options for that particular tool or menu item. On clicking the arrow, the corresponding
cascading menu will be displayed.

Tip
Q You can also select different menusets using the hotkeys that are assigned to them. The default
hotkeys are F2 (Modeling), I3 (Rigging), F4 (Animation), F5 (FX), and F6 (Rendering).

Status Line

The Status Line is located below the menubar. The Menuset drop-down list is located at the left
of the Status Line. The Status Line consists of different graphical icons. The graphical icons are
further grouped and these groups are separated by vertical lines with either a box or an arrow
symbol in the middle. These vertical lines are known as Show/Hide buttons, refer to Figure 1-7.
You can click on a Show/Hide button with a box symbol to hide particular icons on the Status
Line. On doing so, the corresponding icons will hide and the box will change into an arrow
symbol. Similarly, if you click on a Show/Hide button that has an arrow symbol in the middle,
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the icons of the corresponding group will be displayed. Various groups separated by Show/Hide
buttons are discussed next.

Show/Hide buttons

Modeing v | i & o HYOES

Menuset drop-down list

Figure 1-7 The Status Line

Menuset

As mentioned earlier, the Menuset drop-down list in the Status Line —
has different menusets such as Modeling, Rigging, Animation, FX, S —
and Rendering, as shown in Figure 1-8. The options displayed in the =
menubar depend upon the menuset selected from this drop-down iimation
list. For example, if you select the Rendering menuset from the FX
Menuset drop-down list, all the commands related to it will be Rendering
displayed in the menus of the menubar. You can add a custom menuset Customize

by selecting the Customize option. On selecting it, the Menu Set
Editor window will be displayed, as shown in Figure 1-9. To create a
new menuset, choose the New Menu Set button from this window;
the Create New Menu Set window will be displayed. Enter the menu name in Enter name edit
box and then choose the Create button, the new menuset will be added in the Menu sets area
of the window. To add a menu in the Menus in menu set area; select the desired menu items
from the All menus area and right-click on it. Next, choose Add to Menu Set from the shortcut
menu displayed; the selected menu items will be added to the Menus in menu set area. Now,
choose the Close Window button to close the window.

Figure 1-8 The Menuset
drop-down list

M Menu Set Editor = B
Edit Help

Menus in menu set: All menus:

Rendering

New Menu Set Remove Menu et Close Window

Figure 1-9 The Menu Set Editor window

File Buttons Group
The buttons in this group are used to perform different file related operations, refer to
Figure 1-10. The tools in this group are discussed next.

Create a new scene
The Create a new scene button is used to create a new scene. To do so, choose the
New scene button from the Status Line; the Warning: Scene Not Saved message box
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will be displayed with the Save changes to untitled scene? message, as shown in Figure 1-11.
This warning message will only appear if the current scene is not saved. Choose the Save
button to save the scene. Choose the Don’t Save button to create a new scene without saving
the changes made in the current scene. Choose the Cancel button to cancel the saving
procedure.

M Warning: Scene Not Sav... ?

s to untitled

Don't Save Cancel

E=Eoc

Figure 1-10 The File Buttons group Figure 1-11 The Warning: Scene Not
Saved message box

Open a scene

E The Open a scene button is used to open a file created earlier. To do so, choose this
button from the Status Line; the Open dialog box will be displayed, as shown in
Figure 1-12. In this dialog box, specify the location of the file that you want to open

and then choose the Open button; the selected file will open in the Maya interface. This

dialog box is divided into different sections and some of them are discussed next.

Current filepath —-#8

Bookmarks

Filepath rule -
and folder
navigation

Set current project

Main Selection panel Options panel

Figure 1-12 The Open dialog box

Folder Bookmarks

The bookmarks section is used to access the folders in your computer. You can also rearrange
the default location of the folders in this section by dragging them up and down using the
left mouse button.

Set Project

This button is used to set a new project by replacing the current project. On choosing this
button, a new window named Set Project will be displayed. You will learn about this window
later in this book.

Save the current scene
E The Save the current scene button is used to save the current scene. On choosing the
Save the current scene button, the Save As dialog box will be displayed. Enter a name
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for the file in the File name text box, specify the location to save the current scene, and then
choose the Save As button to save the current scene. Maya provides you with various options
that can be used while saving a file. These options are given on the right side of the dialog box
in the Options section.

Undo the last action/Redo the last undone action
The Undo the last action button is used to remove the last applied action and the
Redo the last undone action button is used to apply the last undone action again.

Selection Set Icons Group

The Selection Set Icons group shown in Figure 1-13 is used to define
the selection of objects or the components of objects from the
viewport. This group comprises of three buttons that are discussed Figure 1-13 The Selection
next.

* Objects

set icons group

Select by hierarchy and combinations

m The Select by hierarchy and combinations button is used to select a group of objects
in a scene in a hierarchical order. For example, if four objects are combined under a

single group, clicking on a single object with this button chosen will select the entire group

of objects.

Select by object type
The Select by object type button is used to select only a single object from a group of
objects in a scene. For instance, if four objects are combined under a single group, this
button will enable you to select only the desired object from the group, and not the entire

group.

Select by component type

ﬂ The Select by component type button is used to select the components of an object,
such as vertices or faces. You can also select the control vertices of the NURBS

surfaces using this button.

Tip
Q 1o switch between the object and the component modes of the selection type, press the FS key.

Selection Mask Icons Group

The Selection Mask Icons group comprises of selection filters that help you in selecting objects
or their components in the viewport. The selection mask helps you decide which filters/icons
should be displayed in the viewport. The selection mask icons group depends on the selection
mode button chosen. If the Select by hierarchy and combinations button is chosen, then the
icons under this group will change, as shown in Figure 1-14.

Figure 1-14 The Selection Mask Icons group displayed on
choosing the Select by hierarchy and combinations button

These icons represent the tools that enable you to select the objects based on their hierarchy.
Similarly, on choosing the Select by component type button and the Select by object type
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button, the icons under these groups will change accordingly, and this will enable you to select
either the entire object, or its components, refer to Figures 1-15 and 1-16. The most commonly
used group is the icons group displayed on choosing the Select by object type button. Various

buttons in this selection masks icons group are discussed next.

Figure 1-15 The Selection Mask Icons group displayed on

choosing the Select by component type button

Figure 1-16 The Selection Mask Icons group displayed

on choosing the Select by object type button

Set the object selection mask
I The Set the object selection mask button is used to switch
all the selection icons on or off. To do so, choose the Set
the object selection mask button from the Status Line; a
flyout will be displayed, as shown in Figure 1-17. Choose the
All objects on option from the flyout to make all selection
icons on or select the All objects off option to switch off all
selection icons from the menu.

All objects on

All objects off

Save to Shelf

Figure 1-17 Flyout displayed
on choosing the Set the object
selection mask button

Note
@ If the All objects off option is chosen, you cannot select any object in the viewport.

Select handle objects

The Select handle objects button allows you to select IK handles and selection
handles. You will learn more about this button in the later chapters.

Select joint objects

The Select joint objects button is used to select only the joints of the objects while

animating or rigging them.

Select curve objects

The Select curve objects button is used to select the NURBS curves, curves on the

surface, and paint effects strokes in the viewport.

Select surface objects

The Select surface objects button is used to select the NURBS surfaces, poly surfaces,

planes, and GPU cache in the viewport.

Select deformations objects

. The Select deformations objects button is used to select the lattices, clusters,

nonlinear, and sculpt objects in the viewport.
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Select dynamic objects
The Select dynamic objects button is used to select the dynamic objects in the
viewport.

Select rendering objects
The Select rendering objects button is used to select the lights, cameras, and textures
in the viewport.

Select miscellaneous objects
The Select miscellaneous objects button is used to select miscellaneous objects such
as IK End Effectors, locators, and dimensions in the viewport.

Lock/Unlock current selection
The Lock/Unlock current selection button is used to lock the selection so that left
n mouse button acts on the manipulators instead of selecting objects. Select an object
in the viewport and choose the Lock/Unlock current selection button from the
Status Line; the tool manipulators will be locked to the object and no other object
can be selected from the viewport.

Highlight Selection mode is on
The Highlight Selection mode is on button is used to turn off the automatic display
of the components.

Snap Buttons Group
The Snap Buttons group comprises of different snap options, as shown in
Figure 1-18. These options are used to snap the selected objects to

specific points in a scene. The buttons in this group are discussed next. Figure 1-18 The Snap
Buttons group

Snap to grids

The Snap to grids tool is used to snap an object to the closest grid intersection point.
: For example, to snap a sphere to the closest grid intersection point, choose Create >

Objects > NURBS Primitives > Sphere from the menubar and then click in the viewport;

a sphere will be created. Choose the Snap to grids tool from the Status Line and invoke

Move Tool from the Tool Box. Next, press the middle mouse button over the sphere and

drag it; the sphere will be snapped to the closest grid intersection point, refer to Figure 1-19.

Snap to curves
@ [he Snap to curves button is used to snap an object to the curve in the viewport. For
- example, to snap a cube on a curve, choose Create > Objects > NURBS Primitives >
Cube from the menubar and then click in the viewport; a cube will be created. Next,
choose Create > Curve Tools > EP Curve Tool from the menubar and then create a curve
in the top-Y viewport. Press ENTER to exit EP Curve Tool. Next, choose Move Tool from
the Tool Box and align the cube over the curve. Choose the Snap to curves button from
the Status Line. Press the middle mouse button over the cube and drag it; the cube will
move over the curve while remaining snapped to the curve, refer to Figure 1-20.
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Figure 1-20 The cube snapped to the curve

Snap to points
IR !he Snap to points button is used to snap the selected objects to the closest control
vertex or pivot point. For example, to snap a cube to the vertices of a polygonal plane,
choose Create > Objects > Polygon Primitives > Plane > Option Box from the menubar;
the Tool Settings (Polygon Plane Tool) window will be displayed. Now, set the Width
divisions and Height divisions to 10, and then click in the viewport to make a plane. Next,
create a cube in the viewport, as discussed earlier. Next, select the cube and choose the Snap
to points button from the Status Line and drag the cube with the middle mouse button; the
cube will snap to the closest control vertex of the polygonal plane.

Snap to Projected Center
The Snap to Projected Center button is used to snap an object (joint or locator) to
B8 the center of the other object. For example, to snap a locator to the center of a
polygonal plane, choose Create > Objects > Polygon Primitives > Plane from the menubar
and drag the cursor; a plane will be created. Next, choose Create > Construction Aids >
Locator from the menubar; a locator will be created. Now, select the locator and choose the
Snap to Projected Center button from the Status Line; the locator will snap to the center
of the polygonal plane.

Snap to view planes
The Snap to view planes button is used to snap the selected object to the view plane
of the viewport.
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Tip
Q You can also use the shortcut keys to perform a particular snap function. For example, press
X for Snap to grids,C for Snap to curves, and V for the Snap to points buttons.

Make the selected object live

The Make the selected object live button is used to make the selected surface a live
S8 object. A live object is used to create objects or curves directly on its surface. For
example, to snap a cube on the surface of a polygonal sphere, choose Create >
Objects > Polygon Primitives > Sphere from the menubar and drag the cursor; a sphere
will be created. To create a cube on the surface of the sphere, choose the Make the selected
object live button from the Status Line; the sphere will appear in green wireframe. Now,
choose Create > Objects > Polygon Primitives > Cube from the menubar and drag the

cursor; a cube will be created on the surface of the sphere.

History Buttons Group

This group in the Status Line helps you control various objects. The objects with input connections
are affected or controlled by other objects, whereas the objects with output connections affect
or control other objects.

Inputs to the selected object
The Inputs to the selected object button is used to edit all input connections for the
selected object such that the selected object gets influenced by another object.

Outputs from the selected object
The Outputs from the selected object button is used to select and edit the output
operations of an object.

Construction history on/off
The Construction history on/off button is used to record the construction history.
The construction history is used to track the changes made on an object at a later
stage. Sometimes, the construction history may make a particular file size heavy. To decrease
the file size, you can deactivate this option.

Render Tools Group
This group in the Status Line is used to access all render controls in Maya. The buttons in this
group are discussed next.

Display rendering image

FFF The Open Render View button is used to open the Render View window.
Gk

Render the current frame

E The Render the current frame button is used to render the selected viewport at the
current frame using the Arnold renderer. Choose the Render the current frame

button from the Status Line; the Render View window will be displayed. The

Render View window shows the rendered view of the selected scene, refer to Figure 1-21,
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whereas Output Window will display all the rendering calculations made for rendering the
active scene, refer to Figure 1-22.

™ Render View = =
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Figure 1-21 The Render View window
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Figure 1-22 The Output Window

IPR render the current frame

FEF The IPR render the current frame button is used to perform an IPR render. Here,
IPR stands for Interactive Photorealistic Rendering. This tool helps you to adjust the
lighting or the shading attributes of the rendered scene and then update it as per the

requirement. To render the current frame, choose this button from the Status Line; the

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com
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Render View window will be displayed. Now, press the left mouse button and drag it in the
Render View window to set the selection for IPR rendering. As a result, Maya will render
the selected part only. In other words, it will help you visualize your scene dynamically. Now,
if you make changes in the color or lighting attribute of the scene using Attribute Editor,
the selected part will be rendered automatically.

Display render settings window

ﬁ On choosing the Display render settings window button, the Render Settings window
will be displayed, as shown in Figure 1-23. This window comprises of all controls

needed for rendering. These controls help you adjust the render settings such as resolution,

file options, ray tracing quality, and so on.

M Render Settings = =

¥ File Qutput
File n
I

b Metadata (nam

Transform Pt

Frame r gle Frame) ot

Version Label

¥ Frame Range

Figure 1-23 The Render Settings window

Display and edit connections in shading networks

- On choosing this button, the Hypershade window will be displayed. Using this window,
you can create shading networks. The Hypershde window is discussed in detail in
the later chapters.

Launch Render Setup Window
E On choosing this button, the Render Setup Editor window will be displayed, with the
Render Setup editor on the left and the Property Editor on the right. The Render



Exploring Maya Interface 1-15

Setup editor allows you to create layers, collections and overrides, whereas the Property
Editor allows you to set their corresponding values.

Open the Light Editor
On choosing this button, the Light Editor (Global Mode) window will be displayed.
This window lists all lights in the scene with commonly used attributes for each light.

Toggle pausing Viewport 2 display update
m This button is used to pause Viewport 2 display update.

Input Line Operations Group

This group in the Status Line helps you quickly select, rename, and transform the objects that
are created in the viewport. Some of the options in this group are in hidden modes. To view
them, move the cursor over the arrow on the left of the input field and then press and hold
the left mouse button on it; a flyout will be displayed. Now, select the required option from the
flyout; the corresponding mode will be displayed. By default, the Absolute transform mode is
active. The transform modes are discussed next.

Absolute transform

The Absolute transform area is used to move, rotate, or scale a selected object in the
viewport. To do so, invoke the required transformation tool from the Tool Box and enter
values in the X, Y and Z edit boxes in the Absolute transform area, refer to Figure 1-24.
Now, press ENTER; the selected object will be moved, rotated, and scaled according to the
values entered in the edit boxes.

Note
The Absolute transform area takes the center of the viewport as a reference for transforming an
object.

Relative transform

The Relative transform area is also used to scale, rotate, or move a selected object in the
viewport, refer to Figure 1-25. This area is similar to the Absolute transform area with the
only difference that the Relative transform area takes the current position of the object as
a reference point for transforming an object.

Figure 1-24 The Absolute transform area  Figure 1-25 The Relative transform area

Rename

The Rename area is used to change the name of a selected object. To rename an object,
select the object from the viewport whose name you want to change; the default name of the
selected object will be displayed in the text box in the Rename area, refer to Figure 1-26.
Enter a new name for the object in the edit box and press ENTER.

Select by name
You can select an object in the viewport by entering its name in the text box in the Select
by name area, refer to Figure 1-27.
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Figure 1-26 The Rename area  Figure 1-27 The Select by name area

Autodesk Store Group

There is a drop-down list in this group that has three options: Sign In, Explore Purchase
Options, and Manage License. The Sign In option is used to sign in to the Autodesk account.
On selecting Explore Purchase Options from this drop-down list, open the Autodesk Store web
page from where you can buy various Autodesk products.

The Manage License option will open the License Manager that you can use to manage Maya
license.

Sidebar Buttons Group
The toggle buttons in the Sidebar Buttons group are used to invoke tools, editors, and windows.
The buttons in this group are discussed next.

Show/Hide Modeling Toolkit

E The Show/Hide Modeling Toolkit button is used to open the Modeling Toolkit window,
as shown in Figure 1-28. The Modeling Toolkit window is used to perform multiple
modeling specific operations.

Show/Hide the Character Control Tool

The Show/Hide the Character Control Tool is used to open the Human IK window,
as shown in Figure 1-29. The tools in this window allow you to define and control
multiple character setups in a single window.

Object  Help K’ )v Character: None

—
Multi-Component
Create Skeleton
Create Control Rig

Create Character Definition

Create Custom Rig Mapping
Quick Rig Tool

¥ Import Samples
Import Human IK Example
Import Animation Example

Get HIK and Mocap Examples Online

P Soft Selection

¥ Mesh

Figure 1-28 The Modeling Figure 1-29 The Human IK window
Toolkit window
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Show/Hide Attribute Editor

E The Show/Hide Attribute Editor button is used to toggle the visibility of the Attribute
Editor, refer to Figure 1-30. The Attribute Editor is used to control different properties
of the selected object.

List Selected Forus Attributes  Show

pSphereShapel

Show Hide

Tessellation Attributes
Mesh Component Display
Mesh Controls

Tangent Space

Smooth Mesh
Displacement Map
Render Stats

Object Display

4
4
4
4
4
4
4
4
4

Node Behavior

Motes: pSphereShapel

Load Attributes Copy Tab
Figure 1-30 The Attribute Editor

Show/Hide the Tool Settings
The Show/Hide the Tool Settings button is used to display the options for selected
tool in the Tool Settings window. On choosing this button, the Tool Settings window
of the selected tool will be displayed. For example, if you have chosen Move Tool from the
Tool Box, then you can control its settings by using the Tool Settings (Move Tool) window,
as shown in Figure 1-31.

Show/Hide Channel Box

P The Show/Hide Channel Box button is used to toggle the visibility of the Channel
B8 Box / Layer Editor. This button is similar to the Show/Hide the Attribute Editor
button. On choosing this button, the Channel Box / Layer Editor will be displayed on the
right of the viewport, as shown in Figure 1-32. The Channel Box is used to control the
transformation and the geometrical structure of the selected object. The Layer Editor is
used to organize the objects in a scene when there are many objects in the viewport. Multiple
objects can be arranged in the layer editor to simplify the scene.

Note

By default, the keyable attributes of selected object(s) are displayed in the Channel Box. 1o add
more attributes to it, choose Windows > Editors > General Editors > Channel Control from
the menubar; the Channel Control window will be displayed. In this window, three areas will
be displayed in the Keyable tab: Keyable, Nonkeyable Hidden, and Nonkeyable Displayed.
1o add attributes, select them from the Nonkeyable Hidden area and then choose the Move >>
button. Next, choose the Close button.
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M Tool Settings. = =

Reset Tool Tool Help

Channels Edit Object Show

pSphere1 Transform Node

SHAPES Shapes Node
pSphereShapel

INPUTS
polySpherel

Smart Duplicate Settings

Layer Editor

Figure 1-31 The Tool Settings (Move Tool) Figure 1-32 The Channel Box /
window Layer Editor

Shelf

The Shelf is located below the Status Line, as shown in Figure 1-33. The Shelf is divided into
two parts. The upper part in the Shelf consists of different Shelf tabs and lower part displays
the icons of different tools. The icons displayed in this area depend on the tab chosen, refer to
Figure 1-33.

Figure 1-33 The Shelf

You can also customize the Shelf as per your

requirement. To do so, press and hold the left —
mouse button over the Menu of items to modify Menu of __ e

the shelf button, refer to Figure 1-34; a flyout will items to Shelf Tabs

be displayed, as shown in Figure 1-34. Various Modify Shelf Editor.

options in this flyout are discussed next. the shelf Navigate Shelves

Shelf Tabs et o

Delete Shelf

The Shelf Tabs option is used to toggle the visibility
of the Shelf tabs. On choosing this option, the
Shelfs tabs will disappear, and only the tool icons
corresponding to the selected tab will be visible. Figure 1-34 Flyout displayed on choosing the
Menu of items to modify the shelf button

Load Shelf...

Save All Shelves

Shelf Editor

The Shelf Editor option is used to create a Shelf'and edit the properties of an existing Shelf. When
this option is chosen, the Shelf Editor will be displayed in the viewport, as shown in Figure 1-35.
Alternatively, you can choose Windows > Editors > Settings/Preferences > Shelf Editor from
the menubar to display the Shelf Editor. In the Shelf Editor, you can change the name and
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position of shelves and their contents. You can also create a new shelf and its contents using
the Shelf Editor.

M Shelf Editor

Shelves

Shelves Shelf Contents

Ri
Alignment:  Left MURES Circle

Curves / Surfaces
Poly Modeling

]

le on the grid

Save All Shelves

Figure 1-35 The Shelf Editor

Navigate Shelves

The Navigate Shelves option is used to choose
the previous or next Shelf of the currently
chosen Shelf. On choosing this option, a

Shelf Tabs
cascading menu will be displayed, as shown
- o : Shelf Editor...
in Figure 1-36. The options in the cascading
menu are discussed next. Navigate Shelves
New Shelf Previous Shelf
NEW
. Next Shelf
Previous Shelf Delete Shelf SESNE
The Previous Shelf option is used to [SEEE LT (2 A

choose the Shelf that comes before the
currently chosen Shelf. For example,
choose the Rendering tab; the rendering Figure 1-36  Cascading menu displayed on choosing
specific icons will be displayed. Next, the Navigate Shelves option

press and hold the left mouse button over

the Menu of items to modify the shelf option; a flyout will be displayed. Choose Navigate
Shelves from the flyout; a cascading menu is displayed. From the cascading menu, choose
Previous Shelf; the Animation tab is chosen displaying the dynamic specific icons.

Save All Shelves

Next Shelf
The Next Shelf option is used to choose the shelf that comes after the currently chosen Shelf.
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Jump to Shelf

The Jump to Shelf option is used to choose the specific Shelf by entering its name. On
choosing this option, the Jump to Shelf window will be displayed, as shown in Figure 1-37.
Enter the name of the shelf in the Shelf Name text box and choose the OK button; the
Shelf tab with icons specific to the corresponding shelf are displayed.

New Shelf

The New Shelf option is used to add a new Shelf tab to the existing Shelf. On choosing this
option, the Create New Shelf window will be displayed, as shown in Figure 1-38. Enter a name
for the new Shelf and choose the OK button; a new Shelf will be created, as shown in Figure 1-39.
For adding different tools in the tools area corresponding to the new Shelf created, press and
hold CTRL+SHIFT and then select the desired tools from the pull-down menus.

¥ Jump to Shelf @

Shelf Name

M Create New Shelf | 7 |[s23a]

Enter new shelf name

Figure 1-37 The Jump Figure 1-38 The Create
to Shelf window New Shelf window

NewShelf

Figure 1-39 A new Shelf added

Delete Shelf M Confirm ?

The Delete Shelf option is used to delete a shelf. On choosing A you sure you want o deletethe shek‘Curves / Sufaces 7

this option, the Confirm message box will be displayed, as o cancel

shown in Figure 1-40. Choose the OK button to delete the

selected Shelf. Figure 1-40 The Confirm
message box

Load Shelf

The Load Shelf option is used to load the shelf that was saved previously. When this option
is chosen, the Load Shelf window will be displayed. You can choose the previously saved shelf
from this window; the desired Shelf tab will be displayed in the shelf.

Save all Shelves
The Save all Shelves option is used to save the shelves, so that you can use them later while
working in Maya.

Tool Box

The Tool Box is located on the left side of the workspace. It comprises of the most commonly
used tools in Maya. In addition to the commonly used tools, the Tool Box has several other
options or commands that help you change the layout of the interface. Various tools in the Tool
Box are discussed next.
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Select Tool
The Select Tool is used to select the objects created in the viewport. To select an object,
k invoke the Select Tool from the Tool Box and click on an object in the viewport;
the object will be selected. On invoking this tool, the manipulators will not be activated.

Lasso Tool

The Lasso Tool is used to select an object by using a free hand marquee selection. This

tool is very much similar to the Select Tool. To select an object, invoke the Lasso Tool;

the cursor will change to a rope knot. Next, press and hold the left mouse button and
drag the cursor in the viewport to create a selection area around the object. Then, release the
left mouse button; the object inside the selection area will be selected. To adjust the properties of
the Lasso Tool, make sure that the Lasso Tool is invoked, and then choose the Show/Hide the
Tool Settings button from the Status Line; the Tool Settings (Lasso Tool) window will be
displayed. Adjust the Lasso Tool properties from the Tool Settings (Lasso Tool) window as per
your requirement.

Paint Selection Tool

Pl  The Paint Selection Tool is used to select various components of an object. To select
B various components of an object, invoke the Select Tool from the Tool Box and select
an object in the viewport. Next, press and hold the right mouse button over the selected
object; a marking menu will be displayed. Choose Vertex from the marking menu to make the
vertex selection mode active. Now, choose the Paint Selection Tool from the Tool Box; the
cursor will change to the paint brush. Next, press and hold the left mouse button and drag the
cursor over the object to select the desired vertices. To go back to the object mode, invoke the
Select Tool and then press and hold the right mouse button; a marking menu will be displayed.

Choose Object Mode from the marking menu to make the vertex selection mode inactive.

You can also increase the size of the Paint Selection Tool cursor. To do so, press and hold the B
key on the keyboard. Next, press and hold the left mouse button in the viewport and drag the
cursor to adjust the size of the brush.

Move Tool
The Move Tool is used to move an object from one place to another in the viewport.
n To do so, invoke Move Tool from the Tool Box; the cursor will change to an arrow with
abox at its tip. Select the object in the workspace that you want to move. You can move
the selected object in the X, Y, and Z directions by using the handles/manipulators over the
object. You can also adjust the properties of the Move Tool by

choosing the Show or Hide the Tool Settings button from V-Handie
the Status Line or by double-clicking on the Move Tool itself. g B XY-Handle
To use the Move Tool, you need to create an object in the l YZ-Handle
viewport. To do so, create a sphere by choosing Create > Yellow Box
Objects > Polygon Primitives > Sphere from the menubar. T X_Handle
XZ-Handle

A sphere will be created. Now, invoke the Move Tool from z pHandle
the Tool Box and select the object created by clicking on it;
the Move Tool manipulator will be displayed on the selected
object with three color handles, as shown in Figure 1-41.

Figure 1-41 The Move Tool
manipulator
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These three color handles are used to move the object in the X, Y, or Z direction. The colors
of the handles represent three axes; red represents the X-axis, green represents the Y-axis, and
blue represents the Z-axis. At the intersection point of these handles, a box will be displayed
that can be used to move the object proportionately in all the three directions. Press and hold
the left mouse button over the box and drag the cursor to move the object freely in the viewport.
To adjust the default settings of the Move Tool, double-click on it in the Tool Box; the Tool
Settings (Move Tool) window will be displayed, as shown in Figure 1-42. Change the settings as
per your requirement in this window.

M Tool Settings = =

Reset Tool Tool Help

Edit Pivot

Transfo

ent Settings

Snap Settings

Figure 1-42 The Tool Settings (Move Tool) window

By default, the pivot point is located at the center of the object. To change the pivot point,
make sure that the Move Tool is invoked and then press the INSERT key; the pivot point will be
displayed in the viewport, as shown in Figure 1-43. Move the pivot point to adjust its position.
You can also put the pivot at the center of the object. To do so, choose Modify > Pivot > Center
Pivot from the menubar; the pivot point will be adjusted to the center of the object. You can also
adjust the pivot point by pressing and holding the D key and moving the manipulator.

Note
A prvot is a point in 3D space that is used as a reference point for the transformation of objects.

Rotate Tool
The Rotate Tool is used to rotate an object along the X, Y, or Z axis. To rotate an object
in the viewport, select the object and invoke the Rotate Tool from the Tool Box; the Rotate
Tool manipulator will be displayed on the object, as shown in Figure 1-44. The Rotate Tool
manipulator consists of three colored rings. The red ring represents the X axis, whereas the
green and blue rings represent the Y and Z axes, respectively. Moreover, the yellow ring around
the selected object helps you rotate the selected object in the view axis. On selecting a particular



Exploring Maya Interface 1-23

ring, its color changes to yellow. You can change the default settings of the Rotate Tool by
double-clicking on it in the Tool Box. On doing so, the Tool Settings (Rotate Tool) window will
be displayed, as shown in Figure 1-45. This window contains various options for rotation. You
can change the settings in this window as required.

Figure 1-43 The pivot point Figure 1-44 The Rotate
Tool manipulator
2] Tool Settings = =

Reset Tool Tool Help

Edit Pivot

Figure 1-45 Partial view of the Tool Settings
(Rotate Tool) window

Scale Tool
The Scale Tool is used to scale an object along the X, Y, or Z-axis. To scale an object in
the viewport, select the object and invoke Scale Tool from the Tool Box; Scale Tool
manipulator will be displayed on the object, as shown in Figure 1-46.

The Scale Tool manipulator consists of three boxes. The red box represents the X axis, whereas the
green and blue boxes represent the Y and Z axes, respectively. Moreover, the yellow colored box
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in the center lets you scale the selected object uniformly in all axes. On selecting any one of these
colored scale boxes, the default color of the box changes to yellow. You can also adjust the default
settings of Scale Tool by double-clicking on it in the Tool Box. On doing so, the Tool Settings
(Scale Tool) window will be displayed, as shown in Figure 1-47. Make the required changes in
the Tool Settings (Scale Tool) window to adjust the basic attributes of Scale Tool.

Figure 1-46 The Scale Tool manipulator
Tool Settings = =

Reset Tool Tool Help

Figure 1-47 The partial view of the Tool
Settings (Scale Tool) window

Note

While rotating, moving, or scaling an object, different colored handles arve displayed. These handles
indicate different axes. You can use this color scheme while working with three transform tools as
well. The red, green, and blue colors represent the X, Y, and Z axes, respectively.
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Last Tool Used
The Last Tool Used tool is used to invoke the last used or the currently selected tool. This tool
displays the icon of the last used tool or currently active tool.

Quick Layout Buttons

Using the buttons in the Quick Layout buttons area, refer to Figure 1-5, you can the toggle
the display of layouts as required. You can also change the display of layout buttons. To do so,
right-click on one of the Quick Layout buttons; a shortcut menu with various layout options will
be displayed, as shown in Figure 1-48. Next, choose any of the layout from the shortcut menu
as per your need; the current layout will be replaced by the chosen layout. Using these buttons,
you can also edit the current layout. To do so, right-click on the Quick Layout buttons; a shortcut
menu will be displayed. Choose Edit Layouts from the shortcut menu; the Panels window will
be displayed, as shown in Figure 1-49.

Single Pane

Two Panes Side by Side

Two Panes Stacked
Three Panes Spli

Three Pa

Three Pa

Three Panes

Four Panes

Single Perspective View
Four View

Front,

Save Current Layout...
Edit Layouts...

Change Image...

Figure 1-48 A shortcut menu
with various layout

M Panels

Label Top

Delete

Clase

Figure 1-49 The Panels window
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Time Slider and Range Slider

The Time Slider and the Range Slider, as shown in Figure 1-50, are located at the bottom of
the viewport. These two sliders are used to control the frames in animation. The Time Slider
comprises of the frames that are used for animation. There is an input box on the Time Slider
called Set the current time, which indicates the current frame of animation. The keys in the
Time Slider are displayed as red lines.

Scrub bar Set the currenttime Playback controls

H 1 e lic 4> »i i

1 1 20 2 200 o Anim Laye o C BRI A nimation

Setthe start Set the start Set the end time of playback range Setthe active  Setthe active preferances
time of time of Setthe end time of animation: animation layer  animation layer keyframetoggle
animation  playback range Set the current character set

Figure 1-50 The Time Slider and the Range Slider

Range bar handles

The Time Slider displays the range of frames available in your animation. In the Time Slider,
the grey box, known as scrub bar, is used to move back and forth in the active range of frames
available for animation. The Playback Controls at the extreme right of the current frame help
you to play and stop the animation. The Range Slider located below the Time Slider is used to
adjust the range of animation playback. The Range Slider shows the start and end time of the
active animation. The edit boxes both on the left and right of the Range Slider direct you to the
start and end frames of the selected range. The length of the Range Slider can be altered using
these edit boxes. At the right of the Set the end time of the animation input box is the Set the
active animation layer button. This feature gives you access to all the options needed to create and
manipulate the animation layers. This option helps you to blend multiple animations in a scene.
The Set the current character set is located on the right of the Range Slider. It is used to gain
automatic control over the character animated object. There are two buttons on the extreme
right of the Range Slider: Auto keyframe toggle and Animation preferences. These buttons
are discussed next.

Tip
Q You can also set the keys for animation by choosing Key > Set > Set key from the menubar
or by pressing the s’ key. Ensure that you have selected the Animation menuset.

Auto keyframe toggle
The Auto keyframe toggle button is used to set the keyframes. This button sets the
keyframe automatically whenever an animated value is changed. Its color turns blue when
it is activated.

Animation preferences

The Animation preferences button is used to modify the animation controls. On
choosing this button, the Preferences window will be displayed, as shown in Figure 1-51.

In the Preferences window, the Time Slider option is selected by default in the Categories area.

You can set the animation controls in the Time Slider and Playback area of the Preferences window.

Choose the Save button to save the changes and close the window.
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Edit Help

Time Slider: Animation Time Slider and Playback Preferences
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Time Slider

Framerate: 24 fps

Figure 1-51 The Preferences window

Command Line

The Command Line is located below the Range Slider. It works in Maya interface by using the
MEL script or the Python script. The MEL and Python are the scripting languages used in
Maya. Choose the MEL button to switch between the two scripts. The MEL button is located
above the Help Line.

The Command Line also displays messages from the program in a grey box on the right. At the
extreme right of the Command Line, there is an icon for the Script Editor. The Script Editor
is used to enter complex and complicated MEL and Python scripts into the scene.

Note

MEL stands for MAYA Embedded Language. The MEL command is a group of text strings that

are used to perform various functions in Maya.

Help Line
The Help Line is located at the bottom of the Command Line. It provides a brief description
about the selected tool or the active area in the Maya interface.

Panel Menu

The Panel menu is available in every viewport, as shown in Figure 1-52. The commands or
options in the Panel menu controls all the actions performed in the workspace. The Panel menu
comprises of six menus, which are discussed next.
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Figure 1-52 The Panel menu

View
The View menu is used to view the object in the viewport from different angles using
different camera views.

Shading

The Shading menu is used to view the object in various shading modes such as Wireframe,
Smooth Shade All, Flat Shade All, X-Ray, and so on. You can also use the Wireframe on Shaded
option in this menu for working comfortably in the shaded mode.

Lighting
The Lighting menu helps you use different presets of lights that help in illuminating objects
in the viewport.

Show

The Show menu is used to hide or unhide a particular group of objects in the viewport.

Renderer

The Renderer menu is used to set the quality of rendering in the viewport. You can also set the
color texture resolution and the bump texture resolution for high quality rendering using the
options in this menu.

Panels
The Panels menu is used to switch the active viewport to a different view.

Panel Toolbar

The Panel toolbar, as shown in Figure 1-53, is located just below the Panel menu of all viewports.
This toolbar consists of the most commonly used tools present in the Panel menu. These tools
are discussed next.
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Grid
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Resolution gate Xray joints
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Eield chart Hray Exposure
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Figure 1-53 The Panel toolbar

Select camera

The Select camera tool is used to select the active camera in the nading Lighting
selected viewport. You can also select the current camera in a front -
scene by choosing View > Select Camera from the Panel menu. o

To switch between different camera views, right-click on the Select o

camera tool; a shortcut menu will be displayed, as shown in New Perspective

MNew Orthographic

Figure 1-54. Now, you can switch to the desired camera views by
choosing the corresponding option from the shortcut menu.

Stereo Cameras

Figure 1-54 The shortcut menu

Lock Camera displayed on right-clicking on the

The Lock Camera tool is used to lock the active camera in a Select camera tool

viewport. When camera is locked, you can not change its transform properties such as translate
and rotation. To unlock the camera, choose the Lock Camera tool again.

Camera attributes

The Camera attributes tool is used to display the attributes of the active camera in the Attribute
Editor. The attributes are displayed on the right of the viewport in the Attribute Editor. You
can also view the attributes by choosing View > Camera Attribute Editor from the Panel menu.

Bookmarks

The Bookmarks tool is used to set the current view as a bookmark. To set a bookmark, you can
set a view in the viewport and then invoke the Bookmarks tool; the set view is bookmarked for
further reference. You can also edit an existing bookmark. To do so, press and hold the right
mouse button over the Bookmark tool; a shortcut menu with a list of bookmarks created will
be displayed in the Panel toolbar. Choose the Edit 2D Bookmarks option from this shortcut
menu. On doing so, the Bookmark Editor (persp) window will be displayed, as shown in Figure
1-55. You can change the name and other attributes of the selected bookmark from this window.
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M Bookmark Editor (persp) = =

Apply  Addto Shelf Mew Bookmark Mew 2D Bookmark Delete

Close

Figure 1-55 The Bookmark Editor (persp) window

Image Plane

The Image Plane tool is used to import an image to the active viewport. On choosing the
Image Plane tool, the Open dialog box will be displayed. In the Open dialog box, choose the
image that you want to insert in the active viewport; the image plane will be inserted in the
viewport. You can also set the image to the active viewport by choosing View > Image Plane >
Import Image from the Panel menu.

2D Pan/Zoom
The 2D Pan/Zoom tool is used to toggle the 2D pan/zoom mode on or off.

Grease Pencil

The Grease Pencil tool is used to draw 2D sketches in the viewport. On invoking this tool, the
Grease Pencil window will be displayed, as shown in Figure 1-56. You can also invoke this tool
by choosing View > Camera Tools > Grease Pencil Tool from the Panel menu.

M Grease Pencil

B

Figure 1-56 The Grease Pencil window

Grid

The Grid tool is used to toggle the visibility of the grid in the viewport. You can also invoke this
tool by choosing Show > Grid from the Panel menu. In addition, you can set the attributes for
the grid in the viewport by using this tool. To set the grid attributes, press and hold the right
mouse button on the Grid tool in the Panel toolbar; a flyout will be displayed. Choose Grid
Options from the flyout; the Grid Options window will be displayed, as shown in Figure 1-57.
Next, you can set the grid attributes in this window as per your requirement.
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Apply and Close Apply

Figure 1-57 The Grid Options window

Film gate

The Film gate tool is used to toggle the visibility of Film gate border on or off in the active
viewport. You can also choose View > Camera Settings > Film Gate from the Panel menu to
display the Film gate border in the active viewport.

Resolution gate

The Resolution gate tool is used to toggle the display of the Resolution gate border on or off
in the active viewport. The resolution gate sets the area in the viewport that will be rendered.
You can also choose View > Camera Settings > Resolution Gate from the Panel menu to set
the resolution gate in the active viewport.

Gate mask

The Gate mask tool is used to turn on the display of the Gate Mask border. It changes the color
and opacity of the area that lies outside the Film gate or the Resolution gate. The gate mask will
only work when you have the Film gate or the Resolution gate applied to the active viewport.
You can also choose View > Camera Settings > Gate Mask from the Panel menu to display the
gate mask in the active viewport.

Field chart

The Field chart tool is used to turn on the display of the field chart border. On choosing the Field
chart tool, a grid is displayed, representing twelve standard cell animation field sizes. The Field
chart tool should be used only when the render resolution is set to NTSC dimensions. You can
also invoke this tool by choosing View > Camera Settings > Field Chart from the Panel menu.

Safe action

The Safe action tool is used to turn on the display of the Safe action border. It is used to
set the region in the active viewport for TV production. You can also invoke this tool by
choosing View > Camera Settings > Safe Action from the Panel menu.
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Safe title

The Safe title tool is used to turn on the display of the safe title border. It is also used to set the
region for TV production in the active viewport. This tool should be used only when the render
resolution is set to NTSC or PAL. You can also invoke this tool by choosing View > Camera
Settings > Safe Title from the Panel menu.

Wireframe

The Wireframe tool is used to toggle the wireframe display on or off. You can also choose
Shading > Wireframe from the Panel menu to switch to the wireframe mode. Alternatively,
press 4 from the keyboard to turn on the Wireframe mode.

Smooth shade all

The Smooth shade all tool is used to set the display to smooth shade. You can also choose
Shading > Smooth Shade All from the Panel menu to switch to smooth shade mode. Alternatively,
press 5 from the keyboard to turn on the Smooth Shade All mode.

Use default material
The Use default material tool is used to display the default material on the objects, when
they are in the smooth shaded mode.

Wireframe on shaded
The Wireframe on shaded tool is used to draw wireframes over the smooth shaded objects. You
can also invoke this tool by choosing Shading > Wireframe on Shaded from the Panel menu.

Textured
The Textured tool is used to set the hardware texturing display of the objects in the viewport.
Alternatively, press 6 from the keyboard to switch to the textured mode.

Use all lights
The Use all lights tool is used to illuminate objects by using all lights in the viewport. Alternatively,
choose Lighting > Use All Lights from the Panel menu or press 7.

Shadows

The Shadows tool is used to display the hardware shadow maps. Alternatively, choose
Lighting > Shadows from the Panel menu. This tool is only activated when the Use All Lights
tool is selected in the Panel menu.

Screen space ambient occlusion
The Screen space ambient occlusion tool is used to toggle the display of the ambient occlusion
in the viewport. This tool is enabled only when Viewport 2.0 is active.

Motion blur
The Motion blur tool is used to toggle the display of motion blur in the viewport itself. This
tool is enabled only when Viewport 2.0 is active.
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Multisample anti-aliasing
The Multisample anti-aliasing tool is used to toggle the display of multisample anti-aliasing in
the viewport itself. This tool is enabled only when Viewport 2.0 is active.

Depth of field
The Depth of field tool is used to toggle the display of depth of field in the viewport itself. This
tool is enabled only when Viewport 2.0 is active.

Isolate select

The Isolate select tool is used to display only the selected object in the viewport. To do so,
select an object in the viewport and choose the Isolate select button from the Panel toolbar.
Alternatively, choose Show > Isolate Select from the Panel menu or press SHIFT + 1.

XRay
The XRay tool is used to make the objects semi-transparent in the viewport. You can also choose
Shading > X-Ray from the Panel menu to switch to the XRay mode.

XRay active components

The XRay active components tool is used to display the active components over the top
of other shaded objects. You can also invoke this tool by choosing Shading > X-Ray active
components from the Panel menu.

XRay joints

The XRay joints tool is used to display the skeleton joints over the top of other objects in the
shaded mode. You can also choose this tool by choosing Shading > X-Ray joints from the
Panel menu.

Exposure
E The Exposure tool is used to adjust the brightness of the display.

Gamma
The Gamma tool is used to adjust the contrast or brightness of the midtones in the image.

View Transform
The View Transform tool is used to change the working color space to display. To do so, choose
color space use the drop-down list and choose a difference view transform.

Note
Your system should have a good quality graphic card to support high quality settings.

Channel Box / Layer Editor

The Channel Box and the Layer Editor are used to edit the attributes of an object. The Channel
Box consists of all object attributes used for editing, and the Layer Editor is used for creating
layers for objects in the scene. To display the Channel Box / Layer Editor, choose Windows >
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Editors > General Editors > Channel Box /Layer Editor from the JEErEIEED
menubar. Alternatively, press the CTRL +A keys to open the Kt

Channel Box / Layer Editor, if it is not already displayed. Select
an object; the attributes of the selected object will be displayed in
the Channel Box / Layer Editor, refer to Figure 1-58. The Channel
Box is further divided into three parts, which are discussed next.

Transform node
The Transform node contains the transformation attributes of the [EEEEIEE I
selected object. Select an object from the viewport; the Transform I’Lﬁ‘;l:r_mhsphem
node will become active. In Figure 1-58, nurbsSpherel is the
Transform node of a NURBS sphere. Enter the transform values
in different transform parameters to transform the object in the
viewport. Alternatively, click on an attribute name in the Transform
node; the background of the attribute will change to blue color.
Now, move the cursor to the viewport, press and hold the middle
mouse button and drag it to make changes in the parameters of
the selegted attribuFe. You can also adjust the values of more than g oure 1-58 The Channel
one attribute at a time. To do so, press and hold the SHIFT key p o /Layer Editor

and select the attributes that you want to adjust and then place the

cursor in the viewport. Now, press and hold the middle mouse button and drag the cursor to
make changes in the selected attributes. Choose the Visibility attribute to set the visibility of
the object. Enter 0 in the Visibility edit box to make the visibility of the selected object off, and
enter 1 in the Visibility edit box to set the visibility on.

SHAPES

SHAPES node

The SHAPES node provides a brief information about an object. It displays the shape name
of the selected object, refer to Figure 1-58. For example, when you create a NURBS sphere in
the viewport, it is named as nurbsSphereShapel. Here, NURBS indicates that the object has
been created using the NURBS primitives; Sphere indicates that a sphere has been created; and
Shapel indicates that this is the first sphere shape created in the viewport.

INPUTS node

The INPUTS node is used to modify the geometric structure of an object. To do so, create
a sphere in the viewport and make sure that it is selected in the viewport. Next, select the
makeNurbSpherel in the INPUTS node of the Channel Box; the geometric attributes of the
sphere will be displayed, refer to Figure 1-58. Now, you can adjust the geometric values of the
sphere as required. The Layer Editor is located below the Channel Box. To create a new layer
in the Layer Editor, choose Layers > Create Empty Layer from the Layer Editor, refer to
Figure 1-59; a new layer will be created. To add an object to the layer, select the object in the
viewport and then press and hold the right mouse button over the empty layer; a flyout will be
displayed. Choose Add Selected Objects from the flyout; the selected object will be added to
the layer.

The Layer Editor is mainly used when there are multiple objects in a scene. You can also change
the name and color of layers by using the Layer Editor. To do so, double-click on the name of
a layer; the Edit Layer window will be displayed, as shown in Figure 1-60. Enter the name of



Exploring Maya Interface 1-35

the layer in the Name text box. You can select the display option of the object from the Display
type drop-down list. If you select the Normal option from this list, the object will be displayed
in its object mode and will be selectable. If you select the Template option from the drop-down
list, the object will be displayed in the wireframe mode and the object will not be selectable.
Similarly, if you select the Reference option, the object will be displayed in the shaded mode and
will not be selectable. You can also set the visibility of an object by selecting the Visible check
box. The Color swatches located at the bottom of the window enables you to select a color for
the layer to give it a distinct identity as compared to other layers.

Create Empty Layer

Create Layer from Selected

Remove Selected Objects from Selected Layers

Membership

M Edit Layer

Delete Unused Layers

Layers Options Help

4 € 4 &

Figure 1-59 Creating a new layer Figure 1-60 The Edit Layer window
wn the Layer Editor

Attribute Editor

The Attribute Editor provides information about various attributes of a selected object, tool, or
the material applied to the selected object. It is also used to make changes in the attributes of
the selected object. Choose Windows > Editors > General Editors > Attribute Editor from the
menubar; the Attribute Editor will be displayed on the right of the viewport, refer to Figure 1-61.
The Attribute Editor comprises of a number of attribute tabs that help you modify an object.

HOTKEYS

In Maya 2018, you can create your own shortcut keys or even change default shortcuts. To do
so, choose Windows > Editors > Settings/Preferences > Hotkey Editor from the menubar;
the Hotkey Editor will be displayed, as shown in Figure 1-62. To edit hotkeys, select a hotkey
category from the Edit Hotkeys For drop-down list. Now, find the desired command from the
list displayed below the Edit Hotkeys For drop-down list. Click on the command and then enter
a keyboard shortcut.
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List Selected Focus Attributes Show Help

makeNurbSpherel

¢

makeMurbSphere: makeMurbSphere

anguiny

¥ Sphere Histo

Notes: makeMurbSpherel

Figure 1-61 The Attribute Editor

M Hotkey Editor - ol
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Figure 1-62 The Hotkey Editor

You can search an application command by choosing the Search By text box. Enter the application
command name in the search bar; filtered items will be displayed as shown in Figure 1-63. At the
right side of the Hotkey Editor, the Keyboard tab will be displayed. In this tab the unassigned
keys are highlighted in cyan color.

HOTBOX

Hotbox, as shown in Figure 1-64, helps you access menu items in a viewport. The Hotbox is
very useful, when you work in the expert mode or the full screen mode. It helps you access the
menu items and tools by using cursor in the workspace. To access a command, press and hold
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the SPACEBAR key; the Hotbox will be displayed. Now, you can choose the option that you
need to work from the Hotbox. The Hotbox is divided into five distinct zones, East, West, North,
South, and Center, refer to Figure 1-64.

M Hotkey Editor -olE

Keyboard

Runtime Command

Fo FI0 F11 F12

I Backspace

W Q W E

Gpstock A S D

st Z X C V

) 1211PM

Figure 1-63 Using the Search By filter

File Edit Create Select Modify Display Windows Cache Help

View Shading Lighting Show Renderer Panels

Recent Commands Center zone SEENE R

Mesh  Edit Mesh  Mesh To Mesh Displa Curves Surfaces Deform UV Generate

West zone Skeleton Skin Deform Constrain  Control = [SEE @re]ils]
Visualize Anim Deform Constrain

nParficles Fluids nCloth nHair nConstraint nCache Fields ers Effects Bifrost

Lighting/Shading Texturing Render Toon Stereo

persp

Figure 1-64 The Hotbox

~—~ Note

@ You can twrn off various Ul elements in the Maya interface to get more space and then use the

\ Hotbox to access various commands and tools. But you should do it only after you have established a
workflow for yourself. In the beginning, you should use the menubar at the top of the screen instead
of using the Hotbox as it reduces the possibility of confusion in finding a command at a later stage
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OUTLINER

The Outliner window is used to display all the objects of a scene
in a hierarchical manner, as shown in Figure 1-65. An object in
the scene can be selected by simply clicking on its name in the
Outliner window. In the Outliner window, the objects are placed
in the order of their creation in the viewport. For example, if
you create a cube in the viewport followed by a sphere and a
cylinder, then all these objects will be placed in a sequential
manner in the Outliner window, which means the object (cube)
created first will be placed first and the object created last
(cylinder) will be placed at the last. To organize the sequence
manually, choose the MMB and then drag and drop one object
below another object. To rename an object, double-click on the
name of the object. At the top of the Outliner window, there is
an text box known as the Text Filter Box. You can use this box
to select objects with a particular name. For example, enter
*front* in the box and press ENTER; all the objects having the word “front’ in their name will
be selected in the viewport. By default, there are four cameras in the Outliner window that
represent four default viewports in Maya. As discussed earlier, everything that you see in the
viewport is seen through the camera view. These cameras are visible in the Outliner window by
default. Each object in the Outliner window has an icon of its own. When you double-click on
any of these icons, the Attribute Editor will be displayed, where you can change the properties
of various objects.

MARKING MENUS

Marking menus are similar to shortcut menus that consist of almost all the tools required to
perform an operation on an object. There are three types of marking menus in Maya. The
first type of marking menu is used to create default objects in the viewport. To create a default
object, press and hold the SHIFT key and then right-click anywhere in the viewport; a marking
menu will be displayed, as shown in Figure 1-66. In this marking menu, choose the object that
you want to create.

Figure 1-65 Objects displayed in
the Outliner window

k" Create Polygon Tool [

& Plane [J ® Disc

& cylinder [ 2 Sphere [

& Cone [ G Torus [
@ cube [

@ Platonic Solid

Figure 1-66 Marking menu displaying
options used for creating default objects
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The second type of marking menu is used to switch amongst various components of an object
such as vertices, faces, edges, and so on. To invoke this marking menu, select an object and
right-click; the marking menu will be displayed, as shown in Figure 1-67. Now, you can select the
desired component of the selected object. This marking menu can also be used to apply material
to an object. To do so, choose the Assign New Material option from this marking menu; the
Assign New Material window will be displayed. Next, choose the required material; the material
will be applied to the selected object. This method will be discussed in detail in later chapters.

The third type of marking menu is used to modify the components of an object. To invoke this
marking menu, select a component, press and hold the SHIFT key, and then right-click on the
selected object; the marking menu will be displayed, refer to Figure 1-68. After invoking this
marking menu, you can choose the desired option to perform the corresponding function.

#" Paint Select Faces

Multi-Cut

Object Mode
Vertex uv

Vertex Face Multi

Compaonents

Select Hierarchy
Invert Selection Detach Components

Select Similar Triangulate Faces

Quadrangulate Faces
DG Traversal
Reduce Faces

Bridge Faces
Paint

Metadata Mirrar

Actions
- Extract Faces

Figure 1-67 Marking menu displaying Figure 1-68 The marking menu displaying
components of the selected object various tools for modifying an object

PIPELINE CACHING

In Maya, you can reduce the render time of a complex scene with the help of pipeline cache
tools. Using these tools, you can also increase the loading speed of large 3D scenes. The two
types of caching tools available in Maya are discussed next.

Alembic Cache

The alembic cache enables you to save and export complex Maya scenes in alembic file format.
The alembic file format has been developed to represent a complex 3D geometry as a simple
geometry. The exported alembic files can then be re-imported into Maya to improve playback
performance and reduce memory usage. In order to access this tool, choose Cache > Alembic
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Cache from the menubar; a flyout will be displayed, as shown in Figure 1-69. Various options
in this flyout are discussed next.

~~  Note
@ The Alembic Cache tool is not available by default. 1o invoke this tool, run the following script
\ in Command Line: global proc perFrameCallback(int $frame){print $frame;}

Cache  Arnold Help
Alembic Cache
BIF Cache Open Alembic...

Geometry Cache Reference Alembic...

GPU Cache Import Alembic...
Replace Alembic...
Alembic...

ElGEImG it Selection to Alembic...

About Alembic...

Figure 1-69 Flyout displayed on choosing the
Alembic Cache tool from the menubar

Open Alembic

The Open Alembic option is used to open an alembic file in Maya. When you choose this
option, the Import Alembic dialog box will be displayed. In this dialog box, you can browse to
the location, where the required alembic file has been saved, and then you can open the file in
Maya using the Import button.

Reference Alembic

The Reference Alembic option is used to import the contents of a scene, including objects,
animation, and shaders into your currently opened scene without importing the files into the
scene.

Import Alembic

The Import Alembic option is used to import an alembic file in Maya. When you choose this
option, the Import Alembic dialog box will be displayed. You can set various options in this
dialog box for the file to be imported.

Replace Alembic
The Replace Alembic option is used to replace the selected 3D object with the alembic object
contained in the selected alembic file.

Export All to Alembic

The Export All to Alembic option is used to export all objects in Maya scene as an alembic
cache file. By default, alembic cache files are saved in the cache > alembic folder of the current
Maya project folder.

Export Selection to Alembic
The Export Selection to Alembic option is used to export the selected objects in the Maya
scene as alembic objects.
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INTEROPERABILITY OPTIONS IN MAYA

Autodesk Maya enables you to exchange data between Maya and different softwares such as 3ds
Max, Unity, and Print Studio. However, for exchanging data, the same version of the software
must be available on your system. The Send to 3ds Max, Send to Unity, and Send to Print
Studio options located in the File menu of the menubar are used to send a Maya file to any of
the above mentioned software.

. Note
@ The Send to 3ds Max option located in the File menu of the menubar will be displayed only if you
have matching versions installed on your system. For example, 3ds Max 2018 and Maya 2018
are considered to be the matching versions.

NAVIGATING THE VIEWPORTS

The persp view is the default camera view in Maya. To look around in a scene, you can move
the virtual camera associated with the viewport. You can use the following shortcut keys while
navigating the viewport.

Keyboard Shortcut Function

ALT+MMB+Drag Helps to pan the viewport

ALT+RMB+Drag Helps to dolly in and out the viewport. You can
also use the scroll wheel to dolly in and out.

ALT +LMB+Drag Rotates or orbits the camera around in the
persp window

WORKSPACES

In this version of Maya, workspaces are introduced. Workspaces
are arrangement of windows, panels, and other interface
elements. Maya comes with several predefined workspaces
that you can access from the Workspaces drop-down list
available on the far right of the menubar, as shown in |g
Figure 1-70.

nteractive Groom
You can also save your own workspaces or reset the factory
workspaces. To do so, choose the options available in the
Windows > Workspaces menu.

Rendering

— Rendering

Figure 1-70 Partial view of the
Workspace drop-down list

Evaluation Copy. Do not reproduce. For information visit www.cadcim.com



Evaluation Copy. Do not reproduce. For information visit www.cadcim.com

1-42 Autodesk Maya 2018: A Comprehensive Guide

Self-Evaluation Test

Answer the following questions and then compare them to those given at the end of this
chapter:

1.

Which of the following windows is used to toggle the display of highlights of all menu items
and tool icons?

(a) 1-Minute Startup Movies (b) The Output window
(c) What’s New Highlight Settings (d) None of these

Which of the following tools is used to adjust contrast or brightness of an image?

(a) Exposure (b) Gamma

(c) Display settings (d) Both (a) and (b)
The button is used to snap the selected object to the center of the other object.
The area helps you select an object by entering its name in the Name Selection
area.
The Show/Hide the Modeling Toolkit button is used to toggle the window.
The Panel menu has a set of menus.

The keys set for animation are always displayed in red color. (T/F)

The MEL command is a group of text strings used for performing various functions in Maya.
(1/F)

The Hotbox is used to assign the shortcut keys to the commands. (T/F)

Review Questions

Answer the following questions:

1.

2.

Which of the following tools helps you move the selected objects in a workspace from one
place to another?

(a) Translate Tool (b) Paint Selection Tool
(c) Move Tool (d) Scale Tool

Which of the following combination of shortcut keys is used to toggle between Attribute
Editor and Channel Box/Layer Editor ?

(a) SHIFT+M (b)CTRL+ SHIFT+M
(c) SHIFT+N (d) CTRL+A
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3.

10.

Which of the following shortcut keys is used to invoke the Hotbox?

(a) SPACEBAR (b) BACKSPACE
(c) INSERT (d) ESC
Hotkeys are also known as keys.
The button helps you set keyframes in animation.

The user-defined shortcuts can be created by using the
The is an arbitrary point which is used to determine the location of objects.
MEL stands for

The options in the Animation Preferences window are used to modify the animation con-
trols. (T/F)

The Absolute transform mode is used to move, rotate, and scale a selected object in the
viewport. (T/F)
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Answers to Self-Evaluation Test
1. ¢, 2. d, 3. Snap to Projected Center, 4. Select by name, 5. Modeling Toolkit, 6. six, 7. T,
8.T,9.F



